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Preface

About this document

This demo is for IGLOO®2 field programmable gate array (FPGA) devices. It provides instructions on
how to use the corresponding reference design.

Intended Audience

The following designers using the IGLOO2 devices:
* FPGA designers
+ System-level designers

References

Microsemi Publications
* IGLOOZ2 Power Calculator User Guide
* IGLOO2 FPGA Low Power Design User Guide
* |IGLOOZ2 FPGA Fabric User Guide
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Introduction

Microsemi® IGLOO2 FPGAs are designed to meet the demand of low power FPGAs. The IGLOO2
devices exhibit lower power consumption in static and dynamic modes. This demo guide describes how
to implement standby power mode on the IGLOO2 devices using SmartDesign, .and measure the
standby power. The design drives the LEDs on the IGLOO2 Evaluation Kit with a pattern based on the
state of the switches SW1 and SW3, as shown in Table 1.

Table 1+ LEDs Pattern

LED E1, F4, F3, G7 Behavior| Standby Entry (SW1) Standby Exit (SW3)
LEDs toggle Released Released

LEDs on Depressed and Released | Released

LEDs toggle Depressed and Released | Depressed

This demo guide describes the following:
+ Creating a Libero® System-on-Chip (SoC) project:
* Implementing standby power mode ondGLOO2 devices using SmartDesign.
» Importing a PDC file, running layout and programming the IGLOO?2 silicon.
* Measuring standby power using'a standard Digital Voltmeter (DVM)/Multimeter.

Design Requirements
Table 2 shows the design requirements.

Table 2 « Design Requirements

Design Requirements Description

Hardware Requirements

IGLOO2 Evaluation Kit: Rev C or later
* 12V adapter
* FlashPro4 programmer

Desktop or Laptop Windows 64-bit Operating System
Software Requirements

Libero SoC 11.5

FlashPro Programming Software 11.5
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Demo Design

Introduction

The demo design files are available for download from the following path in the Microsemi website:
http://soc.microsemi.com/download/rsc/?f=m2gl_dg0564_liberov11p5_df
The demo design files include:
* Libero SoC project
+ Constraint file
*  Programming file
» Source files
+ Readme file
Refer to the Readme.txt file provided in the design files for the complete directory structure.

The design consists of a 32 kHz External Main Crystal Oscillator, Fabric CCC (FCCC), Standby power
control logic and Fabric logic block. Figure 1 shows the block diagram of the design.

The FCCC is configured to provide 100 MHz clock to the Fabric logic. It is also configured with PLL
power-down enabled. The 32 kHz External Main Crystal Oscillator is the reference clock source for the
FCCC. The Lock signal is used as a reset signal to the Fabric logic. The standby power control logic
consists of a clocked S-R latch which powers down the PLL of FCCC. The Fabric logic consists of 421
stages 18-bit loadable up-counters, 604 stages of shift registers, and. 11 stages LSRAM and Math blocks.
It also consists of a LED Driver block which is connéected to a set of light-emitting diodes (LEDs) to
monitor the state of the fabric while entering and exiting standby power mode.

32 kHz External Main Crystal 2kHz DL Eabric CCC 100MHz | e Logic | LEDs
Oscillator
A
32 kHz PLL Power-down
h 4
Standby Power Entry ——p| Standby Power IGL002
Standby Power Exit ———| Control

Figure 1«

Design'Block Diagram

Extracting the Source Files

Extract m2gl_dg0564_liberov11p5_df.zip to extract the required lab files to the <C:\ or D:\>Microsemi_prj
folder on the HDD of the PC. Confirm that a folder named IGL2_Standby _tutorial containing sub-folders
named Source_files and Constraints are extracted.
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Creating the Design

This section describes how to create the standby power mode enabled design using SmartDesign. Some
source files are provided in the Source_files folder.

Launching Libero SoC

The following steps describe how to launch Libero SoC:

1. Click Start > Programs > Microsemi Libero SoC v11.5 > Libero SoC v11.5, or click on the
shortcut icon on the PC. This opens Libero SoC Project Manager window as shown in Figure 2.

DMnxecd &
[ sorroe | |

.

Qe o 21
- Libefo®

System-on-Chip

Welcome To Microsemi's Libero SoC'v11.5 3

Libero SoC is the most comprehensive and powerful FPGA design and development software available, providing start-to-
finish design flow guidance and support for novice and experienced users alike. Libero SoC combines Microsemi's tools
with such EDA powerhouses as Synplify Pro® and ModelSim®&.

= IGLOO2 - Build designs targeting the newest Microsemi FPGA device using the IGLOO2 System Builder. — Learn more
Welcome to Libero SoC
Libero 50C Quickstart SmartFusion2 - This SoC FPGA combines a powerful Cortex-M3 microcontroller with programmable FPGA logic. —
Learn more

Libero SaC Interface Description

Libero SoC Release Notes on the Web What's New in Libero SoC v11.5 - Learn more about Libero SoC

Lbero Tutorils New ILOO2 and SmartFusion2 Devices

Product Tutorials
M2S/GLO60 FGET6

M2S/GL150 FCV484

M2S/GLO0S TQ144 Replacing VQ144
M2S/GLO10 TQ144 Replacing VQ144

.
Training Webcasts .
Microsemi SoC Website .
.

Log 8| Message & x
@erors i, warnings ) Info € Errors i, warnings @ Info (=] Manage suppressed messages

Fam: |Die: |Pkg:

Figure 2+ Libero SoC Project Manager

2. Create a new project using one of the following options:
—.Select New on the Start Page tab as shown in Figure 2.
— ' Click Project > New Project from the Libero SoC menu.
This opens New Project window as shown in Figure 3.
3. Enter the following information in the New Project - Project Details page as shown in Figure 3:
— Project Name: IGL2_Standby
— Project Location: <C:\ or D:\>Microsemi_prj\IGL2_Standby _tutorial
— Preferred HDL type: VHDL
— Enable Block Creation: Un-checked
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.
@ New Project = | B )

Project Details
il Specify Project Details

Project Details

Project Mame: IGL2_Standby
B B Project Location: D:WMicrosemi_pri\IGL2_Standby_tutorial
Device Selection
Description:

Device Settings

Design Template Preferred HOL Type:

[] Enable Block Creation

Add HDL Sources
Add Constraints

. gl
Libefo

System-on-Chip

L

Figure 3+ New Project - Project Details Page

4. Click Next. This opens New Project - Device Selection page as shown in Figure 4.
5. Select the following values from the drop-down list (highlighted in Figure 4):

— Family: IGLOO2

— Die: M2GLO10T

— Package: 484 FBGA

— Speed: -1

— Core Voltage: 1.2

— Range: COM
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6. Select the filtered device (M2GL010T-1FG484) as shown in Figure 4.

5
(® New Project = | B o)
Device Selection
[ Select a part for your project from the Part Number list Selected Part: M2GL010T-1FG484
Part Filter
RRleuRSE Family: (16LO02 -] Die: [M26L010T ~|  Package: [484FBGA -
Speed: [—1 - ] Care Voltage: [1.2 - ] Range: [CDM - l
Device Selection
Device Settings Search Part:
I Part Numbe‘r 4uT DFF User I/Os USRAM 1K LSRAM 18K Math (18%18) PLLs and ©
Design Template M2GLO10T-1FG4B4 12084 12084 33 2 pil 2 . 2 N
Add HDL Sources
Add Constraints
Libefo)
System-on Chip ) 3 L &
< Back ] l MNext > ] l Finish ] l Cancel ]
L

Figure 4« New Project - Device Selection Page

7. Click Next. This opens New Project - Device Settings page as shown in Figure 5.

8. Select the following values in the Power Supplies section from the drop-down list (highlighted in
Figure 5):
— PLL Supply Voltage (V): 3.3
— Maximum Core Voltage Rail Ramp Up Time: 100ms Minimum

The PLL Analog Supply voltage can be either 2.5 V or 3.3 V. The voltage setting in the New Project -
Device Settings page must match with the PLL Analog supply voltage on the board to ensure that the
PLL works properly. The PLL Analog Supply voltage is connected to 3.3 V on the IGLOO2 Evaluation Kit.
Therefore, the setting must be changed.

9. Do not change the default selections. Click Finish.
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(® New Project

Device Settings
f Choose Device Settings for your project

IO Settings
Project Details

Reserve Pins for Probes
Device Selection

Default If0 Technalogy: LVCMOS 2.5V = 6 Please use the I/O Editor to change individual IfO attributes.

Device Settings
I Power Supplies

PLL Supply Voltage (V): S

-

Design TEI‘I'Ip'BtE Maximum Core Voltage Rail Ramp Up Time:

Add HDL Sources [ system Controller Suspended Mode

Add Constraints

.
Libefo

System-on-Chip

Selected Part: M2GLO10T-1FG484

< Back ][ Mext = ][ Einish ]I[ Cancel

Figure 5+ New Project - Device Settings Page
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10. Expand Create Design in the Design Flow tab as shown in Figure 6. Right-click Create
SmartDesign and select Run.

Design Flow B X
Please select a root = 0 #
Tool

4 | Create Design
&5 System Builder

| B3 Create SmartDesi !
o : Run

Create HDL

Create SmartDesi Help

Create HDL Testbrmes

¥ Verify Pre-Synthesized Design

Create Constraints

Implement Design

Edit Design Hardware Configuration
Configure Security and Programming Options
Program Design

Debug Design

"
b . . . . . .

Handoff Design for Production

Design Flow Design Hierard’? Stimulus Hierarchy Catalog I Files |

Figure 6 = Creating SmartDesign

11. Enter IGL2_Standby in the Create New SmartDesign dialog box and click OK. New
SmartDesign canvas opens.

-
A} Create New SmartDesign @Iﬂ

Mame:

IGL2_Standby]

o) Lo

Figure 7+ Entering SmartDesign Name
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12. This design uses a Fabric CCC to generate 100 MHz internal clock. The CCC reference clock is
the 32 kHz external main crystal oscillator. Expand Clock & Management in the IP catalog.

Catalog 5 X
[@& ~ [ simulation Mode + B

MName Version
> {Arithmetic ;
> Bus Interfaces

4
Chip Oscillators 1.0.103
Clock Ceonditioning Circuitry (CCC) 2.0.200

» /O

» Macro Library

» Memaory & Controllers
> Peripherals

> Processors

> SC/Tamper

> Tamper

Mo core selected

| Design Flow I Design Hierarchy I Stimulus Hierarchy | Catalog | Files—|—

Figure 8+ Clock & Management Category of Libero SoC IP Catalog
13. Drag an instance of the Clock Conditioning Circuitry (CCC) v2.0.200 component into the
SmartDesign canvas.

14. Double-click on the FCCC_0 component in the SmartDesign canvas and open the FAB CCC
Configurator window as shown in Figure 9.

15. Click Basic tab in the FAB.CCC Configurator window (see Figure 9).
Enter the following information:

— Reference Clock Frequency:'0.032 MHz
— Reference Clock: Select Oscillators > Crystal Oscillator from the pull-down menu
— GLO: Checked; Frequency: 100 MHz
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—
] FAE CCC Configurator

| Basic PLL Options

Basic-Options

D@

Reference Clock

0032w
oo ]

GLO

GL1

GL2

GL3

Figure 9 »  Configuring ric

Revision 3 13



& Microsemi

IGLOO2 FPGA Low Standby Power - Libero SoC v11.5

16. Click Advanced tab in the FAB CCC Configurator window and select
Internal > PLL Internal from the pull-down menu as PLL feedback source, as shown in
Figure 10.

-
—] PLL phase 0 -
-

Figure 10 » Configuring PLL
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17. Click PLL Options tab in the FAB CCC Configurator window and check Expose PLL_ARST_N

and PLL_POWERDOWN_N signals as shown in Figure 11.

| FAB CCC Configurator

Miscellaneous

PLL Optons

wWnie waliung, me FLL IS IN & I0CKEea state _

Qutput Resynchronization After Lock

() Held output in reset {output low) after power-up. Released and resynchronized with the PLL reference dock
after the PLL locked.
@ Outputs operate after power-up. Resynchronized with the PLL reference dock after the PLL locked.

() Outputs operate after power-up. Mo automatic resynchronization.

[ Enable PLL Spread Spectrum Modulation

ﬁ Frequency
A

VCO:

4539.712 MHz
Depth:
0.5%

MinVCO:

497.213 MHz

Frequency: |4p KHz 3
0.000
- Time:

Warning: PLL Feedback Source is forced to PLL Internal when Spread Spectrum Modulation is enabled

[ Expose dynamic configuration interface (APE slave)
[ Expose PLL_BYPASS_N signal. When asserted, the PLL core is off and the PLL Outputs wil tradk the reference dock
Expose PLL_ARST_N and PLL_POWERDOWM_N signals

[ Expose GPD[X]_ARST_N signals for all used GPDs

m

oK ] [ Cancel

Figure 11 »+ Configuring PLL Power-down Signal

18.
19.

20.

21.

Click OK and close the FAB CCC Configurator window.

Drag an instance of the Chip Oscillators v1.0.103 component from the IP catalog into the

SmartDesign canvas.

Double-click on the OSC_0 component in the SmartDesign canvas and open the Chip

Oscillators Configurator window, as shown in Figure 12.

Configure the External Main Crystal Oscillator to drive FCCC and fabric logic.

Enter the following information (see Figure 12):
— External Main Crystal Oscillator: Checked

— Source: Select Crystal (32 KHz - 20 MHz) from the pull-down menu

— Frequency: 0.032 MHz
— Drives Fabric CCC(s): Checked
— Drives Fabric Logic: Checked

Revision 3
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A Chip Oscillators Configuratar

Configuration |
External Main Crystal Oscillator
Source [Crystal (32kHz-20MHz) -] HPMS_CCC
Frequency 0.032 MHz

Drives Fabric CCC(s) RCOSC_50MHZ

Drives Fabric Logic

1
1
1
1
1
1
1
1
1
1
1
1
1

On-chip 25/50 MHz RC Oscillator H
1
1
1
1
1
1
1
1
1
1
1
1
|

1
I
I
I
I
I
I
I
I
I
I
I
1
I
I
Drives Fabric CCC(s) il :
Drives Fabric Logic (| I
RCOSC_1MHZ :
On-chip 1 MHz RC Oscillator |
I
Drives Fabric CCC(s) (| |
Drives Fabric Logic | :
I
> I
IZ'» XTLOSC :
. |
! 1
! [
! [
! [
! [
| FPGA Fabric !
e N ____ [
- o)
= — —

Figure 12 »+ Configuring Chip Oscillators
22. Click OK and close the Chip Oscillators Configurator window.
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23. Import the VHDL source files into the project by selecting Create HDL under Create Design in
the Design Flow tab. Right-click and select Import Files... (see Figure 13).

Design Flow g X
I6L2_Standby B O A ¢
Tool

4 | Create Design
&5 System Builder
Ed Create SmartDesign

: |I Create H™ i

2 Creates Run
Create H X
4 b VerifyP Import Files...

. Sim Help

Create Consorewres

Implement Design

Edit Design Hardware Configuration
Configure Security and Programuding Options
Program Design

Debug Design

Handoff Design for Praduction

W
b . . . . .

Design Flow Design Hierarchy SﬁmLﬂEs;T-Earmy Catalog I Files |

Figure 13 » Importing HDL Source Files

24. Enter the following.information in Import Files dialog box and click Open:
— Look in; £C:\ or D:\>Microsemi_prj\lGL2_Standby _tutorial\Source_files
— Files of type: HDL Source Files (*.vhd *.v *.h)
— File name: Selectall files (click the first item and press Ctrl+A)
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25. The files are visible on Design Hierarchy tab.

Design Hierarchy

E=j_ Standby_Control (Standby_Control.vhd)
O3 1612 Standby
=1 Fabric_Legic (Fabric_Logic.vhd)
E] CNT_UP421 (CNT_UP421.vhd)
E] CNT_UP (CNT_UPvhd)
4 [ Multll_LSRAMI1 (MULT11_LSRAMI1.vhd)
4 [Z| WE_AD_GEN (WE_AD_GEN.vhd)
E] WA_CNT (WA_CNT.vhd)
E| RA_CNT (RA_CNT.whd)
E] WE_CNT (WE_CNT.vhd)
B sign18:d8_mult (SIGNSxE_MULT.vhd)
E] LSRAMIK:1S (LSRAMIK:x18.vhd)
Bl muxbus (MUXBUS.vhd)

[
« £

1 | m 3

| Design Flow | Design Hierarchy [Sﬁmulus Hier;chy Catalog I Files |

Figure 14 + Design Hierarchy Tab with Imported Files

26. Drag Standby_Control and Fabric_Logic components into the SmartDesign canvas.

27. After adding the components, the SmartDesign resembles Figure 15. Drag the components to
improve the appearance of the canvas.

Expand the canvas area by selecting View > Maximize Work Area, or click on
i icon on'the tool bar.

18
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| reports & x | startpage & x | B9 1612 Standby* @ X |

4l

B oEra M 2P P QOO B ANDO

FCCC_0
PLL_ARST_N GLo Standby_Control_0
PLL_POWERDOWN_N LOCK CLK PLL_PowerDown

XTLOSC_CCC_IN Standby_Entry

gv P Standby_Exit

Fabric_Logic_0

0SC_0

XTL 2
XTLOSC_CCC_OUT
G

XTLOSC_02ZF

] [T y

m

Figure 15+ SmartDesign Canvas after Adding Components

Connecting Components in the Canvas

SmartDesign in Libero SoC has a connection mode that supports click, drag, and release to connect the

components.

Connect the components in the SmartDesign canvas using the following procedure:
1. Select SmartDesign > Connection Mode from the Libero SoC menu.
2. Connect the XTLOSC_CCC_OUT port of OSC_0 component to the XTLOSC_CCC_IN port of the

FCCC_0 component as follows:

= Click on the XTLOSC_CCC_OUT port of the OSC_0 component and hold the left mouse

button.

— Hold the left mouse button and drag the XTLOSC_CCC_IN port of FCCC_0 component.

—  Release the mouse button to connect.

Note:
clicking any of the selected ports, and selecting Connect.

You can also connect the ports by selecting them using CTRL (Ctrl + click to select a port), right-

3. Connect the other components in the SmartDesign canvas as per Table 3.

Table 3 « Connections in Canvas

From To

OSC_0: XTLOSC_O2F Standby_Control_0: CLK

Standby_Control_0: PLL_PowerDown |FCCC_0: PLL_ARST_N

FCCC_0: PLL_POWERDOWN_N

Revision 3
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Table 3 + Connections in Canvas (continued)

From To
FCCC_0: GLO Fabric_Logic_0: CLK
FCCC_0: LOCK Fabric_Logic_0: RST

4. Select SmartDesign > Connection Mode from the Libero SoC menu to exit connection mode.

5. Promote the following ports to the top level (see Table 4). Click on the port, Right-click and select
Promote to Top Level.

Table 4 + Promote to Top Level
Ports
Standby_Control_0: Standby_Entry
Standby_Control_0: Standby_Exit
Fabric_Logic_0: LD
Fabric_Logic_0: DIN[17:0]
Fabric_Logic_0: DOUT[17:0]
Fabric_Logic_0: LED_1
Fabric_Logic_0: LED_2
Fabric_Logic_0: LED_3
Fabric_Logic_0: LED 4

The SmartDesign canvas appears as shown in Figure 16. Drag the components or use the
SmartDesign Auto Arrange feature to improve the appearance of the canvas.

| Reports & x [ startpage 5 x | EH1el2 stancky* & X |

SERI M BP0 QA AE ANO

4l

Fabric_Logic_0
—pCLK DOUTIH70] 7
¥ RST LED 1 |
LT] o LED Z2fp——— b LE |
Lﬁ% DIN(T7-0] Lenah— % |
EDp— B

FCCC_0

osc.o FALL_ARST_N G
XTL XTLOSC C2F| FLL_FOWERDOWN N LOCK]
XTLOSG OCC_IN

Standby_Control_0

b CLIC PLL_Fow erDow n
] Standby_Entry
Standby_Exi

Figure 16 « SmartDesign Canvas after Connections

6. Save the design (File > Save IGL2_Standby).
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7. Generate the design by selecting SmartDesign > Generate Component, or by clicking the
Generate Component icon on the SmartDesign toolbar (circled in Figure 16).

8. Restore the work area (View > Restore Work Area) if you expanded the work area earlier.
9. Confirm that the message IGL2_Standby was generated appears in the Libero Log window.
10. Close the design (File > Close IGL2_Standby).

Importing Physical Constraint files
This section describes how to import a physical design constraint (PDC) file to make I/O attribute and pin
assignments for the layout.
There are several ways to make I/O assignments:
1. Expand Create Constraints in the Design Flow tab. Right-click on I/0 Constraints and select

Import Files.....
Design Flow 5 X
16L2_Standby a e @'

Tool
> P Create Design
4 p Create Constraints

i*= /0 Constraints -
Create New Constraint From Root Module

iming Constrai

o Floorplan Const Create New Constraint
Implement Design Import Files...
Edit Design Hardws =

Configure Security|
Program Design Help:

Debug Design

vy vy vrwww

Handoff Design for Préduction

| Design Flow | Design HieraayI I Stimulus Hierarchy Catalog I Files |

Figure 17 « Importing I/O PDC Constraint File

2. Enter the following information in the Import Files dialog box and click Open:
— Look in; <C:\ or D:\>Microsemi_prj\lGL2_Standby _tutorial\Constraints
— Files of type: I/O Constraint Files (*.pdc)
— File name: IGL2_ Standby.pdc

3. Click No in the Information dialog box.

.| Information @

:] Do you want to organize constraint file(s) for your current root (IGL2_Standby) for (Compile)?

[ s J[ mo |

Figure 18 « Information Dialog Box after Importing PDC Constraint File
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4. The file is visible on the Libero SoC Files tab under constraint > io.

Files

> [3 component
4[] constraint
Lfp
4 [0
B 16L2_Standby.pdc
> [ designer
> [ hdl
> [ simulation
[ smartgen
[ stimulus
[ synthesis
> [ tooldata

| Design Flow I Design Hierarchy I Stimulus Hierarchy Catalog | Files |

Figure 19 » 1/0 PDC Constraint File in Libero SoC Project

A description of the Designer PDC constraints is available in the Libero Help (Go to Help > Help Topics
> Implement Design > Constrain Place and Route > Assigning Design Constraints > Design
Constraints Guide > Reference > Constraints by File Format > PDC Command Reference).

Synthesis and Layout
Use the push-button flow to synthesize the design with Synplify Pro, run layout and generate the
programming file as mentioned below:

1. Expand Create Constraints > I/O Constraints in the Libero SoC Design Flow tab. Right-click
IGL2_Standby.pdc under Constraints.

2. Right-click and select Use for Compile, as shown in Figure 20. A green check mark appears next
to the constraint file indicating that the file will be used.

g X

o[ ¢

Design Flow

16L2_Standby

Tool
¥ \Create Design
4§ Create Constraints
4 “E /0 Constraints
a onstrainf—"= = =
d} Timing Const Use for Compile
13 Floorplan Co Open in Text Editor
b Implement Desi(
b EditDesignHard | V& -
» Configure Secur, Delete from Project
» Program Design . .
b Debug Design Delete from Project and Disk
P Handoff Design for Production
Design Flow | Design Hierarchy I Stimulus Hierarchy I Catalog I Files |

Figure 20 » Selecting I/0 PDC Constraint File in Design Flow Tab

22
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3. Click Generate Programming Data icon in the Design Flow tab (circled in Figure 21), or select
Design > Generate Fabric Programming Data to synthesize the design, run layout using the /O
constraints that are created and generate the programming file.

Design Flow

IGL2_Standby

Figure 21+ Generate Programming Data Icon

The design implementation tools run in batch mode. Successful completion of a design-step is indicated
by a green check mark next to Implement Design in the Design Flow tab (see Figure 22).

Design Flow 5 X

1GL2_Standby

Tool

-

Create Design

b
-

Create Constraints
+# 1/0 Constraints
constraint\io\IGL2_Standby.pdc
4 d) Timing Constraints
a synthesis\IGL2 Standby_sdc.sde
Q Floorplan Constraints

[

4 b Implement Design

("4 S Synthesize
4 p Verify Post-SyntheSisTmplementation
. Simulate
v B3 Compile
+] Configure Flash*Freeze
v 9,3 Place and Route

[

b Edit Constraints
=140 Constraints
d) Timing Constraints
:E Floorplan Constraints
b Merify Post Layout Implementation
+'| Generate Back Annotated Files
. Simulate
@ Verify Timing
o} Verify Power

Edit Design Hardware Configuration

[

v -

Configure Security and Programming Options

.

Program Design

@ Configure Bitstream

v @5 Generate Bitstream

T Run PROGRAM Action
Debug Design

Handoff Design for Production

v v

| Design Flow | Design Hierarchy I Stimulus Hierarchy Catalog I Files |

Figure 22 + Successful Design Implementation
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4. Generate a power report by right-clicking Verify Power under Verify Post Layout
Implementation in the Design Flow tab and selecting Run.

Design Flow 5 X
16L2_Standby B Q @'
Tool o
("4 S Synthesize
4 p Verify Post-Synthesis Implementation
. Simulate
v B3 Compile
+] Configure Flash*Freeze | _
v 9,3 Place and Route
> b Edit Constraints
4 p Verify Post Layout Implementation
+L| Generate Back Annotated Files
. Simulate
- @ Verify Timing 2
| it Verify Powe H
> b Edit Design Hardw, Run
» Configure Security Clean and Run All
¢ 4 » Program Design Open Interactively
@ Configure Bitst Clean L&
("4 @ Generate Bitst
T2 Run PROGRAM Help -

| Design Flow | Design Hierarchy I Stimulus Hierarchy Catalog I Files |

Figure 23 » Generating Post Layout Power Report
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5. The Reports tab displays reports for the tools used to implement the design. Select
IGL2_Standby_power_report.xml under Verify Power in the Reports tab to view the power
consumption.

Reports & X StartPage & X |

4 1GL2_Standby reports
4 1612 Standby
IGL2_Standby_FCCC_0_configuration.ml
IGL2_Standby_pinrpt_name.rpt
IGL2_Standby_pinrpt_numberrpt
IGL2_Standby_bankrpt.rpt
IGLZ_Standby_ioffxml
Synthesize
synplify.log
4, IGL2_Standby.srr
run_options.bd
4 Compile
IGL2_Standby_rwnetlist.log
@ 16L2_Standby_compile_log.log
@ 1612 standby_sdc.log
IGL2_Standby_compilexml
IGL2_Standby_combinational loops.xml
Place and Route
IGLZ_Standby_glb_net_report.xml
© 1612 standby layout_log.log
Werify Power
| IGL2_Standby. power_report.xml
Generate Bitstream
IGL2_Standby_generateBitstream.log

[

[

[

[

Figure 24 + Reports Tab after Inplementing Design
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The Reports tab displays the power report as shown in Figure 25.

Reports & X | StartPage & X

» Project Summary
4 16L2_Standby reports
4 16L2_Standby
16L2_Standby_FCCC_0_configuration.xml Power Summary

1612 Standby_manifest.txt
16L2_Standby_pinrpt_name.rpt

16L2_Standby_pinrpt_number.rpt Rewor(mV) | Percentage
IGL2_Standby_bankrpt.rpt Total Power 237.960 100.0%
1GL2_Standby_ioffxml

—randbyletixm Static PowsT ELE 5.9%

4 Synthesize
synplifylog Dynamic Power 224.002 94.1%
i IGL2 Standbysrr
run_options.bdt

4 Compile
16L2_Standby_rwnetlist log Breakdown by Rail
) 16L2_Standby_compile_log.log
@ 1612 Standby_sdc.log
16L2_Standby. compilesml Power (mW) Voltage (V) Current (mA)
IGL2_Standby_combinational_loopsaxml Rail VDD 204 535 1.200 170.446

4 Place and Route

Rail VDDI 2.5 21.925 2.500 8.770
16L2_Standby_glb_net_report.xml
@ 16L2_Standby _layout_log.log Rail CCC_NE1_PLL_VDDA | 9.000 3.300 2727
“ Verify Power Rail VPP 2.500 2.500 1.000
1GL2_Standby_power_report.xml
4 Generate Bitstream
16L2_Standby_generateBitstream.log
Reports & X | StartPage & X
» Project Summary XTL (register outputs) 0.000 0.0% §
4 1GL2_Standby reports
4 1612 Standby XTL (primary inputs) 0.000 0.0%
16L2_Standby_FCCC_0_cenfigurationaxml XTL {combinational outputs) 0.000 0:0%
1GL2_Standby_manifest.txt
16L2_Standby_pinrpt_name.rpt XTL (set/reset nets) 0.000 0.0%
IGL2 Standby_pinrpt_number.rpt Input te Qutput 0.000 0.0%
1GL2_Standby_bankrpt.rpt
16L2_Standby._ioffxml
4 Synthesize
synplifylog
i 1GL2_Standby.srr Breakdown by Type
run_options bt
4 Compile Power (mW) Percentage
16L2_Standby_rwnetlistlog Type Net 62.269 26.2%
i 16L2_standby_compile_loglog .
0 16L2_Stendby_sdclog Type Gate 84 152 35 4%
16L2_Standby_compilexml Type I/0 18.493 7.8%
) p‘a(lﬁG\;i;S;a;udtZy_cumbmat\unal_luups‘xml Type Memory C G 20
1GL2_Standby_glb_net_report.xml Type Core Static 7.878 33%
@ 1612 Standby layout leglog Type Banks Static | 3.580 15% 1
4 Verify Power H
1GL2_Standby_power_reportxml Type VPP Static  2.500 1.1%
4 Generate Bitstream Type Biiiltin Blocks | 9497 40%
16L2_Standby_generateBitstream.log o

Figure 25+ Power Report

Programming

The following steps describe how to run FlashPro in batch mode and program the IGLOO2 M2GL010T
on the IGLOO2 Evaluation Kit board:

1. Prior to programming (and powering up) the IGLOO2 Evaluation Kit board, ensure that the
jumpers are positioned as shown in Table 5.

Table 5 « Jumper Settings

Jumper Location Setting
J3 Above the On/Off Switch in Figure 26 1-2 installed
J8 Below the JTAG Programming Header (J5) in Figure 26 1-2 installed
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50 Mhz LPDDR GPIO SW5 LEDs  JTAG Programming Reset ETM Trace

J 3 Oscillator Header ‘ J8 Header Switch Debug
Header

On/Off
Switch
RVI/IAR
Debug
12V Power Header
Supply Input
E— : TP16
10/100/1000 s 1) ; ;  TP17
Ethernet . S M2GL_M2S-EVALKI T
RJ45 = !?I _u_Biggr . g VP - 107 3001 AN gggéES
Connector - e SMA
Pairs
USB-UART
Terminal
__12c
Header
MicroUSB
OoTG

SERDES
Reference
Clock

Current Standby EXit

Measurement

x1 PCle Edge On Board Current
Connector 125 Mhz Crystals Measurement SW3 sw2

Standby Entry

Figure 26 « 1GLOO2 Evaluation Kit
2. Plug the FlashPro4 ribbon.cable into.connector J5 (JTAG Programming Header) on the IGLOO2
Evaluation Kit board.
3. Connect the mini USB cable between the FlashPro4 and the USB port of the PC.

4. Install the FlashPro4 drivers if prompted. The drivers are located in <FlashPro Installation
Directory>\Drivers folder.

5. Power on the board by plugging in the power cable and switching on the power switch. Three
GreenLEDs on top left of the board are powered on.
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6. Expand Program Design in the Design Flow tab. Right-click Run PROGRAM Action and select
Run to begin programming.

Design Flow

IGL2_Standby

B X

v

Tool

+L| Configure Flash*Freeze

ﬁ:; Place and Route
> ¢ Edit Constraints

4 Verify Post Layout Implementation
*L| Generate Back Annotated Files

. Simulate

& Verify Timing
o} Verify Power

¥ Edit Design Hardware Configuration
» Configure Security and Programming Options

» FProgram Design

@‘ Configure Bitstream

@‘ Generate Bitst

ream

m

|;%. Run PROGRES™
¥ Debug Design
26y Identify Deb
€ SrartDebug
» Handoff Design
4 Export Bitstre
4 Export Progr
+L| Export Pin Re,

Run
Clean amdhRun All

Clean
Configure Action/Procedures...

Help

Design Flow | Desigmerarmv_ Stimulus Hierarchy

Catalog I Files |

Figure 27 «

Launching Programming Software from Design Flow Tab

FlashPro runs in batch mode and programs the device. Programming messages are visible in the Libero
SoC log window. Programmer number differs.

Note:

Do not.interrupt the programming sequence. It may damage the device or programmer.

The following message is displayed in the Reports view under Program Device when the device is
programmed successfully (see Figure 27). Programmer number differs:

programmer '92327'

: device

'M2GLO10T'

: Executing action PROGRAM PASSED.
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Reports & X StartPage & X

4 1GL2_Standby reports
4 1GL2 Standby
16L2_Standby_FCCC_0_configuration.xml
1GL2_Standby_pinrpt_name.rpt
1GL2_Standby_pinrpt_numberapt
1GL2_Standby_bankrpt.rpt
1GL2_Standby_ioffaml
Synthesize
synplifylog
i 16L2_Standby.srr
run_options.txt
Compile
1GL2_Standby_rwnetlist.log
@ 1612 Standby_compile log.leg
@ 1612 Standby sdclog
1GL2_Standby_compilexml
16L2_Standby_combinational_loopsxml
Place and Route
1GL2_Standby_glb_net_reportxml
@ 1612 Standby layout log.log
Verify Power
1GL2_Standby._power_reportxml
Generate Bitstream
1GL2_Standby_generateBitstream.log
Run PROGRAM Action
i 16L2_Standby_PROGRAM.log

S

S

S

S

S

S

{[programmer device "M2GL0O10T' : Executing action PROGRAM PASS

€3 0Fmors j, 2Warnings B 0 Info

The 'open_project' command succesded.
IED file

'D:/Microsemi_prj/IGL2_Standby tutorial/Liberc_project/IGL2_Standby/designer/IGL2_Standby/IGL2_\

Standby.ipd' has been loaded successfully.
DESIGN : IGL2_Standby; CHECKSUM : D230; EDB_VERSION : 1.8
The 'set_programming file' command succeeded.

The 'enable device' command succeeded.
The 'set_programming action' command succeeded.
programmer '9232 Scan Chain

r 7923270 : been selected on . n exter
punp has alsoc been detected. Using externally provided Vpump voltage source.

programmer '$2327' : Check Chain...

programmer : Scan and Check Chain PASSED.

programmer device 'M2GLO10T' : Executing action PROGRAM

programmer device 'M2GLOL0T' : EXPORT ISC_ENABLE RESULT[32] = 007b6244

programmer : device 'M2GLOLOT' : EXPORT CRCERR: [1] = 0

programmer device 'M2GLO10T' : EXPORT EDCERR: [1] = O

programmer device 'M2GLO10T' : TEMEGRADE: ROOM

programmer : device 'M2GLOLOT' : EXPORT VEPRENGE: [3] = 2

programmer device 'M2GLO10T' : VEFRANGE: HIGH

programmer device 'M2GLO10T' : EXPORT TEMP: [2] = 68

programmer : device 'M2GLOLOT' : EXPORT VEE: [2] = Tb

programmer
programmer

device 'M2GLOL0T' : Programming FPGA Array...
: device 'M2GLOLOT'

programmer '392327°' device "M2GLO10T' : EXPORT DSN[128] = 03e£aa010000cd5a00910004001c003a
programmer '92327' : device "M2GLO10T' :
Pprogrammer : device "M2GL0O10T' : Finished: Wed Jul 23 10:08:07 2014 (Elapsed time

00:00:2.

W;L“cqraming BASSED. >
Chain Programming Finished: Wed OUI ZT TUTUETO7 20TZ (Elapsed time 00:00:23)

The 'run selected actions' command succeeded.
The 'set_programming_file' command succeeded.
Project saved.

The 'save_project' command succesded.
Project closed.

m

Figure 28 « Programming Messages in Libero SoC Log Window

7. A green check mark appears next to Program Design and Program Device in the Design Flow
tab indicating that programming has been completed successfully.

Design Flow 5 X

16L2_Standby B Q

Tool 'S

-

Create Design
[»

-

Create Constraints
4

-

Implement Design
S Synthesize
b Verify Post-Synthesis Implementation
55 Compile
L] Cenfigure Flash*Freeze
v 9,3 Place and Route
> b Edit Constraints
> P Verify Post Layout Implementation B

<

-

m

<

b Edit Design Hardware Configuration
> b Configure Security and Programming Options
» Program Design
WE Configure Bitstream
("4 5. Generate Bitstream
v B2 Run PROGRAM Action 8

Design Flow | Design Hierarchy I Stimulus Hierarchy Catalog I Files |

Figure 29 « Design Flow Tab after Programming

8. Close Libero SoC (Project > Exit). Select Yes if prompted about saving changes.
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Running the Demo Design

Power Measurement (Normal Operation and Standby)
IGLOO2 Evaluation Kit board has a voltage measuring circuit which measures the voltage across the
VDD (1.2 V) current sense resistor.
The core power can be calculated using following equations:
» Core Current (mA) = Measured Voltage (mV) + 5 (Scaling Factor)
» Core Power (mW) = 1.2 x Core Current

Connect the positive terminal of a standard digital voltmeter (DVM)/Multimeter to TP14 and negative
terminal to TP7.

Note the digital voltmeter/Multimeter reading and calculate the power using above equations.

Precise Standby Power Measurement

Precise and accurate power measurements can be obtained by measuring voltage across the 1.2V,
0.05 Q sense resistor. Test points TP16 and TP17 can be used to directly measure voltage across the
1.2 V sense resistor. Since the current drawn by the device in standby mode is expected to be around or
less than 10 mA, the voltage measured across the 0.05 Q sense resistor is expected to be less than
0.5 mV. A precise digital voltmeter such as Fluke-287 that can measure sub-millivolt readings should be
used to read voltage measured across the sense resistor.

Convert the voltage measured across sense resistor to power using the following equation:
Power (mW) = (Voltage (mV)/0.05) x 1.2

Total Power (Dynamic and Static)

The following steps describe how to calculate total power:
1. Reset the board by pressing and releasing the Reset button (SW6 DEVRST).
2. Observe the pattern of the LEDs E1, F4, F3, and G7 after resetting the board.
3. Measure the power

Note: If LEDs are not toggling after reset, the device is in Standby mode. Press and release Standby Exit
push button (SW3) and observe the LEDs pattern. The LEDs start toggling. Then, Measure the
power.

Standby Power

The following steps describe how to calculate standby power:

1. Pressand release Standby Entry push button (SW1) and observe the LEDs pattern. The LEDs
stop toggling.

2. Measure the power
3. Press and release Standby Exit push button (SW3).
4.When finished, remove power from the board.
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Appendix A - Power Estimator

Power Estimator

The following steps describe how to use Power Estimator and calculate the total power:

1.
2.
3.

Download the Power Estimator, SmartFusion2 and IGLOOZ2 Power Calculator

Double-click and invoke the power estimator spreadsheet.

Click on the Summary worksheet. The Summary worksheet provides the device settings and the power
summary.

Change the device settings. Enter the following information:

— Family: Select IGLOO2 from the pull-down menu

— Device: Select M2GL010T from the pull-down menu

— Package: Select 484 FBGA from the pull-down menu

- Settings

General
Family

Device

Package

Range

Core Voltage

Process

Data State

Figure A-1 « Settings Section in the Device Settings and Summary Worksheet

The Summary worksheet has an integrated initialize power estimator wizard. This wizard provides an option to select
design specific information. Upon‘running the wizard, it populates the power calculator spreadsheet with information
about the design and performs<power estimation for the design.

5. Click Initialize Power Estimator (see Figure A-2) and invoke the Initialize power estimator wizard. Initialize

Power Estimator dialog box opens (see Figure A-3).

Initialize Power Estimator Reset to Defaults

Settings

General
IGLOO2
M2GLO10T

Family

Device

Figure A-2 - Initialize Power Estimator

Enter the following information in the Initialize Power Estimator dialog box:
uSRAM: Move the slider to zero, 0/22 (0%)

10:

— Technology: LVCMOS25
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— #lnputs: 21
— #Outputs: 22
» Default RAM Enable Rate: 100%

——
Initialize Power Estima
| —Hems — FPGA Fabric
I Used HPMS_CLK | 1 MHz System Clock 100 MHz
HPMS_DDR
Type Width ECC ooT HPMS_DDR_CLK Set all FPGA Fabric resources to 75% w
= [= r PV CLKe L 111 MHz
! = (=1 — - e 4 o
o CERssETET
— FDDR
Type Width Ecc oot AXI/AHECLK  FDDR_CIK R EiN| | [0k 0% ‘l I
I e e s 2 -
wee o iy
| SERDES_IF 0
Technol #Inputs #Outputs
Select Protocol [J::;Zemf AXIJAHB_CLK (PCIe) Ref Clk Freq ke, o g
|| LcMos2s | [21 EN
I seRDESO | PCie [ TN I IS Ma | 100 o
Default Toggle Rate 12.5 %
[ Pee =l [x o [ - |Dev’aultRm&1ah\eRate [ 100 % |
I
Reset OK Cancel | il
— — ==

Figure A-3 ¢ Initialize Power Estimator Wizard

7. Click OK and close the Initialize Power Estimator dialog'box. Click Yes in the Set to Defaults dialog box.

8. Click on the CCC & Oscillator worksheet.and scroll down to FAB_CCC Power section. Enter the following
information in the FAB_CCC Power table:

— Name: FCC_0

— Reference clock frequency (MHz): 0.032
— PLL output frequency (MHz): 500 MHz
—  Output1 frequency (MHz):100 MHz

FAB_CCC Power
Output1 Output2 Output3 Output4 VDD PLL VDDA

Reference  PLL Output

Name Frn-gqlzgr:cy FTSCIJ?J{:(I‘ICV Frequency Frequency Frequency Frequency Power Power
(MHz) (MHz) (MHz) (MHz) (MHz) (MHz) (mW) (mW)
L 1 000 000
0.00 0.00
0.00 0.00
0.00 0.00
0.00 0.00
0.00 0.00
0.00 000

Figure A-4 « FAB_CCC Section
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9. Click on the Summary worksheet to get the total power. The Power Summary section is populated with the
Total Active mode power.

- Power Summary

Active Mode: Summary

Total Power (mW)
Junction Temperature Tj ( °C )
Effective Theta JA ( "C/W )
Maximum Ta ( °C )

Thermal Margin
Maximum Power (mWW) 19787.24

Figure A-5 « Power Summary

10. The Modes and Scenarios section is populated with the total power in the Active, Standby and Flash*Freeze
modes.

- Modes and Scenarios B |

Low Power Mode Scenario

Power in Mode Power in scenario

Made % Time in Mode [mW) (M)

Active
Standby

Flash*Freeze

Figure A-6 » Modes and Scenarios

11. Close the Power Estimator.
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A — List of Changes

The following table lists critical changes that were made in each revision of the chapter in the demo

guide.
Date Changes Page
Revision 3 Updated the document for Libero SoC v11.5 (SAR 64364) NA
(February 2015)
Revision 2 Updated the document for Libero SoC v11.4 NA
(August 2014)
Revision 1 Initial release NA
(October 2013)
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B — Product Support

Microsemi SoC Products Group backs its products with various support services, including Customer
Service, Customer Technical Support Center, a website, electronic mail, and worldwide sales offices.
This appendix contains information about contacting Microsemi SoC Products Group and using these
support services.

Customer Service

Contact Customer Service for non-technical product support, such as product pricing, product upgrades,
update information, order status, and authorization.

From North America, call 800.262.1060

From the rest of the world, call 650.318.4460

Fax, from anywhere in the world, 408.643.6913

Customer Technical Support Center

Microsemi SoC Products Group staffs its Customer Technical Support Center with highly skilled
engineers who can help answer your hardware, software, and design questions about Microsemi SoC
Products. The Customer Technical Support Center spends a great deal of time creating application
notes, answers to common design cycle questions, documentation of known issues, and various FAQs.
So, before you contact us, please visit our online resources. lt'is very likely we have already answered
your questions.

Technical Support

For Microsemi SoC Products Support, visit
http://www.microsemi.com/products/fpga-soc/designsupport/fpga-soc-support

Website

You can browse a variety of technical and non-technical information on the SoC home page, at
http://www.micresemi.com/soc.

Contacting the Customer Technical Support Center

Highly skilled engineers staff the Technical Support Center. The Technical Support Center can be
contacted by email or through the Microsemi SoC Products Group website.

Email

You can communicate your technical questions to our email address and receive answers back by email,
fax, or phone. Also, if you have design problems, you can email your design files to receive assistance.
We constantly monitor the email account throughout the day. When sending your request to us, please
be sure to include your full name, company name, and your contact information for efficient processing of
your request.

The technical support email address is soc_tech@microsemi.com.
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My Cases

Microsemi SoC Products Group customers may submit and track technical cases online by going to My
Cases.

Outside the U.S.

Customers needing assistance outside the US time zones can either contact technical support via email
(soc_tech@microsemi.com) or contact a local sales office. Sales office listings can be found at
.microsemi.com/soc/company/contact/default.aspx.

ITAR Technical Support

For technical support on RH and RT FPGAs that are regulated by International Traffic .in Arms
Regulations (ITAR), contact us via soc_tech_itar@microsemi.com. Alternatively, within My Cases, select
Yes in the ITAR drop-down list. For a complete list of ITAR-regulated Microsemi-FPGAs, visit the ITAR
web page.
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Microsemi.

Microsemi Corporate Headquarters
One Enterprise, Aliso Viejo,
CA 92656 USA

Within the USA: +1 (800) 713-4113
Outside the USA: +1 (949) 380-6100
Sales: +1 (949) 380-6136

Fax: +1 (949) 215-4996

E-mail: sales.support@microsemi.com

© 2015 Microsemi Corporation. All
rights reserved. Microsemi and the
Microsemi logo are trademarks of
Microsemi  Corporation. All  other
trademarks and service marks are the
property of their respective owners.

Microsemi Corporation (Nasdaq: MSCC) offers a comprehensive portfolio of semiconductor
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integrated circuits, FPGAs, SoCs and ASICs; power management products; timing and
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the suitability of its products and services for any particular purpose, nor does Microsemi assume any
liability whatsoever arising out of the application or use of any product or circuit. The products sold
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