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PinEditor (non-MVN) 
PinEditor is a graphical application for assigning I/O ports to package pins.  

Note:  PinEditor (non-MVN) supports only the SX, MX, 3200DX, ACT3, ACT2, and ACT1 families. If you are designing for 
other, newer families, use PinEditor in MultiView Navigator.  See the MultiView Navigator User’s Guide for more 
information. 

Use PinEditor to: 

• Assign I/O macros to pins 

• Lock pin assignments that have been automatically assigned during layout 

• View and print pin assignments 

• Assign I/O standards to banks (for families that use I/O banks) 

• Edit I/O attributes 

• Assign VREF pins (for I/O standards that require an input reference voltage) 

Starting PinEditor 
To start PinEditor from Designer, either click the PinEditor icon in the Designer Design Flow window, or from the Tools menu, 
choose PinEditor. PinEditor displays the pins and I/O macros in your design. 

Components of PinEditor (non-MVN) 
The PinEditor interface is divided into five windows:  

• Package window - view your design elements 

• Assigned list box - displays macros currently assigned to pins 

• Unassigned list box - displays unassigned macros 

• World view window - select the area of the design to display in the Package window 

• I/O Attribute Editor - view, sort, select, and edit I/O attributes 

These windows are highly integrated; anything selected in one is selected or highlighted in all. Commands are accessible from the 
menu bar and frequently-used commands are on the toolbar. 

All the windows and toolbars are independently sizeable, dockable, and closable. To redock or refloat a window, double-click the 
window’s title bar.  



Components of PinEditor (non-MVN)  

 

PinEditor (non-MVN) Interface 

Note:  On UNIX systems, floating windows are not sizeable once undocked, and the I/O Editor does not float. 
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Package window 

Package window 
The PinEditor (non-MVN) Package window displays a graphical interpretation of the pin locations for your selected package type.   

The Package window is integrated with PinEditor windows and list boxes. If you select an assigned pin in the Package window, the 
pin location is highlighted in the World View window and the I/O macro name is selected in the Assigned list box and the I/O 
Attribute Editor. 

The Package Window displays detailed information about each pin, including: 

• Pin number 

• Special pin properties, such as JTAG, clock, ground, or power 

• Assigned I/O macro name, if any 

• Pin type, represented by color 

Colors and symbols 
Colors and symbols differentiate the pin and logic I/O macro assignments in PinEditor. The following table indicates the default colors 
assigned to pins.  

Color/Symbol   Definition 

White border A white border denotes a selected, assigned pin. 

Green   A green border with a black center denotes a regular, unassigned pin. A pin with a grey or yellow border and a green center 
denotes a regular, assigned pin.  

Blue 
A blue border with a black center denotes a special, unassigned pin. A pin with a grey or yellow border and a blue center denotes 
a special, assigned pin. Special pins are pins that have some additional meaning to them. For example, pins used for JTAG are 
blue. When unassigned, special pins have additional descriptive text next to the pin number. 

Grey with red 
center 

Reserved pin. You use this pin for some specific purpose on the package, and you cannot assign it an I/O macro. Examples of 
such pins are ground and power. 

Yellow  Yellow denotes locked assignments. If the assignment is selected, the symbol appears yellow. If the assignment is unselected, the 
border appears yellow. 

Grey/black A pin with a grey border and a black center denotes a pin that is not connected. You cannot use these pins, and they have no 
meaning.  

 

Assigned and Unassigned list boxes 
The Assigned and Unassigned list boxes display assigned or unassigned I/O macros in the design. By default, all assigned I/O macros 
are displayed in the Assigned list box and all unassigned I/O macros are displayed in the Unassigned list box.  

You can filter which pins are displayed in these list boxes. To customize the Assign and Unassign list boxes, from the View menu, 
choose Configure List Boxes. 

See Also 

Customizing Assign and Unassign list boxes

Assigning pins
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I/O Attribute Editor window  

I/O Attribute Editor window 
The I/O Attribute Editor window appears below the Package and World View windows. It functions much like a spreadsheet with sort, 
copy, and paste capabilities. This editor allows selection of variables such as I/O Standard, I/O Threshold, slew rate, and I/O Power-
Up State, depending on the family targeted. You can also enter the capacitance of the load being driven. You can lock assigned pins 
for subsequent place-and-route runs allowing parallel development of the printed circuit board (PCB).  

Use the I/O Attribute Editor to view, sort, select, and edit these attributes. Double-click a column heading to sort by that attribute. If 
you select a macro in the Assigned or Unassigned list box, it will also appear selected in the I/O attribute editor. 

World View window 
The World View window’s default location is under the Assigned list box. Use the World View window to control which portion of 
the package is displayed in the Package window. The blue rectangle (known as the Package rectangle) represents the package. The 
green rectangle (known as the Viewing rectangle) represents the currently displayed area in the Package window. 

To display another part of the package, use the left mouse button to drag the Viewing rectangle to the area on the Package rectangle 
you would like to display. To specify a new display area, use the right mouse button to drag out a new Viewing rectangle on the 
Package rectangle. 

Status bar 
Family, die, and package information appears in the right corner of the status bar. Additionally, the status bar displays information on 
commands, pins, and error messages. 

 

To see other information in the status bar:  

• Hold your mouse over a pin in the Package window to see the pin number, instance name, macro cell, and locked or unlocked 
status.  

• Hold your mouse over a toolbar button or a menu command to see a short description of that command. 

• Error messages provide details about invalid assignment attempts. Choose Extended Error Message from the Help menu for 
more information. 

8  PinEditor (non-MVN) v6.3 User’s Guide  



Assigning pins 

Assigning pins 
Use PinEditor to make and edit I/O macro pin assignments. Edits you make in PinEditor are permanent, provided they are locked and 
have been committed. 

To assign an I/O macro to a pin: 

1. Select the macro name in the Unassigned list box. The macro is simultaneously selected in the I/O Attribute Editor. 

2. Assign the selected macro to a pin location using any one of these methods: 

3. Drag the selected macro name from the Unassigned list box to the pin location in the Package window. Valid pin locations are 
highlighted in the Package Window. 

4. From the Edit menu, choose Assign to invoke Assign mode. Then, select the pin location in the Package window. 

5. Click the Assign toolbar button to invoke Assign mode, and then select the pin location in the Package window. 

6. If you know the specific pin location, enter the pin assignment in the Pin# cell or select a valid placement from the drop-down 
menu. 

If the location is a valid one, the macro is assigned and automatically locked. The status bar displays information about invalid 
assignments. Choose Extended Error Messages from the Help menu for more information about specific error messages. 

Note:  If you assign a macro to a pin that has already been assigned a macro, the previously assigned macro becomes unassigned if 
it was not locked. 

See Also 

Customizing Assign and Unassign list boxes,  Unassigning pins

Unassigning pins 

Unassign an I/O macro from a locked assignment when its locked position is no longer required. Unassigned macros are automatically 
placed in optimum locations during layout. 

To unassign a macro from a pin: 

1. Select the I/O macro in the Assigned list box. 

2. Unassign the selected macro from a pin location using any one of these methods: 

3. Drag the selected macro name from the Assigned list box to the Unassigned list box. 

4. From the Edit menu, choose Unassign. 

5. Click the Unassign toolbar button. 

6. Press the DELETE key. 

7. In the I/O Attribute Editor, select Unassign in the Pin # cell.  

The macro is unassigned. 

See Also 

Customizing Assign and Unassign list boxes

Assigning pins
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Locking and unlocking pins  

Locking and unlocking pins 
Designer does not alter locked pins during Layout. Designer recognizes pins as locked when they are assigned in one of the following 
ways: 

• Manually using PinEditor in a design schematic 

• Using a pin file (all Antifuse families except for Axcelerator) 

• Using a PDC file (ProASIC3E, ProASIC3, and Axcelerator families only) 

• Using a GCF file (Flash families only) 

Locked pins are permanent, provided that you commit your locked pins to your design before you exit PinEditor. To save changes to 
disk (in your .adb file), use the Save command in Designer before exiting PinEditor. 

To lock pins: 

1. Select the pin(s) to lock in the Assigned list box, Package window, or I/O Attribute Editor. To select multiple pins, hold down 
the CTRL key and select multiple pins. To select all pins, from the Edit menu, choose Select All. 

2. From the Edit menu, choose Lock, or select the Locked check box in the I/O Attribute Editor.  

Note:  When you use the I/O Attribute Editor, you can only lock one pin at a time. 

To unlock a pin: 

1. Select the pin(s) to unlock in the Assigned list box, Package window, or I/O Attribute Editor. To select multiple pins, hold 
down the CTRL key and select multiple pins. To select all pins, from the Edit menu, choose Select All. 

2. From the Edit menu, choose Unlock, or clear the Locked check box in the I/O Attribute Editor. 

See Also 

Customizing Assign and Unassign list boxes

Assigning pins 

Closing and committing pin assignments 
The changes you make to your pin assignments and I/O attributes in PinEditor are temporary until you commit them.  

• To commit your pin assignments at any time, from the File menu, choose Commit. 

• To commit your pin assignments when closing PinEditor, click Yes when prompted. 

Committing your changes saves them to the “working” design for this Designer session only.  

To save changes made in PinEditor to disk, you must save your design by choosing Save from the File menu in Designer.  

See Also  

Assigning pins 

Unassigning pins 

Locking and unlocking pin assignments 
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Customizing Assigned and Unassigned list boxes 

Customizing Assigned and Unassigned list boxes 
You can customize which pins are displayed in the Assigned and Unassigned list boxes.  

To customize the list boxes: 

1. From the View menu, choose Configure List Boxes. 

• Filter Assigned and Unassigned Lists - Entering a specific pin name in this field filters out all other pins in the Assigned and 
Unassigned list boxes. Use the * wildcard to filter for groups. 

• Show locked and unlocked pins - Select to display all locked and unlocked pins in the Assigned list box 

• Show only locked pins - Select to filter out all unlocked pins from the Assigned list box 

• Show only unlocked pins - Select to filter out all locked pins from the Assigned list box 

2. Click Apply to see changes. When done, click OK. 

 

Configure List Boxes Dialog Box 

Scripting commands 
You can make pin assignments, lock and unlock pins, commit pin assignments, and edit I/O attributes by running Tool Command 
Language (Tcl) scripts. You can run scripts from the Windows or UNIX command line or store and run a series of commands in a .tcl 
batch file. 

For more information on PinEditor Tcl extension commands, see “Tcl Scripting” in the Designer User’s Guide. 

Assigning I/O macros 
The Pin cell in the I/O Attribute Editor displays either the I/O macro’s assigned Pin number or its Unassigned status. If you know 
the pin number assignment, type the location into the Pin cell.  

Edits you make in PinEditor are permanent, as long as they are locked and committed.  

To assign an I/O macro using the I/O Attribute Editor: 

1. Select the Pin cell for the desired macro in the I/O Attribute Editor. 

2. In the Pin cell, type the pin number or select a valid pin assignment from the drop-down list. 
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Editing multiple rows  

Note:  If you assign a macro to a pin that has already been assigned a macro, the previously assigned macro becomes unassigned. 
Since PinEditor locks all assigned macros, the reassignment unlocks the previous assignment. 

Editing multiple rows 
  To edit multiple rows: 

1. Select the rows to edit.  

To select consecutive rows, click the first row, press and hold down the SHIFT key, and then click the last row.  

To select rows that are not consecutive, press and hold down the CTRL key, and then click each row to select. Continue to hold 
down the SHIFT or CTRL key.  

2. While still holding down the SHIFT or CTRL key, click in the cell containing the value you want to change. Release the SHIFT 
or CTRL key, and then release the mouse button.  

The change occurs in all selected rows. 

Note:  You can also select an entire column, which enables you to edit all rows in that column. 

See Also  

Editing I/O attributes 

Sorting attributes 

Formatting rows and columns 

I/O Attributes by family  

Sorting I/O attributes 
To sort I/O macros by attributes: 

• Double-click a column heading to sort the table rows in ascending order 

• Double-click the same column again to sort the table rows in descending order 

Common I/O attributes (All Families) 
The I/O Attribute Editor displays four common attributes for all I/O macros: 

• Port Name indicates the I/O macro name. 

• Macro Cell indicates the type of I/O macro. 

• Pin # indicates the current pin assignment. 

• Locked, if checked, indicates that you cannot change the current pin assignment during layout. 

Besides the common I/O attributes, the I/O Attribute Editor displays device-specific attributes such as I/O Standard, Skew, and Output 
Load. Only attributes applicable to a specific device appear in the I/O Attribute Editor table.  
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Setting an I/O standard 

Setting an I/O standard 
Choosing an I/O Standard enables the software to set the I/O threshold, slew rate, hot-swap compliance, and output loading.  

To set an I/O standard, select a value from the I/O Standard cell in the macro row you want to edit. 

Refer to the appropriate datasheet for more information about the I/O standards available for your device.   

Setting the power-up state 
All I/Os are equipped with pull-up and pull-down resistors, which are enabled during power-up. These resistors are disabled just 
before VCCA reaches 2.5V, and then the I/Os behave according to the design.  For RTSX-S, the outputs will drive according to the 
design, when the resistors become disabled regardless of the power-up sequence. 

The state of the I/Os during power-up can be configured as High, Low, or None. The default value for Power-Up State in the software 
is “None.”  The only exception to this is an I/O that exists in the netlist as a port, is not connected to the core, and is configured as an 
Output Buffer. In that case, the default setting will be Low. 

To set the power-up state, select a value (High, Low, or None) from the Power Up State cell in the macro row you want to edit. 

Setting the Slew 
The default slew displayed in the I/O Attribute Editor window is based on the I/O Standard. 

The Slew cell indicates the slew rate for output buffers. Generally, available slew rates are high and low. For those devices that 
support additional slew values, Actel recommends that you use the high and low values and let the software map to the appropriate 
absolute slew value. 

To set the slew rate: 

1. Select CUSTOM (SX-A and RTSX-S) from the I/O Standard cell in the macro row to edit. 

2. Select the slew rate (high or low) from the Slew cell. 

Note:  The slow slew rate is incompatible with 3.3V PCI requirements. 

Specifying capacitance 
The default output capacitance appears in the Loading (pf) column of the I/O Attribute Editor. This default value is based upon the I/O 
specification set in the I/O Standard cell. If necessary, you can change the output capacitance default setting to improve timing 
definition and analysis. Both the capacitive loading on the board and the Vil/Vih trip points of driven devices affect output-
propagation delay.  

The I/O Attribute Editor provides a mechanism for setting the expected capacitance to improve the propagation-delay model. Timer, 
Timing-Driven Layout, Timing Report, and Back-Annotation will automatically use the modified delay model for delay calculations. 

To specify capacitance: 

1. Select CUSTOM from the I/O Standard cell in the desired macro row. 

2. Set capacitance in the Loading (pf) column. You can modify the capacitance value to any integer value that accurately reflects 
the capacitive loading on the Actel device pins. Increasing capacitance will increase propagation delays. 
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Specifying I/O Threshold  

Specifying I/O Threshold 
The default I/O Threshold displayed is based upon the I/O Standard. If you want to set the I/O Threshold independently of the I/O 
specification, you must select CUSTOM in the I/O Standard cell. 

To specify I/O Threshold: 

1. Select CUSTOM from the I/O Standard cell in the macro row you want to edit. 

2. Select CMOS, TTL, or PCI from the I/O Threshold cell. CMOS should be faster on high-to-low transitions, and TTL should be 
faster on low-to-high transitions. 

Setting hot swap 
The hot swap attribute Indicates whether the pin is hot-swap capable (on or off). This attribute  is linked to the I/O threshold because 
the same fuse controls both functions. If hot swap is on, it means the pull-up clamp diode is off (not present). In that condition, inputs 
are 5V-tolerant (handle input voltages up to 5.5V), and the device can be used in cold-sparing  applications. Note that with a DC input 
of 5V, the device can draw up to 300 uA per pin. Be sure to also disable the clamp diodes on unused I/Os. Use the dialog box for 
Generate Programming Files. if hot swap is off, it means that the pull-up clamp diode is on (present), and this is only applicable if the 
3.3V PCI I/O standard is selected. Inputs will not be 5Vtolerant and will only support VCCI + 0.5V. The device cannot be used for 
cold-sparing since the pull-up clamp diode will be forward-biased, if a 5V input is applied. 

To set the hot swap, select a value (on or off) from the Hot Swap cell in the macro row you want to edit. 

Specifying Loading 
Loading determines what Timer will use as the loading on the output pin. The output-capacitance value is based on the I/O standard 
selected in the I/O Standard cell. This option is not available in ACTgen.  

The default loadings for different I/O standards are as follows: 

• 35 pf for TTL, LVTTL, and CMOS 

• 50 pf for 5V PCI 

• 10 pf for 3.3V PCI 

Note:  These values are for Timer use only; designers can customize the I/O loading for timing analysis. They do not affect the I/O 
configuration. 
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Menus, Toolbar Buttons, and Shortcut Keys 

Menus, Toolbar Buttons, and Shortcut Keys 
The PC and workstation (UNIX) versions of PinEditor have the same menus. However, some dialog boxes may look slightly different 
due to the different windowing environments. The functionality is the same, though the locations of the fields and buttons on the 
dialog boxes may vary. Field names may also vary between platforms. 

File menu 
Command Icon Shortcut Function 

Commit 
 

 Saves your changes to the working design for this Designer session only 
Note: To save changes to disk, you must also save your file in Designer. 

Prelayout Check   Ensures that the design can be placed and routed 
Print  CTRL + P Prints the design displayed in the Package window 
Close   Closes PinEditor 

Edit menu 
Command Icon Shortcut Function 

Copy  CTRL + C Copies the selection to the Clipboard 
Assign 

 
CTRL + I Assigns the selected I/O macro to the next selected pin 

Unassign 
 

DEL key Unassigns the selected I/O macro 

Lock 
 

CTRL + F Locks the selected I/O macro 

Unlock 
 

 Unlocks the selected I/O macro 

Select All  CTRL + A Selects all assigned I/O macros in your design 
Configure I/O Banks   Not used 
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View menu  

View menu 
Command Icon Shortcut Function 

Zoom Area 
 

 Drag out an area to enlarge 

Zoom In 
 

+ Magnifies the view by a factor of 2 (scale = 2x) 

Zoom Out 
 

- Reduces the view by a factor of 2 (scale = .5x) 

Fit in Window 
 

CTRL + W Fits the entire design within the Package window 

Redraw  F2 Redraws the design in the Package window 
Configure List Boxes...   Displays the Configure List Boxes dialog box, in which you can 

filter which pins appear in the Assigned and Unassigned list boxes 
Color Manager   Displays the Color Manager dialog box, which does nothing in 

PinEditor but changes the colors of nets, clusters, and 
SuperClusters in ChipEditor 

I/O Banks   Not used 
Toolbar   Hides or displays the toolbar buttons 
Assigned List Box   Hides or displays the Assigned List Box 
Unassigned List Box   Hides or displays the Unassigned List Box 
World View   Hides or displays the World View window 
I/O Attribute Editor   Hides or displays the I/O Attribute Editor at the bottom of the 

window 
Status bar   Hides or displays the status bar 

Help menu 
Command Shortcut Function 

Help Topics 
 

 Displays online Help for this version of PinEditor 

Reference Manual  Opens the PinEditor User's Guide (.pdf file) in Adobe Acrobat 
Extended Error Message  Displays a dialog box with more detailed information 
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Contacting Actel 

Contacting Actel 
Actel Headquarters 

Actel Corporation is a supplier of innovative programmable logic solutions, including field-programmable gate arrays (FPGAs) based 
on Antifuse and Flash technologies, high-performance intellectual property (IP) cores, software development tools, and design 
services targeted for the high-speed communications, application-specific integrated circuit (ASIC) replacement, and radiation-tolerant 
markets.  

Address: Actel Corporation 
2061 Stierlin Court 
Mountain View 
CA 94043-4655 
USA 

Phone: (650) 318-4200 
(650) 318-4600 

Technical Support 
Highly skilled engineers staff the Technical Support Center from 7:00 AM to 6:00 PM Pacific Time, Monday through Friday.  

Visit Tech Support Online 

For 24-hour support resources, visit Actel Technical Support at http://www.actel.com/custsup/search.html.   

Contacting Technical Support 

Contact us with your technical questions via e-mail or by phone. When sending your request to us, please be sure to include your full 
name, company name, email address, and telephone number.   

E-mail (Worldwide): tech@actel.com

Telephone (In U.S.): (650) 318-4460  
(800) 262-1060 

Telephone (Outside the US): Contact a local sales office 
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Customer Service  

Customer Service 
Contact Customer Service for order status, order expedites, return material authorizations (RMA), and first article processing. For 
technical issues, contact Technical Support. 

 

From Call 
Northeast and North Central U.S.A. (650) 318-4480 
Southeast and Southwest U.S.A. (650) 318-4480 
South Central U.S.A. (650) 318-4434 
Northwest U.S.A. (650) 318-4434 
Canada (650) 318-4480 
Europe (650) 318-4252 or +44 (0) 1276 401500 
Japan (650) 318-4743 
From the rest of the world (650) 318-4743 
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For more information about Actel’s products, call 888-99-ACTEL or visit our Web site at http://www.actel.com 

Actel Corporation • 2061 Stierlin Court • Mountain View, CA USA 94043 
U.S. Toll Free Line: 888-99-ACTEL • Customer Service: 650-318-4200 • Customer Service FAX: 650-318-2440 
Customer Applications Center: 800.262.1060 • Customer Applications FAX: 650.318.4600 

Actel Europe Ltd. • Dunlop House, Riverside Way • Camberley, Surrey GU15 3YL • United Kingdom  
Tel: +44 (0) 1276 401 450 • Fax: +44 (0) 1276 401 490 

Actel Japan • EXOS Ebisu Bldg. 4F • 1-24-14 Ebisu Shibuya-ku • Tokyo 150 • Japan 
Tel: +81.03.3445.7671 • Fax: +81.03.3445.7668 

Actel Hong Kong International • Suite 2114 • Two Pacific Place • 88 Queensway, Admiralty • Hong Kong 
Tel: +852 2185 6460  • Fax: +852 2185 6488   
5-02-9119-8 
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