'Aclllel Core429 PCB
Programming and Testing Procedure vi.1

Core429 Daughter Board
Programming and Testing Procedure v1.1

This guide provides instructions to program the Platform8051 Development Board and test the
Core429 Daughter Board.

Note: Steps 1-31 can be performed once because only one correctly programmed Platform8051
Board is needed to test multiple Core429 Daughter Boards. Step 32 and above are
required to test each Core429 Daughter Board.
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1. Requirements

a.

-~ 0o o o T

A PC with one available parallel port.

The Platform8051 Development Board (fully tested & known working).
Core429 Daughter Card.

2 DB9 test cables.

9V Power supply.

FlashPro Lite Programmer.

2. Prepare the PC

a.

C.

Install FlashPro 3.2 or later.

A FlashPro 3.2 CD can be found in the Core429 Devkit, insert the CD and
follow the on-screen instructions.

Install FS2 debugger.

A FS2 ISA-Actel51 Debugger CD can be found in the Core429 Devkit,
insert the CD and follow the on-screen instructions.

Insert the Core429 Development Kit CD.
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3. Install jumper “J1” (if not already installed).
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4. Peel off the plastic cover on the LCD (if not already removed).
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5. Connect FlashPro Lite (not FlashPro) to the pf8051 board.
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6. Connect the FlashPro Lite to the PC’s parallel port.
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7. Connect the power supply to the pf8051 board (ensure the switch is off).
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8. Set the DIPSWITCH.

There are 8 switches on the DIPSWITCH:

a.

“open”

1-6 should be set to “closed’, push the small button to the side opposite the one marked

b. 7-8 should be set to “open”, push the small button to the side marked “open”
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9. Turn on the power by sliding the power switch (SW1) to the left.
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10.Run the FlashPro software on the PC.

& Actel FlashPro
File Help

= E » |
File: |
Al::tiun:| j

2 Flash_Pro

Log ] Device Infcll

11.Select: “File -> Connect...”

& Actel FlashPro
File Help

Connect.., |
Analyze Chain
{Jpen STAPL File
Clear Log
“5. 5 Flash_Pro
Exit

Lag | Device Info |
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12. Click “Connect”.

FlashPro: Connect to Programmer §|

Fort:

lpt1

—

Configuration: |ProASIC PLUS ~ |

vvDDL 25
v PP 182
vVPN 13
v VDDP |25 -
[ Drive TRST

Connect |

13. Select “File -> Analyze Chain”.

& Actel FlashPro

File Help
=& »

File: |

Action: | R

[Device:|1: APAS00 -]

Flash Pro

Log ] Device Infn]

Connected to programmer on port 1lptl

Driver: 1.7.7 build 1

FlashPro Lite does not support ¥Vddp and ¥dd power supply.
User needs to supply Vddp and Vdd from the target.
dnalyezing chain...

Found 2 instruction register bits

Checking IDCODEs...
Dewvice 1: 0OL38C1CF Mfr: Actel Part: APAGOOD

Check that APA600 appears in the above window.
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14. Select “File -> Open STAPL File”.

Loak in: |@ hitztreatn v| I ,5'|| =
My Recent
Documents
=
[
Desktop
hdy Documerts File nane: | cored28 stp |
la Files of type: |5T',g,_p|_ (* st v| Cancel ]

15. Browse to “<CD Drive>:/

core429 devkit_2.0/Core429 Demonstration/FPGA_design/bitstream/”,
select “core429.stp” and click “Open”.

& Actel FlashPro

File Help

- BX

= | ‘

File: |D:'l.u:n:ure429_devk'rt_2.IIIICDre4EQ_Demnnstratiu:un'lFPGA_designﬁh'rtstreamﬁmreﬂEl.stp |

Action: |QUERY _SECURITY v|

Device: 1: APAG00 v | FIaSh Pro

Log | Device Info

Connected to programmer on port lptl L
Driver: 1.7.5 build 7 T
FlashPro Lite does not support ¥Vddp and vdd power supply.
Tzer needs to supply Vddp and Vdd from the target.
Adrnalyeing chain...
Found 2 instruction register bhits
Checking IDCODEs...
Dewice 1l: 0O135C1CF Mfr: Actel Part: APAGOO
STAPL file loaded succezsfully
w
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16. Select “Action -> PROGRAM".

& Actel FlashPro

File Help
= ||

File: |D:'u:-:ure429_devk'rt_2.I:I1.C|:|re4EE_Dem-:unstratil:un'lFPG.ﬂ._designﬁh'rtstreamﬁmreﬁlel.stp |

Action: | QUERY _SECURITY | w

evice: [QUERY _SECURITY W F I h
ERASE

Log | READ _IDCODE
YERIFY
':':'nnEDEVICE_INFO Br on port lptl 1
Driw
Flasl%t support ¥ddp and ¥Vdd power supply.
User needs to supply Vddp and Vdd from the target.
Analyeing chain...
Found & instruction register bits
Checking IDCODEs...
Dewice 1: 0138C1CF Mfr: Actel Part: APARO0
STAPL file loaded successfully
"

Jan 2005 50400031-1
© 2005 Actel Corporation



'Aclllel Core429 PCB
Programming and Testing Procedure vi.1

17. Click the “Play” button circled below:

& Actel FlashPro M (=13

File Hel

u

=

File: | Dvcored29_devkit_2 0WZored 28 DemonstrationFPGA_designibitstreamtcored 29 stp |

evice: 1: APABO0 v FIaSh Pro

Lod | Device Info

Driwver: 1.7.8 build 7

FlashPro Lite does not support Vddp and Vdd power supply.
Tzer needs to supply Vddp and Vdd from the target.
Analyzing chain...

3

Found & instruction register bits
Checking IDCODE=...

Device 1: 0138C1CF Mfr: actel Part: APas00
STAPL file loaded successfully

<

18. Click on “Execute”.

Execute Action g

@ v FBCINT_ARRAYS

=
v

v CHECK _SECLURITY
-

Reset | Cancel |
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19. Wait until the message “PASSED, EXIT 0” appears at the bottom of the
window (approximately 10 minutes).

& Actel FlashPro

File Help
=] >

File: |D:1.cure429_devk'rt_2.I:I".Cl:ure429_Dem|:|nstratil:un1.FF‘G.ﬂ-._designﬁb'rtstreamﬁmre-ﬂfzg.stp |

Action: PROGRAM v|

evice: 1: APABOO v| FIaSh Pro

Log | Device Info

wpp set to 16,20 wolts

wph set to -13.60 wolts

Executing action PROGEAM on dewice 1: APAGOD

[ >

Interrupting the operation may result in damage to the FPGA
andsor the Programmer.
At exit code will be returned upon completion.

SERIAL# = 00065543D0ESS0

PROGELMMING APEAY ... 100%

YERIFYING PROGEAMMED EITS... ... l00%
YERIFYING ERASED BIT3... ... 100%

PALESED, EXIT 0O
Operation completed in 00:10:32

<

20. Select “File -> Exit”.
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21. Start “FS2 Debugger” on the PC by clicking “ Start -> Programs -> FS2 ->
FS2 ISA-Actel51 Debugger”. (If Debugger fails to start, exit program, power
cycle the PF8051 board, then start FS2 Debugger again)

2Source [Source Mode] - Actel Flash Pro Programmer

File Edit Config Utlites Tools  Window Help

Go Hailt Step Into Step Ower Goto Cursor ‘ Toggle Bkp
- 0000 - W e
OO00Zp SZD3 mow r=s0,C
0004y 5% anl a,rl
0o05p 33 rle a
000ép  EBOZA anl o, S0xEa
0008p ZOFOZE Jjb Ox£l, 0003 &
O00Bp ©18C ajmp O0=x0&Bc
oodop 6D xrl a,rh
OODEp Z1cC8 ajmp Ox01c8
0010p A4 mul ah
0011p cCEe0 alr ]
0013p AF3HE mow r?, 0x38
0015p 24 add a,rz
001lep E4 olr a
0017y E4 olre a
0013p G4 xrl a, rz -
\ 0
I| Feady | | Halted | User reset

22. Select “Tools-> Load Hex”, enter “0x0000x” in the “Address to load at”
field.

Load Hex File - Actel Flash Pro Programmer

Specify hex file to load:

Address bo load at; |m

Filename: |D:/core429_devkit_2 0/Cored23_Den Browss...

ok Cancel Help |
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23. Browse to “<CD Drive>:/

Core429 _devkit_2.0/Core429 Demonstration/demo_software/”, select

“demo.hex” and click “Open” then “OK”".

Select HEX File
Look jr: |E} dermo_zaftware ﬂ IfF *

- kel
L'“mb demo.hex

by Recent
D ocuments

ol

Desktop

Y
ty Documents

by Computer
My Metwork  File name: |demu:u.he:-: ﬂ Open |
Places
Files of type: | Last file default [* hex] - Cancel |
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24. Wait for about 30 seconds and click on “Go”, the message “Running

should appear in green at the bottom of the window.

Source [Source Mode] - Actel Flash Pro Programmer

Fle Edt Config Utlites Tools Window Help
Go ‘ Halt step Into Step Ower Goto Cursor | Toggle Bkp

| -
Oo03p 3Z reti
ooc4p 52 anl a, rl
ooosp 33 rle a
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O00Bp 32 reti
0o0dcp 8CeD mowv Ox&d, rd
OO0Ep 2108 ajmp O0x01lcE
0010p A4 mul ah
0011p cCEze0 alr 0z&l
0013p 32 reti
0014y 38 adde &, r0
0015p 2 add a,rz
001lep E4 alr a
0017y E4 olr a -

\ 0

|| Peady [Running |
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25.Adjust the screw on the LCD contrast control (circled below) until the

characters on the LCD are clear.
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26.Set the DIPSWITCH
There are 8 switches on the DIPSWITCH:

a.

1 should be set to “open”, push the small button to the side marked “open”

b. 2-6 should be set to “closed’, push the small button to the side opposite the one marked

“open”

C.

7-8 should be set to “open”, push the small button to the side marked “open”
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27.Press the Reset button once and wait for about 15 seconds.
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28.In FS2 Debugger, Select “File -> Exit”.

2Source [Source Mode] - Actel Flash Pro Programmer !__”g|g|
File Edit Config Uflites Tools Window Help

Ga ‘ Halt atep Into otep Ower Gato Cursaor ‘ Toggle Bkp
| i
0003p 32 reti
ooc4p 52 anl a,rl
ooosp 33 rle a
O0Dép BOZA anl ¢, 0xEa
Ooo8p  Z0FO0EEB Jb O=£f0, 00035
O00Bp 32 reti

0o0dcp 8C&D mow Oxéd, rd
O00Ep 2108 ajmp O0x01c8

0010p Ad mul al

001lp CZ60 alre 060

0013p 3Z reti

00l14p 38 adde  a, x0

0015p Z2a add a, rz

001lep E4 alr a

0017p E4 alr a -
\ i

|[Feady [Funning |
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29.Turn off the PF8051 board by sliding the switch below to the right.
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30.Disconnect the FlashPro Lite from the PF8051 Board.

RS-232
o E RIS | | Ruts S22 |l ysp | [Power
| ® ,eusm ® 'Port! | Switch
Fea & T
‘J? Seen J L:::.l |J13 =TT Lgﬁ il
XX senee oz O g7 %l T
1553 J, o 1953 | D«[ﬂﬁﬁlﬂ ml:l@l:los uga
XFR XFR ULl ool ura
[ | " o m 'Ether-
 TTTTY TR TRTNTENTY] j!PHY ‘ CORE POMER I.I=
; P s
1553B Transceiver ’
' Tpmg, —)E --- ae ------Ef]------------j
EsssesssandRERsRER EEEL g-u' ; Sensor : . l-':::::::::::::::::
- i - Yumi ADC [* sesesenssssesenes
gl ¥378 e s sosaastt TR Sesessssssnsassas
- E 3 B Sessssssssnssssas
[ . 1 5 1 ACTEL H e . sesesesssesRRERen
___a {  APASOD | . cosssssesssssesss
4 FGETR e u1e fa sesssesnsssnsanEs
vio, e U ai F v - sssssssssssesenEs
A b v . SESESESABNBERERD
o & ¥ i - I I T T ™™
Lo f il 3 S8 SRBITOROIROIRES
g2 T Ed EETTEw L - (AR R RS R RN RY N
FLASH uis £l (A A RS R R RS R RN R}
i | RO SPI 12C . cesssssssessssass
0 AT B EEPROM EEPROM ™" I3 tssesssssssssssss
3 o0 :ﬂ srt“] iy . tesssssssssssssse
EI"I L :’PH" D.H. i Jzale SO0 BSSORRRRRRS
EE uzs uza . vz s i h I : (A A RS R R RS R RN R}
- 12 0 £l
S "| | * Crystal® | | " Crystal® |= P
EE Tdes % .1EMHZ. .25MHZ. «m+DI0 0]
am td
= s 2l i LT 2181 9
Vi oz o
,f’-'a;\ - RTITTIg w01z
Reset DIP SW lI il Chsesssssesnsesss
y e LA EEEXLE] 1 LEDS td feSsOORTROEROTRRREN
RET g ' o . cssesssssssssssss
® N . tessssssssssssans
Keypadssm LCD R R R R R A R R AR AR Y]
(A LA R AR R L RS EANEERESESERYN]
s L]
| | |
Platform8051
-
® - - [
Jan 2005 50400031-1

© 2005 Actel Corporation




VActel

Core429 PCB

Programming and Testing Procedure vi.1

31.Set the DIPSWITCH

There are 8 switches on the DIPSWITCH:

a.

“open”

1-8 should be set to “closed”, push the small button to the side opposite the one marked
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32.Install Jumper (J1) on the Core429 Daughter Board (circled below):
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33.Install Jumper (J3) such that the top two pins (2 & 3) are connected leaving

the bottom most pin (1) unconnected.
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34.Install Jumpers J20 and J21 (circled below):
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35.Install Jumper (J22) (circled below):
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36.Attach the Core429 Daughter Board (J2) to the PF8051 Board (J23).
Note: Ensure that pin 1 of the Core429 Daughter Board connects to pin 1 on the
PF8051 connector (J23) (See below and picture on following page)

FF

aeel J]a 1]
L Fatok [T Lﬁ A

RS 232 =

‘ RJ-45 Port @| USB | Power | |$x| @

! ® ceees ® lLPurtl _Switch | | 5%
XL XL D} ' RIA5
1553 J, . 1953 | leﬂmlﬁl |:|05 uza -
XFR XFR u IIIIIIII“ l"ﬂllHIIII u14 i
B £ Etherg 'Ether- .___-_"_
[N [ 1111} gnnna L
PHY [ sgp.w . E i
| |

L L] |
LR

® Jﬂ EJE | s
B4 E3

o= 1 :
15563B Transceiver ®
Temp J18 J21
m‘ EEEL “Er Sensor™” F3

T F’°|||||||||| S22 isreap srsaast
= 1 :
g F
" ] ACTEL |1
@ i APAgOD |
i q o
SiE: EEETER 5 ] FeEs |
& i 5 i
oo TETT T RN EER
=
= SPI 12C
& EEPROM EEPROM
..—m o ol
e HIES
§§ vay uz = os
:' ~|° g Crystal * Crystal * | =
:' a5 . SNSRI NIENIRNRBRERES
LA R A R S R R AR E A RS
= LT Lo LA R N R R R AR AR Y]
Guio12 Secsssesssssssassssssse
o1 secsssssssssssssssssnss
s m+Did
LEDs

Platform8051

Keypadssm . LCD -
e

PIN 1 on J23

Jan 2005 50400031-1
© 2005 Actel Corporation



VActel

Core429 PCB
Programming and Testing Procedure vi.1

Jan 2005
© 2005 Actel Corporation

50400031-1

30



'Aciel Core429 PCB
Programming and Testing Procedure vi.1

37.Attach the two DB9 cables.

a. Channel 0 connects to Channel 1

b. Channel 2 connects to Channel 3

Channel O

Channel 1

Channel 2

Channel 3
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38.Turn on the power by sliding the power switch (SW1) to the left.
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Note: If the LCD remains blank after the power has been turned on:
a. Turn off the board power (SW1).
b. Connect the FlashPro Lite Programmer to the PF8051 board.
c. Set the dipswitch as in Step 8. (1-6 set to “closed” and 7-8 set to “open”)
d. Turn on the board power (SW1).
e. Proceed from Step 21 to reprogram the PF8051 Flash Memory.
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39.Hold down the Reset button (SW2) and the UP button (SW3) on the keypad.
While holding down the UP button (SW3), Release the Reset button (SW2).
Keep the UP button (SW3) depressed until “Test Mode” is displayed on the

LCD.
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40.The test will verify operation of each channel by performing four tests:

Transmitting from Channel 0 and Receiving on Channel 1 (0TX 1RX)
Transmitting from Channel 1 and Receiving on Channel 0 (1TX ORX)
Transmitting from Channel 2 and Receiving on Channel 3 (2TX 3RX)

a0 T p

Transmitting from Channel 3 and Receiving on Channel 2 (3TX 2RX)

The test results will be displayed on the LCD screen. If all tests passed, the
message “All PASSED” will be displayed. If a failure occurs, the LCD will
cycle through the failures by displaying messages such as,

“FAILED : OTX 1RX".

41.Record the test results and turn off the board power by sliding SW1 to the
right.

42.Unplug the two DB9 cables from the Core429 Daughter Board and
disconnect the Core429 Daughter Board from the Platform8051 Board.

43.Proceed to Step 32 to test another Core429 Daughter Board.
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