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About this Release

This G-2012.09A-SP3 release includes software features and enhancements for the
Synplify Pro® Microsemi Edition product. For the complete summary of features and

enhancements contained in this release, see G-2012.09A Features and Enhancements on
page 2.

G-2012.09A Features and Enhancements
This section contains a summary of the features and enhancements for the G-2012.09A
release. Topics include:
* New Constraints Style
* Read Write Check on RAM
* HDL Analyst Enhancement

* Interactive Attribute Examples

Compiler Enhancements

New Constraints Style

In this release, the FPGA synthesis tool is replacing the legacy Synplify-style timing
constraints (for example, define_clock and define_false_path) with the Synopsys standard
timing constraints (for example, create_clock and set_false_path). A new FPGA Design
Constraint (FDC) file is generated that contains these Synopsys standard timing constraints
and the design constraints (for example: define_attribute and define_io_standard).

As a result of these updates, there are some changes in the use model:

* Instead of a constraint file created in the legacy SDC format, the tool now supports an
FDC file that includes both timing and non-timing constraints (design constraints).

For existing designs, use the sdc2fdc command to do a one-time conversion of the
constraints from legacy SDC constraints to create an FDC file that contains Synopsys

SDC standard timing constraints and non-timing constraints. See sdc2fdc Conversion
Script on page 3.

For new designs, the SCOPE editor has been enhanced to support the timing
constraint changes, so that new constraints can be entered correctly.

CAsoftware\tutorial\tutorial.fdc *

Current Design: |<Top Level= v| |FJJ Check Constraints |

EI Enable | Name | Object | Period | Waveform | Add I Clock Group Latency Uncertainty Comment E
2 |

5 |

4 |

3 :
E:cks Generated Clocks Collections Inputs/Qutputs Delay Paths Attributes 1/0 Standards Compile Points TCL View
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For more information, see the online help or reference.pdf->Constraints for an overview about
constraints and the SCOPE Constraints Editor for descriptions of the SCOPE panels.

For more information, see the online help or user_guide.pdf->Specifying Constraints for details
on how to use the SCOPE editor.

sdc2fdc Conversion Script

Use the sdc2fdc command to do a one-time conversion of Synplify-style timing constraints
(for example, define_clock and define_false path) to Synopsys standard timing constraints (for
example, create_clock and set_false_path). Load your Project file and from the Tcl command
line in the synthesis tool, the sdc2fdc command scans the input SDC files and attempts to
convert constraints for the implementation. The timing and design constraints are written
to an FDC file and saved to your project. You can open this output file in SCOPE and
analyze its results.

For more information, see the online help or user_guide.pdf->Specifying Constraints->Converting
SDC to FDC and the reference.pdf->Ultilities->sdc2fdc Tcl Shell Command.

Read Write Check on RAM

The Read Write Check on RAM option on the Device panel lets the synthesis tool insert bypass
logic around the RAM to prevent a simulation mismatch between the RTL and post-
synthesis simulations. The synthesis software does not insert bypass logic around the RAM
that read and write to the same address simultaneously. Enable this option, when you want
to simultaneously read and write to the same RAM location.

For more information, see the online help or reference.pdf->Designing with Microsemi Appendix
for devices that support this option and Batch Commands and Scripts->Batch Commands for
Synthesis->set_option for the Tcl syntax.

HDL Analyst Enhancement

The HDL Analyst enhancements include the following:

* Enable the Display color-coded clock nets option from the General tab of the HDL Analyst
Options dialog box to display clock nets with the color green in the HDL Analyst View.

* You can easily locate compile points of type {hard} in the Technology view because they
are now displayed with the color green.
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Interactive Attribute Examples

The Interactive Attribute Examples wizard lets you select pre-defined attributes to run in a
project. Click Generate Run to run synthesis for the implementations. When synthesis
completes:

— The Technology view opens to show how the selected attribute impacts synthesis.

— You can compare resource utilization and timing information between implementations
in the Log Watch window.

To use this tool, see the online help or reference.pdf->User Interface Overview->Other Windows
and Views->Interactive Attribute Examples.

Compiler Enhancements

Compiler enhancements for this release include:
* SystemVerilog Type Operator Support
* VHDL Implicit Data-type Defaults
* The orig_inst_of Property for Parameterized Modules

* VHDL 2008 Enhancements for Bit-string Literals

SystemVerilog Type Operator Support

SystemVerilog provides a type operator as a way of referencing the data type of a variable or
an expression.

For details about syntax and coding examples, see the online help or reference.pdf->System-
Verilog Language Support->Operators and Expressions->Type Operator.

VHDL Implicit Data-type Defaults

Type default propagation avoids potential simulation mismatches that are the result of
differences in behavior with how initial values for registers are treated in the synthesis tools
and how they are treated in the simulation tools.

With implicit data-type defaults, when there is no explicit initial-value declaration for a
signal being registered, the VHDL compiler passes an init value through a syn_init property to
the mapper, and the mapper then propagates the value to the respective register. Compiler
requirements are based on specific data types. These requirements can be broadly grouped
based on the different data types available in the VHDL language.

For details about syntax and coding examples, see the online help or reference.pdf->VHDL

Language Support->VHDL Implicit Data-type Defaults.

The orig_inst_of Property for Parameterized Modules

The compiler uniquifies parameterized modules or instances and the inst_of property can be
used to find the RTL name of the uniquified module/instance. Use the new orig_inst_of
property to find the original module/instance name before it was uniquified.

For more information, see the online help or user_guide.pdf->Analyzing with HDL Analyst and
FSM Viewer->Working in the Schematic Views->Viewing Object Properties.
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VHDL 2008 Enhancements for Bit-string Literals
Bit-string literal support in VHDL 2008 includes:
* Support for characters other than 0 and 1 in the bit string, such as X or Z.

* Optional support for a length specifier that determines the length of the string to be
assigned.

* Optional support for a signed (S) or unsigned (U) qualifier that determines how the bit-
string value is expanded/truncated when a length specifier is used.

* Additional support for a base specifier for decimal numbers (D). The number of
characters in the bit string can be determined by using the expression (logyn)+1; where
nis the decimal integer.

For more information, see the online help or reference.pdf->VHDL 2008 Language Support
->Operators->Bit-String Literals.

Platforms and Patches

This section includes platform support and other platform-specific information.

Platform Support
The software is supported on the following platforms and operating systems:

* Windows (x86_x64):
— 7 Professional or Enterprise (32/64-bit)
— Vista Enterprise or Business (32/64-bit)
— XP Professional (32/64-bit)

* Linux (x86_x64):
— Red Hat Enterprise Linux 4/5/6 (32/64-bit)

Required Operating System Patches

Running this software requires that the Linux operating system include specific patches. To
determine whether your operating system requires patches, refer to the following procedure.
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Checking the Installed Patches

All Linux-based FPGA synthesis applications include a script (syn_system_check) that is
designed to check patches that have been installed and the patches that need to be installed
or updated.

To use this script:
1. Install the product software.
2. Run the script by entering the following command in a shell:
linstall_dirlproduct_version/bin/syn_system_check

3. The script runs and generates a system check summary report that lists the patches and
patch status (OK, Install, or Upgrade).

4. Consult the display and install or update any of the patches indicated.

Example

The following is a sample report.

Synplicity systewm check swmary report for host 'synsuns '

1. /home/syn/user availsble size == 13725736 KB [ OE ]

2. Jtmp swvailshble size == 243192 KB [ 0K ]

3. Svar/tmp svailskle size == 22069 KB [ OK ]

4., Cwurrent DISPLAY is set to 'user:0' [ Check user ]

5. PReguired Pateh '106950-131 [ Install Patch ]
6. Upgrade from '106146-14' to '106146-31' Fecuired [ Tporade Patch ]
7. Upgrade from '106327-08' to '106327-13' Fecuired [ Upgrade Patch ]
§. Upgrade from '106541-07' t£o '106541-19' Fecuired [ Upgrade Patch ]
9. Upgrade from '108376-12' t£o '108376-34' Fecuired [ Upgrade Patch ]
10. sparc architecture [ O]

11. synsunZ solaris 5.7 [ oK ]

Explanation of Cperating system patches, following patches are
awvallable at wvendor's ftp site

106146-31 ] SunCS 5.7: MA4 Graphics Patch

106327-13 ] 3Z-Bit Shared library patch for CH++

106541-19 ] SunCS 5.7: Eernel update patch

106250-13 ] S3unCS 5.7: Linker Patch (| required by 106327-13 )
105376-34 ] Cpenlindows 3.6.1: Esun Patch

Documentation

This section includes the following documentation topics:
* Accessing PDF Documents

* Accessing Online Help
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The Synopsys FPGA Synthesis product documentation set consists of the following:

Document Format Access

Online Help HTML Help See Accessing Online Help on page 8.
Document Type PDF and See Accessing PDF Documents on page 7.
e User Guide HTML help

¢ Reference Manual
¢ Release Notes

¢ Error Messages HTML Help Select Help->Error Messages.

Click on the error message in the log file or
the Message Viewer window.

Accessing PDF Documents

PDF documents display in Adobe Acrobat Reader. You can download the latest Acrobat
Reader at no cost from Adobe’s website (www.adobe.com). The PDF files provided are optimized
for output to a laser printer, not for viewing online.

To access PDF documents either from the software or without running the software, see the
table below for details.

Synopsys FPGA Products

From Linux From outside the software, select:

* Open Acrobat Reader: acroread
Open install directory/documents/docfile

From Windows +« Start->Programs->Synopsys->Synplify Pro for Microsemi Edition
G-2012.09A-SP3->Documents

Then, select the desired document.

¢ From inside the software for all platforms, select Help->Online Documents.
In the Open dialog box, select the desired document:
- user guide.pdf
- reference.pdf
- release notes.pdf

Note: Do not use the View->Full Screen option when viewing documents in Acrobat Reader
unless you are sure you want this full magnification. On some applications, this
selection takes over the monitor and there is no apparent way to access other running
tasks or windows. If you do happen to use the Full Screen option, you can use Ctrl-l to
undo it.
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Accessing Online Help

Topics include:
* Synopsys FPGA Products
* Displaying Graphics

Synopsys FPGA Products

For the FPGA products, you can access help from within the software or outside of the tool.

Accessing Help from inside the tool

All platforms Press F1 or select Help->Help.
For context-sensitive help, click F1 in a dialog box.

Accessing Help from outside the tool

On a Windows machine Select Start->Programs->Synopsys->Synplify Pro Microsemi Edition
G-2012.09A-SP3->Help.

From Linux Run synplify_pro_help.

Displaying Graphics

In some cases, the online help graphics do not display correctly. This is usually because
your Display setting is 256-Color. Reset the display to 16-bit Color, then reopen the online help.
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Known Problems and Solutions

The following problems apply to supported features in the Synplify Pro tool.

Manually Copy Compile Point Sub-directories to Identify Implementation

When compile points are included in an existing FPGA implementation and a new Identify
implementation is created, the compile-point related data is not copied to the Identify
implementation.

Solution: Manually copy the sub-directories in the FPGA implementation to the new Identify
implementation directory. In addition to the sub-directories, the top-level constraint file and
all of the compile-point constraint files for the related modules must be enabled on the Con-
straints panel of the Implementation Options.

Up-to-date Checking Limitation for Sourced Tcl Files in the SDC File

When a design is run, the up-to-date checking feature automatically determines if a design
needs to be re-synthesized or not. This feature can provide significant runtime improvements
especially for team designs.

However, when you modify constraints in a Tcl file sourced within the constraints file (sdc),
the software is not aware of these changes and does not force the design to be re-synthesized.

Solution: This will be fixed in a future release.

Handling State Machines in Different Clock Domains

If a state machine defined in the code feeds sequential elements in a different clock domain,
using any encoding value other than the "original" can cause metastability. By default, the
synthesis tools choose the optimal encoding value based on the number of states in the state
machine. This can introduce additional decode logic that may cause metastability when it
feeds sequential elements in a different clock domain.

Solution: As a workaround, use syn_encoding = "original" to guide the synthesis tool for these
cases.

Verilog Include Paths Missing from VCS Integration

If Verilog include paths have been added to your Project file, these paths are not automatically
added to the VCS script.

Solution: You must add the Verilog include paths manually. To do this, use one of the following
workarounds:

— From the Run VCS Simulator dialog box, add +incdir+<include path> in the Verilog
Compile options field.

— Modify the VCS script file, adding the +incdir+<include path> to all or any relevant
vlogan commands.
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Crossprobing Source Code Files Created with Third-Party Editors

When using source code files created with third-party editors, you sometimes cannot
crossprobe to the correct line number in the source file.

Solution: Open the file in the FPGA synthesis tool text editor.

Editing Externally Created Project (prj) Files

If Tcl commands or script files were used to build your project, you might not be able to save
this Project file from the synthesis Ul in downstream tools, because they contain hard-coded

file paths.

Solution: Generally, use the same method to save a project as you did to create the project. In
this case, save the project file to an external text editor and not in the project UL

Digital Line Detect Error Appears (Windows XP)

When launching the synthesis software, a Digital Line Detect error occasionally appears on a
Dell PC running Windows XP.

Solution: Download the latest update from Dell Corporation. See the following URL for more
information.

http://support.dell.com/support/downloads/format.aspx?releaseid=r84541&c=us&l=en&s=gen&cs

Alternatively, you can deselect the Digital Line Detect entry in your system configuration. To
do this:

1. Select Run from the Start menu.
2. Type msconfig in the open field and click OK.
The System Configuration Utility dialog box appears.
3. Select the Startup tab and scroll down to the Digital Line Detect entry.

4. Deselect the checkbox to disable it.

Invoking Tool can be Slow on Linux With Network Problems

Invoking the synthesis tools might be slow when you are experiencing network problems on
Linux platforms, such as when a mounted drive is not accessible.

Solution: Delete the $HOME/ .config/Trolltech.conf file to avoid caching. This might help to
invoke the tool faster.

. Synopsys, Inc.
S\ n [] PS\ S 700 East Middlefield Road, Mountain View, CA 94043 USA
Phone: +1 650 5845000 or +1 800 5417737

Copyright © 2013 Synopsys, Inc. All rights reserved. Specifications subject to change without notice. Synopsys, Behavior Extracting Synthesis Technology, Certify, DesignWare, HDL
Analyst, Identify, SCOPE, “Simply Better Results”, SolvNet, Synplicity, the Synplicity logo, Synplify, Synplify Pro, Synthesis Constraints Optimization Environment, and VCS are regis-
tered trademarks of Synopsys, Inc. BEST, HAPS, HapsTrak, High-performance ASIC Prototyping System, IICE, MultiPoint, Physical Analyst, System Designer, and TotalRecall
are trademarks of Synopsys, Inc. All other names mentioned herein are trademarks or registered trademarks of their respective companies.
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