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Introduction

This tutorial shows you how use the Actel tools to develop a software application for a Cortex™:-
M1-based embedded processor system. After completing this tutorial you will be familiar with the
software design process which includes the following steps:

e Creating the SoftConsole project
e Configuring the SoftConsole complier/linker settings
e Compiling your code
e Creating and launching a debug session
¢ Debugging your code using SoftConsole
This design is suitable as a starting point for developing an embedded system.

Requirements for the Tutorial

This tutorial requires SoftConsole v2.2 (or newer) and FlashPro v8.6 (or newer) installed on your
computer. FlashPro is often installed as part of the Actel Libero® Integrated Design Environment
(IDE) installation and can be launched from within Libero IDE or standalone. You will also need the
following hardware:
* One of the following Actel development boards:
— Fusion Embedded Development Kit (M1AFS-EMBEDDED-KIT)
— Fusion Advanced Development Kit (M1AFS-ADV-DEV-KIT) along with power supply
* Programming hardware (low-cost programming stick or FlashPro3)
e 2 USB cables (programming and communication)
Programming of the application code to the target board requires a FlashPro3 programmer (or
low-cost programming stick). Development kits contain a low-cost programming stick (LCPS) or

FlashPro3 programmer. You will also need two USB cables; one for connecting the programmer to
your PC and the other to connect the UART interface on the board to your PC.

Tutorial Files

Before starting the tutorial, you need to download the tutorial files from the website for the board
you are targeting. Go to Actel's Design Hardware web page:

(http://www.actel.com/products/hardware/default.aspx)

Click the link for the board you are targeting. On the web page of the target board, click the zip
file under the ARM Cortex-M1 Embedded Processor Software Development Tutorial document.
Download and unzip the file to your hard drive. The files are placed in a folder called
CortexM1_Fusion_SW_Tutorial.

If you browse the contents of the zip file, you will see a subdirectory for every board this tutorial
supports. The directory structure is similar for each board. As an example, Figure 1 shows a picture
of the directory structure for the M1AFS-EMBEDDED-KIT board. The WORKSPACE is the software
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tutorial solution directory. If you change the workspace in SoftConsole to this location (File <
Switch Workspace), you can use this software database directly.

B

J File Edt Wiew Favorites Tools Help | " |

Folders

(2 Tutorial_Files
|2y USB_Drivers
= 1) WORKSPACE
I .metadata
|0 CortexM1_Tutorial

Figure 1  Directory Structure for M1AFS-EMBEDDED-KIT Board

The Completed_Design subdirectory contains the complete Cortex-M1 project for this tutorial
design for your reference. The Tutorial_Files subdirectory contains the source files you need to
complete this tutorial. Table 1 below has a description of these files.

Table 1 » Tutorial Files Descriptions

File Name Description

M1<FPGA>_TUT_TOP.STP FPGA programming file containing Cortex-M1 FPGA design
tutorial (hardware design)

tutorial.h Header file with memory map and interrupt assignments
targeted for Cortex-M1 FPGA design tutorial

main.c Top C source file

boot-from-actel-coreahbnvm.Id Linker script modified to work with Fusion-based tutorial
designs

The drivers subfolder contains the driver code for all the peripherals in the system. The USB Drivers
subdirectory contains the driver for the USB-to-UART chip on the target board. This driver allows
you to communicate with the target board over USB by treating the USB port as a COM port.
Therefore, you can use HyperTerminal to connect to a UART in the design running on the board.

Before debugging software for a Cortex-M1 system, you need the *.STP (program database) file,
which is used to program the FPGA with the hardware design. The *.STP file provided in this
tutorial is from the design created in the Cortex-M1 <FPGA Family> FPGA Design Tutorial.
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Set Up the USB-to-UART Driver

At the end of the tutorial, you program the Fusion FPGA and communicate with the target board.
To complete the tutorial, you need to make sure that the USB-to-UART drivers are installed on your
machine and that you know which COM port the USB port is associated with. Follow the steps
below before starting the tutorial to make sure your machine is properly configured and
connected to the target board.

1. Install the drivers for the USB to RS-232 Bridge by double clicking on the Prelnstaller.exe
executable located in the USB_Drivers subfolder. Accept the default installation folder and
press the Install button. Press the Continue Anyway button if prompted.

2. Connect USB cables and power cables according to Table 1-1.

Table 1-1 « Board Connections

Board Power and USB Connections

M1AFS-EMBEDDED-KIT | Make sure that you have J40 set to use USB power (not V5IN). Connect
a USB cable to J2, which provides power and the USB-to-UART
communication.

M1AFS-ADV-DEV-KIT Connect the 9 V power supply provided with the kit to J3 on the board.
Connect a USB cable to J2. This provides the USB-to-UART
communication and make sure SW7 is in the ON position to supply
power to the board.

3. If Windows prompts you to connect to Windows Update, select No, not at this time and
press Next. Next, select Install the software automatically (recommended) and press Next.
Once installation has completed, press Finish. Repeat the driver installation steps a second
time (if prompted). Press the Continue Anyway button if prompted.

4. Open the Windows® Device Manager by selecting Start > Control Panel > System >
Hardware > Device Manager. Expand the Ports (COM & LPT) section and take note of the
COM port assignment for the SFE USB to RS232 Controller.
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The example shown in Figure 1-1 is assigned to COMS.

£ Device Manager

File  Action Wiew Help

&g =
PL-CORT
t_; Batteries
'y Computer
g Disk drives
§ Display adapters
=% IDE ATAJATAPT controllers
‘s Kevboards
"_'_} Mice and other pointing devices
L Modems
§ Manitars
B8 Mebwork adapters
B PCMCIA adapters
o Ports (COM & LPT)
ny‘ Zommunications Port (COML)

0

[

] O O O O O s O O

5 SFE 1U5B to RS232 Controller (COMS)
S Toshiba BT Port (LOMI0)
o Toshiba BT Port (COM11)
o Toshiba BT Port (COM12)
ﬁ Tashiba BT Part (COMLE)

# Toshiba BT Port (COM14)

[ £

Figure 1-1 » Device Manager

If you do not see SFE USB to RS232 Controller in the Device Manager, you may need to
reboot your machine.
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Set Up HyperTerminal

1. Open the HyperTerminal application (Start > Programs > Accessories > Communications >
HyperTerminal). Enter CortexM1_Tutorial in the Name field in the Connection Description
dialog box and click OK.

2. Select the COM port you identified in "Set Up the USB-to-UART Driver" on page 1-7 and
click OK.

3. Enter the following values for the properties (Figure 1-2):
— Bits per second: 57600
- Data bits: 8
— Parity: None
— Stop bits: 1
- Flow control: None

COM3 Properties

Fort Settings |
Bitz per second: |5?EEIEI V|
Data bits: |8 v|
Barity: |N.:.ne v|
Stop bitz: | 1 » |

Elow controt | [N |

[ Bestore Defaults ]

k. H Cancel H Apply ]

Figure 1-2 « COM Port Properties

4. Click OK. HyperTerminal is now connected with the appropriate settings to communicate
with the UART on the target design.




_ VActel

| Before You Get Started

Install Firmware Catalog

Firmware Catalog is a tool that allows you to create firmware for software development. Typically,
you use the tool to select the firmware that you need and Firmware Catalog places the firmware
into your software development project (SoftConsole, IAR EWARM, or Keil). For this tutorial, you
will use Firmware Catalog to add the drivers and HAL code to your SoftConsole project.

Firmware Catalog is installed by default when Libero IDE is installed (v8.6 or newer). If you do not
want to install Libero IDE, you can download the Firmware Catalog installation only from Actel’s
Downloads web page:

www.actel.com/download/default.aspx

Regardless of which installation method you use, Firmware Catalog is a standalone tool with its
own executable.

10
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Setup Firmware Catalog to Run in SoftConsole

Use the following steps to link Firmware Catalog to SoftConsole.

1. Invoke SoftConsole and define the directory called Workspace for software project data

(Figure 1-3).

E Workspace Launcher

Select a workspace

Actel SoftConscle IDE stores your projects in a folder called a workspace,
Choose a workspace folder to use for this session,

Wiorkspace; |D:‘gProjects\EOOQHFADK_CortexM1_Tutorial\5W_ UTORIAL j Brouvse,,,

[ Use this as the default and do not ask again

84 Cancel

Figure 1-3 » Workspace Launcher

Note: Do not use folders that have spaces in the folder name.

1
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2. From the SoftConsole main GUI, select Run from the toolbar and select External Tools >
Open External Tools Dialog (Figure 1-4).

SC| Debug - Welcome to Actel SoftConsole IDE - Actel SoftConsole IDE

File Edit Mavigate Search Project Window  Help
Aol o 3 O e
S Resume Without Signal = =
3&* Debug &3 5% -<§" 90 Resume At Line (CfCH+) 8 || 64= variables &2 S Breakpoints | 31 Registers | =4 Modules 8
£ DB X %~
", Skip &l Breakpoints
Welcome £ cai_calibration = O 5% outire 2 =0
An outline is not available.
Actel SoftConsole TDE 1 OUHine s not avsiable
”~
SoftConsole is a free software deve —
enabling the rapid production of C & S5 Uise Step Filters Shift+F5
available for use in Actel devices, &~ °
lets wou write software that is imre %Run Chl+F11
%, Debug Fi1
(=) Start a Project Run Histary »
Ta begin your work, click File = Run A v
Give your project a name, and ¢
be compiling For a target other t 0 Open Run Dialog. ..
Then click Finish,
Debug Histary »
Add an initial source file with Fi Debug As »
A A b e il b Bl q&open Debug Dialog... F s
Bl consale 5 v Tasks | [21 prob @ G| ri-=0

C-Build [CortexM1_Tutarial]

. . . A Crganize FL
##%#% Build of configuration Debug for project CortexMil T

make all
make: Nothing to be done for ‘all'.

Figure 1-4 « Open External Tools Catalog
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3. The External Tools dialog will open. Right-click Program, and click New (Figure 1-5).

E External Tools

Create, manage, and run configurations

Fun a program

W = e o
U T Configure launch settings from this dialog:

|type filker text | j - Press the 'Mew' button ko create a configuration of the selected bvpe.

=| - Press the 'Duplicate’ button ta copy the selected configuration.

E! ¥ - Press the 'Delete’ button to remove the selected configuration,

=+, = ] - X " .
i - Press the 'Filker' butkon to configure filkering options.

- Edit or wiew an existing configuration by selecting it

Configure launch perspective settings From the Perspectives preference page,

Filker matched 1 of 1 items

@ Close

Figure 1-5 ¢ Create New Program

The External Tools “Create, manage, and run configurations” dialog will open.
In the Name field, enter Firmware Catalog.

2. Using the Browse File System button, browse to the catalog.exe file. If you have installed
Libero IDE, unless you are instructed otherwise, the catalog.exe file is placed in the path
c\Libero86\Libero_v8.6\Designer\bin\catalog.exe. If you downloaded and installed the
Firmware Catalog independently, the executable will be at the following location:
<drive>:\Firmware_Catalog\bin\catalog.exe.

13
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3. After entering the path, click Run to save the configuration (Figure 1-6). The Firmware
Catalog will also open.

E External Tools

Create, manage, and run configurations Q
—

Fun a program

& [ —+

Marme: | Firnware Catalog

|type filker bext

= @ Program

E| Tlain Q:)<h Refresh | g Environment | = Comman

Location;
| CiiLiberog6iLibero_vd,6\Designeribinicatalog.exe |
[Browse Warkspace. .. ] [Browse File Swstem. .. ] [ Wariables. .. ]
‘wiarking Directory :
|
Browse Workspace... ] [Browse File System... ] [ Wariables. .. ]
Arguments:

Mote: Enclose an argument containing spaces using double-guates ().

Apply Revert
Filker matched 2 of 2 items

@ Run Close

Figure 1-6 « Save Configuration

4. Once the Firmware Catalog has opened, it can be closed. This is necessary to save the
configuration in SoftConsole.

14
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Close the Firmware Catalog (Figure 1-7) by clicking the X on the window.

BX

& Firmware Catalog

File  Yiew Tools Help

i Wmwidi |3 Smarch by ol Fekels (217):

l ;.6 all ” :J Yaulk ][QJ Web repositories @ |
display anly the lakest version of & core

WE= ‘et sion
Coreshblvm Driver z.1.102
CareGPIO Driver 2.1.102
Carelnterrupt Driver 2.1.102
CoreTimer Driver Z.1.101
CaorellaR Tapb Driver z.1.102
CareWWatchdog Driver 2.1.101
Hardware Abstraction Laver (HAL) 2.0.101

Mo core selected

|£5] 5enerake

Figure 1-7 « Firmware Catalog
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5. To verify that the Firmware Catalog is linked to SoftConsole, click Run in SoftConsole again.
You should see Firmware Catalog at the top of the list of External Tools (Figure 1-8).

SC| Debug - Welcome to Actel SoftConsole IDE - Actel SoftConsole IDE

File Edit Mavigate Search Project
] [mil & G @ ¥ 0O
%5 Debug &2 %

=2 % <terminated >Firmware Catalog
Bl <terminated, exit valle: 03

Welcome  £2 cai_calibration,
Actel SoftConsole IDE

SoftConsole is a free software deve
enabling the rapid production of C 3
avallable for use in Actel devices, Cf
lets wou write software that is imre

=+ Start a Project
Ta begin your work, click File =
Give your project & name, and ¢
be compiling For a target other t
Then click Finish,

Add an initial source file with Fi
A i b e nd il b i

B console 52 V) Tasks | [21 prot

<terminated=> Firmware Catalog [Prograriy

Window  Help

", Skip &l Breakpoints

T Use Step Filters

%Run
%, Debug
Run Histary
Run s
0 Open Run Dialog. ..

Debug Histary
Debug As
Q&Open Debug Dialog...

shift+F5

Chrl+F11
F11

= O |69 variables 32

Run As
@ open External Tools Dislag...
Qrganize Favarites. .

S Breakpoints | 31 Registers | =4 Modules

= 0| 5% outire &3

An outline is not available.

>

[

% % | 5 R

e

ﬁl?}‘ﬁDebug @ crc++
=3

LB & =
=3

o @-r3- =0

Figure 1-8 » Verify Firmware Catalog is Linked to SoftConsole
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Open SoftConsole

When you open SoftConsole for the first time, it asks you to specify the location of the workspace.
You can select any location on your machine, keeping in mind that the workspace directory will
contain any SoftConsole projects that you create during this session.

By default, SoftConsole builds your projects every time a source file is saved. For this tutorial,
change this behavior by going to Window > Preferences and selecting General > Workspace. Clear
the check box for Build automatically and click OK.

Create and Build the Software Project

In this section you will create and build a SoftConsole project targeting a Cortex-M1 embedded
processor system. Since this tutorial focuses on the tool flow, the source code is provided.
Therefore, you will import the application source code, drivers, and hardware abstraction layer
(HAL) into the project.

1. Invoke SoftConsole and open the workspace for the software project data (same workspace
set up during step 1 of the "Setup Firmware Catalog to Run in SoftConsole" section on
page 1-11). If some other workspace location is opened by default because the default
location was selected, use File < Switch Workspace and navigate to the desired workspace.

2. Build Automatically is not enabled by default in SoftConsole v2.3. Use Project < Build
Automatically to enable or disable Build Automatically. Make sure a check mark appears
next to Build Automatically so that it is enabled.

17
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3. Choose File > New > Project. The New Project window appears (Figure 2-1).

VActel

B New Project

Select a wizard

Creake a new C project

Wizards;

|t':.f|:|e Filker ket

== General
ﬁ Praoject
== C
 Project
HE&
C++ Project
= s
%ﬁ} Projects From CYS
== swm
;jé} Checkout Projects From SYh

@

Einish

Cancel

Figure 2-1 « New Project Window
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4. Select C Project and click Next. The C Project window appears (Figure 2-2).

sc - [BEX

C Project

—-."\1(

Create C project of selected type

Project name: |

U= default location

| Browse. ..
Projeck bypes: Toolchain:
= Executable {(Managed Make) Actel CoreS051s Tools
(== Stakic Library Actel CoreMPT Tools
== Makefile project [Z= Actel Corkex-M1 Tools

Show project bypes and toolchains only iF they are supported on the platform

Figure 2-2 « C Project Window
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5. Type CortexM1_Tutorial in the Project name field, select Actel Cortex-M1 Tools, and click
Finish. The CortexM1_Tutorial project appears in the Navigator view on the left
(Figure 2-3).

E CIC++ - Welcome to Actel SoftConsole IDE - Actel SoftConsole IDE
Eile Edit Refactor Mavigate Search Run  Project  Window Help

™ & Eai -G R-B B0 Q & & T % oebug G croe+ |
= O B welcome 2 =0 EE Outlin &2 @ make | = O
= ‘& 7 Actel SoftConsole IDE An outling is not available.

SoftConsole is a free software development environment

enabling the rapid praduction of  and C++ executables for processars

available for use in Actel devices, Creating a project inside SoftConsole

lets you write software that is immediately compiled into a usable binary.

4! Start a Project

" To begin your work, click File > New > C Project
Give your project a name, and select a toolchain if you are going to
be compiling for & target other than the default choice of Actel Cortex-M1,
Then click Finish,

Add an initial source file with File > New > Source File

Add code ko it, and dick the Build All icon,

4

Existing Code

Wou can also import an existing source tree using
File = Import...

and click
General > File System

-+ additional Information
~ ¥ Release Notes
http://www.actel.com/download/software /softconsole
* Quick. Start Guide
http://www.actel.com/documents/SoftConsole_QS_UG.pdf
* Online documentation
http:/ /www.actel.com/products/software/softconsole#docs

[L Problems | & Consale 52 1 Properties ﬁ- Debug ga
Ma consoles ko display at this time.

i
L&
f
0
m]

P 0 CortexMi_Tutorial

Figure 2-3 » Navigator View

6. Right-click on the project name and choose Import. You see the Import window appear.
7. Select General > File System and click Next.

8. Click the Browse button.
9

Browse to the location of the tutorial source files:
<zip file location>/CortexM1_Fusion_SW_Tutorial/<KIT PART NUMBER>/Tutorial_Files.

10. Click OK.

20
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Note: You may see error messages, as shown in Figure 2-4. This is okay.

al/ 1T c e — LI %]
Fle Edit Refactor Mavigate Search Run Project  Window  Help
Icrlglg~agrdrG-r A8~ |[H~0~-Q~ |&® 5 |1 & =ilentele
J .@l - ﬁ, L e ] -
[t Project Explorer £3 = B[ wekcome  [¢) main.c £ = 0|8z outh 2 @ Mak | O
= % = lI/1-'**1:1-'***t***f***f***t**fff***f***t***f***f***t**ﬂ! lﬁz }k “S e -
2 S CortexM1_Tutorial 2 * (c) Copyright 2008 Actel Corporation = 2 hah -
---Eb Deblig 37 L | o ftorial.h —
[h] tutorial.h 4 * B coreaih
4 main.c 5 * SVN SRevision: 325 § % ..... A1 core_uart_apb.h
" boot-from-acteh-coreahbrivm.l f * SWN SDate: 2008-05-20 16:54:44 +0100 (Tus, 20 M core_gpioh
T gl # MAX_TEXT_BUFFE
@ Afinclude "hal.h’ = # CHAN_NAME_MAS
O#include "tutorial.h" =N .. # ADC_RESOLUTIO
(x] l#include "coreai h'™ ~ # BAMUD_VALUE_SH
@ 1lg#include "core uart apb.h" =1 | # GPOUT_INIT_STA
@ 1Z2#include "core io.h" - # ¢ channel_name_lu
----- @ © line_returm | cons'
14 E @ ° sep : const UintS_
LG R o o o ok ook ok o S SR o R R R Rk S| 1 key_pressedvoid =
4 | il
{Z{ Problems &2 éTasksW =) DDnsoIe} = Propertie:ﬂ ¥ =0
47 errors, 8 warnings, 0 infos
Description = | Resource | Fath | Locati... |
& Errors (47 items)
& Warnings (8 items)
< | »f
[ Writable SmartInsert | 1:1 |

Figure 2-4 « Import Error Messages

11. Check the boxes next to main.c, tutorial.h, and boot-from-actel-coreahbnvm.Id.
12. Make sure that the Create selected folders only option is selected.

13. Click Finish. If you expand the project in the Navigator, you see the new files that have been
imported into the project.

14. Go to Run > External Tools > Firmware Catalog.
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The Firmware Catalog tool will launch and you should see a list of firmware cores in italics,
indicating that these cores have not been downloaded to the local vault on your machine
(Figure 2-5).

"7 Firmware Catalog

File Wiew Tools Help

Miew (11(25): Search by all figlds (11/11):
[ P ][ o Yault ”U ‘Web repositories a |

display only the latest version of a core

Mame Version Size (ME) Skatus

_;3 Mew cores are available for download  |Download themn now!

Mo core selected

€3 Download | | (2] Generate

Figure 2-5 « Firmware Catalog

15. Click the Download them now! button to download all of the firmware cores.

The Firmware Catalog will proceed to download each core to your local vault. The Vault
location is common to all Actel software (Libero IDE Project Manager, Firmware Catalog,
etc.). Changing your Vault location here updates the Vault location for all Actel tools you
use on this machine. For more information, refer to the “Vault/Repositories Settings Dialog
Box" entry in the Firmware Catalog help.

16. Highlight the following firmware cores by using CTRL + right-click (Figure 2-6):
— CoreAl Driver
— CoreAhbNvm Driver
— CoreGPIO Driver
— CoreUARTapb Driver
— Hardware Abstraction Layer (HAL)

22
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Firmware Catalog

File Wiew Tools Help

Wiew (11/25):
% all ][ ' vaulk HUJ' ‘Web repositories

display only the latest version of a core

Search by all figlds (11/11):

Q-

Mame ‘ersion Size (ME)

Core10100AHEaph Driver 1.0.1

Corel2C driver
Corelnterrupt Driver
CareP'W Driver

Status

Description: Eare metal driver for CoreUAR Taph DirectCore.

Documentation:
CorellARTapb Driver RM.pdf
CorellARTapb Driver UG, pdf
free software license, pdf

Compatible IP cores:
Actel DirectCore CorelJARTapb: from version 1.0

€3 Download

Figure

17.
18.
19.

20.
21.

22.
23.

2-6 * Firmware Catalog Firmware Cores

Click the Generate button. The Generate Options window appears.
Click the Browse button (with the ...) to the right of the Project folder text box.

Browse to your SoftConsole project directory (/<..>/WORKSPACE/CortexM1_Tutorial>). This
tells Firmware Catalog to copy the firmware cores to this SoftConsole project.

Click OK two times.

The Configuring CoreAl_Driver configuration window appears, which looks very similar to
the CoreAl configuration window in SmartDesign (for configuring the hardware IP core).
This driver must be modified based on the configuration of the IP core. Therefore, the same
parameters must be entered in this window as were entered in the CoreAl configuration
window in SmartDesign. This ensures that the driver configuration will match the hardware
configuration. For this design, follow the steps below to achieve this.

Select Target device as AFS1500.
Select Calibration method as None.

23
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24. Configure the quads as listed below while leaving the rest Disabled.
— AVO0input: 0 to 4 Volts
— ACO input: Current monitor
— AV1input: 0 to 2 Volts
— AC1 input: Current monitor
— AT2 input: Temperature monitor
— AC4 input: 0 to 4 Volts

25. Click OK to generate the firmware cores and place them into your SoftConsole project. You
will see a generation report showing you what was done.

26. The Configuring HAL dialog box opens. Confirm that the processor is Cortex-M1 and the
Software tool chain is SoftConsole; then click OK.

27. Clicking Close closes the report. To close the Firmware catalog, click the X in the upper right
corner.

Firmware Catalog has created subfolders in your SoftConsole project containing the four
drivers and the Cortex-M1 HAL.

28. Right-click on your project in SoftConsole and choose Refresh. You should see the new
folders and files created by Firmware Catalog. Specifically, you have a new hal folder (with
subfolders) and a new drivers folder with a subfolder for each driver (four total).

29. Right-click your project and choose Properties.

30. Expand C/C++ Build on the left and select Settings. You see a window similar to the one in
Figure 2-7.

E Properties for, Cortexi1_Tutorial

type Filker text Settings “
Resaurce
Builders

[=- £/C++ Build Configuration: | Debug * | | Manage configurations

Discovery options

i Tool settings A Build steps Build artifact Binary parsers | €3 Error parsers
Wariahles =583 GNU © Compiler Command: | arm-none-eabi-goe -mthumb -mcpu=cortex-m1
CJC++ General oy .
Praject References [ Preprocessar All options: | o0 -g3 -wall -c fmessage-length=0

@ Symhbiols
@ Directaries
@ Cptimization
@ Debugging
@ \Warnings

Refactoring Histary
RunfDebug Settings

@ Miscellaneous Expert settings:
=583 GNU © Linker Command
|
& Ganera e pattorr: | HCOMMAND} ${FLAGS} ${OLTPUT_FLAGH{OUTFUT_PREFIHH{OLITP

@ Libraries
o
(22 Miscellaneous

(=B GNU Assembler
# General

Q\D Mernary map gensrator

(= E% GNU Binary Generator
@ General

(=~ E83 GNU Intel Hex File Generator
@ General

=53 GNU 5-Record Genetator
3 Ganeral

(=83 GNU Listing Generatar
@ General

[ Restare Defaults ] [ Apply ]

Figure 2-7 » Tutorial Properties
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Notice the Configuration is set to Debug and the compiler options include the least optimization (-
00) and highest debug level (-g3). There is also a Release configuration which has the highest
optimization (-O3) and least debugging (none). For this tutorial, you will debug the system, so you
will only modify the Debug configuration.

31. Click GNU C Compiler > Directories.
32. Click the Add button .
33. Click the Workspace button.

34. Expand the CortexM1_Tutorial project, select the /CortexM1_Tutoriallhal subdirectory, and
click OK in the Folder Selection dialog box. Also click OK in the Add Directory Path dialog
box.

35. Repeat the last three steps again for the following directories:
— CortexM1_Tutoriallhal/CortexM1
— CortexM1_Tutorial/hal/CortexM1/GNU
— CortexM1_Tutorialldrivers/CoreAhbNvm
— CortexM1_Tutorial/drivers/CoreAl
— CortexM1_Tutorial/drivers/CoreGPIO
— CortexM1_Tutorialldrivers/CoreUARTApb
36. Click GNU C Linker > Miscellaneous.
37. Enter -T ../boot-from-actel-coreahbnvm.Id in the Linker flags box, as shown in Figure 2-8.

E Properties for Cortexi1_Tutorial

type Filker text Settings e
Resource
Builders
=) C{C++ Build Configuration: |Debug * | | Manage configurations
Discovery options
Environment
Settlngs. ) % Tool settings A Build steps Build artifact Binary parsers | € Error parsars
Tool chain editar
Variables =83 GMU © Compiler Linker flags | -T ../boot-fram-actel-coreahbryvm.|d
CiC++ General 0
. 2% Preprocessor
Praject References (B Symbols Cther options {-¥inker [option]) £

Refactaring Histary

i)
Run/Debug Settings [ Directories

@ Optimization
@ Debugging
@ ‘Warnings
22 Miscellaneous
=B85 @MU € Linker
@ General
[ Libraties Other objects &
3 Miscellanenus
=83 GNU Assembler
@ General
@ Mermnory map generakor
=583 GMU Binary Generator
@ General
=83 G Intel Hex File Generakaor
@ General
=583 G 5-Record Generator
@ General
=83 @MU Listing Generakor
2 General

[ Restore Defaults ] [ Apply ]

Figure 2-8 » Linker Flags

Example linker scripts are provided in the SoftConsole installation in the <SoftConsole
install>/src/Cortex-M1/linker-script-examples directory. This linker script was copied from this
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directory and modified for the target system. The system boots from on-chip NVM, copies
the application code and data to external SRAM, and then runs the application code from
external SRAM. For information about how to modify the linker script for your target
system, refer to the “Start of board customization section” in the linker scripts.

38. Click GNU C Compiler.
39. Add -mlong-calls at the end of the Command box, as shown in Figure 2-9.

E Properties for CortexmM1_Tutorial

bype Filker bext
Resource
Builders

= CfC++ Build

Settings

Yariables

Discovery options
Enviranment

Tool chain editor

CfC++ General
Project References
Refactoring Histary
RunjDebug Settings

Settings

Configuration: | Debug

* | | Manage configurations

B Tool settings

Build steps Build artifact Binary parsers | €3 Error parsers

=55 e

Command: | arm-none-eabi-gee -mkhumb -mcpu=cortex-m1 -mlong-calls
Preprocessor
Symbols

@ Directories
@ Optimization
@ Debugging
@ Warnings

—
Alloptions: | 1"Di\ActelpriCortexM1_TutoriallCortexM1_Tutaorial|hal”

I'Di\ActelpriiCortexM1 _TutorialiCortexM1_TutorialihalCortexml”

-I"Dn\ActelpriyCortexM1_TutarialCortexM1 _TutoriallhalyCarkexMiiGnU"

%
-I"DiActelpritCortexM1 _TutorialCortex1_TutorialldriversiCoreahbMyvm"
-I"DiActelpritCortexM1 _TutoriahCortex1_TutorialldriversiCoreal”

=
=

(2 Miscellaneous
(=B85 GMU C Linker

Expert setkings:
Command

i pttarr; | SCOMMAND} ${FLAGS} ${OUTPUT_FLAGHHOUTPUT_PREFIXHHOUTFUT} ${INPUTS}

22 General
2 Libraries
22 Miscellaneous
=58y GMU Assembler
2 General
@ Mernory map generator
(=B85 GMU Binary Generator
@ General
(=B85 GMU Intel Hex Fils Generator
@ General
=B85 GMU 5-Record Generator
@ General
(=B85 GMU Listing Generator
@ General

[ Restore Defaulks ] [ Apply ]

[ Ok H Cancel ]

Figure 2-9

GNU C Compiler

Note: This flag is only necessary when booting from NVM and running from SRAM (for example,
using boot-from-actel-coreahbnvm.ld). It is necessary to support the call to main() from _start
since _start is in NVM, whose base address is 0x00000000, and main() is being executed from
SRAM, whose base address is 0x18000000. For more information, refer to the GNU GCC
documentation (Start > Programs > Actel SoftConsole > Reference Documentation > GNU
GCC Compiler Manual or <SoftConsole install>\Sourcery-G++\share\doc\arm-arm-none-eabi
\odf\gcc\gce.pdf).

Click OK to save the project settings.

. If Build Automatically is not selected, build the project by right-clicking on the project and
choosing Build Project. You should not see any error in the build. The project is built with
the Debug configuration settings and the corresponding files are created and placed in the
Debug subfolder. You are now ready to debug your application.

40.
41
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Program the FPGA

Now you will use the standalone FlashPro software tool to program the hardware design into the
target FPGA device. If you are familiar with launching FlashPro from within Libero IDE, as described
in the ARM Cortex-M1 Embedded Processor Hardware Development Tutorial, you can modify the

steps below as necessary.
Note: Make sure the connections listed in the "Before You Get Started" section on page 1-7 have
been made.
Launch the FlashPro software from the Windows Start menu.
. Create a new FlashPro project by going to File > New Project.
3. Enter any project name and location you wish. Make sure there are no spaces in the folder
names. Also, confirm that Single device is selected in the Programming mode field.
. Click the Configure Device button.
5. Click the Browse button and select the <FPGA>_TUT_TOP.STP programming file. You will see
the programming file information appear.

27


http://www.actel.com/documents/CortexM1_Proc_HW_Tutorial_UG.pdf

VActel

Tutorial — Programming and Debug

6. Click the View Programmers button and verify that a programmer has been identified in the
Programmer Name list, as shown in Figure 3-1.

=lalx|

Fle Edit WView Tools Programmers Configuration Customize Help

DSR2 [weazEEvs e voee 9o

Mew Pru]ed; ﬁﬁ Configure Device

—.> —|> PROGRAM ="

Open Project s View Programrmers %
=
" Programmer Programmer Port Programmer Programmer

Name Tvoe Status Enabled
151742 FlashPra3 ush51742 (USB -

i
|
g
=
% Refresh/Rescan for Programmers
g
&
=z FlashPro
I Version: 8.6.1.3
Releasze: vB.6 SPA
Software Version: §.6.1.3
Driver : 2.0.4 kuild 5
programmer "51742' : FlashPro3
Created new project 'D:\Projects\Z009\FADE CortexMl Tutcrial%AP_SW\CHE\HW_Prog\HW_Prog.pro’
STAPL file "D:%\Projects\Z009\FADK_CortexMl Tutorial\AP_SW.CortexMl Fusion_&W_Tutorial\MIAFS_ADV_EKIT\Tutorial_Files
DESTGN : MI1AFS_TUT_TOP; CHECESUM : A4C6H; ALG_VERSTON : 19
| | i
A | F |\ AN A Errors g Warnings # Info
Ready \D:\PrOJecTB\ZOOQ\FADK_CortexM 1_TutoriahAP_SWiCortexM1_Fusion_SW_Tutorialyv 1AFS_ADY_KITYTutorial_Fles\M1AFS_TUT_TOP.stp |SINGLE v

Figure 3-1 » FlashPro Programmer List

If no programmer name is shown, click the Refresh/Rescan for Programmers button. If no
programmer is found, make sure that a USB cable is connected between your PC and the
FlashPro3 programming stick and that you have the FlashPro3 programmer drivers installed.

7. Click the PROGRAM button to download the FPGA design. The FlashPro Programmer will
program the FPGA array.

8. After successful programming a Run Passed message is displayed under Programmer Status.
Press the reset switch (SW1) on the board.

9. Close the FlashPro software. Answer Yes if prompted to save files. Next time you want to
program the FPGA with this design you can open this project.
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Create the Cortex-M1 Debug Configuration
For each Cortex-M1 software application that you want to debug, you need to create a Cortex-M1
Debug configuration.
1. Right-click the CortexM1_Tutorial project and select Debug As > Open Debug Dialog.
2. Right-click Actel Cortex-M1 Target and choose New.
3. Click Apply. You should see a window like the one in Figure 3-2.

SC] Debug @
Create, manage, and run configurations ﬁ
e

| Mame: |C0rtexM1_Tut0riaI Debug |

|type filker tet |

E} Main % Debugaer | Bl Commands | B Source | £ Commen
- 8C Actel Core8051s Target ' o '

-8 Actel CoreMPT Target
[=1-SC actel Cortex-M1 Target
1e) Cortextq1_Tutorial Debug l CartexM1_Tutarial | [ Bromse. .. ]
; g C/C++ Attach ko Local Application C}C++ Application:
C | CfC++ Local Application - -
E -+ Postmartem debuager |Debug'l,C0rte><M1_Tutor|al | [Sear-:IJPm]ect...] [ Browse. .. ]

*-[£] &DE Hardware Debugging

Project {optional):

[ Application console

3 | @

Filker matched & of & items

@ Debug l [ Clase

Figure 3-2 » Create New Debug Configuration

A debug configuration called CortexM1_Tutorial Debug is created, which is targeted for the Debug
build configuration of your CortexM1_Tutorial project.
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Launch Debug Session

SoftConsole uses the GNU GDB debugger, in conjunction with the Cortex-M1 Sprite, to support
loading and debugging of programs for the Cortex-M1 processor. The executable file is loaded into
program memory before debugging can take place. Before launching the debug, make sure the
HyperTerminal setup is active and connected to the board (refer to the "Set Up HyperTerminal"
section on page 1-9).

1. Click the Debug button in the Debug configurations window. Or, right-click the

CortexM1_Tutorial project, select Debug As > Open Debug Dialog...and click the Debug
button.
The program code and data are downloaded to the target and the debug session starts.
When the Fusion NVM is being programmed, you might receive messages in red, similar to
those shown in Figure 3-3. This indicates the data is being read from the NVM and
compared. It is not an error message.

[ Do) - Cortex™1_Tutorial/ceivers /CoreAl /coreals - Actel SoRConsole 1DE ==l x|
e e | BrO Qe |0 e e = -
 Debug S5 5 = O v vauties & % Brespon Z =5
5 $0 CorteaM1_Tutcrid Dsbug [Actsl Corte-M1 Target]

ol CipckiActSentonsol v2. NBoureary-5+ + brlam-nons-sai-gd e (/269 10:27 AM)
Vidcome | 1c core ustapbe (LR = =% E s
uintlf fatus. Progress Information = it | o Dz =

i) Launching CortexM1_Tuterid Debug

adc_status = HAL get_lébit_reg{ g_cai_sddress, ADC_STRTUS }:

it { (adc_status & SAMPLE MASK) == 0 }

Wint16_t valid_data - ade statua & DATAVALTD MASK: Come ] o | ~
it { valid_data }
o valid v ult available. , " _'[_I
2 Conscle 5 ) Taoks| £ Froblems| | e =)
CorteML orteeh] Target] ook V2. T\EUTCHry-G e + i rm-none-sabi-gob, e (L0/26,/09 10:27 AM)
Loading section .re ] =]
Loading section .te
ding section .da
4] |
0 Wb Smartiest | 66919
x o -
) start| @yPany_Fov mpeln:nm;g Cortex... = MGV 1027

Figure 3-3 « NVM Programming Message
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You will receive the following window (Figure 3-4).

&= Confirm Pers pective Switch E|

0 This kind of launch is configured to open the Debug perspective when it
\_ﬁ/ suspends,

This Debug perspective is designed ko suppart application debugaging, 1t
incorporates wiews for displaving the debug stack, wariables and breakpaint
management.,

Do wol wank ko open this perspeckive now?

[ Iremember my decision

;es | [ Mo

Figure 3-4 « Confirm Perspective Switch

2. Click Yes to switch from the C/C++ perspective to the Debug perspective. SoftConsole
switches to the Debug perspective and you should see something similar to Figure 3-5.

E Debug - CortexM1_Tutorial/main.c - Actel SoftConsole IDE
File Edit Refactor Mavigate Search Run  Project  ‘Window Help
i W0 Q- ARG B | % Debug | T oo+
%5 Debug 51 [ 3 i T O |ed= varishles 2 g Breakpoints | 408 Registers Bk Modules =0
= S€ CorkexM1_Tutorial Debug [Actel Cortex-M1 Target] =5 3 i hoe

- @
= Embedded GDE (6f15/09 7:15 PM) (Suspended)

=g Thread [0] {Suspended)
= 1 main() D:\ActelpriiCartexM1_Software_Design_Tutorial_Files_v1_1\M1AFS_EME
B CiiProgram Files)ActelSoftConsale v2 .3\ Sourcery-G+-+binlarm-none-sabi-gdb. exe {615

Narne Walue
()= gpio_out -9z
E adc_samples 018003530
< b4

< ¥

2] welcame [£] main.c &2 =0

179 UNUSED_CHANNEL, /% ADC_CHAN LCS #/ ~
180 UNUSED CHANNEL, /7 ADC_CHAN LTS +/
181
182 UNUSED_CHANNEL, /% ADC_CHAN_INT_TENF +/
183 HH
154
» 135 uints t gpio_out = GPOUT_INIT STATE;
1G4
187 GPIO_init| &y_gpio, COREGPIO_BASE ADDR, GFOUT_INIT STATE );
158 CAI init( COREALI_EASE_ADDE ):
189 TUART init({ &y the uart, COREUARTAFE BASE ADDR, BAUD VALUE 57600, (DATA & BITS | WO PARITY) ): ¥

El consale &2 ) Tasks [;_‘Problams EE Outline Disassembly 0 Memoary EY E:,E = |d,z_||@|| = B-r5-=0
E?_r.tfxﬂl,r:[t'tUiiélpfb@,[_'qitgl_c.wt?fﬁgIéﬂgaq.c.:_,l"PrE'E@TfﬂES\'L'qf.tFli'écft_,c,u'js_,'j.l?_,v_?;SES_U_L'E.EEQ"thtll'éiExarm'nU”E'eabi'gdb‘EXE (6/15/09 7:15 PM)
arm-none-ssbhi-sprite: Progream Ox0 sector [Ox4200,+0xE80) erase write

arm-none-eabi-sprice: End of programming

Start address 0x60, load size 16940

Transfer rate: 1 KEB/sec, 63 hytes/write.

monitor debug-reset

thb main

Hardware assisted breskpoint 1 at 0x18000066: file ../main.c, line 185.

cont

main [} at ../ main.c:185

185 uint&_t gpio_out = GPOUT_INIT STATE;

£ b4
fars

Figure 3-5 « Debug Perspective
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The Debug View in the upper left shows the debug communication client running as well as
the call stack in your application.

Note that the processor is currently suspended and the resume button "™ and step buttons
. %% are enabled. A breakpoint is always set at the first executable line of code in main().
You see this line of code highlighted in main.c.

In the upper right there are views which show you various processor views, including the
current variables, breakpoints, processor registers and modules. You can watch these values
change as you step through the code.

Some views may not be displayed by default. You can go to Window > Show View to add
them. If you add the Memory view, you will see a Memory tab at the bottom. Here you can
view the values stored in memory, watch the values change, and modify the memory in the
target. You can add a memory monitor by clicking the green plus sign, typing in the address,
and clicking OK. You can add as many memory monitors as needed.

Continue Debug Session for Fusion-Based Kits

The application code initializes the UART peripheral and the analog quads and ADC of the analog
block of the Fusion FPGA. Then a message is sent to the UART, prompting the user to hit any key.
Once the user hits a key, the Cortex-M1 processor reads and displays the following information
from the analog sources on the board (analog channel in parentheses):

e 3.3 Vsupply voltage (AVO0)

e 3.3V supply current (AV0 and ACO)
¢ 1.5V supply voltage (AV1)

e 1.5V supply current (AV1 and AC1)
¢ Ambient temperature (AT2)

¢ \/oltage of potentiometer RV1 (AC4)

The code then returns to the loop, waiting for a key to be pressed. Follow the steps below to run
and debug the application.

1. Start your application by clicking the Resume button ™ . The LEDs on the board should start
counting to indicate that the application is running.

32



VActel

Continue Debug Session for Fusion-Based Kits

2. Go to your HyperTerminal window. You should see the message shown in Figure 3-6 in the
HyperTerminal window.

“& M1AES_Tutorial - HyperTerminal

File Edit Yiew Call Transfer Help

D= S B

Press any key to display current analog inputs values.

Connecked 0:00:28 Auto detect 57600 8-N-1

Figure 3-6 * HyperTerminal Window Message
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3. Press any key. You should see something similar to Figure 3-7 the in the HyperTerminal
window.

“& M1AFS_Tutorial - HyperTerminal

File Edit Wiew Call Transfer Help
Press any key to display current analog inputs values.
Ava : 3310 mY i ACO : 286 mA
Ayl : 1430 mY i AC1 : 937 mA
AT2 : 32 C i AC4 : 2 mA
Connected 0:01:32 Auto detect 57600 8-N-1

Figure 3-7 » HyperTerminal Analog Inputs Values

4. Change the potentiometer (RV1) on the target board.

5. Go back to HyperTerminal and press any key. You should see AC4 change value, based on
the potentiometer (RV1). The full range is about 0 V to 3.3 V.

6. Click the Pause button Ul to stop the processor from executing code. Notice that the call
stack is updated and the next line of C code is highlighted.
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7. Set a breakpoint at the line of code highlighted in Figure 3-8 by double-clicking in the left
margin next to the line of code. This line of code is near line 180.

CAI_init({ COREAI_BASE_ADDR );
UART init( &g _the uart, COREUARTAPE BASE ADDR, BAUD VALUE_ 57600, (DATA 5 BITS | NO_PARITY) ):

display start({):
while| 1
{
P10 set _ocutput (| &g gpio, ++gpio_our];

delay (OxFFFF) ;

CAI round robin{ adc_samples );

if [ key pressed() |
i

process_samples | adc_samples !

Figure 3-8 » Set Breakpoint

You will see a dot appear in the margin indicating that a breakpoint is set on that line of
code.

8. Click the Resume button ™ to continue executing code. The debugger should stop at the
line of code where you set a breakpoint.

9. Go to Window > Show View > Registers. If you do not see Registers as an option, then this
view is already open (that is, you do not need to do anything for this step).

10. Expand the registers in the upper right window so you can see the values.

11. Click the Step Over button = and watch the values of the registers change. Any registers
that changed value should be highlighted.

Congratulations! You have successfully created a Cortex-M1 software project and debugged it,
running on an Actel FPGA development kit. For more information on features in SoftConsole, refer
to the "Appendix" on page A-37. The "Appendix" also includes instructions for updating the FPGA
programming file (STP file) with new program code and data contents for the NVM block inside
Fusion devices.
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Debugging Features in SoftConsole

* You can set a breakpoint using any of the following methods:
— Place the cursor on the line of code and select Run > Toggle Breakpoint.
— Place the cursor on the line of code, right-click, and choose Toggle Breakpoint.
— Double-click the left margin next to the line of code.
¢ The upper right window has various tabs, including breakpoints, registers, and variables.

Elements are highlighted if they have changed value since the last time the processor was
stopped.

* You can single step through the source code by choosing Run > Step Into or Run > Step Over
or clicking their corresponding icons, t_and = respectively.

e The Step Return button _[© steps to the next instruction of the calling function. You can also
use the menu by going to Run > Step Return.

e To view disassembly, choose Window > Show View > Disassembly. You can then click the
Instruction Stepping Mode button j=: to step by processor instruction.

Updating Contents of NVM in PDB file

In the tutorial we used an STP file for programming the hardware. If you want to update the
hardware with the new application code inside the NVM block, you can update the content of
NVM file in the PDB file, and program only the NVM.

The build process used for debug can also be used to build the release configuration. The *.hex file
generated in the release configuration is used to build NVM client content (refer to "Step 3 -
Create Flash Memory System" in the ARM Cortex-M1 Embedded Processor Hardware Tutorial),
which generates the *.efc file needed by the programmer.

1. Open the FlashPro tool.
2. Click the Configure Device button.

3. Click the Browse button and select the <FPGA>_TUT_TOP.PDB programming file. You will
see the programming file information appear.

4. Click the PDB Configuration button. The Flashpoint — Programming File Generator window
opens. You use this window to modify the contents of the embedded flash memory (NVM)
in the FPGA programming file.

5. Click the Modify button. The Modify Embedded Flash Memory Block window opens.
FlashPro will read the programming file and obtain the path for the (embedded flash
memory configuration) file (*.efc) and Intel hex file (*.hex) for the NVM block. If either file
has been modified since it was last imported, you will see a yellow triangle near the file.

6. Click the Import Configuration File button.

7. Browse to the location of your EFC file, which describes the configuration of the NVM block
in your design. Libero IDE places it in the <Libero project folder>/smartgen/<name of NVM
block> directory.

8. Click Import.

9. Click the Import content button and browse to the location of your *.hex file, which
contains the program code and/or data. SoftConsole automatically creates a *.hex file
containing the program code and data, and places it in the <SoftConsole project>/<Debug
or Release> folder.

10. Click Import.

11. Click OK, and then click Finish.
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B - List of Document Changes

The following table lists critical changes that were made in the current version of the document.

Previous
Version Changes in Current Version (50200162-1) Page
50200162-0 [The "Requirements for the Tutorial" section was revised. FlashPro v8.6 or newer is 5
(March 2009) |required. The M1AFS-ADV-DEV-KIT development board with power supply is now
supported for this tutorial.
The "Tutorial Files" section was revised. The folder name for the tutorial files changed.| 6
The names of the programming file and header file changed. Figure 1 e Directory
Structure for M1AFS-EMBEDDED-KIT Board was replaced.
Table 1-1 ¢ Board Connections was revised to add the M1AFS-ADV-DEV-KIT board. 7
Instructions for installing Firmware Catalog were added to the "Before You Get| 7
Started" section.
The "Tutorial — Create and Build Software Project" section was revised to include use of| 17
Firmware Catalog.
The "Tutorial — Programming and Debug" section was revised to conform with other| 27
changes in the tutorial made for the incorporation of Firmware Catalog.
Figure 3-5 ¢ Debug Perspective was replaced. 31
Figure 3-8 e Set Breakpoint was replaced. 35
The "Appendix" was revised to add some additional steps to the "Updating Contents of | 37
NVM in PDB file" section.
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A - Product Support

Actel backs its products with various support services including Customer Service, a Customer
Technical Support Center, a web site, an FTP site, electronic mail, and worldwide sales offices. This
appendix contains information about contacting Actel and using these support services.

Customer Service

Contact Customer Service for non-technical product support, such as product pricing, product
upgrades, update information, order status, and authorization.

From Northeast and North Central U.S.A., call 650.318.4480
From Southeast and Southwest U.S.A., call 650. 318.4480
From South Central U.S.A., call 650.318.4434

From Northwest U.S.A., call 650.318.4434

From Canada, call 650.318.4480

From Europe, call 650.318.4252 or +44 (0) 1276 401 500
From Japan, call 650.318.4743

From the rest of the world, call 650.318.4743

Fax, from anywhere in the world 650.318.8044

Actel Customer Technical Support Center

Actel staffs its Customer Technical Support Center with highly skilled engineers who can help
answer your hardware, software, and design questions. The Customer Technical Support Center
spends a great deal of time creating application notes and answers to FAQs. So, before you contact
us, please visit our online resources. It is very likely we have already answered your questions.

Actel Technical Support

Visit the Actel Customer Support website (www.actel.com/support/search/default.aspx) for more
information and support. Many answers available on the searchable web resource include
diagrams, illustrations, and links to other resources on the Actel web site.

Website

You can browse a variety of technical and non-technical information on Actel’'s home page, at
www.actel.com.

Contacting the Customer Technical Support Center

Highly skilled engineers staff the Technical Support Center from 7:00 a.m. to 6:00 p.m., Pacific Time,
Monday through Friday. Several ways of contacting the Center follow:

Email

You can communicate your technical questions to our email address and receive answers back by
email, fax, or phone. Also, if you have design problems, you can email your design files to receive
assistance. We constantly monitor the email account throughout the day. When sending your
request to us, please be sure to include your full name, company name, and your contact
information for efficient processing of your request.
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| Product Support

The technical support email address is tech@actel.com.

Phone

Our Technical Support Center answers all calls. The center retrieves information, such as your name,
company name, phone number and your question, and then issues a case number. The Center then
forwards the information to a queue where the first available application engineer receives the
data and returns your call. The phone hours are from 7:00 a.m. to 6:00 p.m., Pacific Time, Monday
through Friday. The Technical Support numbers are:

650.318.4460
800.262.1060
Customers needing assistance outside the US time zones can either contact technical support via

email (tech@actel.com) or contact a local sales office. Sales office listings can be found at
www.actel.com/company/contact/default.aspx.
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