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About SmartTime

SmartTime is the Libero SoC gate-level static timing analysis tool. With SmartTime, you can perform complete
timing analysis of your design to ensure that you meet all timing constraints and that your design operates at the
desired speed with the right amount of margin across all operating conditions.

Note: Creation and Editing of timing constraints are now handled in a separate Timing Constraints Editor.
See the Timing Constraints Editor User Guide for help with creating and editing timing constraints.

Static Timing Analysis (STA)

Static timing analysis (STA) offers an efficient technique for identifying timing violations in your design and
ensuring that it meets all your timing requirements. You can communicate timing requirements and timing
exceptions to the system by setting timing constraints. A static timing analysis tool will then check and report
setup and hold violations as well as violations on specific path requirements.

STA is particularly well suited for traditional synchronous designs. The main advantage of STA is that unlike
dynamic simulation, it does not require input vectors. It covers all possible paths in the design and does all the
above with relatively low run-time requirements.

The major disadvantage of STA is that the STA tools do not automatically detect false paths in their algorithms as
it reports all possible paths, including false paths, in the design. False paths are timing paths in the design that do
not propagate a signal. To get a true and useful timing analysis, you need to identify those false paths, if any, as
false path constraints to the STA tool and exclude them from timing considerations.

The SmartTime user interface provides efficient, user-friendly ways to define these critical false paths.

Timing Constraints
SmartTime supports a range of timing constraints to provide useful analysis and efficient timing-driven layout.

Timing Analysis
SmartTime provides a selection of analysis types that enable you to:
e Find the minimum clock period/highest frequency that does not result in a timing violations
¢ Identify paths with timing violations
e Analyze delays of paths that have no timing constraints
e Perform inter-clock domain timing verification
e Perform maximum and minimum delay analysis for setup and hold checks

To improve the accuracy of the results, SmartTime evaluates clock skew during timing analysis by individually
computing clock insertion delays for each register.

SmartTime checks the timing requirements for violations while evaluating timing exceptions (such as multicycle or
false paths).

SmartTime and Place and Route

Because Libero SoC Place and Route uses SmartTime STA during timing-driven place-and-route in the
background; your analysis and place and route constraints are always consistent.

SmartTime and Timing Reports
From SmartTime > Tools > Reports, the following report files can be generated:
e Timing Report (for both Max and Min Delay Analysis)
e Timing Violations Report (for both Max and Min Delay Analysis)
e Bottleneck Report
e Constraints Coverage Report
e Combinational Loop Report



https://coredocs.s3.amazonaws.com/Libero/12_3_0/Tool/smarttime_ce_ug.pdf

& Microsemi

a AS\MicRocHIP company

Generic User Guide

SmartTime and Cross-Probing into Chip Planner

From SmartTime, you can select a design object and cross-probe the same design object in Chip Planner. Design
objects that can be cross-probed from SmartTime to Chip Planner include:

e Ports
e Macros
e Timing Paths

SmartTime and Cross-Probing into Constraints Editor

From SmartTime, you can cross-probe into the Constraints Editor. Select a Timing Path in SmartTime’s Analysis
View and add a Timing Exception Constraint (False Path, Multicycle Path, Max Delay, Min Delay) . The Constraint
Editor reflects the newly added timing exception constraint.

The Constraints Editor must be running for Cross-Probing to work.

See Also
Starting and Closing SmartTime

Components of SmartTime Timing Analyzer
Changing SmartTime Preferences

Design Flows with SmartTime

You can access SmartTime in Libero SoC either implicitly or explicitly during the following phases of design
implementation:

e During Place and Route — When you select timing-driven place-and-route, SmartTime runs in the
background to provide accurate timing information.

e After Place and Route — Run SmartTime to perform post-layout timing analysis and adjust timing constraints.
In the Libero SoC Design Flow window, expand Implement Design > Verify Post-Layout Implementation.
You can:

e Double-click Verify Timing to generate Timing Reports.
¢ Right-click Open SmartTime > Open Interactively to run SmartTime.

e During Back-Annotation — SmartTime runs in the background to generate the SDF file for timing simulation.
You can also run SmartTime whenever you need to generate timing reports, regardless of which design
implementation phase you are in.

See the Libero SoC User Guide for more information about Place and Route and Back-Annotation.

Starting and Closing SmartTime

You must have completed Place and Route for your design before using SmartTime interactively. If your design
has not yet been placed-and-routed, Libero SoC will complete that phase prior to starting SmartTime.

To open SmartTime interactively, in Implement Design > Verify Post Layout Implementation right-click Open
SmartTime > Open Interactively.

SmartTime reads your design and displays post- or pre-layout timing information.
To close SmartTime, from the File menu, choose Exit.

SmartTime Components

e The Maximum Delay Analysis View and the Minimum Delay Analysis View enable you to analyze
your design

With SmartTime, you can:

e Browse through your design’s various clock domains to examine the timing paths and identify those that
violate your timing requirements
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e Create customizable timing reports
* Navigate directly to the paths responsible for violating your timing requirements

Setting SmartTime Options

You can modify SmartTime options for timing analysis by using the SmartTime Options dialog box.

To set SmartTime options:
From the SmartTime Maximum/Minimum Delay Analysis View window, choose Tools> Options.
The SmartTime Options dialog box has three categories: General, Analysis , and Advanced.

General

1. Inthe General category, select the settings for the operating conditions. SmartTime performs maximum or
minimum delay analysis based on the Best, Typical, or Worst case.

2. Check or uncheck whether you want SmartTime to use inter-clock domains in calculations for timing
analysis.

3. Click Restore Defaults only if you want the settings in the General pane to revert to their default settings.
Analysis
1. Click Analysis to display the options you can modify in the Analysis view.

Enter a number greater than 1 to specify the maximum number of paths to include in a path set during timing
analysis.

3. Check or uncheck whether to filter the paths by slack value. If you check this box, you must then specify the
slack range between minimum slack and maximum slack.

4. Check or uncheck whether to include clock network details.

5. Enter a number greater than 1 to specify the number of parallel paths in the expanded path.
6. Click Restore Defaults only if you want the settings in the Analysis View pane to revert to their default
settings.
Advanced

1. Click Advanced to display advanced options.

Check or uncheck whether to use loopback in bidirectional buffers (bibufs) and/or break paths at
asynchronous pins. Check or uncheck whether to disable non-unate arcs in the clock path.

3. Click Restore Defaults only if you want the settings in the Advanced pane to revert to their default settings.
4. Click OK.
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Figure 2 - SmartTime Options Dialog Box — General Options for PolarFire
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Figure 4 - SmartTime Options Dialog Box — Advanced Options

See Also
SmartTime Options Dialog Box
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SmartTime Toolbar

The SmartTime toolbar contains commands for constraining or analyzing designs. Tool tips are available for each

button.

Table 1 - SmartTime Toolbar
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Icon

Description

Saves the changes

Undoes previous changes

Redoes previous changes

Opens the maximum delay analysis view

Opens the minimum delay analysis view

Opens the manage clock domains manager

Opens the path set manager

2] |2 | | (] (R | e

Recalculates all
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SmartTime Timing Analyzer

SmartTime Timing Analyzer

The SmartTime Timing Analyzer is an interactive Static Timing Analysis tool. Click Open SmartTime in the Design
Flow Window to invoke the SmartTime Timing Analyzer (Design Flow Window > Open SmartTime > Open
Interactively).

Components of the SmartTime Timing Analyzer

Use the SmartTime Timing Analyzer to visualize and identify timing issues in your design for the selected
scenario. In this view, you can evaluate how far you are from meeting your timing requirements, create custom
sets to track, set timing exceptions to obtain timing closure, and cross-probe paths with other tools.
The timing analysis view includes:

e Domain Browser: Enables you to perform your timing analysis on a per domain basis.

e Path List: Displays paths in a specific set in a given domain sorted by slack.

e Path Details: Displays detailed timing analysis of a selected path in the paths list.

e Analysis View Filter: Enables you to filter the content of the paths list.

e Path Slack Histogram: When a set is selected in the Domain Browser, the Path Slack Histogram displays a
distribution of the path slacks for that set. Selecting one or multiple bars in the Path Slack Histogram filters
the paths displayed in the Path List.

You can copy, change the resolution and the number of bars of the chart from the right-click menu.

o FTE
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sk dmariatammiva]
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Figure 5 - SmartTime Timing Analyzer Components

Analyzing Your Design

The timing engine uses the following priorities when analyzing paths and calculating slack:
1. False path
2.  Max/Min delay
3.  Multi-cycle path
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4. Clock

If multiple constraints of the same priority apply to a path, the timing engine uses the tightest constraint.
You can perform two types of timing analysis: Maximum Delay Analysis and Minimum Delay Analysis.
To perform the basic timing analysis:

1. Open the Timing Analysis View using one of the following methods:

e From the SmartTime Tools menu, choose Timing Maximum Delay Analysis or Minimum Delay
Analysis.

e Click the A icon for Maximum Delay Analysis or the icon for Minimum Delay Analysis from
the SmartTime window.

Note: When you open the Timing Analyzer from Designer, the Maximum Delay Analysis window is
displayed by default.

o
a

|

e bt

Maximum Delay Analysis View

2. In the Domain Browser, select the clock domain. Clock domains with a ..+ indicate that the timing
requirements in these domains were met. Clock domains with an x indicate that there are violations within

these domains. The Paths List displays the timing paths sorted by slack. The path with the lowest slack
(biggest violation) is at the top of the list.

3. Select the path to view. The Path Details below the Paths List displays detailed information on how the slack
was computed by detailing the arrival time and required time calculation. When a path is violated, the slack
is negative and is displayed in red color.

4. Double-click the path to display a separate view that includes the path details and schematic.
Note: In cases where the minimum pulse width of one element on the critical path limits the maximum frequency for
the clock, SmartTime displays an icon for the clock name in the Summary List. Click on the icon to display the name
of the pin that limits the clock frequency.

5. Repeat the above steps as required.

Managing Clock Domains

In SmartTime, timing paths are organized by clock domains. By default, SmartTime displays domains with explicit
clocks. Each clock domain includes at least three path sets:

e Register to Register

e External Setup (in the Maximum Analysis View) or External Hold (in the Minimum Analysis View)
e Clock to Out

You must select a path set to display a list of paths in that specific set.

10
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To manage the clock domains:

1. Right-click anywhere in the Domain Browser, and choose Manage Clock Domains. The Manage Clock
Domains dialog box appears (as shown below).

Tip:  You can click the icon in the SmartTime window bar to display the Manage Clock Domains

dialog box.
= 7 IE‘.‘f ,
Available dock domains: Show the dodk domains in this order:
Das(2] ~ Add Das0]
PLL_REF_CLK Das[)
ddr_x32_0/CCC_0¥pll_inst_0OUT DaS3]
ddr_x32_0/CCC_0/pll_inst_0/OUT2 Mewve Down | | ddr_x32_0/DDRPHY_BLE_0/10D_TRAIMING _0/CC

ddr_x32_0/CCC_0¥pli_inst_0/OUT3

ddr_x32 O/DDRPHY_BLE_0/10D_TRAINING Oy
ddr_x32_0/DDRPHY_BLE_0/10D_TRAINING_0; Maove Uip
ddr x32 0/DORPHY ELK_0/10D_ TRAINING 0O/

ddr x32_0/DDRPHY_BLK_O/10D_ TRAINING 0y
ddr_x32_0/DORPHY_BLK_0/I0D_TRAINING 0y , | | Remave

< * < >

Help Mew Cack oK Carcel

Figure 6 - Manage Clock Domains Dialog Box

2. To add a new domain, select a clock domain from the Available clock domains list, and click Add. To add
a non-explicit clock domain, click New Clock.
The Choose the Clock Source Pin dialog box opens, and you can select the clock source pin. You can
choose to filter the available pins and search.

11
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m the _f?fiiz'

Select a Type and Pattern to start selection
Filter available pins :

Type : Pattern :
s [
Search Results :
CCC_0/clkint_0/U0_RGB1:A i‘
CCC_0/clkint_0/UD_RGE1:Y

CCC_0/elkint_0/U0_RGB1:Y.1
CCC_0/clkint_0/U0_RGB1:Y.2
CCC_0/clkint_0/U0_RGB1:Y.3
CCC_0/clkint_0/U0_RGB1:Y.4
CCC_0/clkint_0/U0_RGE1:Y.5
CCC_0Vclkint_0/U0_RGB1:Y.6
CCC_0/clkint_CkA
CCC_/clkint_0xY.2
CCC_/clkint_0xY.3
CCC_0/clkint 0.4
CCC_0/clkint_0kY.5
CCC_0/clkint_0:Y.6
CCC_Ofclkint_0_1:A
CCC_0fclkint_0_1:Y
DDRA_OVCCC_0clkint_4/UD_RGB1:A hd

4] 2
Help ok | cancel |

Figure 7 - Choose Clock Source Pin Dialog Box

4. Toremove a displayed domain, select a clock domain from the Show the clock domains in this order list,
and click Remove.

5. To change the display order in the Domain Browser, select a clock domain from the Show the clock
domains in this order list, and then use the Move Up or Move Down to change the order in the list.

6. Click OK. SmartTime updates the Domain Browser based on your specifications. If you have added a new
clock domain, then it will include at least the three path sets as mentioned above.

See Also
Manage Clock Domains Dialog Box

Managing Path Sets

You can create and manage custom path sets for timing analysis and tracking purposes. Path sets are displayed
under the Custom Path Sets at the bottom of the Domain Browser.

To add a new path set:

1. Right-click anywhere in the Domain Browser, and choose Add Set. The Add Path Analysis Set Dialog Box
appears (as shown below).

Tip:  You can click the icon in the SmartTime window bar to display the Add Path Analysis Set
dialog box.

12
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| Add Path Analysis Set @
MName :- Trace from :- {* Source tosink  Sink to source
Source pins: Sink Pins:

DFM1_0:CLK

DFM1_1:CLK

PF_CCC_CO_D/PF_CCC_CO_0/pll_inst_0:REF_CLK_D

Select Al |

—Filter source pins:

Fin Type: IRegisters by pin names ;I

Filter |

Select Al |

—Filter sink pins:

Pin Type: |Registers by pin names ;I

E Filter I

I:
Help |

o]

Cancel |

2.
3.
4.

Figure 8 - Add Path Analysis Set Dialog Box

Enter a name for the path set.

Select the source and sink pins. You can use the filters to control the type of pins displayed.

Click OK. The new path set appears under User Sets in the Domain Browser (as shown below).

13
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Figure 9 - Updated Domain Browser with User Sets

To remove an existing path set:
1. Select the path set from the User Sets in the Domain Browser.
2. Right-click the set to delete, and then choose Delete Set from the right-click menu.

To rename an existing path set:
1. Select the path set from User Set in the Domain Browser.
2. Right-click the set to rename, and then choose Rename Set from the right-click menu.
3. Edit the name directly in the Domain Browser.

See Also
Add Path Analysis Set Dialog Box

Using Filters

Displaying Path List Timing Information

The Path List in the Timing Analysis View displays the timing information required to verify the timing
requirements and identify violating paths. The Path List is organized in a grid where each row represents a timing
path with the corresponding timing information displayed in columns. Timing information is customizable; you can
add or remove columns for each type of set.

By default, each type of set displays a subset of columns as follows:

e Register to Register: Source Pin, Sink Pin, Delay, Slack, Arrival, Required, Setup, Minimum Period, and
Skew.

e External Setup: Source Pin, Sink Pin, Delay, Slack, Arrival, Required, Setup, and External Setup.
e Clock to Out: Source Pin, Sink Pin, Delay, Slack, Arrival, Required, and Clock to Out.
e Input to Output: Source Pin, Sink Pin, Delay, and Slack.
e Custom Path Sets: Source Pin, Sink Pin, Delay, and Slack.
You can add the following columns for each type of set:
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Register to Register: Clock, Source Clock Edge, Destination Clock Edge, Logic Stage Count, Max Fanout,
Clock Constraint, Maximum Delay Constraint, and Multicycle Constraint.

External Setup: Clock, Destination Clock Edge, Logic Stage Count, Max Fanout, Clock Constraint, Input
Delay Constraint, Required External Setup, Maximum Delay Constraint, and Multicycle Constraint.

Clock to Out: Clock, Source Clock Edge, Logic Stage Count, Max Fanout, Clock Constraint, Output Delay
Constraint, Required Maximum Clock to Out, Maximum Delay Constraint, and Multicycle Constraint.

Input to Output: Arrival, Required, Setup, Hold, Logic Stage Count, and Max Fanout.
Custom Path Sets.

To customize the set of timing information in the Path List:

1.
2.

Select the set to customize.

Choose Customize table on the top left corner of path list to open the Customize Paths List Table dialog
box.

To add one or more columns, select the fields to add from the Available fields list, and click Add.

(7=
Available fields: Show these fields in this order:
Source Pin Add Arrival (ns)
Sink Pin Required (ns)
Delay Setup (ns)
(ns) Move Down | | Recovery (ns)
Slack (ns) External Setup (ns)
External Recovery (ns)
Mave Up Logic Stage Count
Remove
Help Restore Default OK Cancel

Figure 10 - Customize Paths List Table Dialog Box

To remove one or more columns, select the fields to remove from the Show these fields in this order list
and click Remove.

To change the order in which the fields appear, select fields in the Show these fields in this order list and

click Move Up or Move Down.
Click OK to add or remove the selected columns. SmartTime updates the Timing Analysis View.

See Also

Customize Analysis View
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Displaying Expanded Path Timing Information

SmartTime displays the list of paths and the path details for all parallel paths.

PUNENI Y - ey e P i Bemra it Lot Stage Commt

o atpatha

1

sk dmariatammiva]

Figure 11 - Path List View

The Path List displays all parallel paths in your design. The Path Details grid displays the path details for all
parallel paths.
To display the Expanded Path View:

From the Path List: double-click the path, or right-click a path and select expand selected paths.

From the Expanded Path View: double-click the path, or right-click the path and select expand path.

o
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Figure 12 - Expanded Path View

The Expanded Path Summary provides a summary of all parallel paths for the selected path. The Path Profile
chart displays the percentage of time taken by cells and nets for the selected path. If no parallel path is selected
in this view, the Path Profile shows the percentage for all paths. By default, SmartTime only shows one path for
each Expanded Path. You can change this default in the SmartTime Options dialog box.
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The Expanded Path View also includes a schematic of the path and a path profile chart for the paths selected in
the Expanded Path Summary.

Using Filters

You can use filters in SmartTime to limit the Path List content (that is, create a filtered list on the source and sink
pin names). The filtering options appear on the top of the Timing Analysis View. You can save these filters one
level below the set under which it has been created.

To use the filter:

1. Select a setin the Domain Browser to display a given number of paths, depending on your SmartTime
Options settings (100 paths by default).

2. Enter the filter criteria in both the From and To fields and click Apply Filter. This limits the display to the
paths that match your filter criteria.

Figure 13 - Maximum Delay Analysis View

3. Click Store Filter to save your filter criteria with a special name. The Create Filter Set dialog box appears
(as shown below).

Figure 14 - Create Filter Set Dialog Box

4. Enter a name for the filter, such as myfilter01, and click OK. Your new filter name appears below the set
under which it was created.
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Figure 16 - Updated Maximum Delay Analysis View
Repeat the above steps and cascade as many sets as you need using the filtering mechanism.
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To remove a set created with filters:

1. Select the set that uses filters.

2. Right-click the set, and choose Delete Set from the shortcut menu.
To rename a set created with filters:

1. Select the set that uses filters.
2. Right-click the set, and choose Rename Set from the shortcut menu.

3. Edit the name directly in the Domain Browser.

To edit a specific filter in the set:

1. Select the filter to edit.
2. Right-click the filter, and choose Edit Set from the shortcut menu.

See Also
SmartTime Options
Store Filter as Analysis Set
Edit Set dialog box
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Advanced Timing Analysis

Understanding Inter-Clock Domain Analysis

When functional paths exist across two clock domains (the register launching the data and the one capturing it
are clocked by two different clock sources), you must provide accurate specification of both clocks to allow a valid
inter-clock domain timing check. This is important especially when the clocks are specified with different
waveforms and frequencies.

When you specify multiple clocks in your design, the first step is to consider whether the inter-clock domain paths
are false or functional. If these paths are functional, then you must perform setup and hold checks between the
clock domains in SmartTime. Unless specified otherwise, SmartTime considers the inter-clock domain as false,
and therefore does not perform setup or hold checks between the clock domains.

If you have several clock domains that are subset of a single clock (such as if you want to measure clock tree
delay from an input clock to a generated clock), you must configure Generated Clock Constraints for each of the
clock domains in order for SmartTime to do execute the calculation and show timing for each of the inter-clock-
domain paths.

Once you include the inter-clock domains for timing analysis, SmartTime analyzes for each inter-clock domain the
relationship between all the active clock edges over a common period equal to the least common multiple of the
two clock periods. The new common period represents a full repeating cycle (or pattern) of the two clock
waveforms (as shown below).

For setup check, SmartTime considers the tightest relation launch-capture to ensure that the data arrives before
the capture edge. The hold check verifies that a setup relationship is not overwritten by a following data launch.

&_\,_,-"D
ck1 [ op————->
Clk 2 | 2
e
Clk1 .
setup1 setup2 (tightest)
Clk 2

Repeating cycle
Figure 17 - Example Showing Inter-Clock Domains

See Also
Activating inter-clock domain analysis

Deactivating a specific inter-clock domain

Displaying inter-clock domain paths
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Activating Inter-Clock Domain Analysis

To activate the inter-clock domain checking:

1. In SmartTime, from the Tools menu choose Options. The SmartTime Options Dialog Box dialog box
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appears (as shown below).

2. Inthe general category, check the Include inter-clock domains in calculations for timing analysis.

Option Categories
4 Select a category:
General
Analysis
Advanced

General
Operating Conditions

Paformmmdelwmalvﬁbuedmh'm:ﬁ' v | case

Pesform minimum delay analysis based on [BEST * | case

Clodk Domains
] Inchude inter-dock domains in calolatons for timng analyss,

| Enable recovery and remaval chedks.

Figure 18 - SmartTime Options Dialog Box for SmartFusion2, RTG4 and IGLOO2

Help

W SmantTime Options
Option Categories Ganaral
= Select a categony:
Generzl Operating Conditions
g form masimum delay analysis based on [siov_tv_h -
Adhanced Perform maximum delay analysis on [slow_hv_ht case
Perform minimum delay analysis based on [fast_hv_jt | case
~Cock Domains

¥ Indude inter-dodk domains in calculations for timing analysis.

¥ Enable recovery and removal checks.,

=]

Figure 19 - SmartTime Options Dialog Box for PolarFire

3. Click OK to save the dialog box settings.
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See Also
Inter-Clock Domain Analysis
Deactivating a Specific Inter-Clock Domain

Displaying Inter-Clock Domain Paths

Displaying Inter-Clock Domain Paths

Once you activate the inter-clock domain checking for a given clock domain CK1, SmartTime automatically
detects all other domains CKn with paths ending at CK1. SmartTime creates inter-clock domain sets CKn to CK1
under the domain CK1. Each of these sets enables you to display the inter-clock domain paths between a given
clock domain and CK1.

To display an inter-clock domain set:

1. Expand the receiving clock domain of the inter-clock domain in the Domain Browser to display its related
sets. For the inter-clock domain CK1 to CK2, expand clock domain CK2.

2. Select the inter-clock domain that you want to see expanded from these sets. Once selected, all paths
between the related two domains are displayed in Paths List in the same way as any register to register set.
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Maximum Delay Analysis View
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External Setuy
Clock to Out::ut J Source Pin Sink Pin Dfr;y Slack (ns) Ar

§| DFNT_0:CLE DFN1_1:D -0.102

Register to Asynchronous

- External Recovery

Asynchronous to Register
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Rt ot L LJ

| &
I — ﬁ
S 1
£
& b
5
3
0
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slack distribution{ns)
Ready [Temp:0-100¢ [volt: 0.97- 1.03v [speed: =1
Figure 20 - Maximum Delay Analysis View
See Also

Understanding inter-clock domain analysis
Activating inter-clock domain analysis
Deactivating a specific inter-clock domain
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Deactivating a Specific Inter-Clock Domain

To deactivate the inter-clock domain checking for the specific clock domains clk2->clk1, without
disabling this option for the other clock domains:

1.

10.
11.
12.

From the Tools menu, choose Constraints Editor > Primary Scenario to open the Constraints Editor
View.

In the Constraints Browser, double-click False Path under Exceptions. The "Set False Path Constraint
dialog box appears.

Click the Browse button to the right of the From text box. The Select Source Pins for False Path
Constraint dialog box appears.

For Specify pins, select by keyword and wildcard.
For Pin Type, select Registers by clock names from the Pin Type drop-down list.
Type the inter-clock domain name, for example Clk2 in the filter box and click Filter.

Click OK to begin filtering the pins by your criteria. In this example, [get_clocks {Clk2}] appears in the From
text box in the Set False Path Constraint dialog box.

Repeat steps 3 to 7 for the To option in the Set False Path Constraint dialog box, and type CIk2 in the filter
box.

Click OK to validate the new false path and display it in the Paths List of the Constraints Editor.

Click the Recalculate All icon IEI in the toolbar.
Select the inter-clock domain set clk2 -> clk1 in the Domain Browser (as shown below).
Verify that the set does not contain any paths.

prm Ty Bt

s s i | sunro | aomie |

Setupiom] | Mk Period ] — Shack ok P oo il Longic Shape Comt
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Figure 21 - Maximum Delay Analysis View

See Also
Understanding inter-clock domain analysis

Activating inter-clock domain analysis

Displaying inter-clock domain paths

Select Source or Destination Pins for Constraint dialog box

Set False Path Constraint dialog box

23



& Microsemi

a AZ\MicrocHIP company

Generic User Guide

Changing Output Port Capacitance

Output propagation delay is affected by both the capacitive loading on the board and the I/O standard. The 1/O
Attribute Editor in ChipPlanner provides a mechanism for setting the expected capacitance to improve the
propagation delay model. SmartTime automatically uses the modified delay model for delay calculations.

To change the output port capacitance and view the effect of this change in SmartTime Timing Analyzer, refer to

the following example. The figure below shows the delay from DFNL1 to output port Q. It shows a delay of 6.603 ns
based on the default loading of 5 pF.

o) a &=
n x
M oD ke 6=
Meimum Delay Analysis View
& Analyss for scenara
MR e Frem [+ o[
Extemal Recavery B Customize table ApplyFiter | StoreFiter | | Reset Fitar
Asynchranous to Register
v iy FOCC_C0WVFCCC_C0_0/CCC INST/GLY - .
Register to Register Slack | Arrival | Reguired
el S Source Pin Sk Pim (ns) | (ns) | (ns) Clock to Out (ns}
Chock to Output L |DFNL_LOK
Register to Asynchionous &
o cakicie
Hame: Type het Macro el
¥ Summary
data required time
data arrival time
slack
This set has na path, v Data_arrival_time_calculation
% FCCC_CD QYFCCC_C0 OYCOC_INST/GLY
2 FCCC_CD_QVFCCC_CD_Q/CCC_INST/INST_CCC_IP:GLY Clock source
% Clack generation
FCCC_C0_O/FCCC_C0.0/6LY_INST:An net FCCC_C0 OFCCC_C0.0/GL1_net
FCCC_O0 VFCCC_C0.0/6L1_INST-¥Win cell ADUB:GEM -
FCCC €0 QUFCEC O 0/6L1 INST/UD RGE1:An net FCCC €0 Q/FCCC OO 0/6L1 INST/UD YW b
slack destribution(ns) L e
Temp: 0-B5C | Volt: 1,14- 126V |Speed: 5TD

Figure 22 - Maximum Delay Analysis View

If your board has output capacitance of 15 pf on Q, you must perform the following steps to update the timing
number:

1. Open the I/O Attribute Editor and change the output load to 15 pf.

8" /O Editor - X:/10_docs_review/12.0_Relesse/34609/ccel (top)

= (=] x
File Edit View Logic Tools Help
| ad B g HeadialMY Fethy | ok ok 2 S 9 B G &
Main Object Browser X Port View [active] & Pin View & Package View & Foorplanner View & ~  Properties & x
[ iy - | | PortMame |1 Slew |¥| Pre-Emphasis |¥ Outout Drive (ma) ¥| Outoutload(pF) |¥|
= 11| | | | PortName: Q
Ports & |® 1) | Macro: Q_obuf
W /0 Ports {2 [ - - = - | 2 .
T N T N T -
Placed: 237,113
Pin: B29

1/0 Standard: LVCMOS25
170 Bank: Bark1 - DDRIO
VDOL: 2.5v

Figure 23 - 1/O Attribute Editor View
2. Select File > Save.
3. Select File > Close.
4. Open the SmartTime Timing Analyzer.

You can see that the Clock to Output delay changed to 5.952 ns.
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Generating Timing Reports

Types of Reports

Using SmartTime you can generate the following types of reports:
e Timer report — This report displays the timing information organized by clock domain.
e Timing Violations report — This flat slack report provides information about constraint violations.

e Bottleneck report — This report displays the points in the design that contribute to the most
timing violations.

o Datasheet report — This report describes the characteristics of the pins, 1/0 technologies, and timing
properties in the design.

e Constraints Coverage report — This report displays the overall coverage of the timing constraints set on
the current design.

e Combinational Loop report — This report displays loops found during initialization.

e Clock Domain Crossing report — This report analyzes timing paths that cross from one clock domain (the
source clock) to another clock domain (the destination clock).

See Also
Generating a Timing Report

Generating a Timing Violation Report
Generating a datasheet report

Generating a bottleneck report
Generating a constraints coverage report
Generating a Combinational Loop Report

Generating a Clock Domain Crossing Report

Generating a Timing Report

The timing report enables you to quickly determine if any timing problems exist in your design. The Maximum
Delay Analysis timing report lists the following information about your design:

¢ Maximum delay from input I/O to output I/O

e Maximum delay from input I/O to internal registers

¢ Maximum delay from internal registers to output I/O

¢ Maximum delays for each clock network

¢ Maximum delays for interactions between clock networks

To generate a timing report:

1. From the SmartTime Max/Min Delay Analysis View, choose Tools > Reports > Timer. The Timing Report
Options Dialog Box appears.

2. Select the options you want to include in the report, and then click OK.

The timing report appears in a separate window.

See Also
Understanding Timing Reports

Timing Report Options Dialog Box
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Understanding Timing Reports

The timing report contains the following sections:

Header

The header lists:
e The report type
e The version of Designer used to generate the report
e The date and time the report was generated
e General design information (name, family, etc.)

Summary

The summary section reports the timing information for each clock domain.

By default, the clock domains reported are the explicit clock domains that are shown in SmartTime. You can filter
the domains and get only specific sections in the report (see Timing Report Options Dialog Box).

Path Sections

The paths section lists the timing information for different types of paths in the design. This section is reported by
default. You can deselect this option in the Timing Report Options Dialog Box.

By default, the number of paths displayed per set is 5.
You can filter the domains using the Timing Report Options dialog box.

You can also view the stored filter sets in the generated report using the timing report options. The filter sets are
listed by name in their appropriate section, and the number of paths reported for the filter set is the same as for
the main sets.

By default, the filter sets are not reported.

Clock domains
The paths are organized by clock domain.

Register to Register set
This set reports the paths from the registers clock pins to the registers data pins in the current clock domain.

External Setup set
This set reports the paths from the top level design input ports to the registers in the current clock domain.

Clock to output set

This set reports the paths from the registers clock pins to the top level design output ports in the current clock
domain.

Register to Asynchronous set
This set reports the paths from registers to asynchronous control signals (like asynchronous set/reset).

External Recovery set
This set reports the external recovery check timing for asynchronous control signals (like asynchronous set/reset).
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Asynchronous to Register set
This set reports the paths from asynchronous control signals (like asynchronous set/reset) to registers.

Inter-clock domain

This set reports the paths from the registers clock pins of the specified clock domain to the registers data pins in
the current clock domain. Inter-domain paths are not reported by default.

Pin to pin

This set lists input to output paths and user sets. Input to output paths are reported by default. To see the user-
defined sets, use the Timing Report Options Dialog Box.

Input to output set

This set reports the paths from the top level design input ports to top level design output ports.

Expanded Paths

Expanded paths can be reported for each set. By default, the number of expanded paths to report is set to 1. You
can select and change the number when you specify Timing Report Options.
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Timer Report E“E|IE|

Timing Report Max Delay aAnalysis 4

SmartTime Version v12.0
Microsemi Corporation — Microsemi Libero Software Release v12.0 (Version 12.500.0.4)
Date: Fri Sep 14 11:55:24 2018

Design: top

Family: PolarFire

Die: MPF100T

Package: FCG434

Temperature Range: 0 - 100 C
Voltage Range: 0.97 - 1.03 V
Speed Grade: STD

Design State: Post-Layout

Data source: Preliminary
Cperating Conditions: slow_lv_1t
Scenario for Timing Analysis: timing analysis

STMMARY
Clock Domain: CLE
Period (ns): 2.000
Frequency (MHz): 500.000
Required Period (ns): 0.100
Required Frequency (MH=z): 10000.000
External Setup (ns): -1.983
Max Clock-To-Out (ns): 13.607

Input to Output
Max Delay (ns): /L

Clock Domain CLE

Info: The maximum freguency of this clock domain is limited by the minimum pulse
widths of pin CLKE ibuf/U ICPAD:PAD

SET Register to Register

Path 1
From: DFN1_0O:CLEK
To: DFN1 1:D
Delay (ns): 0.434
Slack (ms): —-0,.348 i
Figure 24 - Timing Report
See Also

Generating a Timing Report
Timing Report Options Dialog Box

Generating a Timing Violation Report
The timing violations report provides a flat slack report centered around constraint violations.
To generate a timing violation report

1. From the SmartTime Max/Min Delay Analysis View window, choose Tools > Reports > Timing Violations.
The Timing Violations Report Options Dialog Box appears.
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2. Select the options you want to include in the report, and then click OK. The timing violations report appears
in a separate window.

See Also
Understanding Timing Violation Reports

Understanding Timing Violation Reports

The timing violation report contains the following sections:

Header

The header lists:
e The report type
e The version of Designer used to generate the report
e The date and time the report was generated
e General design information (name, family, etc.)

Paths

The paths section lists the timing information for the violated paths in the design.
The number of paths displayed is controlled by two parameters:

e A maximum slack threshold to report

e A maximum number or path to report

By default, the slack threshold is 0 and the number of paths is limited. The default maximum number of paths
reported is 100.

All clocks domains are mixed in this report. The paths are listed by decreasing slack.

You can also choose to expand one or more paths. By default, no paths are expanded. For details, see the timing
violation report options.
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Timing Vioclation Report Max Delay Analysis

SmartTime Version wll.6

Microsemi Corporation - Microsemi Libero Software Release wl1l.6
11.6.0.1&)

Date: Thu Apr 30 16:18:45 2015

Design: false_path

Family: SmartFusionZ?

Die: M23050

Package: 484 FBGA

Temperature Range: 0 — 85 C

Voltage Range: 1.14 - 1.26 V

Speed Grade: STD

Design State: Post-Layout

Data source: Production

Min Cperating Conditions: BEST - 1.26 V - 0 C
Max Operating Conditions: WCORST - 1.14 W - 85 C
Scenario for Timing Analysis: Primary

(Version

Path 1
From: D2 reg:CLE
To: Q reg:D
Delay (ns): 1.341
Slack (n=): -0.373
Lrrival (ns): 5.333
Regquired (n=s): 4,960
Figure 25 - Timing Violations Report
See Also

Generating a Timing Violation Report
Timing Violations Report Options Dialog Box

Generating a Constraints Coverage Report

The constraints coverage report contains information about the constraints in the design.

To generate a constraints coverage report, from the SmartTime Max/Min Delay Analysis View, choose Tools >
Reports > Constraints Coverage. Select the text format and number of unconstrained instances and click OK.

The report appears in a separate window.

See Also
Understanding Constraints Coverage Reports

Understanding Constraints Coverage Reports

The constraint coverage displays the overall coverage of the timing constraints set on the current design. You can
generate this report either from within Designer or within SmartTime Analyzer. The report contains three sections:
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Results by Clock Domain
Enhancement Suggestions
Constraints_coverag
File Actions Help
Design false_path
Family SmartFusion2
Die M25050
Package 484 FBGA
Temperature Range 0 -85C

Voltage Range 114 o 1260
Speed Grade STD
Design State Post-Layout
Analysis Min Case BEST
Analysis Max Case WCRST
Scenario for Timing Analysis Primary
Coverage Summary
| Type of check | Met | Violated | Untested | Total 1
| Setup 1 0| 10 | 40 | 50 |
| Recovery 1 [+ | [+ | 20 | 20 |
| Cutput Setup | [+ | [+ | 10 | 10 |
| Total Setup | 01 15 | 105 | 120 |
| Hold 1 10 | 0| 40 | 50 |
| Removal 1 0| 01 20 | 20 |
| Output Hold | 01 0| 10 | 10 |
| Total Hold 1 15 | 0 105 | 120 |
Clock domain: my clk
| Type of check | Met | Violated | Untested | Total 1
| Setup 1 0| 3] 12 | 15 |
| Recovery 1 [+ | [+ | & | & |
| Cutput Setup | [+ | [+ | 31 3|
| Total Setup | 01 [ 42 | 48 |
| Hold 1 3] 0| 12 | 15 |
| Removal 1 01 0| 6 | [
| Output Hold | 01 01 3] 3]
| Total Hold 1 [ 0 42 | 48 |
Enhancement Suggestions
— Max input delay constraint missing on ports:

po, Do, DO, D1, D1, D1, D2, D2, D2, RST, RST, RST
— Min input delay constraint missing on ports:

po, Do, DO, D1, D1, D1, D2, D2, D2, RST, RST, RST

m

Figure 26 - Constraints Coverage Report

Coverage Summary

The coverage summary gives statistical information on the timing constraint in the design. For each type of timing
checks (Setup, Recovery, Output, Hold and Removal), it specifies how many are Met (there is a constraint and it
is satisfied), Violated (there is a constraint and it is not satisfied), or Untested (no constraint was found).
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Clock Domain

This section provides a coverage summary for each clock domain.

Enhancement Suggestions

The enhancement suggestion reports, per clock domain, a list of constraints that can be added to the design to
improve the coverage. It also reports if some options impacting the coverage can be changed.

Detailed Stats

This section provides detailed suggestions regarding specific clocks or I/0 ports that may require to be
constrained for every pin/port that requires checks.

Setting SmartTime Options

Generating a Bottleneck Report

The bottleneck report provides a list of the bottlenecks in the design.
To generate a bottleneck report, from the SmartTime Max/Min Delay Analysis View, choose Tools > Reports >
Bottleneck. The report appears in a separate window.
See Also
Understanding Bottleneck Reports
Timing Bottleneck Analysis Options Dialog Box

Understanding Bottleneck Reports - SmartFusion2, IGLOOZ2,
RTG4, and PolarFire

A bottleneck is a point in the design that contributes to multiple timing violations. The purpose of the bottleneck
report is to provide a list of the bottlenecks in the design. You can generate this report either from SmartTime
Analyzer. It contains two sections

e Device Description
e Bottleneck Analysis
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Figure 27 - Bottleneck Report

The bottleneck can only be computed if and only a cost type is defined. There are two options available:
e Path count: This cost type associates the severity of the bottleneck to the count of violating/critical paths

that traverse the instance.

e Path cost: This cost type associates the severity of the bottleneck to the sum of the timing violations for the

violating/critical paths that traverse the instance.

Device Description

The device section contains general information about the design, including:

e Design name

e Family
e Die
e Package

e Software version

Bottleneck Analysis

This section lists the core of the bottleneck information. It is divided into two columns:

e Instance name: refers to the output pin name of the instance.

e Path Count: Displays the number of violating paths which include the instance pin.

See Also
Timing Bottleneck Analysis Options Dialog Box
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Generating a Datasheet Report

The datasheet reports information about the external characteristics of the design.

To generate a datasheet report, from the SmartTime Max/Min Delay Analysis View, choose Tools > Reports >
Datasheet. The report appears in a separate window.

Note: Generating Datasheet Report is not supported in PolarFire.

See Also

Understanding Datasheet Reports

Timing Datasheet Report Options Dialog Box

Understanding Datasheet Reports

The datasheet report displays the external characteristics of the design. . You can generate this report from

SmartTime Max/Min Delay Analysis View. It contains three tables:

Pin Description

DC Electrical Characteristics

AC Electrical Characteristics

File Actions Help
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AC Electrical Characteristics

Description |

| Min |

Max | Unit |

Figure 28 - Datasheet Report

| REFCLE N 1 &T7 I Input | I

| REFCLK P | AO7 | Imput | |

| RXDO_N | AWE | Inpuc | |

| RXDO_P 1 e | Input | |

| RXD1 N | BAS | Input | |

| RED1I_P | RYS | Input | |

| RXD2 N 1 BAT | Imput | I

| RXD2 P 1 AY7 | Input | |

| RED3_N | BRS | Imput | |

| RXD3_F | AYS | Imput | |

| FDDR_CAS N | AN3Z | Qutput | SSTL18I (1) |

| FDDR_CEE | AL3S | Cutput | SSTL1BI (1) |

| FDDR_CLK | AG3S | Cutput | SSTL18I (1) |

| FDDR_CLK N | RG4S0 | Qutput | SSTL1BI (1) |

| FDDR_C5_N | AM3% | Qutput | SSTL18I (1) |

| FODR_DQS_TMATCH O_OUT | AC36 | Cutput | SSTL18I (1) |

| FDDR_ODT | ARE40 | Qutput | S3TL18I (1) |

| FDDR_RAS_N | AH39 | Qutput | SSTL181 (1) |

| FDDR_RESET ! | AN38 | Qurput | SSTL1EI (1) |

| FODR_WE_N | 738 | Output | SSTLI8T (1) |

| GLO | 5 | Output | LVCMOS1E (2) |

| INIT_DCHE | BJ38 | Qutput | LVCMCS1E (2) |

| LOCK | L33 | Cutput | LVCMOS18 (2) I

| TXDO W | AT3 | Qutput | |

| TEDO_P | RO3 | Output | |

| TXD1_ N | ATS | Output | |

| TED1_P | AUS | Qutput | |

| TXD2 W | Ve | Cutput | |

| TXDZ_P | AWE | Qutput | |

| TXD3 N | avE | Qutput | |

| TXD3_P | AWS | output | |

DC Electrical Characteristics

| Name | Veci | Veer | Direction | Output | Odc_Static | Odr | Input | Resistor | Schmictt | Slew | Output |
| (I T ' I | | Load | | Imp | Delay | Pull | Trigger | | Drive |
1 I I I 1 (PF) I | (Qmm) | I 1 I I (mA) I
| LVCMOS18 (1) | 1.8 | | Input ] | | | Cff | Mone | off I | I
| LVCMOSL1E (2) | 1.8 | | Qurput = | | | | NWone I | SLOW | 4 )
| SSTLiBI (1) | 1.8 | 1 | Output | S | | | I I I | I
| SSTLiSI (2} | 1.8 | 1 | Inout | & | off | 50 | o£f | | | | ]
| SSTL1BI (3) | 1.8 | 1 | Input I | Off | 5@ | CEf I I I I 1
+ + + +
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Pin Description

Provides the port name in the netlist, location on the package, type of port, and I/O technology assigned to it.
Types can be input, output, input, or clock. Clock ports are ports shown as "clock" in the Clock domain browser.

DC Electrical Characteristics

Provides the parameters of the different I/O technologies used in the design. The number of parameters displayed
depends on the family for which you have created the design.

AC Electrical Characteristics

Provides the timing properties of the ports of the design. For each clock, this section includes the maximum
frequency. For each input, it includes the external setup, external hold, external recovery, and external removal
for every clock where it applies. For each output, it includes the clock-to-out propagation time. This section also
displays the input-to-output propagation time for combinational paths.

See Also
Generating a Datasheet Report
Timing Datasheet Report Options Dialog Box

Generating a Combinational Loop Report

The combinational loop report displays all loops found during initialization and reports pins associated with the
loop(s), and the location where the loop is broken.

To generate the combinational loop report; from the Tools menu, choose Reports > Combinational Loops ....

Select either the Plain Text or Comma Separated Values option in the Combinational_Loops Report Options
dialog box and click OK.

The plain text report will pop up in a new window; you will be prompted to save the CSV in a directory of your
choosing.

See Also
Understanding Combinational Loop Reports

Understanding Combinational Loop Reports

The combinational loop report displays all loops found during initialization and reports pins associated with the
loop(s), and the location where the loop is broken.
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| -] Combinational_loops

File Actions Help

Combinational Loop Report

SmartTime Version 11.6.0.15

Microsemi Corporation — Microsemi Libero Software Belease vwll.6& (Version
11.6.0.15)

Date: Fri May 01 15:50:15 2015

Design TOP

Family RTG4

Die RT4G150

Package 1657 CG&

Radiation Exposure a

Temperature Range =55 =125 &

Voltage Range 1.14 - 1.26 V

Speed Grade -1

Design State Post-Layout

Analysis Min Case BEST - 1.26 V — -55 C
Analysis Max Case WORST - 1.14 V - 125 C
Scenario for Timing Analysis Primary

No combinational loops were detected in the design.

Figure 29 - Combinational Loop Report

See Also
Generating a Combinational Loop Report

Generating a Clock Domain Crossing (CDC) Report

The CDC report analyzes timing paths that cross from one clock domain (the source clock) to another clock domain
(the destination clock). The CDC report helps identify instances where there may be data loss or metastability issues.

To generate the CDC report from the Tools menu, choose Reports > Report CDC....

Select either the CDC Table or Comma Separated Values format in the Clock Domain Crossing Report Options
dialog box and click OK.
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CDC Table Format

If you select CDC Table, a graphical table appears with color-coded cells. Each cell represents a CDC type between
the source clock and the destination clock domains that has constraints. Clocks without constraints do not appear in

the CDC table.

Destination Clocks

Ik_input_100mh | clk_input_25mhaf g_com_clk_10m | clk_input_30mhi| :g_com_clk_Smk
gen_clk_12p5mhz
.../pll_inst_0/0OUTO
-/pll_inst_0/OUT1
asyn_reg_clk

cli_input_100mhz

Source Clocks

clk_input_25mhz.
reg_com_clk_10mhz

clic_input_50mhz

reg_com_clk_Smhz

~Legend
[ ropatn [ user sgnored paths
W e [ vived nsate)

A

In the CDC report dialog box, you can select which clocks to view or hide. Clicking the > Clock Selection button at
the top left of the dialog box lists all clocks that can be viewed or hidden. By default, all clocks are checked and
visible. To hide a clock, uncheck its check box.

M clic_input_25mhz

reg_com_clk_10mhz clk_input_100mhz
] elk_input_S0mhz
reg_com_clk_Smhz

g cli_input_25mhz

reg_com_clk_10mhz

clk_input_S0mhz

reg_com_clk_Smhz
4 | 2
rLegend
B voetn [ user tonored paths
W e B rimed (Unsate)
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The following table describes the colors in the CDC report shown above.

have NO common primary clock, while paths are found from the
source clock domain to the destination clock domain. Currently,
synchronizers, if present, are not accounted for in this report.

Pattern Status Color
Paths from the source clock domain to the destination clock domain | User Ignored Paths
have all been disabled by false path or clock group constraints.
No Paths found from the source clock domain to the destination No Paths
clock domain.
The source and destination clocks are synchronous: Both clocks Timed Dark Blue
have a common primary clock and paths are found from the source
clock domain to the destination clock domain.
The source and destination clocks are asynchronous: Both clocks Timed (unsafe) Brown

Comma Separated Values (export as CSV)

Select Comma Separated Value to export the CDC report to a CSV file. Selecting this option displays a window
where you assign a name to the CSV file and specify the location where it will be exported. The CSV file shows

details about the CDC between each clock domain in numeric format. Each CDC type is represented as a number
(like colors in the table). The CSV file includes an explanation of each number type and CDC type.

3 T T

2 | Microzerms Corparabon - Microsemi Linero Software Keltase V1.4 (Version 12.900.0.3)

Disters Weed Mar 11 23:48:02 2020

Desgn

16 | sterana far Timing Anaiyss cicck Domain Crazngs
17
]
19 ' Source Clacks £ Destnation Cucks. gen_dk 12pSenhe PF OO OO OVFF OO0 00 Ol st OAOUTO PF COC (O OVFF OOC 00 OVpll ret GYOUTL
20 fgen he Timed Ho Path Mo Path
F_CCC_Cn_OUpl_inst_0/0UTD Mo Path Timed User iznared
F_CCC_C0 0pll_inst_IOUTI Hn path User ignared Trnad
Napath Mo path Hn Path
Timed {unsafa) Ho Fath Mo Path
user ignared NoFath Mo Path
Hu fath Nu path No Path
Hu Palh Hu Palh N Patk
Ho Patn Ho Path M Bt

Lser ignoied Tirned Ne Path

o Bath No #3th W Path Mo Path
Ko Path Nn#ath Wi path Hepath

Ko path Nn Pt Nz Path He path
Timee Trned funsafe)  NePath user ignarsd
nimec unsafe)  Tenad N rath user ignared
Ho bath No#sth Timed N bath

Mo Path Useet e N Path Timed

Mo Path No Patr Timed [unsafe) M Path

reg ok ok gl 100mhe ok inpul_25mhe reg vom ok 20t ok rput SO reg_com_uk_Smihe

User Ignored
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Timing Concepts

Static Timing Analysis Versus Dynamic Simulation

Static timing analysis (STA) offers an efficient technique for identifying timing violations in your design and
ensuring that it meets all your timing requirements. You can communicate timing requirements and timing
exceptions to the system by setting timing constraints. A static timing analysis tool will then check and report
setup and hold violations as well as violations on specific path requirements.

STA is particularly well suited for traditional synchronous designs. The main advantage of STA is that unlike
dynamic simulation, it does not require input vectors. It covers all possible paths in the design and does all the
above with relatively low run-time requirements. The major disadvantage of STA is that the STA tools do not
automatically detect false paths in their algorithms.

Delay Models

The first step in timing analysis is the computation of single component delays. These components could be either
a combinational gate or block or a single interconnect connecting two components.

Gates that are part of the library are pre-characterized with delays under different parameters, such as input-slew
rates or capacitive loads. Traditional models provide delays between each pair of I/Os of the gate and between
rising and falling edges.

The accuracy with which interconnect delays are computed depends on the design phase. These can be
estimated using a simple Wire Load Model (WLM) at the pre-layout phase, or a more complex Resistor and
Capacitor (RC) tree solver at the post-layout phase.

Timing Path Types

Path delays are computed by adding delay values across a chain of gates and interconnects. SmartTime uses
this information to check for timing violations. Traditionally, timing paths are presented by static timing analysis
tools in four categories or "sets":

e Paths between sequential components internal to the design. SmartTime displays this category under the
Register to Register set of each displayed clock domain.

e Paths that start at input ports and end at sequential components internal to the design. SmartTime displays
this category under the External Setup and External Hold sets of each displayed clock domain.

e Paths that start at sequential components internal to the design and end at output ports. SmartTime displays
this category under the Clock to Out set of each displayed clock domain.

e Paths that start at input ports and end at output ports. SmartTime displays this category under the Input to
Output set.

Maximum Clock Frequency

Generally, you set clock constraints on clocks for which you have a specified requirement. The absence of
violations indicates that this clock will be able to run at least at the specified frequency. However, in the absence
of such requirements, you may still be interested in computing the maximum frequency of a specific clock domain.

To obtain the maximum clock frequency, a static timing analysis tool computes the minimum period for each path
between two sequential elements. To compute the maximum period, the tool evaluates the maximum data path
delay and the minimum skew between the two elements, as well as the setup on the receiving sequential
element. It also considers the polarity of each sequential element. The maximum frequency is the inverse of the
largest value among the maximum period of all the paths in the clock domain. The path responsible for limiting the
frequency of a given clock is called the critical path.
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Setup Check

The setup and hold check ensures that the design functions as specified at the required clock frequency.

Setup check specifies when data is required to be present at the input of a sequential component in order for the
clock to capture this data effectively into the component. Timing analyzers evaluate the setup check as a
maximum timing budget allowed between adjacent sequential elements. For more details on how setup check is
processed, refer to Arrival Time, Required Time, and Slack.

See Also
Static Timing Analysis Versus Dynamic Simulation
Arrival Time, Required Time, and Slack

Arrival Time, Required Time and Slack

You can use arrival time and required time to verify timing requirements in the presence of constraints. Below is a
simple example applied to verifying the clock requirement for setup between sequential elements in the design.

The arrival time represents the time at which the data arrives at the input of the receiving sequential element. In
this example, the arrival time is considered from the setup launch edge at CK, taken as a time reference (instant
zero). It follows the clock network along the blue line until the clock pin on FF1 (delay d1). Then it continues along
the data path always following the blue line until the data pin D on FF2. Therefore,

Arrival_Timerr2p = d1 + d2

The required time represents when the data is required to be present at the same pin FF2:D. Assume in this
example that in the presence of an FF with the same polarity, the capturing edge is simply one cycle following the
launch edge. Using the period T provided to the tool through the clock constraint, the event gets propagated
through the clock network along the red line until the clock pin of FF2 (delay d3). Taking into account FF2 setup
(delay d4), this means that the clock constraint requires the data to be present d4 time before the capturing clock
edge on FF2. Therefore, the required time is:

Required_Timerr2p = T + d3 - d4

The slack is simply the difference between the required time and arrival time:

Slackrr2:0 = Required_Timerr2p - ArrivaI_TimeFFZ D

If the slack is negative, the path is violating the setup relationship between the two sequential elements.

dl_.
CK g———
d3
Setup check Setup check
launch edge capture edge
CK
0 T

Figure 30 - Arrival Time and Required Time for Setup Check
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Timing Exceptions Overview

Use timing exceptions to overwrite the default behavior of the design path. Timing exceptions include:

e Setting multicycle constraint to specify paths that (by design) will take more than one cycle.

e Setting a false path constraint to identify paths that must not be included in the timing analysis or the
optimization flow.

e Setting a maximum/minimum delay constraint on specific paths to relax or to tighten the original clock
constraint requirement.

Clock Skew

Cross

The clock skew between two different sequential components is the difference between the insertion delays from
the clock source to the clock pins of these components. SmartTime calculates the arrival time at the clock pin of
each sequential component. Then it subtracts the arrival time at the receiving component from the arrival time at
the launching component to obtain an accurate clock skew.

Both setup and hold checks must account for clock skew. However, for setup check, SmartTime looks for the
smallest skew. This skew is computed by using the maximum insertion delay to the launching sequential
component and the shortest insertion delay to the receiving component.

For hold check, SmartTime looks for the largest skew. This skew is computed by using the shortest insertion
delay to the launching sequential component and the largest insertion delay to the receiving component.
SmartTime makes this distinction automatically.

Probing

Design objects displayed in SmartTime can be cross-probed into other Libero SoC tools. Libero SoC allows
cross-probing from SmartTime to the Constraints Editor (but not vice versa) and from SmartTime to Chip Planner
(but not vice versa). When cross-probing from SmartTime to one of the other tools, both SmartTime and the other
tool must first be opened.

From SmartTime to Constraint Editor

You can add a timing exception constraint from SmartTime and have the Constraints Editor display the
Constraint. From the SmartTime Maximum or Minimum Delay Analysis View, click a timing path to add a timing
exception constraint. When the Constraints Editor's Add Constraint dialog box opens, the fields for source (from)
pin and destination (to) pin are populated with the correct names from the timing path you have selected.

To add a timing exception constraint from a timing path in SmartTime Max/Min Delay Analysis View:

1. Open SmartTime (Design Flow Window > Verify Timing > Open interactively).

2. Open the Constraints Editor (Constraint Manager > Timing Tab > Edit with Constraints Editor).
3. Select Max/Min Delay Analysis View and right-click a timing path in the table.
4

Select a timing exception constraint to add: False Path Constraint, Maximum Delay Constraint, Minimum
Delay Constraint, or Multicycle Path Constraint.
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From * O *
Customize table | apply Fiter | | tore Fiter | | Reset Fiter |
Source Pin Sink Pin B&I:; Slack {ns) ‘ Arrival (ns) ‘ L
1 |alskok a6l 3,990 ' 7502 -
2 [Q4)CLE 4] 36899 7.499
4 |ofz)cLk ofz] Copy 7.463
Print
5 1]:CLK 1 6.640 |
a1l Al Add False Path Constraint
6 |Q[0):CLK Qo] Add Max Delay Constraint 6.633| _
| il Add Min Delay Constraint o
Hii Type Add Multicycle Path Constraint R, B
4 Summary Showv Path in Chip Planner L

data required time
data armval time
slack
4 Data_arrival_time_calculation

Expand selected paths

4 | [}

Figure 31 - Add Timing Constraint from SmartTime’s Reported Timing Path
Note: The Add Max/Min Delay, False Path, and Multicycle Path Constraint menu items are grayed out if the

Constraint Editor is not open.

Add the Constraint in the Add Constraint dialog box. Note that the source/from pin and destination/to pin field are
populated with the correct pin names captured from the SmartTime reported path (Source Pin and Sink Pin) you

have clicked.
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F ™

B Set Maximum Delay Constraint 2 |

Maximum delay : 1.0 ns

Frarm &

[ aet_pirs { q_rea[SPCLK } ] 4

Through :
To
[ get_pins { Q3D } ] -
Comment :
Help | | ok | Cencel
Figure 32 - Add Maximum Delay Constraint
5. Click OK to exit the Add Constraint Dialog box.
6. Click Save in the Constraints Editor.
7. Exit the Constraints Editor.
8. Exit SmartTime.
9. Rerun Place and Route if the newly-added constraint that is added to a file (the Target file) is used for Place

and Route and Verify Timing.
10. Open SmartTime Maximum/Minimum Delay Analysis View.

From SmartTime to Chip Planner

Cross-probing allows you to select a design object in one application and display the selected object in another
application. Because Libero SoC allows you to cross-probe design objects from SmartTime to Chip Planner, you
can better understand how the two applications interact with each other. With cross-probing, a timing path not
meeting timing requirements can be fixed with relative ease when you see the less-than-optimal placement of the
design object (in terms of timing requirements) in Chip Planner. Cross-probing from SmartTime to Chip Planner is
available for the following design objects:

e Macros
e Ports
e Nets/Paths
Note: Cross-probing of design objects is available from SmartTime to Chip Planner but not vice versa.
Before you can cross-probe from SmartTime to Chip Planner, you must:
1. Complete the Place and Route step on the design.
2. Open both SmartTime and Chip Planner.
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Cross-Probing Examples

To cross-probe from SmartTime to Chip Planner, a design macro in SmartTime is used.

Design Macro Example

1. Make sure that the design has successfully completed the Place and Route step.

2. Open SmartTime Maximum/Minimum Analysis View.

3. Open Chip Planner.

4. Inthe SmartTime Maximum Analysis View, right-click the instance Q[2] in the Timing Path Graph and
choose Show in Chip Planner. Note that with cross-probing, the Q[2] macro is selected in Chip Planner’'s
Logical View and highlighted (white) in the Chip Canvas. The Properties window in Chip Planner displays
the properties of Q[2].

Note: Show in Chip Planner is grayed out if Chip Planner is not already open.

Note: You may need to zoom in to view the highlighted Q2 Macro in the Chip Canvas.

[ Mazimuen Delwy - Expanded Path view Fram: QIECLE > Te 30 [ o |[@ ] & [ B Chip Planner - Dy/2Work/prepl_ncf (prepl)

summary for path EethProfe - = e

;;r;i,ﬂgtm : I o, X « S B @ » Qs

Data Required Time {ns) Bata Arrival Time (ns) Shack (ns) L pesion Yow S niMargadation Mode |4 Frppoctis s

13786 4215 =011 JReT | e ] Fittes el :

Laed Logpeal View Macro: 2]
& Peimithes Type(sk OFF
Hame Trpe et W cLE ibuf PMaced: 168,13
CLEibuf_RNVQD4/UO_RGELYL cell u ‘;-“‘-""‘f-":‘f:"gn‘. Resources
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Figure 33 - Cross-Probing — Macro

Timing Path Example

1. Make sure that the design has successfully completed the Place and Route step.

2. Open the SmartTime Maximum/Minimum Analysis View.

3. Open Chip Planner.

4. Inthe SmartTime Maximum/Minimum Analysis View, right-click the net CLK_ibuf/U0/U_IOPAD:PAD in the
Table and choose Show Path in Chip Planner. Note that the net is selected (highlighted in red) in the Chip
Canvas view and the three macros connected to the net are also highlighted (white) in the Chip Canvas
view.

Note:

Show Path in Chip Planner is grayed out if Chip Planner is not already open.
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Figure 34 - Cross-Probing — Timing Path
Alternatively, right-click a path in the Max/Min Delay Analysis View and select Show Path in Chip Planner to
cross-probe the path.
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Figure 35 - Cross-Probing Path from Max/Min Delay Analysis View Table

Port Example
Make sure that the design has successfully completed the Place and Route step.
Open the SmartTime Maximum/Minimum Analysis View.

Open Chip Planner.

In the SmartTime Maximum/Minimum Analysis View, right-click the Port “CLK” in the Path and choose
Show in Chip Planner. Note that the Port “CLK" is selected and highlighted in the Chip Planner Port View.

Note: Show in Chip Planner is grayed out if Chip Planner is not already open.

P wbde
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From the Properties View inside Chip Planner, you will find useful information about the Port “CLK” you are cross-

probing:
e Port Type

e Port Placement Location (X-Y coordinates)

e |/O Bank Number
e |/O Standard
e Pin Assignment

Properties
Macro: CLK_ibuf
Port(s): CLK
Type(s): 1/Q, Single-ended I)0, Input IO
Placed: 0,19

Package Pin(s): HI
1/0 Standard({s): LVCMOS25

Resources

Total Count

Nets
Met

1/0 Bank: Banks - MSIO Locked
Resource
10 1
F"in Fanout
@& u_I0P2D:Y 2 CLK ibuf
Properties Lavers and Colors

Figure 37 - Properties View of Port “CLK”
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SmartTime Tutorials

Tutorial 1 - 32-Bit Shift Register with Clock Enable

This tutorial section describes how to enter a clock constraint for the 32-bit shift register on SmartFusion2 device.
You will use the SmartTime Constraints Editor and perform post-layout timing analysis using the SmartTime
Timing Analyzer.

RST .

>
} DR10] Q3190 L O310]
D E
E— .
|
Q_int[31:0]

i

Figure 38 - 32-bit Shift Register

Use the links below to go directly to a topic:

Add a Clock Constraint

Run Place and Route

Maximum Delay Analysis with Timing Analyzer
Minimum Delay Analysis with Timing Analyzer

Changing Constraints and Observing Results

To set up your project:

1.

2.
3.
4

Invoke Libero SoC. From the Project menu, choose New Project.

Enter sf2_shift32 for your new project name and browse to a folder for your project location.
Select Verilog as the Preferred HDL Type.

Leave all other settings at the default values.

47



Generic User Guide

Project details
Specify project detais

Project Details
Device Selection
Device Settings
Design Template
Add HDL Sources
Add Constraints

Libefo)

System-on-Chig

[
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Fraject name: sf2_shfitsg
Projectlocation: o lactelpn

Preferred HOL type: |Verfog ¥

Enable blodk creation

e Family: SmartFusion2

Figure 39 - New Project Creation - 32 Bit Shift Register
5. Click Next to go to Device Selection page. Make the following selection from the pull-down menu:

e Die: M2S090TS

e Package: 484FBGA
e Speed:STD

e Core Voltage: 1.2V
e Range: COM

Project Datails

Libefo)

Sytem-on Chip

oo |

. Click the M2S090TS-1FG484 part number and click Next.

Select a part for your project from the part number kst

Part fiter

Famiy: |SmarlFusion2

Speed: [-1

Search part:

Part Number LT

e BE1E4

LSRAM 18K Math (183)  PLLsand

[ <pack | [ etz |[ Fosh | [ cCancel |

7. Accept the default settings in the Device Settings page and click Next.

8.  Accept the default settings in the Design Template page and click Next.

9. Click Next to go to the Add Constraints Page.
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10. We are not adding any constraints. Click Finish to exit the New Project Creation wizard.
11. To add a new HDL file, select File> New> HDL. The Create a new HDL file dialog box opens. Name the

HDL file as shift_reg32 as shown below and click OK.

r

=]

8 i
HDL Type
{+ Verilog " VHDL
Name: [shlft_regﬂ
| Initialize file with standard template
Help OK Cancel

Figure 40 - Create a new HDL file Dialog Box

12. Copy and paste the code shown below into the Verilog file:

module shift32 ( Q,CLK,D,EN,RESET);
input D,EN,CLK,RESET;
output[31:0] Q;

reg [31:0] Q_int;
assign Q=Q_int;

always@ (posedge CLK)
begin

iT(RESET)

Q_int<=0;

else begin

iT(EN)
Q_int<={Q_int[30:0],D};
end

end

endmodule

13. Check the HDL file to confirm that there are no syntax errors.

14. Confirm that the shift_reg32 design appears in the Design Hierarchy window, as shown in the figure below.
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Show: [Components v |

=

[=t work

.' l?“—-,h[ shift32 (shift_reg32.v) [work]
#- [[] User HDL Source Files

Figure 41 - shift_reg32 in the Design Hierarchy Window

15. In the Design Flow window, double-click Synthesize to run Synplify Pro with default settings. A green check
mark appears next to Synthesize when Synthesis is successful (as shown in the figure below).

Desgn Flow RS
stef_reg12 (o> I -
[ Tacl -]
{
4 b Create Design |
& System Builder 1l
&4 Configure M55 1

Creste SmantDesign
B Creste HOL i

i Creste SmanDesign Testbench
[l Creste HOL Testbench
+1] Generste Memary Map
4 Verify Pre-Synthesized Design
B Simutse
4 ¢ Comstraints
0 Mansge Constraints.
4 ¥ [mplement Design
v T Synthesize
a b Verify Post-Synthesi Implementation
Simulate

N T SR e ALt
m

1

v

[[=]Messages | @) Emers i, Wamings i info

Oiro: wo vser O rile(s) vas specified.
Cleaning tocl '"Export Hetlist'...
Synthesis completed.

Log [ Message |

| Reos 8% | starge @ x |

4l

4 Project Summary

shifidllog
4 ghift_reg32 reports
4 Syrihesize

synpifilog

A shift_reg3d.ser
nan_oplionstd
shift_reg32_compile_n...
shift_reg32_cornpile_n...
@ srite_regaz_compa.

| (B4 @ oerers iy o wamngs @ 0unfe

|| souzeing ¥i\production Synopsys Symplesy\poy sysplify_J201503M-3\ 11D mens, ~ |

Starting: T\ produstica\SYnopsYs \SYNplifyA RS\ SYAPLLLY_J204503M-IVbARE,
Install: Yriproductica\ Syncpaya \ SIMplLI\ PSSPy _J200503M-1
|| Boscname: WTE4-WOHGA
Dave: Fri Dec 1& 10:0i:12 2018
Veraiedn: J-2015., 0343

Arguments:  ~product synplify pro -licenserype synplifypro_sctel -batch
ProductIype: synplify pro

|:.:.ee:|ae checkout: synplifypre_sctel
|License: symplifypre sctel frem server smge
|| Etcensed vendoz: actel

License Optiom: actel cem

Fumning is Vendor Hede

Implentntation not found: synthesis

. m ] "

Fam: SmartFusion2 |Part: M2SOSOTSFGAB4 | Verkog

Figure 42 - Synthesis and Compile Complete - 32-Bit Shift Register with Clock Enable
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Add a Clock Constraint - 32 Bit Shift Register

To add a clock constraint to your design:

1. Inthe Design Flow window, double-click Manage Constraints. The Constraint Manager appears (as shown
in the figure below.)

Reports & X l StartPage & X : Constraint Manager & X ¥

{1/ Attributes \/ Timing \/ Floor Planner /" Netlist Attributes \,

[ tew |

Import | | Uk | [Edtwith ChipPlanner| | check | | hep + |+

Place and Route

Figure 43 - Constraint Manager

2. Click the Timing tab.
3. Click Edit with Constraints Editor > Edit Place and Route Constraints. The Constraints Editor appears.

3 file| Constraints Tools Edit Help

Bl 0S| G e B bm B e Do

onstrants Cdtor

Constraints
Requirements

Chuck
Genersted Clock
Input Delay
Output Defay
Eaernal Check
Chuck To Out

= Exceplons
Mz Diely
Win Delay
Multicycle
False Path

= Advanced
Dinable Tiring
Clnck Source Latency
Chock Uncertainity
Clock Groups

i T Periud | Frequency | Dutycycle | First | Offsel | |
Sy | GockMame | Gocksowce | "t | Py | Duiprde | (L | O | Wavetom | Ads | e

_@ R e o s nmn Towan [0 e |

Figure 44 - Constraints Editor — Add clock constraint

4. Inthe Constraints Editor, right-click Clock under Requirement and select Add Clock Constraint.

The Create Clock Constraint Dialog Box appears.
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B3 Create Clock Constraint [ =

Clock Name : Clock Source : | E
L&
——Period : ns  ——Mr Freguency: Mhz

[

=

e Offset pra— Duty cyde: "

0.000 ns 50,0000 oo

I Add this dock to existing one with same source

Comment : |

Help oK Cancel

Figure 45 - Create Clock Constraint Dialog Box

5.  From the Clock Source drop-down menu, choose the CLK pin.
6. Enter my_clk in the Clock Name field.

7. Setthe Frequency to 250 MHz (as shown in the figure below) and leave all other values at the default
settings. Click OK to continue.

B3 Create Clock Constraint [ =

Clock Name : |my_dk Clock Source : |[gEtJ30rtE {CLK}] E

M—Period : |4 ns  ——MrFrequency: 250 Mhz

[

=

e Offset pra— Duty cyde: "

0.000 ns 50,0000 oo

I Add this dock to existing one with same source

Comment : |

Help oK Cancel |

Figure 46 - Add a 250 MHz Clock Constraint
The clock constraint appears in the SmartTime Constraints Editor (as shown in the figure below).
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K
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10.

Figure 47 - 250 MHz Clock Constraint in the Constraint Editor

From the File menu, choose Save to save the constraints.
From the SmartTime File menu, choose Exit to exit SmartTime. Libero creates a constraint file to store the

clock constraint. This file is listed and displayed in the Constraint Manager. It is named user.sdc and is

designated as Target.

a AS\MicRocHIP company

Note: A target file is used to store newly added constraints from the Constraint Editor. When the Constraint

Editor is invoked and no SDC timing constraint file is present, Libero SoC creates the user.sdc file (and

marks it as target) to store the timing constraints you create in the Constraint Editor.

In the Constraint Manager, check the checkbox under Place and Route and the checkbox under Timing
Verification to associate the constraint file to the tools. The constraint file is used for both Place and Route

and Timing Verification.
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Figure 48 - SDC Constraint File and Tool Association

Run Place and Route

1. Right-click Place and Route and choose Configure Options.

2. Click the checkbox to enable Timing-Driven layout in Layout Options and leave the other values at the
default settings (as shown in the figure below). Click OK to continue.
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W77 Layout Options 7 ][=]
[+ Timing-driven
[ Power-driven
[ I Register Combining
v Global Pins Demotion
[ Driver Replication
[ High Effort Layout

¥ Repair Minimum Delay Violations

[ Incremental Layout

[ Use Multiple Passes

Help QK Cancel

Figure 49 - Layout Options Dialog Box
3. Double-click Place and Route inside the Design Flow window to start the Place and Route.

A green check mark appears next to Place and Route after successful completion of Place and Route.

Maximum Delay Analysis with Timing Analyzer- 32-Bit Shift
Register Example

The SmartTime Maximum Delay Analysis window displays the design maximum operating frequency and lists any
setup violations.
To perform Maximum Delay Analysis:

1. Right-click Open SmartTime in the Design Flow window and choose Open Interactively to open
SmartTime. The Maximum Delay analysis window appears. A green check next to the clock name indicates
there are no timing violations for that clock domain. The Summary page displays a summary of the clock
domain timing performance.

The Maximum Delay Analysis Summary displays:
¢ Maximum operating frequency for the design
e External setup and hold requirements
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¢ Maximum and minimum clock-to-out times. In this example, the maximum clock frequency for CLK

is 609.75 MHz.
” " &l %
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Figure 50 - Maximum Delay Analysis - Summary
2.  Expand my_clk to display the Register to Register, External Setup and Clock to Output path sets.

3. Select Register to Register to display the register-to-register paths. The window displays a list of register-
to-register paths and detailed timing analysis for the selected path (as shown in the figure below). Note that
all the slack values are positive, indicating that there are no setup time violations
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Figure 51 - SmartTime Register to Register Delay

4. Double-click a path row to open the Expanded Path window. The window shows a calculation of the data
arrival and required times along with a schematic of the path (as shown in the figure below).

Note: The Timing Numbers in these reports may vary slightly with different versions of the Libero Software, and
may not be exactly the same as what you will see when you run the tutorial.
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Figure 52 - Register-to-Register Expanded Path View

5. Select External Setup to display the Input to Register timing. Select Path 3. The Input Arrival time from the

EN pin to Q_int[27]:EN is 4.547 ns (as shown in the figure below).
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Figure 53 - SmartTime - Input to Register Path Analysis

6. Select Clock to Output to display the register to output timing. Select Path 1. The maximum clock to output

time from Q_int[16]:CLK to Q[16 ] is 9.486ns .
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Figure 54 - SmartTime Clock to Output Path Analysis

Minimum Delay Analysis with Timing Analyzer - 32-Bit Shift
Register Example
The SmartTime Minimum Delay Analysis window identifies any hold violations that exist in the design.

To perform Minimum Delay Analysis:

1. From the SmartTime Analysis window, choose Tools > Minimum Delay Analysis. The Minimum Delay
Analysis View appears, as shown in the figure below.
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Figure 55 - SmartTime Minimum Delay Analysis View- Summary

External Removal and Asynchronous to Register path sets.

Expand my_clk to display Register to Register, External Hold, Clock to Output, Register to Asynchronous,

Click Register to Register to display the reg to reg paths. The window displays a list of register to register

paths and detailed timing analysis for the selected path. Note that all slack value are positive, indicating that
there are no hold time violations.

Click to select the first path and observe the hold analysis calculation details, as shown in the figure below.
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Figure 56 - SmartTime Minimum Delay Analysis
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Changing Constraints and Observing Results - 32-Bit Shift
Register Example

You can use the Constraints Editor to change your constraints and view the results in your design. To do so:

1. Open the Constraints Editor (Constraints Manager > Timing Tab > Edit Constraints with Constraint
Editor > Edit Timing Verifications Constraints).

The Constraints Editor displays the clock constraint at 250 MHz that you entered earlier.

I Contapirts Editor =
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4 Conuints . = — --..‘. -— - -
& Bequrements Syl Chock Masne hock Sounce Period fas) | TrESEERCY W:H FstEdge | OMset (ns)
T Clotk
Geneated Clock [ T S W e o | .0% g = o
Fpist Doty = L L [petporm (0K} ] 000 0000 S0/500000 g - 2000

Cutpeet Deley:
Estermad Chach
Cheek T Out

sceptions
Max Delay
M Dy

4

Multicycle
Falie Path
4 Advenced
Dreabide Temeng
Cleck Source Latenssy
Clock Uncedaendy il
Flowck finmams
- ¥ . " '

Figure 57 - Clock Constraint Set to 250 MHz

2. Select the second row. Right click and choose Edit Clock Constraint. This opens the Edit Clock Constraint
dialog box. Change the clock constraint from 250 MHz to 800 MHz and click the green check mark to
continue.

3. Click Open SmartTime > Open Interactively.
4. Choose Maximum Delay Analysis View to view the max delay analysis.

5. Expand my_clk in the Maximum Delay Analysis window. Click Register to Register to observe the timing
information. Note that the slacks decrease after you increase the frequency. You may see the slacks go
negative indicating Timing Violations. Negative slacks are shown in red.
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Figure 58 - Maximum Delay Analysis After Setting Clock Constraint to 800 MHz
Note: The actual timing numbers you see may be slightly different.
6. Close SmartTime. Click No when prompted to save changes.

Tutorial 2 - False Path Constraints

This section describes how to enter false path constraints in SmartTime. You will import an RTL source file from
the design shown below. After routing the design, you will analyze the timing, set false path constraints, and
observe the maximum operating frequency in the SmartTime Timing Analysis window.

:.-.;\L—:

"Rz XOR2

02_rey

Figure 59 - Example Design with False Paths

Set Up Your False Path Example Design Project

1. Open Libero and create a new project (from the Project menu, choose New Project).

2. Name the project false_path and set the project location according to your preferences. Click Next. Enter
the following values for your Device Selection settings:

e Family: SmartFusion2
e Die: M2S050
e Package: 484 FBGA
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e Speed: STD
e Die Voltage: 1.2V
e Range: COM
3. Click Finish to create the new project.

Import the false path Verilog File and Add Constraints

You must import the false_path.v Verilog source file into your design for this tutorial.
Then run Libero SoC.

To import the Verilog Source File:

1. From the File menu, choose Import > HDL Source Files.

2. Browse to the location of the false_path.v you saved and select it. Click Open to import the file.
3.  Verify that the file appears in Design Hierarchy
4

In the Design Flow window, double-click Synthesize to run synthesis. A green check mark appears when
the Synthesis step completes successfully.

Expand Edit Constraints. Right-click Timing Constraints and choose Open Interactively.

6. Double-click on Manage Constraints. Select the Timing tab, pull down the Edit with Constraint Editor
sub-menu, and select the "Edit Place and Route Constraints". The Constraints Editor will open.

7. Double-click on the Requirements: Clock and the Create Clock Constraint dialog box will open.
8. Double click the browse button for Clock Source, and select CLK; name it clk (or whatever you want).
9. Set the frequency to be 100 MHz.

o

" k Cor Ealba

Clock Mame : |dk Clock Source : |[gEtJJDrtS {CLK}] EI

I'—Period =10 ns — My Frequency: 100 Mhz

4

=|

e Offset: g Dutyoyde:

0.000 ns 50,0000 %

[ Add this dock to existing one with same source

Comment : |

Help OK. | Cancel |

Figure 60 - Clock constraint of 100MHz

e Click OK to return to the Constraints Editor and observe that the clock information has been filled in as
shown in the figure below.

B CometrainasEditon « IConst sints. Efitos]

Symtax Clock Name CiockSource  Perod (ms) 'w “‘:ﬁ‘g"’ Frsttdge | Offset(m) Wravetorm
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Figure 61 - Clock Constraint of 100 MHz in false_path design
10. Save your changes (File > Save) and close the Constraints Editor (File > Close).
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11. Inthe Constraint Manager, check the checkbox under Place and Route and the checkbox under Timing
Verification to associate the constraint file to both tools. The constraint file is used for both Place and Route
and Timing Verification.

Place and Route Your FALSE PATH Design

To run Place and Route on false_path design:
1. InLibero SoC, right-click Place and Route and choose Configure Options.

W7 Layout Options (= =]
[+ Timing-driven
[ Power-driven
| 1jo Register Combining
¥ Global Pins Demotion
[ Driver Replication
[ High Effort Layout

Iv Repair Minimum Delay Violations

[ Incremental Layout

| Usze Multiple Passes

Configure...

Help Ok Cancel

Figure 62 - Layout Options Dialog Box

2. Click the checkbox to enable Timing-Driven layout in Layout Options and leave the other values unchecked.
Click OK to close the Layout Options dialog box.

3. Right-click Place and Route and choose Run.

A green check mark appears next to Place and Route in the Design Flow window when Place and Route
completes successfully.
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Design Flow
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Figure 63 - Synthesize and Place and Route Successful Completion

Timing Analysis - Maximum Clock Frequency

The SmartTime Maximum Delay Analysis View displays the design maximum operating frequency and lists any
setup violations.

To perform Maximum Delay Analysis:

1. Expand Verify Post Layout Implementation. Right-click Open SmartTime and choose Open
Interactively to open SmartTime. The Maximum Delay Analysis View appears (as shown in the figure
below). The Maximum Delay Analysis View displays a summary of design performance and indicates that
the design will operate at a maximum frequency of 442.48 MHz.

Note: You may see a slightly different maximum frequency with a different version of Libero SoC.
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Figure 64 - Maximum Delay Analysis Summary

2. Expand clk to expand the display and show the Register to Register path sets.
3. Select Register to Register to display the register-to-register paths. Notice that the slack values are

positive.

4. Double-click to select and expand the row in the path list with the path is from the CLK pin of flip-flop
DO_reg to the D input of flip flop Q_reg. Note that the path goes through the S input of multiplexer

unl_MUX2.

Figure 65 - Expanded Path
Looking at the code in false_path.v, we can see on lines 51 and 52, that DO_reg and D)_inv_reg are always the
inverse of each other in "operational" mode (i.e., except for when RST is active). Line 56 says that XOR2 is the
XOR of these two signals, and hence always 1 (again, except for when RST is active). And finally line 59 says

that XOR?2 is the select of MUX2.
We might reasonably decide that we are not interested in the reset mode delay for this design; and hence this
path is a false path for our timing analysis purposes.
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DO reg <= 1'bd;
DO inv_reg <= 1'k0;
d
ze
gin
DO reg <= D0;:
DO inv _reg <= ~DO:
d
XOR2 = DO reg * DO inv reg;
OR2 = DO inv reg || D1 _reg:
END2 = QOR2 && D2 reg;
MOXZ2 = (¥MOR2) ? (D2 reg) (BHDZ) ;

Figure 66 - Analyzing the false paths
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Similar analysis shows that the path from DO_inv_reg:CLK to Q_reg:D shares exactly the same false-path
characteristic. We should disable both paths.

5.

Re-start the Libero Constraints Editor. The Constraints Editor must be running in order for us to use the

back-annotation feature of StartTime. Go to the Constraint Manager tab, Timing sub-tab; and again pull
down the "Edit with Constraint Editor" , and choose "Edit Timing Verification Constraints".

Leave this running and go back to SmartTime. From the Tools menu select Max Delay Analysis.
To set the path from DO_inv_reg:CLK to Q_reg :D as false, select the row containing this path in the

Register to Register path set, right-click and choose Add False Path Constraint (as shown in the figure
below). The Set False Path Constraint dialog box appears (it may pop-behind; check other Constraint

Manager windows).

[ smartTime « [Masicren Dielay Anafysis View]
m File Edit View Tools  Help
MaD Dk e

Maxanum Delay Analyss Vew

@ R

== E

Lﬂ Analysis for scenar
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* Register 1o Regiser
Extemal Setup

=

dd False Path Constraint
Aca M Delay Constraimt Ly
4 Min Deley Constraint
Add Multicycle Path Constraint

0.067,

Expand selected paths

Figure 67 - Right-Click > Add False Path Constraint

.07
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Figure 68 - Set False Path Constraint Dialog Box
8. Click OK to close the Set False Path Constraint dialog box.

9. Check the Constraints Editor window, there should now be an entry under Exceptions > False Path

10. Return to the SmartTime window and repeat for the DO_reg:CLK -> Q_reg:D path.

11. Since we are only interested in timing analysis through the MUX when select = 1, we can also ignore the

MUX "0" path from D1_reg:D through the AND2. We make this a false path, also.

12. Atthis point the Constraints Editor should now look as follows. Save the file and exit the Constraints Editor

and SmartTime.
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Figure 69 - False Path Constraints in the SmartTime Constraint Editor

13. Place and Route is now invalidated, and needs to be re-run before we can do timing analysis again. This is
because we have changed the constraint file that we are using for both P&R and for Timing Analysis. It is
possible to use different constraint files, in which case we would not need to re-run P&R.

14. Right-click on Open SmartTime and choose Update and Open Interactively. You will see that Place and
Route is run automatically before SmartTime is re-started.

15. View the summary in the Maximum Delay Analysis View (Tools > Max Delay Analysis). Note that
SmartTime now reports the maximum operating frequency as 586.17 MHz, as shown in the figure below.

Note: The maximum operating frequency may vary slightly with a different version of the Libero software.
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Figure 70 - Maximum Delay Analysis View - Summary

16. Select the Register to Register set for my_clk. Observe that only one path is visible, from D2_reg: CLK to
Q_reg:D. This is the only path that propagates a signal (as shown in the figure below).
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Figure 71 - Maximum Delay Analysis View - Register to Register
17. Close SmartTime.
18. Close Libero SoC.
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false path.v

1177777777777 777/77/77/777777/7/777/77/77/777/77777/77/777 77
Company: Microsemi Corp

//

// File history:

// 0.1 Initial Version
//

// Description:

// Simple example design to demonstrate use of timing // constraints.
//

// Targeted device: Family::SmartFusion2; Die::M2S050;

// Package::484 FBGA;

//

// Author: Joe X // //

//

/1777777777777 7/77/777777777777/77/77/77/777/77/7/77/77/777

module false path (DO, D1, D2, RST, CLK, Q);

input DO;

input D1;

input D2;

input RST;

input CLK;

output Q;

reg DO_reg;

reg DO_inv_reg;

reg D1 reg;

reg D2_req;

reg Q _reg;

wire XOR2 /*synthesis syn_keep=1*/;
wire AND2 /*synthesis syn_ keep=1*/;
wire OR2 /*synthesis syn_keep=1*/;
wire MUX2 /*synthesis syn_keep=1*/;
wire NOT1 /*synthesis syn_ keep=1*/;
wire NOT2 /*synthesis syn_keep=1*/;

assign Q = Q_reg /*synthesis syn_keep=1*/;

always @(posedge CLK or posedge RST)
begin
if (RST)
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end

begin
DO _reg <= 1"b0;
DO_i1nv_reg <= 17bO0;
end
else
begin
DO_reg <= DO;
DO_inv_reg <= ~DO;
end

assign XOR2
assign OR2
assign AND2
assign MUX2

DO_reg ™ DO_inv_reg;
DO_inv_reg || D1_regq;

OR2 && D2_reg;

(XO0R2) ? (D2_reg) : (AND2);

always @(posedge CLK)
begin
D1 reg <= D1;
D2_reg <= D2;

Q_reg <= NOTZ;
end

not ul (NOT1, MUX2);
not u2 (NOT2, NOT1);

endmodule
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Dialog Boxes

Add Path Analysis Set Dialog Box

Use this dialog box to specify a custom path analysis set.

Note: The Analysis menu is available only in Maximum or Minimum Delay Analysis view.

To open the Add Path Analysis Set dialog box (shown below) from the SmartTime Timing Analyzer, choose any

path and right click to select Add Set

17 Add Path Analysis Se =]
Name :- | Trace from :- ©* Source tosink  Sink to source
Source pins: Sink Pins:

DFNT_iCLE
DFNT_1:CLE
PF_CCC_CO_0/PF_CCC_C0 0/pll_inst_0:REF_CLK_0
Select all Select all

Filter source pins: — Filter sink pins:

Pin Type: ]Registers by pin names j Pin Type: |Regi5ters by pin names ﬂ
= Filter |= Filter

Help 0K | Cancel |

Figure 72 - Add Path Analysis Set Dialog Box

Name
Enter the name of your path set.

Trace from

Select whether you want to trace connected pins from Source to sink or from Sink to source. By default, the

pins are traced Source to sink.
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Source Pins

Displays a list of available and valid source pins. You can select multiple pins. To select all source pins, click the
Select All button beneath the Source Pins list.

Select All

Selects all the pins in the Source Pins list to include in the path analysis set.

Filter Source Pins

Enables you to specify the source Pin Type and the Filter. The default pin type is Registers by pin name. You
can specify any string value for the Filter. If you change the pin type, the Source Pins shows the updated list of
available source pins.

Sink Pins

Displays list of available and valid pins. You can select multiple pins. To select all source pins, click the Select All
button beneath the Sink Pins list.

Select All

Selects all the pins in the Sink Pins list to include in the path analysis set.

Filter Sink Pins

Enables you to specify the sink Pin Type and the Filter. The default pin type is Registers (by pin). You can
specify any string value for the Filter. If you change the pin type, the Sink Pins shows the updated list of
available sink pins.

Analysis Set Properties Dialog Box

Use this dialog box to view information about the user created set.

To open the Analysis Set Properties dialog box (shown below) from the Timing Analysis View, right-click any
user-created set in the Domain Browser, and choose Properties from the shortcut menu.

3 vt St Propert =]
Mame : |ss
Parent set : |
From : |IF:‘,i 1 1:0L¥ PF_CCC_C0_0/PF_CCC_CO0_0/pll inst D:REF_CLK 0
To: | 0/PF_CCC_CO_0/pll_inst_:REF_CIK_0DFM1_1:CLKDFN1_1:D
Help COK. Cancel

Figure 73 - Analysis Set Properties Dialog Box

Name
Specifies the name of the user-created path set.

Parent Set
Specifies the name of the parent path set to which the user-created path set belongs.
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Creation filter

From
Specifies a list of source pins in the user-created path set.

To

Specifies a list of sink pins in the user-created path set.

Edit Filter Set Dialog Box

Use this dialog box to specify a filter.

To open the Edit Filter Set dialog box (shown below) from the SmartTime Max/Min Delay Analysis view, right-
click an existing filter set in the clock domain browser, and then choose Edit Set from the shortcut menu.

Name

CoreAHBLite_0/matrodxl6/masterstage 0/D EFSLAVEDATASI:I
CoreAHBLite_0/matrixdx16/masterstage_0/DEFSLAVEDATAS
CoreAHBLite_0/matrixdx16/masterstage_0/DEFSLAVEDATAS
CoreAHBLite_0/matrixdx16/masterstage_0/DEFSLAVEDATAS
CoreAHBLite_0/matrixdx16/masterstage_0/DEFSLAVEDATAS
CoreAHBLite_0/matrixdx16/masterstage_0/DEFSLAVEDATAS
CoreAHBLite_0/matrixdx16/masterstage_0/DEFSLAVEDATAS
CoreAHBLite_0/matrixdx16/masterstage_0/DEFSLAVEDATAS
CoreAHBLite_0/matrixdx16/masterstage_0/DEFSLAVEDATAS
CoreAHBLite_0/matrixdx16/masterstage_0/DEFSLAVEDATAS
CoreAHBLite_0/matrixdx16/masterstage_0/DEFSLAVEDATAS
CoreAHBLite_0/matrixdx16/masterstage_0/DEFSLAVEDATAS
CoreAHBLite_0/matrixdx16/masterstage_0/DEFSLAVEDATAS
CoreAHBLite_0/matrixdx16/masterstage_0/DEFSLAVEDATAS
CoreAHBLite_0/matrixdx16/masterstage_0/DEFSLAVEDATAS
CoreAHBLite_0/matrixdx16/masterstage_0/DEFSLAVEDATAS
CoreAHBLite_0/matrixdx16/masterstage_0/DEFSLAVEDATAS
CoreAHBLite_0/matrixdx16/masterstage_0/DEFSLAVEDATAS
CoreAHBLite_0/matrixdx16/masterstage_0/DEFSLAVEDATAS
CoreAHBLite_0/matrixdx16/masterstage_0/DEFSLAVEDATAS
CoreAHBLite_0/matrixdx16/masterstage_0/DEFSLAVEDATAS _

#| Edit Path Analysis Set [
MName - |my_setl Trace from :- @ Source to sink () Sink to source
Source pins: Sink Pins:

CFGO_GMND_INST:Y = | | SerDes_AHBBUS_0/PCIE_SERDES_IF_0/SERDESIF_INST RNO_ -

SerDes AHBBUS_0/PCIE_SERDES_IF_0/5ERDESIF_INST_RNO_
SerDes AHBBUS 0/PCIE_SERDES_IF_0/5ERDESIF_INST_RNO_
SerDes AHBBUS 0/PCIE_SERDES_IF_0/5ERDESIF_INST_RNO_
SerDes AHBBUS 0/PCIE_SERDES_IF_0/5ERDESIF_INST_RNO_
SerDes AHBBUS 0/PCIE_SERDES_IF_0/5ERDESIF_INST_RNO_
SerDes AHBBUS_0/PCIE_SERDES_IF_0/5ERDESIF_INST_RNO_
SerDes AHBBUS_0/PCIE_SERDES_IF_0/5ERDESIF_INST_RNO_
SerDes AHBBUS 0/PCIE_SERDES_IF_0/5ERDESIF_INST_RNO_
SerDes AHBBUS 0/PCIE_SERDES_IF_0/5ERDESIF_INST_RNO_
SerDes AHBBUS 0/PCIE_SERDES_IF_0/5ERDESIF_INST_RNO_
SerDes AHBBUS 0/PCIE_SERDES_IF_0/5ERDESIF_INST_RNO_
SerDes AHBBUS 0/PCIE_SERDES_IF_0/5ERDESIF_INST_RNO_
SerDes AHBBUS 0/PCIE_SERDES_IF_0/5ERDESIF_INST_RNO_
SerDes AHBBUS 0/PCIE_SERDES_IF_0/5ERDESIF_INST_RNO_
SerDes AHBBUS 0/PCIE_SERDES_IF_0/5ERDESIF_INST_RNO_
SerDes AHBBUS 0/PCIE_SERDES_IF_0/5ERDESIF_INST_RNO_
SerDes AHBBUS 0/PCIE_SERDES_IF_0/5ERDESIF_INST_RNO_
SerDes AHBBUS 0/PCIE_SERDES_IF_0/5ERDESIF_INST_RNO_
SerDes AHBBUS 0/PCIE_SERDES_IF_0/5ERDESIF_INST_RNO_
SerDes AHBBUS 0/PCIE_SERDES_IF_0/5ERDESIF_INST_RNO_
SerDes AHBBUS_0/PCIE_SERDES IF_0/SERDESIF_INST RNO_

e ALIDI 4m N fmm et A & femm mcb e~ MIMCEC] AVUEMATAC CrelM~- ALIDDIIC N/NSTC CCONECS TC ASCCONECCTC TRICT DRI

4| [ | * < | 1 | &
Select Al Select Al

Filter source pins: Filter sink pins:

Pin Type: [AII pins v] Pin Type: [AII pins v]
= =

o] o)

Figure 74 - Edit Path Analysis Set Dialog Box

Specifies the name of the path you want to edit.

Creation filter

Source Pins - Displays a list of source pins in the user-created path set.
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Sink Pins - Displays a list of sink pins in the user-created path set.

See Also
Using filters

Customize Analysis View Dialog Box

Use this dialog box to customize the timing analysis grid.
To open the Customize Analysis View dialog box (shown below) from the SmartTime Max/Min Delay Analysis

g File Edit View Tools Help

e Y9xce @@=

Wi Doy Analysia Ve
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View, click the Customize table button (circled in red in the figure below) in the Max/Min Delay Analysis View.

|
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Figure 75 - Customize Table Button
The Customize Paths List Table Dialog Box appears.

5| Customize Paths List Table

(2 lomtom|

Available fields:

iClock

Source Clock Edge
Destination Clock Edge
Legic Stage Count
Clock Constraint (ns)
Multicycle Constraint

ove

Mowve Up

ek

Mowe Down

Help | [Restore Default]

Show these fields in this order:

Source Pin
Sink Pin
Delay

(ns)

Slack (ns)
Arrival (ns)
Required (ns)
Hold (ns)
Skew (ns)

][ Cancel

Available Fields

Figure 76 - Customize Paths List Dialog Box

Displays a list of all the available fields in the timing analysis grid.
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Show These Fields in This Order

Shows the list of fields you want to see in the timing analysis grid. Use Add or Remove to move selected items
from Available fields to Show these fields in this order or vice versa. You can change the order in which these
fields are displayed by using Move Up or Move Down.

Restore Defaults
Resets all the options in the General panel to their default values.

Manage Clock Domains Dialog Box

Use this dialog box to specify the clock pins you want to see in the Expanded Path view.
To open the Manage Clock Domain dialog box (shown below) from the SmartTime Max/Min Delay Analysis view,

. L
click the * icon.

= reC (=]
Available dodk domains: Show the dodk domains in this order:
:DQS[2] " Add Das[0]
PLL_REF_CLK Das[1]
ddr_x32_0/CCC_0/pll_inst_0/OUTY Das[3]
ddr_x32_0/CCC_0/pll_inst_0/0UT2 Move Down | | ddr_x32 0/DDRPHY_BLE_0/10D_TRAIMING_0/CC

ddr_x32 0/CCC_0/pll_inst 0/0UT3

ddr_x32_0/DDRPHY_BLK_0/I0OD_TRAINING_0;
ddr_x32_0/DDRPHY_BLK_0/IOD_TRAINING_0; Move Up
ddr_x32_0/DDRPHY_BLK_0/10D_TRAINING_0;
ddr_x32_0/DDRPHY_BLK_0/IOD_TRAINING_0;
ddr_x32_0/DORPHY_BLK_0/IOD_TRAINING_0; Remove

< > < >

Help Mew Clock 0K Cancel

Figure 77 - Manage Clock Domains Dialog Box

Available Clock Domains

Displays alphanumerically sorted list of available clock pins. The first clock pin is selected by default.

Show the Clock Domains in this Order

Shows the clock pins you want to see in the Expanded Path view. Use Add or Remove to move selected items
from Available clock domains to Show the clock domains in this order or vice versa. You can change the
order in which these clock pins are displayed by using Move Up or Move Down.

New Clock

See Also
Managing Clock Domains

Set False Path Constraint Dialog Box

Use this dialog box to define specific timing paths as being false.
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This constraint removes timing requirements on these false paths so that they are not considered during the
timing analysis. The path starting points are the input ports or register clock pins and path ending points are the
register data pins or output ports. This constraint disables setup and hold checking for the specified paths.

Note: The false path information always takes precedence over multiple cycle path information and overrides
maximum delay constraints.

To open the Set False Path Constraint dialog box (shown below) from the SmartTime Constraints Editor, choose
Constraints > Exceptions False Path > Add False Path Constraint.

i t S
From :
Through :
To:
Comment : |
Help oK Cancel

Figure 78 - Set False Path Constraint Dialog Box

From
Specifies the starting points for false path. A valid timing starting point is a clock, a primary input, an input port, or
a clock pin of a sequential cell.

Through
Specifies a list of pins, ports, cells, or nets through which the disabled paths must pass.

To

Specifies the ending points for false path. A valid timing ending point is a clock, a primary output, an input port, or
a data pin of a sequential cell.
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ide comments for this constraint.

SmartTime Options Dialog Box

General

Use this dialog box

to specify the SmartTime options to perform timing analysis.

This interface includes the following categories:

e General
e Analysis
e Advanced

To open the SmartTime Options dialog box (shown below) from the SmartTime tool, choose Tools > Options.

. FIs
Option Categories General
= Select a categony:
Genesal Operating Conditions
Anatyis. Perform maxmum delay analyses based on | WORST ¥ | case
Advanced
Perform minimum  delay analysis based on | BEST ¥ case
Clock Domains
[#] Indiude inter-clock domains in caloulations for timing analyss,
[+] Ermable recovery snd removal checks.
Restore Defaults
Help oK Cancel

Figure 79 -

SmartTime Options- General Dialog Box for SmartFusion2, IGLOO2 and RTG4
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Olack Domains

¥ Enable recovery and removal chedks,

Option Categories _I Ganaral
=1 Select a category:
Generzl Operating Conditions
Analysis
Advanced Perform maximum delay analysis based on I:ﬂm\_h-'_ht j case
Perform minimum  delay analysis based on |Fast_h\.-_lt | case

W Indude inter-dodk domains in calculations for timing analysis,

o | cancd |

Figure 80 - SmartTime Options - General Dialog Box for PolarFire

Operating Conditions

Allows you to perform maximum or minimum delay analysis based on the Best, Typical, or Worst case. By default,
maximum delay analysis is based on WORST case and minimum delay analysis is based on BEST case.

Clock Domains

e Includeinter-clock domains in calculations for timing analysis: Enables you to specify if SmartTime
must use inter-clock domains in calculations for timing analysis. By default, this option is unchecked.

e Enable recovery and removal checks: Enables SmartTime to check removal and recovery time on
asynchronous signals. Additional sets are created in each clock domain in Analysis View to report the

corresponding paths.

Restore Defaults
Resets all the options in the General panel to their default values.
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Analysis
¥ =
[ Otion C e Analyss view
=l Select a category: Display of Paths
General
.ﬂnu|}r3|5
Limit the number of paths shown in 8 path set to: 100

Advanced
[l Fiter the paths by sladk value

Sladc range from: ns to: ns

[ Show dock network details n expanded path

Limit the number of parallsl paths in expanded path to: 1

Restore Defaults

Figure 81 - SmartTime Options - Analysis View Dialog Box

Display of Paths

Limits the number of paths shown in a path set for timing analysis. The default value is 100. You must specify a
number greater than 1.

Filter the paths by slack value
Specifies the slack range between minimum slack and maximum slack. This option is unchecked by default.

Show clock network details in expanded path
Displays the clock network details as well as the data path details in the Expanded Path views.

Limit the number of parallel paths in expanded path to: For each expanded path, specify the maximum
number of parallel paths that SmartTime displays. The default number of parallel paths is 1.

Restore Defaults
Resets all the options in the Analysis View panel to their default values.
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Advanced

Option Categories

=I- Select a category:
| General
Analysis
Advanced

_ree |

Advanced

Spesial Siutatons
I Use opbad: in bi-directional buffers(bbufs)
I Break paths at asynchronous pins

¥ Disable non-unate arcs in dock nebwork
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Restore Defaults

ok | con |

Figure 82 - SmartTime Options - Advanced Dialog Box

Special Situations

Enables you to specify if you need to use loopback in bi-directional buffers (bibufs) and/or break paths at

asynchronous pins.

Scenarios

Enables you to select the scenario to use for timing analysis and for timing-driven place-and-route.

Restore Defaults
Resets all the options in the Analysis View panel to their default values.

Create Filter Set Dialog Box

Use this dialog box to specify a filter.

To open the Create Filter Set dialog box (shown below) from the SmartTime Timing Analyzer, select a path and
click the Store Filter button in the Analysis View Filter.

Name:l

(7 [=]

Help

| oK

Cancel |

Figure 83 - Create Filter Set Dialog Box
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Name
Specifies the name of the filtered set.

See Also
Using filters

Timing Bottleneck Analysis Options Dialog Box

Use this dialog box to customize the timing bottleneck report.
You can set report bottleneck options for the following categories:
e General pane
e Bottleneck pane
e Sets pane

To open the Timing Bottleneck Analysis Options dialog box (shown below) from the SmartTime tool, choose
Tools > Bottleneck Analysis.

General Pane

7| Timing Bottleneck Analysis Option

Option Categories

General

4 Select a category:
General
Bottleneck
Sets

Slack
Maximum slack to indude [i} ns

Restore Defaults ]
o) )

Figure 84 - Timing Bottleneck Report - General Pane Dialog Box

Slack

Let's you specify whether the reported paths will be filtered by threshold, and if so what will be the maximum slack
to report. By default the paths are filtered by slack, and the slack threshold is 0.

Restore Defaults
Resets all the options in the General pane to their default values.
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Bottleneck Pane

| Timing Bottleneck Analysis Options @lg?j

Option Categories Bottleneck options

4 Select a category:
- Cost Type: Path Count -
Bottleneck 2

Sets
Limit the number of paths per section to: 100

Limit the number of parallel paths per section to:

Limit the number of reported instances to: 10

o) o)

Figure 85 - Timing Bottleneck Report - Bottleneck Pane Dialog Box

Bottleneck Options

Cost Type: Select the cost type that SmartTime will include in the bottleneck report. By default, path count is
selected. You may select one of the following two items from the drop-down list:

e Path count: This cost type associates the severity of the bottleneck to the count of violating/critical paths
that traverse the instance. This is the default.

e Path cost: This cost type associates the severity of the bottleneck to the sum of the timing violations for the
violating/critical paths that traverse the instance.

Limit the number of paths per section to: Specify the maximum number of paths per set type that SmartTime
will include per section in the report. The default maximum number of paths reported is 100.

Limit the number of parallel paths per section to: For each expanded path, specify the maximum number of
parallel paths that SmartTime will include in the report. Only cells that lie on these violating paths are reported.
The default number of parallel paths is 1.

Limit the number of reported instances: Specify the maximum number of cells that SmartTime will include per
section in the report. The default number of cells is 10.

Restore Defaults
Resets all the options in the Bottleneck panel to their default values.
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Sets Pane R e
# | Timing Bottleneck Analysis Option: = =
- . Bottleneck oplions
Option Categories Set Selection

4 Select a category:

General (@ Entire design
ST () Clock Domain
Sets

Clock:

Type:

(71 Use existing user set

Mame: my_set
) Use Input to Qutput Set

Filter

From:

To:

[ OK ][ Cancel ]

Figure 86 - Timing Bottleneck Report - Sets Pane Dialog Box
This pane has four mutually exclusive options:
e Entire Design
e Clock Domain
e Use existing user set
e Use Input to Output Set
Entire Design: Select this option to display the bottleneck information for the entire design.

Clock Domain: Select this option to display the bottleneck information for the selected clock domain. You can
specify the following options:

e Clock: Allows pruning based on a given clock domains. Only cells that lie on these violating paths are
reported.

e Type: This option can only be used in conjunction with -clock. The acceptable values are:

Value Description

Register to Register

Paths between registers in the design

Asynchronous to Register

Paths from asynchronous pins to registers

Register to Asynchronous

Paths from registers to asynchronous pins

External Recovery

The set of paths from inputs to asynchronous pins

External Setup

Paths from input ports to register

Clock to Output

Paths from registers to output ports

Use existing user set: Displays the bottleneck information for the existing user set selected. Only paths that lie
within the name set are will be considered towards the bottleneck report.
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Filter: Allows you to filter the bottleneck report by the following options:
¢ From: Reports only cells that lie on violating paths that start at locations specified by this option.
e To: Reports only cells that lie on violating paths that end at locations specified by this option.
Filter defaults to all outputs.

Restore Defaults
Resets all the options in the Paths panel to their default values.

See Also
Bottleneck Analysis

Timing Datasheet Report Options Dialog Box

Use this dialog box to select the output format for your timing datasheet report.

To open the Timing Datasheet Report Options dialog box (shown below) from the SmartTime Max/Min Delay
Analysis view, choose Tools > Reports > Datasheet.

You can generate your report in one of two formats:

Plain Text
Select this option to save your report to disk in plain ASCII text format.

Comma Separated Values

Select this option to save your report to disk in comma-separated value format (.CSV) format, which you can
import into a spreadsheet.

Option Categories
~v Select a category: Fmat
General
(®) Plain Text () Comma Separated Values
oK Cancel
Help

Figure 87 - Report Options Dialog Box
Note: This Datasheet Report feature is not supported for PolarFire.
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Timing Report Options Dialog Box
Use this dialog box to customize the timing report.
You can set report options for the following categories:

To

General
Paths
Sets
Clock Domains
open the Timing Report Options dialog box (shown below) from the SmartTime Max/Min Delay Analysis View,

choose Tools > Reports> Timer.

General

Option Categories |

—I Select a category:
General
Paths
Sets (* Plain Text " Comma Separated Values
Clock Domains

Format

Summary
Iv Indude a summary of timing results in this report

Slack
[ Filter paths by slack threshald

Maximum slack to indude 0 ns

Help

Figure 88 - Timing Report Options - General Dialog Box

Format

Specifies whether or not the report will be exported as a Comma Separated Value (CSV) file or a plain text
file. By default, the Plain Text option is selected.

Summary
Specifies whether or not the summary section will be included in the report. By default, this option is selected.

Analysis

Specifies the type of analysis to be included in the timing report. It can be either a Maximum Delay Analysis
report or Minimum Delay Analysis report. By default, the Maximum Delay Analysis report is included in the
timing report.

Slack

Specifies whether the reported paths will be filtered by threshold, and if so what will be the maximum slack to
report. By default, the paths are not filtered by slack.
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Paths

Option Categories |
-1 Select a category: Display of paths

General

Paths

Sets W Indude detailed path information in this report

Clock Domains

Limit the number of paths per section to:

Limit the number of expanded paths per section to:

1

Limit the number of parallel paths in expanded path to: ‘

Help

Figure 89 - Timing Report Options - Paths Dialog Box

Display of Paths

Include detailed path information in this report: Check this box to include the detailed path information in the
timing report.

Limit the number of reported paths per section to: Specify the maximum number of paths that SmartTime will
include per section in the report.

Limit the number of expanded paths per section to: Specify the maximum number of expanded paths that
SmartTime will include per section in the report.

Limit the number of parallel paths in expanded path to: For each expanded path, specify the maximum
number of parallel paths that SmartTime will include in the report. The default number of parallel paths is 1.
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Sets

Option Categories i |
=I- Select a category: e
General
| Paths [~ Indude user sets in this report
Sets

Clock Domains

| [+ Indude Input to Output sets in this report

Help

Display of Sets
Specifies whether or not the user sets will be included in the timing report.

User sets are either filters that you have created and stored on the default paths sets (Register to Register, Inputs
to Register, etc.) or Pin to Pin user sets. By default, the paths for these sets are not reported.

In addition, specify whether the Inputs to Output sets will be included in the report. By default, the Input to Output
sets are reported.

88



& Microsemi

a AS\MicRocHIP company

Generic User Guide

Clock Domains

Option Categories |
-l Select a category: Display of Clock Domains
i General
| Paths
Sets [v Indude dock domains

Clock Domains

[¥ Limit reporting on dock domains to specified domains

| CLK Select Domains |
CLE_RNIQOS2/UDY.5
BLOCK_INTERFACE_|_CLK:A
CLE_RNIQOS2/Ul:Y.5
CLK_RNIQO%2/U0_RGE1:Y.1
CLE_RNIQOS2/U0_RGE1:Y.4
CLK_RNIQOS2/U0_RGE1:Y.6
CLE_RMNIQOS2:A

! CLE_RNIQOS2:Y

Help ‘

Figure 91 - Timing Report Options - Clock Domains Dialog Box

Display of Clock Domains

Let’s you specify what clock domains will be included in the report. By default, the current clock domains used by
the timing engine will be reported.

Include Clock Domains
Enables you to include or exclude clock domains in the report. Click the checkbox to include clock domains.

Limit reporting on clock domains to specified domains
Let’s you include one or more of the clock domain names in the box, or include additional clock domain names
using Select Domains.

See Also

Generating a datasheet report
Understanding datasheet reports

Timing Violations Report Options Dialog Box

Use this dialog box to customize the timing violation report.
You can set report violation options for the following categories:
e General
e Paths

To open the Timing Report Options dialog box (shown below) from the SmartTime tool, choose Tools > Reports
> Timing Violations.
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General
]
Option Categories General
—I Select a categony: ot
General
Paths
{* Plain Text (" Comma Separated Values
-Slack
Iv Filter paths by slack threshold
Maximum slack to indude 0 ns
| Restore Defaults |
Help CK | Cancel |
Figure 92 - Timing Violations Report - General Dialog Box
Format

Specifies whether or not the report will be exported as a Comma Separated Value (CSV) file or a plain text file. By
default, the Plain Text option is selected.

Analysis

Let’s you specify what type of analysis will be reported in the report. By default, the report includes Maximum
Delay Analysis.

Slack

Let’s you specify whether the reported paths will be filtered by threshold, and if so what will be the maximum slack
to report. By default the paths are filtered by slack, and the slack threshold is 0.

Restore Defaults
Resets all the options in the General panel to their default values.
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Paths
# | Timing Violations Re EE
Option Categories Display of paths
4 Select a category:
General Limit the number of reparted paths
Paths
Limit the number of paths per section to: 100

Limit the number of expanded paths per section to:

Limit the number of parallel paths in expanded path to:

o) o)

Figure 93 - Timing Violations Report - Paths Dialog Box

Display of paths

Limit the number of reported paths: Check this box to limit the number of paths in the report. By default, the
number of paths is limited.

Limit the number of paths per section to: Specify the maximum number of paths that SmartTime will include
per section in the report. The default maximum number of paths reported is 100.

Limit the number of expanded paths per section to: Specify the maximum number of expanded paths that
SmartTime will include per section in the report. The default number of expanded paths is 0.

Limit the number of parallel paths in expanded path to: For each expanded path, specify the maximum
number of parallel paths that SmartTime will include in the report. The default number of parallel paths is 1.

Restore Defaults
Resets all the options in the Paths panel to their default values.

See Also
Generating timing violation report
Understanding timing violation report

Data Change History - SmartTime

The data change history lists features, enhancements and bug fixes for the current software release that may
impact timing data of the current design.

To generate a data change history, from the Help menu, choose Data Change History. This opens a data
change history in text format.
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SmartTime Data Change History

Family: SmartFusion2/IGLOOZ2

Die: M25090T/M250%0/M2GLOS0T/M2GLOS0/H25090TV
Data source: Production

Libero 11.6

67526 - Update CCC arc delays

66997 — Update clock met delays

87272 - Update MSS/FDDR setup time in AXT mode
54350 - Update IO enable HZ/LZ arc delay

Libero 11.5 S5P2A
59225 - Timing data (IND/COM) updated from advanced to production
59228 - Support 1.0V timing (for M2S090TV, -1, IND)

Figure 94 - SmartTime Data Change History Report
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TCI Commands

For details about the Tcl commands supported by SmartTime, refer to the SmartFusion2, IGLOO2, RTG4
Tcl Commands Reference Guide or the PolarFire FPGA Tcl Commands Reference Guide.
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arrival time

Actual time in nanoseconds at which the data arrives at a sink pin when considering the propagation delays
across the path.

asynchronous
Two signals that are not related to each other. Signals not related to the clock are usually asynchronous.

capture edge
The clock edge that triggers the capture of data at the end point of a path.

clock
A periodic signal that captures data into sequential elements.

critical path

A path with the maximum delay between a starting point and an end point. In the presence of a clock constraint,
the worst critical path between registers in this clock domain is the path with the worst slack.

dynamic timing analysis

The standard method for verifying design functionality and performance. Both pre-layout and post-layout timing
analysis can be performed via the SDF interface.

exception
See timing exception.

explicit clock

Clock sources that can be traced back unambiguously from the clock pin of the registers they deserve, including
the output of a DLL or PLL.

filter
A set of limitations applied to object names in timing analysis to generate target specific sets.

launch edge
The clock edge that triggers the release of data from a starting point to be captured by another clock edge at an
end point.

minimum period
Timing characteristic of a path between two registers. It indicates how fast the clock will run when this path is the

most critical one. The minimum period value takes into consideration both the skew and the setup on the
receiving register.

parallel paths
Paths that run in parallel between a given source and sink pair.
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path
A sequence of elements in the design that identifies a logical flow starting at a source pin and ending at a sink pin.
path details
An expansion of the path that shows all the nets and cells between the source pin and the sink pin.
path set
A collection of paths.
paths list
Same as path set.
post-layout

The state of the design after you run Layout. In post-layout, the placement and routing information are available
for the whole design.

potential clock

Pins or ports connected to the clock pins of sequential elements that the Static Timing Analysis (STA) tool cannot
determine whether they are is enabled sources or clock sources. This type of clock is generally associated with
the use of gated clocks.

pre-layout
The state of the design before you run Layout. In pre-layout, the placement and routing information are not
available.

recovery time
The amount of time before the active clock edge when the de-activation of asynchronous signals is not allowed.

removal time
The amount of time after the active clock edge when the de-activation of asynchronous signals is not allowed.

required time
The time at which the data must be at a sink pin to avoid being in violation.

requirement
See timing requirement.

scenario (timing constraints scenario)
Set of timing constraints defined by the user.

setup time

The time in nanoseconds relative to a clock edge during which the data at the input to a sequential element must
remain stable.

sink pin
The pin located at the end of the timing path. This pin is usually the one where arrival time and required time are
evaluated for path violation.
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skew
The difference between the clock insertion delay to the clock pin of a sink register and the insertion delay to the
clock pin of a source register.

slack
The difference between the arrival time and the required time at a specific pin, generally at the data pin of a
sequential component.

slew rate
The time needed for a signal to transition from one logic level to another.

source pin
The pin located at the beginning of a timing path.

STA

See static timing analysis.

standard delay format (SDF)

Standard Delay Format, a standard file format used to store design data suited for back-annotation.

static timing analysis
An efficient technique to identify timing violations in a design and to ensure that all timing requirements are met. It

is well suited for traditional synchronous designs. The main advantages are that it does not require input vectors,
and it exclusively covers all possible paths in the design in a relatively short run-time.

synopsys design constraint (SDC)

A standard file format for timing constraints. Synopsys Design Constraints (SDC) is a Tcl-based format used by
Synopsys tools to specify the design intent, including the timing and area constraints for a design. Microsemi SoC
tools use a subset of the SDC format to capture supported timing constraints. You can import or export an SDC
file from the Designer software. Any timing constraint that you can enter using Designer tools, can also be
specified in an SDC file.

timing constraint
A requirement or limitation on the design to be satisfied during the design implementation.

timing exception
An exception to a general requirement usually applied on a subset of the objects on which the requirement is
applied.

timing requirement
A constraint on the design usually determined by the specifications at the system level.

virtual clock

A virtual clock is a clock with no source associated to it. It is used to describe clocks outside the FPGA that have
an impact on the timing analysis inside the FPGA. For example, if the I/Os are synchronous to an external clock.

WLM

Wire Load Model. A timing model used in pre-layout to estimate a net delay based on the fan-out.
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