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About Microsemi
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and system solutions for aerospace & defense, communications, data center and industrial
markets. Products include high-performance and radiation-hardened analog mixed-signal
integrated circuits, FPGAs, SoCs and ASICs; power management products; timing and
synchronization devices and precise time solutions, setting the world's standard for time; voice
processing devices; RF solutions; discrete components; enterprise storage and communication
solutions; security technologies and scalable anti-tamper products; Ethernet solutions; Power-
over-Ethernet ICs and midspans; as well as custom design capabilities and services. Microsemi
is headquartered in Aliso Viejo, California, and has approximately 4,800 employees globally.
Learn more at www.microsemi.com.
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Welcome to SmartPower

Welcome to SmartPower, the Microsemi SoC state-of-the-art power analysis tool. SmartPower enables you to
globally and in-depth visualize power consumption and potential power consumption problems within your design,
so you can make adjustments — when possible — to reduce power.

SmartPower provides a detailed and accurate way to analyze designs for Microsemi SoC FPGAs: from top-level
summaries to deep down specific functions within the design, such as gates, nets, 10s, memories, clock domains,
blocks, and power supply rails.

You can analyze the hierarchy of block instances and specific instances within a hierarchy, and each can be
broken down in different ways to show the respective power consumption of the component pieces.

SmartPower also analyses power by functional modes, such as Active, Flash*Freeze, Shutdown, Sleep, or Static,
depending on the specific FPGA family used. You can also create custom modes that may have been created in
the design. Custom modes can also be used for testing "what if" potential operating modes.

SmartPower has a very unique feature that enables you to create test scenario profiles. A profile enables you to
create sets of operational modes, so you can understand the average power consumed by this combination of
functional modes. An example may be a combination of Active, Sleep, and Static modes — as would be used over
time in an actual application.

SmartPower generates detailed hierarchical reports of the power consumption of a design for easy evaluation.
This enables you to locate the power consumption source and take appropriate action to reduce the power if
possible.

SmartPower supports use of files in the Value-Change Dump (VCD) format, as specified in the IEEE 1364
standard, generated by the simulation runs. Support for this format lets you generate switching activity information
from ModelSim or other simulators, and then utilize the switching activity-over-time results to evaluate average
and peak power consumption for your design.

Starting SmartPower

Note: When you launch SmartPower, you must first set your target clock and data frequencies before you
evaluate your power consumption.

To invoke the SmartPower analysis tool, in the Design Flow window, right-click Verify Power and choose Open
Interactively.
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Figure 1 - SmartPower User Interface — SmartFusion2, IGLOO2, RTG4
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SmartPower Interface

Summary Tab

The Summary tab is divided into five sections: Power Consumption, Breakdown, Annotation Coverage,
Operating Conditions, and Battery Life.

%Sun‘ln‘lar‘f la@ Domains . }ﬁ.ﬂ.nalysis . (‘D Frequencies . %Pmbahilﬂ:es ]

Power Consumption

Total 0.042  miw
Static 0.042  miw
Dwnamic 0 mw
Breakdown—| By Type - Show & Chat  Gd

Power Usage

Banks Static
0.008 mivy]

Hide: annotation coverage
Annatation Coverage | Frequancy=0 -
YCD Manual SmantTime Yectorless .
Frequency>=0 Annotation | Annotation Constraint E stimation Fized Values = Total
1 |Clocks 010%) 01[0%) 0[0z%) 0[0%) 5[100%) 5
2 |Reqister outputs 010%) 01[0%) 0[0z) 0[0%) 18 (100%) 18
3 | Combinational outputs 010%) 0[0%) 0[0%) 0[0%) 53 [100%) ]
4 |Set/Feset nets 010%) 01[0%) 0[0z%) 0[0%) 4 [100%) 4
5 | Primary inputs 010%) 01[0%) 0[0z) 0[0%) 9[100%) 9
B |Enable ping 01[0%) 0[0%) 0[0%) 0[0%) 01[0%) a
7 | Other ping 010%) 0[0%) 0[0%) 0[0%) 01[0%) a
Operating Conditions ; Typical
Operating Conditions VYalue
1|0 Junction Temperature 250
2 WCC 1.2
3 WCCI 1.5 15
Change Operating Conditions
Battery
Battery capacity 100000 méHrs
Battery life 29340.12 Hourlz)

Figure 3 - SmartPower Summary Tab

Power Consumption

Displays the total power consumption and the static and dynamic power of the design. (Accurate only after you
have entered your target clock and data frequencies).

Breakdown

Displays a breakdown of power consumption in the design. You can specify whether to see the power breakdown
by type of component, by voltage rail, or by clock domain from the drop-down list.
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Show

Displays power usage as a chart or as a grid.

When you select By Type from the drop-down list, the Summary tab displays a breakdown of the design's power
usage by the following types:

o Net

e Gate

e |/O

e Memory

e Core Static
e Banks Static
¢ Analog (for Fusion Designs)

Any static power used by instances of a component in a design will be included in the appropriate category. As a
result, the sum of the power in breakdown by type will equal the total of the static and dynamic power
consumption of the design. Percentages displayed are fractions of the total power. Global nets are included in the
net power types. To obtain the power of a clock, select breakdown by clock domain.

When you select By Rail from the drop-down list, the Summary tab displays a breakdown of the power usage by
the rail that the power is drawn from and a breakdown for the current usage. For each rail, the power, voltage,
and current drawn are displayed.

When you select By Clock Domain from the drop-down list, the Summary tab displays a breakdown of the power
usage by the clock domain that the power is drawn from. For each clock domain, the power and percentage of
power drawn are displayed. Dynamic power is accounted for in breakdown by clock, but static power is not
associated by any clock.

When you select By Mode — available only when a scenario is selected in the Modes and Scenarios toolbar —
the Summary tab displays power consumption, duration and power duration weight by mode.

Whether you selected By Type, By Rail, By Mode, or By Clock Domain, you can customize which columns are
displayed in the grid by right-clicking the column headers. To exclude a column, remove its checkmark from the
right-click menu. Right-click a column header to set the column default size for the selected column or for all
columns, sort the values in ascending or descending order, or customize columns.

To sort the contents of a column, double-click a column header.

To export the contents of the grid to a file, from the File menu, choose Export Grid or click its associated toolbar
button.

To print the grid, from the File menu, choose Print Grid or click its associated toolbar button.
To copy the grid, from the Edit menu, choose Copy Grid or click its toolbar button.

To copy the chart, click the contents of the chart, and from the right-click menu, choose Copy Chart to
Clipboard.

To export the chart, click the contents of the chart, and from the right-click menu, choose Export Chart to File.

To rotate the chart by 90 degrees, click the contents of the chart, and from the right-click menu, choose Rotate
Chart Clockwise or Rotate Chart Counter-Clockwise.

Annotation Coverage

Displays the number and percentage of pins annotated by each source (VCD, manual annotation, SmartTime
constraint, vectorless estimation, and fixed values) for all clocks, register outputs, combinational outputs, set/reset
nets, primary inputs, enable pins, and other pins.

To hide/show the annotation coverage, click the Hide annotation coverage or Show annotation coverage
link.

Use the Annotation Coverage Summary drop-down menu to view probability or frequency annotation statistics
(frequency=0 shows statistics for pins that have a frequency of 0).

VCD: displays the number/percentage of pins with frequencies/probabilities imported from a VCD file.
Manual annotation: displays the percentage of pins with manually-annotated frequencies/probabilities.
SmartTime constraint: displays the percentage of pins initialized with SmartTime.
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Fixed values: displays the percentage of pins with default frequency/probability.

Vectorless estimation: displays the percentage of pins that have been annotated with vectorless
estimation.

Operating Conditions

Displays the temperature and voltage operating conditions for the selected mode or scenario as specified in the
Operating Conditions dialog box. When you select a scenario, the temperature and voltage operating conditions
for each mode in the scenario are displayed.

To change the operating conditions, click the Change Operating Conditions link or from the Tools menu,
choose Operating Conditions.

Battery Life
Enables you to set the battery capacity in mA/hr and reports the battery life.

Domains Tab

The Domains tab displays a list of existing domains with their corresponding clock and data frequencies and
probabilities.

When you start SmartPower for the first time, it will automatically initialize frequencies from SmartTime with a
default data toggle rate of 10%. However, if you update your timing constraints in SmartTime, you can use the
Initialize Frequencies and Probabilities dialog box to update SmartPower with new frequencies from SmartTime. If
you don't have timing constraints in SmartTime, you can manually initialize clock and data frequencies by directly
editing the Domains tab grid, or you can use the Initialize Frequencies and Probabilities dialog box.

If you import a VCD file, the Domains tab will display average clock and data frequencies for each clock domain
and input set. This average is calculated using VCD information.

Note: If you change a clock or data frequency in the Domains tab, it will only impact nets using the default
estimation source. Nets use the default estimation source when they have not been manually set to a
specific frequency in the Frequencies tab, and when they have not been set by importing a VCD file.
To see explicitly the list of nets using the default estimation source, refer to the Frequencies tab.

= Surnrmary €5 Domains |,Gﬁ Analyziz [ 5 Frequencies [ B Probabilites l

Show : f+ " Probabilities
Clock domains
Clocks Register SetfReset  Primary inputs Combinational
Ekatus Blanie {MHz) outputs nets {MHz) outputs {MHz)
1 o CLKIN 100 5 (10 %) 0{0 %) 5 (10 %) 5 (10 %)
Hide set of ping
Set of ping
Status Name - ([:ﬁ:za)
1 Py Input to Qutput i
Frequencies and Probabilities displayed in this tab are default values. They are used for nets that have not been annotated by any method [ie. YCD or manual
anhotation]. Changing these values may not impact power estimation, depending on the percentage of nets annotated.

Figure 4 - SmartPower Domains Tab
Note: Data and clock frequencies are automatically set to zero when in non-active modes.
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The Domains tab displays frequencies or probability data for clock domains and sets of pins. In this tab, you can
add, edit, or remove domains or sets of pins, and change the clock and/or data frequency of a selected domain.

To hide or display the grid for set of pins, click the Hide/Show set of pins link.
You can edit frequency or probability data directly from the grid.
To create a new clock domain or set of pins:

1. Right-click the clock domain or set of pins and choose to add a new create new clock domain or create
new set of pins.

2. Enter a name and click OK. The new clock domain or set of pins appears in the Domains tab.
3. Modify the frequency and probability data as needed.

Clock domain frequencies can be initialized by right-clicking the clock domain name and selecting Initialize
Frequencies and Probabilities. If there is no frequency constraint set for this clock domain in SmartTime, the
clock frequency of the domain will not be changed.

The status of a clock frequency or probability is displayed in the first column by an icon. Mouse over the icon to
identify the status:

Table 1 - Clock Frequency/Probability Status

Icon Description

This clock has not been initialized

No constraints available for this clock from SmartTime

Average frequencies/probabilities imported from VCD

Clock constraints imported from SmartTime

GRS (PP

This clock has been manually initialized

Note: This feature is only available when in active operating mode or when in a mode based on the Active
mode.

The status of a set of pins is displayed in the first column by an icon. Mouse over the icon to identify the status:
Table 2 - Set of Pins Status

Icon Description

& This set has not been initialized

<

Average frequencies/probabilities imported from VCD

\/ This set has been manually initialized

Note: This feature is only available when in active operating mode or when in a mode based on the Active
mode.

To remove one or multiple clock domains, select the clock domain(s), and click Remove Selected Domains(s).
To edit a clock domain or a set of pins:

1. Select the clock domain and from the right-click menu, choose Edit Domain. The Clock Domain or Set-of-
Pins window appears.

10
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CTRLAJ 2 + Remove |
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Figure 5 - Clock Domain Window

Any pins that do not belong to a domain are listed in the Unclassified Pins list box. You can select a pin from the
Unclassified Pins list box and add it to the current domain. You may also select a pin from the current domain and
remove it from the domain (this pin will appear in the Unclassified Pins list box).

Clock Pins and Data Pins: Select Clock Pins from the pull-down list to display all clock pins for the selected

domain, or select Data Pins to display registers, asynchronous signals, primary input, and combinational signals for
the selected domain.

Use the filter boxes to narrow your search for a specific pin. The boxes are text filters; * is a wildcard.
2. Click OK.

To delete a clock domain or a set-of-pins, select the clock domain or set-of-pins and from the right-click menu,
choose Remove Domain.

Analysis Tab

The Analysis tab enables you to inspect detailed hierarchical reports of the power consumption. The Analysis
tab consists of two windows: the Hierarchy of Instances window and the Analysis window.

11
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Figure 6 - SmartPower Analysis Tab

Hierarchy of Instances Window

SmartPower displays the hierarchy of instances in a list in the Hierarchy of Instances window. Sub-blocks of a
block are shown in the tree when you click the plus sign (+) next to the block. Only hierarchical blocks are
displayed in this list (no gates or nets).

When you select a block of the hierarchical tree, SmartPower displays its name and power consumption in the
Analysis window.

Analysis Window

The Analysis window is divided into two sections: Power Consumption and Breakdown.

Power Consumption

Displays the name of the currently selected block from the hierarchy of instances window, as well as the static
and dynamic power consumption of the selected block.

Show

Displays power usage as a chart (not available when breakdown by instance is selected) or as a grid.

Breakdown
Displays a breakdown of power usage of the currently selected block. Use the drop-down list to select whether to
display the power breakdown by type of component, instance, or clock domain.
When you select By Type from the drop-down list, the Analysis tab displays a breakdown of the selected block's
power usage by the following types:

e Net
e Gate
e |/O

12



SmartPower User Guide

& Microsemi

a S\ MicrocHIP company

e Memory

e Core Static

e Banks Static

¢ Analog
Any static power used by instances of a component in a design will be included in the appropriate category. As a
result, the sum of the power in breakdown by type will equal the total of the static and dynamic power

consumption of the design. Percentages displayed are fractions of the total power. Global nets are included in the
net power types. To obtain the power of a clock, select breakdown by clock domain.

When you select By Clock Domain from the drop-down list, the Analysis tab displays a breakdown of the power
usage by the clock domain that the power is drawn from. For each clock domain, the power and percentage of
power drawn are displayed. Dynamic power is accounted for in breakdown by clock, but static power is not
associated by any clock.

Whether you selected By Type, By Instance or By Clock Domain, you can customize which columns are
displayed in the grid by right-clicking the column headers. To exclude a column, remove its checkmark from the
right-click menu. Right-click a column header to set the column default size for the selected column or for all
columns, sort the values in ascending or descending order, or customize columns.

To sort the contents of a column, double-click a column header.

To export the contents of the grid to a file, from the File menu, choose Export Grid or click its associated toolbar
button.

To print the grid, from the File menu, choose Print Grid or click its associated toolbar button.

To copy the grid, from the Edit menu, choose Copy Grid or click its toolbar button.

To copy the chart, click the contents of the chart, and from the right-click menu, choose Copy Chart to
Clipboard.

To export the chart, click the contents of the chart, and from the right-click menu, choose Export Chart to File.
To rotate the chart by 90 degrees, click the contents of the chart, and from the right-click menu, choose Rotate
Chart Clockwise or Rotate Chart Counter-Clockwise.

To view instance properties, right-click any instance and select Instance Properties. This brings the Instance
Properties window, which displays the instance name, type and power and other properties specific to each type
of instance, see image below.

Instance Properties E|

Property | Yalue |

Mame 141

Power Ot

Twpe zate

Macro ADLIE:IMY
Pin Lisk:

Pin Met | Cromain | Freq. (MHz) |

1418 Busoukput CPUCIk {data)  0.000

141y DRAMData_... CPUCHk (data) 0.000

Figure 7 - Instance Properties: Gate
The Instance Properties allows you to access a list of pins of a gate and to check their domain and frequency.

13
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See Also

Analyze results
Advanced Analysis of 1/0Os

Frequencies Tab

Use the Frequencies tab to attach switching frequency attributes to the interconnects of the design. The
Frequencies tab is divided into Switching Frequencies, Average Frequencies, and Annotation Statistics.

8% Surnrmary . i Dornains . S8 prialysis 7 Frequencies lg{}thahil'mes l

Switching Freguencies:
Diriver: |* Set Domair: | Al - Source: Al -
Driver Net Domain Fr'zﬂ#lez';c? Source A
1 | PwWM_out_pad/U0/UL:DOUT PWM_out_pad/J0/METL unl_dataa_int 0 Fixed Walues
2 PWM_out_pad/U0SU0:PAD | PWM_out unl_dataa_int 0 Fixed Walues
3 nPWHM_out_pad/J0/J1: 00U | nPYWM_out_pad/U0/METL unl_dataa_int 0 Fixed Walues
4 |nPwh_out_pad/U0AUD:PAD nPWM_out unl_dataa_int 0 Fixed Walues
5 |unl_dataa_int_ME:Y unl_dataa_int_ME unl_dataa_int |0 Fixed Values
6 |PWM_out:Q PuM_out_c unl_dataa_int |0 Fixed Values
7 |nPWM_out:Q nPWM_out_c unl_dataa_int |0 Fixed Values
8 | Aclr_padsuosuo:y Aclr_pad,/U0,/MET1 Pt _cll (set/ |0 Fized Walues
9 | PwM_clk Pt _cllc Pt _cll {cloc |0 Fixed Values
10 Pwi_clk_pad/Unsun:y Pt _cll_pad/U0/METL Pt _cll (cloc |0 Fixed Walues
11 |PwWM_data_in<5= PuiyM_data_in[5] Pt _clle {prim 0 Fized Walues
12 |PwWM_data_in<3= PuM_data_in[3] Pt _cll {prim 0 Fized Walues v
Select al
Average Frequencies: Annotation Statistics:
WCD Import: 0%
Fir: a tHz tanual Annatation: 0%
Fixed Walues: 100 %
Wectorless Estimation: 0%

Figure 8 - SmartPower Frequencies Tab

Switching Frequencies

Displays the pins and lists the net, domain, frequency, and frequency source for each pin.

The Driver box enables you to filter the list of pins based on the criteria entered. Enter text in the filter box, and
click Set to apply this text as a filter. Use the * character to display all pins or as a wildcard.

Use the Domain drop-down list to select a different domain (All, CLKIN, Default, or Input to Output).
Use the Source drop-down list to select a different source (All, Default, Manual Annotation, or VCD Import).

You can change the frequency by entering a new value in the Frequency column or by selecting multiple pins
and pressing the Set frequencies for selected pins button and entering a new frequency. Use Reset
frequencies for selected pins to revert to the default frequency.

To select all the pins, click Select All.

Average Frequencies

Displays the average frequency of all pins displayed in the grid.

Average Frequencies are useful when you import a VCD file or SAIF file. Since these files enable you to specify
the frequency of each pin individually, it is often useful to know the average clock pin or data pin frequency for a
particular clock domain.
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If you did not specify a frequency annotation for any clock pin in this clock domain, the average value is equal to
the default clock frequency of the clock domain. If you set one or several clock pins, SmartPower takes these
specific annotations into account to compute an average value.

If you did not specify a frequency annotation for any data pin in this clock domain, the average value is equal to
the default data frequency of the clock domain. If you set one or several data pins, SmartPower takes these
specific annotations into account to compute an average value.

Annotation Statistics
VCD import: displays the percentage of pins with frequencies imported from the *.vcd file.
Manual annotation: displays the percentage of pins with manually-annotated frequencies.
Fixed values: displays the percentage of pins with default frequency.

Probabilities Tab

You can use the Probabilities tab to control the probabilities for all pins.

Bidirectional and Tristate 1/Os: Controls the output probability of each tristate and bidirectional I/0. The
probability is the percent of time that the I/O is used as an output. You can change the default value and set a
specific value for each bidirectional or tristate 1/0.

Memories: Controls the read cycle probability or the write cycle probability of a memory block. The probability is
the percent of time that a memory block will be used either in a read cycle or a write cycle. You can change the
default value as well as set a specific value for each enable pin of each memory block available in the design.

If an enable pin is active low, assign it a probability of 0% to completely enable the 1/O or the memory block, or
100% to disable it completely.

In designs with a cascaded memory, all memory enable pins are shown in the Probabilities tab. To simulate real-
world power consumption, selectively enable only some memory enable pins, as specified in the memory
cascading structure. For purely vertical cascading, enable the pins belonging to one RAM block. For purely
horizontal cascading, enable all pins belonging to all RAM blocks of the cascaded memory. You can find which
RAM block corresponds to which pin by cross-probing with the MVN NetlistViewer.

The Probabilities tab displays the drivers, nets, types, polarity, rates, and source for each pin.

% Surnmary . fgi Domainz . S fnalysis . &5 Frequencies I2- Probabilites ‘

Driver: g Set Type: &l - Polarity: | All - Source: Al -
Driver Net Type Polarity Pro?:;hh)lht? Source A
1 rst_n rst_n Input to -- 99,9949 Manual &
z rst_n_pad/U0AU0:Y rst_n_pad/U0/METL Input to -- 99,9949 Manual &
3 rst_n_pad/U0AUL:Y rst_n_c Input to -- 99,9949 Manual &
4 fpu_op=0= fpu_op[0] Input to -- 0 Manual &
5 fpu_op_pad[0]/00/00:  |(fpu_op_pad[0]/UO/NETL |Input to -- 0 Manual &
[ fpu_op_pad[0]/00/0L:y  |(fpu_op_c[0] Input to -- 0.000003 Manual &
7 UUT /unl_fpu_op_3_0_aZ |UJT/M_1112 Input to -- 0.000003 Manual &
8 UUTfracta_mul_w_0_a2 [UJT/M_1111 Input to -- 0.000003 Manual &
9 fpu_op=1= fpu_op[1] Input to -- 0 Manual &
10 fpu_op_pad[1]A00/00:%  (fpu_op_pad[1]/U0/MET1 |Input to -- ] Manual &
11 fpu_op_pad[1]/U0/01:y  |fpu_op_c[1] Input to -- 0.000003 Manual &
1z UUT/unl_fpu_op_1_0_a2 UUT/MN_1026 Input to -- 0.000003 Manual &
13 fpu_op<z=> fpu_op[2] Input to -- 0 Manual &
14 fpu_op_pad[2]A00/00:  (fpu_op_pad[2]/J0/METL |Inputto -- ] Manual A
15 fpu_op_pad[2]/U0s01: v (fpu_op_c[2] Input ta -- 0.000003 Manual A
16 UUT/fract_denorm[30]:Q |UUTAract_denorm[30]  |UUTAun3_out_ |-- 0.0125 Manual &
17 UUT/fract_denorm[32]:Q |\UUTAract_denorm[32]  |UUTAun3_out_ | -- 0.0125 Manual & =
1o INITHezmd Aarmmaerr=l 24T THITHezrd darmmreal 217 THIT AR Aok - nni2c PMarii=l A
Select all

Figure 9 - SmartPower Probabilities Tab
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The Driver box enables you to filter the list of drivers based on the criteria entered. Enter text in the filter box, and
click Set to apply this text as a filter. Use the * character as a wildcard.

Use the Type drop-down list to filter the pin list by different type (All, All enable, CLKIN, Default, or Input to
Output).
Use the Polarity drop-down list to filter the pin list by polarity (Low, High, or All).

Use the Source drop-down list to filter the pin list by source (All, Default Estimation, Manual Annotation, Saif
Import, or VCD Import).

You can change the rate by entering a new value in the Rate column or by selecting multiple pins, pressing the
Set Probabilities for selected pins button, and entering a new frequency in the Set Default Probabilities dialog
box.

Set probability for pin(s) E|

Probability:

| S
(0] 4 | Cancel |

Figure 10 - Set Probability for Pins Dialog Box

Use Reset Probabilities for selected pins to revert to the default polarity.
You can change the default probability from the Domains tab.
To select all the drivers, click Select All.

You can set or reset the probabilities, set a default probability, copy, export, or print the grid by selecting one or
multiple pins and choosing an option from the right-click menu.

See Also
Specify probabilities

Preferences Toolbar

The SmartPower Preferences toolbar gives you quick access to commonly used settings. Mouse over the toolbar
button to view a description of the command. Use the drop-down list to select your settings.

Operating Frequency Powver
Conditions Preferences  Preferences

| y
IT_I,Ipiu:aI j |h-1H2 j |mW ﬂ|

Figure 11 - SmartPower Preferences Toolbar

Operating Conditions: Enables you to set the operating conditions - Best, Typical, or Worst.

The actual voltage and temperature of a given operating condition is defined by the operating condition range
selected for the current design (COM, IND, MIL, Auto, TGrade1, TGrade2, and Custom). For SmartPower, unlike
SmartTime, the worst voltage is the upper bound of the range. That is, higher (worst-case) power comes from
higher voltage, whereas higher voltage results in best-case speed.

Note: Worst-case and best-case calculations are available only for certain families and devices.
Frequency: Sets unit preferences for frequency — Hz, KHz, MHz.
Power Units: Sets unit preferences for power — W, mW, or uWw.

See Also
SmartPower toolbar / menu commands
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Modes and Scenarios Toolbar

The Modes and Scenarios toolbar displays all pre-defined modes, custom modes, pre-defined scenarios, and
custom scenarios. The Modes and Scenarios toolbar is shown by default, but can be closed or undocked. To view
the toolbar, from the View menu, choose Modes and Scenarios toolbar.

From this toolbar, you can:

Select a pre-defined mode by clicking the mode name
Select a custom mode by clicking the mode name

Select a custom mode for power-driven layout by right-clicking the active-based mode and selecting Use for
PDPR

Re-import a VCD file from an Active mode or a custom mode by right-clicking the VCD file and selecting Re-
import VCD File

Remove a VCD file from an Active mode or a custom mode by right-clicking the VCD file and selecting
Remove VCD File from <mode name> Mode; or from the Simulation menu, choose Remove VCD File
> <file name>

Generate an Activity and Hazards Power report by right-clicking the VCD file and selecting Activity and
Hazards Power Report

Create a new custom mode by clicking Custom modes and selecting New Custom Mode; or by clicking
the New Custom Mode hyperlink

Edit and delete a custom mode by right-clicking the mode name and selecting Edit custom mode or
Delete custom mode

Copy a custom or a pre-defined mode by right-clicking the mode name and selecting Create a copy of this
mode

Select a scenario by clicking the scenario name
Create a new custom scenario by clicking Scenarios and selecting New custom scenario

Edit and delete a custom scenario by right-clicking the scenario name and selecting Edit custom scenario
or Delete custom scenario

Copy a scenario by right-clicking the scenario name and selecting Create a copy of this scenario
Note: When a scenario is selected, only the Summary tab is available.

Modes and scenarios =
Pre-defined modes
3 Active
Static
Flazh*Freeze
Sleep
Custom modes
active_low
Pre-defined scenarios
B0% Flazh*Freeze
20% Flazh*Freeze
95% Flazh*Freeze
Cuztomn scenarios
[mpoer

Figure 12 - Modes and Scenarios Toolbar

SmartPower Standard Toolbar and Menu Commands

The SmartPower standard toolbar contains commands for performing common SmartPower operations on your
designs. Roll the mouse pointer over the toolbar button to view a description of the button. Click the button to
access the command.
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Toolbar Button

Description

Commit

@ | @

Settings Summary

Operating Conditions

Options

i |

Export Path Grid

g

Copy Path Grid

Print Grid

Generate Power Report

® | B | M

Initialize Frequencies and Probabilities

22

Refreshes Vectorless Estimation

The PC and UNIX workstation versions of SmartPower have the same menus. However, some dialog boxes may
look slightly different on the two platforms due to the different window environments. The functionality is the same
on both platforms, though the locations of the fields and buttons on the dialog boxes may vary. The names of

some fields may also vary between the PC and workstation versions.

File Menu
Menu Description

Commit Commits power information. You must commit your changes if you wish to
save your settings in SmartPower. If you commit your changes, the
information is stored in the .adb file, and your settings are restored the
next time you open your design in SmartPower

Export Grid Exports the selected area of the Report window to a text (.txt) file

Print Grid Prints the selected area of the Report window

Settings Summary Displays a summary of the power settings for the current design

Close Closes SmartPower
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Menu

Sub-Menu

Description

Domains

New Clock Domain

Adds a clock domain

New Set of Pins

Adds a set of pins

Delete Domain

Deletes a clock domain

Edit Domain

Edits a clock domain

Modes and Scenarios

Use for Analysis > mode or
scenario name

Sets the selected mode or scenario to be
used for analysis

Use for PDPR > mode or
scenario name

Sets the selected mode or scenario to be
used for Power-Driven Layout

Custom Modes > New
Custom Mode

Creates a new custom mode

Custom Modes > Edit
Custom Mode

Edits a custom mode

Custom Modes > Delete
Custom Mode

Deletes a custom mode

Custom Scenarios > New
Scenario

Creates a new custom scenario

Custom Scenarios > Edit
Scenario

Edits a custom scenario

Custom Scenarios > Delete
Scenario

Deletes a custom scenario

Copy Grid — Copies the selected cells of the dynamic
grid onto the clipboard
View Menu
Menu Description

Standard Toolbar

Displays or hides the SmartPower Standard toolbar

Preferences Toolbar

Displays or hides the SmartPower Preferences toolbar

Modes and Scenarios
Toolbar

Displays or hides the Modes and Scenarios toolbar

Unprocessed Simulation
Files Toolbar

Displays or hides the_Unprocessed Simulation Files toolbar

Customize Columns

Selects and orders the columns displayed in the user interface
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Menu

Description

Reset Window Layout

Resets the window layout to the default layout

Tools Menu

Options — Invokes the Options dialog box, where you can
set analysis and display preferences

Reports Power Report Generates a power report
Scenario Power Report Generates a scenario power report
Activity and Hazards Generates an activity and hazards power
Power Report report

Simulation Menu
Menu Description
Import VCD File Invokes the Import VCD Options dialog box

Help

Menu

Sub-Menu Description

Initialize Frequencies and
Probabilities

— Imports clock constraints from SmartTime and

enables the user to input frequencies and
probabilities for the design

Operating Conditions

— Enables the user to customize the_operating
conditions used in SmartPower

Remove VCD file

Removes the selected CVD file from the design

Audit files

Audits simulation files within the project

Menu

Menu

Description

Help on current tab

Displays the help content for the current tab

Help Topics

Opens the help files for SmartPower

SmartPower User's Guide

Displays the SmartPower User's Guide

Data Change History

Displays the data change history report

20



SmartPower User Guide

& Microsemi

a S\ MicrocHIP company

See Also
SmartPower preferences toolbar

Power - Settings Summary

The Power - Settings Summary dialog box displays a summary of the power settings for the current design.
To open the Power - Settings Summary dialog box, from the File menu, choose Settings Summary or click the

i

icon in the SmartPower toolbar.

Power - Settings Summary I El

Attribute | " alue I
Dezign SMALL_GATED

Farmily ProtSIC3

Die A3P125

Fackage 144 FEGA
Temperature Range k4

Yaoltage Range COkd

Dperating Conditions Typical

Operating Mode Active

Figure 13 - Power - Settings Summary Dialog Box

The Power - Settings Summary dialog box displays the following information:

Design: Displays the name of the design.

Family: Displays the device family used in the design.
Die: Displays the die.

Package: Displays the package.

Temperature Range: Displays the temperature range.
Voltage Range: Displays the core supply voltage.

Operating Condition: Displays the operating conditions that SmartPower uses to calculate static and
dynamic power contributions.

Operating Mode: Displays the operating mode that SmartPower uses to calculate static and dynamic power
contributions.

Note: The status bar also shows the ambient temperature, VCCA and speed grade.

Initializing Frequencies and Probabilities
The Initialize Frequencies and Probabilities dialog box enables you to initialize the frequencies and
probabilities for your design.

To open the Initialize Frequencies and
Probabilities dialog box, from the Tools menu, choose Initialize Frequencies and

Probabilities, or click the @ icon in the SmartPower toolbar.

Note: This feature is only available in the Active operating mode or modes derived from the Active mode.

The dialog box is organized in the following panels: General, Clocks, Register Outputs, Set/Reset Nets, Primary
Inputs, Combinational Outputs, Enables Sets of Pins, and Other Sets of Pins.
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ower, - Initialize Frequencies and Probabilities

@ General Use this dialog box to initislize frequencies and probabilities For your design.
Ul Clocks
1T Reqister autputs Initialize mode: ’m a
‘T, Set/Reset nets
= Primary inputs
T» Combinational outputs
=2 Set of pins
Enables * Use vectorless analysis
Cthers

o For pins that have not been annotated, SmartPower can estimated their
frequency and probability using a Yectorless analysis or fixed values,

" Use fixed values

[~ Remave Simulation File (YCDY i are,

[ Remave any manual annotations,

Help [a]'4 | Cancel

Figure 14 - Initialize Frequencies and Probabilities Dialog Box — General
Initialize mode — Select an active-based mode to initialize the frequencies and probabilities for.
For pins that have not been annotated, SmartPower can estimate their frequency and probability using vectorless
analysis or fixed values:
Use vectorless analysis — SmartPower initializes frequencies and probabilities with vectorless analysis.
Use fixed values — SmartPower initializes frequencies and probabilities (%) of all registers with a default toggle
rate (available only when using toggle rates), frequency, and probability.
Based on the selected mode, a warning appears with information on the annotated pins. If the selected mode
contains any annotations, you can remove annotations by selecting one or both options below:
Remove simulation file (VCD) if any — Select this option to remove the simulation file for the selected
mode.
Remove any manual annotations — Select this option to remove all manual pin annotations for the
selected mode.
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SmartPower - Initialize Frequencies and Probabilities

Ul General

Ul Clocks
1T Reqister oukputs
‘T, Set/Reset nets
= Primary inputs

T» Combinational outputs
=2 Set of pins
Enables i

Cth
Srs [¥ else, with default frequency 10.00 MHz

and duty cycle 50,00 o

[¥ Initislize clock frequencies and duty cycles

Help [a]'4 | Cancel

a S\ MicrocHIP company

Figure 15 - Frequencies and Probabilities Dialog Box — Clocks

Initialize clock frequencies and duty cycles — Select this option to initialize clock frequencies and duty cycles,

with:

with clock constraint if available in SmartTime: When only this box is checked, SmartPower initializes

all clock domains in SmartPower with clock constraints from SmartTime. If there

is no frequency

constraint set for this clock domain in SmartTime, the clock frequency of the domain will not be updated.

else, with default frequency (MHz) and duty cycle (%): When only this

box is checked, SmartPower initializes all clock domains in SmartPower with the specified default

frequency and duty cycle.

Note: When both boxes (with clock constraint if available in SmartTime and with default frequency and
duty cycle) are checked, SmartPower initializes all clock domains with clock constraints from
SmartTime. If there is no frequency constraint set for a clock domain in SmartTime, it is initialized

with the specified default frequency and duty cycle.
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Register Outputs

SmartPower - Initialize Frequencies and Probabilities

Ul General
Ul Clocks
eN R e qister oubputs
H‘L:’ Set/Reset nets ¥ Initislize frequencies and probabilitiss
= Primary inputs
T» Combinational outputs
=2 Set of pins ~
Enables

Cthers
,7

* with Yectorless analysis

Help [a]'4 | Cancel

Figure 16 - Frequencies and Probabilities Dialog Box —Registers
Initialize frequencies and probabilities — Select this option to initialize frequencies and probabilities for register
outputs in your design.
With vectorless analysis — SmartPower initializes frequencies and probabilities using vectorless analysis.

With fixed values: SmartPower initializes frequencies and probabilities (%) of all register outputs with a
default toggle rate (available only when using toggle rates) or frequency (when not using toggle rates),
and a default probability.

Set/Reset Nets

SmartPower - Initialize Freguencies and Probabilities

Ul General
Ul Clocks
1T Reqister oukputs
S8 ek nets

I» Combinational outputs Iv Initialize frequencies and probabilities
=2 Set of pins
Enables with Fixed toggle rate 0.00 o,
Cthers

with Fixed probability 50,00 Yo

Help oK | Cancel

Figure 17 - Frequencies and Probabilities Dialog Box — Asynchronous

Initialize frequencies and probabilities — Select this option to initialize frequencies and probabilities for set/reset

nets in your design.
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With default toggle rate (%): SmartPower initializes frequencies and probabilities of all set/reset nets
with the specified default toggle rate. This option is available only when using toggle rates.

With default frequency (MHz): SmartPower initializes all set/reset nets in SmartPower with the specified
default frequency. This option is available only when not using toggle rates.

With default probability (%): SmartPower initializes probabilities of all set/reset nets with the specified
default probability.

Primary Inputs

SmartPower - Initialize Freguencies and Probabilities

Seleet a Category:
ol General

UL Clacks
ir Register outputs
‘L. SetfReset nets
WY Criraty inpuks

I Combinational outputs ¥ Initialize Frequencies and probabilities
. et of pins
Enables with Fizzed toggle rate 10,00 o
Others

with Fixzed probability 50.00 e

Help [w]'4 | Cancel

Figure 18 - Frequencies and Probabilities Dialog Box — Primary Inputs

Initialize frequencies and probabilities — Select this option to initialize frequencies and probabilities for the
primary inputs in your design.
With default toggle rate (%): SmartPower initializes frequencies and probabilities of all primary inputs
with the specified default toggle rate. This option is available only when using toggle rates.
With default frequency (MHz): SmartPower initializes all primary inputs in SmartPower with the specified
default frequency. This option is available only when not using toggle rates.
With default probability (%): SmartPower initializes probabilities of all primary inputs with the specified
default probability.

25



& Microsemi

SmartPower User Guide :
a S\ MicrocHIP company

Combinational Outputs

SmartPower - Initialize Frequencies and Probabilities

Ul General
Ul Clocks
1T Reqister oukputs
H‘L:’ Set/Reset nets ¥ Initislize frequencies and probabilitiss
= Primary inputs
bp Cornbinational outputs
=2 Set of pins ~
Enables

Cthers
,7

* with Yectorless analysis

Help [a]'4 | Cancel

Figure 19 - Frequencies and Probabilities Dialog Box — Combinational
Initialize frequencies and probabilities — Select this option to initialize frequencies and probabilities for the

combinational outputs in your design.

With vectorless analysis — SmartPower initializes frequencies and probabilities with vectorless analysis.
With fixed values: SmartPower initializes frequencies and probabilities (%) of all combinational outputs
with a default toggle rate (available only when using toggle rates) or frequency (when not using toggle

rates), and a default probability.

Enables

SmartPower - Initialize Freguencies and Probabilities

Ul General
Ul Clocks
L Register outputs ¥ Initiaslize frequencies and probabilities
‘T, Set/Reset nets
> Primary inputs ¥ with Vectorless analysis
T» Combinational outputs i~
=2 Set of pins
. Frequency Probability
EormeT MHz o
Others 1 10sEnableset 0,00 12.50
Z MermoriesEnableset 0.00 12.50

Help oK | Cancel

Figure 20 - Frequencies and Probabilities Dialog Box — Enables
Initialize frequencies and probabilities — Select this option to initialize frequencies and probabilities for the
enable sets of pins in your design.
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With vectorless analysis — SmartPower initializes frequencies and probabilities with vectorless analysis.

With fixed values: SmartPower initializes frequencies and probabilities of all enables sets of pins with
the specified default probability and frequency.

Others

SmartPower - Initialize Freguencies and Probabilities

Seleet a Category: Foers
ol General

UL Clacks
ir Register outputs
‘L. SetfReset nets
== Primary inputs

[v Initialize Frequencies and probabilities

(% with Vectorless analysis

T+ Combinational outputs primary inpuks frequency | 1.00 MHz
=i Set of p'ljrlls primary inputs probabilicy | 50,00 %o
Enables

Help [w]'4 | Cancel

Figure 21 - Frequencies and Probabilities Dialog Box — Others
Initialize frequencies and probabilities — Select this option to initialize frequencies and probabilities for the
other sets of pins in your design with default values.
With vectorless analysis — SmartPower initializes frequencies and probabilities with vectorless analysis as
specified in the primary inputs frequency and probability.
With fixed values: SmartPower initializes frequencies and probabilities (%) of all other sets of pins with a
default frequency and probability.

See Also
Domains Tab
Vectorless Analysis

Power Options
Enables you to set options that affect the graphical and textual reports.
To open the SmartPower Power Options dialog box:

e From the File menu choose Options
e Select the Options panel in the Power Report dialog box.

e Click the % icon in the SmartPower toolbar.
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Power - Options

x]

Initz
Poweer: LA | E
Frequency MHz

[v Usze toggle rates

Help | ] | Cancel |

Figure 22 - SmartPower Preferences Dialog Box
There are two sections: Units and Use Toggle Rates.

e Units: Sets unit preferences for power (W, mW, vW) and frequency (Hz, KHz, MHz).

¢ Use Toggle Rates: When toggle rates are active (Use Toggle Rates box is checked), the data frequency of
all the clock domains is defined as a function of the clock frequency. This updates the data frequency
automatically when you update the clock frequency. Toggle rates enable you to specify the data frequency
as a percentage of clock frequency, but you can no longer specify the data frequency as a number, only as
a percentage of the clock frequency. To specify data frequencies, clear the Use Toggle Rates option in the
Preferences window.

You can set the data frequency percentage when you create a new clock domain with toggle rates active. In
addition, when toggle rates are active you can set the data frequency percentage in the Domain and Frequencies
tabs.

X

Cancel |

Patential Clock Pin

Clock Frequency I 10 MHz

[ata Frequency 20 4

Figure 23 - Create Clock Domain — Toggle Rates Enabled

Operating Conditions

The SmartPower Operating Conditions dialog box enables you to customize the operating conditions used in
SmartPower for voltage and temperature.
Note: Changes will apply only to SmartPower and will not change the operating conditions set in Designer.

The General panel enables you to select the operating condition you want to apply to SmartPower: Best, Typical,
or Worst.
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B | SmartPower - Operating Conditions @

- ¢ General

- g2 Process settings
a emperature settings
Thermal resistance settings
Voltage settings

Use this dialog box to customize the operating conditions used in SmartPower. Changes wil
-VDDI 1.8 apply only to SmartPower and will not change the operating conditions set in the Designer.

Select an active operating condition for SmartPower from
the options below:

Typical _:!

Help I Ok I Cancel J

Figure 24 - SmartPower Operating Conditions Dialog Box - General
The process settings panel enables you to select the process characteristic.

7 SmartPower - Operating Conditions @
Process settings ]

- & General
- ¢ Process settings

Ternperature settings

Thermal resistance settings
Voltage settings
VDD Select the process characteristic:
- VDDALX "Typical”is based on average standby power consumption
-yDDI 1.2 "Maximum” can be used for worst-case analysis

Typical L}

Help I Ok I Cancel J

Figure 25 - SmartPower Operating Conditions Dialog Box - Process

You can customize temperature settings in the Temperature Settings panel, and the voltage settings in the
Voltage Settings panels — each VCC voltage used in the design appears under Voltage settings.
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T ShriPower - Operating Condhfions (@ |[=]
Temperature settings

Use: |Design operating range (default) j

# Temperature settings
d; Thermal resistance settings

SmartPower uses the operating range specified in the Device Selection Wizard:

Valtage settings This design uses "EXT" settings.

VDD

VDDAUX

vDDI 1.8

VDD25

vDD18
Junction Temperaure( in degrees Celsius )
Best: 0.00
Typical: 25.00

Worst: 100.00

Help Ok | Cancel

Figure 26 - SmartPower Operating Conditions Dialog Box - Temperature Settings
Select one of three options to specify the temperature or voltage settings:

+ Design operating range (default): sets the temperature or voltage operating range as specified in your
Project Settings..

e Custom operating range: sets the temperature (junction or ambient) or voltage operating range for the
current design in SmartPower only. You can enter temperature values in degrees Celsius and voltage
values in volts for Best, Typical, and Worst.

¢ Mode by mode operating range: sets the temperature (junction or ambient) or voltage for each mode in
SmartPower only. You can use the grid to enter temperature values in degrees Celsius and voltage values
in volts for each mode, or select multiple modes in the grid, and click the Set values for selected modes
button to enter the same values for all selected modes.
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[®][=]

Sciecta Categary:
- 2 General
=) Process settings
- o Temperature settings

d; Thermal resistance settings
=-|§ Voltage settings

Use: |Mode by mode operating range _ﬂ

SmartPower uses a different operating range for each mode.
Operating ranges for each mode can be spedified below, They apply to SmartPower

VDD only.
i VDDAUX Specify {in Celcius degrees):
VDDl 1.8 {* Junction Temperature
- VDD25 " Ambient Temperature
vDDe Junction Temperature
Mode Best Typical Worst
1| Static 0.00 25.00 100.00
2| Active 0.00 25.00 100.00

Set values for selected mode(s). .. Select Al

Help Ok | Cancel |

Figure 27 - SmartPower Operating Conditions Dialog Box - Mode-Specific Temperature Settings

The junction temperature and static power are computed iteratively until they converge.
The formulas are:

T_.f= T/f+ U_.M ’ (P.{wn.ﬂlrrr IPf.fm‘rr}
me.-'.-.-= f {T_.F) = Pg. + Pl * Tj

If the computed junction temperature is outside the operating condition range (smaller than the best case value or
greater than the worst case value), a violation warning will be reported.

Both T, and Ps:ic will be re-computed when any of the following parameters are changed:
e Ambient temperature
e Cooling style
e Custom thermal resistance,
or any parameters/options that affect the static or dynamic power values:
e Junction Temperature Display Mode
e Operating Condition (Affect dynamic power)
e Operating Mode (Affect dynamic power)
e Any of the clock domain frequencies (Affect dynamic power)

If you specified the Ambient temperature in the Temperature Settings panel, you can select the thermal
characteristic for Thetaua .
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(7=

Select a Category: M Thermal resistance settings )

22 General
=) Process settings
# Ternperature settings

Select the thermal characteristic for ThetalA

d; Thermal resistance settings " Custom {+ Estimated

= Voltage settings
VDD
VDDAUX Thetala [ cw
vDDI 1.8

vDD25 Heat Sink 20mm - High Profile =
Air Flow 2.5m/fs A
Custom ThetaSa a ciw

Board Thermal Model JEDEC (2s2p) i

& This setting only applies if you specify Ambient temperature
in the ‘Temperature settings’ page.

Help Ok | Cancel

Figure 28 - SmartPower Operating Conditions Dialog Box - Thermal Resistance Settings

The thermal resistance is predefined for Still Air, 300 ft/min and Case Cooling. To enter a custom thermal
resistance, select Custom from the Cooling field, and change the value.

SmartPower also reports the thermal resistance, Thetaja.

See Also
SmartPower toolbar / menu commands

SmartPower preferences toolbar

Custom Operating Modes

SmartPower enables you to use pre-defined and custom operating modes. A pre-defined operating mode is an
inherent mode of a family of devices that comes with a number of hard availability constraints on the FPGA
resources. Custom operating modes are user-defined modes based on one of the pre-defined modes available for
the family, where parameters such as clock, data, and toggle rate frequencies have been customized. A custom
mode can also be linked to a VCD.

Custom modes can be used:

e To define additional modes where the chip is in the active pre-defined mode, but where the clock
frequencies or the toggle rates are scaled up or down.

e To import multiple VCD files that capture individual steps that take place in different modes.

e To define a sequence of modes with a duration for each mode and get an estimate of the overall power
consumption, from which extrapolate the battery life for the application. The Scenario Power report enables
you to define a sequence of modes and estimate the weighted average of the power consumption of the
chip over the whole sequence.

e To define additional modes where the chip is in a pre-defined mode, but the junction/ambient temperature or
the rails' voltage modes are different.

To set the current mode:

From the Edit menu in SmartPower, choose Modes and Scenarios > Use for Analysis > mode name; or select
the mode in the Modes and Scenarios toolbar.
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To create a new custom mode:

1. From the Edit menu in SmartPower, choose Modes and Scenarios > Custom Modes > New Custom
Mode; or click Custom Modes in the Modes and Scenarios toolbar, and select New custom mode. This
brings up the New Custom Mode dialog box.

Power - New Custom Mode rs__(|
Mame: | Mode3
Based on mode: |.ﬁ.l:l:ive ﬂ
Comrment:

| Frequency 15 MHz|

Help K | Cancel |

Figure 29 - New Custom Mode Dialog Box

2. Enter the mode name, select the base mode, and enter comments that describe the mode. The base mode
can be either a user-defined custom mode or the active mode. The new mode will inherit all clock and data
frequencies and annotations of its base mode.

3. Click OK. The newly created operating mode is set as default in the Modes and Scenarios toolbar.

To edit a custom mode:

1. From the Edit menu in SmartPower, choose Modes and Scenarios > Custom Modes > Edit Custom
Mode; or right-click the mode in the Modes and Scenarios toolbar, and select Edit custom mode. This
brings up the Edit Custom Mode dialog box.

Power - Edit Custom Mode [custom_mode] [‘S__<|

Marme: cuskom_mode

Cornrment:

| Copied from "sleep”

This mode is derived from the "Sleep” low power mode.,

Help (] 4 | Cancel

Figure 30 - Edit Custom Mode Dialog Box
2. Edit the mode name and comments.
3. Click OK.

Note: You can only use the Edit Mode dialog box to edit the name and comment of the current mode. To
edit the mode properties such as clock and data frequencies, use the SmartPower tabs.

To copy a custom mode:

1. Right-click the mode in the Modes and Scenarios toolbar, and select Create a copy of this mode. This
brings up the New Custom Mode dialog box.
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Power - New Custom Mode PS__<|
Marmne: Zopy of Ackive
Based on mode: |.ﬁ.ctive j
Cormment:

| Copied from "Ackive"
Help (] 4 | Cancel |

Figure 31 - New Custom Mode Dialog Box

2. Edit the mode name and comments.
3. Click OK.

To delete a custom mode:

1. From the Edit menu in SmartPower, choose Modes and Scenarios > Custom Modes > Delete Custom
Mode; or right-click the mode in the Modes and Scenarios toolbar, and select Delete Mode. This brings up
the Delete Custom Mode dialog box.

Power - Delete Custom Mode f'5_<|

Choose the custom mode to delete:

Help Ik | Zancel

Figure 32 - Delete Custom Mode Dialog Box

2. Select the mode from the pull down and click OK.
Note: You can only delete custom operating modes. Pre-defined modes cannot be deleted.

Scenarios

A scenario is a sequence of previously defined operating modes with a specific duration for each mode. When
you create a new design, SmartPower will automatically create some pre-defined scenarios that can be used as
is, or copied to create a new scenario based on the pre-defined one.

Note: Pre-defined scenarios cannot be deleted or edited.

To set the current scenario for analysis:

From the Edit menu in SmartPower, choose Modes and Scenarios > Use for Analysis > <scenario name>; or
select the scenario in the Modes and Scenarios toolbar.

Note: When a scenario is selected, only the Summary tab is available.

To create a new custom scenario

1. From the Edit menu in SmartPower, choose Modes and Scenarios > Custom Scenarios > New Custom
Scenario; or click Scenarios in the Modes and Scenarios toolbar, and select New custom scenario. This
brings up the New Custom Scenario dialog box.

2. Enter the scenario name, enter a duration (total duration for the sequence must equal to 100%) and select
previously defined operating modes for this sequence.

3. Click OK. The newly created scenario is set as default in the Modes and Scenarios toolbar.
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To edit a custom scenario:

1. From the Edit menu in SmartPower, choose Modes and Scenarios > Custom Scenarios > Edit Custom
Scenario; or right-click the scenario in the Modes and Scenarios toolbar, and select Edit custom scenario.
This brings up the Edit Custom Scenario dialog box.

Power - Edit Custom Scenario [Copy of 50% Flash®F... X

Duration [¥] Mode
Al Ative
a0 Flazh"Freeze

0 00| =1 O O e L 0 —

Tatal: 100 %%

(IR

Carmrmenk:

| Copied from "50% Flash*Fresze"

Help (4 | Cancel |

Figure 33 - Edit Custom Scenario Dialog Box

2. Edit the information.
3. Click OK.

To copy a scenario:

1. Right-click the scenario in the Modes and Scenarios toolbar, and select Create a copy of this scenario.
This brings up the New Custom Scenario dialog box.
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Power - New Custom Scenario [g|
Marme:
Duration [%] Mode -
1 20 Active
2 2l Sleep
3
4 |
5
E
7
S
I 4
Tokal: 100 %
Cornrment:
| Copied from "scenariol”
Help Ik | Cancel |

Figure 34 - New Custom Scenario Dialog Box
2. Edit the information.
3. Click OK.

To delete a custom scenario:

1. From the Edit menu in SmartPower, choose Modes and Scenarios > Custom Scenarios > Delete Custom
Scenario; or right-click the scenario in the Modes and Scenarios toolbar, and select Delete Scenario. This
brings up the Delete Custom Scenario dialog box.

Power - Delete Custom Scenario [‘S__<|

Choose the cuskom scenario ko delete:

Help Ik | Zancel

Figure 35 - Delete Custom Scenario Dialog Box
2. Select the scenario from the pull down and click OK.

Power Reports

The power report enables you to quickly determine if any power consumption problems exist in your design.

To generate a power report:

1. From the Designer Tools menu, choose Reports > Power > Power. The Power Report dialog box appears.

2. Select the options you want to include in the report, and then click OK. The power report appears in a
separate window.

You can also generate the power report from within SmartPower. From the Tools menu, choose Reports >
Power Report, or click the Report button to open the Report dialog box. By default, the report includes global
design information and a power summary. Specify which results you want to display by selecting the categories
and their options.
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The power report dialog box is organized in the following panels: General, Operating Conditions, Options,
Breakdown by Instance, Frequency Summary, and Probability Summary.

General

The general panel enables you to select what to include in the report, the report format, and the mode that you
want to generate the report for.

*{J Power Repo [® =]
E| General
Operating Conditions Include in the report I:
Options

W Power summary

I Breakdown by rail

[ Breakdown by type

I Breakdown by dock domain
[ Thermal summary

[ Battery life

I Clock domain summary

—

Breakdown by Instance
Frequency Summary
2% Probability Summary

I N

Report Format: |}{ML

Led Led L

Modes: |5tah'c

Help Ok | Cancel

Figure 36 - SmartPower Power Report Dialog Box - General Panel

Include in the Report
Select the option(s) that you want to include in the Power Report:
Power summary — This section reports the static, dynamic and total power consumption of the design.
Breakdown by rail — This section shows the power consumption of each rail.

Breakdown by type — This section enables reporting on the power consumption according to: gates, nets,
clocks, core static, IOs and memories.

Breakdown by clock domain — This section enables reporting on the power consumption of each clock domain.

Thermal summary — This section includes a thermal report. The ambient temperature can be defined by the
operating conditions or defined by the ambient temperature.

When the first option is selected, the following characteristics are reported:
e Operating conditions
e Temperature range
e Junction temperature
When the second option is selected, the following characteristics are reported:
e Ambient temperature
e Cooling style
e Package
e Thermal resistance Theta-JA
e Junction temperature
e Temperature range
e Junction temperature range limits specification
Battery Life — This section reports the battery life.
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Clock Domain Summary — This section reports the clock and data frequencies for each clock domain.
Operating Condition Summary — This section reports the operating conditions.

Annotation Coverage - This section reports the number and percentage of pins annotated by each source (VCD,
manual annotation, SmartTime constraint, vectorless estimation, and fixed values) for all clocks, register outputs,
combinational outputs, set/reset nets, primary inputs, enable pins, and other pins

Report Format
Select Text, XML or CSV (Comma Separated Value) as the desired export format.

Mode

Select a mode to generate the report for.

Operating Conditions
The Operating Conditions panel enables you to select the operating conditions for the current report.

A0 Power Report ==

Select a Category Operating Conditions
5 General

Operating Conditions

= Options

g Breakdown by Instance
Frequency Summary

Q{} Probability Summary

Case: ]Typical ﬂ

Help oK | Cancel |

Figure 37 - SmartPower Power Report Dialog Box - Operating Conditions Panel

Options

The Options panel enables you to select power and frequency units and to use toggle rates.
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7 Powerkepen (7=

pr—
= General

Operating Conditions
1= Options

Breakdown by Instance
Frequency Summary

2 Probability Summary —Units
Power: iy -
Frequency: MHz -

¥ Use Toggle Rates

Help Ok | Cancel

Figure 38 - SmartPower Power Report Dialog Box - Options Panel

Units
Frequency: Sets unit preferences for frequency - Hz, KHz, MHz.
Power Units: Sets unit preferences for power - W, mW, or uWw.

Use Toggle Rates
When toggle rates are active (Use Toggle Rates box is checked), the data frequency of all the clock domains is
defined as a function of the clock frequency. This updates the data frequency automatically when you update the
clock frequency. Toggle rates enable you to specify the data frequency as a percentage of clock frequency, but
you can no longer specify the data frequency as a number, only as a percentage of the clock frequency. To set
the data frequency again, clear the Use Toggle Rates option.

Breakdown by Instance
From this panel you can include the breakdown by instance in the report and set specific options.
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7 Powerkepen (7=

= General

Operating Conditions
1= Options
g Breakdown by Instance

Frequency Summary
@} Probability Summary [T Limit the number of reported instances to 0

(= Report anly instances with power greater than 0.00 miif
Sortby : Power Values
Sort order Descending it

r I Indude Breakdown by Instance

Help Ok | Cancel |

Figure 39 - SmartPower Power Report Dialog Box - Breakdown By Instance Panel
Include breakdown by instance — This section shows the power consumption of each element that has been
instantiated in the design: gates, nets, memories, and 10s.
The breakdown by instance can be filtered by:
¢ Limit the number of reported instances to: will limit the number of instances reported to the specified
number.
¢ Report only instances with power greater than: any instance with power consumption below the selected
value will not be reported.
This section can be sorted by selecting the preferred method:
e Sort by: Name (alphabetical) or Power Values
e Sort Order: Ascending or Descending
Note: The filter reduces the number of lines in the report, one per instance.

Frequency Summary
From this panel you can include the frequency summary in the report and set specific options.
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A7 Power Report (% =]

select a Category Frequency Summary
5 General

Operating Conditions

= Options
Breakdown by Instance r I Indude Frequency Summary
Frequency Summary
2% Probability Summary [T Limit the number of reported pins to 0

(™ Report anly pins with frequencdies greater than llj.l:ID MHz
Sort by : Frequency v
Sort order Descending it

Help Ok | Cancel |

Figure 40 - SmartPower Power Report Dialog Box - Frequency Summary Panel

Include frequency summary — This section shows the frequency summary and reports the pin, net, domain,
frequency, and frequency source for each pin.

The frequency summary can be filtered by:
e Limit the number of reported pins to: will limit the number of pins reported to the specified number.

¢ Report only pins with frequencies greater than: any pin with a frequency below the selected value will
not be reported.

This section can be sorted by selecting the preferred method:
e Sort by: Pin Name, Net Name, Domain, Frequency, or Source
e Sort Order: Ascending or Descending

Probability Summary

From this panel you can include the probability summary in the report and set specific options.
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f[]] Power Report

Options

Frequency Summary
Probability Summary

g
T

Help I

Breakdown by Instance

Select a Category Probability Summary
5 General

= Operating Conditions

(o=

- [~ Indude Probability Summary

Sortby :

Sort order :

IPin MName "I
IDescending - I

[ o |

Cancel I

Figure 41 - SmartPower Power Report Dialog Box - Probability Summary Panel

Include probability summary — This section shows the probability summary and reports the driver, net, rate,
source, and type for each pin.

This section can be sorted by selecting the preferred method:

e Sort by: Pin Name

, Net Name, Rate, Source, or Type

e Sort Order: Ascending or Descending

:G]i.-_-n |E||EI $4
-
Power Report for design top with the following settings:
Vendoz: Microsemi Corporation
Program: Microsemi Libero Software, Release wvl2.1 (Version 12.600.0.14)
Copyright (C) 1989-201%
Date: Thu May 2 16:29:27 2019
Version: 3.0
Design: top
Family: PolarFire
Die: MPF100T
Package: FCG484
Temperature Range: EXT
Voltage Range: EXT
Operating Conditions: Typical
Operating Mode: Static
Process: Typical
Data Source: Production
Power Summary
e e ——————— e ———————— +
I | Power (mW) | Percentage |
+ + - e e +
| Total Power | 52.153 | 100.0% |
| Static Power | 52.153 | 100.0% |
| Dynamic Power | 0.000 | 0.0% |
=z
Kl i

Figure 42 - SmartPower Report

In addition to the information selected on the Power Reports dialog box, the report contains global design

information.
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Global design information: This section shows the target family, the package and the die. It also shows
information about the operating conditions, speed grade, and power mode. This option is set by default.

See Also

Report (Power)

Scenario Power Report

The scenario power report enables you to select a previously defined scenario and calculate the average power
consumption and the battery life for this scenario.

To generate a scenario power report:
Note: To generate a scenario power report, your design must contain one or more scenarios.
1. From the Designer Tools menu, choose Reports > Power > Power Scenario. The Scenario Power Report
dialog box appears.
2. Select the options you want to include in the report, and then click OK. The scenario power report appears
in a separate window.

You can also generate the scenario power report from within SmartPower. From the Tools menu, choose
Reports > Scenario Power Report, or click the Scenario Power Report button to open the Power Scenarios
dialog box. By default, the report includes global design information and power sequencer summary. Specify
which results you want to display by checking the boxes to be included in the report.

The power report dialog box is organized in the following panels: General, Operating Conditions, Options, and
Battery Life.

General

The general panel enables you to select what to include in the report, the report format, and the scenario you
want to generate the report for.

Scenario Power Report &l

|
1B General

&= Operating Conditions Include in the report

B Dptiors i Break dovn by rail

k Battery life Breakdown by tupe

Breakdown by mode
Operating condition surmmary

Repart format; |Te:-:t j

Scenario; |scenari02 -

Help Ok | Cancel |

Figure 43 - SmartPower Scenario Power Report Dialog Box — General Panel

Include in the Report
Breakdown by Rail — This section shows the power consumption of each rail.

Breakdown by Type — This section enables reporting on the power consumption according to: gates, nets,
clocks, core static, |Os, and memories.

Breakdown by Mode - This section enables reporting on the power consumption by mode.
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Operating Condition Summary — This section reports the operating conditions.

Report Format

Select Text or CSV (Comma Separated Value) as the desired export format.

Scenario

Select a previously defined scenario to generate the report from.
Operating Conditions
The Operating Conditions panel enables you to select the operating conditions case for the current design.

X

Scenario Power Report

Select a Category: Operating Conditions |
1B General
el Operating Conditions

B Dptiors
[ Battery life

Case! | Typical j

Help [ o ]

Cancel

Figure 44 - SmartPower Scenario Power Report Dialog Box — Operating Conditions Panel
Options

The Options panel enables you to select power and frequency units and to use toggle rates.
Scenario Power Report &|

1B General
&&| Operating Conditions

[ Battery life

Units
FPower: mi -

Frequency: MHz -

v Use toggle rates

Help 0k | Cancel

Figure 45 - SmartPower Scenario Power Report Dialog Box — Options Panel
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Units

Frequency: Sets unit preferences for frequency — Hz, KHz, MHz.
Power Units: Sets unit preferences for power — W, mW, or vW.

Use Toggle Rates

When toggle rates are active (Use Toggle Rates box is checked), the data frequency of all the clock domains is
defined as a function of the clock frequency. This updates the data frequency automatically when you update the
clock frequency. Toggle rates enable you to specify the data frequency as a percentage of clock frequency, but
you can no longer specify the data frequency as a number, only as a percentage of the clock frequency. To set
the data frequency again, clear the Use Toggle Rates option.

Battery Life

The Battery Life panel enables reporting of the battery capacity and the battery life. Enter a battery capacity in
MA/Hrs.

Scenario Power Report &l

Select a Category: Battery life |

1B General
&&| Operating Conditions
B Dptiors

Iv Include battery life

Battery capacity: | 1000.00 ma * Hrs

Help Ok | Cancel

Figure 46 - SmartPower Scenario Power Report Dialog Box — Battery Life Panel
The SmartPower scenario power report returns the average power consumption and battery life for this sequence.
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Fa| fpga_igloo - Power_scenario Report

EEX

File Actions Help
~
Soenario  Power Report for design fpga igloo with the following settings:
Vendor: hotel Corporation
Program: hotel Designer Software, Belease 8.4, Copyright (C) 1989-2008
Date: Thu May 29 13:42:10 2005
Version: 3.0
Design: fpga igloo
Family: IGLOO
Die: AGLE0O0OVE
Package: 454 FEGL
Temperature Range: COM
Voltage Range: COM
Operating Conditions: Typical
Data Source: Adwanced
Scenario Name: my_scenario
Socenario Average Power
o Fmm Fmm +
| | Power (wll} | Percentage |
o Fmm Fmm +
| Total Power | 10.926 | 100.0% |
| SZtatic Power | 0.138 | 1.3% |
| Dynamic Power | 10.788 | 958.7% |
o o o +
Battery Life
B e Tt B e Tt +
| Battery Capacitcy | 1000.000 mi*Hours |
B e Tt B e Tt +
| Battery Life | 207.803 Hours |
B e Tt B e Tt +
Ereakdown by mode
o E e e e o o +
| Mode | Power in the Mode (wl) | Duration | Power*Duration Weight |
o E e e e o o +
| Mode Actiwve | 21.733 | sS0.0% | 99.5% |
| Mode Static | 0.156 | 35.0% | 0.5% |
| Mode 3leesp | 0.033 | 15.0% | 0.0% |
o e o o +
W
< >

Figure 47 - SmartPower Scenario Power Report

In addition to the information selected on the Scenario Power Reports dialog box, the report contains global
design information, a mode summary and the sequence average power.

Global design information: This section shows the target family, the package and the die. It also shows
information about the operating conditions, speed grade and power mode. This option is set by default.

Power Summary: This section reports the power consumptio
default.

n of the sequence by mode. This option is set by

Sequence Average Power: This section reports the average power consumption of the sequence. This option is

set by default.
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See Also
Report (Sequencer)

Activity and Hazards Reports

General

Traditional Power Analysis based on a VCD simulation file reports an average power value that will account for all
nets switching in the design. This switching includes functional transitions and spurious transitions. Due to the
delay of each gate, paths arriving at one internal gate may have different propagation delays. Therefore, a gate
may exhibit multiple spurious transitions before settling to the correct logic level. The Activity and Hazards Power
Report allows to quickly identify gates and nets of the design that consume power because of spurious
transitions. This is helpful to understand and further minimize power consumption. The activity and hazards report
reads a VCD file and reports transitions and hazards for each clock cycle of the VCD file.

To generate an activity and hazards power report:

1. From the Designer Tools menu, choose Reports > Power > Power Activity and Hazards. The Activity and
Hazards Power Report dialog box appears.

2. Select the options you want to include in the report, and then click OK. The activity and hazards report
appears in a separate window.

You can also generate the activity and hazards report from within SmartPower. From the Tools menu, choose
Reports > Activity and Hazards Report; or select a vcd file from the Modes and Scenarios toolbar, and from the
right-click menu, select Tools > Power Activity and Hazards

The activity and hazards report dialog box is organized in the following panels: General, Partial Parsing, Top-
Level Name, Glitch Filtering, and Clock Domains.

Activity And Hazards Power Report E|
General
YLD parsing optiahz WD Files |D:'I,WDrk'l,CDdE'I,dESigI‘I_VCd'I,BMCItDr.‘\.-'Cd j El

Fartial parsing

Top level name Report Format: | Text -

Glitch fikering
Clock. damaing |Jse operating conditions Fram: |.ﬁ.ctive j (1 ]

Repart type: Report by Mek - summary j

For each net, report activity and power

sort by kotal power: sort order descending;
Limit: the number of reported nets to 40,

Help 0k Cancel

Figure 48 - SmartPower Activity and Hazards Report Dialog Box — General

VCD file — Select the VCD file you want to import.
Report format — Select Text or CSV (Comma Separated Value) as the desired export format.
Use operating conditions from — Select the mode from which the operating conditions will be used.
Report type — Select the report type:

e Report by net — summary: summary report by net

e Report by net — detailed: detailed report by cycle

e Report by cycle — summary: summary report by net
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e Report by cycle — detailed: detailed report by cycle

The selected report type reports activity and power for each net sorted by power in descending order and
limits the number of reported nets to 20 by default. To change these options, click each option and from
the pop-up menu, select the desired option:
e Report: Select the query report type: activity, power, or activity and power.
e Sort by: Select the query sort by functional power, functional transitions, spurious power, spurious
transitions, or total power.
e Sort order: Select the query sort order: ascending or descending.

e Limit the number of reported nets: Enter the query filter limit.

Partial Parsing

Activity And Hazards Power Report

Select a Category: Partial parsing

General

WD parsing options
Partial parsing
Top level name
Glitch filkering

Clock domains

__ [

v Partially parse WCD

Start kime: 0.00 ns

End kime: 10000.00 ns

Help Ok | Cancel

Figure 49 - SmartPower Activity and Hazards Report Dialog Box — Partial Parsing

Partially parse VCD file — Specify the Start and End times to partially parse the VCD file. This option can be
used for large VCD files.
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Top-Level Name

Activity And Hazards Power Report E|
Select a Category: Top level name |
General

YLD parsing optiahz
Fartial parsing

Top level name
Glitch fikering
Clock domains

+  Automatic detection

" Specify: |

Help 0k | Cancel

Figure 50 - SmartPower Activity and Hazards Report Dialog Box — Top-Level Name
This option enables you to select how the top-level name is specified. Select Automatic Detection to let the
VCD reader automatically detect the top-level name of the design, or select Specify to manually specify the top-
level name.

Glitch Filtering

Activity And Hazards Power Report E|
Select a Category: Glitch filtering |
General

WD parsing options
Partial parsing
Top level name

Clock domains C off

(¥ pAukornatic glicch Filkering

(" Specify Filkering threshold:

Help Ok | Cancel

Figure 51 - SmartPower Activity and Hazards Report Advanced Options Dialog Box — Glitch Filtering

This option enables you to filter out pulses of short durations by selecting Automatic Glitch Filtering or by
entering a value in the Specify Filtering Threshold field. The default glitch filtering option is Automatic Glitch
Filtering.
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Clock Domains

Activity And Hazards Power Report El
Select a Category: Clock domains |
General Clock domain

YLD parsing optiahz
Fartial parsing

Top level name ™ Specify: l—

Glitch fikering

Clack damains ’—

{* Automatic construction

Clock domain | Active clock | Achive edge

1 | Pwdbd_clk tiue | riging |
2 lunl_dataa_int_ME|true || rizing |

Help 0k | Cancel |

Figure 52 - SmartPower Activity and Hazards Report Advanced Options Dialog Box — Clock Domains
The clock domain can be automatically constructed or it can be specified by the user.

Automatic construction — This option automatically constructs the clock domain. SmartPower automatically
analyzes your design to assess if a clock is active and what is the active edge.

Specify — Select this option to specify the period and first edge.
Use the clock domain table to set the active edge (rising, falling or both) and to set a clock as transparent.
The results are displayed in the activity and hazards power report below.

50



& Microsemi

a S\ MicrocHIP company

SmartPower User Guide

[l simple_PWM_B - Power_activity_and_hazards Report

File Actions Help

Llctlvit.y map report -~

Aotel Corporation — Actel Designer Software Release 8.4 (Version 8.4.0.0)
Copyright (o) 1989-2008
Date: Tus May 06 10:43:59 Z00S

Design : simple_PUWM &

Family : IGLOO

Die : AGLEOOVZ

Package : 256 FBGL
Temperature Range @ COM
Woltage Range @ CON

COperating Conditions : Typical
Operating Mode : Active

Data Source : Advanced

Wod file: D:fwork/code/design ved/BMotor . ved

Aotivicy Map @0 Swnmary

Transitions | Dynamic Power (wW) |

| Total | 44154 | 0.155
| Tunctional | 32364 | 0.1z@

| Spurious

11620 | 0.027 |

Aetivicy Map: Net Swanary

| Net | Clock Domain | Type | Functionsl | Spurious | Functional | Spurious |
| | | | Transitions | Transitions | Power | Power |
| | | | | [ | (xall) |
| PUM_clk o | PUM_clk | Clock | 58999 | o | 0.020 | 0.000

| PUM _clk c_0O | PUM_clk | Clock | 55999 | o | 0.01% | 0.000

| Qaux[0] | uni_dataa_int NE:¥ | Data | 1 | zZ95a8 | 0O.000 | 0.013 |
| PUM_clk pad/U0/NET1 | PUM_clk | Clock | 5999 |0 | o.o010 | 0.000

| Qaux[1] | unl datsa int NE:¥ | Data | 1 | 1492 | 0O.000 | 0.005 |
| un3 gaux U1l DWACT FINC E[0] | PUM clk | Data | 746 | o | 0.003 | 0.000

| Qaux[2] | unl_datasa_int NE:Y | Data | O | 746 | O.000 | 0.003

| Qaux[3] | unl_dataa_int NE:Y¥ | Data | 23 | 350 | O.000 | 0.002

| unl_dacasa_int_0_1 | unl_dacaa_int NE:Y | Daca | 1 | zZ956 | O.000 | 0.001

| I_4 | PUM_clk | Data | 29&7 | o | o.o001 | 0.000

| 15 | PUM_clk | Data | 1494 | o | o.oo1 | 0.000

| PUM out pad/U0/HNET1 | uni datsa int NE:¥ | Data | 21 |0 | o.oo01 | 0.000

| unl datsa int 1 i | unl datsa int NE:¥ | Data | 1 | 1492 | 0O.000 | 0.001 |
| I3 | PUM clk | Data | 747 | 0 | 0.001 | 0.000 |
| Qaux[4] | unl_datasa_int_NE:Y | Data | 2 | 184 | O.000 | 0.001

| I_13 | PUM_clk | Data | 373 | 374 | 0.000 | 0.000

| und_gaux_N_22 | PUM_clk | Data | 746 | o | 0.000 | 0.000

| Qaux[5] | uni_dataa_int_NE:T | Data | 3 | =0 | 0O.000 | 0.000 | “

£ >

Figure 53 - SmartPower Activity and Hazards Report

Importing a VCD File

The Value Change Dump (VCD) file is a simulation file. The format of this file is specified in the IEEE 1364
standard.

You can configure the Project Manager to automatically generate VCD files using ModelSim.

You can also generate a VCD file with a ModelSim simulator using the following commands:
ved file example.vced
ved add -r /testbench/<top> 0/*
run 1 us
ved flush

This example creates a VCD file example.vcd, adds all signals recursively, runs the simulation for one micro
second, and quits. You must quit ModelSim in order to get an accurate result from SmartPower.

If you have not yet completed the layout of the design, the design software guides you through place-and-route so
that you can import the VCD file. In order to successfully annotate your VCD values to the design, Designer must
complete place-and-route even if you generated your VCD file using timing simulation (pre-layout).
Note: SmartPower has been validated with VCD files generated by ModelSim. However, you may use any
Verilog/VHDL simulator that offers a VCD dump feature.

Refer to the user manual of your simulation tool for more information on how to generate a VCD file.
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To import a VCD file:
1.

Import YCD Options

Select a Category:
General
WCD parsing ophions
Partial parzing
Top level name

General

& Microsemi

a S\ MicrocHIP company

From the Simulation menu, select Import VCD File. This opens the Import VCD Options dialog box.

X

Glitch filkering

YD File: | Dihwarklcodedsub,ved
Remaining signals

Impork in:

|

{* Existing mode: |.0.ctive

" Mew maode: |

Help [ o ]

Cancel

Figure 54 - Import VCD File Dialog Box
2.

mode name.

3. Select the options you want to specify:

Select the VCD file you want to import and select a mode to import it in, or click New Mode and enter a

Partial Parsing — Specify the Start and End Times to partially parse the VCD file. This option can be used

for large VCD files.
Import ¥CD Options

Select a Category: Partial parsing

General
WCD parzing options

Partial parsing

Top level name

Glitch filkering
Fiemaining signals

[ Partially parse WD

Help [ ok ]

Cancel

X

Figure 55 - Import VCD File Dialog Box — Partial Parsing

Top-Level Name — This option enables you to select how the top-level name is specified. The Top Level Name is

the instance name of your design instantiated in the simulation testbench.

Select Automatic Detection to let the VCD reader automatically detect the top-level name of the design, or select

Specify to manually specify the top-level name.
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Import ¥CD Options

Select a Category: Top level name

General
WCD parzing options
Partial parsing

Top level name
Glitch filkering
Fiemaining signals

(* pmutomatic detection

™ Specify:

]

Cancel

Help
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X

Figure 56 - Import VCD File Dialog Box — Top-Level Name

Glitch Filtering — This option enables you to filter out pulses of short durations by selecting Automatic Glitch

Filtering or by entering a value in the Specify Filtering Threshold field. The default option
Filtering.

Import YCD Options

Select a Category: Glitch filtering

General

WCD parsing ophions
Partial parzing
Top level name

Glitch filkering
Remaining signals

" off

*  gukarmatic gikch filkering

" Specify filkering threshold:

Help 1] 8 | Cancel

is Automatic Glitch

X

Figure 57 - Import VCD File Dialog Box — Glitch Filtering

Remaining Signals — Some signals may not be annotated by the VCD reader. This generally happens with VCD
files created from a behavioral or a post-synthesis simulation. For those signals, you can either complete the
annotation with the vectorless analysis or with the average values computed from the VCD file.
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Select a Category:

General

WCD parzing options
Partial parsing
Top level name

Glitch filkerin

ighals

emaining &

f* Lse Yectarless analysis

" Use Average values computed from YCD

Help [ ok ]

Cancel
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X

Figure 58 - Import VCD File Dialog Box — Remaining Signals
4. Click OK.

5.  When the vcd file is successfully imported, the file appears in the Modes and Scenarios toolbar, under the

imported mode. The following messages appear in the Designer Log window:
Info:
VCD:34 glitch(es) filtered with 1000 ps threshold

The message above reports the number of glitches that have been filtered by the VCD reader.

Info:
VCD: Annotation Statistics
Percentage of Annotated Pins:100.00 %

Percentage of Unannotated Pins:0.00

Percentage of Annotated Pins with Zero Frequency: 25.99 %

If the percentage of annotated pins is less than 50.00%, a warning message will be generated.

If the percentage of annotated pins is low, you may want to verify that signals at all levels of hierarchy

were added recursively (for example using ved add -r in ModelSim).

If you simulate a pre-synthesis netlist or a post-synthesis RTL netlist, it is possible to get a low percentage
of annotated pins. This happens because not all logic elements are in the pre-synthesis netlist and the
post-synthesis RTL netlist. For accurate power estimation, it is best to run post-layout simulation with a

back-annotated netlist.

If you want to see exactly which pins are not annotated, open the SmartPower Frequencies_tab. If your
file was imported successfully, you will see a list of pins with annotated individual frequencies displayed
with VCD Import as a source. The unannotated pins are displayed with Default Estimation as source. If

your design has enable pins, open the SmartPower Probabilities_tab.

After finishing the import VCD process, you can now create a custom mode based on the active mode.
This custom mode will inherit all the clock and toggle frequencies of the active mode that have just been
set through the VCD import. This final step is optional. It gives you the flexibility to modify the active mode
frequencies while saving the VCD scenario in SmartPower. Refer to_ Custom operating modes for more

details.

Note: If you generated the VCD file from Project Manager and if you are using Designer from Libero IDE,
the list of generated VCD files appear in the unprocessed VCD file list. To import the VCD file,

right-click and select Import VCD File.
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Unprocessed Simulation Files  « x
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Figure 59 - Unprocessed Simulation Files

Removing a VCD File

The Value Change Dump (VCD) file is a simulation file. The format of this file is specified in the IEEE 1364
standard.

To remove a VCD file:

e Select the VCD file from Active mode or a custom mode, right-click the VCD file, and select Remove VCD
File from <mode name> Mode; or

e From the Simulation menu, choose Remove VCD File > <file name>
Note: Any annotation will be removed when you remove the VCD file.

See Also
Importing a VCD File
Modes and Scenarios Toolbar

Auditing Files
SmartPower checks the time stamps of the VCD file and reports any missing or out-of-date files.

Audit is performed automatically when SmartPower is launched. You can trigger file audit at any time from the
Simulation menu, by choosing Audit Files. An icon displaying the file status appears in the Modes and
Scenarios toolbar next to the VCD file. Mouse over the icon to obtain more information.

Modes and scenarios =

Maodes

Achive

& test? vod
Flazh*Freeze
Sleep
Static
new_custom

o test vod

Scenanios

Figure 60 - Audit Files Results
Table 4 - Audit Files Icons and Descriptions

Icon Description

A Indicates that the VCD file has been modified
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Icon

Description

Q

Indicates that the VCD file is missing

To re-import the VCD file, right-click the VCD file and select Re-import VCD File, this will open the Import VCD

Options dialog box.

56



& Microsemi

a S\ MicrocHIP company

SmartPower User Guide

Calculating Power

Steps to Calculate Power

Use the steps below to calculate the power consumption of your design. The list of screens and steps appear in
the order in which you should view them to analyze your power accurately.

1. Summary tab — View global power at the design level and view its impact on junction temperature.

2. Domains tab — Define clock domains and specify a clock frequency and a data frequency for each clock
domain.

3. Analysis tab — View detailed hierarchical analysis of your power consumption. This step is optional. But if
your power consumption exceeds your budget, this step will help you to understand where there is room for
improvement.

4. Frequencies tab — Specify individual pin frequencies, this step is optional, but gives you pin-by-pin control of
the frequency.

5. Probabilities tab — Specify probabilities, this step is optional. You can use the default probabilities or set your
own.

Extracting Power Consumption of a Specific Clock Domain

To calculate the power consumption of a single clock domain (clock tree and data path) in a design:

1. Set SmartPower in toggle-rate mode. This is the default setting. To confirm that SmartPower is in toggle-rate
mode, choose Preferences from File menu. Select the Use Toggle Rates check box

2. In the Domains tab, set all the Clock Frequencies to zero except for the clock domain for which you are
calculating the power consumption.

The total power consumption of this clock domain is displayed in the Summary tab. This includes the contribution
of the clock buffer, clock tree, and all clock input of the registers of this specific clock domain.

Note: In case you need to determine the power of the clock tree only, set the toggle rate of data on that
clock domain to zero. The total power displayed is the power of that clock tree.

Advanced Analysis of 1/Os

SmartPower provides an easy way of estimating the power consumption related to 1/0s. You can then analyze
power consumption in detail.

To display I/O power consumption:

1. Inthe Summary tab, select By Type from the Breakdown drop-down list. The grid displays the total power
consumption of all I/Os in the design, as well as all other components. If you use different I/0 standards, and
different Vcci power rails, you can also display the power consumption for each rail by selecting By Rail
from the Breakdown drop-down list. Breakdown By Rail shows the power consumption and current for
each Vcci rail in the design.

2. Inthe Analysis tab, select the highest hierarchy level in the Hierarchy tree in the left pane. Select By
Instance from the Breakdown drop-down list.

3. Inthe Analysis tab, unselect all categories under Instances Contributions except I/Os, and then click
Apply. The table then displays a list of all I/Os in the design, along with the power contribution of each
individual I/O. The columns display important I/O attributes: external port name, load, standard, drive-
strength, slew, and macro.

4. In the Probabilities tab, you can control the output probability of each tri-state and bidirectional 1/0. The
probability is the percentage of time that the 1/O is used as an output. The default value can be changed and
a specific value can also be set for each bidirectional or tri-state 1/0.
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See Also

Analyze results
Analysis tab

Define Clock Domains and Set of Pins

When you run SmartPower, it researches your existing clock domains and partitions your design automatically.
You may wish to review the list of clock domains in the Domains tab to ensure that all the clocks of your design
are included in the list. Add or remove clocks as necessary.

To add a new clock domain:

1. Click the Domains tab, and click the Add Domain button. Select Clock Domain from the drop-down list.
This opens the Create Clock Domain dialog box.

Create Clock Domain

x|
Creat
Patential Clock Pin | =(=F N 1M1

Cahicel
Clock Frequency I 10 MHz
[rata Frequency I 1 MHz

Figure 61 - Create Clock Domain Dialog Box — Toggle Rates Disabled

2. To create a new clock, select a Potential Clock Pin, specify a clock and data frequency, and click Create.
The new clock domain appears in the Domains window. If you select an existing clock pin from the drop-
down list, the lists of clock pins and data pins of this new clock domain are computed automatically based on
the netlist topology.

Note: Select Use Toggle Rates in the SmartPower Preferences to define your data frequency as a
percentage of your clock frequency. If your data frequency is 20% of your clock frequency, type "20"
in the Data Frequency text box.

Create Clock Domain x|

Creat
Fatential Clack Pin |G (N TN 41
Cancel |

[ata Frequency

Clock. Frequency I 10 MHz
I 20 %

Figure 62 - Create Clock Domain Dialog Box — Toggle Rates Enabled

You may wish to create an empty clock domain and fill the lists of clock-pins and data pins manually. If so, do not
select a clock pin, just type a new name for your clock domain.

Beyond the verification of the list of clock domains, you may also wish to verify that the lists of clock pins and data
pins computed for each clock domain are correct.

To verify the lists of clock pins and data pins of a clock domain:
1. Click the Domains tab and select a specific Domain in the list.

2. Display the list of clock pins or data pins of this Domain. A drop-down list in the Domains tab enables
you to select clock pins or data pins. SmartPower displays the list of pins corresponding to your selection
below the drop-down list. You can add or remove clock pins and data pins as necessary.

3. Remove a pin from a clock domain. Highlight the selected pin and click the Remove button. The pin is
removed from the clock domain and is made available in the list of pins that you can add in another clock
domain.

4. Highlight the selected pin in the list of pins that are not yet in a domain and click the Add button to add a pin
in a clock domain. This pin is added to the clock domain. It is a clock pin or a data pin, depending on the
specification of the drop-down list when you click the Add button.
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Note: You cannot add a pin that exists in another domain until you free it from its existing domain. The pin is
unavailable until you remove it from that domain.

After you have verified that all the clocks of your designs are correctly identified and constructed, you must
specify the correct clock and data frequency for each clock domain.

To add a new set of pins:

1.  Open the Create Clock Domain dialog box. Click the Domains tab, and click the Add Domain button.
Select Set of Pins from the drop-down list.

x|

Creat
Y e —

Cahicel |
Frequency I 1 MHz

Figure 63 - Create Set of Pins Dialog Box

2. Create a Set of Pins. Name your new set of pins, specify a data frequency, and click Create. The new set
of pins appears in the Domains window.

Specify Clock and Data Frequencies in SmartPower

To specify a clock and data frequency:

1. Click the Domains tab
2. select the Clock/Data frequency cell and type in a new value

SmartPower defaults to 0 MHz for the clock frequency. Import your clock frequency from SmartTime by using the
Initialize Frequencies dialog box in SmartPower or input your target for each clock frequency in the Domains
tab. You must also specify a data frequency (5% of your clock frequency is a typical guideline for your data
frequency — this corresponds to a toggle rate of 10 %.)

Not all the pins/gates/nets of your design are associated with a specific clock. For example, the frequency of a
design input port is not always correlated to a clock frequency. By extension, all pins that are upstream of the first
level of sequential elements are not associated with any clock. SmartPower creates an InputSet by default that it
uses to group all the pins that are controlled by design inputs (instead of sequential elements). You may wish to
view and verify the InputSet to further evaluate your design.

Viewing and Verifying the InputSet in SmartPower

To verify the InputSet:

1. Click the Domains tab and select the domain named InputSet in the list.

2. Verify the list of pins of this domain. All the input ports of your design (except the clocks) belong in the
InputSet. Also, all the pins that are between these input ports and the first level of sequential elements
belong in the InputSet. You can add or remove pins as necessary.

3. Specify an average input frequency. SmartPower uses the same frequency for all pins of the InputSet. The
default InputSet frequency is 1 MHz. Type in a new value to change it.

You may wish to split the InputSet into several sets in order to specify different frequencies. A classic example is
to create a ResetSet, a reset tree with a very low frequency.

To split the InputSet into several sets:

1. Create a new set of pins: In the Domains tab, click the New button, and select Set of Pins from the drop-
down menu. In the Create Set Of Pins dialog box, type a name and a frequency for the new set and click
Create. The new set of pins appears in the Domains window. You can only create an empty set of pins, but
it is possible to add pins to this domain later.

2. Remove a group of pins from the InputSet. Click the Domains tab and select the domain named InputSet
in the list. Select the pins that you want to remove and click the Remove button.
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3. Add this group of pins to the new set of pins. Click the Domains tab and select the newly created set of pins
in the list. Highlight the pins in the list of pins that are not yet in a domain, and click the Add button. Repeat
these three steps as necessary to create multiple input sets.

Specifying Individual Pin Frequencies
The Frequencies tab enables you to specify an average clock and data frequency for each clock domain, and also
an average frequency for each set of pins. This gives you an initial estimate of the power consumption of your
design. However, if this estimate is not accurate enough, you may refine it with a pin-by-pin annotation of the
frequency.

To specify a frequency annotation for an individual pin:

1. Locate the pin in the Frequencies tab. You may need to select different clock domains from the drop-down
list on the Frequencies tab. You can use filters to facilitate this search.

2. Select the pin(s) in the grid and click the Set frequencies for selected pins button, enter a new frequency
value, and click OK. This specifies a new frequency for the selected pin(s).

Note: This annotation procedure enables you to set the frequency of an individual pin, but this does not
mean that the pin is removed from its clock domain. A frequency annotation just overrides the domain
level frequency.

You may wish to change or remove a frequency annotation of an individual pin. This may be useful when you
import a VCD (value change-dump) file or a SAIF (Switching Activity Interchange Format) file.

To change the frequency annotation of an individual pin:

1. Locate the pin in the Frequencies tab. You may need to select different clock domains from the drop-down
list on the Frequencies tab. You can use filters to facilitate the search.

2. Select the pin(s) in the grid and click the Set frequency for selected pins button, enter a new frequency
value, and click OK. This specifies a new frequency for the selected pin(s).
To remove the frequency annotation of an individual pin:

1. Locate the pin in the Frequencies tab. You may need to select different clock domains from the drop-down
menu on the Frequencies tab. You can use filters to facilitate the search.

2. Select the pin(s) in the grid and click the Reset frequencies for selected pins button. This removes the
specified frequency from the selected pins.

Specifying Individual Pin Probabilities
The Probabilities tab enables you to specify the default output probability value for memory blocks, and tristate
and bidirectional 1/Os. In addition, you can increase the accuracy of the power estimation by annotating the
probability of specific pins.
To specify or change the probability for one or multiple pins:

1. Locate the pin(s) in the Probabilities tab. You can use filters to facilitate this search.

2. Select the pin(s) and press the Set probabilities for selected pins button.

3. Enter a new probability value and press OK.

To reset the probability for one or multiple pins:
1. Locate the pin(s) in the Probabilities tab. You can use filters to facilitate this search.

2. Select the pin(s) and press the Reset Probabilities for selected pins button. This will reset the probability
value.

Vectorless Estimation

The Vectorless estimation method is an accurate method of annotating individual pins with frequencies and
probabilities. It uses primary inputs, clock frequencies, and nets annotated with other methods as a starting point,
and uses a Monte Carlo simulation to annotate all nets in the design with frequencies and probabilities.
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Vectorless estimation is available and enabled by default for SmartFusion, IGLOO, ProASIC3 and Fusion families
of devices.

Vectorless estimation can be enabled from the Initialize Frequencies and Probabilities dialog box or from the VCD
Import dialog box.

Changes to probabilities or frequencies in the Probabilities, Frequencies, or Domains tabs result in an out-of-date

~
vectorless estimation. To update vectorless estimation, press the refresh vectorless ™ button.

Viewing Results (Design Level)

Click the Summary tab to view global power consumption at the design level. The Summary tab shows your
design's estimated power consumption and temperature information.

The power estimation reported in the Summary tab is the total static and dynamic power consumption of your
design. For a more detailed view of this power consumption, click the Analysis tab.

To estimate the junction temperature:

1. Verify your package. You cannot change your package directly in SmartPower, because it may render your
place-and-route information (and thus it may severely impact the total power consumption). If you wish to
choose another package, you have to do it in Designer > Tools > Device Selection.

2. Click the Summary tab, and select a Cooling style in the list. Thermal resistance changes automatically
when you update the cooling style.

3. Specify an ambient temperature. Enter an ambient temperature (default value is 25°C), and click the Set
button.

Note: The junction temperature value changes according to the package, cooling style, and ambient
temperature values you choose.

Analyzing Results

The Analysis tab displays the estimated power consumption of individual blocks, gates, nets, I/Os, and memory
and enables you to make a hierarchical analysis of your power consumption. The Analysis tab may also help you
to improve your power consumption by identifying the components that consume a significant amount of power.

To identify the components consuming the most power:

1. Use the Analysis tab to expand the design hierarchy. The Analysis tab enables you to expand your design
hierarchy and view a complete list of the blocks in your design. In the hierarchy window, click the + next to
your design to view the items in the hierarchy. Click the + next to a sub-block to view its sub-elements.
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Figure 64 - Analysis Tab Dialog Box

2. Click to select a block. By default, SmartPower selects the design-level block, but you can always select
another block in the hierarchical tree. The Report window displays the list of sub-elements of the selected
block. Initially, this list includes all sub-elements. The grid in the Analysis window displays a breakdown of
the power of the selected block by type. This breakdown provides you a good overview of which areas of
your design you should optimize for power.

3. To find the components that use a significant amount of power, choose By Instance from the Breakdown
drop-down list.

4. Sort and filter the sub-elements to find the component that is using the most power. The Analysis window
displays the list of sub-elements of the selected block. By default, this list includes all sub-elements. The grid
contains columns for name, type, power, driver, fanout, macro, I/O standard, output load, output drive, slew,
port, domain and frequency. You may limit the list of sub-elements to a list of sub-blocks, nets, gates, 1/Os,
memories, or any combination of these five classes of sub-elements. You can sort the list according to any
column by double-clicking the column header.

See Also
Advanced Analysis of 1/0Os

Analysis tab

SmartPower Calculation Equations

SmartPower calculates the static power and the dynamic power of your design, for given operating conditions and
operating modes:

Static Power: This value is a summation of the static power consumed by each element of the design.
SmartPower provides a static power consumption of the array. This value is die-dependent. This value is also a
function of the operating mode. For some families, SmartPower also considers a static power contribution per I/O
bank. For specific I/0 technologies like voltage referenced |/Os or differential 1/0s, SmartPower also considers a
static power contribution per 1/0.

Dynamic Power: This value is a summation of the dynamic power consumed by each element of the design
(nets, modules, I/Os, RAMs, FIFOs, PLLs, etc.).

Operating Conditions: SmartPower calculates power consumption in Worst, Typical, or Best operating
conditions. SmartPower uses the following as general guidelines:
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o |t applies a voltage derating to dynamic power contributions. Higher voltage typically leads to higher power
consumption.

e |t applies a temperature derating to static power contributions. Higher temperature typically leads to higher
power consumption.

e |t applies no radiation derating.

Operating Modes: SmartPower calculates power consumption in Active, Static, Flash*Freeze, Sleep, and
Shutdown operating modes, when applicable for your design.

Sample Equations:

The examples below are for general evaluation purposes only. They are not a precise representation of the actual
calculations, since each calculation takes into account family-specific information.

e For a net,
Pp=cC- 1. F
where C is the total capacitive loading of the net (extracted from the routing topology), V is the net's voltage
swing, and F is the average switching frequency.

Note: For the ProASICELYS family, SmartPower extracts the capacitive loading of a net from a Wire Load
model.

e For a module, the power is computed using a characterized library (by family and die-size) describing a
specific power model for each type of module. For example, the power model of a flip-flop is given by

P= P(“K' 'L-{‘K"' Jr}DOU]‘"' 'L-DO,[_."T-'- PD.I'H ' ’J'-Dns
where Fck is the average clock-input frequency for this flip-flop, Foour is its average data-output frequency,

and Pck, Poour, poin are three constants estimated by electrical simulation and silicon characterization for this
flip-flop module, and FDin is its average data-input frequency.

e Foran /0, the formula used for computing the power consumption depends on the I/O technology and the
family. For example, for a TTL output, the dynamic power is given by
lr} = ir}‘[_ll\.']r' .I;'-+(_I' i'} I-.
where C is the output load (derived from what you have set in the 1/O Attribute Editor GUI, typically 35 pF for
TTL), V is the output's voltage swing (3.3 V for TTL), and Pint represents an internal power contribution
dissipated in the pad, and F is the average switching frequency of the I/O.

e For a complex block, like a RAM, a FIFO, or a PLL, SmartPower uses a high-level power model that
integrates design parameters.
SmartPower automatically computes all the constant parameters of these equations. However, the frequencies
depend on the target frequencies of your design. Since it is impractical to enter each frequency manually,
SmartPower has several flows that help you to estimate the frequencies and calculate the power consumption.
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SmartPower Tcl Commands

Refer to the following documents for detailed information about Tcl commands supported by SmartPower:
e SmartFusion2, IGLOO2, RTG4 Tcl Commands Reference Guide
e PolarFire FPGA Tcl Commands Reference Guide
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https://coredocs.s3.amazonaws.com/Libero/12_2_0/Tool/pf_tcl_cmd_ref_ug.pdf
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Data Change History - SmartPower

The data change history report lists power data updates up to the current release that may impact the power
consumption of the design.

To generate a data change history report, from the Help menu, choose Data Change History. This opens a data
change history report in text format.
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