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Introduction 

This tutorial demonstrates how to develop an application that can be implemented using SmartFusion
®
 

customizable system-on-chip (cSoC) device. After completing this tutorial, you will be familiar with the 

following: 

1. Creating and implementing a project using SoftConsole and SmartFusion cSoC device 

2. Configuring the peripherals using SmartDesign 

3. Configuring the analog compute engine (ACE) 

4. Generating the programming file to program the SmartFusion cSoC device 

5. Compiling application code 

6. Creating and launching a debug session 

Tutorial Requirements 

Software Requirements 

This tutorial requires the following software installed on your PC: 

 Libero
®
 system-on-chip (SoC) v10.0 (or later) that can be downloaded from the link below: 

www.microsemi.com/soc/download/software/libero/files.aspx. 

 Microsemi SoftConsole v3.3 or later, which is installed as a part of Libero SoC v10.0 installation or can be 

downloaded from www.microsemi.com/soc/download/software/softconsole/default.aspx 

 FlashPro v10.0 or higher, which is often installed as part of the Microsemi Libero SoC installation and can 

be launched from within Libero SoC or as a standalone. 

Hardware Requirements 

This tutorial requires the following hardware: 

 SmartFusion Evaluation Kit Board or SmartFusion Development Kit Board. 

 Two USB cables (programming and communication) — one for connecting the programmer to your PC 

and the other to connect the universal asynchronous receiver/transmitter (UART) interface on the board to 

PC. 

Associated Project Files 

You can download the associated project files for this tutorial from the Microsemi website: 

www.microsemi.com/soc/download/rsc/?f=SmartFusion_SoftConsole_POTlevel_UART_tutorial_DF. 

You can download the programming file (*.stp) in release for this tutorial from the Microsemi website: 

www.microsemi.com/soc/download/rsc/?f=SmartFusion_SoftConsole_POTlevel_UART_tutorial_PF. 

MSS Components Used 

 ARM
®
 Cortex

™
-M3 processor 

 Communications matrix 

 Clock conditioning circuitry (CCC) 

 UART_0 

 ACE 

http://www.microsemi.com/soc/download/software/libero/files.aspx
http://www.microsemi.com/soc/download/software/softconsole/default.aspx
http://www.microsemi.com/soc/download/software/softconsole/default.aspx
http://www.microsemi.com/soc/download/rsc/?f=SmartFusion_SoftConsole_POTlevel_UART_tutorial_DF
http://www.microsemi.com/soc/download/rsc/?f=SmartFusion_SoftConsole_POTlevel_UART_tutorial_PF
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Target Board 

SmartFusion Evaluation Kit Board (A2F-EVAL-KIT) or SmartFusion Development Kit Board (A2F-DEV-KIT). 

Objective 
The objective of this tutorial is to explain how to configure the SmartFusion cSoC MSS peripherals using the 

SmartFusion cSoC MSS configurator outside the Libero SoC V10.0 flow. 

Design Steps 

Following are the major steps to be executed for this tutorial: 

 Configure the SmartFusion cSoC MSS peripherals using SmartDesign MSS 

 Generate the programming file and program the SmartFusion cSoC device 

 Create a simple project and run the application using the SoftConsole debugger 

As a part of MSS configuration, this tutorial demonstrates how to configure SmartFusion analog channels 

and ACE (used to monitor the voltage across the potentiometer). 

The UART_0 is used to send the analog to digital converter (ADC) results to a serial terminal program 

(HyperTerminal). 

The hardware configuration has four flags: 

 Over 1.0 V 

 Over 1.5 V 

 Over 2.0 V 

 Over 2.5 V 

The design monitors the voltage across a potentiometer (POT) and the four flags are included for voltage 

monitoring.
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Working with the SoftConsole 

Step 1 - Launching SoftConsole 
1. Open SoftConsole by clicking Start > Programs > Microsemi SoftConsole v3.3 > Microsemi 

SoftConsole IDE. 

2. The SoftConsole Workspace Launcher is displayed as shown in Figure 1 · . Click Browse on the 

SoftConsole Workspace Launcher to navigate to your preferred location (where you will create your 

project), or enter the location of your workspace. For example: C:\Microsemiprj\POT_Uart). Click OK. 

Note:  You can also specify the workspace as a default workspace for all your projects by selecting Use 

this as the default and do not ask again. 

You can switch workspaces within SoftConsole by selecting File > Switch Workspace. 

 

Figure 1 · Specifying the SoftConsole Workspace 

Step 2 - Configuring MSS Peripherals 
1. Open the External Tools dialog box using Run > External Tools > External Tools Configurations. 

2. Double-click Program to create a new configuration. 

3. Enter MSS_Configurator in the Name field. 

4. Click Browse File System in the Location field. The Open dialog box is displayed. 

5. Navigate to the Libero.exe. 

6. In the Arguments field, enter the following: 

 STARTED_BY:SoftConsole  

 PROJECT_LOCATION:C:\Microsemiprj\POT_Uart\Voltage_Monitor  

 DESIGN_NAME:Voltage_Monitor 

 Click Apply and then click Run. 
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Figure 2 · Running SmartFusion MSS Configurator 

7. The Libero SoC appears with a New Project dialog box, as shown in Figure 3 ·  below. Select the 

following: 

 Die: If you are using SmartFusion Evaluation Kit Board, enter A2F200M3F; if you are using 

SmartFusion Development Kit Board, enter A2F500M3F. 

 Package: 484 FBGA 

 Speed: STD 

 Die Voltage: 1.5 
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The Project Name and Project Directory parameters are already specified. 

 

Figure 3 · New Project Dialog Window 

Note:  If you do not see the latest MSS version (v2.5.106 or later), you need to change your repositories 

settings. Steps for setting up repositories are described in Appendix A – Libero SoC 

Vault/Repository Settings.  

If your vault does not have MSS core then, double click on MSS name in the Design Template to 

download the core. 
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8. Click OK. The MSS canvas is displayed, as shown in Figure 4 · . 

 

Figure 4 · MSS in the SmartDesign Canvas 

The enabled MSS peripherals are highlighted in blue, and can be configured in hardware. The disabled 

peripherals are shown in gray. 

To disable a peripheral that is not required, select the peripheral, right-click, and clear the Enabled 

check box in the lower right corner of the peripheral box. The box turns grey to indicate that the 

peripheral has been disabled. Disabled peripherals can be enabled by repeating the procedure. 

An enabled peripheral looks as shown in Figure 5 · . 

 

Figure 5 · Enabling the Peripheral 

For this design we will be using the analog compute engine (ACE), UART_0, and clock management 

peripherals. Other peripherals must be disabled. 

9. Double-click the Clock Management block and configure as shown below: 

 CLKA: On-chip RC Oscillator 

 MSS Clock source: PLL output 

 MSS clock frequency: 80 MHz 

 10/100CLK: Cleared check box (by default it will be cleared, if MAC is disabled) 

 Use default settings for all other fields. 
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10. After completing the configuration, click OK. 

 

Figure 6 · MSS Clock Configuration 

11. Click Project  > Save to save SmartFustion_UART_MSS. 

Configuring ACE 

To configure ACE, double-click the ACE peripheral block and configure as follows: 

1. Connect TM0 to the potentiometer (POT) on the SmartFusion Evaluation Kit Board or the SmartFusion 

Development Kit Board. Configure a voltage monitor to measure the voltage across the POT and also 

create flags to indicate when the voltage is greater than 1.0 V, 1.5 V, 2.0 V, and 2.5 V. These flags will 

be used to monitor the voltage. 

 

Figure 7 · MSS ACE Configuration 
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2. Select ADC Direct Input and click Add (or double-click ADC Direct Input) and enter the parameters as  

shown in Table 1 

 Signal name: TM0_Voltage 

 Send raw results to DMA: un-checked 

 Acquisition time: 10 µs 

 Filtering factor: None 

Table 1 · Configure ADC Direct Input Dialog Box 

Flag Name Flag Type Threshold (V) Hysteresis (mV) 

over_1p0v OVER 1 1 

over_1p5v OVER 1.5 1 

over_2p0v OVER 2 1 

over_2p5v OVER 2.5 1 

 

 

Figure 8 · MSS ADC Direct Input Configuration 

3. Click OK. 

4. Assign ADC Direct Input Signal to package pin W8 in the Configure ACE dialog box. 
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5. The Configure ACE tab is displayed as shown in Figure 9 · . 

 

Figure 9 · The Configure ACE Tab 

The next step in configuring the ACE is to enable the sampling sequence. This configuration dialog is 

launched by clicking the Controller tab (next to the Configure ACE tab). 

6. Select Manual as the Operating sequence entry in the Controller tab. 

 

Figure 10 · Insert Operating Sequence Slot 

7. Click the Insert operating sequence slot, highlighted in Figure 10 · . 
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8. Select SAMPLE. 

 

Figure 11 · Select SAMPLE 

9. The Configure SAMPLE window is displayed. Select TM0_Voltage from the drop-down list and click 

OK. 

 

Figure 12 · Configure SAMPLE 

10. Click Insert operating sequence slot again and select RESTART SEQUENCE. 

11. Click Calculate Actual Rate. The final Controller tab window is displayed as shown in Figure 13 · . 

 

Figure 13 · MSS ACE Configuration: Final Controller Tab  

12. Click the Flags tab in the Configure ACE window. This tab lists the Flags set from PPE registers. 
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13. Click the + sign to expand the Flag Registers group. The PPE_FLAGSn registers contain the user-

defined flags. 

Select PPE_FLAGS0 (FLAGBANK0). Observe that PPE_FLAGS0 contains the 4 threshold flags 
assigned earlier. These are the flags that were defined when the direct input voltage service was 
configured. The flag register can be read by the Cortex-M3 processor. The flags also generate 
interrupts to the Cortex-M3 processor. 

 

Figure 14 · ACE Flag Mapping: PPE Flag Registers 

14. Click OK to close the ACE configuration box. 

Configuring the General Purpose Input/Output (GPIO) Peripheral 

Note:  If you are not using SmartFusion Evaluation Kit Board – REV E, skip the configuration of GPIO. 

Double-click the GPIO block in the MSS component, configure as shown in Figure 15 · , and click OK. 

 

Figure 15 · Configure MSS_GPIO_0 

This example requires GPIO_31, GPIO_30, GPIO_29, and GPIO_26 to be connected to LED_8 to 

LED_5 on the SmartFusion Evaluation Kit Board (A2F_EVAL-KIT Rev E).  
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Generating the MSS Component 

1. The MSS canvas is displayed, as shown in Figure 16 · . 

 

Figure 16 · The MSS Canvas 

2. Save your design using Project  > Save Voltage_Monitor_MSS. 

3. Click Design > Configure Firmware as shown in Figure 17 · . 

 

Figure 17 · The Firmware Tab 

Note:  Check whether or not you are able to see the latest version of the drivers without any warning or error 

indicating that firmware is missing from the Vault. If missing, refer to Appendix B – Firmware Catalog 

Settings to set your Repositories. If you are opening the SmartDesign for the first time then you need 

to download the all firmware drivers from the Firmware tab in the SmartDesign 
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4. On the DESIGN_FIRMWARE tab, clear the Generate check boxes for all the peripherals for which you 

do not need to generate the firmware. Click Configuration on the SmartFusion_CMSIS_PAL_0 

instance and select SoftConsole as the configuration. 

 

Figure 18 · Configuring SmartFusion_CMSIS_PAL_0 

5. Click OK. 

6. Click Project  > Save to save the Design_Firmware. 

7. Save the design and generate the MSS component by clicking Generate Component or clicking 

SmartDesign > Generate Component. 

 

Figure 19 · Select SoftConsole in the Configuration Window 

8. Confirm that the design was successfully generated. 

Note:  If errors are indicated, open the log window (View > Log Window) to get additional information. 

9. Open the memory map for the design (Design > Reports). Scroll the window to become familiar with 

the locations of the peripherals. Close the window when finished. 

Step 3 - Programming SmartFusion Board Using FlashPro 

Jumper Settings for SmartFusion Evaluation Kit Board 

Before you proceed with programming the device, ensure that LCPS or FlashPro4 is properly connected to 

the board. Use the following details to ensure the correct jumper settings. Refer to the SmartFusion 

Evaluation Kit User’s Guide and the SmartFusion Development Kit User’s Guide for additional information. 

 JP10: Connect pin 1 and 2. 

 JP7: Connect pin 1 and 2 for LCPS programming mode. 

 J6: Connect pins 1 and 2 with the jumper. 

 JP6: Connect pins 2 and 3 with the jumper. 

 J13: Connect USB cable to the J13 connector. When the cable is connected, the FlashPro4 or FlashPro 

drivers might be installed if they are not already installed. 

http://www.microsemi.com/soc/documents/A2F_EVAL_KIT_UG.pdf
http://www.microsemi.com/soc/documents/A2F_EVAL_KIT_UG.pdf
http://www.microsemi.com/soc/documents/A2F500_DEV_KIT_UG.pdf
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 J14: Connect one end of USB mini B cable to J14. 

Jumper Settings for SmartFusion Development Kit Board 

 SW9 must be off (JTAGSEL = H) in order to program the SmartFusion device. SW9 remains in the off 

position for Libero SoC and SoftConsole programming. Make the jumper settings as shown in the 

following table: 

Table 2 · Jumper Settings for Development Kit Board 

Factory Default Factory Default Factory Default 

   

   

   

   

   

   

   

   

   

Programming the Device 

1. Click Program Device as shown in Figure 20 ·  or click Design > Program Device. 

 

Figure 20 · Select SoftConsole in the Configuration Window 

Note:  If errors are indicated, open the Reports (Design > Reports) to get additional information. 

2. Close Libero (File > Exit). 
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Step 4 - Building the Project 
1. Invoke the SoftConsole project generated by Libero SoC v10.0 using File > Switch Workspace > 

Other… and browse to the SoftConsole workspace as shown in Figure 21 · . 

 

Figure 21 · Specifying the Workspace 

2. The SoftConsole window looks as shown in Figure 22 ·  on page17. 

 

Figure 22 · SoftConsole Window 



Displaying POT Values over UART - SoftConsole Standalone Flow Tutorial for SmartFusion cSoC 

 

18 Displaying POT Values over UART - SoftConsole Standalone Flow Tutorial for SmartFusion cSoC 

3. Enter the code provided below in main.c file in the Voltage_Monitor_MSS_MSS_CM3_0_app project. 

Sample C code 

#include "mss_uart.h" 

#include "mss_ace.h" 

#include "mss_gpio.h" 

#include <stdio.h> 

 

#define  Microsemi_logo \ 

"\n\r \ 

**     **  *******   ******  *****    ****    *****  ******  **     **  ******* \n\r \ 

* *   * *     *     *        *    *  *    *  *       *       * *   * *     *    \n\r \ 

*  * *  *     *     *        *****   *    *   ****   ******  *  * *  *     *    \n\r \ 

*   *   *     *     *        *    *  *    *       *  *       *   *   *     *    \n\r \ 

*       *  *******   ******  *    *   ****   *****   ******  *       *  ******* " 

 

int main() 

{ 

 

 const uint8_t greeting[] = "\n\rWelcome to Microsemi's SmartFusion Voltage 

Monitor\n\n\r"; 

    const uint8_t * channel_name; 

/*Initialize and Configure GPIO*/ 

    MSS_GPIO_init(); 

    MSS_GPIO_config( MSS_GPIO_31 , MSS_GPIO_OUTPUT_MODE ); 

    MSS_GPIO_config( MSS_GPIO_30 , MSS_GPIO_OUTPUT_MODE ); 

    MSS_GPIO_config( MSS_GPIO_29 , MSS_GPIO_OUTPUT_MODE ); 

    MSS_GPIO_config( MSS_GPIO_28 , MSS_GPIO_OUTPUT_MODE ); 

 

    /*Initialize UART_0*/ 

    MSS_UART_init( 

        &g_mss_uart0, 

        MSS_UART_57600_BAUD, 

        MSS_UART_DATA_8_BITS | MSS_UART_NO_PARITY | MSS_UART_ONE_STOP_BIT ); 

 

    /*Initialize ACE*/ 

    ACE_init( ); 

 

    MSS_UART_polled_tx_string( &g_mss_uart0, (const uint8_t*)Microsemi_logo ); 

    MSS_UART_polled_tx( &g_mss_uart0, greeting, sizeof(greeting) ); 

 

    channel_name = ACE_get_channel_name( TM0_Voltage ); 

 

    for (;;) 

    { 

        uint8_t display_buffer[32]; 

        uint16_t adc_result; 
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     int32_t adc_value_mv; 

 

     adc_result   = ACE_get_ppe_sample( TM0_Voltage ); 

     adc_value_mv = ACE_convert_to_mV( TM0_Voltage, adc_result ); 

 

     if ( adc_value_mv < 0 ) 

      { 

          snprintf( (char *)display_buffer, sizeof(display_buffer), 

             "%s : -%.3fV\r\b", channel_name, ((float)(-adc_value_mv) / 

(float)(1000))); 

      } 

     else 

         { 

       snprintf( (char *)display_buffer, sizeof(display_buffer), 

             "%s : %.3fV\r\b", channel_name, ((float)(adc_value_mv) / (float)(1000))); 

         } 

MSS_UART_polled_tx_string( &g_mss_uart0, display_buffer ); 

 

     /* checking the status of Voltage flags */ 

     int32_t flag_status_2p5v = ACE_get_flag_status(TM0_Voltage_over_2p5v); 

  int32_t flag_status_2p0v = ACE_get_flag_status(TM0_Voltage_over_2p0v); 

  int32_t flag_status_1p5v = ACE_get_flag_status(TM0_Voltage_over_1p5v); 

  int32_t flag_status_1p0v = ACE_get_flag_status(TM0_Voltage_over_1p0v); 

 

  /* Voltage flags are displayed on the LEDs through GPIO */ 

  uint32_t gpio_output; 

  if ( flag_status_2p5v == FLAG_ASSERTED ) 

   gpio_output = ~( 

     MSS_GPIO_28_MASK | 

              MSS_GPIO_29_MASK | 

              MSS_GPIO_30_MASK | 

              MSS_GPIO_31_MASK ); 

  else 

  if ( flag_status_2p0v == FLAG_ASSERTED ) 

   gpio_output = ~( 

     MSS_GPIO_28_MASK | 

              MSS_GPIO_29_MASK | 

              MSS_GPIO_30_MASK ); 

  else 

  if ( flag_status_1p5v == FLAG_ASSERTED ) 

   gpio_output = ~( 

     MSS_GPIO_28_MASK | 

              MSS_GPIO_29_MASK ); 

  else 

  if ( flag_status_1p0v == FLAG_ASSERTED ) 

   gpio_output = ~( 
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     MSS_GPIO_28_MASK ); 

  else 

   gpio_output = ( 

     MSS_GPIO_28_MASK | 

              MSS_GPIO_29_MASK | 

              MSS_GPIO_30_MASK | 

              MSS_GPIO_31_MASK ); 

 

            MSS_GPIO_set_outputs( gpio_output ); 

      } 

    return 0; 

} 

/***************************************************************************/ 

4. The SoftConsole window looks similar to Figure 23 ·  on page 20. 

 

Figure 23 · SoftConsole workspace 

 

5. Perform a clean build by selecting Project > Clean. Accept the default settings in the Clean dialog box 

and click OK. 
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Figure 24 · Settings for a Clean Build 

6. Make sure there are no errors and warnings.  

Note:  If there are any compilation errors regarding the file or directory missing then use the 

SoftConsole directories including feature from Project options > C/C++ Build > settings > GNU 

C Compiler > Directories to include the header file directories. This enables the compiler to look 

in to added directories for the included header files. 

Step 5 - Configuring the Serial Terminal Emulation Program 
Prior to running the application program, you need to configure the terminal emulator program 

(HyperTerminal, included with Windows
®
) on your computer. Perform the following steps to use the 

SmartFusion Evaluation Kit Board or the SmartFusion Development Kit Board: 

1. Connect a second mini USB cable between the USB connector on the SmartFusion Evaluation Kit 

Board (or the SmartFusion Development Kit Board) and a USB port of your computer. If Windows 

prompts you to connect to Windows Update, select No, not at this time and click Next. 

2. If the SFE USB to RS232 Controller drivers are automatically detected (this can be verified in Device 

Manager), as shown in Figure 25 · , proceed to next step; otherwise follow the Step 6 - Installing Drivers 

for the USB to RS232 Bridge. 

 

Figure 25 · Device Manager Listing SFE USB to RS232 Controller Drivers 
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3. From the Windows Start menu, select Programs > Accessories > Communications > 

HyperTerminal. This opens HyperTerminal. If your computer does not have HyperTerminal, use any 

free serial terminal emulation program like PuTTY or Tera Term. Refer to the Configuring Serial 

Terminal Emulation Programs tutorial for configuring the HyperTerminal, Tera Term, and PuTTY. 

4. Enter Hyperterminal in the Name field in the Connection Description dialog box and click OK. 

 

Figure 26 · New Connection 

5. Select the appropriate COM port (to which USB-Rs232 drivers are pointed) from the Connect using 

drop-down list and click OK. 

 

Figure 27 · Selecting the COM Port 

6. Set the following in the COM Properties window and click OK: 

 Bits per second: 57600 

 Data bits: 8 

 Parity: None 

 Stop Bits: 1 

 Flow control: None 

http://www.microsemi.com/soc/documents/Configuring_Serial_Terminal_Emulation_Programs.pdf
http://www.microsemi.com/soc/documents/Configuring_Serial_Terminal_Emulation_Programs.pdf
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Figure 28 · Setting the COM Properties 

7. Click OK to close the Hyperterminal Properties dialog box. 

Next time you can directly open HyperTerminal (without configuring) by selecting, Programs > 
Accessories > Communications > HyperTerminal > Hyperterminal. 

Step 6 - Installing Drivers for the USB to RS232 Bridge 
Note:  To install the USB-RS232 drivers, you should have administrative privileges for your PC. 

Use the following steps to install drivers for the USB to RS232 Bridge: 

1. Unzip USB_Drivers.zip file and browse to the USB Drivers folder. 

2. Double-click (run) the PreInstaller.exe. 

3. Accept the default installation location and click Install. 

4. Click Continue Anyway if prompted. 

5. When the installation is complete, click OK. The ports (COM & LPT) section of the Device Manager lists 

SFE USB to RS232 Controller under the Ports section of the Device Manager. 

Step 7 - Running the Application 
Follow the steps given below to debug the application project using SoftConsole: 

1. Select Open Debug Dialog or Debug Configurations from the Run menu of the SoftConsole. The 

Debug dialog is displayed. 

2. Double click on Microsemi Cortex-M3 RAM target. The Debug Configurations window is displayed, 

as shown in Figure 29 · . 
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Figure 29 · Debug Configurations Window 

3. Confirm that the following appear on the Main tab in the Debug window: 

 Name: Voltage_Monitor_MSS_MSS_CM3_app Debug 

 Project: Voltage_Monitor_MSS_MSS_CM3_app 

 C/C++ application: Debug\ Voltage_Monitor_MSS_MSS_CM3_app 

4. Select the Commands tab. Confirm that commands appear in the Initialize and Run command sections, 

as shown in Figure 30 · . 

 

Figure 30 · Debugger Commands 

5. Click Apply and Debug. 

6. Click Yes when prompted for Confirm Perspective Switch. This displays the debug view mode. 
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Figure 31 · Confirm Perspective Switch 

7. The Debug Prospective window is displayed, as shown in Figure 32 · . 

 

Figure 32 · Debug Perspective 

8. Run the application by clicking Run > Resume or by clicking the Run icon on the SoftConsole toolbar. 

The voltage measurement along with the greeting message is displayed in the terminal program 

window. 

9. Turn the potentiometer (POT) on the SmartFusion Evaluation Kit Board or the SmartFusion 

Development Kit Board. The voltage measurement is displayed on HyperTerminal and the LEDs on the 

SmartFusion Evaluation Kit Board or the SmartFusion Development Kit Board will illuminate when one 

of the voltage monitor flags is asserted. 

10. Adjust the POT and observe that the voltage measurement is continuously updated. 
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Figure 33 · Voltage Monitor 

 

Figure 34 · Voltage Measurement Continuous Update 

11. Observe the state of the LEDs as the POT is adjusted. Confirm that the flags work as specified in the 

ACE configurator. 

12. Suspend the software application by clicking Run > Suspend from the SoftConsole menu. 
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Step 8 - Debugging the Application 
Use the following steps to further debug the application: 

1. Select the Registers tab on the upper right window pane to view the value of the Cortex-M3 processor 

internal registers. 

 

Figure 35 · The Registers Tab 

2. Select the Variables tab in the upper left window pane to view the value of variables in the source code. 

 

Figure 36 · The Variables Tab 

3. In the Debug window, select Window > Show View > Disassembly to display the assembly level 

instructions. The Assembly window opens on the right-side of the Debug perspective. 



Displaying POT Values over UART - SoftConsole Standalone Flow Tutorial for SmartFusion cSoC 

 

28 Displaying POT Values over UART - SoftConsole Standalone Flow Tutorial for SmartFusion cSoC 

 

Figure 37 · Assembly Window 

4. You can single-step through the source code by choosing Run > Step Into or Run > Step Over or by 

clicking the Step Into  or Step Over  icons. Observe the changes in the source code window and 

Disassembly view. Performing a Step Over allows for stepping over functions. The entire function is 

executed but there is no need to single step through each instruction contained in the function. 

5. Click the Instruction Stepping  icon and then perform Step Into operations. Observe that Step 

Into now executes a single line of assembly code. 

6. Click the Instruction Stepping icon to exit the instruction stepping mode. Single-step through the 

application and observe the instruction sequence in the source code window in the middle of the Debug 

perspective, and the values of the variables and registers. 

7. Resume execution of the code by choosing Run > Resume or by clicking the Resume icon. 

8. You can even add breakpoints in the application for further debugging.  

9. Once you are done, terminate the debugger by selecting Voltage_Monitor_MSS_MSS_CM3_0_app 

Debug in the Debug view, then right-clicking and selecting Terminate and Remove. 
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Figure 38 · Terminating the Program 

10. Close the Debug perspective by selecting Close Perspective from the Window menu. 

11. Close the voltage monitor project by selecting the project name in the SoftConsole Project Explorer 

view, right–clicking, and selecting Close Project. 

12. Close SoftConsole using File > Exit. 

13. Close HyperTerminal using File > Exit. Click Yes, when prompted for closing immediately. 

Step 9 - Building an Executable Image in Release mode 
You can build an application executable image in “release mode” and load it into eNVM for executing code 

in eNVM of SmartFusion cSoC device. You can load the application executable image into eNVM with the 

help of eNVM data storage client from SmartDesign MSS Configurator and IAP or FlashPro programming 

software. In the release mode, you cannot use the SoftConsole debugger to load the executable image into 

eNVM.  

For steps to build an executable image for our application refer the tutorial SmartFusion: Building Executable 

Image in Release Mode and Loading into eNVM.  

This concludes the tutorial. 

http://www.microsemi.com/soc/documents/SmartFusion_Release_Built_Tutorial.pdf
http://www.microsemi.com/soc/documents/SmartFusion_Release_Built_Tutorial.pdf
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Appendix A – Libero SoC Vault/Repository 

Settings 

Listed below are the steps to show how to configure your vault location and set up the repositories in Libero 

SoC. 

1. Click Project > Vault/Repositories Settings. 

2. The Vault/Repositories Settings window is displayed. Click Repositories and add the following in the 

address field: 

 www.actel-ip.com/repositories/SgCore 

 www.actel-ip.com/repositories/DirectCore 

 www.actel-ip.com/repositories/Firmware 

Note:  Click Add after entering each path. 

 

Figure 39 · Setting Repositories 

3. Click on Vault location in the Vault/Repositories Settings window. Browse to a location on your 

computer to set the vault location where the IPs can be downloaded from the repositories. 

 

Figure 40 · Setting the Vault Location 

4. Click OK. 
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Appendix B – Firmware Catalog Settings 

1. Open the <Libero Installation directory>\Designer\bin\catalog.exe. 

2. Select Tools > Vault/Repositories Settings, from the Firmware Catalog widow. 

 

Figure 41 · Firmware Catalog Settings 

3. Select Repositories in the Vault/Repositories Settings dialog box. 

4. Confirm that the following repositories are displayed (add them if needed): 

 www.actel-ip.com/repositories/SgCore 

 www.actel-ip.com/repositories/DirectCore 

 www.actel-ip.com/repositories/Firmware 

5. Add the above mentioned paths in the address field if required by selecting the repository and clicking 

Add. 

6. If new cores are available for download, click Download them now! to download the new cores to the 

vault.
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Product Support 

Microsemi SoC Products Group backs its products with various support services, including Customer 

Service, Customer Technical Support Center, a website, electronic mail, and worldwide sales offices. This 

appendix contains information about contacting Microsemi SoC Products Group and using these support 

services. 

Customer Service 
Contact Customer Service for non-technical product support, such as product pricing, product upgrades, 

update information, order status, and authorization. 

From North America, call 800.262.1060 
From the rest of the world, call 650.318.4460 
Fax, from anywhere in the world 408.643.6913 

Customer Technical Support Center 
Microsemi SoC Products Group staffs its Customer Technical Support Center with highly skilled engineers 

who can help answer your hardware, software, and design questions about Microsemi SoC Products. The 

Customer Technical Support Center spends a great deal of time creating application notes, answers to 

common design cycle questions, documentation of known issues and various FAQs. So, before you contact 

us, please visit our online resources. It is very likely we have already answered your questions. 

Technical Support 
Visit the Microsemi SoC Products Group Customer Support website for more information and support 

(http://www.microsemi.com/soc/support/search/default.aspx). Many answers available on the searchable 

web resource include diagrams, illustrations, and links to other resources on website.  

Website 
You can browse a variety of technical and non-technical information on the Microsemi SoC Products Group 

home page, at http://www.microsemi.com/soc/.  

Contacting the Customer Technical Support Center 
Highly skilled engineers staff the Technical Support Center. The Technical Support Center can be contacted 

by email or through the Microsemi SoC Products Group website. 

Email 

You can communicate your technical questions to our email address and receive answers back by email, 

fax, or phone. Also, if you have design problems, you can email your design files to receive assistance. We 

constantly monitor the email account throughout the day. When sending your request to us, please be sure 

to include your full name, company name, and your contact information for efficient processing of your 

request. 

The technical support email address is soc_tech@microsemi.com. 

My Cases 

Microsemi SoC Products Group customers may submit and track technical cases online by going to My 

Cases. 

http://www.microsemi.com/soc/support/search/default.aspx
http://www.microsemi.com/soc
http://www.microsemi.com/soc/
file:///C:/Documents%20and%20Settings/alim/Local%20Settings/Temporary%20Internet%20Files/Content.Outlook/BPCDM203/soc_tech@microsemi.com
http://www.microsemi.com/soc/mycases/
http://www.microsemi.com/soc/mycases/
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Outside the U.S. 

Customers needing assistance outside the US time zones can either contact technical support via email 

(soc_tech@microsemi.com) or contact a local sales office. Sales office listings can be found at 

www.microsemi.com/soc/company/contact/default.aspx. 

ITAR Technical Support 
For technical support on RH and RT FPGAs that are regulated by International Traffic in Arms Regulations 

(ITAR), contact us via soc_tech_itar@microsemi.com. Alternatively, within My Cases, select Yes in the ITAR 

drop-down list. For a complete list of ITAR-regulated Microsemi FPGAs, visit the ITAR web page. 

 

mailto:tech@microsemi.com
http://www.microsemi.com/soc/company/contact/default.aspx
http://www.microsemi.com/soc/company/contact/default.aspx
http://www.microsemi.com/soc/company/contact/default.aspx
http://www.microsemi.com/soc/company/contact/default.aspx#itartechsupport
mailto:soc_tech_itar@microsemi.com
http://www.microsemi.com/mycases/
http://www.microsemi.com/soc/ITAR/
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