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Preface

About this document

This demo is for the IGLOO®2 field programmable gate array (FPGA) devices. It provides instructions on
how to use the corresponding reference design.

Intended Audience

IGLOO2 devices are used by:
* FPGA designers
« System-level designers

References

Microsemi Publications

e SmartFusion2 and IGLOO2 Power Estimator User Guide
*  UG0444: SmartFusion2 SoC and IGLOO2 FPGA Low Power Design User Guide
*  UG0445: SmartFusion2 SoC and IGLOO2 FPGA Fabric User Guide
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IGLOO2 FPGA Low Standby Power - Libero SoC
v11.6

Introduction

Microsemi® IGLOO2 FPGAs are designed to meet the demand of low power FPGAs. The IGLOO2
devices exhibit lower power consumption in static and dynamic modes. This demo guide describes how
to implement the standby power mode on the IGLOO2 devices using SmartDesign, and measure the
standby power. The design drives the light emitting diodes (LEDs) on the IGLOO2 Evaluation Kit with a
pattern based on the state of the switches SW1 and SW3, as shown in Table 1.

Table 1+ LEDs Pattern

LED E1, F4, F3, G7 Behavior Standby Entry (SW1) Standby Exit (SW3)
LEDs toggle Released Released

LEDs on Depressed and Released Released

LEDs toggle Depressed and Released Depressed

This demo guide describes the following:
«  Creating a Libero® System-on-Chip (SoC) project
+ Implementing the standby power mode on the IGLOO2 devices using SmartDesign
» Importing a PDC file, running layout, and programming the IGLOO2 silicon
» Measuring the standby power using a standard digital voltmeter (DVM)/multimeter

Design Requirements

Table 2 shows the design requirements.

Table 2 « Design Requirements

Design Requirements Description

Hardware Requirements

IGLOO2 Evaluation Kit: Rev C or later
* 12V adapter
* FlashPro4 programmer

Desktop or Laptop Windows 64-bit Operating System
Software Requirements

Libero SoC v11.6

FlashPro Programming Software v11.6
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Demo Design

Introduction
The demo design files are available for download from the following path in the Microsemi website:
http://soc.microsemi.com/download/rsc/?f=m2gl_dg0564_liberov11p6_df
The demo design files include:
* Libero SoC project
+ Constraint file
*  Programming file
» Source files
+ Readme file
Refer to the Readme.txt file provided in the design files for the complete directory structure.

The design consists a 32 kHz external main crystal oscillator, fabric CCC (FCCC), standby power control
logic, and fabric logic block. Figure 1 shows the block diagram of the design.

FCCC is configured to provide a 100 MHz clock to the fabric logic. It is also configured with
phase-locked loop (PLL) power-down enabled. The 32 kHz external main crystal oscillator is the
reference clock source for FCCC. The lock signal is used as the reset signal to the fabric logic. The
standby power control logic consists a clocked S-R latch, which powers down the PLL of FCCC. The
fabric logic consists 269 stages of 18-bit loadable up-counters, 13 stages of shift registers, and 11 stages
of LSRAM and math blocks. It also consists an LED driver block, which is connected to a set of LEDs to
monitor the state of the fabric while entering and exiting the standby power mode.

32 kHz Extern.al Main Crystal 32 kHz > Fabric CCC 100MHz | Eovric Logic | LEDs
Oscillator —>
A
32 kHz PLL Power-down
4
Standby Power Entry ———p| Standby Power IGL002
Standby Power Exit ———pf Control

Figure 1+ Design Block Diagram

Extracting the Source Files

Extract the m2gl_dg0564 _liberov11p6_df.zip file to the <C:\ or D:\>Microsemi_prj folder on the PC.
Confirm that a folder named IGL2_Standby _tutorial containing sub-folders named Source_files and
Constraints are extracted.
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Creating the Design

This section describes how to create the standby power mode enabled design using SmartDesign. Some
source files are provided in the Source_files folder.

Launching Libero SoC

The following steps describe how to launch Libero SoC:

1. Go to Start > Programs > Microsemi Libero SoC v11.6 > Libero SoC v11.6, or double-click the
shortcut icon on the PC. This opens the Libero SoC Project Manager window, as shown in

Figure 2.
Clbeo 0 T T T TR T T (]|

Project  File Edit View Design Tools Help

StartPage & X
-

Qe ‘ o 21
leelgg‘

Recent Projects
System-on-Chip

4l

m

m

Welcome To Microsemi's Libero SoC v11.6

Libero SoC is the most comprehensive and powerful FPGA design and development software
Welcome to Libero SoC available, providing start-to-finish design flow guidance and support for novice and experienced
Libero SoC Quickstart users alike. Libero SoC combines Microsemi's tools with such EDA powerhouses as Synplify
Pro® and ModelSim®&.
Libero SoC Interface Description £
Libero SoC Release Motes on the Web Device Support Changes in Libero SoC v11.6
Libero Tutorials s ac
Product Tutorials ”Change” Family ” Die ” Package | ,.F_'fi .,_,?_rf‘”Ranges”GuId”Flatinl -
|4 n (2
Log 2 X

QErrors 1. Warnings 0 Info

log | Message

Fam: |Part: |VHDL

b

Figure 2+ Libero SoC Project Manager

2. Create a new project using one of the following options:
— Select New on the Start Page tab, as shown in Figure 2.
— In the Libero SoC menu, go to Project > New Project.
This opens the New Project window, as shown in Figure 3 on page 8.

3. Enter the following information in the New Project - Project Details window, as shown in
Figure 3 on page 8:

— Project Name: IGL2_Standby

— Project Location: <C:\ or D:\>Microsemi_prj\IGL2_Standby _tutorial
— Preferred HDL type: VHDL

— Enable Block Creation: Not selected
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.
@ New Project = | B )

Project Details
il Specify Project Details

Project Details

Project Mame: IGL2_Standby
B B Project Location: D:WMicrosemi_pri\IGL2_Standby_tutorial
Device Selection
Description:

Device Settings

Design Template Preferred HOL Type:

[] Enable Block Creation

Add HDL Sources
Add Constraints

. gl
Libefo

System-on-Chip

L

Figure 3+ New Project - Project Details

4. Click Next. This opens New Project - Device Selection window as shown in Figure 4 on page 9.
5. Select the following values from the drop-down list, highlighted in Figure 4 on page 9:

— Family: IGLOO2

— Die: M2GLO10T

— Package: 484 FBGA

— Speed: -1

— Core Voltage: 1.2

— Range: COM
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6. Select the filtered device M2GL010T-1FG484, as shown in Figure 4.

~
(® New Project = | B o)
Device Selection
[ Select a part for your project from the Part Number list Selected Part: M2GL010T-1FG484
Part Filter
RRleuRSE Family: (16LO02 -] Die: [M26L010T ~|  Package: [484FBGA -
Speed: [—1 - ] Care Voltage: [1.2 - ] Range: [CDM - l
Device Selection
Device Settings Search Part:
I Part Numbe‘r 4uT DFF User I/Os USRAM 1K LSRAM 18K Math (18x18) PLLs and C
Design Template M2GLO10T-1FG484 12084 12084 233 2 Pl 22 2
Add HDL Sources
Add Constraints
Libefo)
System-on Chip ) 3 L &
< Back ] l MNext > ] l Finish ] l Cancel ]
L

Figure 4+ New Project - Device Selection

7. Click Next. This opens New Project - Device Settings window as shown in Figure 5 on page 10.

8. Select the following values in the Power supplies section from the drop-down list, highlighted in
Figure 5 on page 10:

— PLL Supply Voltage (V): 3.3V
— Power on Reset Delay: 100 ms

The PLL analog supply voltage can be either 2.5 V or 3.3 V. The voltage setting in the New Project -
Device Settings window must match the PLL analog supply voltage on the board to ensure that the PLL
works properly. The PLL analog supply voltage is connected to 3.3 V on the IGLOO2 Evaluation Kit.

9. Do not change the default selections. Click Finish.
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r =
G‘ New project - =0
Device settings
Choose device settings for your project Selected part: M2GL010T-1FG484
I/0 settings

Project Details

Default If0 technology: LVCMOS 2.5V = 6 Please use the I/O Editor to change individual IfO attributes.
Reserve pins for probes
Device Selection

Device Settings

Power supplies

PLL supply voltage (V): 3.3 -
DesignTemplate | | g, oo gect ey
Add HDL Sources [ system contraller suspended mode
il Add Constraints

.
Libefo

System-on-Chip

< Back ][ Mext = ][ Einish ]l Cancel

b

Figure 5+ New Project - Device Settings

10. In the Design Flow window, expand Create Design, as shown in Figure 6 on page 11.
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11. Right-click Create SmartDesign and click Run.

Design Flow [
Please select a root = 0 @ #
Tool

4 | Create Design
- &5 System Builder
| B3 Create SmartDesi !

o Create HDL Run
Create SmartDesi Help
Create HDL Testbrmes

¥ Verify Pre-Synthesized Design

Create Constraints

Implement Design

Edit Design Hardware Configuration
Configure Security and Programming Options
Program Design

Debug Design

"
b . . . . . .

Handoff Design for Production

Design Flow Design Hierarchy Stimulus Hierarchy Catalog I Files |

Figure 6 « Creating SmartDesign

12. In the Create New SmartDesign dialog box, enter the Name as IGL2_Standby and click OK. A
new SmartDesign canvas opens.

- =
| Create New SmartDesign M

Mame:

IGL2_Standby]

o [

Figure 7+ Entering SmartDesign Name

This design uses a fabric CCC to generate a 100 MHz internal clock. The CCC reference clock is
the 32 kHz external main crystal oscillator.
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13. In the IP Catalog tab, expand Clock & Management.

Catalog 5 X
[@ ~ [ Simulation Mode o~

MName Version
» iArithmetic ;
> Bus Interfaces

Clock & Management
Chip Oscillators 1.0.105
Clock Conditioning Circuitry (CCC) 2.0.200

» TSP

> WO

> Macro Library

> Memory & Controllers
> Peripherals

> Processors

> SC/Tamper

» Tamper

Mo core selected

| Design Flow I Design Hierarchy I Stimulus Hierarchy | Catalog | Files |

Figure 8+ Clock & Management Category of Libero SoC IP Catalog
14. Drag an instance of the clock conditioning circuitry (CCC) v2.0.200 component into the
SmartDesign canvas.

15. Double-click the FCCC_0 component in the SmartDesign canvas and open the FAB CCC
Configurator window, as shown in Figure 9 on page 13.

16. Click the Basic tab in the FAB CCC Configurator window, as shown in Figure 9 on page 13 and
enter the following information:

— Reference Clock Frequency: 0.032 MHz
— Reference Clock: Select Oscillators > Crystal Oscillator from the drop-down list
— GLO: Checked; Frequency: 100 MHz
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3 ~
i FAB CCC Configurator = | B [

Basic Advanced PLL Options

Basic-Options
Reference Clock r j
CcCcC
0.032 MHz Exact Value Frequency Actual
Crystal Oscilator GLO
] | 100 |MHz | |MHz
|
[ ety
EE—— [ 100 bz | |z
[[eLz
[ 100 bz | |z
[[eLs
— | 100 |MHz | |MHz
LOCK

o] [ o

Figure 9+ Configuring Fabric CCC
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17. Click the Advanced tab in the FAB CCC Configurator window and select
Internal > PLL Internal from the drop-down list as PLL feedback source, as shown in Figure 10.

A =

[oase | advared | i ptons |

—] PLL phase 0 -

= PLL phase 0 -

o | @_]

Figure 10 » Configuring PLL Feedback Source
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18. Click the PLL Options tab in the FAB CCC Configurator window and select the Expose
PLL_ARST_N and PLL_POWERDOWN_N signals checkbox, as shown in Figure 11.

| FAB CCC Configurator

-,

o S

PLL Optons

wWnie waliung, me FLL IS IN & I0CKEea state

Qutput Resynchronization After Lock

after the PLL locked.

() Outputs operate after power-up. Mo automatic resynchronization.

[ Enable PLL Spread Spectrum Modulation
ﬁ Frequency

A
VCOo:

() Held output in reset {output low) after power-up. Released and resynchronized with the PLL reference dock

@ Outputs operate after power-up. Resynchronized with the PLL reference dock after the PLL locked.

4539.712 MHz

MinVCO:
497.213 MHz

Krz £

Frequency: |4p

Miscellaneous

[ Expose dynamic configuration interface (APE slave)

Expose PLL_ARST_N and PLL_POWERDOWN_N signals

[ Expose GPD[X]_ARST_N signals for all used GPDs

Warning: PLL Feedback Source is forced to PLL Internal when Spread Spectrum Modulation is enabled

[ Expose PLL_BYPASS_N signal. When asserted, the PLL core is off and the PLL Outputs will track the reference dock

P Time

m

oK ] [ Cancel

Figure 11+ Configuring PLL Power-down Signal

19. Click OK.

20. Drag an instance of the Chip Oscillators v1.0.105 component from the IP catalog into the

SmartDesign canvas.
21.

Double-click the OSC_0 component in the SmartDesign canvas and open the Chip Oscillators

Configurator window, as shown in Figure 12 on page 16.

22.

Configure the external main crystal oscillator to drive FCCC and fabric logic.

Enter the following information, as shown in Figure 12 on page 16:

— External Main Crystal Oscillator: Select
— Source: Select Crystal (32 KHz - 20 MHz) from the drop-down list

— Frequency: 0.032 MHz
— Drives Fabric CCC(s): Select
— Drives Fabric Logic: Select

Revision 4
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A Chip Oscillators Configuratar

Configuration i e it kel
External Main Crystal Oscillator
Source [Crystal (32kHz-20MHz) -] HPMS_CCC
Frequency 0.032 MHz

Drives Fabric CCC(s) RCOSC_50MHZ

Drives Fabric Logic

Drives Fabric CCC(s)

Drives Fabric Logic

1
1
1
1
I
1
1
1
1
I
1
I
1

[T on-chip 25/50 MHz RC Gscillator 1
1
1
I
1
I
1
1
1
1
I
1
I
1

RCOSC_1MHZ
[] On-chip 1 MHz RC Oscillator
Drives Fabric CCC(s) cce
Drives Fabric Logic cce
IZF XTLOSC
1 n
1 User Logic
1
1
1
1
| FPGA Fabric
e [
- o ) [ cone
= y

Figure 12 + Configuring Chip Oscillators
23. Click OK.
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24. Import the VHDL source files into the project by selecting Create HDL under Create Design in
the Design Flow tab. Right-click and select Import Files..., as shown in Figure 13.

Design Flow g X
I6L2_Standby B O A ¢
Tool

4 | Create Design
&5 System Builder
Ed Create SmartDesign

: |I Create H™ ;

4 Creates Run
Create H X
4 b VerifyP Import Files...

. Sim Help
Create Consorewres

Implement Design

Edit Design Hardware Configuration
Configure Security and Programming Options
Program Design

Debug Design

W
b . . . . .

Handoff Design for Production

Design Flow Design Hierarchy Stimulus Hierarchy Catalog I Files |

Figure 13 + Importing HDL Source Files

25. Browse to <C:\ or D:\>Microsemi_prj\lGL2_Standby _tutorial\Source_files, select all .vhd, .v, and
.h files, and click Open.
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The files are visible in the Design Hierarchy tab.

Design Hierarchy

E=j_ Standby_Control (Standby_Control.vhd)
O3 1612 Standby
=1 Fabric_Legic (Fabric_Logic.vhd)
E] CNT_UP421 (CNT_UP421.vhd)
E] CNT_UP (CNT_UPvhd)
4 [ Multll_LSRAMI1 (MULT11_LSRAMI1.vhd)
4 [Z| WE_AD_GEN (WE_AD_GEN.vhd)
E] WA_CNT (WA_CNT.vhd)
E| RA_CNT (RA_CNT.whd)
E] WE_CNT (WE_CNT.vhd)
B sign18:d8_mult (SIGNSxE_MULT.vhd)
E] LSRAMIK:1S (LSRAMIK:x18.vhd)
Bl muxbus (MUXBUS.vhd)

[
« £

1 | m

| Design Flow | Deesign Hierarchy Stimulus Hierarchy Catalog I Files |

Figure 14 + Design Hierarchy Tab with Imported Files
26. Drag the Standby_Control and Fabric_Logic components into the SmartDesign canvas. The
SmartDesign resembles Figure 15 on page 19.
27. Align the components to improve the appearance of the canvas.
Expand the canvas area by selecting View > Maximize Work Area, or click the

* icon on the tool bar.
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| reports & x | startpage & x | B9 1612 Standby* @ X |

4l

B oEra M 2P P QOO B ANDO

FCCC_0

PLL_ARST_N
PLL_POWERDOWN_N
XTLOSC_CCC_IN

GLO
LOCK

@'IP

0SC_0

XTLOSC_D2F
XTLOSC_CCC_OUT

@'IP

m_+m

Standby_Control_0

CLK PLL_PowerDown
Standby_Entry

Standby_Exit

m

Fabric_Logic_0
DOUTI17:0]

Figure 15+ SmartDesign Canvas after Adding Components

Connecting Components

in the Canvas

SmartDesign in Libero SoC has a connection mode that supports click, drag, and release to connect the

components.

Connect the components in the SmartDesign canvas using the following procedure:
1. Select SmartDesign > Connection Mode from the Libero SoC menu.

2. Connect the XTLOSC_CCC_OUT port of the OSC_0 component to the XTLOSC_CCC_IN port of
the FCCC_0 component as follows:

a. Click and hold the XTLOSC_CCC_OUT port of the OSC_0 component.
b. Drag the XTLOSC_CCC_IN port of the FCCC_0 component and release the mouse button to

connect.

Note: You can also connect the ports by selecting them using CTRL (Ctrl + Click to select a port),
right-clicking any of the selected ports, and selecting Connect.

3. Connect the other components in the SmartDesign canvas as per Table 3.

Table 3 « Connections in Canvas

From

To

OSC_0: XTLOSC_O2F

Standby_Control_0: CLK

Standby_Control_0: PLL_PowerDown

FCCC_0: PLL_ARST N
FCCC_0: PLL_POWERDOWN_N

FCCC_0: GLO

Fabric_Logic_0: CLK

FCCC_0: LOCK

Fabric_Logic_0: RST
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4. Select SmartDesign > Connection Mode from the Libero SoC menu to exit connection mode.

5. Promote the ports shown in Table 4 to the top level. Right-click the port and select Promote to
Top Level.

Table 4 « Promote to Top Level

Ports

Standby_Control_0: Standby_Entry

Standby_Control_0: Standby_Exit

Fabric_Logic_0: LD

Fabric_Logic_0: DIN[17:0]

Fabric_Logic_0: DOUT[17:0]

Fabric_Logic_0: LED_1

Fabric_Logic_0: LED_2

Fabric_Logic_0: LED_3

Fabric_Logic 0: LED_4

The SmartDesign canvas appears as shown in Figure 16. Drag the components or use the
SmartDesign Auto Arrange feature to improve the appearance of the canvas.

| Reports & x| stertpage @ x | &3 16L2_Standby* @ X |

B)oEra M 222,08 QA QG AN D

4l

Fabric_Logic_0

—CLK DOUTI170] OUT 1701 ]
——RST LED ip——— |
[is] LD LED 2l B |
Eﬁg 5 ; DIN{17:0) LED z2p——— |
ED<p— @ 1

|

FCCC_0
FLL ARST M G
XTL XTLOSC_C2F| FLL_FCWERDGWN_ N LOCK]
T XTLOSC OCC N

Standby_Control_0

b CLK FLL_FowerDown
e —
Stendby Exi

Figure 16 « SmartDesign Canvas after Connections

6. Go to File > Save IGL2_Standby, to save the design.

7. Generate the design by selecting SmartDesign > Generate Component, or by clicking the
Generate Component icon on the SmartDesign toolbar (highlighted in Figure 16).

8. Go to View > Restore Work Area to restore the work area, if you expanded the work area earlier.
9. Confirm that the message IGL2_Standby was generated appears in the Libero Log window.
10. Go to File > Close IGL2_Standby to close the design.
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Importing Physical Constraint files

This section describes how to import a physical design constraint (PDC) file to make 1/O attribute and pin
assignments for the layout.

The following steps describe how to make I/O assignments:

1. Expand Create Constraints in the Design Flow tab. Right-click I/O Constraints and select
Import Files.....

Design Flow 5 X

1GL2_Standby

Tool

> P Create Design

4 p Create Constraints
i*= /0 Constraints

d) Timing Constrai
Q Floorplan Const

Create New Constraint From Root Module

Create New Constraint

> b Implement Design Import Files...
> p Edit Design Hardw: Link Files...

> b Configure Security

> P Program Design Help

> b Debug Design

> P Handoff Design for Production

| Design Flow | Design Hierarchy I Stimulus Hierarchy Catalog I Files |

Figure 17 » Importing I/0 PDC Constraint File

2. Browse to <C:\ or D:\>Microsemi_prj\IGL2_Standby _tutorial\Constraints, select the
IGL2_Standby.pdc file, and click Open.

3. Select No in the Information dialog box.

.| Information @

:] Do you want to organize constraint file(s) for your current root (IGL2_Standby) for (Compile)?

.

Figure 18 « Information Dialog Box after Importing PDC Constraint File
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The file is visible in the Libero SoC Files tab under constraint > io.

Files

> [3 component
4[] constraint
Lfp
4 [0
B 16L2_Standby.pdc
> [ designer
> [ hdl
> [ simulation
[ smartgen
[ stimulus
[ synthesis
> [ tooldata

| Design Flow I Design Hierarchy I Stimulus Hierarchy Catalog | Files |

Figure 19 » 1/0 PDC Constraint File in Libero SoC Project

A description of the designer PDC constraints is available in the Libero Help (Go to Help > Help Topics
> Implement Design > Constrain Place and Route > Assigning Design Constraints > Design
Constraints Guide > Reference > Constraints by File Format > PDC Command Reference).

Synthesis and Layout
Use the push-button flow to synthesize the design with Synplify Pro, run layout, and generate the
programming file as mentioned below:

1. Expand Create Constraints > I/O Constraints in the Libero SoC Design Flow tab. Right-click
IGL2_Standby.pdc under Constraints.

2. Right-click and select Use for Compile, as shown in Figure 20. A green tick mark appears on the
constraint file indicating that the file will be used.

g X

o[ ¢

Design Flow

1GL2_Standby

Tool
P Create Design
4 p Create Constraints
4 “E /0 Constraints
a onstrainf—"= = =
d} Timing Const Use for Compile
13 Floorplan Co Open in Text Editor
b Implement Desi(
b EditDesignHard | V& -
» Configure Secur, Delete from Project
» Program Design . .
b Debug Design Delete from Project and Disk
P Handoff Design for Production
Design Flow | Design Hierarchy I Stimulus Hierarchy I Catalog I Files |

Figure 20 » Selecting I/0O PDC Constraint File in Design Flow Tab

22
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3. Click the Generate Bitstream icon in the Design Flow tab (highlighted in Figure 21), or select
Design > Generate Bitstream to synthesize the design, run layout using the 1/0 constraints that
are created, and generate the programming file.

Design Flow

IGL2_Standby

Figure 21+ Generate Programming Data Icon

The design implementation tools run in the batch mode. Successful completion of a design step is
indicated by a green tick mark next to Implement Design in the Design Flow tab, as shown in
Figure 22.

Design Flow 5 X

1GL2_Standby

Tool

-

Create Design

b
-

Create Constraints
+# 1/0 Constraints
constraint\io\IGL2_Standby.pdc
4 d) Timing Constraints
a synthesis\IGL2_Standby_sdc.sdc
Q Floorplan Constraints
4 b Implement Design

[

("4 S Synthesize
4 p Verify Post-Synthesis Implementation
. Simulate
v B3 Compile
+] Configure Flash*Freeze
v 9,3 Place and Route

4 b Edit Constraints
+E 1/0 Constraints
d) Timing Constraints
:E Floorplan Constraints

[

b Verify Post Layout Implementation
+L| Generate Back Annotated Files
. Simulate
@ Verify Timing
o} Verify Power

Edit Design Hardware Configuration

v v

Configure Security and Programming Options

<

Program Design

@ Configure Bitstream

v @ Generate Bitstream

T Run PROGRAM Action
Debug Design

Handoff Design for Production

v v

| Design Flow | Design Hierarchy I Stimulus Hierarchy Catalog I Files |

Figure 22 + Successful Design Implementation
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4. Generate a power report by right-clicking Verify Power under Verify Post Layout
Implementation in the Design Flow tab and selecting Run.

Design Flow 5 X
16L2_Standby B Q @'
Tool o
("4 S Synthesize
4 p Verify Post-Synthesis Implementation
. Simulate
v B3 Compile
+] Configure Flash*Freeze | _
v 9,3 Place and Route
> b Edit Constraints
4 p Verify Post Layout Implementation
+L| Generate Back Annotated Files
. Simulate
- @ Verify Timing 2
| it Verify Powe H
> b Edit Design Hardw, Run
» Configure Security Clean and Run All
¢ 4 » Program Design Open Interactively
@ Configure Bitst Clean |
("4 @ Generate Bitst
T2 Run PROGRAM Help -

| Design Flow | Design Hierarchy I Stimulus Hierarchy Catalog I Files

Figure 23 + Generating Post Layout Power Report
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5. The Reports tab displays reports for the tools used to implement the design. Select
IGL2_Standby_power_report.xml under Verify Power in the Reports tab to view the power
consumption.

Reports & X StartPage & X |

4 1GL2_Standby reports
4 1612 Standby
IGL2_Standby_FCCC_0_configuration.ml
IGL2_Standby_pinrpt_name.rpt
IGL2_Standby_pinrpt_numberrpt
IGL2_Standby_bankrpt.rpt
IGLZ_Standby_ioffxml
Synthesize
synplify.log
4, IGL2_Standby.srr
run_options.bd
4 Compile
IGL2_Standby_rwnetlist.log
@ 16L2_Standby_compile_log.log
@ 1612 standby_sdc.log
IGL2_Standby_compilexml
IGL2_Standby_combinational_loops.xml
Place and Route
IGL2_Standby_glb_net_report.xml
@ 1612 standby_layout_log.log
Verify Power
| IGL2_Standby_power_report.xml
Generate Bitstream
IGL2_Standby_generateBitstream.log

[

[

[

[

Figure 24 + Reports Tab after Implementing Design
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The Reports tab displays the power report, as shown in Figure 25.

(™ Libero - ENIGL2_Stand I\Libero_p IGL2_Standby\IGL2_Standby.prjx

Project File Edit View Design Tools Help

El=1

| reports & x | swrtpage & x|

16L2_Standby_FCCC_0_configurationxml =
16L2_Standby_manifest txt

X Power Summary
16L2_Standby_pinrpt_name.rpt

IGL2_Standby_pinrpt_numberrpt Power (mW) | Percentage

1GL2_Standby_bankrpt.rpt w .

16L2_Standby,_ioftxml Total Power 175.671 100.0%
4 Synthesize Static Power 12 467 T1%

synelifylog Dynamic Power 163.204 92.9% B

i, 1GL2_Standby.srr

run_options.txt =
4 Compile

) 16L2_Standby_compile_log.log Breakdown by Rail L

@ 1612 Standby_sdc.log
16L2_Standby_compilexml
16L2_Standby_combinational_loopsaml

m

Power (mW) Voltage (V) Current (mA)

# Place and Route Rail VDD 144.121 1.200 120.101
16L2_Standby_glb_net_reportaml
16L2_Standby_mindelay_repair_report.rpt Rail VDDI 2.5 21925 2500 8.770
@ 1612 standby layout log.log Rail CCC_NE1_PLL_VDDA | 9.000 3.300 2727
4 Vierify Power
16L2_Standby_power_reportxml Rail VPP 0.625 2.500 0.250
4 Generate Bitstream
16L2_Standby_generateBitstream.log L
Fam: IGLOO2 |Part: M2GLO10T-1FG484 | VHDL

Figure 25+ Power Report

Programming
The following steps describe how to run FlashPro in the batch mode and program IGLOO2 M2GL010T
on the IGLOO2 Evaluation Kit board:
1. Prior to programming and powering up the IGLOO2 Evaluation Kit board, ensure that the jumpers
are positioned as shown in Table 5.

Table 5 + Jumper Settings

Jumper Location Setting
J3 Above the On/Off Switch in Figure 26 1-2 installed
J8 Below the JTAG Programming Header (J5) in Figure 26 1-2 installed
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50 Mhz LPDDR GPIO SW5 LEDs  JTAG Programming Reset ETM Trace
Oscillator Header ‘ Header J8 Switch Debug
J3 | ' Header
|
On/Off
Switch
RVI/IAR
Debug
12V Power Header
Supply Input
10/100/1000
Ethernet | Tx/Rx
RJ4S SERDES
Connector — SMA
: I : Pairs
K e < 9
i I TP16
USB-UART " ; 1 = /35 - ¢
Terminal ﬁmﬂ ‘ ¥ 30y w 7| =) TP17
i b= Mi ! _I2c
Header
MicroUSB
OoTG
SERDES
Reference
Clock Standby
SPI C t Exit
TP7 urren
IGLOO2 TP14  sw4 Flash Measurement
Standby x1 PCle Edge On Board LP Current
Entry Connector 125 Mhz Crystals Measurement ~ SW3 SW2

Figure 26 » IGLOO2 Evaluation Kit
2. Plug the FlashPro4 ribbon cable into connector J5 (JTAG Programming Header) on the IGLOO2
Evaluation Kit board.
3. Connect FlashPro4 to the USB port of the PC using the mini USB cable.

4. Install the FlashPro4 drivers if prompted. The drivers are located at: <FlashPro Installation
Directory>\Drivers.

5. Power on the board by plugging in the power cable and switching on the power switch. Three
green LEDs on the top left of the board are powered on.
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6. In the Design Flow tab, expand Program Design. Right-click Run PROGRAM Action and
select Run to begin programming.

Design Flow

IGL2_Standby

B X

v

!I

Tool

4 | Debug Design

]

K]

]

¥ Handoff Design

+L| Configure Flash*Freeze

ﬁ:; Place and Route
» Edit Constraints

¥ Verify Post Layout Implementation
*L| Generate Back Annotated Files

. Simulate
& Verify Timing
o} Verify Power

Edit Design Hardware Configuration
Configure Security and Programming Options

Program Design

@‘ Configure Bitstream
@‘ Generate Bitstream

m

%% Run PROGRE™

26y Identify Deb
€ SrartDebug

4 Export Bitstre

4 Export Progr
+L| Export Pin Re,

Run
Clean and Run All

Clean

Configure Action/Procedures...

Help

Design Flow | Design Hierarchy

Stimulus Hierarchy

Catalog I Files |

Figure 27 «

Launching Programming Software from Design Flow Tab

FlashPro runs in the batch mode and programs the device. Programming messages are visible in the
Libero SoC log window. Programmer number differs.

Note:

Do not interrupt the programming sequence. It may damage the device or programmer.

The following message is displayed in the Reports view under Program Device when the device is
programmed successfully as shown in Figure 28 on page 29. Programmer number differs:

programmer '92327'

: device

'M2GLO10T'

: Executing action PROGRAM PASSED.
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Reports & X | StartPage & X 5
4 1612 Standby reports €3 0Fmors j, 2Warnings B 0 Info
4 1GL2 Standby
1GL2_Standby_FCCC_0_configuration.xml The 'open_project' command succeeded. -
16L2_Standby_pinrpt_name.rpt 12D file . . . . . .
16L2_Standby_pinpt_nomberrpt D: Microsems_pr3/1612_Standpy_susorial/Libero_projecsT6L2_Ssandby/deaigner/T612_Ssandby/T612_\
Standby.ipd' has been loaded successfully.
1612 Standby bankrpt.rpt DESTGN : TGL2_Standby; CHECKSUM : D230; EDB_VERSTON : 1.8
IGL2_Standby_ioffxml The '"set_programming file' commend succeeded.
4 Synthesize P ing is a o
synplifylog The 'enable device' command succeeded.
i, 16L2_Standbystr The 'set_programming_action' command succeeded. n
run_options.bet programmer '9232 Scan Chain... _
4 Compile 1 p r '92327" : been selected on mes n externally
punp has also been detected. Using externally provided Vpump voltage source.
1GL2_Standby_rwnetlist.log programmer '82327' : Check Chain...
i 1612 Standby_compile log.log programmer : Scan and Check Chain PASSED.
@ 1612 Standby _sdclog programmer device "M2GLO10T' : Execuring acticn PROGREM
16L2_Standby_compilesml programmer device "M2GLO10T' : EXPORT ISC_ENABLE RESULT[32] = 007bg4d
16L2_Standby_combinational loops.ml programmer : deviee 'M2GLO10T' : EXFORT CRCERR: [1] = 0
4 Place and Route programmer :Evlce 52331'5 : g}éﬁg}a;ggcr:iﬂ:ym =0
programmer evice "M2G ' : TEMPGRADE: ROOM
1GL2_Standby_glb_net_reportxml programmer : device 'M2GLOLOT' : EXPORT VPPRANGE: [3] = 2
@ 1612 Standby _layout log.log programmer device "M2GLO10T' : VPERANGE: HIGH
4 Verify Power programmer device 'M2GLOL0T' : EXPORT TEMP: [8] = &8
1GL2_Standby._power_reportxml programmer : device 'M2GLO10T' : EXFORT VEP: [8] = Tb
4 Generate Bitstream programmer device "M2GLO10T' : Programming FPGA Array... L
16L2_Standby_generateBitstream.log programmer : device 'M2GLOLOT' 1
# Run PROGRAM Action programmer '92327' : device 'M2GLO10T' : EXFORT DSN[128] = 03e8aa010000cd5a00910004001c003a
2327 126] : EXFO] 28] = 03e8
& 16L2 Standby PROGRAM.leg programmer '92327' : device 'M2GLO10T' :
programmer : device 'M2GLOL0T' : Finished: Wed Jul 23 10:08:07 2014 (Elapsed time
00:00:2
f[Programmer device "M2GLO10T' : Executing action PROGRAM PASSE
.W:imc;mmmg EASSED.
Chain Programming FIRIShedT Wl OUI ZT TTTUETOT Z0TT (Elepeed time 00:00:29)
The 'run_selected actions' command succeeded.
The 'set_programming_file' command succeeded.
Project saved. b
The 'save_project' command succeeded.
Project closed. -

Figure 28

Programming Messages in Libero SoC Log Window

7. A green tick mark appears next to Program Design and Program Device in the Design Flow
tab indicating that programming is completed successfully.

Design Flow

1GL2_Standby

Tool 'S

>

-

Create Design
[»

-

Create Constraints
a

-

Implement Design
S Synthesize
b Verify Post-Synthesis Implementation
B3 Compile
L] Cenfigure Flash*Freeze
v 9,3 Place and Route
> ¥ Edit Constraints
> P Verify Post Layout Implementation B

<

m

<

Edit Design Hardware Configuration

Configure Security and Programming Options

Program Design

WE Configure Bitstream

("4 5. Generate Bitstream

v B2 Run PROGRAM Action 8

Design Flow | Design Hierarchy I Stimulus Hierarchy Catalog I Files |

Figure 29

Design Flow Tab after Programming

8. Select Project > Exit to close Libero SoC. Select Yes, if prompted about saving the changes.
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Running the Demo Design

Power Measurement (Normal Operation and Standby)

The IGLOO2 Evaluation Kit board has a voltage measuring circuit that measures the voltage across the
VDD (1.2 V) current sense resistor.

The core power can be calculated using the following equations:

Core Current (mA) = Measured Voltage (mV)+5(Scaling Factor)
EQ1
Core Power (mW) = 1.2x Core Current

EQ2

Connect the positive terminal of a standard digital voltmeter (DVM)/multimeter to TP14 and negative
terminal to TP7.

Note the digital voltmeter/multimeter reading and calculate the power using the above equations.

Precise Standby Power Measurement

Precise and accurate power measurements can be obtained by measuring voltage across the 1.2V,
0.05 Q sense resistor. Test points TP16 and TP17 can be used to directly measure voltage across the
1.2 V sense resistor. Since the current drawn by the device in standby mode is expected to be around or
less than 10 mA, the voltage measured across the 0.05 Q sense resistor is expected to be less than
0.5 mV. A precise digital voltmeter such as Fluke-287 that can measure sub-millivolt readings must be
used to read voltage measured across the sense resistor.

Convert the voltage measured across sense resistor to power using the following equation:

Power (mW) = (Voltage(mV)/0.05) x 1.2
EQ3

Total Power (Dynamic and Static)

The following steps describe how to calculate total power:
1. Reset the board by pressing and releasing the Reset button (SW6 DEVRST).
2. Observe the pattern of the LEDs E1, F4, F3, and G7 after resetting the board.
3. Measure the power.

Note: If the LEDs are not toggling after reset, the device is in the Standby mode. Press and release the
standby exit push button (SW3) and observe the LEDs lighting pattern. When the LEDs start
toggling, measure the power.

Standby Power

The following steps describe how to calculate standby power:

1. Press and release the standby entry push button (SW1) and observe the LEDs lighting pattern.
The LEDs stop toggling.

Measure the power.
3. Press and release the standby exit push button (SW3).
4. When finished, remove power from the board.
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Appendix: Power Estimator

Power Estimator

The following steps describe how to use Power Estimator and calculate the total power:

Download the Power Estimator, SmartFusion2 and IGLOOZ2 Power Calculator.

Double-click and open the power estimator spreadsheet.

Click the Summary worksheet. The Summary worksheet provides the device settings and the power summary.
Change the device settings by entering the following information:

— Family: Select IGLOO2 from the drop-down list

— Device: Select M2GL010T from the drop-down list

— Package: Select 484 FBGA from the drop-down list

PoDN -~

- Settings

General
Family

Device

Package

Range

Core Voltage

Process

Data State Preliminary

Figure 1+ Settings Section in the Device Settings and Summary Worksheet

The Summary worksheet has an integrated initialize power estimator wizard. This wizard provides an option to select
design specific information. Upon running the wizard, it populates the power calculator spreadsheet with information
about the design and performs power estimation for the design.
5. Click Initialize Power Estimator as shown in Figure 2. The Initialize Power Estimator dialog box opens as
shown in Figure 3 on page 32.

Initialize Power Estimator Reset to Defaults

Settings

General
Family IGLOO2
Device M2GL010T

Figure 2 » Initialize Power Estimator
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Appendix: Power Estimator

Set all FPGA fabric resources to: 50%
uSRAM: Move the slider to zero, 0/22 (0%)
10:

Technology: LVCMOS25

#Inputs: 21
#Outputs: 22

Enter the following information in the Initialize Power Estimator dialog box:

* Default RAM Enable Rate: 100%

rlnilialize Power Estimator . ® ‘ - ‘ ’ g
— HPMS — FPGA Fabric
[~ Used HPMS_CLE 100 MHz System Clock 100 MHz
HPMS_DDR
Type Width ECC ooT HPM5_DDR_CLK |Seta\lFPG.ﬂFabncrasourcestu 50 %% vl |
- B - = 0_0DT = HPMS_CLK*1 v | 100 MHz
, o [e -] Lo S = T
|
o
— FODR
Type Width ECC oot AXIJAHB CLK FDOR_CLK I e il | I%I "
drd r° [ & [w ] [k s N
MACC x| ol | 11/22(0%)
— SERDES_IF 0
Technol #Inputs #0utputs
Select Protocal Number of - sajare oLk (Pete) Ref Clk Freq i i e
|| LVCMOS25 | E | 22 |
I seroeso | roe 2 S wi | 1 B
Default Toggle Rate 12.5 o
seroes 1 | poe e [ I 125 Iuefau\mAMEnah\eRahe [ zool - I |
Reset | K Cancel |
e —

Figure 3 » Initialize Power Estimator Wizard

7. Click OK. Click Yes in the Reset and set to the values specified dialog box.

8. Click the CCC & Oscillator worksheet and scroll down to the FAB_CCC Power section. Enter the following
information in the FAB_CCC Power table:

— Name: FCC_0

— Reference clock frequency (MHz): 0.032
— PLL output frequency (MHz): 500 MHz
— Output1 frequency (MHz):100 MHz

FAB_CCC Power
Output1 Output2 Output3 Output4 VDD PLL VDDA

Reference  PLL Output
Clock Clock

Name Frequency Frequency Frequency Frequency Power Power
Frequency  Frequency
(MHz) (MHz) (MHz) (MHz) (MHz) (MHz) (mW) (mW)
L 1 000 000
0.00 0.00
0.00 0.00
0.00 0.00
0.00 0.00
0.00 0.00
0.00 000

Figure 4+ FAB_CCC Section
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9. Click the Summary worksheet to get the total power. The Power Summary section is populated with the Total

Active Mode power.

Total Power (mW)

Thermal Power (mWV)

Effective Theta JA ( "C/W )

Thermal Margin

- Power Summary

Active Mode: Summary

Junction Temperature Tj ( °C )

Maximum Ta ( °C )

Maximum Power (mW)

Figure 5+ Power Summary

10. The Modes and Scenarios section is populated with the total power in the Active, Standby, and Flash*Freeze

modes.

- Modes and Scenarios

Active

Mode % Time in Mode

Low Power Mode Scenario

Power in Mode Power in scenario
(mWW) (mW)

Standby

Flash*Freeze

Scenario Power

Figure 6 = Modes and Scenarios

11. Close Power Estimator.
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A — List of Changes

The following table shows the important changes made in this document for each revision.

Date Changes Page
Revision 4 Updated the document for Libero SoC v11.6 (SAR 71653). NA
(October 2015)
Revision 3 Updated the document for Libero SoC v11.5 (SAR 64364). NA
(February 2015)
Revision 2 Updated the document for Libero SoC v11.4. NA
(August 2014)
Revision 1 Initial release. NA
(October 2013)

Revision 4 34




& Microsemi
B — Product Support

Microsemi SoC Products Group backs its products with various support services, including Customer
Service, Customer Technical Support Center, a website, electronic mail, and worldwide sales offices.
This appendix contains information about contacting Microsemi SoC Products Group and using these
support services.

Customer Service

Contact Customer Service for non-technical product support, such as product pricing, product upgrades,
update information, order status, and authorization.

From North America, call 800.262.1060
From the rest of the world, call 650.318.4460
Fax, from anywhere in the world, 408.643.6913

Customer Technical Support Center

Microsemi SoC Products Group staffs its Customer Technical Support Center with highly skilled
engineers who can help answer your hardware, software, and design questions about Microsemi SoC
Products. The Customer Technical Support Center spends a great deal of time creating application
notes, answers to common design cycle questions, documentation of known issues, and various FAQs.
So, before you contact us, please visit our online resources. It is very likely we have already answered
your questions.

Technical Support

For Microsemi SoC Products Support, visit
http://www.microsemi.com/products/fpga-soc/design-support/fpga-soc-support.

Website

You can browse a variety of technical and non-technical information on the Microsemi SoC Products
Group home page, at http://www.microsemi.com/products/fpga-soc/fpga-and-soc.

Contacting the Customer Technical Support Center

Highly skilled engineers staff the Technical Support Center. The Technical Support Center can be
contacted by email or through the Microsemi SoC Products Group website.

Email

You can communicate your technical questions to our email address and receive answers back by email,
fax, or phone. Also, if you have design problems, you can email your design files to receive assistance.
We constantly monitor the email account throughout the day. When sending your request to us, please
be sure to include your full name, company name, and your contact information for efficient processing of
your request.

The technical support email address is soc_tech@microsemi.com.
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Product Support

My Cases

Microsemi SoC Products Group customers may submit and track technical cases online by going to My
Cases.

Outside the U.S.

Customers needing assistance outside the US time zones can either contact technical support via email
(soc_tech@microsemi.com) or contact a local sales office. Visit About Us for sales office listings and
corporate contacts.

ITAR Technical Support

For technical support on RH and RT FPGAs that are regulated by International Traffic in Arms
Regulations (ITAR), contact us via soc_tech@microsemi.com. Alternatively, within My Cases, select Yes
in the ITAR drop-down list. For a complete list of ITAR-regulated Microsemi FPGAs, visit the ITAR web

page.
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Microsemi.

Microsemi Corporate Headquarters
One Enterprise, Aliso Viejo,
CA 92656 USA

Within the USA: +1 (800) 713-4113
Outside the USA: +1 (949) 380-6100
Sales: +1 (949) 380-6136

Fax: +1 (949) 215-4996

E-mail: sales.support@microsemi.com

© 2015 Microsemi Corporation. All
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Microsemi  Corporation. All  other
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property of their respective owners.
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