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Accessing Serial Flash Memory using SPI Interface 
- Libero SoC and IAR Embedded Workbench Flow 
Tutorial for SmartFusion2 SoC FPGA

Introduction
The Libero® System-on-Chip (SoC) software generates firmware projects using IAR, Keil, and
SoftConsole tools. This tutorial describes the process to build an IAR application that can be
implemented and validated using the SmartFusion®2 system-on-chip (SoC) field programmable gate
array (FPGA) Development Kit. 

The same firmware project can be built using SoftConsole and Keil tools. Refer to the respective tutorials
(links given below): 

• Accessing Serial Flash Memory using SPI Interface - Libero SoC and SoftConsole Flow Tutorial 
for SmartFusion2 SoC FPGA 

• Accessing Serial Flash Memory Using SPI Interface - Libero SoC and Keil uVision Flow Tutorial 
for SmartFusion2 SoC FPGA 

After completing this tutorial, you will be able to perform the following tasks:

• Create a Libero SoC project using System Builder

• Generate the programming file to program the SmartFusion2 device

• Open the project in IAR Embedded Workbench from Libero SoC 

• Compile application code

• Debug and run code using IAR Embedded Workbench

Tutorial Requirements
Table 1 • Reference Design Requirements and Details

Reference Design Requirements and Details Description

Hardware Requirements

• SmartFusion2 Development Kit

– FlashPro4 programmer 

– J-Link programmer

– USB A to Micro-B cable

– 12 V adapter 

Rev C or later

Host PC or Laptop Any 64-bit Windows Operating System

Software Requirements

Libero SoC

• FlashPro programming software v11.3

11.3

IAR Embedded Workbench for ARM 6.40
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Accessing Serial Flash Memory using SPI Interface - Libero SoC and IAR Embedded Workbench Flow Tutorial for 
SmartFusion2 SoC FPGA
Associated Project Files
Download the associated project files for this tutorial from the Microsemi® website: 
www.microsemi.com/soc/download/rsc/?f=SF2_SPI_Flash_IAR_Tutorial_DF 

The demo design files include:

• Libero project

• Programming files

• Source files

• Flash drivers

• Readme file

Refer to the Readme.txt file provided in the design files for the complete directory structure.

Target Board
SmartFusion2 Development Kit board (SF2_DEV_KIT) Rev C (or later).

Design Overview
This design example demonstrates the execution of basic read and write operations on the SPI flash
present on the SmartFusion2 Development Kit board. This kit has a built-in Atmel SPI flash memory
AT25DF641, which is connected to the SmartFusion2 microcontroller subsystem (MSS) through
dedicated MSS SPI_0 interface. The SPI flash memory transfers are performed using the peripheral
direct memory access (PDMA).

Read and write data information is displayed using HyperTerminal which communicates to the
SmartFusion2 MSS using the MMUART_1 interface.

For more information on SPI, refer to the SmartFusion2 Microcontroller Subsystem User Guide.

USB to UART drivers -

One of the following serial terminal emulation programs:

• HyperTerminal

• TeraTerm

• PuTTY

-

Table 1 • Reference Design Requirements and Details (continued)

Reference Design Requirements and Details Description
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Step 1: Creating a Libero SoC Project
Figure 1 shows interfacing the external SPI flash to MSS SPI_0.

Step 1: Creating a Libero SoC Project

Launching Libero SoC
1. Click Start > Programs > Microsemi Libero SoC v11.3 > Libero SoC v11.3, or click the shortcut 

on desktop to open the Libero SoC v11.3 Project Manager.

2. Create a new project by selecting New on the Start Page tab (highlighted in Figure 2), or by 
clicking Project > New Project from the Libero SoC menu. 

Figure 1 • SPI Flash Interfacing Block Diagram

Figure 2 • Libero SoC Project Manager
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Accessing Serial Flash Memory using SPI Interface - Libero SoC and IAR Embedded Workbench Flow Tutorial for 
SmartFusion2 SoC FPGA
3. Enter the information as required for the new project and the device in the New Project dialog
box as shown in Figure 3.

– Project

- Name: SPI_Flash

- Location: Select an appropriate location (for example, D:/Microsemi_prj)

- Preferred HDL type: Verilog

– Device (select the following values using the drop-down list provided):

- Family: SmartFusion2

- Die: M2S050T

- Package: 896 FBGA

- Speed: STD

- Core Voltage: 1.2

– Operating conditions: COM
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Step 1: Creating a Libero SoC Project
4. Check the Use Design Tool check box and select Use System Builder in the Design 
Templates and Creators section of the New Project window as shown in Figure 3. 

Note: System Builder is a graphical design wizard. It creates a design based on high-level design 
specifications by taking the user through a set of high-level questions that will define the intended 
system.

Figure 3 • New Project Dialog BoxSup
ers

ed
ed
Revision 1 7



Accessing Serial Flash Memory using SPI Interface - Libero SoC and IAR Embedded Workbench Flow Tutorial for 
SmartFusion2 SoC FPGA
5. Clicking Edit Tool Profiles (highlighted in Figure 3 on page 7) displays the Tool Profiles window 
as shown in Figure 4. Check the following tool settings:

– Software IDE: IAR

– Synthesis: Synplify Pro ME I-2013.09M-SP1

– Simulation: ModelSim ME 10.2c

– Programming: FlashPro 11.3

6. Click OK on the Tool Profiles window.

7. Click OK on the New Project window. This displays the System Builder dialog box.

8. Enter a name for your system, enter SPI_Flash as the name of the system and click OK. The 
System Builder dialog box is displayed with the Device Features page open by default, as 
shown in Figure 5. 

Figure 4 • Tool Profiles

Figure 5 • Create New System Builder Dialog Box
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Step 1: Creating a Libero SoC Project
9. In the System Builder – Device Features page, check the Peripheral DMA check box under
Microcontroller Options as shown in Figure 6. 

Figure 6 • System Builder – Device Features Page
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Accessing Serial Flash Memory using SPI Interface - Libero SoC and IAR Embedded Workbench Flow Tutorial for 
SmartFusion2 SoC FPGA
10. Click Next. The System Builder – Peripherals page is displayed. Under the MSS Peripherals
section, uncheck all the check boxes except MM_UART_1 and MSS_SPI_0, as shown in
Figure 7. 

Figure 7 • System Builder Configurator – Peripherals Page
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Step 1: Creating a Libero SoC Project
11. Configure MMUART_1 for Fabric by clicking on the MM_UART_1 configurator highlighted as 
shown in Figure 8. 

12. In the MM_UART_1 configurator window, select Fabric from the Connect To drop-down list, as 
shown in Figure 9. 

Figure 8 • System Builder – Peripherals Page
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Figure 9 • Configuring MM_UART_1
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Step 1: Creating a Libero SoC Project
13. Click Next. The System Builder – Clocks page is displayed, as shown in Figure 10. Select
System Clock source as On-chip 25/50 MHz RC Oscillator. The M3_CLK is configured to 
100 MHz by default.

14. Click Next. The System Builder – Microcontroller page is displayed. Leave all the default
selections.

15. Click Next. The System Builder – SECDED page is displayed. Leave all the default selections.

16. Click Next. The System Builder – Security page is displayed. Leave all the default selections.

17. Click Next. The System Builder – Interrupts page is displayed. Leave all the default selections.

18. Click Next. The System Builder – Memory Map page is displayed. Leave all the default
selections.

19. Click Finish.

Figure 10 • System Builder – Clocks Page
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Accessing Serial Flash Memory using SPI Interface - Libero SoC and IAR Embedded Workbench Flow Tutorial for 
SmartFusion2 SoC FPGA
The System Builder generates the system based on the selected options. The System Builder 
block is created and added to the Libero SoC project automatically, as shown in Figure 11.

Connecting Components in SPI_Flash_top SmartDesign
Perform the following steps to connect the SmartDesign components:

1. Right-click FAB_RESET_N and select Tie High.

2. Right-click POWER_ON_RESET_N and select Mark Unused.

3. Right-click MSS_READY and select Mark Unused.

4. Right-click MMUART_1_FABRIC and select Promote to Top Level.

5. Expand INIT_PINS, right-click INIT_DONE and select Mark Unused.

6. Expand FAB_CCC_PINS, right-click FAB_CCC_GL0 and select Mark Unused.

7. Click File > Save. The SPI_Flash_top design is displayed as shown in Figure 12.

Configuring and Generating Firmware
The Design Firmware window displays compatible firmware drivers based on peripherals configured in 
the design. Following drivers are used in this tutorial:

• CMSIS

• MMUART

• PDMA

• SPI

1. To generate the required drivers, click Design > Configure Firmware and uncheck all drivers 
except CMSIS, MMUART, PDMA, and SPI as shown in Figure 13.

Figure 11 •  System Builder Generated System

Figure 12 • SPI_Flash_top Design
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Step 1: Creating a Libero SoC Project
Note:Select the latest version of the drivers.

2. From the SPI_Flash_top tab, click Generate Component, as shown in Figure 14. 

If the design is generated without any errors, a message, ’SPI_Flash_top’ was generated is 
displayed on the Libero SoC Log window as shown in Figure 15. 

Figure 13 •  Configuring Firmware

Figure 14 • Generate Component

Figure 15 • Log WindowSup
ers

ed
ed
Revision 1 15



Accessing Serial Flash Memory using SPI Interface - Libero SoC and IAR Embedded Workbench Flow Tutorial for 
SmartFusion2 SoC FPGA
Step 2: Generating the Program File
1. Double-click I/O Constraints in the Design Flow window as shown in Figure 16. The I/O Editor

window is displayed after completing Synthesize and Compile.  

2. In the I/O Editor window, make the pin assignments as shown in Table 2.

Figure 16 • I/O Constraints

Table 2 • Port to Pin Mapping

Port Name Pin Number

MMUART_1_RXD_F2M R29

MMUART_1_TXD_M2F R24Sup
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Step 3: Programming the SmartFusion2 Board Using FlashPro
These pin assignments are for connecting MMUART_1 ports TX and RX to the mini-B USB 
through fabric I/Os. After the pins are assigned, the I/O Editor window is displayed as shown in 
Figure 17.

3. After updating the I/O Editor, click Commit and Check.

4. Close the I/O Editor window.

5. Click Generate Programming Data as shown in Figure 18 to complete place-and-route and 
generate the programming file.

Step 3: Programming the SmartFusion2 Board Using 
FlashPro

1. Connect the FlashPro4 programmer to the J59 connector of the SmartFusion2 Development Kit.

2. Connect the jumpers on the SmartFusion2 Development Kit board as listed in Table 3 on 
page 18.
For more information on jumper locations, refer Appendix C - SmartFusion2 Development Kit 
Board Jumper Locations.

CAUTION: While making the jumper connections, the SW7 power supply switch on the board 
must be in OFF position. 

Figure 17 • I/O Editor

Figure 18 • Generate Programming Data
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Accessing Serial Flash Memory using SPI Interface - Libero SoC and IAR Embedded Workbench Flow Tutorial for 
SmartFusion2 SoC FPGA
3. Connect the power supply to the J18 connector.

4. Switch ON the SW7 power supply switch. 

Refer to Appendix A - Board Setup for Programming the Tutorial for information on board setup 
for running the tutorial.

5. To program the SmartFusion2 device, double-click Run PROGRAM Action in the Design Flow
window as shown in Figure 19. 

After successful programming, the SmartFusion2 Development Kit is ready for running and 
debugging the IAR Embedded Workbench application through J-Link Debugger.

Table 3 • SmartFusion2 Development Kit Jumper Settings

Jumper Number Settings Notes

J70, J93, J94, J117, 
J123, J142, J157, J160, 
J167, J225, J226, J227

1-2 closed These are the default jumper settings of the Development 
Kit. Ensure that these jumpers are set properly.

J2 1-3 closed

J23 2-3 closed

J121,J110,J119,J118 1-2 closed To connect the SmartFusion2 SPI0 to the external flash.

Figure 19 • Run Programming Action
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Step 4: Building the Software Application using IAR Embedded Workbench
Step 4: Building the Software Application using IAR 
Embedded Workbench

1. Connect the J-Link programmer to J34 connector of SmartFusion2 Development Kit.

Refer to "Appendix B- Board Setup for Running the IAR Tutorial" on page 45 for information on 
the board setup for running and debugging the IAR software application.

Make sure that the SmartFusion2 Development Kit Jumper J93 is in 2-3 closed position for IAR 
Embedded Workbench and J-Link communication.

2. Open the IAR project by double-clicking Write Application Code under Develop Firmware in the 
Design Flow window as shown in Figure 20. 

Figure 20 • Invoking IAR Embedded Workbench from the Libero SoC Software
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Accessing Serial Flash Memory using SPI Interface - Libero SoC and IAR Embedded Workbench Flow Tutorial for 
SmartFusion2 SoC FPGA
The IAR workspace is displayed, as shown in Figure 21. 

3. Browse to the main.c file location in the design files folder:
<download folder>\SF2_SPI_Flash_IAR_Tutorial_DF\SourceFiles.

4. Copy the main.c file and replace the existing main.c file under SPI_Flash_MSS_CM3_app
project in the IAR workspace.

Figure 21 • IAR Workspace
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Step 4: Building the Software Application using IAR Embedded Workbench
The IAR window displays the main.c file, as shown in Figure 22. 

5. at25df641 SPI flash drivers are not included in the Libero generated IAR workspace. To include
the drivers in the IAR workspace, browse to the location of the at25df641 drivers in the design
files folder: <download_folder>\SF2_SPI_Flash_IAR_Tutorial_DF\SPI_Flash_Drivers.

6. Copy the at25df641 folder to the drivers folder of SPI_Flash_MSS_CM3_hw_platform project in
the IAR workspace: projectdirectory\IAR\drivers.

Figure 22 • IAR Workspace main.c file 
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Accessing Serial Flash Memory using SPI Interface - Libero SoC and IAR Embedded Workbench Flow Tutorial for 
SmartFusion2 SoC FPGA
7. Right-click and add the driver files (at25df641.c and at25df641.h) to the
SPI_Flash_MSS_CM3_hw_platform project in the IAR workspace as shown in Figure 23.

Figure 23 • IAR Workspace Window - Add at25df641 SPI Driver Files

Sup
ers

ed
ed
22 Revision 1



Step 4: Building the Software Application using IAR Embedded Workbench
Figure 24 shows the IAR workspace window displaying at25df641 SPI Driver Files.

Figure 24 • IAR Workspace Window - Display at25df641 SPI Driver Files
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Accessing Serial Flash Memory using SPI Interface - Libero SoC and IAR Embedded Workbench Flow Tutorial for 
SmartFusion2 SoC FPGA
8. To configure the project, right-click the project name (SPI_Flash_MSS_CM3_hw_platform) and 
click Options as shown in Figure 25. 

This tutorial uses printf statements to display memory read data. Redirection of the output of 
printf() to a UART is enabled by adding the MICROSEMI_STDIO_THRU_UART symbol.

9.  In Options window, click C/C ++ Compiler. 

10. Click Preprocessor tab. 

Figure 25 • IAR Workspace Window - Choose Options

Sup
ers

ed
ed
24 Revision 1



Step 4: Building the Software Application using IAR Embedded Workbench
11. Under Defined symbols enter MICROSEMI_STDIO_THRU_UART and click OK, as shown in 
Figure 26.

Figure 26 • IAR Workspace Window - Adding Symbol
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Accessing Serial Flash Memory using SPI Interface - Libero SoC and IAR Embedded Workbench Flow Tutorial for 
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12. To configure the project, right-click the project name (SPI_Flash_MSS_CM3_app) and click 
Options as shown in Figure 27. 

Figure 27 • IAR Workspace Window - Choose Options
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Step 4: Building the Software Application using IAR Embedded Workbench
13. The Options for node SPI_Flash_MSS_CM3_app window is displayed as shown in Figure 28.

14. Click Debugger. Under the Setup tab, select J-Link/J-Trace from the Driver the drop-down list
(refer to Figure 29).

Figure 28 • IAR Node Options
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Accessing Serial Flash Memory using SPI Interface - Libero SoC and IAR Embedded Workbench Flow Tutorial for 
SmartFusion2 SoC FPGA
15. Click Download tab and select the Verify download check box as shown in Figure 30.

16. Click OK to close the Options window and build the project.

Figure 29 • IAR Debugger Options - Selecting Driver

Figure 30 • IAR Debugger Options - Download
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Step 4: Building the Software Application using IAR Embedded Workbench
17. Right-click on SPI_Flash_MSS_CM3_hw_platform - Debug and select Make as shown in 
(Figure 31 and Figure 32 on page 30). 

Figure 31 • IAR Workspace - Hardware Platform Code Compilation using Make

Sup
ers

ed
ed
Revision 1 29



Accessing Serial Flash Memory using SPI Interface - Libero SoC and IAR Embedded Workbench Flow Tutorial for 
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Figure 32 • IAR Workspace - Successful Hardware Platform Code Compilation using Make
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Step 4: Building the Software Application using IAR Embedded Workbench
18. Right-click on the SPI_Flash_MSS_CM3_app - Debug project name and select Set as Active as 
shown in Figure 33.

Figure 33 • IAR Workspace - SPI_Flash_MSS_CM3_app Set as Active
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Accessing Serial Flash Memory using SPI Interface - Libero SoC and IAR Embedded Workbench Flow Tutorial for 
SmartFusion2 SoC FPGA
19. Right-click on the SPI_Flash_MSS_CM3_app - Debug project name and select Clean as shown 
in Figure 34.

Figure 34 • IAR Workspace - Execute Clean on SPI_Flash_MSS_CM3_app Project
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Step 4: Building the Software Application using IAR Embedded Workbench
20. After cleaning the project, the Messages log section shows that some files are deleted as shown 
in Figure 35.

Figure 35 • IAR Workspace - Deleted Files
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Accessing Serial Flash Memory using SPI Interface - Libero SoC and IAR Embedded Workbench Flow Tutorial for 
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21. Right-click on the SPI_Flash_MSS_CM3_app - Debug project name and click Rebuild All as 
shown in Figure 36. 

Figure 36 • IAR Workspace - Select Rebuild All
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Step 5: Configuring Serial Terminal Emulation Program
Step 5: Configuring Serial Terminal Emulation Program
1. Install the USB driver. For serial terminal communication through the FTDI mini USB cable, install 

the FTDI D2XX driver. Download the drivers and the installation guide from: 
www.microsemi.com/soc/documents/CDM_2.08.24_WHQL_Certified.zip.

Figure 37 • IAR Workspace - Rebuild All
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Accessing Serial Flash Memory using SPI Interface - Libero SoC and IAR Embedded Workbench Flow Tutorial for 
SmartFusion2 SoC FPGA
2. Connect the host PC to the J24 connector using the USB Mini-B cable. The USB to UART bridge
drivers are automatically detected. Of the four COM ports, select the one with Location as on
USB Serial Converter D. Figure 38 shows an example Device Manager window.

3. Start the HyperTerminal session. If the HyperTerminal program is not available in the computer,
any free serial terminal emulation program such as PuTTY or TeraTerm can be used. Refer to the
Configuring Serial Terminal Emulation Programs Tutorial for configuring the HyperTerminal,
TeraTerm, or PuTTY.

The HyperTerminal settings are as follows:

– 57,600 baud rate

– 8 data bits

– 1 stop bit

– No parity

– No flow control

Figure 38 • Device Manager Window
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Step 6: Debugging the Application Project using IAR Workbench
Step 6: Debugging the Application Project using IAR 
Workbench

1. Switch to SPI_Flash_MSS_CM3_app - Debug tab from Overview tab as shown in Figure 39.

2. In the IAR Workbench, click Download and Debug as shown in Figure 40.

Figure 39 • Debug Window

Figure 40 • IAR Workbench - Download and Debug OptionSup
ers
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Accessing Serial Flash Memory using SPI Interface - Libero SoC and IAR Embedded Workbench Flow Tutorial for 
SmartFusion2 SoC FPGA
IAR Debugger Perspective window is opened, as shown in Figure 41.

3. Click Go on IAR workbench to run the application as shown in Figure 42.

Figure 41 • IAR Workbench - Debugger Perspective

Figure 42 • IAR Workbench - Go Option

Sup
ers

ed
ed
38 Revision 1



Step 6: Debugging the Application Project using IAR Workbench
4. On successful operation, the HyperTerminal window displays a message as Read Data From
Flash as shown in Figure 43.

Figure 43 • HyperTerminal Window
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Accessing Serial Flash Memory using SPI Interface - Libero SoC and IAR Embedded Workbench Flow Tutorial for 
SmartFusion2 SoC FPGA
5. Click View > Register to view the values of the ARM® Cortex™-M3 processor internal registers
as shown in Figure 44.

Figure 44 • Values of the Cortex-M3 Internal Registers
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Step 6: Debugging the Application Project using IAR Workbench
6. Click View > Statics to view the values of variables in the source code as shown in Figure 45.

Figure 45 • Values of the Source Code Variables
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Accessing Serial Flash Memory using SPI Interface - Libero SoC and IAR Embedded Workbench Flow Tutorial for 
SmartFusion2 SoC FPGA
7. Click View > Disassembly to view the values of variables in the source code as shown in
Figure 46. 

8. When debug process is finished, terminate execution of the code by choosing Debug > Stop
Debugging as shown in Figure 47.

Figure 46 • Assembly Level Instructions

Figure 47 • IAR Workbench - Stop Debugging OptionSup
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Conclusion
9. The Step Level Debugging can be performed before running the application using Go. These can
be accessed from the Debug menu or on the IAR workbench as shown in Figure 48:

– Source code can be single-stepped by selecting from the Debug menu Debug > Step Into, 
Debug > Step Out, Debug > Step Over or selecting the respective options from the IAR 
workbench as shown in Figure 48. Observe the changes in the source code window and 
Disassembly view. Performing a Step Over provides an option for stepping over functions. 
The entire function is run but there is no need to single-step through each instruction 
contained in the function.

10. Close Debug Perspective by selecting Close Perspective from the Window menu.

11. Close IAR Embedded Workbench using File > Exit. 

12. Close the HyperTerminal using File > Exit. 

Conclusion
This tutorial provides steps to create a Libero SoC design using the System Builder. It describes the
procedure to build, debug, and run an IAR Embedded Workbench application. It also provides a simple
design to access the SPI flash.

Figure 48 • IAR Workbench - Step Level Debugging
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Appendix A - Board Setup for Programming the 
Tutorial

Figure 1 shows the board setup for programming the tutorial on the SmartFusion2 Development Kit
board.

Figure 1 • SmartFusion2 Development Kit Setup
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Appendix B- Board Setup for Running the IAR 
Tutorial

Figure 1 shows the board setup for running and debugging the tutorial on the SmartFusion2
Development Kit board.

Figure 1 • SmartFusion2 Development Kit J-Link Programmer ConnectionSup
ers
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Appendix C - SmartFusion2 Development Kit Board 
Jumper Locations

Figure 1 shows the jumper locations on the SmartFusion2 Development Kit board.

Note:

• Jumpers highlighted in red are set by default.

• Jumpers highlighted in green must be set manually.

• The location of the jumpers in Figure 1 are searchable.

Figure 1 • SmartFusion2 Development Kit Board Jumper Locations
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Product Support

Microsemi SoC Products Group backs its products with various support services, including Customer
Service, Customer Technical Support Center, a website, electronic mail, and worldwide sales offices.
This appendix contains information about contacting Microsemi SoC Products Group and using these
support services.

Customer Service
Contact Customer Service for non-technical product support, such as product pricing, product upgrades,
update information, order status, and authorization.

From North America, call 800.262.1060
From the rest of the world, call 650.318.4460
Fax, from anywhere in the world, 408.643.6913

Customer Technical Support Center
Microsemi SoC Products Group staffs its Customer Technical Support Center with highly skilled
engineers who can help answer your hardware, software, and design questions about Microsemi SoC
Products. The Customer Technical Support Center spends a great deal of time creating application
notes, answers to common design cycle questions, documentation of known issues, and various FAQs.
So, before you contact us, please visit our online resources. It is very likely we have already answered
your questions.

Technical Support
Visit the Customer Support website (www.microsemi.com/soc/support/search/default.aspx) for more
information and support. Many answers available on the searchable web resource include diagrams,
illustrations, and links to other resources on the website. 

Website
You can browse a variety of technical and non-technical information on the SoC home page, at
www.microsemi.com/soc.

Contacting the Customer Technical Support Center
Highly skilled engineers staff the Technical Support Center. The Technical Support Center can be
contacted by email or through the Microsemi SoC Products Group website.

Email
You can communicate your technical questions to our email address and receive answers back by email,
fax, or phone. Also, if you have design problems, you can email your design files to receive assistance.
We constantly monitor the email account throughout the day. When sending your request to us, please
be sure to include your full name, company name, and your contact information for efficient processing of
your request.

The technical support email address is soc_tech@microsemi.com.
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Product Support
My Cases
Microsemi SoC Products Group customers may submit and track technical cases online by going to My
Cases.

Outside the U.S.
Customers needing assistance outside the US time zones can either contact technical support via email
(soc_tech@microsemi.com) or contact a local sales office. Sales office listings can be found at
www.microsemi.com/soc/company/contact/default.aspx.

ITAR Technical Support
For technical support on RH and RT FPGAs that are regulated by International Traffic in Arms
Regulations (ITAR), contact us via soc_tech_itar@microsemi.com. Alternatively, within My Cases, select
Yes in the ITAR drop-down list. For a complete list of ITAR-regulated Microsemi FPGAs, visit the ITAR
web page.
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