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Tutorial for SmartFusion2

Introduction

Libero® System-on-Chip (SoC) Firmware catalog shows a list of available firmware cores. Sample
projects for each firmware core can be generated from Firmware catalog. A sample project is an example
of how the firmware core can be integrated in a project. This sample project contains firmware. project
using SoftConsole, IAR workbench, and Keil tools. But a sample project does not have a Libero project
for that generated firmware project. Each sample project folder contains a.Readme. text file which gives
an overview of the design and hardware requirements. Using this information, the'Libero SoC project can
be generated.

This tutorial describes downloading the SoftConsole sample project-from Firmware catalog and creating
a Libero SoC hardware design for the downloaded sample project. This. tutorial provides an example
design for System Services.

Upon completion of this tutorial, you will be familiar with the following:
» Downloading SoftConsole sample project from/Firmware catalog
* Creating a Libero SoC project
» Generating the programming file
* Opening the project in SoftConsole
* Creating and launching a debug/session
* Running the System Services application
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Tutorial Requirements

Table 1+ Reference Design Requirements and Details

Reference Design Requirements and Details

Description

Hardware Requirements

SmartFusion2 Development Kit
* FlashPro4 programmer

* USB A to Mini-B cable
12V Adapter

Rev C or later

Host PC or Laptop

Any Windows 64-Bit Operating System

Software Requirements

Libero SoC
+ SoftConsole v3.4
* FlashPro programming software v11.3

1.3

Host PC Drivers

USB to UART drivers

Any one of the following serial terminal emulation
programs:

* HyperTerminal
*  TeraTerm
« PUuTTY

Associated Project Files

The design files for this tutorial can be downloaded from the Microsemi® website:
http://soc.microsemi.com/download/rsc/?f=SF2_SYS SERVICES_Tutorial DF

The design files include:
» Libero project
* Programmingfiles
* Readme file

Refer to the rReadme . txt file provided in the design files for the complete directory structure.

Target Board

SmartFusion2 Development Kit Board (SF2_DEV_KIT) Rev C or later.

Design Overview

This tutorial demonstrates the following Device and Design Information services:

« Serial Number Service: Fetches the 128-bit device serial number (DSN) and is set during
manufacturing.

+ USERCODE Service: Fetches the programmed 32-bit JTAG USERCODE.
» User Design Version Service: Fetches the 16-bit user design version.

+ NVM Data Integrity Check Service: Recalculates and compares cryptographic digests of the
selected NVM component(s)—fabric, eNVMO0, and eNVM1—to those previously computed and
saved in NVM.

Note: In this tutorial only fabric digest check is demonstrated.
System Services Information is displayed on HyperTerminal using MMUART_O interface.
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For more information on System Services, refer to SmartFusion2 System Controller User Guide.

Step 1: Downloading SoftConsole Project from Firmware
Catalog

1. Click Start > Programs > Microsemi SoC Libero SoC 11.3 > Firmware Catalog v11.3 >
Firmware Catalog. Right-click on SmartFusion2 MSS System Services Driver and select
Generate Sample Project > Cortex-M3 > SoftConsole > Read Version Information as shown

in Figure 1.
# Firmware Catalog A = | B o
File View Tools Help
View (33/69): Search by description (43/43):

[ Al ][ 3 Vault || @] web repositories &
display only the latest version of a core M
Name Version Size (MB) Status -
SmartFusion2 MSS eNVM Driver 21102 047

SmartFusion2 MSS Watchdog Driver 20102 078

SmartFusion2 M5S USE Driver 22103 312

SmartFusion2 MSS Timer Driver 20100 093

FSmartFusion? VS5 System Services O .o 121100 324 y Y

SmartFusion2 MSS SPI Driver £ 20103 088

SmartFusion2 MSS RTC Driver & Remove from vault 21102 101 £
SmartFusion2 M55 PDMA driver 20102 0.92

SmartFusion2 MSS MMUART Driver | & Show details.. 20101 0.76

SmartFusion2 MSS 12C Driver Open documentation 4 20100 0.52

SmartFusion2 MSS HRDMA Driver v " |

SmartFusion2 M55 GPIO Driver SRR s I Corterh3 > D =i S

SmartFusion2 MSS Ethernet MAC Driver 21102 Keil-MDK i Y\

SmartFusion2 MSS CAN Centroller Driver 20100 SoftConsole » | Read Vercion Information |

SmartFusion2 CMSIS Hardware Abstraction Layer 21100 ar —

SmartFusion MSS eNVM Driver 22102 0at [ T D T S

SmartFusion MSS Watchdog Driver 20107 0.77 | Flash Freeze

SmartFusion M55 UART Driver 23101 107 Cryptography Services

SmartFusion MSS Timer Driver 21100 093 ot

SmartFusicn MSS SPI Driver 21100 080

SmartFusion MSS RTC Driver 20100 095 Challenge Response

SmartFusion MSS Peripheral DMA Driver 20102 0.70 POR Digest Check

SmartFusion MSS IAP Driver 22100 142 1P USB SPT FLASH

SmartFusien M$S I2C Driver 20100 055

SmartFusicn MSS GPIO Driver 20105 057 -

@ Downioad

Figure 1+ Downloading Sample Project from Firmware Catalog

Note: Select latest version of SmartFusion2 MSS System Services driver.
Generate Sample Options window is displayed as shown in Figure 2.

G\ GenerateSample Options lilﬂ—hj

Samples folder:  D:\SF2_Sysservices)| E]

Files wil be generated in:
[0:\5F2_Sysservices\SF2_GML_SysServ_read_version

Show generation report

&) [ et

Figure 2+ Generate Sample Options Window

2. Browse to a location to save System Services Read Version Information SoftConsole Project.
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3. Open Readme file provided in the SF2_GNU_SysSer_read_version project folder. Readme file
gives target hardware information. Refer to "Appendix 3: Readme File" on page 37 for the
Readme file.

Step 2: Creating a Libero SoC Project

This step helps you create a SmartFusion2 System Services design using the Libero tool.

Launching Libero SoC
1. Click Start > Programs > Microsemi Libero SoC v11.3 > Libero SoC v11.3, or click the shortcut
on desktop to open the Libero 11.3 Project Manager.
2. Create a new project using one of the following options:
— Select New on the Start Page tab as shown in Figure 3.
— Click Project > New Project from the Libero SoC menu.

r(-\ Libero = — e s | B [ |

Project  File Edit View Design Tools Help

4

StartPage

m

.,
Recent Projects i lee@\
System-of-Chip
Welcome to Libero SoC — . . .
Libero SoC Ouidkstart Welcome To Microsemi's Libero
Libero SoC Interface Description i SOC V1 1 _3 Software i

Figure 3+ Libero SoC Project Manager
3. Enter the required information for the project and the device in the New Project dialog box, as
shown in Figure 4 on page 7:
— Project Name: Sysservices
= Project Location: Select an appropriate location (for example, D:/SF2_Sysservices)
— ' Preferred HDL Type: Verilog
—/ Family: SmartFusion2
— Die: M2S050T
— Package: 896 FBGA
— Speed: STD
— Die Voltage: 1.2
— Operating Conditions: COM
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4. Select Use Design Tool and SmartFusion2 Microcontroller Subsystem (MSS) in the Design
Templates and Creators section of the New Project window as shown in Figure 4.

r ~
(® New Project @
Project
Name: Sysservices
Location: D:/SF2_Sysservices
Prefered HOL type: @ Verilog () VHDL
Description:
0 Edit Tool Profiles. ..
Device
Die: M25050T -
Package: 896 FBGA -

Core Voltage (V): d-2 * | RampRate:

Operating Conditions:

Range Best Typical Worst

Junction Temperature (C) ’COM >0 25 85

Core Voltage (V) [com - [ 1.280 1.200 f340
[ System Controller Suspend Mode
PLL Supply Voltage {V): 2.5 =
Design Templates and Creators

Use Design Toal
Core Version
Use System Buider 1.0
ion2 Microcontraller 5 tem (1155

Show only latest version

i

Figure 4 - _Libero New Project Dialog Box

5. Click Edit Tool Profiles to display the Tool Profiles window as shown in Figure 5 on page 8.
6. In the Tool Profiles window, verify the following tool settings and click OK:

— Software IDE: SoftConsole

— Synthesis: Synplify Pro ME [-2013.09M-SP1

— Simulation: ModelSim ME 10.2c

Revision 1 7



& Microsemi

Creating a Libero Project for Firmware Catalog Sample Project - Libero SoC and SoftConsole Flow Tutorial for

SmartFusion2

Programming:

FlashPro 11.3

@ Tool Profiles

19 i

4 Tools
Software IDE Software IDE profiles
Synthesi
il Active Name Path
Simulation
Stimulus @ 5 softConsole C:\MicrosemilLibero_v11. 1\SoftConsole\Edlipse \edipse.exe
Programming 3
; C:'Program Files (x86)\IAR Systems'Embedded Workbench
Identify Debugger LAh &, $\common’binilarldePm.exe
i Keil CReilUV4 UV exe

ExportPrcﬁIes...] [ QK. ] ’ Cancel

Figure 5+ Tool Profiles Window
7. Click OK on the New Project window.
SmartDesign window with Sysservices_MSS_0 component is displayed as shown in Figure 6.
Project  File Edit View Design Tools SmartDesign Help
~ "

W= )

Design Flow & X | startpage & X | & Sysservices @ X L ¥
= p—_ F ]

Sysservices = o @' ==HD '-E E.*.-—D-=DD DD lgD @l‘qq @ A \ D
Tool |- i
4 p Create Design L WSEMCBS MSS 0 I

&H Systern Builder 1 i _ B =
Confi MSS = MCCC_CLK_BASE [2C_0_PADS [#12C 0 PADS 1
g C°” '9;’5 Desi 2C_1_PADSH 2C 1 PADS
: reate SmartDesign SA0_PADSHE = m
Create HDL SA_1_PADSE ESO 1 _DADS
24 Create SmartDesign Testbench MMVUART _1_PADSH ;]MMJART FADS |
Create HDL TestBench MMUART_0_FADSEH = ART ADS |
& Vi . . MAC_MI_FABRICEH
View/Configure Firmware Cores USB ULP! PADSE@ == ==n=== EUSE ULE BAOS
4 » Verify Pre-Synthesized Desigh MDDR_PADSEH@-~ - ------ ENDOR_PADS
. Simulate
4 b Create Constraints
= 1O Constraints i
Desig... | Design Hier... I Stimulus Hie... | Catalog I F\|EST q m E
Log 8 X
€ Errors 4, Warnings “Inﬁ:

The Sysi:arvices project w;created. -
Info: PAD pin "Sysservices M55 0:I2C_0_PADS of “Sysservices M55 0° is autcmatically connected to a top-level port. |E|
Tnfo: PRAD pin “Sysserwices _MS5 0:T2C 1_PRDS" of “Sysservices_MS55_0° is automatically connected to a top-lewvel port. bl |
Info: PAD pin "S§Sservices_MS5 0:SPI_0_PRDS" of “Sysservices MS5S_0° is automatically connected to a top-level port.

Info: PRD pin “Sysservices M55 0:5PI 1 PADS" of “Sysservices M55 0 is automatically connected to a top-level port.
Fam: SmartFusion2 | Die: M2S050T |Pkg: 896 FBGA | Verilog
Figure 6 = SmartDesign Window with Sysservices_MSS_0 Component

Revision 1



& Microsemi

Creating a Libero Project for Firmware Catalog Sample Project

8. Double-click Sysservices_MSS_0 to configure the MSS. The MSS is displayed in the
SmartDesign canvas in a new tab, as shown in Figure 7.

| startpage & x | Edsysservices & x| B sysserviees Mss @ x|
BERI M Lo d AARKX E AN\DO
|

4l

m

[

Figure 7+ MSS in the SmartDesign Canvas
The enabled MSS blocks are highlighted in blue. The disabled peripherals are shown in gray.
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9. To disable a peripheral that is not required, right-click the peripheral block and clear the Disable
check box, as shown in Figure 8, or clear the check box in the lower right corner of the peripheral
box. The box turns gray to indicate that the peripheral has been disabled.

Configure

&
@ Disable
»

Delete

Em e EE s s s s EEE s s s s EEEEEEEEEEE- REF'EEE Ccrﬂpcnrzntfc|'1n5tan|:r:|:5]m --------------

SPl 0 Update Instance(s) with Latest Component... L

% Clear User Connections

D'ﬂ QuickConnect... Ctrl+K

Replace Instance Version...

@ MS5_MMUART Help 2

Figure 8 » Disabling a Peripheral Block

10. Disabled peripherals can be enabled by either selecting the check box in the lower right corner of
the peripheral box or by right-clicking the peripheral block or selecting the Enable check box. An
enabled peripheral is shown in Figure 9.

Figure 9.+ Enabling the Peripheral

11. Disable the following peripherals on the MSS canvas:
—  MMUART_1
< SPI_0and SPI_1
— 12C_0Oand 12C_1
- PDMA
— WATCHDOG
— FIC_OandFIC_1
- USB
— Ethernet
- RTC
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— MDDR PADS
- CAN
- GPIO

After disabling the above components, the MSS configuration window is displayed similar to
Figure 10.

B sysservices_Mss @ X | StartPage & X | Esysservices g X |
BEM 2 M S RAAMAE ANDO

| MICROCONTROLLER SUBSYSTEM |

F

|
;LJE |
T

e
'_D ]

T

Figure 10 + Enabled and Disabled MSS Components
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12. Double-click MMUART_0 and configure it as shown in Figure 11.
— Select Main Connection as Fabric for TXD and RXD Full Duplex MSIOs
— Click OK on MMUART_0 Configurator to complete the configuration

(57 MSS MMUART_0 Configurator I r—-,_ | ‘ B [t |
Configuration Connectivity Preview Il
Duplex Mode
Async/Sync Mode
Use Modem Interface [~
Assignment Advanced Options [
MSIO Direction Main Connection Package Pin =i
Full Duplex
RXD i
o our
Half Duplex E.
TXD_RXD INOUT 0 H27 EI [
>
Sync/Async S
CLK INOUT 10 H25 M
Modem FPGA Fabric
RTS ouT Notiised Click on a signal row to see the preview =
4 n.__ A . . | 3
h

Figure 11+ MMUART_0 Configurator Window

13. Double-click MSS_CCC block to configure as shown in Figure 12 on page 13:

— The clock input is by default selected as CLK_BASE, select CLK_BASE frequency as
50 MHz

— Select the check box for Monitor FPGA Fabric PLL Lock (CLK_BASE_PLL_LOCK)
— Select M3_CLK as /50 MHz

— Select APB_0.CLK and APB_1_CLK frequency as M3_CLK/1

—. Leave the rest as default

— Click OK on'MSS Clock Configurator to complete the clock configuration

The above selection configures the MSS CCC to receive the input clock from the fabric CCC. The
lock input of the MSS CCC is configured to be received from the fabric CCC block.
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This completes the configuration of the MSS.

% MSS Clock Conditioning Circuitry Configurator

System Clocks | Advanced Options

Clock Source

EKJASE 50 MHzI

Monitor FPGA Fabric PLL Lock (CLK_BASE_PLL_LOCK}

Cortex-M3 and MSS Main Clock

|M3 ClK 50 MHz 50.000 MHzl
MDDR. Clocks
MDDR CLK =M3_CLK= |2 -

DDR SMC FIC CLK =MDDR_CLK / [1 -
M5 APS_D/1 Sub-busses Clocks
v mBoCKk =m3ak/ 50.000 MHz
¥  apB LK -MICK/ 50,000 MHz
FPGA Fabric Interfacs Clocks

Ecoak =mick/([L -

B 1ak  =msck/ (1 -

MSS_GCe

CLK_BAsE |

Lowest frequenc:

CCC/PLL

& e 4L

Figure 12 »

MSS Clock Conditioning Circuitry Configurator

14. Select File > Save to save Sysservices_MSS: Select the Sysservices tab on the Smart Design
canvas, right-click Sysservices_MSS_0, and select Update Instance(s) with Latest
Component, as shown in'Figure 13.

Configure

a
&
®

Delete

Lock Position for Auto Arrange

& ¥

Replace Component for Instance(s)...

Update Instance(s) with Latest Component...

Clear User Connections

QuickConnect... Ctrl+K

MSS Help »

-@EI2C 0_PADS

2MMUART 1_PADS |

EMMUART_0_PADS
FEUSB_ULP_PADS
#MDDR _PADS

Figure 13 »

Updating the Sysservices_MSS_0
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After successfully updating, the Sysservices_MSS_0 instance displays similar to Figure 14.

Sysservices MSS_0

MCCC_CLK_BASE MMUART_0 FABRICEH
MCCC _CLK BASE PLL LOCK
e

Figure 14 » Updated Sysservices_MSS_0

Instantiating Clock Conditioning Circuitry (CCC) and Chip
Oscillators in Sysservices SmartDesign

The Libero SoC catalog provides IP cores that can be easily dragged and droppéed.into the SmartCanvas
workspace. Many of these IPs are free to use while several require a license agreement.

1. Click on the Catalog tab and drag and drop the Clock Conditioning Circuitry (CCC) and Chip
Oscillators block from the Clock and Management sub-section of the IP Catalog into
Sysservices SmartDesign window as shown in Figure 15.

Catalog @
@& ~ [ simulation Made 5
Mame : Version
» Arithmetic

> Bus Interfaces
4 Clock & Management
Chip Oscillators 1.0.100
Clock Conditioning Circuitry (CCC) 2.0.200
» DSP
» /o
» Macro Library
» Memory & Controllers
> Peripherals
+ Processors

» SCfMTamper

Figure 15+ Catalog Window
2. Double click FCCC_0 to configure it. Figure 16 on page 15 shows the FAB CCC Configurator
window.
— Select Reference Clock as 50 MHz and 25/50 MHz Oscillator from the drop-down list.
— | Select GLO Frequency as 50 MHz.
— Click OK to complete the configuration.
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R.] FAB CCC Configurator

Basic | Advanced PLL Options

Basic-Options
Reference Clock ( )
50.000 MHz cee Frequency

25/50 MHz Oscillator GLO
— |SD—IMH2 50000 |MHz

. J

DL | 100 IMHz I |MHz
[ 6Lz
[0 | [z |
[ as
— | 100 IMHz I l\‘IHz
LOCK

@ Advanced options have been modified, The information displayed in this tab might be inaccurate, please use the advanced tab for the
actual configuration.

h

OK

] [ Cancel

Figure 16

FAB CCC Configurator

3. Double-click the OSC_0 instance to open its Configuration window. Make the following
selections; as shown in Figure 17 on page 16:

Select the check box for On Chip 25/50 MHz RC Oscillator
Select the check box for Drives Fabric CCC(s)

Leave the rest as default

Click OK to complete the configuration
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On-chip 50 MHz RC oscillator drives the input of the fabric CCC block instantiated earlier.

Configuration

|| External Main Crystal Oscillator

Source
Frequency

Drives Fabric CCC(s)

Drives Fabric Logic

Drives Fabric CCC(s)

Drives Fabric Logic

|| On-chip 1 MHz RC Oscillator

Drives Fabric CCC(s)

Drives Fabric Logic

r
7] Chip Oscillators Configurator m
T T T T T T T T T T T T E T T e T T m———— 1
1 |
1 |
1 |
Crystal (32KHz-20MHz) - : MSS_CCC |
1
1 |
20,00 MHz | I
| | reosc_somnz !
1 |
1 |
1 |
) ; 1 |
On-chip 25/50 MHz RC Oscillator 1 H
i :
@ ! 1
1| reosc_imz !
1 |
1 |
i - cce |
1 |
H cce |
1 |
1 |
g KTLOSC ‘ :
H 1
; I
| ser Logic H
1 |
1 |
1 |
1 |
| FPGA Fabric !
[y A A 1
—

Figure 17 » Chip Oscillator Configurator

Connecting Components in Sysservices SmartDesign

There are three methods for connecting components in Sysservices SmartDesign:

The first method is by using the Connection Mode option. To use this method, change the
SmartDesign to connection mode by clicking the Connection Mode button on the SmartDesign
window, as shown in Figure 18 on page 17. The cursor changes from the normal arrow shape to
the connection mode icon shape. To make a connection in this mode, click on the first pin and
drag-drop to the second pin that you want to connect.

The second method:is by selecting the pins to be connected together and selecting Connect from
the context menu. To select multiple pins to be connected together, hold the CTRL key while
selecting the pins. Right-click the input source signal and select Connect to connect all the
signals together. In the same way, select the input source signal, right-click it, and select
Disconnect to disconnect the signals that are already connected.

The third method is by using the Quick Connect option. To use this method, change the
SmartDesign to quick connect mode by clicking on Quick Connect mode on the SmartDesign
window, as shown in Figure 18 on page 17. Quick connect window will be opened. Find the
Instance Pin you want to connect and click to select it. In Pins to Connect, find the pin you wish
to connect, right-click and choose Connect as shown in Figure 19 on page 18.

16
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Project  File Edit  View Design  Tools  SmartDesign  Help

NEHoNe0R @

| ESy'sservices_MSS 5 X | @Sysservices g X ‘

4l

el P ] oo 30 AU B A \ O
=35

L'
Connection Mode  Quick Cu:unneu:t-‘ﬂ'”"fED Arrange
Button Button Instances button

Sysservices_MSS_0

MCCC CLK BASE MMUART 0 FABRICH
MCCC CLK BASE PLL_LOCK
ral

0SC_ 0 FCCC 0
RCOSC_25_50MHZ_CCC_OUT ROOSGC 25_50MHZ_.CCC_IN

Fw

GLO
LOCK

g

m

Figure 18 « Sysservices SmartDesign
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-

G\ QuickConnect "

=)

Instance Pins

[AJI unconnected pins in design

* | Search: ** -

Pins to Connect

Enter 3 widcard search in the form of (Tnstance]. (Pinf

[ rccc 0:GLO

[ Fccc_0:L0CK

B FcCC0RCOSC_25_50MHZ_CCCIN
W 0SC_0:RCOSC_25_50MHZ_CCC_OUT

Sysservices_MSS_0:MCCC_CLK_BASE

A2 Sysservices_M55_:MCCC_CLE_BASE_PLL_LOCK
33 Sysservices M35_:MMUART_0_RXD_F2M

[B Sysservices MSS_0:MMUART_0_TXD_M2F

Right-ohck on pins fo perform connectivity schons.
Driver pins are blue,

Connection

4 FCCCO

IE rco|-— Disconnect

4 05CO
W RCOSC_25_50MHZ_CCC_OUT
4 Sysservices M550
B MCCC_CLK_BASE
B MCCC_CLK_BASE_PLL_LOCK
B MMUART_0_RXD_F2M
B> MMUART_0_TXD_M2F

Close

=

Figure 19 »

Quick Connect Window

18
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Use one of the three options described above and make the following connections:

Connect ROSC_25_50MHZ_CCC_OUT of OSC_0 to ROSC_25_50MHZ_CCC_IN of FCCC_0.
Connect GL0 of FCCC_0 to MCCC_CLK_BASE of Sysservices_MSS_0.

Connect LOCK of FCCC_0 to MCCC_CLK_BASE_PLL_LOCK input of Sysservices_MSS_0.
Right-click the MMUART_0_FABRIC of Sysservices_MSS_0 and select Promote to Top Level.

Click Auto Arrange Instances to arrange the instances and click File > Save. Libero top-level
design is displayed as shown in Figure 20.

S

Sysservices MSS_0
MCCC_CLK_BASE MMUART 0 FABRICE @ —----===== === == mm oo e oo 8 FVMUART_0_FABRIC
MCCC_CLK_BASE PLL_LOCK
gFe,
0sCc 0 FCCC_0
RCOSC_25_50MHZ_CCC_OUT| RCOSC_25_50MHZ_CCC_IN GLO
ga P LOCK

gw

Figure 20 + Sysservices SmartDesign

Configuring and Generating Firmware

1. Click Design > Configure Firmware in Libero SoC to open the DESIGN_FIRMWARE window,
as shown in Figure 21.

Project File Edit View [Design | Tools SmartDesign Help

|_1 [ ”' E ﬂ Ifl"\'lt’?@ Configure Firmware |
- Generate Programming Data
Design Hierarchy -l © g 9
@ Reports

Show: |Components -

Figure 21+ Opening DESGIN_FIRMWARE Window
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2. Clear all drivers except CMSIS, MMUART_0 and System Services as shown in Figure 22.

Note: SoftConsole sample project for System Services driver can also be downloaded from
DESIGN_FIRMWARE window. Right-click SmartFusion2_MSS_System_Services_Driver_0.
Select Read Version Information.

(%Y Libero - D:\SFZ_Sysservices\Libernll.gupdatE\SF2_Sy:_SenrioE_Tutoria]_DF\LiberoPrujecf\SyssEmios\Syssewices.prj—x__

Project  File Edit View Design Tools SmartDesign  Help

NEeH2c@o03

| Reports & X | G sysservices Mss & X | EE Sysservices 8 x| DEsioN_FIRMwARE & X |

Al

—"
Q

Generate I Instance Name Core Type \ersion Compatible Hardware Instance:
i @4 SmartFusion2_CMSIS_0 SmartFusion2_CMSIS ZL1pi Sysservices_MSS f
2 D qg SmartFusion2_MSS_HPDMA _Driver_0 SmartFusion2_MS5_HPDMA_Driver 2.0.101 Sysservices_MSS [l
3 !g SmartFusion2_MSS_MMUART_Driver_0 SmartFusion2_MS5_MMUART_Driver 2.0.101 Sysservices_MSS:MMUART_O
4 D qg SmartFusion2_MSS_NVM_Driver_0 SmartFusion2_MS5_NVM_Driver 2,1.102 « |Sysservices MSS
5] qg SmartFusion2_MSS_System_Services_Driver_0 SmartFusion2_MS5_System_Services_Driver 2.1.100) » |Sysservices_MSS
(3 D !3 SmartFusion2_MSS_Timer _Driver_0 SmartFusion2_MSS_Timer_Driver 2.0.101 Sy sserviceS M8

Fam: SmartFusion2 | Die: M25050T |Pkg: 895 FBGA | Verilog

= = ~—

Figure 22 «+ DESIGN_FIRMWARE Window

3. Select Sysservices tab on the SmartDesign canvas.and click Generate Component as shown
in Figure 23.

) sysservices M35 @ X | B sysservices™ & X | &%) DESIGN_FIRMWARE & X |

@)zt M 2850503 REHIRE A\ O

Generate Component

Sysservices MSS 0

MCCC_CLK_BASE MMUART_O_FABRCE@ —----- @ A EVMVMUART 0 FABRC |
MCCC_CLK_BASE PLL_LOCK
@

0sSC 0 FCCC 0
RCOSC_25_50MHZ_CCC_OUT RCOSC_25_50MHZ_CCC_IN GLO

P as L&'G:P

Figure 23 + Generate Component
After successful generation of all the components, the following message is displayed on the log
window, as shown in Figure 24 on page 21.
Info: 'Sysservices' was generated.
Libero also generates the SoftConsole software project.
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Log

&3 Errors 4, Warnings i Info
v

a2 Open Firmware View to i

oIn:'c: 'Sysservices' was generated.

: Firmware drivers successfully generated.
OIn:'c:: SoftConscle workspace was succeasfully generated.
Info: Read more on how Libero Sol integrates with your software development environment.

Open datasheet for details

[

Figure 24 + Log Window

Step 3: Generating the Program File

1. Double-click I/O Constraints in the Design Flow window as shown'in Figure 25.
window is displayed after completing Synthesize and Compile.

The 1/0 Editor

Design Flow

Sysservices

Tool

v
v

bk

F

»
4

4

»

4

F

F

Create Design
&4 System Builder
&4 Configure MSS
B3 Create SmartDesign
Create HDL
o Create SmartDesign Testbench
Create HDL TestBench
¥ View/Configure Firmware Cores
P Verify Pre-Synthesized Design
. Simulate
Create Constraints
"‘E /O Canstraints
constraint\io\Sysservices.io.pdc
(b Timing Constraints
& synthesis\Sysservices_sde.sdc
Q Floorplan Constraints
Implement Design
S Synthesize
P Verify Post-Synthesis Implementation
. Simulate
% Compile
+| Configure Flash*Freeze
?1,; Place and Route
b Edit Constraints
) Timing Constraints
E Floorplan Constraints
P Verify Post Layout Implementation

L I al P P PR ]

m

Figure 25 « Design Flow Window
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2. Make the pin assignments shown in Table 2. After the pins have been assigned, the 1/O Editor is

displayed as shown in Figure 26.
Table 2 « Port-to-Pin Mapping

Port Name Pin Number
MMUARTO_0_RXD_F2M R29
MMUARTO_0_TXD_M2F R24

*F /O Editor - Sysservices™ sl s s SR - -
Eile Edit VYiew Tools Help

Helo > &+ 5 ¢
Ifo Ec| Commit and Check h

| Port Mame & I Direction I 10 Standard I Pin Number
MMUART 0_R¥D_F2M Input

I Locked I Bank Name I
LVCMOS525 R29

MMUART_0_TXD_ M2F Output LVCHMO0525 m

Figure 26 » 1/0O Editor

3. After updating I/O editor, click Commit and Check.
4. Close the I/O editor.

5. Click Generate Programming Data as shown in Figure 27 to complete place and route, and

generate the programming file.

Project  Rile  Edit Miew  Design. Tools

RES T

Design Hierarchiy

SmartDesign  Help

[ Generate Programming Data l =

Figure 27 » Generate Programming Data
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Step 4: Programming the SmartFusion2 Board Using
FlashPro

1. Connect the FlashPro4 programmer to the J59 connector of SmartFusion2 SoC FPGA
Development Kit.

2. Connect the jumpers on the SmartFusion2 Development Kit board, as described in Table 3. For
more information on jumper locations, refer to "Appendix 1: Jumper Locations" on page 35.

Caution: While making the jumper connections, the power supply SW7 switch on the board
should be in OFF position.

Table 3 + SmartFusion2 SoC FPGA Development Kit Jumper Settings

Jumper Number Settings Notes

J70, J93, J94, J117, J123, J142, J157, J160, 1-2 closed These are the default jumper settings of the
J167, J225, J226, J227 Development Kit. Make sure that these jumpers
12 1-3 closed are set properly.

J23 2-3 closed

3. Connect the power supply to the J18 connector.

4. Switch the power supply switch SW7 to ON position:Refer to."Appendix 2: Board Setup for
Running the Tutorial" on page 36 for information on the board setup for running the tutorial.

5. To program the SmarFusion2 device, double-click Run Programming Action in the Design
Flow window as shown in Figure 28.

Design Flow — @

SPI_Flash_top E 0 @'

Tool

Vv % Compile
+'| Configure Flash*Freeze
Vv 9{; Place and Route

4 W EditGonstraints
+= 1/0 Constraints
G} Timing Constraints
9 Floorplan Constraints
4 7% Verify Post Layout Implementation
+L| Generate Back Annotated Files
. Simulate
(& Verify Timing
o} Verify Power
4 b Edit Design Hardware Configuration
Il Programming Connectivity and Interface
& Programmer Settings
s Device /O States During Programming
4} Configure Security and Programming Options
@ Security Policy Manager
@‘ Bitstream Configuration
@‘ Update eNVM Memory Content
4 4 » Program Design

m

v W‘ Generate Programming Data
i Sy Run PROGRAM Action
- ebug Design
Q Identify Debug Design
€) SmartDebug Design -

Figure 28 + Run Programming Action
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Step 5: Building the Software Application using SoftConsole

1. After successful programming, open the SoftConsole project by double-clicking
Write Application Code under Develop Firmware in Design Flow window as shown in
Figure 29.

Design Flow

SPI_Flash_top 3 Q

Tool o
B simulate
& Verify Timing
El Verify Power
4} Edit Design Hardware Configuration
I*[ Programming Connectivity and Interface
& Programmer Settings
ftss Device I/O States During Programming
4 ¢ Configure Security and Programming Options
@ Security Policy Manager
@‘ Bitstream Configuration
@‘ Update eMVM Memery Content
4 » Program Design
@‘ Generate Programming Data
BE: Run PROGRAM Action
4 » Debug Design
-Q Identify Debug Design
€ SmartDebug Design
4 » Handoff Design for Production
v 4 Export Programming File
+L| Export Pin Report
+L| Export BSBL
+ ExportIBIS Model

{&s<

m

1

Figure 29 « Invoking SoftConsole from the Libero SoC
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The SoftConsole perspective is displayed as shown in Figure 30.

F
SC C/C++ - Welcome to Microsemi SoftConsole IDE v3.4 - Microsemi SoftConsole IDE v3.4

File Edit Source

ke

b v 5] v % v o

Refactor Mavigate Search Project Run

9 s i@ A E

Window Help

#-0O-Q- & -

E

[ Project Explorer &2 =0 Welcome 2

= % 7| Microsemi SoftConsole IDE ¥3.4

=5 Sysservices MSS_CM3_app

5 Sysservices MSS_CM3_hw_platform SoftCensole is a free software development environment

- - enabling the rapid production of C and C++ executables for processors
available for use in Microsemi devices, Creating a project inside SoftConsole

lets you write software that is immediately compiled into a usable binary.

(= Start a Project
To begin your werk, click File > New > C Project
I Give your project a name, and select a teolchain if you are going to
be compiling for a target other than the default choice of the Microsemi Cortex-M3,
Then click Finish.

Add an initial source file with File > New > Source File

Add codeto it, and click the Build All icon,

(=) Existing Code
You can also import an existing source tree using
File > Import...
and click
‘General > File System

[Zl Problems | %) Tasks £3

= Console] =] Pruper‘tieq

- =0

0 iterns

=

! Description Resource Path

Location Type

v A

Figure 30 + SoftConsole Workspace

2. Go to the location where the SoftConsole sample Firmware catalog project is saved, as shown in

Figure 31.
r — F=NFEN
@Ov |, « Local Disk (D) » SF2 Sysservices  SF2_GMNU_SysServ_read_version » ~ | %3 |l| Search SF2 GNU_SysServ_read_version 0 |
i e e G S —— - e = & = e e
Organize = j;,j Open = Burn Mew folder ] @
< At = Marge ’ Date modified Type Size
| Pl Desktop W CMSIS 3/27/2014 4:16 PM File folder
4. Downloads L ﬁ drivers 3/27/2014 416 PM File folder
| 5l Recent Places 1 ,y drivers_config File folder
W hal / File folder
= Libraries || .cproject 3/24/2014 2:26 PM CPROJECT File 44 KB
@ Documents L | .project 3/24/2014 2:26 PM PROJECT File 3 KB
&' Music | main 3/24/2014 2:26 PM C File 9 KB
[E=] Pictures = README 3/24/2014 2:26 PM Text Document 4 KB
El] Subversion |
E Videos -
B main Date modified: 3/24/2014 2:26 PM Date created: 3/27/2014 4:16 PM I
C File Size: 8.64 KB J

Figure 31+ Sample Project main. c File
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3. Copythe main.c file and replace it with the existing main.c file under

Sysservices_MSS_CM3_app project in the SoftConsole workspace. The SoftConsole window

looks as shown in Figure 32.

R— ..

r —— - = = = = M
S8C C/C++ - Sysservices_MSS, app/main.c - Microsemi SoftConsole IDE v3.4 Sy — —u g
File Edit Source Refactor Mavigate Search Project Run  Window Help
m-~-Felm 9 EreE-f-@r |- B0~ S [AET FHrirmera- Y %5 Debug ”
[ Project Explorer 32 = O|(E Welcome [ f¢] maine £3 S0z~ =0
28~ 2, 0 =
15 Sysservices_MSS_CM3_app 54 Main function IEHR -
g';;b Binaries " *
& Ln:!]udes int main() 2 ctdioh
=] E.UQ i B drivers/r
A€l main.c uint8_t serial number[1§]: > u /
< - — - Bl drivers/r
= Sysservices_MS5_CM3_hw_platform uint8_t user_code[4]; ‘= &°c reetit
B Archives uinté_t design_version[2]; il e 9-9
il Includes uind_t device certificare[512]; N gfse‘pm
= CMSIS uintd_t status: i?‘s isplay_¢
= Debug ints t tx_complete; '; display !
I = drivers < gp'.mg'l
ini E . main() :
(& drivers_canfig MS55_5YS5_init (M55_SYS_NO_EVENT_HANDLER) ; || J... S o
isplay_¢
= hal 5
ini @ ° display_t
| [0l Sysservices_hw_platform.h MSS_UART_init (gp_my_uazt, isplay.
MSS_UART 57600_EAUD,
MSS_UART DATA 8 BITS | MSS UART NO_PARITY | M55 _UART ONE STOE BIT):
I /* Display greeting message. */
display_greeting(}:
I !
# Device Serial Number (DSN).
status = MS5S_SYS get serial number (serial numbef);:
< m - g v « [m] r
[L Problems &2 E‘Tasks E Console| = Properties ¥ =0
0 errors, 2 warnings, 0 others ) |
I Description - Resource Psth Loeation  Type
| % Warninas (2 items]
0* Writzble Smartlnsert | 74:81
Il
L

Figure 32 « SoftConsole Workspace - main.c File

Device certificate service is not demonstrated in this tutorial. It will be available in future releases.

— Comment the lines in main.c file which execute the Device Certificate service
Modified main. c is available in "Appendix 4: main.c File" on page 38.
Figure 33 on/page 27 shows the SoftConsole workspace with modified main.c file
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C/C++ - Bys:

Edit Source Refactor MNavigate

p/main.c - Microsemi

Search  Project Run  Window Help |

E v

lib~-Hals 9 s @-&8-F-G~

[ Project Explorer 52

=
8%~

1= Sysservices_MSS_CM3_app

5 Sysservices MSS_CM3_hw_platform

4 Binaries
[l Includes
= Debug
A€] main.c

B Archives

[l Includes

(= CMSIS

= Debug

(= drivers

& drivers_config

= hal

[ Sysservices_hw_platform.h

KRB B0~ ® - HEN 3 R -RCRAE T %5 Debug »
e N =8|z~ ™ —0o
™ -l =
* Device certificate. W .
=/ R e
/*status = MSS_SYS_get_device certificate(device_certificate); £
if (M55_SYS_SUCCESS == status) =1 stdioh
! ol drivers/r
M35_UART polled tx string(gp_my uart, 5 drivers/r
i *) "Dewi $£4 Loy
(const uint8_t*)"Device certificate: y: @c g_greetit

display hex values(device certificate, gizeof(device certificate)):

®° g separa

) s
else display ¢
E display._|

MS5_URRT_polled tx_string(gp_my uart, B_my_t
(const uinté_t+)"Service get device certificate fails :

if (M55_SYS_MEM ACCESS_ERROR == status) display_t
{
M55_UART polled tx string(gp_my uart,
(gonst, uint8_t*) "Error

}
M35_UART polled_tx string(gp_my uart, g_separator);
da {

&7 tx_complete = M55 UART tx complete (gp_my uart): I

&8 } while (0 == tx complete):

69%/

70 i# < |
< m ¥ < [m] Al

[ Problems &2 ¥ Tasltsw B Cnnsde] =] Plopel‘lis]

v =g

| Description

0 errors, 2 warnings, 0 others

| Resource

A Wi

(2 items)

il od

Figure 33 «+ SoftConsole Workspace - Modified
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4. Right-click Sysservices_MSS_CM3_app in Project Explorer window of SoftConsole project
and select Properties as shown in Figure 34.

[ Project Explorer &3 &Y =0
4 |25 Sysservices MSS_CM3 |
s i{;p‘ Binaries E g
» il Includes GoInto
Deb
=4 E_UQ Open in New Window
> ] main.c
4 25 Sysservices_MSS_CM3 2 Copy CirleC
’ E’ Archives Paste Ctrl+V
> [t Includes
. = CMSIS K Delete Delete
: = Debug Move...
= drivers Rename... F2 I
» = drivers_config
. = hal g2 Import.. !
» [n| Sysservices_hw_pla iy Export...
Build Project |
Clean Project
& Refresh F5

Close Project

Close Unrelated Prajects

Exclude frgimrild...

Build Configurations 2
Make Targets 2
Index 2
Convert,To...

Run As 2
Debug As 2
Profile As 2
Teamn 3
Compare With 2

Restore from Lecal History...

Properties Alt+Enter

Figure 34 » Project Explorer Window of SoftConsole Project
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5. In the Properties window, go to Settings under C/C ++ Build and select GNU C linker as
debug-in-microsemi-smartfusion2-esarm.ld as shown in Figure 35. Click Apply and OK.

-
SC Properties for Sysservices_ MSS_CM3_app

[ESTE==)

type filter text

Resource

Builders

C/C++ Build
Build Variables
Discovery Options
Environment

ool Chain Editor

C/C++ General
Project References
Run/Debug Settings

Settings

- * v

-

Configuration: [Debug [ Active]

'] [ Manage Configurations...

& Tool Settings ‘ . Build Steps |

Build Artifact I Binary Parsers | £ Error Parsers

a B GNU C Compiler
(%2 Preprocessor
2 Symbols
(%2 Directories
(#2 Optimization
(%2 Debugging
(#2 Warnings
(#2 Miscellaneous
a B8 GMU C Linker
(#2 General
(2 Libraries
4 5 GNT Assembler
(#2 General
5 Memory map generator
a [53 GMNU Intel Hex File Generator
(#2 General
a [ GMU S-Record Generator
(#2 General
a B GNU Listing Generator
(#2 General

Linker flag sI -T../../Sysservices_MS5_CM3_hw_platform/CMSIS/startup_gec/debug-in-microsemi-smartfusion2-esram.|d I

Generate linker memory map

Other options (-Xlinker [option])

-gc-sections

LS S

Other objects

"${workspace loc:/Sysservices MSS_CM3_hw_platform/Debug/CMSIS/startup_gcc/startup

"${waorkspace_loc/Sysservices_MS5_CM3_hw_platform/Debug/CMSIS/startup_gce/newlib_stubs.o}"

€5 84 #

<

| »

lRa:tﬂre Qefau\rs] l Apply It

@

(

ok || cance |

Figure 35+ Sysservices_MSS_CM3_app Properties Window
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6. Perform a clean build by selecting Project > Clean. Accept the default settings in the Clean
dialog box and click OK, as shown in Figure 36. SoftConsole project must not have any errors.

s Clean )

Clean will discard all build problems and built states. The next time a build cccurs
the projects will be rebuilt from scratch.

@ iClean all prujects:f (") Clean projects selected below

= Sysservices_MS5_CM3_app
[l = Sysservices_MS5_CM3_hw_platform

Start a build immediately
(@ Build the entire workspace

() Build only the selected projects

[ K Cancel

Figure 36 « Settings for a Clean Build

7. Install the USB driver. For serial terminal communication through the FTDI mini-USB cable, install
the FTDI D2XX driver. Download the drivers and the installation guide from
www.microsemi.com/soc/documents/CDM_2.08.24 WHQL_ Certified.zip

8. Connect the host PC to the J24 connector using the USB min-B cable. The USB to UART bridge
drivers are automatically detected. Verify if the detection is made in the device manager, as
shown.in Figure 37 on page 31.
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r
i Device Manager

File Action View Help

o TEHE %S

4 2 wi-onteddhus
& Computer
g Disk drives
o e Display adapters
548 DVDYCD-ROM drives
b &'ﬁ Human Interface Devices
B g JDE ATASATAPT controllers
» 2= Keyboards
B ﬂ Mice and other pointing devices
- Bl Monitors
o WF Metwork adapters
2 75 Ports (COM & LPT)
; T:?' Communications Port (COML)
Y57 ECP Printer Port (LPT1
[ USB Serial Port (COMLO)|
) USE Serial Port (COMT)
5" 1USB Serial Port (COMS)
; % USE Serial Port (COMI)
N Processors
B ﬂ Sound, video and game controllers
o B8 Systenn devices
b ¥ Universal Serial Bus controllers

USE Serial Port (COMI0) Properties

General | Port Sestings [ Driver | Details |

USE Seral Poet (COM0)

L=
Devics ype: Poets (COM & LPT)
Manufacturar: FTDH
Loeatian or USHE Sesa Carvenér O
Devics stalus
Thiz device i working properdy, -

Figure 37 » Device Manager Window

9. Start the PuTTY session. If the PUTTY program is not available in the computer system, any free
serial terminal emulation program such as HyperTerminal or TeraTerm can be used. Refer to the

Configuring Serial Terminal Emulation Programs Tutorial for configuring the HyperTerminal,
TeraTerm, or PuTTY.

The PuTTY settings are as follows:

57,600 baud rate
8 data bits

1 stop bit

No parity

No flow control
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10. Select Debug Configurations from the Run menu of the SoftConsole. The Debug dialog box is
displayed. Double-clicking the Microsemi Cortex-M3 Target displays a window similar to
Figure 38.

SC Debug Configurations

Create, manage, and run configurations

w2 =] i -
= X | = Mame: Sysservices MS5_CM3_app Debug
type filter text = .
[E] Main %5 Debugger| Bl Commands| & Source| &= Common
= Launch Group A
SC Microsemi Core8051s Target Project (optional):

SC Microsemi CoreMP7 Target Sysservices_MS5_CM3_app

SC Microsemi Cortex-M1 Target |
4 SC Microsemi Cortex-M3 Target C/C++ Application:
SC Sysservices MS5_CM3_app Debug Debug\Sysservices_M55_CM3_app Search Project...] ’ Browse... ]

[] Application console

Apply Revert

Filter matched 6 of 9 items

C_?' Debug ] [ Close

=

Figure 38 + Debug Configurations Window

11. Confirm that the following details appear on the Main tab in the Debug window and click Debug:
— Name: Sysservices_ MSS_ CM3_app Debug
— Project: Sysservices_ MSS_CM3_app
— C/C++ Application: Debug\Sysservices_ MSS_MSS_CM3_app

12. Click Yes when prompted for the Confirm Perspective Switch, as shown in Figure 39. This
displays the debug view mode.

SC Confirm Perspective Switch @

@>% Thiskind of launch is associated with the Debug perspective.

. This Debug perspective is designed to support application debugging. It
incerporates views for displaying the debug stack, variables and breakpeoint
managerment.

Do you want to open this perspective now?

[T Remember my decision

Yes | ’ No

Figure 39 » Confirm Perspective Switch
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The SoftConsole Debugger Perspective window is opened, as shown in Figure 40.

r = = —— ———— — -— —— —— —— — il
SC Debug - Sysservices MSS_CM3_app/miin.c - Microsemi SoftConsole IDE v3.4 C=RRC] g
— -
File Edit Source Refactor Mavigate Search Project Run  Window Help
Crd@lm $-0-Qu~ @9~ Hrfrobro- T (3% Debug | 0@ C/c+ 7 |y
% Debug 32 * §1 Oe ‘ | i _%El @ 7 = O)|[td= Variables £2 % Braakpointq bl Registers &Mﬂdu\aﬂ =0
SC Sysservices_MS5_CM3_app Debug [Microsemi Cortex-M3 Target] 5 B | 69 gd“ ®x % =7
&% Embedded GDB (8/2/13 11:41 AM) (Suspended) | e Value o
o Thread [1] (Suspended) Tl
= = serial_number 02000ttt |
= 1 main() d\sf2_sysservices\sysservices\softconsole\sysservices_mss_cm3\sysservices_n bﬂ -
W C\MicrosemilLibero_vi11\SoftConsole\Sourcery-G++\bin\arm-none-eabi-gdb.exe (/2131 || (= usercode O:2000fed
4 [ | 3
<[ [ ] 3
[¢] main.c £2 = O 5= Outline &2 =0
Main function. - lﬂz a \S @ * =7
é . U stdidh
nt main(} %l drivers/mss_sys_services/mss sys_servic
. .
uinté_t serial number([16]: K| ;IB drlversf_mss,uarrfmss,uaft.ra
uintf t user code[4]: B g-greeting msg : :or!st uintg ]
uints_t design_version[2]: . N g:separator: o f"'“ﬁ*tu
uint8_t device_certificate[512]; 'H' display_greeting(void] : void
uint t status; -HE display_hex_values(const uintd_t*, uint3
@ gp_my_uart : mss_uart_instance_t* cons
M55_S5Y5_init (M55_S¥5 NO_EVENT HRNDLER) ; @ main(:int
&% display_greeting(void) : void
MSS_UART_init (gp_my_uart, o8 display_hex_values(const uintd_t*, uint3
MSS_UART_57600_BAUD,
M2E TADT NATA 8 RTTE 1 MI8 TIADT NN DADTTY | MI8 TIADT ANR STAD RTT - L
4 3 [y T | 3
& Console 32 Z.Ta;kq & Prob\amq 0 Executableq n Mamorﬂ o ‘ Eﬂ‘ E-.E & EI@‘ = 2~ rﬁ ~=0
Sysservices_MS5_CM3_app Debug [Microsemi Cortex-M3 Target] C:\Microsemil\Libero_v11.1\SoftConsole\Sourcery-G++\bin\arm-none-eabi~gdb.exe (8/2/1311:41 AM) I

1/SoftConsole/Eclipse//../Sourcer
"C:/Microsemi/Libero_vl

source C:/Microsemi/Libero_
target remote |

ar

—none-eabi-sprite:
0x00000188 in 2? ()

Target reset

-G++/share/gdbifdt /micrdSemi-cértex-m3-target-gdbinit
1/5oftConsole/Eclipse//../Sourcery-G++/Bin/ari none-e@bi -sprite™ flashpro:?cpu=Cortex-M3 "D:/5F2_[7
arm-none-eabi-sprite: Using memory map D:/SF2_ Sysservices/Sysservices/SoftConsolefSydservices MSS CM3/Sysservices M35 CM3 app/Debug/memor

cont

Temporary breakpoint 1, main () at ../main.c:65 Z
< Ul [ 4 - = ’
o° Writable Smartlnsert  65:1

Figure 40 » SoftConsole Debugger Perspective
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13. Run the application by clicking Run > Resume. Information on the SmartFusion2 device and the
design, along with a greeting message is displayed on the PuTTY, as shown in Figure 41.

h

P COM7 - PuTTY ESNEENCE)

Figure 41+ PuTTY Window

14. Terminate execution of the code by choosing-Run > Terminate.

15. Close Debug Perspective by selecting Close Perspective from the Window menu.
16. Close SoftConsole using File = Exit.

17. Close the PuTTY. Click Yes when prompted for closing.

Conclusion

This tutorial describes how to.download the SoftConsole Sample project from the Firmware catalog and
how to create a Libero SoC project. It explains the procedure to generate the programming file and to run
the SoftConsole project on the SmartFusion2 Development Kit. A sample project for implementing
System Services featuresiis created to display the SmartFusion2 device and design information.
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Appendix 1: Jumper Locations

Figure 42 shows the jumper locations in SmartFusion2 Development Kit Board.
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Figure 42 « Jumper Locations

Note:
« Jumpers highlighted in red are set by default.
The location of the jumpers in Figure 42 are searchable.
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Appendix 2: Board Setup for Running the Tutorial

Figure 43 shows the board setup for running the tutorial on the SmartFusion2 Development Kit Board.

Power supply
switch SW7

DC Jack
to connect
12 V adapter

USB Mini - B
connector

FlashPro 4
connector

SWO to reset

q
4. i .
i . Microsemi.

J SF2 DEV KIT

1025 400- a
2 ‘?:)?COO 001}

Figure 43 » SmartFusion2 Development Kit
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Appendix 3: Readme File

This example project demonstrates the use of the SmartFusion2 System Services
functions:

- MSS_SYS get serial number ()

- MSS_SYS_get_user_ code()

- MSS_SYS get design version()

- MSS_SYS get device certificate()

- MSS_SYS check_digest ()

This example project requires MMUARTO to be connected to a host PC. The host PC must
connect to the serial port using a terminal emulator such as HyperTérminal or PuTTY
configured as follows:

- 57600 baud

- 8 data bits

- 1 stop bit

- no parity

- no flow control

The example project will display the following information about the SmartFusion2 device
on which it is executed:

- device serial number

- user code

- design version

- device certificate

- digest status

NOTE: In Release mode(i.e. when the code is executed from eNVMO), Digest Check
service will not work for eNVMO option.

This example project is targeted at a SmartFusion2 design which has MMUARTO enabled and
connected to a‘host PC. The example project is built for a design using a SmartFusion2
MSS APB clock freguency of 83MHz. Trying to execute this example project on a different
design will“result in incorrect baud rate being used by MMUARTO or no output if MMUARTO
is not enabled and connected.

This example project can be used with another design using a different clock
configuration. This can be achieved by overwriting the content of this example project's
"drivers_ config/sys config" folder with the one generated by Libero as part of your
design's creation.

Please note that it is possible to redirect MMUARTO to the J198 RS232 connector on the
SmartFusion2 Development Kit despite J198 being connected to the MMUART1 SmartFusion2
pads. This can be done in your hardware design by selecting to direct the MMUARTO TXD
and RXD signals to the FPGA fabric and then connecting these signals to top level ports
assigned to pin H30 for TXD and pin G29 for RXD.

Silicon revision dependencies
| A A A A A A A A A A A A A A |

This example is built to execute on an M2S050T ES die (M2S050T revision B). You will
need to overwrite this example project's "drivers config/sys config" and "CMSIS" folders
with the one generated by Libero for your hardware design if using a newer silicon
revision.
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The "drivers_config/sys config" folder contains information about your hardware design.
This information is used by the CMSIS to initialize clock frequencies global variables
which are used by the SmartFusion2 drivers to derive baud rates. The CMSIS boot code may
also complete the device's clock configuration depending on silicon version. The "CMSIS"
and "drivers config/sys config" for your design can be found in the "firmware" folder
of your Libero design.

Appendix 4: main.c File

/*******************************************************************************

* (c) Copyright 2012-2013 Microsemi SoC Products Group. All rights reserved.
Retrieve device and design information using System Services.
Please refer to file README.TXT for further details about this example.

SVN S$Revision: 5933 $

SVN $Date: 2013-11-04 15:00:37 +0530 (Mon, 04 Nov 2013) $
/

#include <stdio.h>

#include "drivers/mss_sys_services/mss_sys_services.h"
#include "drivers/mss_uart/mss_uart.h"

L N S I

/*¥=============—===—===—=—=—=—=—=—==—=—==——=—=—=——=—=—=—=—=——=—=——=—=—=—=—=—&Z——=—=—-—=-———=b_=-—-—=-—-—=-—=—======
Messages displayed over the UART.

*/

const uint8_t g greeting msgl] =

"\r\n\r\n\

**********************************************************************\r\n\

*x*kkxkkx %% SmartFusion2 System Services Read Version Example *x**x**xx**\r\n\
**********************************************************************\r\n\
This example project displays information about the device/design\r\n\
retrieved using the SmartFusion2 System Services.\r\n\
It uses the following System Services driver functions:\r\n\

- MSS_SYS get_serial number () \r\n\

- MSS_SYS get user code()\zr\n\

- MSS_SYS get design version ()\r\n\

- MSS_SYS check digest ()\r\n\

Private functioms.
A
static void display greeting(void) ;
statiec woid display hex values
(
const uint8_t * in buffer,
uint32 t byte length

UART selection.
Replace the line below with this one if you want to use UART1 instead of

UARTO :
mss_uart_instance_t * const gp my uart = &g mss_uartl;
*/

mss_uart instance t * const gp my uart = &g mss_uartoO;

Main function.

*/
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int main()

{
uint8_t serial number[16];
uint8 t user code[4];
uint8_ t design version([2];
uint8_t device certificate[512];
uint8_t status;
int8_t tx_complete;

MSS_SYS init (MSS_SYS NO_EVENT HANDLER) ;

MSS_UART_init (gp_my_uart,
MSS_UART_57600_BAUD,
MSS_UART DATA 8 BITS | MSS UART NO PARITY | MSS UART_ONE STOP BIT) ;

/* Display greeting message. */
display greeting() ;

*/

status = MSS SYS get serial number (serial number) ;

if (MSS_SYS_SUCCESS == status)
{
MSS UART polled tx string(gp my uart,
(const uint8 t*)!Device serial number: ");
display hex values(serial number, sizeof(serial number)) ;

}

else

{

MSS_UART_polled tx stringd{gp_my uart,

(const uint8 t*)"Service read device serial number
failed.\r\n") ;

if (MSS_SYS_MEM_ACCESS_ERROR == status)

{
MSS UART polled. tx string(gp_my uart,
(const uint8_t*)"Error - MSS memory access error.");

}

MSS_UART polled tx string(gp_my uart, g_separator);

Y R e
* User code.
*/
status = MSS SYS get user code (user_ code) ;
if (MSS_SYS SUCCESS == status)
{
MSS UART polled tx string(gp my uart,
(const uint8_t*)"User code: ");
display hex values (user_ code, sizeof (user code)) ;
}
else

{

MSS UART polled tx string(gp my uart,
(const uint8_ t*)"Service read user code failed.\r\n");

if (MSS_SYS MEM ACCESS ERROR == status)

{
MSS UART polled tx string(gp my uart,
(const uint8_t*)"Error - MSS memory access error.");
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MSS_UART polled tx string(gp_my uart, g_separator);

Y e T
* Design version.
*/
status = MSS_SYS get design version(design version) ;
if (MSS_SYS_ SUCCESS == status)
{
MSS UART polled tx string(gp my uart,
(const uint8_t*)"Design version: ");
display hex values (design version, sizeof (design version));
}
else

{
MSS UART polled tx string(gp my uart,
(const uint8 t*)"Service get design version failed.\r\n");

if (MSS_SYS MEM ACCESS ERROR == status)

{

MSS UART polled tx string(gp my uart,
(const uint8_ t*)"Error - MSS memory access error.");

}

MSS UART polled tx string(gp my uart, g _separator);

/* __________________________________________________________________________
* Device certificate.
*/
/*status = MSS_SYS get device_ certificate(device certificate);
if (MSS_SYS SUCCESS == status)
{
MSS_UART polled tx string{gp_my uart,
(const uint8 t*)"Device certificate: ");
display hex values (device certificate, sizeof (device certificate));
}
else

{
MSS UART polled tx string(gp_my uart,
(const uint8 t*)"Service get device certificate failed.\r\n");

if (MSS_SYS MEM ACCESS ERROR == status)

{
MSS UART polled tx string(gp_my uart,
(const uint8_t*)"Error - MSS memory access error.");

}

MSS_UART polled tx string(gp_my uart, g_separator);

do {
tx complete = MSS UART tx complete(gp my uart);
} while (0 == tx_complete) ;
*/
e i it
* Check digest.
*/
status = MSS SYS check digest (MSS_SYS DIGEST CHECK FABRIC) ;
if (MSS_SYS SUCCESS == status)

{
MSS UART polled tx string(gp my uart,
(const uint8 t*)"Digest check success.");

}

else

{

uint8_t fabric_digest_check_ failure;
uint8 t envmO_digest check failure;
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uint8 t envml digest check failure;

fabric_digest check failure = status & MSS_SYS DIGEST CHECK FABRIC;
envm0_digest check failure = status & MSS_SYS DIGEST CHECK ENVMO;
envml_digest check failure = status & MSS_SYS DIGEST CHECK ENVMI;

MSS_UART_polled tx string(gp_my uart,

(const uint8_t*)"\r\nDigest check failure:
if (fabric_digest check failure)

{

MSS UART polled tx_string(gp_my uart,
(const uint8_t*)"\r\nFabric digest<{check failed.");

}

if (envmO_digest check failure)
{
MSS UART polled tx_ string(gp_my uart,
(const uint8_t*)"\r\neNVMO digest check failed.");

}

if (envml_ digest check failure)

{

MSS_UART polled_tx_string(gp_my_ uart,
(const uint8_ t*)"\¥\neNVM1l digest check failed.");

}

MSS_UART polled tx string(gp_my uart, g_separator) ;

for(;;)

{

}
}
/*================—===—===—=—==—===—==——=—=—=——=—==——==—&————=—=——=—=—=—=—=——=—=—=—=—===—=—===========

Display greeting message when application is started.

*/

static void display greetding(void)
{

MSS_UART_polled tx string(gp_my uart, g_greeting msg);

Display content of buffer passed as parameter as hex values
*/
static void display hex values
(
const uint8_t * in buffer,
uint32 t byte length

uint8 t display buffer[128];
uint32 t inc;

if (byte_length > 16u)

{
}

MSS_UART polled_tx_string( gp_my uart, (const uint8_t*)"\r\n" );

for(inc = 0; inc < byte_length; ++inc)

{

if((inc > 1lu) &&(0u == (inc % 16u)))

{
}

MSS UART polled tx string( gp my uart, (const uint8 t*)"\r\n" );
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snprintf ((char *)display buffer, sizeof (display buffer), "%02x ",
in buffer[incl);

MSS_UART polled tx_string(gp my uart, display buffer);
}
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Microsemi SoC Products Group backs its products with various support services, including Customer
Service, Customer Technical Support Center, a website, electronic mail, and worldwide sales offices.
This appendix contains information about contacting Microsemi SoC Products Group and using these
support services.

Customer Service

Contact Customer Service for non-technical product support, such as product pricing, product upgrades,
update information, order status, and authorization.

From North America, call 800.262.1060
From the rest of the world, call 650.318.4460
Fax, from anywhere in the world, 408.643.6913

Customer Technical Support Center

Microsemi SoC Products Group staffs its Customer Technical Support Center with highly skilled
engineers who can help answer your hardware, software, and design questions about Microsemi SoC
Products. The Customer Technical Support Center spends a gteat deal of time creating application
notes, answers to common design cycle questions, documentation of known issues, and various FAQs.
So, before you contact us, please visit our online resources. ltis very likely we have already answered
your questions.

Technical Support

Visit the Customer Support website (www.microsemi.com/soc/support/search/default.aspx) for more
information and support. Many answers-available on the searchable web resource include diagrams,
illustrations, and links to other resources on the website.

Website

You can browse a variety of technical and non-technical information on the SoC home page, at
WWW.microsemi.com/soc.

Contacting the Customer Technical Support Center

Highly skilled engineers staff the Technical Support Center. The Technical Support Center can be
contacted by email or through the Microsemi SoC Products Group website.

Email

You can communicate your technical questions to our email address and receive answers back by email,
fax, or phone. Also, if you have design problems, you can email your design files to receive assistance.
We constantly monitor the email account throughout the day. When sending your request to us, please
be sure to include your full name, company name, and your contact information for efficient processing of
your request.

The technical support email address is soc_tech@microsemi.com.
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My Cases

Microsemi SoC Products Group customers may submit and track technical cases online by going to My
Cases.

Outside the U.S.

Customers needing assistance outside the US time zones can either contact technical support via email
(soc_tech@microsemi.com) or contact a local sales office. Sales office listings can be found at
www.microsemi.com/soc/company/contact/default.aspx.

ITAR Technical Support

For technical support on RH and RT FPGAs that are regulated by International Traffic .in Arms
Regulations (ITAR), contact us via soc_tech_itar@microsemi.com. Alternatively, within My Cases, select
Yes in the ITAR drop-down list. For a complete list of ITAR-regulated Microsemi-FPGAs, visit the ITAR
web page.
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Microsemi.

Microsemi Corporate Headquarters

One Enterprise, Aliso Viejo CA 92656 USA
Within the USA: +1 (800) 713-4113
Outside the USA: +1 (949) 380-6100
Sales: +1 (949) 380-6136

Fax: +1 (949) 215-4996

E-mail: sales.support@microsemi.com

Microsemi Corporation (Nasdaq: MSCC) offers a comprehensive portfolio of semiconductor
and system solutions for communications, defense and security, aerospace, and industrial
markets. Products include high-performance and radiation-hardened analog mixed-signal
integrated circuits, FPGAs, SoCs, and ASICs; power management products; timing and
synchronization devices and precise time solutions, setting the world's standard for time; voice
processing devices; RF solutions; discrete components; security technologies and scalable
anti-tamper products; Power-over-Ethernet ICs and midspans; as well as custom design
capabilities and services. Microsemi is headquartered in Aliso Viejo, Calif. and has
approximately 3,400 employees globally. Learn more at www.microsemi.com.

© 2014 Microsemi Corporation. All rights reserved. Microsemi and the Microsemi logo are trademarks of
Microsemi Corporation. All other trademarks and service marks are the property of their respective owners.
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