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Chapter 1
Introduction

Assumptions

Using thistutorial for ModelSim™ is based on the following assumptions:

® You arefamiliar with how to use your operating system, along with its window
management system and graphical interface: OpenWindows, OSF/Moatif, CDE, KDE,
GNOME, or Microsoft Windows XP.

® You have aworking knowledge of the language in which your design and/or test bench
iswritten (such as VHDL, Verilog). Although ModelSim is an excellent application to
use while learning HDL concepts and practices, thistutorial is not intended to support
that goal.

Before you Begin

Preparation for some of the lessons leaves certain details up to you. You will decide the best
way to create directories, copy files, and execute programs within your operating system.
(When you are operating the simulator within ModelSim’s GUI, the interface is consistent for
all platforms.)

Examples show Windows path separators - use separators appropriate for your operating system
when trying the examples.

Example Designs

Model Sim comes with Verilog and VHDL versions of the designs used in these lessons. This
allowsyou to do the tutorial regardless of which license type you have. Though we havetried to
minimize the differences between the Verilog and VHDL versions, we could not do so in all
cases. In cases where the designs differ (e.g., line numbers or syntax), you will find language-
specific instructions. Follow the instructions that are appropriate for the language you use.
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Chapter 2
Conceptual Overview

Introduction

ModelSim is a verification and simulation tool for VHDL, Verilog, SystemV erilog, and mixed-
language designs.

Thislesson provides abrief conceptual overview of the Model Sim simulation environment. Itis
divided into fourtopics, which you will learn more about in subsequent lessons.

® Basic simulation flow — Refer to Chapter 3, Basic Smulation.
® Project flow — Refer to Chapter 4, Projects.
* Multiplelibrary flow — Refer to Chapter 5, Working With Multiple Libraries.

® Debugging tools— Refer to remaining lessons.

Basic Simulation Flow

The following diagram shows the basic steps for ssmulating a design in ModelSim.

Figure 2-1. Basic Simulation Flow - Overview Lab

Create a working library

'

Compile design files

'

Load and Run simulation

'

Debug results

® Creating the Working Library
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Conceptual Overview
Project Flow

In ModelSim, all designs are compiled into alibrary. You typically start a new
simulation in Model Sim by creating aworking library called "work," which isthe
default library name used by the compiler as the default destination for compiled design
units.

Compiling Y our Design

After creating the working library, you compile your design unitsinto it. The ModelSim
library format is compatible across all supported platforms. Y ou can simulate your
design on any platform without having to recompile your design.

Loading the Simulator with Y our Design and Running the Simulation

With the design compiled, you load the simulator with your design by invoking the
simulator on atop-level module (Verilog) or a configuration or entity/architecture pair
(VHDL).

Assuming the design loads successfully, the ssmulation time is set to zero, and you enter
arun command to begin simulation.

Debugging Y our Results

If you don’t get the results you expect, you can use Model Sim'’ s robust debugging
environment to track down the cause of the problem.

Project Flow

A project is acollection mechanism for an HDL design under specification or test. Even though
you don’t have to use projects in Model Sim, they may ease interaction with the tool and are
useful for organizing files and specifying simulation settings.

The following diagram shows the basic steps for simulating a design within aModelSim
project.

10
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Conceptual Overview
Multiple Library Flow

Figure 2-2. Project Flow

Create a project

'

Add files to the project

'

Compile design files

'

Run simulation

'

Debug results

Asyou can see, the flow is similar to the basic ssmulation flow. However, there are two
important differences:

® Youdo not haveto create aworking library in the project flow; it is done for you
automatically.

® Projects are persistent. In other words, they will open every time you invoke ModelSim
unless you specifically close them.

Multiple Library Flow

Model Sim uses libraries in two ways: 1) as alocal working library that contains the compiled
version of your design; 2) asaresource library. The contents of your working library will
change as you update your design and recompile. A resource library istypicaly static and
serves as a parts source for your design. Y ou can create your own resource libraries, or they
may be supplied by another design team or athird party (e.g., asilicon vendor).

Y ou specify which resource libraries will be used when the design is compiled, and there are
rules to specify in which order they are searched. A common example of using both aworking
library and aresource library is one where your gate-level design and test bench are compiled
into the working library, and the design references gate-level models in a separate resource
library.

The diagram below shows the basic steps for simulating with multiple libraries.

ModelSim Tutorial, v10.3a 11



Conceptual Overview
Debugging Tools

Figure 2-3. Multiple Library Flow

Create a working library

'

Compile design files

'

Link to resource libraries

'

Run simulation

v

Debug results

Y ou can aso link to resource libraries from within a project. If you are using a project, you
would replace the first step above with these two steps: create the project and add the test bench
to the project.

Debugging Tools

Model Sim offers numerous tools for debugging and analyzing your design. Several of these
tools are covered in subsequent lessons, including:

Using projects

Working with multiple libraries

Setting breakpoints and stepping through the source code
Viewing waveforms and measuring time

Viewing and initializing memories

Creating stimulus with the Waveform Editor

Automating simulation

12
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Chapter 3
Basic Simulation

Introduction
In this lesson you will go step-by-step through the basic simulation flow:
1. Create the Working Design Library
2. Compile the Design Units
3. Loadthe Design
4. Runthe Simulation

Design Files for this Lesson

The sample design for this lesson is asimple 8-hit, binary up-counter with an associated test
bench. The pathnames are as follows:

Verilog — <install_dir>/examples/tutorials/verilog/basicS mulation/counter.v and tcounter.v
VHDL —<install_dir>/exampleg/tutorials/vhdl/basicS mulation/counter.vhd and tcounter.vhd

This lesson uses the Verilog files counter.v and tcounter.v. If you have aVHDL license, use
counter.vhd and tcounter.vhd instead. Or, if you have a mixed license, feel free to use the
Verilog test bench with the VHDL counter or vice versa.

Related Reading

User's Manual Chapters: Design Libraries, Verilog and SystemVerilog Simulation, and VHDL
Simulation.

Reference Manual commands: vlib, vmap, vlog, vcom, view, and run.

Create the Working Design Library

Before you can simulate a design, you must first create a library and compile the source code
into that library.

1. Create anew directory and copy the design files for thislesson into it.

Start by creating a new directory for this exercise (in case other users will be working
with these lessons).

ModelSim Tutorial, v10.3a 13



Basic Simulation
Create the Working Design Library

3.

Verilog: Copy counter.v and tcounter.v files from
/<install_dir>/examples/tutorial s/verilog/basicS mulation to the new directory.

VHDL: Copy counter.vhd and tcounter.vhd files from
[<ingtall_dir>/examples/tutorial ’'vhdl/basicS mulation to the new directory.

Start Model Sim if necessary.
a Typevsim at aUNIX shell prompt or use the Model Sim icon in Windows.

Upon opening Model Sim for the first time, you will see the Welcome to ModelSim
diaog. Click Close.

b. Select File> Change Directory and change to the directory you created in step 1.
Create the working library.
a Select File> New > Library.

This opens a dialog where you specify physical and logical names for the library
(Figure 3-1). You can create anew library or map to an existing library. We'll be
doing the former.

Figure 3-1. The Create a New Library Dialog

Create a New Library x|

—Creake

" anew library
i~ amap to an existing library

{* anew library and a logical mapping ko it

—Library Mame;

|tm:| rk

—Librarw Physical Mame:

|tm:| rk

Ok | Cancel|

b. Typework inthe Library Namefield (if it isn’'t already entered automatically).
c. Click OK.

Model Sim creates a directory called work and writes a specially-formatted file
named _info into that directory. The _info file must remain in the directory to
distinguish it asaModelSim library. Do not edit the folder contents from your
operating system; all changes should be made from within Model Sim.

14

ModelSim Tutorial, v10.3a



Basic Simulation
Compile the Design Units

Model Sim also adds the library to the Library window (Figure 3-2) and records the
library mapping for future reference in the Model Sim initialization file
(modelsim.ini).

Figure 3-2. work Library Added to the Library Window

e

Mame Type Path ’
+Hl work Library work “.
i} floatfidip Library  $MODEL_TECH/.dd
+{l mtiavm Library SMODEL_TECH/. .=
+{lp mtiovm Library SMODEL_TECH/. .
+- ) mtiupF Library EMODEL_TECH/. . /i
-l sv_std Library  $MODEL_TECH/../s
+l vitslzo00 Library $MODEL _TECH/ .Y,
+-4l iees Library  SMODEL_TECH/..[i#
4} modelsim_iib Library SMODEL_TEcy

I ;@ ibj’_.q_ Library  $MODE
- RA— -

When you pressed OK in step 3c above, the following was printed to the Transcript window:

vlib work
vmap work work

These two lines are the command-line equivalents of the menu selections you made. Many
command-line equivalents will echo their menu-driven functions in this fashion.

Compile the Design Units

With the working library created, you are ready to compile your source files.

Y ou can compile by using the menus and dialogs of the graphic interface, asin the Verilog
example below, or by entering acommand at the Model Sim> prompt.

1. Compile counter.v and tcounter.v.

a. Select Compile > Compile. This opens the Compile Source Files dialog (Figure 3-
3).

If the Compile menu option is not available, you probably have a project open. If so,
close the project by making the Library window active and selecting File > Close
from the menus.

b. Select both counter.v and tcounter.v modules from the Compile Source Files dialog
and click Compile. The files are compiled into the work library.

c. When compileisfinished, click Done.

ModelSim Tutorial, v10.3a 15



Basic Simulation
Compile the Design Units

Figure 3-3. Compile Source Files Dialog

x
Librany: Iwu:urk j

Loak in: I | basicSimulation j - £ B~

= = | -| Date modified | =] Type |-
1 work 10/15/2013 6:56... File folder

|| counter.v 7(31/2013 8:43PM ¥ File

|| tcounter.v 7312013 8:43PM W File
1| | 0

File name: I j Compile I
Fies oftype:  [HDL Files (".v:".vl:"vhd:"vhdl:" vho:" hdl:".vo:* ¥ | Done |

[ Compile selected files tagether Default Options... Edit Source |

2. View the compiled design units.

a. IntheLibrary window, click the’+" icon next to the work library and you will see
two design units (Figure 3-4). You can also see their types (Modules, Entities, etc.)
and the path to the underlying sourcefiles.
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Basic Simulation
Load the Design

Figure 3-4. Verilog Modules Compiled into work Library

BT EEEEEE——

Mame Type Path
= wark, Library wirk,
4/_‘1%_] counter Maodule C: fmodeltech

{[] kest_counter Maodule Z: fmodeltech

i,—ﬂj]_ Floakfixlib Library FMODEL_TECH/ ., [Floakfixlib
i,—ﬂj]_ mce_lib Library $MODEL_TECH/. . fmcZ_lib
+ rikiBe T Libraty FMODEL_TECH/. . [avm
1,—ﬂjl rkiCeem Library $MODEL_TECH).. fovm-2.0.3
1,—ﬂj]_ kP s Library $MODEL_TECH).. Jpa_lib
slmare | Wy SR Tl

Load the Design

1. Loadthetest_counter module into the smulator.

a. IntheLibrary window, click the‘+" sign next to the work library to show the files
contained there.

b. Double-click test_counter to load the design.

Y ou can also load the design by selecting Simulate > Start Simulation in the menu
bar. This opens the Start Simulation dialog. With the Design tab selected, click the
"+’ sign next to the work library to see the counter and test_counter modules. Select
thetest_counter module and click OK (Figure 3-5).
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Basic Simulation
Load the Design

Figure 3-5. Loading Design with Start Simulation Dialog

Start Simulation x|
Design I YHOL ] Yerilog ] Libraries ] S0DF ] Cthers ] ﬂﬂ
¥|Mame Type Path =
— L ok, Libirary otk
/] ounter Module : JTukorialfexamples ftutorialsverilog/basicSin
Module I Tukorialfexamples ftukorialsverilog fbasicSin
+4 Floatfixlib Library $MODEL_TECH], . /Floatfixlib
+ ki Library SMODEL_TECH/ . favm
+ ki Library $MODEL_TECH]. fovm-2.0 o
+ mkiLPF Library $MODEL_TECH]. . Jupf_lib
4 sv_std Library +MODEL_TECH] . Jsv_std
+4 witalzoo0 Library +MODEL_TECH] .. Jwital2000
J | [
~Design Linikis) Resolution————
|t-1|:|1:}: . LESL_counter ’7|default j
—pkimization
™ Enable optimization Cptimization Cptions. .. |

Ok | Cancel |

When the design is loaded, a Structure window opens (Iabeled sim). This window
displays the hierarchical structure of the design as shown in Figure 3-6. Y ou can
navigate within the design hierarchy in the Structure (ssim) window by clicking on
any linewitha’+ (expand) or -’ (contract) icon.

Figure 3-6. The Design Hierarchy

& sim

Instance Design unit

Madule

- dut counter(fast) Module +acc=...
%‘ increment counter(fast) Function +acc=...

o #ALWAYS#3IS  counter(fast) Process

o #IMITIAL#17 kest_rcounter(fast]  Process

o #INITIAL#Z23 kest_rcounter(fast]  Process

o #INITIAL#30 kest_rcounter(fast]  Process
|g #wsim_capacitby i Fareign +acc=,..

ﬁwty‘lﬁﬂ‘.—"*ﬁkwwq;'mimxr .

2. Open the Objects and Processes windows.
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Basic Simulation
Run the Simulation

a. Select View > Objects from the menu bar.
b. Select View > Process.

The Objects window shows the names and current values of data objectsin the
current region selected in the Structure (sim) window (Figure 3-7). Data objects
include signals, nets, registers, constants and variables not declared in a process,
generics, parameters.

The Processes window displays alist of HDL processesin one of four viewing
modes: Active, In Region, Design, and Hierarchical. The Design view modeis
intended for primary navigation of ESL (Electronic System Level) designs where
processes are a foremost consideration. By default, this window displays the active
processes in your simulation (Active view mode).

Figure 3-7. The Object Window and Processes Window
$a objects o L H & X

Register Internal

Register Internal
4 count Internal

Run the Simulation

We'reready to run the simulation. But before we do, we'll open the Wave window and add
signalstoit.

1. Open the Wave window.
a. Enter view wave at the command line.

The Wave window opens in the right side of the Main window. Resize it, if
necessary, so it isvisible.

Y ou can aso use the View > Wave menu selection to open a Wave window. The
Wave window isjust one of several debugging windows available on the View
menu.
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Basic Simulation
Run the Simulation

2. Add signalsto the Wave window.

a. Inthe Structure (sim) window, right-click test_counter to open a popup context
menul.

b. Select Add Wave (Figure 3-8).
All signalsin the design are added to the Wave window.

Figure 3-8. Using the Popup Menu to Add Signals to Wave Window
& =im - Default -

View Dedaration

View Instantiation

P FALE i
& #INITIA .
o FINITIA LPFE kP
& #INITIA

Add Wave
Add Weaye New

Add Wave To k
Add Dataflow Ctrl+D

Add to
ot P et il

|g #vsim_capa

3. Run the simulation.

a. Click the Runicon.

The simulation runsfor 100 ns (the default simulation length) and waves are
drawn in the Wave window.

b. Enter run 500 at the VSIM> prompt in the Transcript window.
The simulation advances another 500 ns for atotal of 600 ns (Figure 3-9).

Figure 3-9. Waves Drawn in Wave Window

fave - Default

Cursor 1

o]
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Basic Simulation
Set Breakpoints and Step through the Source

c. Click the Run -All icon on the Main or Wave window toolbar.

The simulation continues running until you execute a break command or it
hits a statement in your code (ie., a Verilog $stop statement) that halts the
simulation.

d. Click the Break icon | |54 | to stop the simulation.

Set Breakpoints and Step through the Source

Next you will take abrief 100k at one interactive debugging feature of the ModelSim
environment. Y ou will set a breakpoint in the Source window, run the simulation, and then step
through the design under test. Breakpoints can be set only on executable lines, which are
indicated with red line numbers.

1. Open counter.v in the Source window.
a. Select View > Filesto open the Files window.
b. Click the + sign next to the sim filename to see the contents of vaim.wif dataset.

c. Double-click counter.v (or counter.vhd if you are ssmulating the VHDL files) to
open the file in the Source window.

2. Set abreakpoint on line 36 of counter.v (or, line 39 of counter.vhd for VHDL).
a. Scrall to line 36 and click in the Ln# (line number) column next to the line number.

A red dot appears in the line number column at line number 36 (Figure 3-10),
indicating that a breakpoint has been set.

Figure 3-10. Setting Breakpoint in Source Window

-HIC

n& | T+ B How 4]

35 | -

38 Ial'u'.i}rs @ (poszedge clk or posedge reset)

37 if ({reaet)

38 count = #tpd reset_to _count 3'h00;

250 else

40 count <= #tpd clk _to count increment (count): b

41 -
e — ;IZI
| Wave || counter.w | _ﬂ_?'l

3. Disable, enable, and delete the breakpoint.
a. Click the red dot to disable the breakpoint. It will become a gray dot.
b. Click the gray dot again to re-enable the breakpoint. It will become ared dot.
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c. Click thered dot with your right mouse button and select Remove Breakpoint 36.

d. Click intheline number column next to line number 36 again to re-create the
breakpoint.

4. Restart the simulation.

a. Click the Restart icon to rel oad the design elements and reset the simulation

timeto zero.

The Restart dialog that appears gives you options on what to retain during
the restart (Figure 3-11).

Figure 3-11. Setting Restart Functions

x

v List Format

¥ wWave Format
| Breakpoints

¥ Logged Signals
v virtual Definitions
¥ Assertions

v Cover Directives
¥ ATV Format

oK Cancel

b. Click the OK button in the Restart dialog.

c. Click the Run-All icon.

The simulation runs until the breakpoint is hit. When the simulation hits the
breakpoint, it stops running, highlights the line with ablue arrow in the
Source view (Figure 3-12), and issues a Break message in the Transcript window.

Figure 3-12. Blue Arrow Indicates Where Simulation Stopped.

. [Tutorial fexamples ftutorials frerilog basicSimulation fcounter. v (ftest_counter /dut) - Default

Lnz | %) B i | P

35 | =

36 Ial‘-.u'a}fs @ (posedge clk or possdge reaset)

37 if (reset)

38 count = #tpd_reset_to_count E'h00;

39 elae

40 count <= #tpd clk to_count increment{count); P

41 -
1 I FIJ
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When a breakpoint is reached, typically you want to know one or more signal
values. Y ou have severa options for checking values:

® Look at the values shown in the Objects window (Figure 3-13).

Figure 3-13. Values Shown in Objects Window
$4 Objects e L H x|

4 tpd reset to_count  32h00000003 Parameter Internal

4 tpd dk_to_count 32h00000002  Parameter Internal
4, count ghie Packed Array Out

£ dk 1Thi Met In

4 reset 1ho Met In

® Set your mouse pointer over a variable in the Source window and a yellow box
will appear with the variable name and the value of that variable at the time of
the selected cursor in the Wave window (Figure 3-14).

Figure 3-14. Hover Mouse Over Variable to Show Value

B =< tutorislspveriog/basicSimulationfoounter v {frest_counter/dut) - Default -H

Lng | T+ B How 4]

35 F -

a6 ‘ always @ (pozedge clk or posedge reset)

57 if (rdset)

38 COUN rpest pounter/dut/reset|5 RO00Z

a9 else 1 -

40 COMNT——= F oIk _ 0O norement (count) !

41 -
4| | 3

® Highlight asignal, parameter, or variable in the Source window, right-click it,
and select Examine from the pop-up menu to display the variable and its current
value in a Source Examine window (Figure 3-15).

Figure 3-15. Parameter Name and Value in Source Examine Window

x

ftest_counter/dut/#ALWAYS#35/tpd reset to count
3

oK|

® usethe examine command at the VSIM> prompt to output a variable value to
the Transcript window (i.€., examine count)
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5. Try out the step commands.
a. Click the Step Into icon on the Step toolbar. *
This single-steps the debugger. *
Experiment on your own. Set and clear breakpoints and use the Step, Step Over, and
Continue Run commands until you feel comfortable with their operation.
Lesson Wrap-Up

This concludes this lesson. Before continuing we need to end the current simulation.

1. Sdect Smulate> End Simulation.

2. Click Yeswhen prompted to confirm that you wish to quit ssmulating.
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Introduction

In this lesson you will practice creating a project.

At aminimum, projects contain awork library and a session state that is stored in an .mpf file. A
project may also consist of:

®* HDL sourcefilesor referencesto sourcefiles
® other files such as READMESs or other project documentation
® |ocd libraries

* referencesto global libraries

Design Files for this Lesson

The sample design for this lesson is asimple 8-bit, binary up-counter with an associated test
bench. The pathnames are as follows:

Verilog —<install_dir>/examples/tutorial s/verilog/projects/counter.v and tcounter.v
VHDL —<install_dir>/examples/tutorials/'vhdl/projects/counter.vhd and tcounter.vhd

This lesson uses the Verilog files tcounter.v and counter.v. If you have aVHDL license, use
tcounter.vhd and counter.vhd instead.

Related Reading
User's Manual Chapter: Projects.

Create a New Project

1. Create anew directory and copy the design files for thislesson into it.

Start by creating a new directory for this exercise (in case other users will be working
with these lessons).

Verilog: Copy counter.v and tcounter.v files from
/<install _dir>/examples/tutorial s/verilog/projects to the new directory.
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VHDL: Copy counter.vhd and tcounter.vhd files from
/<install_dir>/examples/tutorial s/'vhdl/projects to the new directory.

2. If you just finished the previous lesson, Model Sim should already be running. If not,
start ModelSim.

a. Typevsim at a UNIX shell prompt or use the Model Sim icon in Windows.

b. Select File> Change Directory and change to the directory you created in step 1.
3. Create anew project.

a. Select File> New > Project (Main window) from the menu bar.

This opens the Create Project dialog where you can enter a Project Name, Project
Location (i.e., directory), and Default Library Name (Figure 4-1). Y ou can also
reference library settings from a selected .ini file or copy them directly into the
project. The default library is where compiled design units will reside.

b. Typetest inthe Project Namefield.

c. Click the Browse button for the Project Location field to select a directory where the
project file will be stored.

d. Leavethe Default Library Name set to work.
e. Click OK.

Figure 4-1. Create Project Dialog - Project Lab

Create Projeck El

— Project Mame
|test

— Project Location
|E: /Tutonial/examples/projects Browse. ..

— Default Libram Mame
|wu:|rk

— Copy Settings From

|a’mndelsim.ini Browse...

% Copy Library Mappings © Reference Libran Mappings

Ok | I:ance||

Add Objects to the Project

Once you click OK to accept the new project settings, a blank Project window and the “Add
items to the Project” dialog will appear (Figure 4-2). From the dialog you can create a new
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design file, add an existing file, add a folder for organization purposes, or create a ssmulation
configuration (discussed below).

Figure 4-2. Adding New Items to a Project

Add items to the Projeck #

— Click on the icon to add items of that pe:——

] ]

Create Mew File Add Exizting File
Create Simulation Create Mew Folder

Cloze |

1. Addtwo existing files.
a. Click Add Existing File.

Thisopensthe Add fileto Project dialog (Figure 4-3). Thisdialog lets you browse to
find files, specify the file type, specify afolder to which the file will be added, and
identify whether to leave thefilein its current location or to copy it to the project
directory.

Add file to Project - x|
— File Mame
|n:|:|unter.v tocounter.y Browse. . |
— Addfile az type——— Folder
| detault ]| | [eilog files b
¥ Feference from current location € Copy to project directary
OF. I Cancel I

b. Click the Browse button for the File Name field. This opens the “ Select files to add
to project” dialog and displays the contents of the current directory.

c. Verilog: Select counter.v and tcounter.v and click Open.
VHDL : Select counter.vhd and tcounter.vhd and click Open.
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This closes the “ Select files to add to project” dialog and displays the selected files
inthe “Add file to Project” dialog (Figure 4-3).

. Click OK to add the files to the project.
. Click Closeto dismissthe Add items to the Project dialog.

Y ou should now see two files listed in the Project window (Figure 4-4). Question-
mark iconsin the Status column indicate that the file has not been compiled or that
the source file has changed since the last successful compile. The other columns
identify file type (e.g., Verilog or VHDL), compilation order, and modified date.

Figure 4-4. Newly Added Project Files Display a’'?’ for Status

Mame Status Type Order  |Modified
toounter. v '? Verilog 1 10/15/08 09:58:50 PM
counter.y > verlog 0 10,/15/08 09:53:50 PM

1
J]l Library | ¥ Project I—ﬂi'l

Changing Compile Order (VHDL)

By default Model Sim performs default binding of VHDL designs when you load the design
with vsim. However, you can elect to perform default binding at compile time. (For details,
refer to the section Default Binding in the User’s Manual.) If you elect to do default binding at
compile, then the compile order isimportant. Follow these steps to change compilation order
within a project.

1. Change the compile order.

a. Select Compile > Compile Order.

This opens the Compile Order dialog box.

. Click the Auto Gener ate button.

Model Sim determines the compile order by making multiple passes over thefiles. It
starts compiling from the top; if afilefails to compile due to dependencies, it moves
that file to the bottom and then recompilesit after compiling the rest of thefiles. It
continues in this manner until all files compile successfully or until afile(s) can’'t be
compiled for reasons other than dependency.

Alternatively, you can select afile and use the Move Up and Move Down buttons to
put the filesin the correct order (Figure 4-5).

28
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Figure 4-5. Compile Order Dialog

Compile Drder x|

——iCurrent Order

tcounter,y il

=
counker v

Move up/down buttons ——

[T [

Auko Generate| Ok | Can-:e||

c. Click OK to close the Compile Order dialog.

Compile the Design
1. Compilethefiles.

a. Right-click either counter.v or tcounter.v in the Project window and select Compile
> Compile All from the pop-up menu.

Model Sim compiles both files and changes the symbol in the Status column to a
green check mark. A check mark means the compile succeeded. If compilefails, the
symbol will beared’X’, and you will see an error message in the Transcript
window.

2. View the design units.
a. Click theLibrary tab (Figure 4-6).
b. Click the’+ icon next to the work library.

Y ou should see two compiled design units, their types (modulesin this case), and the
path to the underlying source files.
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Figure 4-6. Library Window with Expanded Library

Type Path
Library C:ftutorials fverilogfprojectsfw
{/]] counter Module C: ftutorials frerilog fprojects foounter v '
{1/]] test_counter Module C: ftutorials fverilogfprojects ftcounter . v 4‘
ﬂm floatfixlib Library  SMODEL_TECH/../floatfixib
+ mtiAwvm Library SMODEL_TECH/. . favm ,
¥ mtCvm Library SMODEL_TECH/.. fovm-2.0 ’
+ mtLIPF Library SMODEL_TECH/. . fupf_lib
l’ﬂ sv_std Library SMODEL_TECH/. . fsw_std
1,4]1 vital2000 Library  $MODEL_TECH/.. vital2000
1,4]1 iees Library  SMODEL_TECH/..fiese r
+ modelsim_lib Library EMODEL_TECH/. . fmodelsim_lib
R . L
Im Library
iy

Load the Design
1. Loadthetest_counter design unit.
a. Double-click the test_counter design unit.

The Structure (sim) window appears as part of the tab group with the Library and
Project windows (Figure 4-7).

Figure 4-7. Structure(sim) window for a Loaded Design

& cim - Default

Design unit type  |Visibility  |Total cowé
B test_counter test_counte... Module
- %dut counter(fast) Module

Bl increment counter(fast) Function

of FALWAYS#,.. counter(fast) Process

o FINITIAL#17 test_counte...Process

o FINITIAL#23 test_counte...Process

o FINITIAL#31 test_counte...Process
|g #Fwsim_capacity # Capacity

M Library -~ | F3

At this point you would typically run the simulation and analyze or debug your
design like you did in the previous lesson. For now, you'll continue working with
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the project. However, first you need to end the simulation that started when you
loaded test_counter.

2. End the smulation.
a  Select Smulate > End Simulation.

b. Click Yes.

Organizing Projects with Folders

If you have alot of filesto add to a project, you may want to organize them in folders. Y ou can
create folders either before or after adding your files. If you create afolder before adding files,
you can specify in which folder you want afile placed at the time you add the file (see Folder
field in Figure 4-3). If you create afolder after adding files, you edit the file properties to move

it to that folder.

Add Folders

As shown previously in Figure 4-2, the Add items to the Project dialog has an option for adding
folders. If you have already closed that dialog, you can use a menu command to add afolder.

1. Addanew folder.
a. Right-click in the Projects window and select Add to Project > Folder.
b. Type Design Filesin the Folder Name field (Figure 4-8).

Figure 4-8. Adding New Folder to Project

Add Folder x|

— Folder Mame

IDesign Filez

— Folder Location

|T|:||:u Lewvel ZI

Ok I Eancell

c. Click OK.
The new Design Filesfolder is displayed in the Project window (Figure 4-9).
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Figure 4-9. A Folder Within a Project

Project - C: ftutorials fverilogfprojectsftest

Mame
counter.y \f Verilog 0 10/15/03 09:58: 50 PM
toounter. v + Verilog 1 10/15/08 09:58:50 PM

[C] Diesign Files Folder

¢
3
\

2. Add asub-folder.
a. Right-click anywherein the Project window and select Add to Project > Folder.
b. TypeHDL inthe Folder Namefield (Figure 4-10).

Figure 4-10. Creating Subfolder

Add Folder x|

— Folder Mame

[HOL

— Folder Locatian

Dezign Files

|Top Lewvel

=

c. Click the Folder Location drop-down arrow and select Design Files.
d. Click OK.

A+’ icon appears next to the Design Files folder in the Project window (Figure 4-
11).

Figure 4-11. A folder with a Sub-folder

Project - C:ftutorials fverilog/projects ftest

Mame Modified

counter.v v Verilog O 10/15/08 09:58:50 PM
toounter. v + verilog 1 10,/15/08 09:58:50 PM

=8 Design Files Folder

] HOL Folder ,
£
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e. Click the’+' icon to seethe HDL sub-folder.

Moving Files to Folders

If you don’t place filesinto afolder when you first add the files to the project, you can move
them into afolder using the properties dialog.

1. Movetcounter.v and counter.v to the HDL folder.
a. Select both counter.v and tcounter.v in the Project window.
b. Right-click either file and select Properties.

This opens the Project Compiler Settings dialog (Figure 4-12), which allows you to
set avariety of options on your design files.

Figure 4-12. Changing File Location via the Project Compiler Settings Dialog

Project Compiler Settings El

General I Verilog & System Verilog ] Coverage ] ﬂﬂ
—General Settings
[T Do Mot Compile  Compile to library: |w|: rk ﬂ
Place in Folder: |[-DL j
—File Properties
Multiple files selected
Ok, | Cancel |

c. Click the Placeln Folder drop-down arrow and select HDL.

d. Click OK.

The selected files are moved into the HDL folder. Click the’+’ icon next to the HDL
folder to see thefiles.

The files are now marked with a’? in the Status column because you moved the
files. The project no longer knows if the previous compilation is till valid.

Simulation Configurations

A Simulation Configuration associates a design unit(s) and its ssmulation options. For example,
let’s say that every time you load tcounter.v you want to set the simulator resolution to
picoseconds (ps) and enable event order hazard checking. Ordinarily, you would have to specify
those options each time you load the design. With a Simulation Configuration, you specify
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options for adesign and then save a*“ configuration” that associates the design and its options.
The configuration is then listed in the Project window and you can double-click it to load
tcounter.v along with its options.

1. Create anew Simulation Configuration.

a. Right-click in the Project window and select Add to Project > Simulation
Configuration from the popup menu.

This opens the Add Simulation Configuration dialog (Figure 4-13). The tabsin this
dialog present several ssmulation options. Y ou may want to explore the tabs to see
what isavailable. Y ou can consult the Model Sim User’s Manual to get a description
of each option.

Figure 4-13. Simulation Configuration Dialog

Add Simulation Configuration x|

Simulation Configuration Mame———  Place in Folder
’7||:|:|unter ’7 |HDL ﬂ Add Folder ...
Dresign I WHOIL ] Werilog ] Libraries ] SDF ] Others ] e
*|Name | Type |Path (=
— il waork: Library C:fqueskasim_5,5d/examples/tukarials, .
{1] counter Module C:fqueskasim_5,5d/examples/tukarials, .
Module C:fguestasim_&,5dfexamples/tutorials. ..
ﬁ kestcounter_opk, .. Optimized. .
+Hk) Flaatfidib Libraty $MODEL_TECH. . [Floatfixlib
+HH mtiavm Library $MODEL_TECH]. . favm 1
L mticvm Library $MODEL_TECH]. . fovm-2.0.3
w4k e Library $MODEL_TECH]. . /pa_lib
+l meiupF Library $MODEL_TECH]. . jupf_lib
w4l sv_std Library $MODEL_TECH. . fsw_skd
i PODELTECH e T
~Design Unitgs] Resolution
|tm:| rk.test_counter ’7|ps ﬂ
—iopkimization
[ Enable optimization Cipkimization COpkions. .. |

Save | Cancel |

b. Typecounter inthe Simulation Configuration Name field.
c. Select HDL from the Place in Folder drop-down.

d. Click the’+ icon next to the work library and select test_counter.
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e. Click the Resolution drop-down and select ps.
f. For Verilog, click the Verilog tab and check Enable hazard checking (-hazar ds).
g. Click Save.

The files tcounter.v and counter.v show question mark iconsin the status column
because they have changed location since they were last compiled and need to be
recompiled.

h. Select one of thefiles, tcounter.v or counter.v.
i. Select Compile> CompileAll.

The Project window now shows a Simulation Configuration named counter in the
HDL folder (Figure 4-14).

Figure 4-14. A Simulation Configuration in the Project window

Project - C: ftutorials fverilogfprojectsftes

:,-[__F| Design Files Folder
=H_] HOL Falder
toounter. v + Verilog i 10/15/08 09:58:50 PM
counter.v .( Verilag i} 10/15/08 09:58:50 PM
M counter Simulation

2. Load the Simulation Configuration.
a. Double-click the counter Simulation Configuration in the Project window.

In the Transcript window of the Main window, the vsim (the Model Sim simulator)
invocation shows the -hazards and -t ps switches (Figure 4-15). These are the
command-line equivalents of the options you specified in the Simulate dial og.

Figure 4-15. Transcript Shows Options for Simulation Configurations

—————

w3im -hazards -t ps -novopt work.test_counter

# voim -hazards -t ps -novopt work.test counter
# Loading work. test_counter

# Loading work.counter

WSIM 14 |

Projeck @ test |Mow: O p
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Lesson Wrap-Up

This concludes this lesson. Before continuing you need to end the current ssmulation and close
the current project.

1. Select Smulate > End Simulation. Click Yes.
2. Inthe Project window, right-click and select Close Proj ect.

If you do not close the project, it will open automatically the next time you start
ModelSim.
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Introduction

In this lesson you will practice working with multiple libraries. Y ou might have multiple
libraries to organize your design, to access | P from athird-party source, or to share common
parts between simulations.

Y ou will start the lesson by creating aresource library that contains the counter design unit.
Next, you will create a project and compile the test bench into it. Finally, you will link to the
library containing the counter and then run the simulation.

Design Files for this Lesson

The sample design for this lesson is asimple 8-hit, binary up-counter with an associated test
bench. The pathnames are as follows:

Verilog —<install_dir>/examples/tutorial s/verilog/libraries/counter.v and tcounter.v
VHDL —<install_dir>/examples/tutorials/vhdl/libraries/counter.vhd and tcounter.vhd

Thislesson usesthe Verilog files tcounter.v and counter.v in the examples. If you haveaVHDL
license, use tcounter.vhd and counter.vhd instead.

Related Reading
User's Manual Chapter: Design Libraries.

Creating the Resource Library

Before creating the resource library, make sure the modelsim.ini in your install directory is
“Read Only.” Thiswill prevent permanent mapping of resource libraries to the master
modelsim.ini file. See Permanently Mapping VHDL Resource Libraries.

1. Create adirectory for the resource library.

Create anew directory called resource_library. Copy counter.v from
<install_dir>/examples/tutorials/verilog/librariesto the new directory.

2. Create adirectory for the test bench.
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Create anew directory called testbench that will hold the test bench and project files.
Copy tcounter.v from <install_dir>/examples/tutorials/verilog/librariesto the new
directory.

Y ou are creating two directories in this lesson to mimic the situation where you receive
aresource library from athird-party. As noted earlier, we will link to the resource
library in the first directory later in the lesson.

3. Start Model Sim and change to the resource_library directory.

If you just finished the previous lesson, Model Sim should already be running. If not,
start ModelSim.

a. Typevsim at aUNIX shell prompt or use the Model Sim icon in Windows.
If the Welcome to Model Sim dialog appears, click Close.

b. Select File> Change Directory and change to the resource_library directory you
created in step 1.

4. Createtheresourcelibrary.
a Select File> New > Library.

b. Typeparts lib inthe Library Name field (Figure 5-1).

Figure 5-1. Creating New Resource Library

Create a New Library x|

—_reate

' anew library
" amap ko an existing library

¥ & new library and a logical mapping to it

—Library Mame:

|p arts_lih

—Library Physical Mame:

|p arts_lib

Ok | Caru:e||

The Library Physical Name field isfilled out automatically.

Once you click OK, ModelSim creates a directory for the library, listsit in the
Library window, and modifies the modelsim.ini file to record this new library for the
future.

5. Compile the counter into the resource library.
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a. Click the Compile icon on the Main window toolbar. @

b. Select the parts lib library from the Library list (Figure 5-2).

Figure 5-2. Compiling into the Resource Library
x|
Library: Iparts_lil:u j

Lok in: I | resource_Jibrary j = i gl EEE

Mame = |v| Date modified |~r| Type |v|
J parts_lib 10/16/2013 6:19... File folder

counter.v 7/31/2013 8:43PM  V File

a | o]
File name: Icnunter.\r j Compile I
Files of type: [HDL Files (“.v:*vi;"vhd:* vhdl:" vho:* hdl:" vo:* ¥ | Done

[~ Compile selected files together Default Options. .. | E dit Source |

c. Double-click counter.v to compileit.
d. Click Done.

Y ou now have aresource library containing a compiled version of the counter
design unit.

6. Change to the testbench directory.

a. Select File > Change Directory and change to the testbench directory you created
instep 2.
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Creating the Project

Now you will create a project that contains tcounter.v, the counter’ s test bench.

1. Createthe project.
a. Select File> New > Project.
b. Type counter inthe Project Namefield.

c. Do not change the Project Location field or the Default Library Name field. (The
default library nameiswork.)

d. Makesure“Copy Library Mappings’ is selected. The default modelsim.ini file will
be used.

e. Click OK.
2. Add the test bench to the project.
a. Click Add Existing Filein the Add items to the Project dialog.

b. Click the Browse button and select tcounter.v in the “ Select files to add to project”
dialog.

c. Click Open.
d. Click OK.
e. Click Close to dismissthe “Add itemsto the Project” dialog.
The tcounter.v fileislisted in the Project window.
3. Compile the test bench.
a. Right-click tcounter.v and select Compile > Compile Selected.

Linking to the Resource Library

To wrap up this part of the lesson, you will link to the parts lib library you created earlier. But
first, try loading the test bench without the link and see what happens.

Model Sim responds differently for Verilog and VHDL in this situation.

Verilog
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Load the Verilog Test Bench
1. Load aVerilog design with amissing resource library.

a. IntheLibrary window, click the’+' icon next to the work library and double-click
test_counter.

The Transcript reports an error (Figure 5-3). When you see a message that contains
text like "Error: (vsim-3033)", you can view more detail by using the verror
command.

Figure 5-3. Verilog Simulation Error Reported in Transcript

ModelSim = wsim work, test counter
# Loading work. test_counter

Error: {vsim-3033) C:/tutorials/testbench/tcounterw({15): Instantiation of ‘counter’ failed, The design unit was not ﬁ:uun?

I
#
#

Region: ftest_counter
Searched libraries;
C:\utorialstestbenchywork
Error loading design

RN

ModelSim = |

Praoject : counter |<Nu Design Loaded = |

b. Typeverror 3033 at the Model Sim> prompt.

The expanded error message tells you that a design unit could not be found for
instantiation. It also tells you that the original error message should list which
libraries Model Sim searched. In this case, the original message says ModelSim
searched only work.

c. Typequit -sim to quit the simulation.

The process for linking to aresource library differs between Verilog and VHDL. If you are
using Verilog, follow the stepsin Linking to aResource Library. If you are using VHDL, follow
the steps in Permanently Mapping VHDL Resource Libraries one page later.

VHDL

Load the VHDL Test Bench
1. Loadthe VHDL test bench with amissing resource library.

a. IntheLibrary window, click the’+' icon next to the work library and double-click
test_counter.

The Main window Transcript reports awarning (Figure 5-4). When you see a
message that contains text like "Warning: (vsim-3473)", you can view more detail
by using the verror command.
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Figure 5-4. VHDL Simulation Warning Reported in Main Window

Questasim: vsim -voptargs="+acc” test_counter
# vsim ~voptargs=\"+acc\” test_counter

# ** Note: (vsim-3312) Design is being optimized. .. '
# == \Warning: [1] C:ftutorials/testbench/tcounter. vhd(31): (vopt-3473) Component instance “dut : counter” is not bound,

# Loading std.standard

# Loading work. test_counter [only) #1

# == Warning: (vsim-3473) Compaonent instance "dut : counter” is not bound.

# Time: O ns Iteration: O Region: ftest_counter File; C:ftutarials/testbenchftcounter, vhd #

V5IM 7=

Project ; counter |Nuw: Ons Delta: 0 |sjm:,|’test_munter

b. Typeverror 3473 at the VSIM> prompt.

The expanded error message tells you that a component ('dut’ in this case) has not
been explicitly bound and no default binding can be found.

c. Typequit -sim to quit the simulation.

Linking to a Resource Library

Linking to aresource library requires that you specify a"search library" when you invoke the
simulator.

1. Specify asearch library during simulation.

a. Click the Simulate icon on the Main window toolbar. %

b. Click the’+ icon next to the work library and select test_counter.
c. Click the Libraries tab.

d. Click the Add button next to the Search Librariesfield and browseto parts_libin the
resource_library directory you created earlier in the lesson.

e. Click OK.

The dialog should have parts lib listed in the Search Librariesfield (Figure 5-5).
f. Click OK.

The design loads without errors.
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Start simulation

Design | VHDL | Verlog Lihraries] SDF | Others | e

—  Search Librariez [ L ]

. /modeltech/eramplesdresource_library/partz_lib Add
kodify..

Delete

— Search Libraries First [ -Lf ]

Add
hdodify. .

PEE | EEE

Delete

Ok, I Cancel I

Permanently Mapping VHDL Resource
Libraries

If you reference particular VHDL resource librariesin every VHDL project or simulation, you
may want to permanently map the libraries. Doing this requires that you edit the master
modelsim.ini filein the installation directory. Though you won’t actually practiceit in this
tutorial, here are the steps for editing thefile:

1

L ocate the modelsim.ini file in the Model Sim installation directory
(<install_dir>/modeltech/modelsim.ini).

IMPORTANT - Make a backup copy of thefile.

Change the file attributes of modelsim.ini so it is no longer "read-only."

Open the file and enter your library mappings in the [Library] section. For example:
parts_lib = C:/libraries/parts_lib

Save thefile.

Change the file attributes so the file is "read-only" again.
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Lesson Wrap-Up

This concludes this lesson. Before continuing we need to end the current ssmulation and close
the project.

1. Select Smulate > End Simulation. Click Yes.
2. Select the Project window to make it active.
3. Sdect File> Close. Click OK.
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Chapter 6
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Introduction

The Wave window allows you to view the results of your ssmulation as HDL waveforms and
their values. The Wave window is divided into a number of panes (Figure 6-1). Y ou can resize
the pathnames pane, the values pane, and the waveform pane by clicking and dragging the bar
between any two panes.

Figure 6-1. Panes of the Wave Window
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Related Reading
User’'s Manual sections: Wave Window and Recording Simulation Results With Datasets
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Loading a Design

For the examples in thislesson, we will use the design ssimulated in Basic Simulation.

1. If youjust finished the previous lesson, Model Sim should already be running. If not,
start ModelSim.

a Typevsim at aUNIX shell prompt or use the Model Sim icon in Windows.
If the Welcome to Model Sim dialog appears, click Close.
2. Load the design.

a. Select File> Change Directory and open the directory you created in the “Basic
Simulation” lesson.

The work library should already exist.
b. Click the’+ icon next to the work library and double-click test_counter.

Model Sim loads the design and opens a Structure (sim) window.

Add Objects to the Wave Window

Model Sim offers several methods for adding objects to the Wave window. In this exercise, you
will try different methods.

1. Add objects from the Objects window.
a. Open an Objects window by selecting View > Objects.

b. Select anitem in the Objects window, right-click, and then select Add to > Wave >
Signalsin Region.

Model Sim opens a Wave window and displays signalsin the region.

c. Placethe cursor over an object and click the middle mouse button to open a context
menu. Then click Add Wave to place the object in the Wave window.

d. Select agroup of objects then click the middle mouse button to open the context
menu and click Add Wave.

2. Undock the Wave window.

By default Model Sim opens the Wave window in the right side of the Main window.
Y ou can change the default viathe Preferences dialog (Tools > Edit Preferences).
Refer to the Simulator GUI Preferences section in the Model Sim Graphical User
Interface (GUI) Reference Manual for more information.

a. Click the undock icon on the Wave window. ﬂ
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The Wave window becomes a standal one, un-docked window. Resize the window as
needed.

3. Add objects using drag-and-drop.

Y ou can drag an object to the Wave window from many other windows (e.g., Structure,
Objects, and Locals).

a. Inthe Wave window, select Edit > Select All and then Edit > Delete.
b. Drag aninstance from the Structure (sim) window to the Wave window.
Model Sim adds the objects for that instance to the Wave window.
c. Dragasignal from the Objects window to the Wave window.
d. Inthe Wave window, select Edit > Select All and then Edit > Delete.
4. Add objects using the add wave command.

a. Typethefollowing at the VSIM> prompt.
add wave *

ModelSim adds all objects from the current region.

b. Run the simulation for 500 ns so you can see waveforms.

Zooming the Waveform Display
There are numerous methods for zooming the Waveform display.

1. Zoom the display using various techniques.

a Click the Zoom Mode icon on the Wave window toolbar. | "Gy

b. Inthewaveform display, click and drag down and to theright.

Y ou should see blue vertical lines and numbers defining an areato zoom in
(Figure 6-2).
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Figure 6-2. Zooming in with the Mouse Pointer
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c. Select View > Zoom > Zoom L ast.

The waveform display restores the previous display range.

d. Click the Zoom Inicon afew times. Cﬂ

e. Inthewaveform display, click and drag up and to the right.
Y ou should see a blue line and numbers defining an area to zoom out.

f. Sdect View > Zoom > Zoom Full.

Using Cursors in the Wave Window

Cursors mark simulation time in the Wave window. When Model Sim first draws the Wave
window, it places one cursor at time zero. Clicking in the cursor timeline brings the cursor to the
mouse location.

Y ou can also:

® add additional cursors;
®* name, lock, and delete cursors;
® usecursorsto measuretimeintervas;, and

® usecursorsto find transitions.

First, dock the Wave window in the Main window by clicking the dock icon. ¥

Working with a Single Cursor

1. Position the cursor by clicking in the cursor timeline then dragging.
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a. Click the Select Mode icon on the Wave window toolbar. | ®

b. Click anywherein the cursor timeline.

The cursor snaps to the time where you clicked (Figure 6-3).

Figure 6-3. Working with a Single Cursor in the Wave Window

m Wave - Default
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c. Drag the cursor and observe the value pane.

The signal values change as you move the cursor. Thisis perhaps the easiest way to
examine the value of asignal at a particular time.

d. Inthewaveform pane, position the mouse pointer over the cursor line. When the
pointer changes to atwo headed arrow (Figure 6-3), click and hold the left mouse
button to select the cursor. Drag the cursor to the right of atransition.

The cursor "snaps" to the nearest transition to the left when you rel ease the mouse
button. Cursors "snap" to awaveform edge when you drag a cursor to within ten
pixels of an edge. Y ou can set the snap distance in the Window Preferences dialog
(select Tools > Window Preferences).

e. Inthe cursor timeline pane, select the yellow timeline indicator box then drag the
cursor to the right of atransition (Figure 6-3).

The cursor does not snap to a transition when you drag in the timeline pane.
2. Rename the cursor.
a. Right-click "Cursor 1" in the cursor pane, then select and del ete the text.
b. TypeA and press Enter.

The cursor name changesto "A" (Figure 6-4).
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Figure 6-4. Renaming a Cursor

) 322 ns
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3. Jump the cursor to the next or previous transition.

Click signal count in the pathname pane.

Click the Find Next Transition icon on the Wave window toolbar. | =

The cursor jumps to the next transition on the selected signal.

Click the Find Previous Transition icon on the Wave window toolbar. | %

The cursor jumps to the previous transition on the selected signal.

Working with Multiple Cursors

1. Add asecond cursor.

a
b.

C.

Jtest_counter)clk 0 ;l

+
Click the Insert Cursor icon on the Wave window tool bar. Q
Right-click the name of the new cursor and del ete the text.
Type B and press Enter.

Drag cursor B and watch the interval measurement change dynamically (Figure 6-5).

Figure 6-5. Interval Measurement Between Two Cursors

B 129ns

W] « 3 (1] ol
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2. Lock cursor B.

a. Right-click the yellow time indicator box associated with cursor B (at 56 ns).
b. Select Lock B from the popup menu.

The cursor color changesto red and you can no longer drag the cursor (Figure 6-6).

Figure 6-6. A Locked Cursor in the Wave Window

B 129ns

3. Delete cursor B.
a. Right-click cursor B (the red box at 56 ns) and select Delete B.

Lesson Wrap-Up

This concludes this lesson. Before continuing we need to end the current simulation.

1. Select Smulate> End Simulation. Click Yes.
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Chapter 7
Viewing And Initializing Memories

Introduction

In this lesson you will learn how to view and initialize memories. Model Sim defines and lists
any of the following as memories:

®* reg, wire, and std_logic arrays
® Integer arrays
® Single dimensional arrays of VHDL enumerated types other than std_logic

Design Files for this Lesson

The installation comes with Verilog and VHDL versions of the example design located in the
following directories:

Verilog —<install_dir>/examples/tutorials/verilog/memory
VHDL —<install_dir>/examples/tutorials/'vhdl/memory

This lesson uses the Verilog version for the exercises. If you have aVHDL license, use the
VHDL version instead.

Related Reading
User's Manual Section: Memory List Window.

Reference Manual commands. mem display, mem load, mem save, and radix.

Compile and Load the Design
1. Create anew directory and copy thetutorial filesinto it.

Start by creating a new directory for this exercise (in case other users will be working
with these lessons). Create the directory and copy all files from
<install_dir>/examples/tutorials/verilog/memory to the new directory.

If you have aVHDL license, copy thefilesin
<install_dir>/examples/tutorial s/vhdl/memory instead.

2. Start Model Sim and change to the exercise directory.
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If you just finished the previous lesson, Model Sim should already be running. If not,
start ModelSim.

a. Typevsim at a UNIX shell prompt or use the Model Sim icon in Windows.
If the Welcome to Model Sim dialog appears, click Close.
b. Select File> Change Directory and change to the directory you created in step 1.
3. Create the working library and compile the design.
a Typevlib work at the Model Sim> prompt.

b. Verilog:
Typevlog *.v at the Model Sim> prompt to compile all verilog filesin the design.

VHDL:
Typevcom -93 sp_syn_ram.vhd dp_syn_ram.vhd ram_tb.vhd at the Model Sim>
prompt.

4. Load the design.

a. OntheLibrary tab of the Main window Workspace, click the"+" icon next to the
work library.

b. Double-click theram tb design unit to load the design.

View a Memory and its Contents

The Memory List window lists all memory instances in the design, showing for each instance
the range, depth, and width. Double-clicking an instance opens a window displaying the
memory data.

1. Openthe Memory List window and view the data of a memory instance
a. If the Memory List window is not already open, select View > Memory List.

A Memory List window is shown in Figure 7-1.

Figure 7-1. The Memory List Window

i Memory Lisk

TIInstanu:e |Range |Depth |'-.-'-.-'i|:|th | |
w} fram_tb/spraml/mem  [0:4095] 4095 g
w} fram_tb/spramz/mem  [0:2047] 2045 17
w} fram_tb/spram3/mem  [0:85535] 65536 32

1,—-‘ fram_tb/spram4/mem  [0:3] 4 -
w} fram_tb/dpraml/mem  [0:15] 16 g
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b. Double-click the /ram_th/spraml/mem instance in the memory list to view its
contents.

A Memory Data window opens displaying the contents of spraml. The first column
(blue hex characters) lists the addresses, and the remaining columns show the data
values.

If you are using the Verilog example design, the datais all X (Figure 7-2) because
you have not yet simulated the design.

Figure 7-2. Verilog Memory Data Window

=2 Memory Data - fram_tbspramlfmerm - Defaulk

OOO00000 |xx =X XX XX X XX XM XX MM MM XX XM MM XX XM XX :I
OOO000L0 |xx =X XX XX X HNX¥ XM XN MM MM XX XM MM XX XM XX
OO000020 |=x =¥ XX XX XX XX XX XX XX XM XX XM MM XX XN XX
OO000030 |=x =X XX XX XX XX XX XX XX XN XX XM MM XX XM XX
OOO000A0 |xx = XE XX MM MM XM MM MM WM XXM XM MM NN MM XX
OOOD0050 |xx = XM XM MM MM XM MM MM WM XM XM MM XX XM XX
OOODO00E0 |dx = M MM MM MM 2000 M0 MM MM MM MM MM MM MM MM
OOODOO70 |Hx M M MM MM MM MM MM MM MM MM MM MM MM MM MM
OOO000E0 |=x =X XX XX XX XX XM XX MX MM XX XM MM XX XM XX
OOO00090 |xx =X XX XX X XX XM XX MM MM XX XM MM XN XM XX
000000al =X =X XX XX XX XX XX XN MX MM M XM MM XX XM XX

4] A Kl 2| |
B Memary List Iﬁ Mermary ... spramil mem | ﬂ_?—l

If you are using the VHDL example design, the datais all zeros (Figure 7-3).

Figure 7-3. VHDL Memory Data Window

i=2 Memaory Data - fram_tbfspramlmem

oooooaod {00 o0 0o 00 00 00 00 00 00 o0 0o 0o 00 o0 oo a0 ﬂ
oooooold {00 o0 oo 0o 00 00 00 00 00 o0 0o 0o 00 o0 oo a0
ooooooz=a {00 o0 0o 00 00 o0 00 00 00 o0 0o 0o 00 o0 oo a0
QooQoo3d (00 00 00 00 00 00 00 00 00 00 00 00 OO0 00 OO 0o
oooooo4a 00 oo oo 00 00 00 00 00 00 o0 0o 00 00 00 oo 0o
oooooasa {00 oo 0o 0o 00 00 00 00 00 o0 0o 00 00 o0 oo 0o
oooooaged {00 00 0o 00 00 00 00 00 00 o0 0o 0o 00 o0 oo a0
oooooaya {00 oo oo 0o 00 o0 00 00 00 o0 0o 0o 00 o0 oo 0o

DR 21|

c. Double-click the instance /ram_tb/spram2/memin the Memory List window. This
opens a second Memory Datawindow that contains the addresses and data for the
spram2 instance. For each memory instance that you click in the Memory List
window, a new Memory Data window opens.

2. Simulate the design.

a Click therun -all icon in the Main window.
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A Source window opens showing the source code for the ram tb file at the point
where the simulation stopped.

VHDL:

In the Transcript window, you will see NUMERIC_STD warnings that can be ignored
and an assertion failure that is functioning to stop the simulation. The simulation itself

has not failed.

a. Click the Memory ...spraml/mem tab to bring that Memory data window to the
foreground. The Verilog data fields are shown in Figure 7-4.

Figure 7-4. Verilog Data After Running Simulation

== Memory Data - fram_tb/spram1/mem

00000000 (00101000
00000008 (00110000
00000010 (00111000
00000018 (01000000
00000020 (01001000
00000028 (01010000
00000030 (01011000
00000038 (01100000
00000040 (01101000
00000048 (01110000

é Akl |

00101001
00110001
00111001
01000001
01001001
01010001
01011001
01100001
01101001
01110001

00101010
00110010
00111010
01000010
01001010
01010010
01011010
01100010
01101010
01110010

00101011
00110011
00111011
01000011
01001011
01010011
01011011
01100011
01101011
01110011

00101140
00110100
00111100
01000100
01001100
01010100
01011100
01100100
01101100
011101400

The VHDL data fields are show in Figure 7-5.

Figure 7-5. VHDL Data After Running Simulation

=== Memory Data - fram_th/spram 1/mem

00000000 40 41 2 43 44 45 da 47 il
00000008 43 49 50 51 2 53 54 55
00000010 5a 57 58 59 [} 6l 2 683
00000018 ad &5 a& a7 35} [ 70 T1
00000020 T2 73 T4 T5 Ta 77 T8 T4
00000028 &0 i B2 83 g4 B85 ga 87
00000030 fafa] 3] a0 91 92 93 94 a5
00000038 94 a7 3] 99 100 101 102 103
é 4] I -|

3. Change the address radix and the number of words per line for instance

/ram_tb/spraml/mem.

a. Right-click anywhere in the spraml1 Memory Data window and select Properties.

b. The Properties dialog box opens (Figure 7-6).
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Figure 7-6. Changing the Address Radix

Properties |
— Address Radix— Data Radix—
" Hexadecimal ™ Symbuolic
* Decimal " Binary
" Octal
i~ Decimal
" Unsigned
¥ Hexadecimal
—Line Wrap
" Fit in Window
" waords per Line |1
K | Zancel |

c. For the Address Radix, select Decimal. This changes the radix for the addresses
only.

d. Select Words per lineand type 1 in thefield.
e. Click OK.

Y ou can see the Verilog results of the settingsin Figure 7-7 and the VHDL resultsin
Figure 7-8. If the figure doesn’t match what you have in your Model Sim session, check
to make sure you set the Address Radix rather than the Data Radix. Data Radix should
still be set to Symbolic, the default.

Figure 7-7. New Address Radix and Line Length (Verilog

=22 Memory Data - fram_th/spram1/mem

00101000 il
00101001
00101010
00101011
00101140
00101101
00101110
00101111
00110000
00110001

[a s

L]

e = T I R L o I

oo

-
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Figure 7-8. New Address Radix and Line Length (VHDL)

=22 Memory Data - fram_th/spram1/mem

1] 40 ;I
1 41 P
2 42
3 43
4 44
5 45
[ da
7 47
é Kl I -|

Navigate Within the Memory

Y ou can navigate to specific memory address locations, or to |ocations containing particular
data patterns. First, you will go to a specific address.

1. Use Goto to find a specific address.
a. Right-click anywhere in address column and select Goto (Figure 7-9).
The Goto dialog box opens in the data pane.

Figure 7-9. Goto Dialog

x
Goto Addreszs
|7|3EI

b. Type 30in the Goto Addressfield.
c. Click OK.
The requested address appears in the top line of the window.
2. Edit the address location directly.
a. Toquickly moveto aparticular address, do the following:
i. Double click address 38 in the address column.

li. Enter address 100 (Figure 7-10).
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Figure 7-10. Editing the Address Directly

=2 Memory Data - fram_tbfspram1fmem ———————— 3

ENERO1I000110
31 |01000111
32 (010010040
33 |01001001
34 (010010140
35 (01001011
38 (01001104
37 |01001101
100 01001110
29 |01001111

1 inI

iii. Pressthe Enter or Return key on your keyboard.

k

The pane jumps to address 100.
3. Now, let’sfind a particular data entry.
a. Right-click anywhere in the data column and select Find.
The Find in dialog box opens (Figure 7-11).

Figure 7-11. Searching for a Specific Data Value

Find in /ram_tb/spraml /mem il

| FindData Find Hext |
Pattern: (11111010
' glob (E.g. 1234, 101 011, *057, 'hfa3g) | _Feplace

.
=R Replace Al

Replace with: |

[ Find backwards Close

b. Verilog: Type 11111010 in the Find data: field and click Find Next.
VHDL: Type 250 in the Find data: field and click Find Next.

The data scrolls to the first occurrence of that address. Click Find Next afew more
times to search through the list.

c. Click Close to close the dialog box.

Export Memory Data to a File

Y ou can save memory datato afile that can be loaded at some later point in simulation.
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1. Export amemory pattern from the /ram_tb/spraml/meminstance to afile.

a. Make sure/ram_th/spraml/mem s open and selected.

b. Select File> Export > Memory Data to bring up the Export Memory dialog box

(Figure 7-12).

Figure 7-12. Export Memory Dialog

Export Memory x|
—Instance Mame
Irar_tbjsprami fmem
— #Address Range
= al
" aAddresses {in decimal)
Start |0 End |4095
File Farmat
£ Yerilog Hex [ Mo addresses
" verilog Binary [T Compress
% MTI
—Address Radix —Data Radix—
" Hexadecimal " Symbuolic
% Decimal % Binary
™ octal
" Decimal
" Unsigred
" Hexadecimal
—Line YWrap
" Fit in Mindiw
% words per Line I]_
File Save
Filename data_mem.menl Browse. ..
[8]4 | Cancel |

For the Address Radix, select Decimal.
For the Data Radix, select Binary.

e o0

e. For the Words per Line, set to 1.

f. Typedata mem.mem into the Filename field.

g. Click OK.
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Y ou can view the exported file in any editor.

Memory pattern files can be exported as relocatable files, smply by leaving out the
address information. Rel ocatable memory files can be loaded anywhere in a memory
because no addresses are specified.

2. Export arelocatable memory pattern file from the /ram_tb/spram2/mem instance.

a
b.

C.

Select the Memory Data window for the /ram_tb/spram2/mem instance.
Right-click on the memory contents to open a popup menu and select Properties.

In the Properties dialog, set the Address Radix to Decimal; the Data Radix to
Binary; and the Line Wrap to 1 Words per Line. Click OK to accept the changes
and close the dialog.

Select File> Export > Memory Data to bring up the Export Memory dialog box.
For the Address Range, specify a Start address of 0 and End address of 250.

For the File Format, select MTI and No addr esses to create a memory pattern that
you can use to relocate somewhere else in the memory, or in another memory.

g. For Address Radix select Decimal, and for Data Radix select Binary.

For the Words per Line, set to 1.

Enter the file name as reloc.mem, then click OK to save the memory contents and
close the dialog. You will use thisfile for initialization in the next section.

Initialize a Memory

In ModelSim, it is possible to initialize amemory using one of three methods: from an exported
memory file, from afill pattern, or from both.

First, let’sinitialize amemory from afile only. Y ou will use the one you exported previously,
data_mem.mem.

1. View instance /ram_tb/spram3/mem.

a. Double-click the /ram_tb/spram3/mem instance in the Memory List window.

Thiswill open anew Memory Data window to display the contents of
/ram_tb/spram3/mem. Familiarize yourself with the contents so you can identify
changes once the initialization is compl ete.

Right-click and select Properties to bring up the Properties dial og.

Changethe Address Radix to Decimal, Data Radix to Binary, Wordsper Lineto 1,
and click OK.

2. Initialize spram3 from afile.
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a. Right-click anywhere in the data column and select Import Data Patter nsto bring
up the Import Memory dialog box (Figure 7-13).

— Instance Mame
Jram_thbfspram3mem

Figure 7-13. Import Memory Dialog

Impork Memory

" verilog Binary
i~ MII
i Specified in File

— Load Type Address Range
" File ol o al
" Data Orly " Addresses {in decimal)
" Both Fil and Data Start |0 End |65535
— File Load
—File Format [ Update Properties
" Yerilog Hex

—Loading Mode
% Incremental

" Mo Incremental

Filenarme

data mem. mEIrI

Browse, ..

—Daka Load
—Fill Tvpe
7 value

£ Increment
" Decrement
" Random

Fill Data

word(s)

K

Zancel

The default Load TypeisFile Only.

b. Typedata mem.memin the Filename field.

c. Click OK.

The addresses in instance /ram_tb/spram3/mem are updated with the data from
data_mem.mem (Figure 7-14).
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Figure 7-14. Initialized Memory from File and Fill Pattern

Memory Data - fram_th/spram3/mem

0wl 2=

HH Memory ...spram1/mem l HH Memory ...spram2/mem l |h] ram_tb.v I B Memory ...spram3/mem ]-ﬂil

In this next step, you will experiment with importing from both afile and afill pattern.
Y ou will initialize spram3 with the 250 addresses of data you exported previously into
the relocatablefile reloc.mem. Y ou will also initialize 50 additional address entries with
afill pattern.

3. Import the /ram_tb/spram3/mem instance with a relocatable memory pattern
(reloc.mem) and afill pattern.

a. Right-click in the data column of spram3 and select Import Data Patternsto bring
up the Import Memory dialog box.

b. For Load Type, select Both File and Data.

c. For Address Range, select Addresses and enter O as the Start address and 300 asthe
End address.

This means that you will be loading the file from 0 to 300. However, the reloc.mem
file contains only 251 addresses of data. Addresses 251 to 300 will be loaded with
thefill data you specify next.

d. For File Load, select the M TI File Format and enter reloc.mem in the Filename
field.

e. For DatalLoad, select aFill Type of Increment.
f. IntheFill Datafield, set the seed value of O for the incrementing data.
Click OK.

h. View the data near address 250 by double-clicking on any address in the Address
column and entering 250.

Y ou can see the specified range of addresses overwritten with the new data. Also, you
can see the incrementing data beginning at address 251 (Figure 7-15).
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Figure 7-15. Data Increments Starting at Address 251
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Now, before you leave this section, go ahead and clear the memory instances already
being viewed.

4. Right-click in one of the Memory Data windows and select Close All.

Interactive Debugging Commands

The Memory Data windows can also be used interactively for avariety of debugging purposes.
The features described in this section are useful for this purpose.

1. Open amemory instance and change its display characteristics.
a. Double-click instance /ram_tb/dpraml/memin the Memory List window.
b. Right-click in the dpraml Memory Data window and select Properties.
c. Change the Address and Data Radix to Hexadecimal.
d. Select Wordsper line and enter 2.
e. Click OK. Theresult should be asin Figure 7-16.

Figure 7-16. Original Memory Content
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a. Right-click in the data column of /ram_tb/dpraml/mem and select Change to open
the Change Memory dialog (Figure 7-17).

Figure 7-17. Changing Memory Content for a Range of Addresses**OK
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b. Select Addresses and enter the start address as 0x00000006 and the end address as
0x00000009. The "0x" hex notation is optional.

c. Select Random asthe Fill Type.
d. Enter 0 asthe Fill Data, setting the seed for the Random pattern.
e. Click OK.

The data in the specified range are replaced with a generated random fill pattern
(Figure 7-18).

Figure 7-18. Random Content Generated for a Range of Addresses
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3. Change contents by highlighting.
Y ou can aso change data by highlighting them in the Address Data pane.

ModelSim Tutorial, v10.3a 65



Viewing And Initializing Memories
Interactive Debugging Commands

a. Highlight the data for the addresses 0x0000000c: 0x0000000e, as shown in Figure 7-
19.

Figure 7-19. Changing Memory Contents by Highlighting
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b. Right-click the highlighted data and select Change.

This brings up the Change memory dialog box. Note that the Addressesfield is
already populated with the range you highlighted.

c. Select Value asthe Fill Type. (Refer to Figure 7-20)
d. Enter the datavaluesinto the Fill Datafield asfollows: 24 25 26.

Figure 7-20. Entering Data to Change**OK
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e. Click OK.

The data in the address | ocations change to the values you entered (Figure 7-21).
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Figure 7-21. Changed Memory Contents for the Specified Addresses
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4. Edit datain place.

5

To edit only one value at atime, do the following:

a. Double click any value in the Data column.

b. Enter the desired value and press the Enter or Return key on your keyboard.
If you needed to cancel the edit function, press the Esc key on your keyboard.

Lesson Wrap-Up

This concludes this lesson. Before continuing we need to end the current simulation.

1. Select Smulate > End Simulation. Click Yes.
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Chapter 8
Automating Simulation

Introduction

Aside from executing a couple of pre-existing DO files, the previous lessons focused on using
Model Sim in interactive mode: executing single commands, one after another, viathe GUI
menus or Main window command line. In situations where you have repetitive tasks to
complete, you can increase your productivity with DO files.

DO files are scripts that allow you to execute many commands at once. The scripts can be as
simple as a series of Model Sim commands with associated arguments, or they can be full-blown
Tcl programs with variables, conditional execution, and so forth. Y ou can execute DO files
from within the GUI or you can run them from the system command prompt without ever
invoking the GUI.

Note
D This lesson assumes that you have added the <install_dir>/<platform> directory to your

PATH. If you did not, you will need to specify full pathsto the tools (i.e., vlib, vmap,
vlog, vcom, and vsim) that are used in the lesson.

Related Reading
User’s Manual Chapter: Tcl and Macros (DO Files).

Practical Programming in Tcl and Tk, Brent B. Welch, Copyright 1997

Creating a Simple DO File

Creating aDO fileis as simple as typing a set of commandsin atext file. In this exercise, you
will create aDO filethat |oads a design, adds signals to the Wave window, provides stimulus to
those signals, and then advances the ssmulation. Y ou can also create a DO file from a saved
transcript file. Refer to "Saving a Transcript File asaMacro (DO file)."

1. Changeto the directory you created in the "Basic Simulation” lesson.

2. Create aDO file that will add signals to the Wave window, force signals, and run the
simulation.

a. Sdect File> New > Source > Do to create anew DO file.

b. Enter the following commands into the Source window:
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vsim test_counter
add wave count
add wave clk

add wave reset
force -freeze clk 0 0, 1 {50 ns} -r 100
force reset 1

run 100

force reset 0

run 300

force reset 1

run 400

force reset 0

run 200

3. Savethefile.
a. Sedect File> Save As.

b. Typesim.dointhe File name: field and save it to the current directory.
4. Executethe DOfile.

a. Enter do sim.do at the VSIM> prompt.

Model Sim loads the design, executes the saved commands and draws the waves in
the Wave window. (Figure 8-1)

Figure 8-1. Wave Window After Running the DO File
m Wave - Defaulk

o] ]

5. When you are done with this exercise, select File > Quit to quit Model Sim.

Running in Command-Line Mode

We use the term "command-line mode" to refer to ssmulations that are run from aDOS/ UNIX
prompt without invoking the GUI. Several Model Sim commands (e.g., vsim, vlib, vlog, etc.)
are actually stand-alone executables that can be invoked at the system command prompt.
Additionally, you can create aDO file that contains other Model Sim commands and specify that
file when you invoke the simulator.

70
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1. Create anew directory and copy thetutorial filesinto it.

Start by creating a new directory for this exercise. Create the directory and copy the
following filesinto it:

* /<ingtall_dir>/examples/tutorial s/'verilog/automation/counter.v
* /<install_dir>/examples/tutorials/'verilog/automation/stim.do

This lesson uses the Verilog file counter.v. If you have aVHDL license, use the
counter.vhd and stim.do filesin the /<install_dir>/examples/tutorial s'vhdl/automation
directory instead.

2. Create anew design library and compile the sourcefile.

Again, enter these commands at a DOS/ UNIX prompt in the new directory you created
instep 1.

a. Typevlib work at the DOS UNIX prompt.

b. For Verilog, typevlog counter.v at the DOS UNIX prompt. For VHDL, type vcom
counter.vhd.

3. CreateaDOfile.
a. Open atext editor.
b. Typethefollowing linesinto anew file:

# list all signals in decimal format
add list -decimal *

# read in stimulus
do stim.do

# output results
write list counter.lst

# quit the simulation
quit -f

c. Savethefilewith the name sim.do and place it in the current directory.
4. Run the batch-mode simulation.
a. Enter the following command at the DOS/UNIX prompt:

vsim -c -do sim.do counter -wlf counter.wlf

The -c argument instructs Model Sim not to invoke the GUI. The -wlf argument
saves the simulation resultsin aWLF file. This allows you to view the smulation
resultsin the GUI for debugging purposes.

5. View thelist output.
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a. Open counter.Ist and view the simulation results. Output produced by the Verilog
version of the design should look like Figure 8-2:

Figure 8-2. Output of the Counter
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The output may appear dightly different if you used the VHDL version.
6. View theresultsin the GUI.

Since you saved the simulation results in counter.wif, you can view them in the GUI by
invoking VSIM with the -view argument.

Note
Make sure your PATH environment variable is set with the current version of ModelSim

at the front of the string.

a. Typevsim -view counter .wlf at the DOS/ UNIX prompt.
The GUI opens and a dataset tab named "counter” is displayed (Figure 8-3).

Figure 8-3. The counter.wIf Dataset in the Main Window Workspace

& counter d ‘I Chijects P ' H A X

Inskance Design unik  |Design unit bype

Mame Yalue

4. count 01100100
4k Sk

F counker counter Module

4 reset Sk

. |
]i[ Library E u:u:uunter] ﬂ_?'l 1| | r

b. Right-click the counter instance and select Add Wave.
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The waveforms display in the Wave window.

7. When you finish viewing the results, select File > Quit to close Model Sim.

Using Tcl with the Simulator

The DO files used in previous exercises contained only Model Sim commands. However, DO
filesarereally just Tcl scripts. This means you can include awhole variety of Tcl constructs
such as procedures, conditional operators, math and trig functions, regular expressions, and so
forth.

In this exercise, you create asimple Tcl script that tests for certain values on asignal and then
adds bookmarks that zoom the Wave window when that value exists. Bookmarks allow you to
save a particular zoom range and scroll position in the Wave window.

1. Create the script.

a. Inatext editor, open anew file and enter the following lines:

proc add_wave_zoom {stime num} {
echo "Bookmarking wave S$Snum"
bookmark add wave "bk$Snum" "[expr S$stime - 100] [expr $stime + 50]" 0

}

These commands do the following:

® Create anew procedure called "add_wave zoom" that has two arguments, stime
and num.

® Create abookmark with azoom range from the current simulation time minus
100 time units to the current simulation time plus 50 time units.

b. Now add these lines to the bottom of the script:

add wave -r /*
when {clk'event and clk="1"} {
echo "Count is [exa count]"

if {[examine count]== "8'h27"} {
add_wave_zoom Snow 1
} elseif {[examine count]== "8'h47"} {

add_wave_zoom Snow 2
}
}

These commands do the following:
® Addall signalsto the Wave window.
® Useawhen statement to identify when clk transitionsto 1.

* Examinethe value of count at those transitions and add a bookmark if itisa
certain value.
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C.

Save the script with the name "add_bkmrk.do" into the directory you created in the
Basic Simulation lesson.

2. Load thetest_counter design unit and make sure the radix is set to binary.

a
b.

Start ModelSim.

Select File > Change Directory and change to the directory you saved the DO file
to above (the directory you created in the Basic Simulation lesson).

Typeradix -binary at the Model Sim> prompt
Enter the following command at the QuestaSim> prompt:

vsim test_counter

3. Executethe DO file and run the design.

a
b.

Typedo add_bkmrk.do at the VSIM> prompt.
Type run 1500 ns at the VSIM> prompt.
The simulation runs and the DO file creates two bookmarks.

If the Wave window is docked in the Main window make it the active window (click
anywhere in the Wave window), then select Bookmarks > bk 1. If the window is
undocked, select Bookmar ks> bk1 in the Wave window.

Watch the Wave window zoom in and scroll to the time when count is8h27. Try the
bk2 bookmark as well.

Lesson Wrap-Up

This concludes this lesson.

1. Select File> Quit to close ModelSim.
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End-User License Agreement

The latest version of the End-User License Agreement is available on-line at:
www.mentor.com/eula

IMPORTANT INFORMATION

USE OF ALL SOFTWARE IS SUBJECT TO LICENSE RESTRICTIONS. CAREFULLY READ THIS LICENSE
AGREEMENT BEFORE USING THE PRODUCTS. USE OF SOFTWARE INDICATES CUSTOMER’'S COMPLETE
AND UNCONDITIONAL ACCEPTANCE OF THE TERMS AND CONDITIONS SET FORTH IN THIS AGREEMENT.

ANY ADDITIONAL OR DIFFERENT PURCHASE ORDER TERMS AND CONDITIONS SHALL NOT APPLY.

END-USER LICENSE AGREEMENT (“Agreement”)

Thisisalegal agreement concerning the use of Software (as defined in Section 2) and hardwar e (collectively “Products”)
between the company acquiring the Products (“ Customer™), and the Mentor Graphics entity that issued the corresponding
quotation or, if no quotation was issued, the applicable local Mentor Graphics entity (“Mentor Graphics’). Except for license
agreementsrelated to the subject matter of thislicense agreement which are physically signed by Customer and an authorized
representative of Mentor Graphics, this Agreement and the applicable quotation contain the parties’ entire understanding
relating to the subject matter and supersede all prior or contemporaneous agreements. |f Customer does not agree to these
terms and conditions, promptly return or, in the case of Softwarereceived electronically, certify destruction of Software and all
accompanying itemswithin five days after receipt of Software and receive a full refund of any license fee paid.

ORDERS, FEESAND PAYMENT.

1.1. To the extent Customer (or if agreed by Mentor Graphics, Customer’s appointed third party buying agent) places and Mentor
Graphics accepts purchase orders pursuant to this Agreement (each an “Order”), each Order will constitute a contract between
Customer and Mentor Graphics, which shall be governed solely and exclusively by the terms and conditions of this Agreement,
any applicable addenda and the applicable quotation, whether or not those documents are referenced on the Order. Any additional
or conflicting terms and conditions appearing on an Order or presented in any electronic portal or automated order management
system, whether or not required to be electronically accepted, will not be effective unless agreed in writing and physically signed
by an authorized representative of Customer and Mentor Graphics.

1.2. Amountsinvoiced will be paid, in the currency specified on the applicable invoice, within 30 days from the date of such invoice.
Any past due invoices will be subject to the imposition of interest charges in the amount of one and one-half percent per month or
the applicable legal rate currently in effect, whichever is lower. Prices do not include freight, insurance, customs duties, taxes or
other similar charges, which Mentor Graphics will state separately in the applicable invoice. Unless timely provided with avalid
certificate of exemption or other evidence that items are not taxable, Mentor Graphics will invoice Customer for all applicable
taxes including, but not limited to, VAT, GST, sales tax, consumption tax and service tax. Customer will make all payments free
and clear of, and without reduction for, any withholding or other taxes; any such taxes imposed on payments by Customer
hereunder will be Customer’s sole responsibility. If Customer appoints a third party to place purchase orders and/or make
payments on Customer’s behalf, Customer shall be liable for payment under Orders placed by such third party in the event of
default.

1.3. All Products are delivered FCA factory (Incoterms 2010), freight prepaid and invoiced to Customer, except Software delivered
electronically, which shall be deemed delivered when made available to Customer for download. Mentor Graphics retains a
security interest in all Products delivered under this Agreement, to secure payment of the purchase price of such Products, and
Customer agrees to sign any documents that Mentor Graphics determines to be necessary or convenient for use in filing or
perfecting such security interest. Mentor Graphics' delivery of Software by electronic meansis subject to Customer’s provision of
both a primary and an alternate e-mail address.

GRANT OF LICENSE. The software installed, downloaded, or otherwise acquired by Customer under this Agreement, including any
updates, modifications, revisions, copies, documentation and design data (“ Software”) are copyrighted, trade secret and confidential
information of Mentor Graphics or its licensors, who maintain exclusive title to all Software and retain all rights not expressly granted
by this Agreement. Mentor Graphics grants to Customer, subject to payment of applicable license fees, a nontransferable, nonexclusive
license to use Software solely: (a) in machine-readable, object-code form (except as provided in Subsection 5.2); (b) for Customer’s
internal business purposes; (c) for the term of the license; and (d) on the computer hardware and at the site authorized by Mentor
Graphics. A siteisrestricted to a one-half mile (800 meter) radius. Customer may have Software temporarily used by an employee for
telecommuting purposes from locations other than a Customer office, such as the employee’s residence, an airport or hotel, provided
that such employee’s primary place of employment is the site where the Software is authorized for use. Mentor Graphics' standard
policies and programs, which vary depending on Software, license fees paid or services purchased, apply to the following: (a)
relocation of Software; (b) use of Software, which may be limited, for example, to execution of a single session by a single user on the
authorized hardware or for arestricted period of time (such limitations may be technically implemented through the use of
authorization codes or similar devices); and (c) support services provided, including eligibility to receive telephone support, updates,
modifications, and revisions. For the avoidance of doubt, if Customer provides any feedback or requests any change or enhancement to
Products, whether in the course of receiving support or consulting services, evaluating Products, performing beta testing or otherwise,
any inventions, product improvements, modifications or devel opments made by Mentor Graphics (at Mentor Graphics' sole discretion)
will be the exclusive property of Mentor Graphics.

ESC SOFTWARE. If Customer purchases a license to use devel opment or prototyping tools of Mentor Graphics Embedded Software
Channel (“ESC"), Mentor Graphics grants to Customer a nontransferable, nonexclusive license to reproduce and distribute executable
files created using ESC compilers, including the ESC run-time libraries distributed with ESC C and C++ compiler Software that are


http://www.mentor.com/eula

linked into a composite program as an integral part of Customer’s compiled computer program, provided that Customer distributes
these files only in conjunction with Customer’s compiled computer program. Mentor Graphics does NOT grant Customer any right to
duplicate, incorporate or embed copies of Mentor Graphics' real-time operating systems or other embedded software products into
Customer’ s products or applications without first signing or otherwise agreeing to a separate agreement with Mentor Graphics for such
purpose.

BETA CODE.

4.1. Portionsor al of certain Software may contain code for experimental testing and evaluation (which may be either alpha or beta,
collectively “Beta Code"), which may not be used without Mentor Graphics' explicit authorization. Upon Mentor Graphics'
authorization, Mentor Graphics grants to Customer atemporary, nontransferable, nonexclusive license for experimental useto test
and evaluate the Beta Code without charge for a limited period of time specified by Mentor Graphics. Mentor Graphics may
choose, at its sole discretion, not to release Beta Code commercialy in any form.

4.2. If Mentor Graphics authorizes Customer to use the Beta Code, Customer agrees to evaluate and test the Beta Code under normal
conditions as directed by Mentor Graphics. Customer will contact Mentor Graphics periodically during Customer’s use of the
Beta Code to discuss any malfunctions or suggested improvements. Upon completion of Customer’s evaluation and testing,
Customer will send to Mentor Graphics a written evaluation of the Beta Code, including its strengths, weaknesses and
recommended improvements.

4.3. Customer agrees to maintain Beta Code in confidence and shall restrict access to the Beta Code, including the methods and
concepts utilized therein, solely to those employees and Customer location(s) authorized by Mentor Graphics to perform beta
testing. Customer agrees that any written evaluations and all inventions, product improvements, modifications or developments
that Mentor Graphics conceived or made during or subsequent to this Agreement, including those based partly or wholly on
Customer’s feedback, will be the exclusive property of Mentor Graphics. Mentor Graphics will have exclusive rights, title and
interest in all such property. The provisions of this Subsection 4.3 shall survive termination of this Agreement.

RESTRICTIONS ON USE.

5.1. Customer may copy Software only as reasonably necessary to support the authorized use. Each copy must include all notices and
legends embedded in Software and affixed to its medium and container as received from Mentor Graphics. All copies shall remain
the property of Mentor Graphics or its licensors. Customer shall maintain a record of the number and primary location of all
copies of Software, including copies merged with other software, and shall make those records available to Mentor Graphics upon
request. Customer shall not make Products available in any form to any person other than Customer’s employees and on-site
contractors, excluding Mentor Graphics competitors, whose job performance requires access and who are under obligations of
confidentiality. Customer shall take appropriate action to protect the confidentiality of Products and ensure that any person
permitted access does not disclose or use Products except as permitted by this Agreement. Customer shall give Mentor Graphics
written notice of any unauthorized disclosure or use of the Products as soon as Customer becomes aware of such unauthorized
disclosure or use. Except as otherwise permitted for purposes of interoperability as specified by applicable and mandatory local
law, Customer shall not reverse-assembl e, reverse-compile, reverse-engineer or in any way derive any source code from Software.
Log files, datafiles, rule files and script files generated by or for the Software (collectively “Files”), including without limitation
files containing Standard Verification Rule Format (“SVRF”) and Tcl Verification Format (“TVF’) which are Mentor Graphics
trade secret and proprietary syntaxes for expressing process rules, constitute or include confidential information of Mentor
Graphics. Customer may share Files with third parties, excluding Mentor Graphics competitors, provided that the confidentiality
of such Filesis protected by written agreement at least as well as Customer protects other information of a similar nature or
importance, but in any case with at |east reasonable care. Customer may use Files containing SVRF or TVF only with Mentor
Graphics products. Under no circumstances shall Customer use Products or Files or allow their use for the purpose of developing,
enhancing or marketing any product that is in any way competitive with Products, or disclose to any third party the results of, or
information pertaining to, any benchmark.

5.2. If any Software or portions thereof are provided in source code form, Customer will use the source code only to correct software
errors and enhance or modify the Software for the authorized use. Customer shall not disclose or permit disclosure of source code,
in whole or in part, including any of its methods or concepts, to anyone except Customer’s employees or on-site contractors,
excluding Mentor Graphics competitors, with a need to know. Customer shall not copy or compile source code in any manner
except to support this authorized use.

5.3. Customer may not assign this Agreement or the rights and duties under it, or relocate, sublicense, or otherwise transfer the
Products, whether by operation of law or otherwise (“ Attempted Transfer”), without Mentor Graphics' prior written consent and
payment of Mentor Graphics' then-current applicable relocation and/or transfer fees. Any Attempted Transfer without Mentor
Graphics' prior written consent shall be a material breach of this Agreement and may, at Mentor Graphics' option, result in the
immediate termination of the Agreement and/or the licenses granted under this Agreement. The terms of this Agreement,
including without limitation the licensing and assignment provisions, shall be binding upon Customer’s permitted successors in
interest and assigns.

5.4. The provisions of this Section 5 shall survive the termination of this Agreement.

SUPPORT SERVICES. To the extent Customer purchases support services, Mentor Graphicswill provide Customer with updates and
technical support for the Products, at the Customer site(s) for which support is purchased, in accordance with Mentor Graphics' then
current End-User Support Terms located at http://supportnet.mentor.com/supportterms.

LIMITED WARRANTY.

7.1. Mentor Graphics warrants that during the warranty period its standard, generally supported Products, when properly installed, will
substantially conform to the functional specifications set forth in the applicable user manual. Mentor Graphics does not warrant
that Products will meet Customer’s requirements or that operation of Products will be uninterrupted or error free. The warranty
period is 90 days starting on the 15th day after delivery or upon installation, whichever first occurs. Customer must notify Mentor
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10.

11

12.

Graphicsin writing of any nonconformity within the warranty period. For the avoidance of doubt, thiswarranty applies only to the
initial shipment of Software under an Order and does not renew or reset, for example, with the delivery of (a) Software updates or
(b) authorization codes or alternate Software under a transaction involving Software re-mix. This warranty shall not be valid if
Products have been subject to misuse, unauthorized modification, improper installation or Customer is not in compliance with this
Agreement. MENTOR GRAPHICS' ENTIRE LIABILITY AND CUSTOMER'S EXCLUSIVE REMEDY SHALL BE, AT
MENTOR GRAPHICS OPTION, EITHER (A) REFUND OF THE PRICE PAID UPON RETURN OF THE PRODUCTS TO
MENTOR GRAPHICS OR (B) MODIFICATION OR REPLACEMENT OF THE PRODUCTS THAT DO NOT MEET THIS
LIMITED WARRANTY. MENTOR GRAPHICS MAKES NO WARRANTIES WITH RESPECT TO: (A) SERVICES; (B)
PRODUCTS PROVIDED AT NO CHARGE; OR (C) BETA CODE; ALL OF WHICH ARE PROVIDED “AS|1S.”

7.2. THE WARRANTIES SET FORTH IN THIS SECTION 7 ARE EXCLUSIVE. NEITHER MENTOR GRAPHICS NOR ITS
LICENSORS MAKE ANY OTHER WARRANTIES EXPRESS, IMPLIED OR STATUTORY, WITH RESPECT TO
PRODUCTS PROVIDED UNDER THIS AGREEMENT. MENTOR GRAPHICS AND ITS LICENSORS SPECIFICALLY
DISCLAIM ALL IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
NON-INFRINGEMENT OF INTELLECTUAL PROPERTY.

LIMITATION OF LIABILITY. EXCEPT WHERE THIS EXCLUSION OR RESTRICTION OF LIABILITY WOULD BE VOID
OR INEFFECTIVE UNDER APPLICABLE LAW, IN NO EVENT SHALL MENTOR GRAPHICS OR ITS LICENSORS BE
LIABLE FOR INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES (INCLUDING LOST PROFITS OR
SAVINGS) WHETHER BASED ON CONTRACT, TORT OR ANY OTHER LEGAL THEORY, EVEN IF MENTOR GRAPHICS
OR ITS LICENSORS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. IN NO EVENT SHALL MENTOR
GRAPHICS OR ITSLICENSORS' LIABILITY UNDER THIS AGREEMENT EXCEED THE AMOUNT RECEIVED FROM
CUSTOMER FOR THE HARDWARE, SOFTWARE LICENSE OR SERVICE GIVING RISE TO THE CLAIM. IN THE CASE
WHERE NO AMOUNT WAS PAID, MENTOR GRAPHICS AND ITS LICENSORS SHALL HAVE NO LIABILITY FOR ANY
DAMAGES WHATSOEVER. THE PROVISIONS OF THIS SECTION 8 SHALL SURVIVE THE TERMINATION OF THIS
AGREEMENT.

HAZARDOUS APPLICATIONS. CUSTOMER ACKNOWLEDGES IT IS SOLELY RESPONSIBLE FOR TESTING ITS
PRODUCTS USED IN APPLICATIONS WHERE THE FAILURE OR INACCURACY OF ITS PRODUCTS MIGHT RESULT IN
DEATH OR PERSONAL INJURY (“HAZARDOUS APPLICATIONS"). EXCEPT TO THE EXTENT THIS EXCLUSION OR
RESTRICTION OF LIABILITY WOULD BE VOID OR INEFFECTIVE UNDER APPLICABLE LAW, IN NO EVENT SHALL
MENTOR GRAPHICS OR ITS LICENSORS BE LIABLE FOR ANY DAMAGES RESULTING FROM OR IN CONNECTION
WITH THE USE OF MENTOR GRAPHICS PRODUCTS IN OR FOR HAZARDOUS APPLICATIONS. THE PROVISIONS OF
THIS SECTION 9 SHALL SURVIVE THE TERMINATION OF THIS AGREEMENT.

INDEMNIFICATION. CUSTOMER AGREES TO INDEMNIFY AND HOLD HARMLESS MENTOR GRAPHICS AND ITS
LICENSORS FROM ANY CLAIMS, LOSS, COST, DAMAGE, EXPENSE OR LIABILITY, INCLUDING ATTORNEYS' FEES,
ARISING OUT OF OR IN CONNECTION WITH THE USE OF MENTOR GRAPHICS PRODUCTS IN OR FOR HAZARDOUS
APPLICATIONS. THE PROVISIONS OF THIS SECTION 10 SHALL SURVIVE THE TERMINATION OF THIS AGREEMENT.

INFRINGEMENT.

11.1. Mentor Graphics will defend or settle, at its option and expense, any action brought against Customer in the United States,
Canada, Japan, or member state of the European Union which alleges that any standard, generally supported Product acquired by
Customer hereunder infringes a patent or copyright or misappropriates a trade secret in such jurisdiction. Mentor Graphics will
pay costs and damages finally awarded against Customer that are attributable to such action. Customer understands and agrees
that as conditions to Mentor Graphics' obligations under this section Customer must: (&) notify Mentor Graphics promptly in
writing of the action; (b) provide Mentor Graphics all reasonable information and assistance to settle or defend the action; and (c)
grant Mentor Graphics sole authority and control of the defense or settlement of the action.

11.2. If aclaim is made under Subsection 11.1 Mentor Graphics may, at its option and expense: (&) replace or modify the Product so
that it becomes noninfringing; (b) procure for Customer the right to continue using the Product; or (c) require the return of the
Product and refund to Customer any purchase price or license fee paid, |ess a reasonabl e allowance for use.

11.3. Mentor Graphics has no liability to Customer if the action is based upon: (@) the combination of Software or hardware with any
product not furnished by Mentor Graphics; (b) the modification of the Product other than by Mentor Graphics; (c) the use of other
than acurrent unaltered rel ease of Software; (d) the use of the Product as part of an infringing process; (€) aproduct that Customer
makes, uses, or sells; (f) any Beta Code or Product provided at no charge; (g) any software provided by Mentor Graphics'
licensors who do not provide such indemnification to Mentor Graphics' customers; or (h) infringement by Customer that is
deemed willful. In the case of (h), Customer shall reimburse Mentor Graphics for its reasonable attorney fees and other costs
related to the action.

11.4. THIS SECTION 11 IS SUBJECT TO SECTION 8 ABOVE AND STATES THE ENTIRE LIABILITY OF MENTOR
GRAPHICS AND ITS LICENSORS, AND CUSTOMER’S SOLE AND EXCLUSIVE REMEDY, FOR DEFENSE,
SETTLEMENT AND DAMAGES, WITH RESPECT TO ANY ALLEGED PATENT OR COPYRIGHT INFRINGEMENT OR
TRADE SECRET MISAPPROPRIATION BY ANY PRODUCT PROVIDED UNDER THIS AGREEMENT.

TERMINATION AND EFFECT OF TERMINATION.

12.1. If a Software license was provided for limited term use, such license will automatically terminate at the end of the authorized
term. Mentor Graphics may terminate this Agreement and/or any license granted under this Agreement immediately upon written
notice if Customer: (a) exceeds the scope of the license or otherwise fails to comply with the licensing or confidentiality
provisions of this Agreement, or (b) becomes insolvent, files a bankruptcy petition, institutes proceedings for liquidation or
winding up or enters into an agreement to assign its assets for the benefit of creditors. For any other material breach of any
provision of this Agreement, Mentor Graphics may terminate this Agreement and/or any license granted under this Agreement
upon 30 days written notice if Customer failsto cure the breach within the 30 day notice period. Termination of this Agreement or
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any license granted hereunder will not affect Customer’s obligation to pay for Products shipped or licenses granted prior to the
termination, which amounts shall be payable immediately upon the date of termination.

12.2. Upon termination of this Agreement, the rights and obligations of the parties shall cease except as expressly set forth in this
Agreement. Upon termination, Customer shall ensure that all use of the affected Products ceases, and shall return hardware and
either return to Mentor Graphics or destroy Software in Customer’s possession, including all copies and documentation, and
certify in writing to Mentor Graphics within ten business days of the termination date that Customer no longer possesses any of
the affected Products or copies of Softwarein any form.

EXPORT. The Products provided hereunder are subject to regulation by local laws and United States (“U.S.”) government agencies,
which prohibit export, re-export or diversion of certain products, information about the products, and direct or indirect products thereof,
to certain countries and certain persons. Customer agrees that it will not export or re-export Products in any manner without first
obtaining all necessary approval from appropriate local and U.S. government agencies. If Customer wishesto disclose any information
to Mentor Graphicsthat is subject to any U.S. or other applicable export restrictions, including without limitation the U.S. International
Traffic in Arms Regulations (ITAR) or specia controls under the Export Administration Regulations (EAR), Customer will notify
Mentor Graphics personnel, in advance of each instance of disclosure, that such information is subject to such export restrictions.

U.S. GOVERNMENT LICENSE RIGHTS. Software was developed entirely at private expense. The parties agree that all Softwareis
commercial computer software within the meaning of the applicable acquisition regulations. Accordingly, pursuant to U.S. FAR 48
CFR 12.212 and DFAR 48 CFR 227.7202, use, duplication and disclosure of the Software by or for the U.S. government or a U.S.
government subcontractor is subject solely to the terms and conditions set forth in this Agreement, which shall supersede any
conflicting terms or conditions in any government order document, except for provisions which are contrary to applicable mandatory
federal laws.

THIRD PARTY BENEFICIARY. Mentor Graphics Corporation, Mentor Graphics (Ireland) Limited, Microsoft Corporation and
other licensors may be third party beneficiaries of this Agreement with the right to enforce the obligations set forth herein.

REVIEW OF LICENSE USAGE. Customer will monitor the access to and use of Software. With prior written notice and during
Customer’s normal business hours, Mentor Graphics may engage an internationally recognized accounting firm to review Customer’s
software monitoring system and records deemed relevant by the internationally recognized accounting firm to confirm Customer’'s
compliance with the terms of this Agreement or U.S. or other local export laws. Such review may include FlexNet (or successor
product) report log files that Customer shall capture and provide at Mentor Graphics' request. Customer shall make records availablein
electronic format and shall fully cooperate with data gathering to support the license review. Mentor Graphics shall bear the expense of
any such review unless a material non-compliance is revealed. Mentor Graphics shall treat as confidential information all information
gained as aresult of any request or review and shall only use or disclose such information as required by law or to enforce its rights
under this Agreement. The provisions of this Section 16 shall survive the termination of this Agreement.

CONTROLLING LAW, JURISDICTION AND DISPUTE RESOLUTION. The owners of certain Mentor Graphics intellectual
property licensed under this Agreement are located in Ireland and the U.S. To promote consistency around the world, disputes shall be
resolved as follows: excluding conflict of laws rules, this Agreement shall be governed by and construed under the laws of the State of
Oregon, U.S,, if Customer is located in North or South America, and the laws of Ireland if Customer is located outside of North or
South America. All disputes arising out of or in relation to this Agreement shall be submitted to the exclusive jurisdiction of the courts
of Portland, Oregon when the laws of Oregon apply, or Dublin, Ireland when the laws of Ireland apply. Notwithstanding the foregoing,
all disputesin Asiaarising out of or in relation to this Agreement shall be resolved by arbitration in Singapore before a single arbitrator
to be appointed by the chairman of the Singapore International Arbitration Centre (“SIAC”) to be conducted in the English language, in
accordance with the Arbitration Rules of the SIAC in effect at the time of the dispute, which rules are deemed to be incorporated by
referencein this section. Nothing in this section shall restrict Mentor Graphics' right to bring an action (including for example amotion
for injunctive relief) against Customer in the jurisdiction where Customer’s place of business is located. The United Nations
Convention on Contracts for the International Sale of Goods does not apply to this Agreement.

SEVERABILITY. If any provision of this Agreement is held by a court of competent jurisdiction to be void, invalid, unenforceable or
illegal, such provision shall be severed from this Agreement and the remaining provisions will remain in full force and effect.

MISCELLANEOUS. This Agreement contains the parties’ entire understanding relating to its subject matter and supersedes all prior
or contemporaneous agreements. Some Software may contain code distributed under a third party license agreement that may provide
additional rights to Customer. Please see the applicable Software documentation for details. This Agreement may only be modified in
writing, signed by an authorized representative of each party. Waiver of terms or excuse of breach must be in writing and shall not
constitute subsequent consent, waiver or excuse.

Rev. 140201, Part No. 258976
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