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Chapter 1
Overview

The Model Sim graphical user interface (GUI) provides access to numerous debugging tools and
windows that enable you to analyze different parts of your design. All windowsinitialy display
within the Model Sim Main window.

Figure 1-1. Graphical User Interface
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General GUI Tasks

This section describes tasks common to more than one individual window and is organized into
the following categories:

® Window Management

® Column-Based Windows
* Bookmarks

® Scribble Mode

* Font Management

®* Find and Filter Functions

Window Management

The following tasks define actions you can take with the various windows.

Saving the Layout Upon Exit

By default when you exit Model Sim, the current layout is saved for a given design so that it
appears the same the next time you invoke the tool.

Resetting the Window Layout to the Default

The windows are customizable in that you can position and size them as you see fit, and
Model Sim will remember your settings upon subsequent invocations. Y ou can restore
Model Sim windows and panes to their original settings by selecting L ayout > Reset in the
menu bar.

Copying Text from a Window Header
Y ou can copy thetitle text in awindow header by selecting it and right-clicking to display a
popup menu. Thisis useful for copying the file name of a source file for use elsewhere .
Selecting the Active Window

When the title bar of awindow is highlighted - solid blue - it is the active window. All menu
selections will correspond to this active window. Y ou can change the active window in the
following ways.

® (default) Click anywherein awindow or onitstitle bar.

®* Move the mouse pointer into the window.
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To turn on this feature, select Window > FocusFollowsM ouse. Default time delay for
activating awindow after the mouse cursor has entered the window is 300ms. Y ou can
change the time delay with the PrefMain(FFMDelay) preference variable.

Moving a Window or Tab Group
1. Click on the header handle in the title bar of the window or tab group.

Figure 1-2. Window Header Handle

% CObjects

2. Drag, without releasing the mouse button, the window or tab group to adifferent area of
the Main window

Wherever you move your mouse you will see adark blue outline that previews where
the window will be placed.

If the preview outline is a rectangle centered within awindow, it indicates that you will
convert the window or tab group into new tabs within the highlighted window.

3. Release the mouse button to complete the move.

Moving a Tab out of a Tab Group
1. Click on the tab handle that you want to move.

Figure 1-3. Tab Handle

1
I [‘I Ohjects ] ﬁi Processes J ﬂ_?-' l

2. Drag, without releasing the mouse button, the tab to a different area of the Main window

Wherever you move your mouse you will see adark blue outline that previews where
the tab will be placed.

If the preview outline is arectangle centered within awindow, it indicates that you will
move the tab into the highlighted window.

3. Release the mouse button to complete the move.

Undocking a Window from the Main Window

® Follow the stepsin Moving aWindow or Tab Group, but drag the window outside of the
Main window, or
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®* Click on the Dock/Undock button for the window.

Figure 1-4. Window Undock Button

% Objects

Column-Based Windows

This section describes tasks related to column-based windows throughout the GUI.

Customizing the Column Views

Y ou can customize the display of columns column-based windows, and then save these views
for later use.

Procedure

1. Right-click in the column headings and select Configure Column Layout. This
displays the Configure Column Layout dialog box.

a. Select Create. This displays the Create Column Layout dialog box.
I. Layout Name — enter aname for the layout for future reference.
ii. Column Selections — move columnsto your desired state.
iii. Click OK.
b. Your new layout is added to the Layouts list.
c. Click Done.

After applying your selections, the rearranged columns and custom layouts are saved and
appear when you next open that column view in the window.

Bookmarks

Y ou can create bookmarks that allow you to return to a specific view or place in your design for
some of the windows. The bookmarks you make can be saved and automatically restored. Some
of the windows that allow bookmarking include the Structure, Files, Objects, Wave, and
Objects windows.

Working with Bookmarks

The Bookmarks toolbar and the Bookmarks menu give you access to the following
bookmarking features:
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* Add Bookmarks

Bookmarks are added to an active window by selecting Bookmarks > Add
Bookmark or by clicking the Add Bookmark button. Y ou will be prompted to
automatically save and restore your bookmarks when you set the first bookmark.
Y ou can change the automatic save and restore settings in the Bookmark Options
Dialog Box.

®* Add Custom

Selecting Add Custom opens the New Bookmark dialog box with the context
field(s) populated and afield for specifying an alias for the bookmark. Click and
hold the Add Bookmar k button to access this feature from the Bookmar ks toolbar.

Note
D Aliases are mapped to the window in which abookmark isset. Y ou can usethe same adias

for different bookmarks as long as each aliasis assigned to abookmark set in a different
window.

* Deleting Bookmarks

Y ou can choose to delete the bookmarks from the currently active window or from
all windows.

®* Manage Bookmarks

Opens the M anage Bookmar ks dialog box. Refer to Managing Y our Bookmarks
for more information.

* | oad Bookmarks

L oads the bookmarks saved in the bookmarks.do file. Y ou can choose whether to
load bookmarks for the currently active window or al the bookmarks saved in the
bookmarks.do file. Bookmarks are automatically loaded from the saved
bookmarks.do file when you start a new simulation session.

Note
Y ou must reload bookmarks for awindow if you close then reopen that window during

the current session.

®  Jump to Bookmark

Shows the available bookmarks in the currently active window followed by a drop
down list of bookmarks for each window. Y ou can set the maximum number of
bookmarks listed in the Bookmark Options Dialog Box.
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Managing Your Bookmarks

Y ou can open the Manage Bookmarks dialog box with the M anage Bookmar ks toolbar button
or by selecting Bookmar ks> Manage Bookmarks. The dialog box can be kept open during
your simulation (Figure 1-5).

Figure 1-5. Manage Bookmarks Dialog Box
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® Simple view mode changes the buttons from name and icon mode to icon only mode.

® Checking Active window only changes the display to show the bookmarks in the
currently active window. Selecting a different window in the tool changes the display to
the bookmarks set in that window.

® Selecting New opensthe New Bookmark dialog box. The fieldsin the dialog
automatically load the settings of the view in the currently active window. Y ou can
choose to name the bookmark with an alias to provide a more meaningful description.
Aliases are displayed in the Alias column in the Manage Bookmarks dialog box.

® Selecting Options opens the Bookmark Options dialog box (Figure 1-6).
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Figure 1-6. Bookmark Options Dialog Box
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¥ Restore bookmarks when windows open
¥ Show informational messages after bookmark actions

[” Reset confirmation queries

@

The Menu Display section allows you to:

o Set the number of bookmarks displayed in the Bookmarks menu or the Jump to
Bookmark button menu.

o Select the types of information displayed for each bookmark.
The Other section allows you to:
o Specify adifferent base name for bookmarks.

o Choose whether you want to automatically save bookmarks and when they are
saved.

o Automatically restore the bookmarks when windows are first loaded in the current
session.

o Show informational message after bookmark actions sends bookmark actions to
the transcript. For example:
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# Bookmark(s) were restored for window "Source"

Saving and Reloading Formats and Content

Y ou can use the write format restart command to create a single .do file that will recreate all
debug windows and breakpoints (see Saving and Restoring Breakpoints) when invoked with the
do command in subsequent simulation runs. The syntax is:

write format restart <filename>

If the ShutdownFile modelsim.ini variableis set to this .do filename, it will call thewrite
format restart command upon exit.

Scribble Mode

On Linux systems, you can capture an image of the desktop or a single window, make line
drawings and take notes, then save the image for later review or to share with others. Scribble
mode provides a quick way to make annotions directly on the GUI.

Figure 1-7. Scribble Mode
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Y ou can access this feature by selecting Window > Enable Scribble M ode from either the
main window or a separate window. A new window with ared border is superimposed over a
window or the desktop and access to all window and toolbar functions are suspended until you
exit Scribble Mode. Use the left mouse button to draw and drag atext box into position. Use the
right mouse button to open a menu with the following options:

Table 1-1. Scribble Mode Menu
Menu Item Description

Add Text Opens the Scribble Text
dialog box for entering and
formatting text

Attributes Choose color and line
thickness

Clear Items Choose which graphic
elementsto delete

Save Image Savestheimage asabitmap

to the current directory

Exit Scribble Mode

Font Management

Y ou may need to adjust font settings to accommodate the aspect ratios of wide screen and
double screen displays or to handle launching Model Sim from an X-session. Refer to Making
Global Font Changes for more information.

Font Scaling

To change font scaling, select the Transcript window, then Transcript > Adjust Font Scaling.
Y ou will need aruler to complete the instructions in the lower right corner of the dialog. When
you have entered the pixel and inches information, click OK to close the dialog. Then, restart
Model Sim to see the change. Thisis a one time setting; you should not need to set it again
unless you change display resolution or the hardware (monitor or video card). The font scaling
applies to Windows and UNIX operating systems. On UNIX systems, the font scaling is stored
based on the $DISPLAY environment variable.

Find and Filter Functions

Finding and/or filtering capabilities are available for most windows. The Find mode toolbar is
shown in Figure 1-8. The filtering function is denoted by a*“Contains’ field (Figure 1-9).

Figure 1-8. Find Mode
*|Find: |ﬂv ‘P j M Seatch For - {ay [T
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Figure 1-9. Filter Mode
J Conkains |c & i

Windows that support both Find (Figure 1-8) and Filter modes (Figure 1-9) allow you to toggle
between the two modes by doing any one of the following:

® Usethe Ctrl+M hotkey.
® (Click the“Find” or “Contains” words in the toolbar at the bottom of the window.

® Select the mode from the Find Options popup menu (see Using the Find Options Popup
Menu).

The last selected mode is remembered between sessions.

A “Find” toolbar will appear along the bottom edge of the active window when you do either of
the following:

® Sdect Edit > Find in the menu bar.
® (Click theFind iconin the Standard Toolbar. | ik

All of the above actions are toggles - repeat the action and the Find toolbar will close.

The Find or Filter entry fields prefill as you type, based on the context of the current window
selection. The find or filter action begins as you type.

There is a simple history mechanism that saves find or filter strings for later use. The keyboard
shortcuts to use this feature are:

® Ctrl+P — retrieve previous search string
® Ctrl+N — retrieve next search string

Other hotkey actionsinclude:

® Esc— closesthe Find toolbar
* Enter (Windows) or Return (UNIX or Linux) — initiates a“Find Next” action
® Citrl+T — search while typing (default is on)

The entry field turns red if no matches are found.

The graphic elements associated with the Find toolbar are shown in Table 1-2.
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Note

The Find Toolbar graphic el ements are context driven. The actions available change for

each window.

Table 1-2. Graphic Elements of Toolbar in Find Mode

Graphic Element

Action

Find opens the find toolbar in the active
oy window
x| Close closes the find tool bar

| lﬂv entry field o7

Find entry field

allows entry of find parameters

i Find Options

opens the Find Options popup menu at
the bottom of the active window. The
contents of the menu changes for each
window.

Clear Entry Field

Q|

clearsthe entry field

Execute Search

I

initiates the search

Toggle Search Direction

toggles search direction upward or
downward through the active window

Find All Matches;

E | |&

Bookmark All Matches (for Source

highlights every occurrence of the find
item; for the Source window only,

Search For =

window only) places a blue flag (bookmark) at every
occurrence of the find item
Search For Click and hold the button to open a

drop down menu with the following
options:

® |nstance

® Design Unit

Match Case search must match the case of the text
[~ Aa entered in the Find field

Exact (whole word) searches for whole words that match
I {a} those entered in the Find field

g Regular Expression

Searches for aregular expression;
Source window only.
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Table 1-2. Graphic Elements of Toolbar in Find Mode (cont.)

Graphic Element

Action

Wrap Search
i

Searches from cursor to bottom of
window then continues search from top

of the window.

Searching in the Structure Window

The Structure window Find bar supports hierarchical searching to limit the regions of a search.
A forward slash (/) character is used to separate the search words. A double slash (//) is used to
specify arecursive search from the double slash down the hierarchy (Figure 1-10). Refer to
Finding Items in the Structure Window for more information.

Figure 1-10. Find Mode Popup Displaying Matches
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Using the Filter Mode

By entering a string in the “Contains’ text entry box you can filter the view of the selected
window down to the specific information you are looking for.

Table 1-3. Graphic Elements of Toolbar in Filter Mode

Button Name Shortcuts | Description

Filter Regular Expression None A drop down menu that allows
you to set the wildcard mode.

A text entry box for your filter
string.

Clear Filter None Clears the text entry box and
.f_"F removes the filter from the
active window.

Wildcard Usage

There are three wildcard modes:

® glob-style— Allows you to use the following special wildcard characters:
* — matches any sequence of charactersin the string
? — matches any single character in the string
[<chars>] — matches any character in the set <chars>

\<x> — matches the single character <x>, which allows you to match on any special
characters (*, 2, [, ], and)\)

Refer to Finding Items in the Structure Window and the Tcl documentation for more
information:

Help > Tcl Man Pages
Tcl Commands > string > string match

® regular-expression — (Source window only) allows you to use wildcard characters
based on Tcl regular expressions. For more information refer to the Tcl documentation:

Help > Tcl Man Pages
Tcl Commands > re_syntax

® exact — indicates that no characters have special meaning, thus disabling wildcard
features.

The string entry field of the Contains toolbar item is case-insensitive, If you need to search for
case-sendgitive strings in the Source window select “regular-expression” and prepend the string
with (?c).
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Using the Find Options Popup Menu

When you click the Find Optionsicon &g intheFind entry field it will open a Find Options
popup menu (Figure 1-11). T

Figure 1-11. Find Options Popup Menu

i | j ‘ SearchFor v | [ 2
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v Find Cirl-+H
Search Field :
Match Case Design unit

Exact (whaole word) -
v \Wrap Search

v Search While Typing Cirl+T

Recent Searches L
Execute Search Enter
Close Esc

The Find Options menu displays the options available to you as well as hot keys for initiating
the actions without the menu.

General Visual Elements

This section descibes elements that are used by multiple windows.

Elements of the Main Window

The following sections outline the GUI terminology used in this manual.

Menu Bar Toolbar Frame
Toolbar Window
Tab Group Pane

The Main window is the primary access point in the GUI. Figure 1-12 shows an example of the
Main window during a simulation run.
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The Main window contains a menu bar, toolbar frame, windows, tab groups, and a status bar,
which are described in the following sections.

Menu Bar

The menu bar provides access to many tasks available for your workflow. Figure 1-13 shows
the selection in the menu bar that changes based on whichever window is currently active.

The menu items that are available and how certain menu items behave depend on which
window is active. For example, if the Structure window is active and you choose Edit from the
menu bar, the Clear command is disabled. However, if you click in the Transcript window and
choose Edit, the Clear command is enabled. The active window is denoted by a blue title bar
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Figure 1-13. Main Window — Menu Bar
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Toolbar Frame

Thetoolbar frame contains several toolbars that provide quick access to various commands and
functions.

Figure 1-14. Main Window — Toolbar Frame
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Toolbar

A toolbar isacollection of GUI elementsin the toolbar frame and grouped by similarity of task.
There are many toolbars available within the GUI, refer to the section “ Toolbars’ for more
information about each toolbar. Figure 1-15 highlights the Compile toolbar in the toolbar frame.
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Figure 1-15. Main Window — Toolbar

Compile Toolbar

Window

Model Sim can display over 40 different windows you can use with your workflow. This manual
refersto all of these objects as windows, even though you can rearrange them such that they
appear as a single window with tabs identifying each window.

Figure 1-16 shows an example of alayout with five windows visible; the Structure, Objects,
Processes, Wave and Transcript windows.
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Figure 1-16. GUI Windows
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Y ou can group any number of windows into a single space called atab group, allowing you to
show and hide windows by selecting their tabs. Figure 1-17 shows atab group of the Library,
Files, Capacity and Structure windows, with the Structure (ssim) window visible.
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Figure 1-17. GUI Tab Group
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Pane

Some windows contain panes, which are separate areas of awindow display containing distinct
information within that window. One way to tell if awindow has panesis whether you receive
different popup menus (right-click menu) in different areas. Windows that have panes include

the Wave, Source, and List windows. Figure 1-18 shows the Wave window with its the three
panes.
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Figure 1-18. Wave Window Panes
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Main Window Status Bar

Fields at the bottom of the Main window provide the following information about the current
simulation:

Figure 1-19. Main Window Status Bar

Froject : rl Mow: O ns Delta: O sim:ftap/p y

Table 1-4. Information Displayed in Status Bar

Field Description
Project name of the current project
Now the current simulation time
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Table 1-4. Information Displayed in Status Bar (cont.)

Field Description

Delta the current simulation iteration number

Profile Samples the number of profile samples collected during the
current ssimulation

Memory the total memory used during the current ssmulation

environment name of the current context (object selected in the

active Structure window)

line/column line and column numbers of the cursor in the active
Source window

Design Object Icons and Their Meanings

The color and shape of icons convey information about the language and type of adesign
object. Table 1-5 shows the icon colors and the languages they indicate.

Table 1-5. Design Object Icons

I con color Design Language

light blue Verilog or SystemVerilog
dark blue VHDL

orange virtual object

Hereisalist of icon shapes and the design object types they indicate:

Table 1-6. Icon Shapes and Design Object Types

Icon shape | Example Design Object Type
Square o any scope (VHDL block, Verilog named block, SC module,
class, interface, task, function, and so forth.)
Square and SystemVerilog object, OVM, and UVM test bench scope or
red asterix | 4 object
Circle rocess
¥ ) p
Diamond ‘ valued object (signals, nets, registers, and so forth.)
Diamond '-ﬁ an editable waveform created with the waveform editor
and yellow
pulse on red
dot
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Table 1-6. Icon Shapes and Design Object Types (cont.)

Icon shape | Example Design Object Type

Diamond * valued object (abstract)
and red
asterix

Diamond d indicates mode (In, Inout, Out) of an object port
and green " ¢ wb

arrow

Triangle A caution sign on comparison object

Star 4' transaction; The color of the star for each transaction depends
on the language of the region in which the transaction stream

occurs: dark blue for VHDL, light blue for Verilog and
SystemVerilog, green for SystemC.

Window Time Display

There are two basic time designations used to control display of object valuesin many simulator
windows.

®* Now — The end-of-simulation time or the time at which the simulation has stopped.

® Current Time— The current time displayed in an open window. The time may be any
time between 0 and the end of simulation, and is set in severa ways.

o by moving awave cursor

o by interacting with the Current Time Label. Refer to Current Time Label for
more information.

A number of windows are dynamically linked to update when the time setting in one is changed.
The windows include the FSM, Objects, Source, and Watch windows.

Current Time Label

The Current Time Label allows you to interact with and change the ssmulation time displayed in
severa windows. The Current Time Label displays the Now (end of simulation) or Current
Time, and allows you to search the time line for a transition on a selected object in the window
(Figure 1-20).
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Figure 1-20. Current Time Label

Minimize/Maximize Button
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When you run asimulation and it comes to an end, the Current Time Label displays the Now
time which is the end-of-simulation time. When you select a cursor in the Wave window, the
Current Time Label automatically changes to display the time of the current active cursor and
updates the other windows to the same time.

The Current Time Label includes a minimize/maximize button that allows you to hide or
display the label.

When you select an object in awindow displaying the Current Time label, you can jump to the
previous or next transition for that object, with respect to the current time, by clicking the Find
Previous or Find Next button.

To change the display from showing the Current Time to showing the Now time (default), or
vice versa, click on the time display in the Current Time label to open a drop down menu
(Figure 1-21) or select View > Time M ode.

Figure 1-21. Enter Current Time Value

Hil =]
T# @ 2025 nz k=~

O Mow (2,820 ns)
v @ Current Time (2025 ns)

| EnterValue x|

Change Current Time to:
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Window-specific Menu

Chapter 2
Menus

The main window menu bar is dynamic based on which window is selected, resulting in some
menu items changing name or becoming unavailable (greyed out). This section describes the
menu items at the highest-possible level.

Window-specific Menu

Every window has a window-specific menu that appears in the menu bar between the Add and
Tools menus.

The menu options available pertain only to that window and are described in the window-
specific section of the chapter “Window Reference”.

ModelSim GUI Reference Manual, v10.3a
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File Menu
File Menu
Table 2-1. File Menu — Item Description
Menu Item Description
New ® Folder — create a new folder in the current directory
® Source — create anew VHDL, Verilog or other sourcefile
® Project — create a new project
® Library — create anew library and mapping
® Debug Archive — archive debug data for post-simulation
analysis. Refer to the archive write command for more
information.
[ )
Open Open afile of any type.
Load ® Macro File— load and run amacro file (.do or .tcl)
® Debug Archive — load archived debug data for post-
simulation analysis. Refer to the archive load command for
more information.
Close Close an opened file
Import ® Library — import FPGA libraries
®* EVCD — import an extended VCD file previoudly created
with the Model Sim Waveform Editor. Thisitem is enabled
only when aWave window is active
®* Memory Data— initialize amemory by reloading a
previously saved memory file.
¢ Column Layout — apply apreviously saved column layout
to the active window
[ )
Export ® Waveform — export a created waveform
® Tabular list — writes List window datato afilein tabular
format
® Event list — writes List window datato afile as a series of
transitions that occurred during simulation
® TSSI list — writes List window datato afilein TSS|
format
® |mage — saves an image of the active window
®* Memory Data— saves data from the selected memory in
the Memory List window or an active Memory Data
window to atext file
¢ Column Layout — saves a column layout from the active
window
[ ]
* HTML — opens up adialog where you can specify the
name of an HMTL file and the directory whereit is saved

40 ModelSim GUI Reference Manual, v10.3a



Menus
File Menu

Table 2-1. File Menu — Item Description (cont.)

Menu Item Description

Save These menu items change based on the active window.
Save as

Report Produce atextual report based on the active window

Change Directory

Opens a browser for you to change your current directory. Not
available during asimulation, or if you have a dataset open.

Use Source

Specifies an adternative file to use for the current sourcefile.
This mapping only exists for the current simulation. This
option is only available from the Structure window.

Source Directory

Control which directories are searched for source files.

Datasets

Manage datasets for the current session.

Environment Set up how different windows should be updated, by dataset,
process, and/or context. Thisis only available when the
Structure, Locals, Processes, and Objects windows are active.
Page Setup Manage the printing of information from the selected window.
Print

Print Postscript

Recent Directories

Display alist of recently opened working directories

Recent Projects

Display alist of recently opened projects

Close Window

Close the active window

Quit

Quit the application
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Edit Menu

Table 2-2. Edit Menu — Item Description

Menu Item Description

Undo Alter your previous edit in a Source window.

Redo

Cut Use or remove selected text.

Copy

Paste

Delete Remove an object from the Wave and List windows

Clear Clear the Transcript window

Select All Change the selection of itemsin awindow

Unselect All

Expand Expand or collapse hierarchy information

Goto Goto a specific line number in the Source window

Find Open the find toolbar. Refer to the section “Find and Filter
Functions’ for more information

Replace Find and replace text in a Source window.

Signal Search Search the Wave or List windows for a specified value, or the
next transition for the selected object

Find in Files search for text in saved files

Previous Coverage Miss
Next Coverage Miss

Find the previous or next line with missed coverage in the
active Source window

View Menu
Table 2-3. View Menu — Item Description

Menu Item Description

window name Displays the selected window

New Window Open additional instances of the Wave, List, or Dataflow
windows

Sort Change the sort order of the Wave window

Filter Filters information from the Objects and Structure windows.

Justify Change the alignment of data in the selected window.

Properties Displaysfile property information from the Files or Source
windows.
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Compile Menu

Table 2-4. Compile Menu — Item Description

Menu [tem

Description

Compile

Compile sourcefiles

Compile Options

Set various compile options.

Compile All Compile adl filesin the open project. Disabled if you don’t
have a project open

Compile Selected Compilethe files selected in the project tab. Disabled if you
don’t have a project open

Compile Order Set the compile order of the filesin the open project. Disabled

if you don’t have a project open

Compile Report

report on the compilation history of the selected file(s) in the
project. Disabled if you don’t have a project open

Compile Summary

report on the compilation history of all filesin the project.
Disabled if you don’t have a project open

Simulate Menu

Table 2-5. Simulate Menu — Item Description

Menu item

Description

Design Optimization

Open the Design Optimization dialog to configure simulation
optimizations

Start Simulation

Load the selected design unit

Runtime Options

Set various simulation runtime options

Run

® Run <default>— run simulation for one default run length;

change the run length with Simulate > Runtime Options,

or use the Run Length text box on the tool bar

Run -All — run ssimulation until you stop it

Continue — continue the simulation

Run -Next — run to the next event time

Step — single-step the ssimulator

Step -Over — execute without single-stepping through a

subprogram call

® Restart — reload the design elements and reset the
simulation time to zero; only design elements that have
changed are reloaded; you specify whether to maintain
various objects (logged signals, breakpoints, etc.)

Break

Stop the current simulation run
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Table 2-5. Simulate Menu — Item Description (cont.)

Menu item

Description

End Simulation

Quit the current ssmulation run

44
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Add Menu
Table 2-6. Add Menu — Item Description

Menu Item Description

To Wave Add information to the Wave window

ToList Add information to the List window

ToLog Add information to the Log file

To Dataflow Add information to the Dataflow window

Window Pane Add an additional pane to the Wave window. Y ou can remove
this pane by selecting Wave > Delete Window Pane.

Tools Menu
Table 2-7. Tools Menu — Item Description

Menu Item Description

Breakpoints Manage breakpoints

Trace Perform signal trace actions.

Dataset Snapshot Enable periodic saving of simulation datato a .wif file.

Tcl Execute or debug a Tcl macro.

Wildcard Filter Refer to the section “Using the WildcardFilter Preference
Variable” for more information

Edit Preferences Set GUI preference variables. Refer to the section “ Simulator
GUI Preferences’ for more information.

Layout Menu
Table 2-8. Layout Menu — Item Description

Menu Item Description

Reset Reset the GUI to the default appearance for the selected layout.

Save Layout As Save your reorganized view to a custom layout. Refer to the
section “Customizing the Simulator GUI Layout” for more
information.

Configure Configure the layout-specific behavior of the GUI. Refer to the
section “ Configure Window Layouts Dialog Box” for more
information.
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Table 2-8. Layout Menu — Item Description (cont.)

Menu Item Description
Delete Delete a customized layout. Y ou can not delete any of the five
standard layouts.

Select a standard or customized layout.

layout name
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Bookmarks Menu

Table 2-9. Bookmarks Menu — Item Description

Menu Item Description
Add Clicking this button bookmarks the current view of the Wave
window.
Add Custom Opens the New Bookmark dialog box.
Manage Opens the Manage Bookmarks dialog box.
Delete All ® Active Window Only
* All Windows.
Reload from File ® Active Window Only
* All Windows.

Window Menu

Table 2-10. Window Menu — Item Description

Menu Item Description

Cascade Arrange all undocked windows. These options do not impact

Tile Horizontally any docked windows.

Tile Verticaly

Icon Children Minimize (Icon) or Maximize (Deicon) undocked windows.

Icon All These options do not impact any docked windows.

Deicon All

Show Toolbar Toggle the appearance of the Toolbar frame of the Main
window

Show Window Headers | Toggle the appearance of the window headers. Note that you

will be unable to rearrange windows if you do not show the
window headers.

FocusFollowsM ouse

Mouse pointer makes window active when pointer hoversin
the window briefly. Refer to Selecting the Active Window for
more information.

Toolbars Toggle the appearance of available toolbars. Similar behavior
to right-clicking in the toolbar frame.

window name Make the selected window active.

Windows Display the Windows dialog box, which allowsyou to activate,

close or undock the selected window(s).
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Help Menu

Table 2-11. Help Menu — Item Description

Menu Item Description
About Display Model Sim application information.
Release Notes Display the current Release Notes in the Model Sim Notepad

editor. Y ou can find past release notesin the
<install_dir>/docs/rIsnotes/ directory.

Welcome Window

Display the Important Information splash screen. By default
thiswindow is displayed on startup. Y ou can disable the
automatic display by toggling the Don’t show this dialog
again radio button.

Command Completion

Toggles the command completion dropdown box in the
transcript window.

When you start typing a command at the Transcript prompt, a
dropdown box appears which lists the available commands
matching what has been typed so far. Y ou may use the Up and
Down arrow keys or the mouse to select the desired command.
When a unique command has been entered, the command
usage is presented in the drop down box.

Register File Types

Associate files types (such as .v, .sv, .vhd, .do) with the
product. These associations are typically made upon install, but
this option allows you to update your system in case changes
have been made since installation.

ModelSim Open the HTML -based portal for all PDF and HTML
Documentation - documentation.

InfoHub

ModelSim Open the PDF-based portal for the most commonly used PDF

Documentation - PDF
Bookcase

documents.

Tcl Help Open the Tcl command reference (man pages) in Windows
help format.

Tcl Syntax Open the Tcl syntax documentation in your web browser.

Tcl Man pages Open the Tcl/Tk manual in your web browser.

Technotes Open atechnical note in the Model Sim Notepad editor.
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Chapter 3
Toolbars

The Main window contains atoolbar frame that displays context-specific toolbars. The
following sections describe the toolbars and their associated buttons.

Y ou can determine the name of atoolbar in the GUI by right-clicking on the toolbar and looking
for the bolded name in the pop-up menu.

Bookmarks Toolbar

The Bookmark toolbar allows you to manage your bookmarks of the Wave window

Figure 3-1. Bookmarks Toolbar

33 3

Table 3-1. Bookmarks Toolbar Buttons

Button | Name Shortcuts Description
: Add Command Wavewindow | Clicking this button
ETEJ * | Bookmark only: bookmark add wave bookmarks the current view of

Menu Wave window only: | the active window.
Add >ToWave>
Bookmark Click and hold the button to
open a drop down menu with
the following options:

® Add Current View

® Add Custom ...

® Set Default Action

: Delete All CommandWave window Removes all bookmarks, after
I'-_:a Bookmarks | only: bookmark delete wave | prompting for your
-al confirmation.

Click and hold the button to
open a drop down menu with
the following options:

® Active Window

* All Windows
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Table 3-1. Bookmarks Toolbar Buttons (cont.)

Button | Name Shortcuts Description
: Manage None Displays the Manage

I'__:.: Bookmarks Bookmarks dialog box.

Reload from | None Reloads bookmarks from the
"—E] - | File bookmarks.do file.

¢ Set Default Action

Jump to CommandW ave window Displays bookmarks grouped

I':El Bookmark | only: bookmark goto wave | by window. Select the
<name> bookmark you want to display.

Compile Toolbar

The Compile toolbar provides access to compile and simulation actions.

Figure 3-2. Compile Toolbar

Table 3-2. Compile Toolbar Buttons

Button | Name Shortcuts Description

Compile Command: vcom or viog Opens the Compile Source
@ Menu: Compile> Compile | Filesdialog box.

Compile All | Command: vcom or viog Compilesal filesin the open

|'H'| Menu: Compile> Compile | project.
all
H Simulate Command: vsim Opens the Start Simulation
ﬁ Menu: Simulate > Start dialog box.
Simulation
Break Menu: Simulate > Break Stop a compilation,
E Hotkey: Break elaboration, or the current

simulation run.

Coverage Toolbar

The Coverage toolbar provides tools for filtering code coverage data in the Structure and
Instance Coverage windows.
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Figure 3-3. Coverage Toolbar

Button

Coverage Toolbar
$+ T T Threshald | s 2= ? X =

Name

Enable
14

Filtering

I

Shortcuts

Table 3-3. Coverage Toolbar Buttons
None

Description

Threshold
Above

.

Threshold
Below

None

Enables display filtering of
coverage statistics in the
None

Structure and Instance
Coverage windows.

mil Filter
b

Threshold

None

Displaysall coverage statistics

above the Filter Threshold for
selected columns.

Statement

None

Displaysall coverage statistics

below the Filter Threshold for
selected columns

Branch

Specifies the display coverage
percentage for the selected
coverage columns

None

Condition

Appliesthe display filter to all
Statement coverage columnsin
the Structure and Instance
Coverage windows.

None

Expression

None

Appliesthe display filter to all
Branch coverage columnsin

the Structure and Instance
Coverage windows.

Toggle

Appliesthe display filter to al
Condition coverage columnsin
the Structure and Instance
Coverage windows.

None

Appliesthe display filter to al
Expression coverage columns

in the Structure and Instance
Coverage windows.
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Dataflow Toolbar
The Dataflow toolbar provides access to various tools to use in the Dataflow window.

Figure 3-4. Dataflow Toolbar
| Je *H-B*BE-rEéﬂ|

Table 3-4. Dataflow Toolbar Buttons

Button | Name Shortcuts Description
Tracelnput | Menu: Tools> Trace > Move the next event cursor to
J-"' Net to Event | Trace next event the next input event driving the
selected output.
Trace Set Menu: Tools> Trace > Jump to the source of the
d= Trace event set selected input event.
Trace Reset | Menu: Tools> Trace > Return the next event cursor to
- Trace event reset the selected output.
TraceNetto | Menu: Tools> Trace > Step back to the last driver of
ﬁ Driver of X | TraceX an unknown value.
Expand Net | None Display driver(s) of the
aq- to all Drivers selected signal, net, or register.
= Expand Net | None Display driver(s) and reader(s)
j.E to all Drivers of the selected signal, net, or
and Readers register.
Expand Net | None Display reader(s) of the
+E to all Readers selected signal, net, or register.
Show Wave | Menu: Dataflow > Display the embedded wave
|.| Show Wave viewer pane.

Help Toolbar

The Help toolbar provides away for you to search the HTML documentation for a specified
string. The HTML documentation will be displayed in aweb browser.
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Figure 3-5. Help Toolbar
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Table 3-5. Help Toolbar Buttons

Button Name Shortcuts Description
Search None A text entry box for your
Help | Documentation search string.
Search Hotkey: Enter Activates the search for the
ﬁ Documentation term you entered into the text
entry box.

Layout Toolbar

The Layout toolbar allowsyou to select a predefined or user-defined layout of the graphical user
interface. Refer to the section * Customizing the Simulator GUI Layout” for more information.

Figure 3-6. Layout Toolbar

J Layout [sipnlate j ‘

Table 3-6. Layout Toolbar Buttons
Button Name Shortcuts Description

I.i J Change Menu: Layout > A dropdown box that allows
Aimulate Wi ) oo <layoutName> you to select a GUI layout.
* NoDesign

* Simulate

* Coverage

* VMgmt

Memory Toolbar

The Memory toolbar provides access to common functions.

Figure 3-7. Memory Toolbar

% Goko: li ‘
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Table 3-7. Memory Toolbar Buttons

Button Name Shortcuts Description
Split Screen | Menu: Memory > Splits the memory window.
% Split Screen
. Goto Address Highlights the first element of
Gotas | the specified address.

Mode Toolbar

The Mode toolbar provides access to tools for controlling the mode of mouse navigation.

Figure 3-8. Mode Toolbar
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Table 3-8. Mode Toolbar Buttons

Button | Name Shortcuts Description
Select Mode | Menu: Dataflow > Set the left mouse button to
&_ Mouse M ode> Select M ode | select mode and middle mouse
—_— button to zoom mode.
= Zoom Mode | Menu: Dataflow > Set |eft mouse button to zoom
n_nl Mouse Mode > Zoom Mode | mode and middle mouse
—— button to pan mode.
Pan Mode Menu: Dataflow > Set left mouse button to pan
$ Mouse Mode > Pan Mode | mode and middle mouse
E— button to zoom mode.
Two Cursor | Menu: Wave > Sets two cursorsin Wave
L L Mode Mouse Mode > Two Cursor | window. First cursor moves
with LM B, second cursor with
MMB.
oy Edit Mode Menu: Wave or Dataflow > | Set mouse to Edit Mode,
I—L: Mouse Mode > Edit Mode | where you drag the left mouse
button to select arange and
drag the middle mouse button
to zoom.
Stop None Halt any drawing currently
H [ Drawing happening in the window.
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Objectfilter Toolbar

The Objectfilter toolbar provides filtering of design objects appearing in the Objects window.

Figure 3-9. Objectfilter Toolbar
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Table 3-9. Objectfilter Toolbar Buttons

Button | Name Shortcuts Description
View Inputs | None Changes the view of the Objects Window
I Only to show inputs.
View None Changes the view of the Objects Window
o Outputs Only to show outputs.
View Inouts | None Changes the view of the Objects Window
LiC] | only to show inouts.
i ViesInternal | None Changes the view of the Objects Window
1 Signals to show Internal Signals.
Reset All None Clears thefiltering of Objects Window
ALL| |Filters entries and displays all objects.
é}" Change Filter | None Opens the Filter Objects dialog box.

Process Toolbar

The Process toolbar contains three toggle buttons (only one can be active at any time) that
controls the view of the Process window.

Figure 3-10. Process Toolbar

| oo 2|

ModelSim GUI Reference Manual, v10.3a 55



Toolbars
Profile Toolbar

Table 3-10. Process Toolbar Buttons

Button | Name Shortcuts Description
View Active | Menu: Process > Active Changes the view of the
'ﬁ Processes Processes Window to only
—_— show active processes.
View Menu: Process > In Region | Changesthe view of the
'ﬁ Processesin Processes window to only
—— | Region show processes in the active
region.
View Menu: Process > Design Changes the view of the
Processes for Processes window to show
the Design processes in the design.

View Process | Menu: Process > Hierarchy | Changes the view of the
hierarchy Processes window to show
process hierarchy.

5| [

Profile Toolbar

The Profile toolbar provides access to tools related to the profiling windows (Ranked, Calltree,
Design Unit, and Structural.

Figure 3-11. Profile Toolbar
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Table 3-11. Profile Toolbar Buttons

Button Name Shortcuts Description
— Collapse Menu: Tools > Profile > Toggle the reporting for
T—; Sections Collapse Sections collapsed processes and
functions.
o | | Profile None Display perfqrmance and
| 0. 10 El Cutoff memory profile data equal to
or greater than set percentage.
Refresh None Refresh profile performance
‘ﬂ Profile Data and memory data after
changing profile cutoff.
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Table 3-11. Profile Toolbar Buttons (cont.)

Button Name Shortcuts Description
Save Profile | Menu: Tools> Profile> Save profile data to output file
E Results Profile Report (prompts for file name).

Schematic Toolbar

The Schematic toolbar provides access to tools for manipulating highlights and signalsin the
Dataflow and Schematic windows.

Figure 3-12. Schematic Toolbar
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Table 3-12. Schematic Toolbar Buttons

Button Name Shortcuts Description
Remove All | Menu: Dataflow > Clear the green highlighting
E - Highlights Remove Highlight identifying the path you've
or traversed through the design.
Schematic > Edit > Remove
Highlight Click and hold the button to
open a drop down menu with
the following options:
* Remove All Highlights
® Remove Selected
Highlights
® Set Default Action
Delete Menu: Delete the selected signal.
K = | Content Dataflow > Delete
or Click and hold the button to
Schematic > Edit > Delete | open adrop down menu with
Schematic > Edit > Delete | the following options:
All ® Delete Selected
® Delete All
® Set Default Action
Regenerate | Menu: Dataflow > Redraws the current schematic
{E‘l Regenerate view to better take advantage
or of the available space. For
Schematic > Edit > example, after adding or
Regenerate removing elements.
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Simulate Toolbar

The Simulate toolbar provides various tools for controlling your active simulation.

| %l & e BF o s AR AT R B

Figure 3-13. Simulate Toolbar

Table 3-13. Simulate Toolbar Buttons

Menu: Simulate > Run >
Continue

Button Name Shortcuts Description
Source None Toggles display of hyperlinks
%| Hyperlinking in design sourcefiles.
Environment | Command: env .. Changes your environment up
f Up Menu: File > Environment | one level of hierarchy.
Environment | Command: env -back Change your environment to
‘h Back Menu: File> Environment | its previous location.
Environment | Command: env -forward Change your environment
* Forward Menu: File> Environment | forward to a previously
selected environment.
- Restart Command: restart Reload the design elements
E' Menu: Simulate > Run > andreset thesimulation timeto
Restart zero, with the option of
maintaining various settings
and objects.
Run Length | Command: run Specify the run length for the
100 ns = Menu: Simulate > current simulation.
Runtime Options
= Run Command: run Run the current simulation for
= Menu: Simulate > Run > the specified run length.
Run default_run_length
= Continue Command: run Continue the current
= Run -continue simulation run until the end of

the specified run length or until
it hits a breakpoint or specified
break event.
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Table 3-13. Simulate Toolbar Buttons (cont.)

Button Name Shortcuts Description
Run All Command: run -all Run the current simulation
Menu: Simulate > Run > forever, or until it hitsa
Run -All breakpoint or specified break
event.
Break Menu: Simulate > Break Immediate stop of a
E Hotkey: Break compilation, elaboration, or
simulation run. Similar to
hitting a breakpoint if the
simulator isin the middle of a
process.
Stop -sync None Stop simulation the next time

time/deltais advanced.

w
il

Performance | Menu: Tools> Profile >

Enable collection of statistical

Profiling Performance performance data.
Im Memory Menu: Tools > Profile > Enable collection of memory
d Profiling Memory usage data.
Edit Menu: Tools > Breakpoint | Enable breakpoint editing,
'TI_."E Breakpoints loading, and saving.

Source Toolbar

The Source toolbar allows you to perform several activities on Source windows.

Figure 3-14. Source Toolbar
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Table 3-14. Source Toolbar Buttons

Button Name Shortcuts Description

Previous None Jump to previous line with
::HH Zero Hits zZero coverage.

Next Zero None Jump to next line with zero
h}l:: Hits coverage.
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Table 3-14. Source Toolbar Buttons (cont.)

Button Name Shortcuts Description
Clear Menu: Source > Removes any bookmarksin
ﬂ Bookmarks | Clear Bookmarks the active sourcefile.

Standard Toolbar

The Standard toolbar contains common buttons that apply to most windows.
Figure 3-15. Standard Toolbar
J-2 @& BRI O-#E

Table 3-15. Standard Toolbar Buttons

Button | Name Shortcuts Description
New File Menu: File > New > Source | Opens anew Source text file.
_-l - Theicon changesto reflect the

default file type set with the
Set Default Action menu pick
from the dropdown menu.

Click and hold the button to
open a dropdown menu with
the following options:

* VHDL
* Verilog
® SystemC
® SystemVerilog
* Do
® Other
® Set Default Action
Iil,“ Open Menu: File > Open Opens the Open File dialog
Save Menu: File > Save Savesthe contents of the active
E window or
Saves the current wave
window display and signal
preferences to amacro file
(DOfie).
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Table 3-15. Standard Toolbar Buttons (cont.)

Collapse All

Button | Name Shortcuts Description
= Reload Command: Dataset Restart | Reload the current dataset.
=3 Menu: File > Datasets
% Print Menu: File > Print Opens the Print dialog box.
Cut Menu: Edit > Cut
,;i{. Hotkey: Ctrl+x
B Copy Menu: Edit > Copy
Hotkey: Ctrl+c
Paste Menu: Edit > Paste
E Hotkey: Ctrl+v
Undo Menu: Edit > Undo
i_:] Hotkey: Ctrl+z
Redo Menu: Edit > Redo
':_: Hotkey: Ctrl+y
Add Selected | Menu: Add > to Wave Clicking adds selected objects
.__-_":| » |toWindow | Hotkey: Ctrl+w to the Wave window. Refer to
“Add Selected to Window
Button” for more information
about the dropdown menu
selections.
¢ Set Default Action
Find Menu: Edit > Find Opens the Find dialog box.
ﬂ Hotkey: Ctrl+f (Windows)
or Ctrl+s (UNIX)
F— Collapse All | Menu: Edit > Expand >
-

1. You can set the default insertion location in the Wave window from menus and hotkeys with the
PrefWave(l nsertM ode) preference variable.

Add Selected to Window Button

This button is avail able when you have selected an object in any of the following windows:
Dataflow, List, Locals, Memory, Objects, Process, Structure, Watch, and Wave windows.
Using asingle click, the objects are added to the Wave window. However, if you click-and-hold

the button you can access additional options via a dropdown menu, as shown in Figure 3-16.
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Figure 3-16. The Add Selected to Window Dropdown Menu
J'ﬁn—“ Help ﬁ“

_| Add to Wave (Insertion Point) **
_| .ﬁ.dd to Wave (Append Paint)

Add to Wave (End)

Add to Wave (Top)

Add to List
Add to Dataflow
Add to Watch

w Set Default Action *

® AddtoWave (Anchor Location) — Adds selected signals above the Insertion Point Bar
in the Pathname Pane by default.

® AddtoWave (Append Point) — Adds selected signals below the insertion pointer in the
Pathname Pane.

® Addto Wave (End) — Adds selected signals after the last signal in the Wave Window.
® AddtoWave (Top) — Adds selected signals above the first signal in the Wave window.
® AddtoList— Adds selected objects to the List Window.

® Add to Dataflow — Adds selected objects to the Dataflow Window.

® Addto Watch — Adds selected objects to the Watch Window.

® Set Default Action — Selecting one of the items from the dropdown menu sets that item
as the default action when you click the Add Selected to Window button. The title of
the selection isshown in bold typein the Add Selected to Window dropdown menu and
two asterisks ( **) are placed after the title to indicate the current default action. For
example, Add to Wave (Anchor Location) isthe default action in Figure 3-16.

® You can change the default

Step Toolbar

The Step toolbar alows you to step through your source code.

Figure 3-17. Step Toolbar
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Table 3-16. Step Toolbar Buttons

Step

Button | Name Shortcuts Description
* Step Into Command: step Step the current simulation to
- Menu: Simulate > Run > the next statement.

ﬁ Step Over

Command: step -over
Menu: Simulate > Run >
Step -Over

Execute HDL statements,
treating them as simple
statements instead of entered
and traced line by line.

* Step Out Command: step -out Step the current simulation out
. of the current function or
procedure.
,.r Step Into Command: step -current Step the simulation into the
8l Current current instance, process, or
thread.
Step Over Command: step -over Step the simulation over the
% Current -current current instance, process, or
thread.
Step Out Command: step -out Step the simulation out of the
T Current -current current instance, process, or

thread.

Wave Toolbar

The Wave toolbar allows you to perform specific actions in the Wave window.

Figure 3-18. Wave Toolbar
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Table 3-17. Wave Toolbar Buttons

Button

Name

Shortcuts

Description

¢ -

Show Drivers

Show Drivers
(source only)

None

Display driver(s) of the
selected signal, net, or
register in the Dataflow and
Source windows.

Display driversonly in the
Source window

The source window is not
shown if there are no
drivers.

Show Readers

Show Readers
(source only)

None

Display reader(s) of the
selected signal, net, or
register in the Dataflow
window.

Display driversonly in the
Source window

The source window is not
shown if there are no
readers.

Add Menu: Add > To Wave | Createsagroup labeled
3?’ Contributing | > Contributing Signals | Contributors. <name>,
Signals where <name> is the name
of the currently selected
signal. This group contains
the inputs to the process
driving <name>.
= Wave Search | Click on the box when in | Text-entry box for the search
Search: [ ¥ | Box transition mode (Falling | string. Dropdown button
Edge, Rising Edge, or displays previous search
Any Transition) to cycle | strings. Long search times
through these options. result in the display of astop
icon you can use to cancel
the search.
Search Previous: Shift+Enter Searches for the next
cﬁﬁ ﬂ% Previous/Next | Next: enter occurrence of the string,

either backward or forward
in time, from the cursor.

64

ModelSim GUI Reference Manual, v10.3a




Toolbars
Wave Compare Toolbar

Table 3-17. Wave Toolbar Buttons (cont.)

Button Name Shortcuts Description
Search Dropdown button to:
lﬁ ’ Options ¢ Change Mode: value,

rising edge, falling edge,
or any transition.

® Digplay the Wave Signal
Search Dialog Box for
advanced search
behavior.

® Clear the value history.

Using the Wave Search Box

Y ou can use the Wave Search box to search the timeline of a selected signal for transitionsto a
specific value, or just for transitions themsel ves.

1. Select asigna in the left-hand side of the Wave window.
2. Place awave cursor where you want to begin the search.

3. Enter avauein the Wave Search box. The value must be of a compatible format type
for the signal you selected.

Alternatively you can use the Search Options button to change the mode from “value” to
Rising Edge, Falling Edge, or Any Transition. This popul ates the Wave Search box with
the selected transition type.

4. Usethe Search Reverse or Search Forward buttons to |ocate the next occurrence of the
value (or transition).

For large simulations, if the search takes along time, the Wave Search box will display a
stop icon you can click to stop the search.

Wave Compare Toolbar
The Wave Compare toolbar allows you to quickly find differences in a waveform comparison.

Figure 3-19. Wave Compare Toolbar
| R e fle 55 98 0l
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Table 3-18. Wave Compare Toolbar Buttons

Button | Name Shortcuts Description

Find First None Find thefirst differencein a
%'ﬂ Difference waveform comparison

Find None Find the previous annotated
g"' Previous difference in awaveform

Annotated comparison

Difference

Find None Find the previous differencein
%"' Previous awaveform comparison

Difference

Find Next None Find the next differencein a
ﬁ Difference waveform comparison

Find Next None Find the next annotated
ﬁ Annotated difference in awaveform

Difference comparison

Find Last None Find the last differencein a
ﬁ Difference waveform comparison

Wave Cursor Toolbar

The Wave Cursor toolbar provides various tools for manipulating cursors in the Wave window.

Figure 3-20. Wave Cursor Toolbar
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Table 3-19. Wave Cursor Toolbar Buttons

Button | Name Shortcuts Description

I Insert Cursor | None Addsanew cursor to the active
é_ Wave window.

o Delete Menu: Wave > Deletes the active cursor.
'£ Cursor Delete Cursor
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Table 3-19. Wave Cursor Toolbar Buttons (cont.)

Button | Name Shortcuts Description
Find Menu: Edit > Signal Search | Moves the active cursor to the
|"' Previous Hotkey: Shift + Tab previous signal value change
Transition for the selected signal.
Find Next Menu: Edit > Signal Search | Moves the active cursor to the
"‘l Transition Hotkey: Tab next signal value change for
the selected signal.
Find Menu: Edit > Signal Search | Moves the active cursor to the
E Previous previous falling edge for the
Falling Edge selected signal.
Find Next Menu: Edit > Signal Search | Moves the active cursor to the
}_ Falling Edge next falling edge for the
selected signal.
Find Menu: Edit > Signal Search | Moves the active cursor to the
_|L: Previous previous rising edge for the
Rising Edge selected signal.
Find Next Menu: Edit > Signal Search | Moves the active cursor to the
__j‘_ Rising Edge next rising edge for the

selected signal.

Wave Edit Toolbar

The Wave Edit toolbar provides easy access to tools for modifying an editable wave.

Figure 3-21. Wave Edit Toolbar
| e | i R s T B

Table 3-20. Wave Edit Toolbar Buttons

.Ij;‘..-

Wave Editor > Delete Edge
Command: wave edit delete

Button | Name Shortcuts Description
Insert Pulse | Menu: Wave > Insert atransition at the
|-L|« Wave Editor > Insert Pulse | selected time.
Command: wave edit
insert_pulse
Delete Edge | Menu: Wave > Delete the selected transition.

ModelSim GUI Reference Manual, v10.3a

67



Toolbars

Wave Expand Time Toolbar

Table 3-20. Wave Edit Toolbar Buttons (cont.)

Button | Name Shortcuts Description
- Invert Menu: Wave > Invert the selected section of
J-L‘-l_r Wave Editor > Invert the waveform.
Command: wave edit invert
Mirror Menu: Wave > Mirror the selected section of
mllﬂ Wave Editor > Mirror the waveform.
Command: wave edit mirror
Change Menu: Wave > Change the value of the
]Pﬁq Vaue Wave Editor > Value selected section of the
Command: wave edit waveform.
change _value
.... | Stretch Edge | Menu: Wave > Move the selected edge by
]ji-} Wave Editor > Stretch Edge | increasing/decreasing
Command: wave edit stretch| waveform duration.
Move Edge | Menu: Wave > Move the selected edge
-lJ_ Wave Editor > Move Edge | without increasing/decreasing
ik Command: wave edit move | waveform duration.
1r.. |ExtendAll Menu: Wave > Increase the duration of al
%‘:’ Waves Wave Editor > editable waves.

Extend All Waves
Command: wave edit extend

Wave Expand Time Toolbar

The Wave Expand Time toolbar provides access to enabling and controlling wave expansion

features.
Figure 3-22. Wave Expand Time Toolbar
| nmmr oo
Table 3-21. Wave Expand Time Toolbar Buttons

Button | Name Shortcuts Description

Expanded Menu: Wave > Expanded turns off the expanded time

| Time Off Time > Off display (default mode)

Expanded Menu: Wave > Expanded displays delta time steps
_I_ Time Deltas | Time > Deltas Mode
—— | Mode
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Table 3-21. Wave Expand Time Toolbar Buttons (cont.)

Button | Name Shortcuts Description
Expanded Menu: Wave > Expanded displays event time steps
. Time Events | Time > Events Mode
Mode
Expand All | Menu: Wave > Expanded expands simulation time over
. Time Time > Expand All the entire simulation time
range, from O to current time
Expand Time | Menu: Wave > Expanded expands simulation time at the
—I_ at Active Time > Expand Cursor simulation time of the active
Cursor cursor
Collapse All | Menu: Wave > Expanded collapses ssimulation time over
| Time Time > Collapse All entire simulation time range
Collapse Menu: Wave > Expanded collapses simulation time at
|_ Time at Time > Collapse Cursor the simulation time of the
= Active active cursor
Cursor

Zoom Toolbar

The Zoom toolbar allows you to change the view of the Wave window.

Figure 3-23. Zoom Toolbar

|aqen.am

Table 3-22. Zoom Toolbar Buttons

@

Zoom Full
Hotkey: f or F

Button | Name Shortcuts Description
Zoom In Menu: Wave > Zoom > Zoomsin by afactor of 2x.
':ﬂ ZoomIn
Hotkey: i, 1, or +
Zoom Out Menu: Wave > Zoom > Zooms out by afactor of 2x.
'E% Zoom Out
Hotkey: o, O, or -
Zoom Full Menu: Wave > Zoom > Zooms to show the full length

of the ssmulation.
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Table 3-22. Zoom Toolbar Buttons (cont.)

Button | Name Shortcuts Description
Zoomin Menu: Wave > Zoom > Zoomsin by afactor of 2x,
IJ_E% on Active Zoom Cursor centered on the active cursor.
Cursor Hotkey: cor C
Zoom Zoomsin or out to show the
él% between range between the last two
Cursors selected cursors.
Zoom Other Changesthe view in additional
EQ Window instances of the Wave window
to match the view of the active
Wave window.

Toolbar Tabs

The default GUI toolbar format of multiple separate toolbars can be replaced with arow of tabs
contai ning buttons grouped into common tasks such as editing, debugging, coverage, and so
forth. The buttons are context driven and either operative or greyed out depending on which
window is currently active. To change the GUI to Toolbar Tab format, set

prefToolbar (newEnabled) to 1 (select Tools > Edit Preferences, By Name tab, and expand
the Toolbar object). Y ou must restart the application for the change to take effect. On restarting
the application, the GUI displays the toolbar tabs (Figure 3-24).
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Figure 3-24. Toolbar Tabs and Overflow Menu
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=g Add Contributing Signals

v _| Expanded Time Off
_I_Eupanded Time Deltas Mode
.Eupanded Time Events Mode

. Expand All Time
_r Expand Time At Active Cursar
[ Collapse All Time
[ Collapse Time At Active Cursor

gﬂ Find first difference
gt Find previous annotated difference
gt Find previous difference

ﬁ Find next difference

i@ Find next annotated difference

If the application window istoo narrow to accommodate all of the buttons and widgets assigned
toit, an overflow button will appear on the right edge of the toolbar. Clicking the overflow
button opens a drop-menu (Figure 3-24) which displays the remaining buttons. Y ou can change
the overflow from a drop-menu to a scrolling menu by setting pref T oolbar (newScr ollable) to
1

The following sections describe the tabs and their associated buttons.

Compile Toolbar Tab

The Compile Toolbar Tab provides access to compile actions.

Figure 3-25. Compile Tab
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Table 3-23. Compile Toolbar Tab Buttons

Button | Name Shortcuts Description
Compile Command: vcom or viog Opens the Compile Source
@ Menu: Compile> Compile | Filesdialog box.
ferazas Compile All | Command: vcom or viog Compilesal filesin the open
|‘H'| Menu: Compile> Compile | project.
all
= Simulate Command: vsim Opens the Start Simulation
ﬁ Menu: Simulate > Start dialog box.
Simulation
Break Menu: Simulate > Break Stop a compilation,
E Hotkey: Break elaboration, or the current
simulation run.
.. | Compile Out Recompileif changes have
ﬂl of Date been made to any sourcefiles.

Coverage Toolbar Tab

The Coverage toolbar tab provides tools for filtering code coverage data in the Structure and

Instance Coverage windows.

Figure 3-26. Coverage Tab
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Table 3-24. Coverage Toolbar Tab Buttons

Button Name Shortcuts Description

11 Enable Filtering | None Enables display filtering of

= coverage statisticsin the
Structure and Instance
Coverage windows.

Threshold None Displays all coverage statistics

; Above above the Filter Threshold for

selected columns.
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Table 3-24. Coverage Toolbar Tab Buttons (cont.)

Button Name Shortcuts Description
S Threshold None Displays all coverage statistics
T Below below the Filter Threshold for
selected columns
Ii il Filter Threshold | None Specifies the display coverage
1007 percentage for the selected

coverage columns

Statement None Appliesthe display filter to all
Statement coverage columnsin
the Structure and Instance
Coverage windows.

Branch None Appliesthe display filter to all
-ﬂ Branch coverage columnsin
the Structure and Instance
Coverage windows.

) Condition None Appliesthe display filter to all

Condition coverage columnsin
the Structure and Instance
Coverage windows.

Expression None Appliesthe display filter to all
I Expression coverage columns

in the Structure and Instance
Coverage windows.

Toggle None Appliesthe display filter to all
= Toggle coverage columnsin
the Structure and Instance
Coverage windows.

Previous Zero None Jump to previous line with
}l::" Hits Zero coverage.
Next Zero Hits | None Jump to next line with zero
.'}l:: coverage.
pracison [ Set Precision for | Menu: Verification A text entry box that allows
fEEEan VMgmt Browser > you to control the precision of
Set Precision the datain the Verification
Browser window.
- Restore Default Restores the precision to the
Ay Precision default value (2).
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Debug Toolbar Tab

The Debug toolbar tab provides tools for debugging in various windows.

Figure 3-27. Debug Tab
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Table 3-25. Debug Toolbar Tab Buttons

Button Name Shortcuts Description
Zoom In Menu: Wave > Zoom > | Zoomsin by afactor of 2x.
':ﬂ ZoomIn
Hotkey: i, I, or +
Zoom Out Menu: Wave> Zoom > | Zooms out by afactor of 2x.
'El Zoom Out
Hotkey: o, O, or -
Zoom Full Menu: Wave>Zoom> | Zoomsto show thefull length
% Zoom Full of the ssimulation.
Hotkey: f or F
Zoomin Menu: Wave > Zoom > Zoomsin by afactor of 2x,
élq on Active Zoom Cursor centered on the active cursor.
Cursor Hotkey: cor C
Zoom Zoomsin or out to show the
IJ__IE between range between the last two
Cursors selected cursors.
Zoom Other Changes the view in
%a' Window additional instances of the
Wave window to match the
view of the active Wave
window.
Source None Togglesdisplay of hyperlinks
%| Hyperlinking in design sourcefiles.
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Table 3-25. Debug Toolbar Tab Buttons (cont.)

Button Name Shortcuts Description
1 Insert Cursor | None Adds a new cursor to the
,él active Wave window.
o Delete Menu: Wave > Deletes the active cursor.
lél Cursor Delete Cursor
Find Menu: Edit > Signal Moves the active cursor to
|"' Previous Search the previous signal value
Transition Hotkey: Shift + Tab change for the selected
signal.
Find Next Menu: Edit > Signal Moves the active cursor to
"‘l Transition Search the next signal value change
Hotkey: Tab for the selected signal.
Find Menu: Edit > Signal Moves the active cursor to
E Previous Search the previous falling edge for
Falling Edge the selected signal.
Find Next Menu: Edit > Signal Moves the active cursor to
__;l"|_ Falling Edge | Search the next falling edge for the
selected signal.
Find Menu: Edit > Signal Moves the active cursor to
_1: Previous Search the previous rising edge for
Rising Edge the selected signal.
Find Next Menu: Edit > Signal Moves the active cursor to
__d‘_ Rising Edge | Search the next rising edge for the
selected signal.
Select Mode | Menu: Dataflow > Set the left mouse button to
& Mouse M ode > Select select mode and middle
— Mode mouse button to zoom mode.
= Zoom Mode | Menu: Dataflow > Set | eft mouse button to zoom
u_.l Mouse Mode > Zoom mode and middle mouse
—_— Mode button to pan mode.
Pan Mode Menu: Dataflow > Set |eft mouse button to pan
4$i Mouse M ode > Pan Mode | mode and middle mouse
E— button to zoom mode.
Two Cursor | Menu: Wave > Sets two cursorsin Wave
l l Mode Mouse M ode > Two window. First cursor moves
—_— Cursor with LMB, second cursor
with MMB.
Stop None Halt any drawing currently
H [» Drawing happening in the window.
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Table 3-25. Debug Toolbar Tab Buttons (cont.)

Button Name Shortcuts Description
Show Drivers| None Display driver(s) of the
3¢ ~ selected signal, net, or
register in the Dataflow and
Source windows.
Display driversonly in the
Show Drivers Source window
(source only)
The source window is not
shown if there are no drivers.
Show None Display reader(s) of the
"E M Readers selected signal, net, or
register in the Dataflow
window.
Display driversonly in the
Show Source window
Readers
(source only) The source window is not
shown if there are no readers.
Add Menu: Add > To Wave > | Creates agroup labeled
g?’ Contributing | Contributing Signals Contributors: <name>,
Signals where <name> is the name of
the currently selected signal.
This group contains the
inputs to the process driving
<name>.
Expanded Menu: Wave > Expanded | turns off the expanded time
| Time Off Time > Off display (default mode)
Expanded Menu: Wave > Expanded | displays deltatime steps
_I_ Time Deltas | Time > Deltas Mode
—_— Mode
Expanded Menu: Wave > Expanded | displays event time steps
. Time Events | Time > Events Mode
—_— Mode
Expand All | Menu: Wave > Expanded | expands simulation time over
. Time Time > Expand All the entire simulation time
range, from O to current time
Expand Time | Menu: Wave > Expanded | expands simulation time at
r at Active Time > Expand Cursor the ssimulation time of the
= Cursor active cursor
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Table 3-25. Debug Toolbar Tab Buttons (cont.)

t

Button Name Shortcuts Description
Collapse All | Menu: Wave > Expanded | collapses simulation time
| Time Time > Collapse All over entire smulation time
range
Collapse Menu: Wave > Expanded | collapses simulation time at
|_ Time at Time > Collapse Cursor | the simulation time of the
- Active active cursor
Cursor
Find First None Find thefirst differencein a
g’" Difference waveform comparison
Find None Find the previous annotated
g"' Previous difference in awaveform
Annotated comparison
Difference
Find None Find the previous difference
g"' Previous in awaveform comparison
Difference
Find Next None Find the next differencein a
ﬁ Difference waveform comparison
Find Next None Find the next annotated
ﬁ Annotated difference in awaveform
Difference comparison
Find Last None Find the last differencein a
ﬁ Difference waveform comparison
i+ — Wave Search | Click on the box whenin | Text-entry box for the search
Search: [ || Box transition mode (Falling | string. Dropdown button
Edge, Rising Edge, or Any | displays previous search
Transition) to cycle strings. Long search times
through these options. result in the display of a stop
icon you can useto cancel the
search.
Search Previous. Shift+Enter Searches for the next
ﬁh '!ﬁ:- Previous/Nex | Next: enter occurrence of the string,

elther backward or forwardin
time, from the cursor.
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Table 3-25. Debug Toolbar Tab Buttons (cont.)

Button Name Shortcuts Description
Search Menu: Edit > Signal Dropdown button to:
ﬁfﬁ Options Search ® Change Mode: value,

rising edge, falling edge,
or any transition.

® Display the Wave Signal
Search Dialog Box for
advanced search
behavior.

® Clear the value history.

Edit Toolbar Tab

The Edit toolbar tab provides tools for modifying an editable waveform.

Figure 3-28. Edit Tab

ﬁ Edit
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Table 3-26. Edit Toolbar Tab Buttons

Button | Name Shortcuts Description
New File Menu: File > New > Source | Opens anew Source text file.
_-I - The icon changesto reflect the

default file type set with the
Set Default Action menu pick
from the dropdown menu.

Click and hold the button to
open a dropdown menu with
the following options:

* VHDL

* Verilog

* SystemC

® SystemVerilog
Do
Other
Set Default Action
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Table 3-26. Edit Toolbar Tab Buttons (cont.)

Mouse Mode > Edit Mode

Button | Name Shortcuts Description
Insert Pulse | Menu: Wave > Insert atransition at the
| -H.- Wave Editor > Insert Pulse | selected time.
Command: wave edit
insert_pulse
{;,__ Delete Edge | Menu: Wave > Delete the selected transition.
]_. Wave Editor > Delete Edge
Command: wave edit delete
. Invert Menu: Wave > Invert the selected section of
JL_T Wave Editor > Invert the waveform.
Command: wave edit invert
Mirror Menu: Wave > Mirror the selected section of
ﬂmﬂ Wave Editor > Mirror the waveform.
Command: wave edit mirror
Change Menu: Wave > Change the value of the
]Pﬁq Vaue Wave Editor > Vaue sel ected section of the
Command: wave edit waveform.
change value
... | Stretch Edge | Menu: Wave > Move the selected edge by
]i;-} Wave Editor > Stretch Edge | increasing/decreasing
Command: wave edit stretch| waveform duration.
Move Edge | Menu: Wave > Move the selected edge
-lJ_ Wave Editor > Move Edge | without increasing/decreasing
Tt Command: wave edit move | waveform duration.
1r.. | ExtendAll Menu: Wave > Increase the duration of all
L | Waves Wave Editor > editable waves.
nr- Extend All Waves
Command: wave edit extend
Edit Mode Menu: Wave or Dataflow > | Set mouse to Edit Mode,

where you drag the left mouse
button to select arange and
drag the middle mouse button
to zoom.

Home Toolbar Tab

The Home toolbar tab contains common buttons that apply to most windows.
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Figure 3-29. Home Tab
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Table 3-27. Home Toolbar Tab Buttons

Button | Name

Shortcuts

Description

—~ Open

Menu: File > Open

Opens the Open File dialog

E Save

Menu: File> Save

Savesthe contents of the active
window or

Saves the current wave
window display and signal
preferences to amacro file
(DOfie).

= Reload Command: Dataset Restart | Reload the current dataset.
=) Menu: File > Datasets
% Print Menu: File > Print Opens the Print dialog box.

Cut

Menu: Edit > Cut
Hotkey: Ctrl+x

&
Copy

Menu: Edit > Copy
Hotkey: Ctrl+c

Menu: Edit > Paste
Hotkey: Ctrl+v

Undo

EPaste
P,

Menu: Edit > Undo
Hotkey: Ctrl+z

Redo
(e

Menu: Edit > Redo
Hotkey: Ctrl+y
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Table 3-27. Home Toolbar Tab Buttons (cont.)

Button | Name Shortcuts Description
Add Selected | Menu: Add > to Wave Clicking adds selected objects
\ ___‘:l = | toWindow | Hotkey: Ctrl+w to the Wave window. Refer to
“Add Selected to Window
Button” for more information
about the dropdown menu
selections. 1
® Set Default Action
Find Menu: Edit > Find Opens the Find dialog box.
ﬂ Hotkey: Ctrl+f (Windows)
or Ctrl+s (UNIX)
Environment | Command: env.. Changes your environment up
i Up Menu: File> Environment | one level of hierarchy.
Environment | Command: env -back Change your environment to
‘h Back Menu: File> Environment | its previous location.
Environment | Command: env -forward Change your environment
*‘ Forward Menu: File > Environment | forward to a previously
selected environment.
. Add Command Wavewindow | Clicking this button
:_E] * | Bookmark only: bookmark add wave bookmarks the current view of
Menu Wave window only: | the active window.
Add >ToWave>
Bookmark Click and hold the button to
open a drop down menu with
the following options:
® Add Current View
* Add Custom ...
¢ Set Default Action
. Delete All CommandWave window Removes all bookmarks, after
:E Bookmarks | only: bookmark delete wave | prompting for your
-l confirmation.
Click and hold the button to
open a drop down menu with
the following options:
® Active Window
* All Windows
e Manage None Displays the Manage
Cr Bookmarks Bookmarks dialog box.
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Table 3-27. Home Toolbar Tab Buttons (cont.)

Button | Name Shortcuts Description

Reload from | None Reloads bookmarks from the
Elﬂ » | File bookmarks.do file.

® Set Default Action

Jump to CommandWave window Displays bookmarks grouped

I':El Bookmark only: bookmark goto wave | by window. Select the
<name> bookmark you want to display.

Search None A text entry box for your
Help |_ Documentati search string.

on

Search Hotkey: Enter Activates the search for the
ﬁ Documentati term you entered into the text

on entry box.

1. You can set the default insertion location in the Wave window from menus and hotkeys with the
PrefWave(l nsertM ode) preference variable.

Layout Toolbar Tab

The Layout toolbar tab alows you to select a predefined or user-defined layout of the graphical
user interface. Refer to the section “ Customizing the Simulator GUI Layout” for more
information.

Figure 3-30. Layout Tab
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Table 3-28. Layout Toolbar Tab Buttons

Button Name Shortcuts Description
Column Menu: A dropdown box that
Calumnlayout [411Coveragel | Layout Verification allows you to specify the
Browser > column layout for the
1: hd Configure active window.
Column Layout
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Table 3-28. Layout Toolbar Tab Buttons (cont.)

Button Name Shortcuts Description
Iﬁ J Change Menu: Layout > | A dropdown box that
e | Layout <layoutName> allows you to select aGUI

layout.

* NoDesign
® Simulate
* Coverage
* VMgmt

Profile Toolbar Tab

The Profile toolbar tab provides access to tools related to the profiling windows (Ranked,
Calltree, Design Unit, and Structural .

 Home | Eit | Compiee | Coverage | Simulate | Debug  Profie
13e B w0

+Z |Under %%

Figure 3-31. Profile Tab

—

Table 3-29. Profile Toolbar Tab Buttons

Button Name Shortcuts Description
— Collapse Menu: Tools > Profile > Toggle the reporting for
T—; Sections Collapse Sections collapsed processes and
functions.
a| | Profile None Display performance and
| 0. 10 El Cutoff memory profile data equal to
or greater than set percentage.
Refresh None Refresh profile performance
E’ Profile Data and memory data after
changing profile cutoff.
Save Profile | Menu: Tools > Profile > Save profile data to output file
E Results Profile Report (prompts for file name).
B Performance | Menu: Tools > Profile > Enable collection of statistical
d] Profiling Performance performance data.
m Memory Menu: Tools > Profile > Enable collection of memory
d Profiling Memory usage data.
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Schematic and Dataflow Toolbar Tab

The Schematic toolbar tab provides access to tools for manipulating highlights and signalsin
the Dataflow and Schematic windows.

Figure 3-32. Schematic Tab
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Table 3-30. Schematic Toolbar Tab Buttons

Button | Name Shortcuts Description
Tracelnput | Menu: Tools> Trace > Move the next event cursor to
J-+ Net to Event | Trace next event the next input event driving the
selected output.
Trace Set Menu: Tools> Trace > Jump to the source of the
L Trace event set selected input event.
Trace Reset | Menu: Tools> Trace > Return the next event cursor to
- Trace event reset the selected outpuit.
Trace Netto | Menu: Tools> Trace > Step back to the last driver of
ﬁ Driver of X | TraceX an unknown value.
Expand Net | None Display driver(s) of the
31- to all Drivers selected signal, net, or register.
= Expand Net | None Display driver(s) and reader(s)
:l.E to all Drivers of the selected signal, net, or
and Readers register.
Expand Net | None Display reader(s) of the
-]nE to all Readers selected signal, net, or register.
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Table 3-30. Schematic Toolbar Tab Buttons (cont.)

Button | Name Shortcuts Description
Remove All | Menu: Dataflow > Clear the green highlighting
E - | Highlights | Remove Highlight identifying the path you've
or traversed through the design.
Schematic > Edit > Remove
Highlight Click and hold the button to

open adrop down menu with
the following options:

* Remove All Highlights

® Remove Selected

Highlights
® Set Default Action
Delete Menu: Delete the selected signal.
K + | Content Dataflow > Delete
or Click and hold the button to

Schematic > Edit > Delete | open adrop down menu with
Schematic > Edit > Delete | the following options:

All ® Delete Selected
* Delete All
® Set Default Action
Regenerate | Menu: Dataflow > Redraws the current schematic
{E‘I Regenerate view to better take advantage
or of the available space. For
Schematic > Edit > example, after adding or
Regenerate removing elements.
Show Wave | Menu: Dataflow > Display the embedded wave
M Show Wave viewer pane.

Simulate Toolbar Tab

The Simulate Toolbar tab alows you to control aspects of simulation including running the
simulation and stepping through your code.

Figure 3-33. Simulate Tab

PRS- SaRT- T 2= FELEIELE D | R O
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Button

Name

Source
Hyperlinking

Step Into

Shortcuts

None

Table 3-31. Simulate Toolbar Tab Buttons

Description

Iy

Command: step

Step Over

Menu: Simulate > Run >
Step

Toggles display of hyperlinks

in design source files.

s

Step Out

Command: step -over

Menu: Simulate> Run >
Step -Over

Step the current simulation to
the next statement.

Step Into
Current

Command: step -out

Execute HDL statements,
treating them as simple

statements instead of entered
and traced line by line.

Step Over
Current

Command: step
-current

Step the current simulation out

of the current function or
procedure.

Step Out
Current

Command: step -over
-current

Step the simulation into the
current instance, process, or
thread.

Restart

Command: step -out
-current

Step the simulation over the
current instance, process, or
thread.

Command: restart

Menu: Simulate > Run >
Restart

Step the simulation out of the
current instance, process, or
thread.

100 ns 3]

Run

Run Length

Command: run
Menu: Simulate >
Runtime Options

and objects.

Reload the design elements

and reset the simulation timeto
zero, with the option of

maintaining various settings

Continue
Run

Command: run

Menu: Simulate > Run >

Specify the run length for the
current simulation.

86

Command: run
-continue

Run default_run_length

Menu: Simulate > Run >
Continue

Run the current simulation for
the specified run length.

Continue the current

simulation run until the end of

the specified run length or until
it hits abreakpoint or specified
break event.
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Table 3-31. Simulate Toolbar Tab Buttons (cont.)

Button Name Shortcuts Description
Run All Command: run -all Run the current simulation
Menu: Simulate > Run > | forever, or until it hitsa
Run -All breakpoint or specified break
event.
= Simulate Command: vsim Opens the Start Simulation
ﬁ Menu: Simulate> Start | dialog box.
Simulation
Break Menu: Simulate > Break | Immediate stop of a
E Hotkey: Break compilation, elaboration, or

simulation run. Similar to
hitting a breakpoint if the
simulator isin the middle of a

process.
Stop -sync None Stop simulation the next time
m time/deltais advanced.
Edit Menu: Tools > Enable breakpoint editing,
'TI_TIE Breakpoints | Breakpoint loading, and saving.

Windows With Dedicated Toolbars

Buttons that function only in a specific window are available in a bar at the top of the window.
Click the Show/Hide Toolbar button in the window title bar to display the window specific
buttons (Figure 3-34). Y ou can add buttons to any currently open window. Refer to
Customizing Button and Tab Location for more information.
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Figure 3-34. Window Specific Buttons

Ohjects

| I | o |I"'D'| ﬂﬁ |Showﬂ-|ideTnnIbar|

£ dk Thi Met  In
4 rdy 1'hd Met  In
4. addr &h09 Met Cut
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4, strh thi Met  Out
4. data 16'h0009Met  Inout
4. addr_r &h0g  Padk.. Internal
data_r 16'hzzzz Padk... Internal
rw_r Thi Regis...Internal
strb_r Thi Regis...Internal

= Thi Regis...Internal
t_out Thx Met  Internal
t_set 1'hx Met  Internal

rw_out 1'hx Met  Internal

The following windows have default buttons or widgets:
®* FSM Viewer Window
®* Memory Data Window
® Objects Window
® Processes Window
® Source Window

® Vaeification Results Analysis Window

Toolbar Visibility and Layout

Y ou can customize the display of the Toolbar Tabs in the main GUI and undocked windows.

Procedure
1. Right-click in thetab or toolbar area of the GUI.
2. Select one of the following items from the popup menu (Table 3-32):

Table 3-32. Toolbar Tab Popup Menu
Popup Menu Item Description
Hide Tabs Hides all tabs except for the currently active tab.
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Table 3-32. Toolbar Tab Popup Menu (cont.)

Popup Menu Item Description

Edit Toolbars Opens the Toolbar Tab Widget Toolbox and locks the GUI into
edit mode.

Remove <name> Tab Removes the tab that is under the cursor.

Add Tab Opens the Add/Create Tab dialog box. Use this dialog box to
create a new user-defined tab or restore a previously defined tab.

Reset Tabs Resets GUI to the default tabs and order of tabs. Removes user-
defined tabs.

Reset <name> Toolbar | Resets the selected tab to the default buttons and widgets.

Reset All Toolbars Resets all toolbar tabs to their default buttons and widgets. User-
defined toolbar tabs default to an empty toolbar.

Y ou can aso remove al toolbars from the GUI by selecting Window > Show Toolbar. This
removes toolbar tabs from the main GUI only.

Creating and Restoring Toolbar Tabs

Y ou can create your own tabs and populate them with the buttons and widgets you want to use.
In addition you can restore tabs you have deleted from the main GUI or an undocked window.

Procedure

Right-click in the toolbar area of the main GUI or the undocked window you want to modify
and select Add Tab from the popup menu to open the Add/Create Tab dialog box.

® Tocreateauser defined toolbar tab, enter anamein the Tab Namefield then click Add.
The new tab is added to the main GUI or the currently active undocked window.

® Torestore an existing toolbar tab, select atab name from the drop down list in the Tab
Namefield. The tab and all buttons currently registered to that tab are added to the GUI
or undocked window.

Customizing Button and Tab Location

Y ou can add and delete buttons from any Toolbar Tab or window and add buttons to windows
that do not have default buttons associated with them. In addition you can change the order of
the Toolbar Tabs. Open the Toolbar Tab Widget Toolbox to make modifications to Toolbar
Tabs by right-clicking in the toolbar area of the main GUI and selecting Edit Toolbars.
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Toolbar Tab Widget Toolbox

The Widget Toolbox Figure 3-35. allows you to change the default layout of the Toolbar Tabs
and buttons on each tab and window.

Figure 3-35. Toolbar Widget Toolbox
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Home
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Layout
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Miscellaneous
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Simulate

The GUI locks into edit mode when the Widget Toolbox is open preventing interaction with
your design and allowing you to change the following items in the GUI:

® Button Location — Add or delete buttons from the main GUI or an undocked window
by dragging and dropping. All currently open windows will display atoolbar area at the
top of the window where you can add buttons. The toolbar areain awindow will
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disappear if it doesn’t contain any buttons when the Widget Toolbox closes. To delete
buttons, drag the button to the Widget Toolbox or outside of the main GUI and drop it.

Refer to Windows With Dedicated Toolbars for more information on windows with

dedicated toolbar buttons.

® Tab Ordering — Change the order of the tabs by dragging the tab to a new location in

the GUI. Y ou can aso change tab order in undocked windows. Tab order in undocked
windows is saved separately from the main GUI and reloaded every time you undock a

modified window.

Tabbed Toolbar Mapping to Default Toolbars

The following table provides you with the toolbar tab locations of the 10.2 and earlier toolbars.

Table 3-33. Pre-10.3 Toolbar Mapping to Toolbar Tab Location

Process Toolbar

Default Toolbar Toolbar Tab
Bookmarks Toolbar Home Toolbar Tab
Help Toolbar

Standard Toolbar

Wave Edit Toolbar Edit Toolbar Tab
Compile Toolbar Compile Toolbar Tab
Coverage Toolbar Coverage Toolbar Tab

Simulate Toolbar
Step Toolbar

Simulate Toolbar Tab

Mode Toolbar

Source Toolbar

Wave Toolbar

Wave Compare Toolbar
Wave Compare Toolbar
Wave Cursor Toolbar

Wave Expand Time Toolbar
Zoom Toolbar

Debug Toolbar Tab

Profile Toolbar

Profile Toolbar Tab

Dataflow Toolbar
Schematic Tool bar

Schematic and Dataflow Toolbar Tab

Layout Toolbar

Layout Toolbar Tab

Memory Toolbar

Memory Data Window

Objectfilter Toolbar

Object Window Toolbar
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Table 3-33. Pre-10.3 Toolbar Mapping to Toolbar Tab Location (cont.)

Default Toolbar

Toolbar Tab

Process Toolbar

Process Window Toolbar

Bookmarks Toolbar

Source Window Toolbar

92
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Chapter 4
Window Reference

The following table summarizes al of the available windows.

Table 4-1. GUI Windows

Window

Description

Call Stack Window

displays the current call stack, allowing you to debug
your design by analyzing the depth of function calls

Class Graph Window

displays interactive relationships of SystemVerilog
classesin graphical form

Class Instances Window

displays class instances

Class Tree Window

displays interactive relationships of SystemVerilog
classesin tabular form

Dataflow Window

displays "physical" connectivity and lets you trace
events (causality)

Files Window

displays the source files and their locations for the
loaded simulation

Library Window

lists design libraries and compiled design units

List Window

shows waveform data in a tabular format

Locals Window

displays data objects that are immediately visible at the
current execution point of the selected process

Memory List Window
Memory Data Window

windows that show memories and their contents

Message Viewer Window

allows easy access, organization, and analysis of Note,
Warning, Errors or other messages written to transcript
during simulation

Objects Window

displays all declared data objects in the current scope

Processes Window

displays al processes that are scheduled to run during
the current ssimulation cycle

Projects

provides access to information about Projects

Source Window

atext editor for viewing and editing files, such as
Verilog, VHDL, and DO files
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Table 4-1. GUI Windows (cont.)

Window

Description

Structure Window
Also known asthe “sim”
window.

displayshierarchical view of active simulation. Name of
window is either “sim” or “<dataset _name>"

Transcript Window

keeps a running history of commands and messages and
provides a command-line interface

Watch Window displays signal or variable values at the current
simulation time
Wave Window displays waveforms

94
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Call Stack Window

The Call Stack window displays the current call stack when:

® you single step the simulation.
® the simulation has encountered a breakpoint.
® you select any processin either the Structure or Processes windows.

When debugging your design you can use the call stack datato analyze the depth of function
callsthat led up to the current point of the simulation, which include:

® Veilog functions and tasks
® VHDL functions and procedures
® SystemC methods and threads

® C/C++ functions
Accessing
Access the window using the following menu item:
* View > Call Stack

Figure 4-1. Call Stack Window

File Address

0 Module bot 30 C:/QuestaT estcazes/callstackMiew/callstack sv - YeB3ar2d
1 Function [3 25 C:AQuestal estcases/callstackView/callstack. sy 7eB3adlf
2 Function [2 20 C:AQuestal estcases/callstackView/callstack.sv ~ 7eB3a18f
3 Function 1 15 C:/QuestaT estcases/callstackView/callstack sy 7eB839efd
4 Module top 35 C:/Questal estcases/callstackView/callstack sy TeB32905

Line

Call Stack Window Tasks

Thiswindow allows you to perform the following actions:

® Double-click on theline of any function call:
o Displaysthelocal variables at that level in the Locals Window.

o Displaysthe corresponding source code in the Source Window.
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Related Commands of the Call Stack Window

Table 4-2. Commands Related to the Call Stack Window

Command Name Description

stack down this command moves down the call stack.

stack frame this command selects the specified call frame.

stack level this command reports the current call frame number.
stack th this command is an alias for the tb command.

stack up this command moves up the call stack.

GUI Elements of the Call Stack Window

This section describes GUI elements specific to this Window.

Column Descriptions

Table 4-3. Call Stack Window Columns

Column Title Description

# indicates the depth of the function call, with the most recent
at the top.

In indicates the function. If you see “unknown” in this column,

you have most likely optimized the design such that the
information is not available during the simulation.

Line indicates the line number containing the function call.
File indicates the location of the file containing the function call.
Address indicates the address of the execution in aforeign

subprogram, such as C.
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Class Graph Window

The Class Graph window provides a graphical view of your SystemVerilog classes, including
any extensions of other classes and related methods and properties.

Accessing
®* Menuitem: View > Class Browser > Class Graph

® Command: view classgraph

Figure 4-2. Class Graph Window

e | - >
? eth_packet
] Froperties:
bit[47:0] dest
bit[4T:0] sre
bit[15:0] ethertype
int payload_sz
byte<id=[1517] payload
int ifg
/ bit[31:0] fes
= | bit[31:0] fes_corrupt
= bit mac_plus
) bit any_payld_size
bit sm_payld_size
_ bit reg_payld_size
L o bit huge_payld_size
e bit basic
hit short_ifg
e bit reg_ifg
\ static Class fcs_gen
4 | J.|L1

Class Graph Window Tasks

This section describes tasks for using the Cover Directives window.
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Navigating in the Class Graph Window

Y ou can change the view of the Class Graph window with your mouse or the arrow keys on
your keyboard.

® Left click-drag — allows you to move the contents around in the window.
® Middle Mouse scroll — zoomsin and out.
® Middle mouse button strokes:
o Upper left — zoom full
o Upper right — zoom out. The length of the stroke changes the zoom factor.
o Lower right — zoom area.
* Arrow Keys— scrolls the window in the specified direction.
o Unmodified — scrolls by a small amount.
o Citrl+<arrow key> — scrolls by alarger amount

o Shift+<arrow key> — shifts the view to the edge of the display

GUI Elements of the Class Graph Window

This section describes the GUI elements specific to the Class Graph window.

Popup Menu Items

Table 4-4. Class Graph Window Popup Menu

Popup Menu Item Description

Filter Controls the display of methods and properties from
the class boxes.

Zoom Full

View Entire Design Reloads the view to show the class hierarchy of the

complete design.

Print to Postscript

Organize by Base/Extended Class | reorganizes the window so that the base or extended
(default) classes are at the top of the hierarchy.
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Class Instances Window

The Class Instances window shows the list of class instances and their values for a particular
selected classtype. Y ou may add the classitems directly to the wave or list windows, log them,
or get other information about them.

Accessing
* Menuitem: View > Class Browser > Class | nstances

® Command: view classinstances

Figure 4-3. Class Instances Window

| PR 0-AE| g - a0 8. g
*|Mame Walue Kind e
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;_}-) super fmem_item} 305 @uvm_ohject_string_poal_... SWClass{uvm_tran...
4 m_sequence_id -1 Int
-Q m_use_sequence_inf.. 1 Protected Bit
b m_depth -1 Protectad Int
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_ij--v) m_parent_sequence  {m_mem_seq} 433 @uvm_object_string_poo.. Class Instance
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g m_client_str Frotected String
-) m_client rll Class Instance
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o issuedl 0 Static Bit
g izsuBd?2 0 Static Bit
g report_id RER_ITEM String
g instruction RE&D Enum
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Viewing Class Instances

The Class Instances window is dynamically populated by selecting SV Classes in the Structure

(sm) window. All currently active instances of the selected class are displayed in the Class

Instances window. Class instances that have not yet come into existence or have been destroyed

are not displayed.

Once you have chosen the class type you want to observe, you can fix that instance in the

window while you debug by selecting File > Environment > Fix to Current Context.

Class Naming Format

Class instance names are formatted as follows: @<class_type>@<nnn> where
@<class_type>@ isthe name of the class type and <n> is the reference identifier for a
particular instance of the class type. For example, @uvm_queue 3@14 is the 14th instance of

the classuvm_queue 3.

GUI Elements of the Class Instances Window

This section describes the GUI elements specific to the Class Instances window.

Popup Menu Items

Table 4-5. Class Instances Window Popup Menu

Popup Menu Item

Description

View Declaration

Highlights the line of code where the type of the
instance is declared, opening the sourcefileif
necessary.

Add Wave

Adds the selected class instance to the Wave window.

Addto

Allowsyou to log the selected class instance, or add it

to the Wave or List windows.
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Class Tree Window

The Class Tree window provides a hierarchical view of your SystemV erilog classes, including
any extensions of other classes, related methods and properties, as well as any covergroups.

Figure 4-4. Class Tree Window

u " Class Tree

Class L[ Type File Unique Id |Scope =
- xbus_status Class xbus_bus_monita..,
+ Extends owm_object Class ovwmn_object.svh
— Methods
) create Funckion
get_object_tvpe Function
—ﬁ';.;] gek_bvpe skakic Function
—]‘i';;;] get_tvpe_name Funickion
—]i\;] m_field_aukomation Funckion
—ﬁg New Function
+} Properties
-8 whus_transfer Class xbus_transfer.sw E
| | -

Accessing
® Sdect View > ClassBrowser > Class Tree

® Usethe command: view classtree

GUI Elements of the Class Tree Window

This section describes the GUI elements specific to the Class Tree window.

Icons

Table 4-6. Class Tree Window Icons

Icon Description

of Class

oo Parameterized Class
fig Function

f5d Task
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Table 4-6. Class Tree Window Icons (cont.)

I con Description

x= Variable

u Virtua Interface
S Covergroup

{} Structure

Column Descriptions

Table 4-7. Class Tree Window Columns

Column Description

Class The name of the item

Type The type of item

File The source location of the item

Uniqueld The internal name of the parameterized class
(only available with parameterized classes)

Scope The scope of the covergroup
(only available with covergroups

Popup Menu Items

Table 4-8. Class Tree Window Popup Menu

Popup Menu Item

Description

View Declaration

Highlights the line of code where the item is declared,
opening the source file if necessary.

View as Graph Displays the class and any dependent classesin the
Class Graph window.
(only available for classes)
Filter allows you to filter out methods and or properties
Organize by Base/Extended Class | reorganizes the window so that the base or extended

(default) classes are at the top of the hierarchy.
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Use this window to explore the "physical” connectivity of your design. Y ou can also useit to
trace events that propagate through the design; and to identify the cause of unexpected outputs.

The Dataflow window displays:

® processes
® signals, nets, and registers

The window has built-in mappings for al Verilog primitive gates (that is, AND, OR, PMOS,
NMOS, and so forth.). For components other than Verilog primitives, you can define amapping
between processes and built-in symbols. See Symbol Mapping for details.

Note
D Thisversion of Model Sim has limited Dataflow functionality resulting in many of the
features described in this chapter operating differently. The window will show only one

process and its attached signals or one signal and its attached processes, as displayed in
Figure 4-5.

Accessing

Access the window using either of the following:

®* Menuitem: View > Dataflow

® Command: view dataflow
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Figure 4-5. Dataflow Window - ModelSim
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Figure 4-6. Dataflow Window
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Dataflow Window Tasks
This section describes tasks for using the Dataflow window.

Y ou can interact with the Dataflow in one of three different Mouse modes, which you can
change through the DataFlow menu or the Zoom T ool bar:

® Select Mode — your left mouse button is used for selecting objects and your middle
mouse button is used for zooming the window. This is the default mode.

® Zoom Mode— your left mouse button is used for zooming the window and your
middle mouse button is used for panning the window.

®* Pan Mode— your left mouse button is used for panning the window and your middie
mouse button is used for zooming the window.

Selecting Objects in the Dataflow Window
When you select an object, or objects, it will be highlighted an orange color.
® Select asingle object — Single click.

® Select multiple objects — Shift-click on all objects you want to select or click and drag
around all objectsin adefined area. Only available in Select Mode.
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Zooming the View of the Dataflow Window

Several zoom controls are available for changing the view of the Dataflow window, including
mouse strokes, toolbar icons and a mouse scroll wheel.

Zoom Full — Fills the Dataflow window with all visible data.

o Mouse stroke — Up/Left. Middle mouse button in Select and Pan mode, L eft mouse
button in Zoom mode.

o Menu— DataFlow > Zoom Full
o Zoom Toolbar — Zoom Full
Zoom Out

o Mouse stroke — Up/Right. Middle mouse button in Select and Pan mode, L eft
mouse button in Zoom mode.

o Menu— DataFlow > Zoom Out

o Zoom Toolbar — Zoom Out

o Mouse Scroll — Push forward on the scroll whesel.

Zoom In

o Menu— DataFlow > Zoom In

o Zoom Toolbar — Zoom In

o Mouse Scroll — Pull back on the scroll whesl.

Zoom Area— Fills the Dataflow window with the data within the bounding box.
o Mouse stroke — Down/Right

Zoom Selected — Fills the Dataflow window so that al selected objects are visible.
o Mouse stroke — Down/L eft

Panning the View of the Dataflow Window

Y ou can pan the view of the Dataflow window with the mouse or keyboard.

Pan with the Mouse — In Zoom mode, pan with the middle mouse button. In Pan mode,
pan with the left mouse button. In Select mode, pan with the Ctrl key and the middle
mouse button.

Pan with the Keyboard — Use the arrow keys to pan the view. Shift+<arrow key> pans
to the far edge of the view. Ctrl+<arrow key> pans by a moderate amount.
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Displaying the Wave Viewer Pane

Y ou can embed a miniature wave viewer in the Dataflow window (Figure 4-7.

1. Select the DataFlow > Show Wave menu item.

2. Select aprocess in the Dataflow pane to populate the Wave pane with signal
information.

Refer to the section “ Exploring Designs with the Embedded Wave Viewer” for more
information.

Figure 4-7. Dataflow Window and Panes

EDataﬂuw .
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Files Window

Use this window to display the source files and their locations for the loaded simulation.

Prerequisites
Y ou must have executed the vsim command before this window will contain any information
about your simulation environment.

Accessing

Access the window using either of the following:

®* Menuitem: View > Files

® Command: view files

Figure 4-8. Files Window

rame © |Specified path Full path Tvpe |

-5} sim wsirn, wlf C:fQuestaTestca, .,
— v_andz,vhd v_andz,vhd C:fQuestaTestca,,, vhdl
— ukil, whd ukil, whd C:fQuestaTestca,,, vhdl
— kop,whd kop,whd C:QuestaTestca,,, vhdl
— kiming_p_2000.vhd i fqueskasim_mainfwin3z2/.. ... i fquestasim_mai... whdl
— kiming_b_2000.vhd i fqueskasim_mainfwin3Z/.. ... i fquestasim_mai... whdl
— kesckio, vhd i fquestasim_main/win3z/..... i fquestasim_mai... whdl
— skdlagic, vhd C:fqueskasim_main/win3z),. ... C:fqueskasim_mai.., vhdl
— skd_logic_kextio,vhd C:fqueskasim_main/win3z).. ... C:fqueskasim_mai... vhdl
— standard, vhd C:fqueskasim_main/win3z).. ... Z:fqueskasim_mai... vhdl
— set,whd set,whd C:fQuestaTestca,,, vhdl
— prac,vhid prac,vhid C:QuestaTestca,,, vhdl
— prmtys_b_2000,vhd i fqueskasim_mainfwin3z2/.. ... i fquestasim_mai... whdl
— mki_numeric_std.vhd i fqueskasim_mainfwin3Z/.. ... i fquestasim_mai... whdl
— mermory, vhd mermory, vhd CifCuestaTestca,,, vhdl
— gates,vhd gates,vhd C:fQuestaTestca,,, vhdl
— cache,vhd cache,vhd C:fQuestaTestca,,, vhdl

| |

GUI Elements of the Files Window

This section describes GUI elements specific to this Window.

ModelSim GUI Reference Manual, v10.3a

109



Window Reference
Files Window

Column Descriptions

Table 4-9. Files Window Columns

Column Title Description
Name The name of thefile
Specified Path The location of the file as specified in the
design files.
Full Path The full-path location of the design files.
Type Thefiletype.
Popup Menu

Right-click anywhere in the window to display the popup menu and select one of the following
options:

Table 4-10. Files Window Popup Menu

Menu Item Description

View Source Opens the selected file in a Source window

Open in external editor Opens the selected file in an external editor.
Only availableif you have set the Editor preference:
* set PrefMain(Editor) {<path_to_executable>}
® Tools> Edit Preferences; by Name tab, Main group.

Properties Displays the File Properties dialog box, containing
information about the selected file.

Files Menu

This menu becomes available in the Main menu when the Files window is active.

Table 4-11. Files Menu

FilesMenu Item Description
View Source Opens the selected file in a Source window
Open in external editor Opens the selected file in an external editor.

Only availableif you have set the Editor preference:
® set PrefMain(Editor) { <path_to_executable>}
® Tools> Edit Preferences; by Nametab, Main
group.

Save Files Saves atext file containing a sorted list of unique
files, one per line. The default name is summary.txt.
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Library Window

Use this window to view design libraries and compiled design units.

Accessing
Access the window using either of the following:
®* Menuitem: View > Library

® Command: view library

Figure 4-9. Library Window

[l Library
Marmne Type Path 1=
j—ﬂl wirk, Library i fquestasim_6.6/examples/tutorials). ..
] andz Module Ciquestasim_6.6\examplesitutorialsy, ..
] cache Maodule Chquestasim_f,.6lexamplesitukarials),
mi cache_set Maodule C:hquestasim_f,.6lexamplesiukarials),
— ] memary Maodule C:hquestasim_f.6lexamplesitukarials), —
— ] arz Madule C:hquestasim_f.6lexamplesikarials),
— ] proc Module Ciquestasim_6.6\examplesitutorials. ..
— ] top Module Ziquestasim_6.&\examplesitutorials. ..
—M top_opt Optirnized, .
1] v_andz Maodule Cquestasim_f,6lexamplesitukarials),
ﬂ—ﬂl Floatfixlib Library $MODEL_TECH/ . [Floatfixlib -

GUI Elements of the Library Window

This section describes GUI elements specific to this Window.

Column Descriptions

Table 4-12. Library Window Columns

Column Title Description

Name Name of the library or design unit
Path Full pathname to the file

Type Type of file
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Popup Menu
Right-click anywhere in the window to display the popup menu and select one of the following
options:
Table 4-13. Library Window Popup Menu

Popup Menu Item Description

Simulate Loads a simulation of the selected design unit

Simulate with Coverage Loads asimulation of the selected design unity,
enabling coverage (-coverage)

Edit Opens the selected file in your editor window.

Refresh Rel oads the contents of the window

Recompile Compiles the selected file.

Update

Create Wave Runs the wave create command for any portsin the
selected design unit.

Delete Removes a design unit from the library or runs the
vdel command on a selected library.

Copy Copiesthe directory location of libraries or the
library location of design units within the library.

New Allowsyou to create a new library with the Create a
New Library dialog box.

Properties Displaysinformation about the selected library or
design unit.
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List Window

The List window displays simulation results in tabular format. Common List window tasks
include:

® Using gating expressions and trigger settings to focus in on particular signals or events.
See Configuring New Line Triggering.

® Debugging deltadelay issues. See Delta Delays for more information.

The window is divided into two adjustable panes, which allows you to scroll horizontally
through the listing on the right, while keeping time and delta visible on the | eft.

Figure 4-10. Tabular Format of the List Window

st ~1olx]

File Edit Wiew #&dd Tools Window

|DsEe s a0 i wE of
P ezt sm/finto—,
delta— foest smfoutofi—,

ftest _smirst—
ftest_smiclk—,

430000 +0 ooooooz0 171 0 1
491000 +1 ooooooz0 171 0 1
425000 40 Qoooaoog 171 0 1
sSaaoao +0 ogoaoooon 171 0 0
510000 +0 ogoaoooon 171 0 1 —
Llloa00 +1 ogoaoooon 171 0 1
El11l000 b aoooooan 171 0 1
ElEQ00 40 40000000 187 0 1
S0000 +0 40000000 187 0 0
L3000 +l‘ 40000000 127 0 0 ‘:J
164 lines « | | |

Use thiswindow to display atextua representation of waveforms, which you can configure to
show events and delta events for the signals or objects you have added to the window.

Y ou can view the following object typesin the List window:

* VHDL — signals, aliases, process variables, and shared variables
®* Verilog— nets, registers, and variables

® Virtuals— virtual signals and functions

Accessing

Access the window using either of the following:
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* Menuitem: View > List

®  Command: view list

Figure 4-11. List Window

na—, m Jtopfpaddr—, JtopSpdata—, Jtopfsaddr—, Pl
delta— Jtopfpru—, Jtopfaru—,
fropfpatrbh— fronfsatrbh—
Ftopsprdy—, ftopfsrdy—,
0 +0 0 U 17 10

=0 =
=0 =

0 +1 O 7T UUUUTTTY UUUUUUTUUTUUIUOY 7 U 1 U U
o +2 W 17 17 17 TUUUTTTT U 7 17 77 T T
5 40 W 0 1 1 00000000 Z22Z2Z2ZZZZEEEZZZ2Z2Z2 0 1 1 00000000 Z22ZZ%.
5 +1 W 0 1 1 00000000 Z2ZZZZZZEEZZZZZZ2 0 1 1 00000000 ZZ2ZZ%,
5 42 W 0 1 1 00000000 ZEZ2ZZZZZEZEZZZZZZ2 0 1 1 00000000 ZZ2ZZZ.
5 43 W 0 1 1 00000000 ZEZZZZZZEZEZZZZZZ2 01 1 00000000 ZZ2ZZX,
20 40 01 1 00000000 ZEE2Z222222E8Z22222 0 1 1 00000000 EZE2ZZZ.
20 +1 01 1 00000000 EEZE2222Z25E2ZZ22 0 1 1 00000000 ZEZZE.
25 40 00 1 00000000 ZZZ222Z2ZZZZZZZ22 0 1 1 00000000 ZZZZZILI
216 lines 4| | |

-I =7 list I 2| wave ] L

List Window Tasks

This section describes tasks for using the List window.

Adding Data to the List Window

Y ou can add objects to the List window in any of the following ways:

® right-clicking on signals and objectsin the Objects window or the Structure window and
selecting Add > to List.

® using the add list command.

® using the “Add Selected to Window Button”.

Selecting Multiple Signals
To create alarger group of signals and assign a new name to this group, do the following:
1. Select agroup of signals
o Shift-click on signal columns to select arange of signals.

o Control-click on signal columnsto select a group of specific signals.
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2. Select List > Combine Signals
3. Complete the Combine Selected Signals dialog box
o Name — Specify the name you want to appear as the name of the new signal.
o Order of Indexes — Specify the order of the new signal as ascending or descending.

o Remove selected signals after combining — Specify whether the grouped signals
should remain in the List window.

This process creates virtual signals. For more information, refer to the section Virtual Signals.

Setting Time Markers in the List Window

Time markersin the List window are similar to cursors in the Wave window. Time markers tag
linesin the data table so you can quickly jump back to that time. Markers areindicated by athin
box surrounding the marked line.

Figure 4-12. Time Markers in the List Window
=10l x|
File Edit | Yiew Add Tools '-.-'u'inu:_h:uw

J D = Signal Properties. .. |;
sim:ftest_sm!DuQ:J

N oo

delta—, st smSrst—
test smfclk—

R T O 0 0000000000000 0000000001010 0 1 000000000000 0000000000001

| Looooo 40 0 0 gooooooooooooQoooo0oo0o0l

Lloooo 4o 0 1 ooooooaoooooooooaoooooool

Ellooo0  +1 0 1 ooooooaoooooooooaoooooool

E1l1la000 0 1 ooooooaoooooooooaoooooool

SO0 O 1 20000000000 000000000004a0al1
Lzoooo 4o oo DDDDDDDDDDDDDDDDDDDDDDDDl_J

Ez92000 +1 0O 0O goooooaoooooooooaoooooool

L0000 40 0 1 ooooooaoooooooooaoooooool

L2lo000 +1 0 1 go0ooooaooo0ooQooao0oo0o0l

| L21000  += | [ispeiajajuiajajujsja)ajajuiajayujajujujajuya}n 0 1 gooooooogooaooooaoooooaol
il iR Al O OO0 0a0000000000000000a00 o1l DDDDDDDDDDDDDDDDDDDDDDDD{:J

Kl | ~

Working with Markers
The table below summarizes actions you can take with markers.
Table 4-14. Actions for Time Markers

Action Method
Add marker Select aline and then select List > Add Marker
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Table 4-14. Actions for Time Markers (cont.)
Action M ethod
Delete marker Select atagged line and then select List > Delete Marker
Goto marker Select View > Goto > <time> (only available when
undocked)

Expanded Time Viewing in the List Window

Event time may be shown in the List window in the same manner as deltatime by using the
-delta events option with the configure list command.

When the List window displays event times, the event time isrelative to events on other signals
also displayed in the List window. This may be misleading, asit may not correspond to event
times displayed in the Wave window for the same eventsiif different signals are added to the
Wave and List windows.

The write list command (when used after the configure list -delta events command) writesalist
filein tabular format with aline for every event. Please note that thisis different from the write
list -events command, which writes a non-tabular file using a print-on-change format.

Thefollowing examplesillustrate the appearance of the List window and the corresponding text
file written with the write list command after various options for the configure list -delta
command are used.

Figure 4-13 shows the appearance of the List window after the configure list -delta none
command isused. It corresponds to the file resulting from the write list command. No columnis
shown for deltas or events.

Figure 4-13. List Window After configure list -delta none Option is Used

o lst + @ X
ns— Atopllfinpl—= Al
topll foutpl—
Atopll Ainpl—

Atopll/outpl—,
1] -20 -20 -14 -14 "

10 -4 -4 E E
20 ATl = d

4 lines - =

| =] list | 43|

Figure 4-14 shows the appearance of the List window after the configure list -delta collapse
command is used. It corresponds to the file resulting from the write list command. Thereisa
column for deltatime and only the final deltavalue and the final value for each signal for each
simulation time step (at which any events have occurred) is shown.

ModelSim GUI Reference Manual, v10.3a 117



Window Reference
List Window

Figure 4-14. List Window After configure list -delta collapse Option is Used

= list +| 2 %
ns— Atopllifinpl—, Al
delta— Ftopll foutpl—<
Fopllinp2—,
Ftopllfoutpl—,
0 +0 -20 -20 -14 -14 &
i +2 = =l E §
20 +2 -10 -10 -2 -2 Ly
4 lines |- |
] list | <3

Figure 4-15 shows the appearance of the List window after the configure list -delta all optionis
used. It corresponds to the file resulting from the write list command. There is a column for
deltatime, and each delta time step value is shown on a separate line along with the final value
for each signal for that deltatime step.

Figure 4-15. List Window After write list -delta all Option is Used

= list +| & x|
ns—, Ftopll finpl—, i
delta—, Ftopll foutpl—,
Ftopll finp2—<
Atopll/outpi—,
0 +0 -20 -20 -14 -14
10 +1 -4 -20 5 -14
10 +2 =db =Ab EE
20 +1 20 =4 =B §
20 +2 ATl e 7|
4 lines |
7 list I 4|3

Figure 4-16 shows the appearance of the List window after the configure list -delta events
command is used. It corresponds to the file resulting from the write list command. Thereisa
column for event time, and each event time step value is shown on a separate line along with the
final value for each signal for that event time step. Since each event corresponds to a new event
time step, only one signal will change values between two consecutive lines.
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Figure 4-16. List Window After write list -event Option is Used
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Searching in the List Window

The List window provides two methods for locating objects:

1. Finding signal names:
o Select Edit > Find
o click the Find toolbar button (binoculars icon)
o usethefind command

The first two of these options will open a Find mode toolbar at the bottom of the List
window. By default, the “ Search For” option is set to “Name.” For more information,
see Find and Filter Functions.

2. Search for values or transitions:
o Select Edit > Signal Search
o click the Find toolbar button (binocularsicon) and select Search For > Value from
the Find toolbar that appears at the bottom of the List window.
Searching for Values or Transitions

The search command lets you search for values of selected signals. When you select Edit >
Signal Search, the List Signal Search dialog (Figure 4-17) appears.
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Figure 4-17. Wave Signal Search Dialog Box

List Signal Search (window List) x|

—Signal Mame(s)
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—Search Type
i+ Any Transition

" Rising Edge
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" Search for Signal Value  Value: |

" Search for Expression  Expression: | Euilder...l

—5earch and Match Count Options

m-Search Furward|
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" Search until time: ﬂ & Stop Search
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¥ Move active marker to location of match

—Search Results
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= ¥ Cloze | ﬂ

One option of noteis Sear ch for Expression. The expression can involve more than one signal
but islimited to signals currently in the window. Expressions can include constants, variables,
and DO files. Refer to Expression Syntax for more information.

Any search terms or settings you enter are saved from one search to the next in the current
simulation. To clear the search settings during debugging click the Reset To Initial Settings
button. The search terms and settings are cleared when you close Model Sim.

Using the Expression Builder for Expression Searches

The Expression Builder is afeature of the List Signal Search dialog box and the List trigger
properties dialog box. You can useit to create a search expression that follows the
GUI_expression_format.

To display the Expression Builder dialog box, do the following:

1. Choose Edit > Signal Search... from the main menu. This displays the Wave Signal
Search dialog box.
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2. Select Search for Expression.

3. Click the Builder button. This displays the Expression Builder dialog box shown in
Figure 4-18

Figure 4-18. Expression Builder Dialog Box

Expression Builder x|

"Expressinn

~Expression Builder

Selected Signal |

{
'eventl 'risingl 'Fallingl Bl
=
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Clear | Save | Test | ok Cancel

Y ou click the buttonsin the Expression Builder dialog box to create a GUI expression. Each
button generates a corresponding element of Expression Syntax and is displayed in the
Expression field. In addition, you can use the Selected Signal button to create an expression
from signals you select from the List window.

For example, instead of typing in asignal name, you can select signalsin a List window and
then click Selected Signal in the Expression Builder. This displays the Select Signal for
Expression dialog box shown in Figure 4-19.
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Figure 4-19. Selecting Signals for Expression Builder

Select Signal for Expression x|

Signials
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Note that the buttonsin this dialog box allow you to determine the display of signals you want
to put into an expression:

List only Select Signals— list only those signals that are currently selected in the
parent window.

List All Signals— list all signals currently available in the parent window.

Once you have selected the signals you want displayed in the Expression Builder, click OK.

Saving an Expression to a Tcl Variable

Clicking the Save button will save the expression to aTcl variable. Once saved this variable can
be used in place of the expression. For example, say you save an expression to the variable
"fo0." Here are some operations you could do with the saved variable:

® Read the value of foo with the set command:

set foo
* Put $foo in the Expression: entry box for the Search for Expression selection.
® |ssue asearchlog command using foo:

searchlog -expr $foo 0
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Formatting the List Window

Setting List Window Display Properties

Before you add objects to the List window, you can set the window’ s display properties. To
change when and how asignal isdisplayed in the List window, select Tools> List Preferences
from the List window menu bar (when the window is undocked).

Figure 4-20. Modifying List Window Display Properties

Modify Display Properties (list) 5[
windaw Properties ] Trigaers ] ﬁﬂ
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[ Ahways undock list windows

ok | Cancel Apply

Formatting Objects in the List Window

Y ou can adjust various properties of objects to create the view you find most useful. Select one
or more objects and then select View > Signal Properties from the List window menu bar
(when the window is undocked).

Changing Radix (base) for the List Window

One common adjustment you can make to the List window display isto change the radix (base)
of an object. To do this, choose View > Proper ties from the main menu, which displaysthe List
Signal Properties dialog box. Figure 4-21 shows the list of radix types you can select in this
dialog box.
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Figure 4-21. List Signal Properties Dialog

List Signal Properties = 0] x|
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The default radix type is symbolic, which means that for an enumerated type, the window lists
the actual values of the enumerated type of that object. For the other radix types (binary, octal,
decimal, unsigned, hexadecimal, ASCII, time), the object value is converted to an appropriate
representation in that radix.

Changing the radix can make it easier to view information in the List window. Compare the
image below (with decimal values) with the image in the section List Window (with symbolic
values).
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Figure 4-22. Changing the Radix in the List Window
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In addition to the List Signal Properties dialog box, you can also change the radix:

® Changethe default radix for the current ssmulation using Simulate > Runtime Options
(Main window)

® Change the default radix for the current smulation using the radix command.

® Change the default radix permanently by editing the DefaultRadix variable in the
modelsim.ini file.

Saving the Window Format

By default, al List window information is lost once you close the window. If you want to
restore the windows to a previously configured layout, you must save awindow format file as
follows:

1. Add the objects you want to the List window.
2. Edit and format the objects to create the view you want.

3. Savetheformat to afile by selecting File > Save Format. This opens the Save Format
dialog box where you can save List window formatsin a .do file.

To usethe format file, start with ablank List window and run the DO file in one of two ways:

®* |nvoke the do command from the command line:

VSIM> do <my_format_file>
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® Sdect File>Load.

Note
Window format files are design-specific. Use them only with the design you were

simulating when they were created.

In addition, you can use the write format restart command to create a single .do file that will
recreate all debug windows and breakpoints (see Saving and Restoring Breakpoints) when
invoked with the do command in subsequent simulation runs. The syntax is.

write format restart <filename>

If the ShutdownFile modelsim.ini variableis set to this .do filename, it will call the write format
restart command upon exit.

Combining Signals into Buses

Y ou can combine signalsin the List window into buses. A busis acollection of signals
concatenated in a specific order to create a new virtual signa with a specific value. A virtual
compare signal (the result of a comparison simulation) is not supported for combination with
any other signal.

To combine signalsinto a bus, use one of the following methods:

® Select two or moresignalsinthe Wave or List window and then choose List > Combine
Signals from the menu bar. A virtual signal that is the result of a comparison simulation
Is not supported for combining with any other signal.

® Usethevirtual signal command at the Main window command prompt.

Configuring New Line Triggering

New line triggering refers to what events cause a new line of data to be added to the List
window. By default Model Sim adds a new line for any signal change including deltas within a
single unit of time resolution.

Y ou can set new line triggering on a signal-by-signal basis or for the whole simulation. To set
for asingle signal, select View > Signal Properties from the List window menu bar (when the
window is undocked) and select the Trigger sline setting. Individual signal settings override
global settings.
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Figure 4-23. Line Triggering in the List Window
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To modify new linetriggering for the whole simulation, select Tools> List Preferences from
the List window menu bar (when the window is undocked), or use the configure command.
When you select Tools > List Preferences, the Modify Display Properties dialog appears:
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Figure 4-24. Setting Trigger Properties
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The following table summaries the triggering options:

Table 4-15. Triggering Options

Option Description

Deltas Choose between displaying all deltas (Expand
Deltas), displaying the value at the final delta
(Collapse Delta). You can also hide the delta
column all together (No Delta), however this will
display the value at the final delta.

Strobe trigger Specify an interval at which you want to trigger
datadisplay

Trigger gating Use a gating expression to control triggering; see
Using Gating Expressionsto Control Triggering for
more details
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Using Gating Expressions to Control Triggering

Trigger gating controls the display of data based on an expression. Triggering is enabled once
the gating expression evaluatesto true. This setup behaves much like a hardware signal analyzer
that starts recording data on a specified setup of address bits and clock edges.

Here are some points about gating expressions:

® Gating expressions affect the display of data but not acquisition of the data.

® Theexpression isevaluated when the List window would normally have displayed arow
of data (given the other trigger settings).

® Theduration determines for how long triggering stays enabled after the gating
expression returns to false (0). The default of O duration will enable triggering only
while the expression istrue (1). The duration is expressed in x number of default
timescale units.

® Gating islevel-sensitive rather than edge-triggered.

Trigger Gating Example Using the Expression Builder

This example shows how to create a gating expression with the Model Sim Expression Builder.
Here is the procedure:

1. Select Tools>Window Prefer encesfrom the List window menu bar (when the window
is undocked) and select the Triggers tab.

2. Click the Use Expression Builder button.

Figure 4-25. Trigger Gating Using Expression Builder
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3. Select thesignal in the List window that you want to be the enable signal by clicking on
its name in the header area of the List window.

4. Click Insert Selected Signal and then 'rising in the Expression Builder.
5. Click OK to close the Expression Builder.

Y ou should see the name of the signal plus "rising" added to the Expression entry box of
the Modify Display Properties dialog box.

6. Click OK to close the dialog.

If you already have ssmulation datain the List window, the display should immediately switch
to showing only those cycles for which the gating signal isrising. If that isn't quite what you
want, you can go back to the expression builder and play with it until you get it the way you
want it.

If you want the enable signal to work like a"One-Shot" that would display all values for the
next, say 10 ns, after the rising edge of enable, then set the On Duration value to 10 ns.

Trigger Gating Example Using Commands

The following commands show the gating portion of atrigger configuration statement:

configure list -usegating 1
configure list -gateduration 100
configure list -gateexpr {/test_delta/iom_dd'rising}

See the configure command for more details.

Sampling Signals at a Clock Change

Y ou easily can sample signals at a clock change using the add list command with the
-notrigger argument. The -notrigger argument disables triggering the display on the specified
signals. For example:

add list clk -notriggerab c
When you run the simulation, List window entries for clk, a, b, and ¢ appear only when clk
changes.
If you want to display on rising edges only, you have two options:

1. Turn off the List window triggering on the clock signal, and then define a repeating
strobe for the List window.

2. Define a"gating expression” for the List window that requires the clock to bein a
specified state. See above.
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Other List Window Tasks

List > List Preferences— Allows you to specify the preferences of the List window.

File> Export > Tabular List — Exportsthe information in the List window to afilein
tabular format. Equivalent to the command:

write list <filename>

File> Export > Event List — Exports the information in the List window to afilein
print-on-change format. Equivalent to the command:

write list -event <filename>

File> Export > TSSI List — Exportsthe information in the List window to afilein
TSSI. Equivalent to the command:

write tssi -event <filename>

Edit > Signal Search — Allows you to search the List window for activity on the
selected signal.

GUI Elements of the List Window

This section describes the GUI elements specific to the List window.

Window Panes

The List window is divided into two adjustable panes, which allow you to scroll horizontally
through the listing on the right, while keeping time and delta visible on the | eft.

® Theleft pane shows the time and any deltas that exist for agiven time.

® Theright pane contains the datafor the signals and objects you have added for each time
shown in the left pane. The top portion of the window contains the names of the signals.
The bottom portion shows the signal values for the related time.

Note
The display of time valuesin the left column is limited to 10 characters. Any time value

of more than 10 charactersis replaced with the following:

too narrow

Markers

The markersin the List window are analogous to cursorsin the Wave window. Y ou can add,
delete and move markersin the List window similarly to the Wave window. Y ou will notice two
different types of markers:
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Active Marker — The most recently selected marker shows as a black highlight.

Non-active Marker — Any markers you have added that are not active are shown with
agreen border.

Y ou can manipulate the markersin the following ways:

Setting a marker — When you click in the right-hand portion of the List window, you
will highlight a given time (black horizontal highlight) and a given signal or object
(green vertical highlight).

Moving the active marker — List window markers behave the same as Wave window
cursors. There is one active marker which is where you click along with inactive
markers generated by the Add Marker command. Markers move based on where you
click. The closest marker (either active or inactive) will become the active marker, and
the others remain inactive.

Adding amarker — Y ou can add an additional marker to the List window by right-
clicking at alocation in the right-hand side and selecting Add Marker.

Deleting a marker — Y ou can delete amarker by right-clicking in the List window and
selecting Delete Marker. The marker closest to where you clicked is the marker that will
be deleted.

Popup Menu

Right-click in the right-hand pane to display the popup menu and select one of the following
options:

Table 4-16. List Window Popup Menu

Popup Menu Item Description

Examine Displaysthe value of the signal over which you used
the right mouse button, at the time selected with the
Active Marker

Add Marker Adds amarker at the location of the Active Marker
Delete Marker Deletes the closest marker to your mouse location

The following menu items are available when the List window is active:
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Locals Window

Use this window to display data objects declared in the current, or local, scope of the active
process. These data objects are immediately visible from the statement that will be executed

next, which is denoted by ablue arrow in a Source window. The contents of the window change
from one statement to the next.

Accessing

Access the window using either of the following:

* Menuitem: View > locals

® Command: view locals

Figure 4-26. Locals Window

B daka_mem I
B atag_mem 4 JLI-

B valid_mem {False False False False

Locals Window Tasks

This section describes tasks for using the Locals window.

Viewing Data in the Locals Window

Y ou cannot actively place information in the Locals window, it is updated as you go through

your simulation. However, there are several ways you can trigger the Locals window to be
updated.

® Run your simulation while debugging.

Select a Process from the Processes Window.
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® Select aVerilog function or task or VHDL function or procedure from the Call Stack

Window.
GUI Elements of the Locals Window
This section describes the GUI elements specific to the Locals Window.

Column Descriptions

Table 4-17. Locals Window Columns

Column Description

Name lists the names of the immediately visible data objects.
This column also includes design object icons for the
objects, refer to the section “Design Object Icons and
Their Meanings” for more information

Vaue lists the current value(s) associated with each name
State Count Not shown by default. This column, State Hits, and
State % are all specific to coverage analysis
State Hits Not shown by default
State % Not shown by default
Popup Menu

Right-click anywhere in the Locals window to open a popup menu.

Table 4-18. Locals Window Popup Menu

Popup Menu Item Description

View Declaration Displays, in the Source window, the declaration
of the object

Add Adds the selected object(s) to the specified
window (Wave, List, Log, Dataflow, )

Copy Copies selected item to clipboard

Find Opens the Find toolbar at the bottom of the
window

Expand/Collapse Expands or collapses data in the window

Global Signal Radix Setsradix for selected signal(s) in all windows

Change Displays the Change Selected Variable Dialog
Box, which alows you to alter the value of the
object
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Change Selected Variable Dialog Box

This dialog box allows you to change the value of the object you selected. When you click
Change, the tool executes the change command on the object.

Figure 4-27. Change Selected Variable Dialog Box

Change Selected ¥ariable x|
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Yalue: | a

Change | Zancel |

The Change Selected Variable dialog is prepopul ated with the following information about the
object you had selected in the Locals window:

Variable Name — contains the complete name of the object.
Value — contains the current value of the object.

When you change the value of the object, you can enter any value that isvalid for the variable.
An array value must be specified as a string (without surrounding quotation marks). To modify
the valuesin arecord, you need to change each field separately.
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Memory Data Window

Use this window to view the contents of a memory.

Accessing

Access the window by:
® Double-clicking on amemory in the Memory List window.

Figure 4-28. Memory Data Window
B2 Memory Data - jtop/cfs0fatag_mem Y 1 H A x|
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Address Pane I Data Pane

Memory Data Window Tasks
This section describes tasks for using the Memory Data window.

Direct Address Navigation

Y ou can navigate to any address location directly by editing the address in the address column.
Double-click on any address, type in the desired address, and hit Enter. The address display
scrolls to the specified location.

Splitting the Memory Contents Window

To split amemory contents window into two screens displaying the contents of asingle memory
instance select Memory Data > Split Screen.
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Thisallows you to view different address locations within the same memory instance

simultaneously.

Figure 4-29. Split Screen View of Memory Contents
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GUI Elements of

the Memory Data Window

This section describes GUI elements specific to this Window.

Popup Menu

Right-click in the window to display the popup menu and select one of the following options:

Table 4-19. Memory Data Popup Menu — Address Pane

Popup Menu Item

Description

Goto Allowsyou to go to a specific address

Split Screen Splits the Memory Data window to allow you to
view different parts of the memory simultaneously.

Properties Allows you to set various properties for the Memory

Data window.

Close Instance

Closes the active Memory Data window.

Close All

Closes al Memory Data windows.
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Table 4-20. Memory Data Popup Menu — Data Pane

Popup Menu Item

Description

Edit

Allowsyou to edit the value of the selected data.

Change

Allows you to change data within the memory
through the use of the Change Memory dialog box.

Import Data Patterns

Allows you to import data patterns into the selected
memory through the Import Memory dialog box.

Export Data Petterns

Allows you to export data patterns from the selected
memory through the Export Memory dialog box.

Split Screen

Properties

Close Instance

Close All

Refer to itemsin the Memory Data Popup Menu —
Address Pane

Memory Data Menu

This menu becomes available in the Main menu when the Memory Data window is active.

Table 4-21. Memory Data Menu

Popup Menu Item

Description

Memory Declaration

Opens a Source window to the file and line number
where the memory is declared.

Compare Contents

Allows you to compare the selected memory against
another memory in the design or an external file.

Import Data Petterns

Export Data Patterns

Refer to itemsin the Memory Data Popup Menu —
Data Pane

Expand Packed Memories

Toggle the expansion of packed memories.

Identify Memories Within
Cells

Toggletheidentification of memorieswithin Verilog
cells.

Show VHDL String as
Memory

Toggle the identification of VHDL strings as
memories.

Split Screen

Refer to itemsin the Memory Data Popup Menu —
Address Pane
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Memory List Window
Use thiswindow to view alist of all memoriesin your design.

Single dimensional arrays of integers are interpreted as 2D memory arrays. In these cases, the
word width listed in the Memory window isequal to theinteger size, and the depth isthe size of
the array itself.

Memories with three or more dimensions display with aplussign’+’ next to their namesin the
Memory window. Click the '+’ to show the array indices under that level. When you finally
expand down to the 2D level, you can double-click on the index, and the data for the selected
2D dlice of the memory will appear in a memory contents window.

Prerequisites

The simulator identifies certain kinds of arrays in various scopes as memories. Memory
identification depends on the array element kind as well as the overall array kind (that is,
associative array, unpacked array, and so forth.).

Table 4-22. Memory Identification

VHDL Verilog/SystemVerilog SystemC
Element Kind!| * enum? any integral type (that is, * unsigned char
® hit_vector integer_type): ® unsigned short
* floating point type | ® shortint ® unsigned int
® std_logic_vector ®int ® unsigned long
® std ulogic vector | ® longint ® unsigned long long
® integer type ® byte ® char
® hit (2 state) ® short
® |ogic ®int
°® reg * float
® integer ® double
® time (4 state) ® enum
® packed struct/ ® sc bigint
packed union (2 state) | ® sc_biguint
® packed_struct/ ® sCint
packed _union (4 state) | ® sc_uint
® packed array ® sc signed
(single-Dim, multi-D,2 | ® sc_unsigned
state and 4 state)
® enum
® string
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Table 4-22. Memory Identification (cont.)

VHDL

Verilog/SystemVerilog

SystemC

Scope:

in

Recognizable

® architecture
® process
record

module

interface

package

compilation unit

struct

static variables within a
® task

® function

®* named block

® class

® sc_ module

Array

Kind ® single-dimensional

multi-dimensional

any combination of
unpacked, dynamic and
associative arrays’
real/shortreal

float

® single-dimensional
® multi-dimensional

1. The element can be "bit" or "std_ulogic" if the array has dimensionality >= 2.
2. These enumerated types must have at |east one enumeration literal that is not acharacter literal. The listed
width is the number of entriesin the enumerated type definition and the depth is the size of the array itself.

3. Any combination of unpacked, dynamic, and associative arraysis considered amemory, provided the | eaf
level of the data structure isastring or an integral type.

Accessing

Access the window using either of the following:

Menu item: View > Memory List

Command: view memory list
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Figure 4-30. Memory List Window
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Memory List Window Tasks

This section describes tasks for using the Memory List window.

Viewing Packed Arrays

By default, packed dimensions are treated as single vectors in the Memory List window. To
expand packed dimensions of packed arrays, select Memories> Expand Packed Memories.

To change the permanent default, edit the PrefMemory(ExpandPackedMem) variable. This
variable affects only packed arrays. If the variable is set to 1, the packed arrays are treated as
unpacked arrays and are expanded along the packed dimensions such that they appear as a
linearized bit vector. Refer to the section “ Simulator GUI Preferences” for details on setting
preference variables.

Viewing Memory Contents

When you double-click an instance on the Memory List window, Model Sim automatically
displays aMemory Data window, where the name used on the tab is taken from the name of the
instance, as seen in the Memory window. Y ou can also enter the command add mem
<instance> at the vsim command prompt.

Viewing Multiple Memory Instances

Y ou can view multiple memory instances simultaneously. A Memory Data window appears for
each instance you double-click in the Memory List window. When you open more than one
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window for the same memory, the name of the tab receives an numerical identifier after the
name, such as“(2)”.

Saving Memory Formats in a DO File

Y ou can save al open memory instances and their formats (for example, address radix, data
radix, and so forth) by creating aDO file.

1. Select the Memory List window
2. Select File > Save Format
displays the Save Memory Format dialog box
3. Enter thefile namein the “ Save memory format” dialog box

By default it is named mem.do. Thefilewill contain all open memory instances and their
formats.

Toload it at alater time, select File> L oad.

Saving Memories to the WLF File

By default, memories are not saved in the WLF file when you issuea"log -r /*" command. To
get memoriesinto the WLF file you will need to explicitly log them. For example:

log /top/dut/i0/mem
It you want to use wildcards, then you will need to remove memories from the WildcardFilter
list. To seewhat is currently in the WildcardFilter list, use the following command:

set WildcardFilter

If "Memories' isin thelist, reissue the set WildcardFilter command with all itemsin the list
except "Memories." For detals, see Using the WildcardFilter Preference Variable.

Note
For post-process debug, you can add the memoriesinto the Wave or List windows but the

Memory List window is not available.

GUI Elements of the Memory List Window

This section describes GUI elements specific to this Window.
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Column Descriptions

Table 4-23. Memory List Window Columns

Column Title Description
Instance Hierarchical name of the memory
Range Memory range
Depth Memory depth
Width Word width
Popup Menu

Right-click anywhere in the window to display the popup menu and select one of the following

options:

Table 4-24. Memory List Popup Menu

Popup Menu Item

Description

View Contents

Opens a Memory Data window for the selected
memory.

Memory Declaration

Opens a Source window to the file and line number
where the memory is declared.

Compare Contents

Allows you to compare the selected memory against
another memory in the design or an external file.

Import Data Petterns

Allows you to import data patterns into the selected
memory through the Import Memory dialog box.

Export Data Patterns

Allows you to export data patterns from the selected
memory through the Export Memory dialog box.
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Memory List Menu

This menu becomes available in the Main menu when the Memory List window is active.

Table 4-25. Memories Menu

Popup Menu Item Description

View Contents Refer to itemsin the Memory List Popup Menu

Memory Declaration

Compare Contents

Import Data Patterns
Export Data Patterns
Expand Packed Memories | Toggle the expansion of packed memories.

Identify Memories Within | Toggle the identification of memorieswithin Verilog

Cells cells.
Show VHDL String as Toggle the identification of VHDL strings as
Memory memories.
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Message Viewer Window

Use thiswindow to easily access, organize, and analyze any Note, Warning, Error or other
elaboration and runtime messages written to the transcript during the simulation run.

Prerequisites

By default, the tool writes transcripted messages during elaboration and runtime only to the
transcript. To write messages to the WLF file (thus the Message Viewer window), use the
-displaymsgmode and -msgmode options with the vsim commmand to change the default
behavior. By writing messagesto the WLF file, the Message Viewer window is able to organize
the messages for your analysis during the current ssmulation as well as during post simulation.

Y ou can control what messages are available in the transcript, WLF file, or both with the
following switches:

displaymsgmode messages — User generated messages resulting from callsto Verilog
Display System Tasks and PLI/FLI print function calls. By default, these messages are
written only to the transcript, which means you cannot access them through the Message
Viewer window. In many cases, these user generated messages are intended to be output
as agroup of transcripted messages, thus the default of transcript only. The Message
Viewer treats each message individually, therefore you could lose the context of these
grouped messages by modifying the view or sort order of the Message Viewer.

To change this default behavior you can use the -displaymsgmode argument with the
vsim command. The syntax is:

vsim -displaymsgmode {both | tran | wlf}
Y ou can aso use the displaymsgmode variable in the modelsim.ini file.
The message transcribing methods that are controlled by -displaymsgmode include:

Verilog Display System Tasks — Swrite, $display, $monitor, and $strobe. The
following also apply if they are sent to STDOUT: $fwrite, $fdisplay, $fmonitor, and
$fstrobe.

msgmode messages — All elaboration and runtime messages not part of the
displaymsgmode messages. By default, these messages are written only to the transcript.
To change this default behavior you can use the -msgmode argument with the veim
command. The syntax is:

vsim -msgmode {both | tran | wlf}

To write messagesto the WLF file and transcript, which provides access to the messages
through the Message Viewer window, you can also use the msgmode variable in the
modelsim.ini file.
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Accessing

Access the window using either of the following:

®* Menuitem: View > Message Viewer and select aloaded WLF dataset for viewing

® Command: view msgviewer <dataset>.wlf

Figure 4-31. Message Viewer Window
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Message Viewer Window Tasks
Figure 4-32 and Table 4-26 provide an overview of the Message Viewer and severa tasksyou

can perform.
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Table 4-26. Message Viewer Tasks

Icon | Task Action
1 Display a detailed description of the Right-click the message text
message. then select View Verbose
M essage.

Open message in Source window Double-click the message in the
Message Column.

Expand a hierarchical node Double-click on anon-leaf node
in the Messages column.

2 Open the Configuration Options for L eft-click the down arrow to
Message Viewer dialog. Provides accessto | toggle the “drawer” open and
Analysis Questions, Column Layout, Filter | closed.

Expression, Hierarchy Configuration and
Sort Configuration.

3 Open the sourcefile and add abookmark to | Double-click the object name(s).
the location of the object(s).

3 Change the focus of the Structure and Double-click the hierarchical
Objects windows. reference.

4 Open the source file and set amarker at the | Double-click the file name.

line number.
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GUI Elements of the Message Viewer Window

This section describes the GUI elements specific to this window.

Column Descriptions

Table 4-27. Message Viewer Window Columns

Column Description
Assertion Expression Assertion expression associated with the message
Assertion Filename Name of the file where the assertion failure message originated
Assertion Line Number | Line number within the filename where the message originated
Assertion Name Name of the assertion associated with the message
Assertion Start Time Start time of the assertion associated with the message
Category Keyword for the various categories of messages:
* DISPLAY
* FLI
°* PA
* PLI
* SDF
® TCHK
* VCD
* VITAL
* WLF
* MISC
® <user-defined>
Comment User comment
Compulsory Whether an item was in a compulsory (required) test for ranking
Count Date the test was run (in UCDB format)
CPU Time Total CPU time consumed
Date Date the test was run
FileInfo Filename related to the cause of the message, and in some cases
the line number in parentheses
Host OS Operating system in use by the host on which the test was run
Hostname Name of host (server) on which the test was run
instance Instance or region associated with the message
Iteration/Delta Iteration (delta) in which the message occurs
LOG name Name (path) to the generated log/transcript file
MEMUSAGE Total memory used by the ssmulator for the test

ModelSim GUI Reference Manual, v10.3a

149



Window Reference
Message Viewer Window

Table 4-27. Message Viewer Window Columns (cont.)

Column Description

Message Organized tree-structure of the sorted messages, as well as, when
expanded, the text of the messages.

Message ID Message ID

Message ID Name Message ID name

Objects Object(s) related to the message, if any.

Process Process or leaf associated with the message

Region Hierarchical region related to the message, if any

run CWD Directory in which the test was run

Seed Random seed

Severity M essage severity, such as Warning, Note or Error.

Sim Time Total ssimulation time

sim Timeunits Timeunit used by the simulation

Source File Name Name of the file where the message originated

Source File Number Declaration number of the file associated with the message

Source Line Number Line number within "filename" where the message originated

Test Args Application command used to generate the coverage data if the
datawas not generated by vsim, similar to how Vsim Args
operates for vsim commands

Test Name Name of the test

Test Status Completion status (OK, Error, €etc.)

Time Time of simulation when the message was issued.
Timing Check Kind Information about timing checks

UCDB Filename Name of the UCDB file from which the test was imported
User ID Username under which the test was run

VRM Context Username under which the test was run

Vsim Args Arguments passed to vsim command

WLF Filename Name of WLF file from which message was imported
WLF Name Name (path) to the generated WLF file

WLF Raw Time Simulation time (in ticks) associated with the message
WLF Time Unit Simulation time unit
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Popup Menu

Right-click anywhere in the window to open a popup menu that contains the following

selections:

Table 4-28. Message Viewer Window Popup Menu

Popup Menu Item

Description

Reload Viewer Data

Opens a Source window for the file, and in some cases takes you
to the associated line number.

View

Verbose Message
Message Source

Log File

Object Declarations
Assertion Info

ATV

Change Environment
Waveform:

® Goto Timein Wave
® Add Objsto Wave

Opens selected item:
Verbose Message dialog box with details about message
Source code at line number where message is
Log file, in a Source window
Object window, to view declarations
Assertion window, to view assertions
ATV, to view assertion threads
Change environment
Waveform window, opens:
at time of selected message
adds objects associated with selected message

Analysis Questions

Opens Analysis Questions dialog box; used for saving and
managing specific queries of the data.

Filter Expressions

Opens Filter Expressions dialog; used for saving and managing
filters.

Hierarchy Configurations

Opens Hierarchy Configurations dialog box; used for saving and
managing particular hierarchy configurations of the data.

Column Layouts

Opens Configure Column Layout dialog; used for creating,
editing and managing the configuration of columns.

Show Titlesin Hier

Toggles on and off showing the titles within the hierarchy column

Column
Global Options Configures how/when Message Viewer opens.
Edit Transforms... Opens adialog which will open atransform rulesfile for editing

with the Transform Rule File Editor.

L oad/Save Setup File

L oads/Saves a particular setup to a name you specify.

Expand/Collapse
Selected/All

Manipulates the expansion of the Messages column.

Related GUI Features

®* The Messages Bar in the Wave window provides indicators as to when a message

occurred.
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Message Viewer Configuration of Data

The Message Viewer window containsa“drawer” of optionsfor configuring the data, including
analysis questions, column layouts, filter expressions, hierarchy of data, and sort configurations.
The“drawer”, where all these settings can be set in one convenient location, is opened with a
small toggle button at the bottom of the window, as highlighted in Figure 4-33.

Figure 4-33. Configuration Options for Message Viewer

 H®oE) 3

~1

—

Analysis Question | Configure...

Column Layout |Defnult Configure...

Filter Expression |NOFilter Configure...

Hierarchy Configuration |Defﬂu1t Configure...

4 |C[C[d 4

Sort Configuration | Caonfigure...

Custom Hierarchy Configurations

To save your own custom column layout and any filter settings to an external file
(<msgviewer>.do), select File > Export > Hierarchy Configuration while the window is
active. Y ou can reload these settings with the do command. This export does not retain changes
to column width.

Edit Filter Expressions Dialog Box

Y ou can customize exactly which messages are shown in both the Message Viewer and the
Results Analysis windows using the Filter Expressions > [Configure Filter] > Filter Expressions
dialog box.

® Filter Expression Terms area— Create filter rules that specify which messages are
shown in the windows. From left to right, each filter rule is made up of the following:

o Add and Remove buttons — either add arule filter row below the current row or
remove that rule filter row.

o Logicfield — specifiesalogical argument for combining adjacent rules. Y our
choicesare: AND, OR, NAND, and NOR.

o Open Parenthesis field — controls rule groupings by specifying, if necessary, any
open parentheses. The up and down arrows increase or decrease the number of
parentheses in the field.

o Column field — specifies that your filter value appliesto a specific column of the
Message Viewer.

o Inclusion field — specifies whether the Column field should or should not contain a
given value.
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o For text-based filter values your choices are: Contains, Doesn’'t Contain, or Exact.
o For numeric- and time-based filter values your choices are: ==, I=, <, <=, >, and >=.

o Case Sensitivity field — specifies whether your filter rule should treat your filter
value as Case Sensitive or Case Insensitive. Thisfield only applies to text-based
filter values.

o Filter Value field — specifies the filter value associated with your filter rule.

o Time Unit field — specifies the time unit. Y our choices are: fs, ps, ns, us, ms. This
field only appliesto the Time selection from the Column field.

o Closed Parenthesis field — controls rule groupings by specifying, if necessary, any
closed parentheses. The up and down arrows increase or decrease the number of
parentheses in the field.

® First Message Filter area— Allows you to control the appearance of either all matching
messages or just the first matching message (with further filtering options).

®* Time Range are— Allows you to filter which messages appear according to simulation
time. The default isto display messages for the complete simulation time.

* Displayed Objects area— Allows you to filter which messages appear according to the
values in the Objects column. The default isto display al messages, regardless of the
valuesin the Objects column. The Objectsin thelist text entry box allows you to specify
filter strings, where each string must be on anew line.

The Edit Filter Expression dialog box in Figure 4-34 shows an example where you want to
show all messages, either errors or warnings, that reference the 15th line of the file cells.v.

Figure 4-34. Edit Filter Expression Dialog Box

@ @[ =t 2llsevericy  w|[contains w|[case Insensicive w[exrox = =l
9 @fm w[ 2[severity  wl[contains ¥|[case Insensitive w|[varning =
9 @ wl[i 2[ineiwver  wl[-- ha| 5 [ 2
O @[mo w|[ 2llFilensme  w[concains w|[case sensitive w[cells.v =
-
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Objects Window

Use this window to view the names and current values of declared data objects in the current

region, as selected in the Structure window.

Viewable data objects include:

signals
nets

registers

constants and variables not declared in a process

generics

parameters

Accessing

Access the window using either of the following:

Menu item: View > Objects

Command: view objects

Wave window: View Objects Window Button

. I|:|'||-|1‘

E_ Value mm

4. data_width
4 addr_width
[+ .:||:||:|r
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Figure 4-35. Objects Window
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Objects Window Tasks

This section describes tasks for using the Objects window.

Hn-t
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Pack...
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. Internal
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Interacting with Other Windows

1. Click an entry in the window to highlight that object in the Dataflow, and Wave
windows.

2. Double-click an entry to highlights that object in a Source window

Setting Signal Radix
Y ou can set the signal radix for a selected signal or signalsin the Objects window as follows:

1. Click (LMB) asignal to select it or use Ctrl-Click Shift-Click to select a group of
signals.

2. Select Objects > Radix from the menu bar; or right-click the selected signal(s) and
select Radix from the popup menu.

This opens the Signal Radix dialog box (Figure 4-36), where you may select a radix.
This sets the radix for the selected signal(s) in the Objects window and every other
window where the signal appears.

Figure 4-36. Setting the Global Signal Radix from the Objects Window
Signal Radix

Signal: jftestl rrw

Specify radix ko apply ko the selected signalis):

(¥ Mone (use session default)
Svmbaolic

Einary

Octal

Decimal

Insigned

Hezxadecimal

8511

Tirne

B B T T S I

[ Show Base

oK | Cancell .ﬁ.ppl':.f|

Finding Contents of the Objects Window

Y ou can filter the contents of the Objects window by either the Name or Vaue columns.

1. Citrl-F to display the Find box at the bottom of the window.
2. Click the“Search For” button and select the column to filter on.
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3. Enter astring in the Find text box
4. Enter

Refer to the section “Find and Filter Functions’ for more information.

Filtering Contents of the Objects Window

Y ou can filter the contents of the Objects window by the Name column.

1. Citrl-F to display the Find box at the bottom of the window.
2. Citrl-M to changeto “Contains’ mode.
3. Enter astring in the Contains text box
The filtering will occur as you begin typing. Y ou can disable this feature with Ctrl-T.

Filters are stored relative to the region selected in the Structure window. If you re-select a
region that had afilter applied, that filter is restored. Thisallowsyou to apply different filtersto
different regions.

Refer to the section “Find and Filter Functions’ for more information.

Filtering by Signal Type

The View > Filter menu selection allows you to specify which signal typesto display in the
Objects window. Multiple options can be selected. Select Change Filter to open the Filter
Objects dialog, where you can select port modes and object types to be displayed.

Popup Menu

Right-click anywhere in the window to display the popup menu and select one of the following
options:

Table 4-29. Objects Window Popup Menu

Popup Menu Item Description

View Declaration Opens a Source window to the declaration of the
object

View Memory Contents

Add Wave Adds the selected object(s) to the Wave window

Add Wave New Creates a new instance of the Wave window and
adds the selected object(s) to that window.

Add WaveTo Opens adrop down list of Wave windows when

multiple windows exist. Adds the selected object(s)
to the selected Wave window.
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Table 4-29. Objects Window Popup Menu (cont.)

Popup Menu Item Description
Add Dataflow Adds the selected object(s) to a Dataflow window
Addto Add the selected object(s) to any one of the

following: Wave window, List window, Log file,
Schematic window, Dataflow window. Y ou may
choose to add only the Selected Signals, al Signals
in Region, all Signalsin Design.

Copy Copies information about the object to the clipboard
Find Opens the Find box

Insert Breakpoint Adds a breakpoint for the selected object

Modify Modify the selected object(s) by selecting one of the

following from the submenu:

® Force - opens Force Selected Signal dialog
Remove Force - remove effect of force command
Change Vaue - change value of selected
Apply Clock - opens Define Clock dialog
Apply Wave - opens Create Pattern Wizard

Radix Opens Signal Radix dialog, alowing you to set the
radix of selected signal(s) in all windows

Show Shows list of port types and object kinds that are
displayed. Includes a Change Filter selection that
opens the Filter Objects dialog, which allows you to
filter the display.

GUI Elements of the Objects Window

This section describes GUI elements specific to this Window.

Current Time Label — Displays the Current Time or the Now (end of simulation)
time. Thisisthe time used to control state values annotated in the window. (For details,
see Current Time Label.)
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Column Descriptions

Object Window Dedicated Toolbar

Table 4-30. Toggle Coverage Columns in the Objects Window

Column name | Description

Name the name of each object in the current region
Vaue the current value of each object

Kind the object type

Mode the object mode (interndl, in, out, and so forth.)

The Objectfilter toolbar provides filtering of design objects appearing in the Objects window.

Figure 4-37. Object Window Toolbar

| o] w) @] wl

Table 4-31. Object Window Toolbar Buttons

Button | Name Shortcuts Description
View Inputs | None Changes the view of the Objects Window
I Only to show inputs.
View None Changes the view of the Objects Window
i) | | outputs Only to show outputs.
View Inouts | None Changes the view of the Objects Window
I.|"|::' Only to show inouts.
i ViesInternal | None Changes the view of the Objects Window
1 Signals to show Internal Signals.
Reset All None Clearsthe filtering of Objects Window
ALL| | Filters entries and displays all objects.
é}" Change Filter | None Opens the Filter Objects dialog box.
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Processes Window

Use thiswindow to view alist of HDL processes in one of four viewing modes:

Active — (default) active processes in your simulation.
In Region — process in the selected region.

Design — intended for primary navigation of ESL (Electronic System Level) designs
where processes are aforemost consideration.

Hierarchy — atree view of any SystemVerilog nested fork-joins.
In addition, the data in this window will change as you run your simulation and processes
change states or become inactive.
Accessing

Access the window using either of the following:

* Menuitem: View > Process

® Command: view process

Figure 4-38. Processes Window
Fr||||-=n|-=1IH||'||-'I 5.

Tluame  [Type(fitered)  |state  [order [parentPath |

4 RINITIAL#17 Initial Ready 4 Jbest_counter
4 RINITIAL#ZS Initial g Jrest_counter

4 RINITIAL#30 Iriitial Leady ) [test_counter

Processes Window Tasks

This section describes tasks for using the Processes window.

Changing Your Viewing Mode

Y ou can change the display to show all the processesin aregion or in the entire design by doing
any one of the following:

® Select Process > In Region, Design, Active, or Hierarchy.
® Usethe Process Toolbar

® Right-click in the Process window and select I n Region, Design, Active, or Hierarchy.
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The view mode you select is persistent and is “ remembered” when you exit the ssmulation. The
next time you bring up the tool, this window will initialize in the last view mode used.

Filtering Processes

Y ou can control which processes are visible in the Processes window as follows:

1. Right-click in the Processes window and select Display Options.

2. Inthe Process Display Options dialog box select the Type or States you want to include
or exclude from the window.

3. OK

When you filter the window according to specific process states, the heading of the State
column changes to “ State (filtered)” as shown in Figure 4-39.

Figure 4-39. Column Heading Changes When States are Filtered

Process (Design) —78 i —n——————————— O&
Mame Type (filkered) |State (filtered) porder © [Parent Path
. |
o #ALWAYSE15S Always Ready Z(Mexk Ackive)  ftopfc

The default “No Implicit & Primitive” selection causes the Process window to display all
process types except implicit and primitive types. When you filter the display according to
specific process types, the heading of the Type column becomes “Type (filtered)”.

Once you select the options, data will update as the simulation runs and processes change their
states. When the In Region view mode is selected, data will update according to the region
selected in the Structure window.

Viewing the Full Path of the Process
By default, al processes are displayed without the full hierarchical context (path). Y ou can

display processes with the full path by selecting Process > Show Full Path
Viewing Processes in Post-Processing Mode

Thiswindow also shows datain the post-processing (WLF view or Coverage view) mode. Y ou
will need to log processes in the simulation mode to be able to view them in post-processing
mode.

In the post-processing mode, the default selection values will be same as the default valuesin
the live simulation mode.

Things to remember about the post-processing mode:

ModelSim GUI Reference Manual, v10.3a 161



Window Reference
Processes Window

® There are no active processes, so the Active view mode selection will not show
anything.

® All processes will have same ‘Done’ state in the post-processing mode.

®* Thereisno order information, so the Order column will show *-* for all processes.

Setting a Ready Process as the Next Active Process

Y ou can select any “Ready” process and set it to be the next Active process executed by the
simulator, ahead of any other queued processes. To do this, simply right-click any “Ready”
process and select Set Next Active from the popup context menu.

When you set a process as the next active process, you will see “(Next Active)” in the Order
column of that process (Figure 4-40).

Figure 4-40. Next Active Process Displayed in Order Column

Process (Design)

Mame Type (filkered)| State Crder © [Parent Path =

.
o FALWAYSHISE  Always Ready 2(Mext Active) |ftopfc

(58 8 S

Creating Textual Process Report

Y ou can create atextual report of all processes by using the process report command.

Figure 4-41. Sample Process Report in the Transcript Window

Transcripk

# Configuration;

#  MiewMode = [achive]

#  Wisible Types = [noimplprimm]

#  Wisible States = [all]

#  SorkMode = [arder]

#  Fullpath =1

#

# | Type | skate | Order | Mame

*

# | Initial | Active | 1 | Jop/pl#INITIAL#659

# | Abways | Ready |2 | fhopfofalwWAYSH#155

# | always | Ready |3 | feopim/#alw Ay S#3s

#*

# -
‘ l Transcripk I ﬂi‘l
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GUI Elements of the Processes Window

This section describes GUI elements specific to this Window.

Column Descriptions

Table 4-32. Processes Window Column Descriptions

Column Title Description
Name Name of the process.
ClassInfo SystemVerilog class object id or UVM

component name.

Order Execution order of al processesin the
Active and Ready states. Refer to the
section “ Process Order Description” for
more information.

Parent Path Hierarchical parent pathname of the process

State Process state. Refer to the section “Process
State Definitions” for more information.

Type Process type, according to the language.
Refer to the section “Process Type
Definitions’ for more information.

Process State Definitions

The process states reported under the State column heading are:

I dle — Indicates an inactive SystemC Method, or a process that has never been active.
The ldle state will occur only for SC processes or methods. It will never occur for HDL
Processes.

Wait — Indicates the processis waiting for awake up trigger (changein VHDL signal,
Verilog net, SystemC signal, or atime period).

Ready — Indicates the process is scheduled to be executed in current sSimulation phase
(or in active simulation queue) of current delta cycle.

Active — Indicates the processis currently active and being executed.

Queued — Indicates the process is scheduled to be executed in current delta cycle, but
not in current simulation phase (or in active simulation queue).

Done — Indicates the process has been terminated, and will never restart during current
simulation run.
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Processes in the Idle and Wait states are distinguished as follows. Idle processes (except for
ScMethods) have never been executed before in the simulation, and therefore have never been
suspended. Idle processes will become Active, Ready, or Queued when atrigger occurs. A
process in the Wait state has been executed before but has been suspended, and is now waiting
for atrigger.

SystemC methods can have one of the four states: Active, Ready, Idle or Queued. When
ScMethods are not being executed (Active), or scheduled (Ready or Queued), they are inactive
(Idle). ScMethods execute in 0 time, whenever they get triggered. They are never suspended or
terminated.

Process Type Definitions

The Type column displays the process type according to the language used. It includes the
following types:

* Always

®* Assign

* Fina

® Fork-Join (dynamic process like fork-join, sc_spawn, and so forth.)

® |nitia

* Implicit (internal processes created by simulator like Implicit wires, and so forth.)
® Primitive (UDP, Gates, and so forth.)

* ScMethod

® ScThread (SC Thread and SC CThread processes)

* VHDL Process

Process Order Description

The Order column displays the execution order of all processes in the Active and Ready states
in the active kernel queue. Processes that are not in the Active or Ready states do not yet have
any order, in which case the column displays a dash (-). The Process window updates the
execution order automatically as simulation proceeds.
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The Source window allows you to view and edit source files as well as set breakpoints, step
through design files, and view code coverage statistics.

By default, the Source window displays your source code with line numbers. Y ou may also see

the following graphic elements:

Red line number s — denote executable lines, where you can set a breakpoint

Blue arrow — denotes the currently active line or a process that you have selected in

the Processes Window

Red ball in line number column — denotes file-line breakpoints; gray ball denotes

breakpoints that are currently disabled

Blueflag in line number column — denotes line bookmarks

Figure 4-42. Source Window

E| {examples ftutorials fverilog basicSimulationftcounter. v (ftest_counter) - Default [H

=l

Ln# J@ }I—L’S Driver Lines | < |» | | B Fow = ¢
18 imitial // Clock generator ;l
19 E  begin

20 clk = 07

21 | | forever #10 clk = rcik;

22 end

23 -

24 initial // Tesat stimalus

25 E  begin

25 A reset = 0;

27 #5 resst = 1:

28 #4 reset = 0;

29 end

30 -

31 initial o
32 smeniter{$stime, , reset,, clk,,, count);

o

Current Time L abel — displaysthe Current Time or the Now (end of simulation) time.
Thisisthetime used to control state values annotated in the window (For details, refer to

Current Time Label.)

Code Folding I ndicator s— denotes sections of code that can be folded or expanded
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Opening Source Files

Y ou can open source files using the File > Open command or by clicking the Open icon.
Alternatively, you can open source files by double-clicking objectsin other windows. For
example, if you double-click an item in the Objects window or in the structure tab (sim tab), the
underlying source file for the object will open in the Source window and scroll to the line where
the object is defined.

From the command line you can use the edit command.

By default, files you open from within the design (such as when you double-click an object in
the Objects window) open in Read Only mode. To make the file editable, right-click in the
Source window and select (uncheck) Read Only. To change this default behavior, set the

Pref Source(ReadOnly) variable to 0. Refer to Simulator GUI Preferences for details on setting
preference variables.

Disabling Automatic Opening of Source Files

By default, the Source window opens when the simulator hits a breakpoint, encounters acall to
$finish(), or you are single stepping through your code. In each case, the simulator stops, the
Source window opens and displays the last line of code that was executed. Y ou can disable
automatic opening by changing the preference variable settings:

® Breakpoints — Set the Pref Source(OpenOnBreak) variable to 0.
® S$finish() call — Set the Pref Source(OpenOnFinish) variable to 0.
® Single Stepping — Set the Pref Source(OpenOnStep) variable to O.

Displaying Multiple Source Files

By default each file you open or create is marked by awindow tab, as shown in the graphic
below.
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Figure 4-43. Displaying Multiple Source Files

E] C:fexamples ftutorials fverilog /dataflow/proc.v {ftop/p) - Default
Ln# || 3¢ 1/3 Driver Lines| i | | 1+ @ 2065 n= |+ |e
34 J; -]
35 E task read;
36 input [“addr size-1:0] ar
37 output [ word size-1:0] d:
38 = begin
39 if (wverbose) fdisplavy("%t: Reading from addr=%h", 5time, a):
40 addr r = ar oo
41 w_r = 1;

Source File Tabs

42 strb_r = 0;

43 @ {posedge clk) strb r = 1;

44 @ {posedge clk) while (rdy !'= 0) M({posedge clk)
45 d = data;

48 = end

47

Dragging and Dropping Objects into the Wave and
List Windows

Model Sim allows you to drag and drop objects from the Source window to the Wave and List
windows. Double-click an object to highlight it, then drag the object to the Wave or List
window. To place agroup of objectsinto the Wave and List windows, drag and drop any section
of highlighted code. When an object is dragged and dropped into the Wave window, the add
wave command will be reflected in the Transcript window.

Setting your Context by Navigating Source Files

When debugging your design from within the GUI, you can change your context while
analyzing your source files. Figure 4-44 shows the pop-up menu the tool displays after you
select then right-click an instance namein a sourcefile.
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Figure 4-44. Setting Context from Source Files

E| C:jexamples ftutorials fverilog/dataflowfproc.v {ftop/p) - Default s £
tn# |3k ¢ 1/3Driver Lines| < > | ¢ @ 2065
35 [l] task read;

38 & input [“addr size-1:0] a:
37 output [ word_size-1:0] d;
38 [ begin
359 if (verbose) Sdisplav(T%t: Reading from addr=%h", Stime, a);
40 0 addr r = a; ST
41 i r=1; S
42 st;]:- r=0; Ascend Env
15 A - Back L4
i proc.v(71) [ Foward ]|
S cache.v(30)
45 sim: ftop c/ £ASSIGN %29 Add '
6 Structure(sim: /top/c/ZASSIGNE29) Cu G+
a7 cache.v(29) Cop CiHE
48 r | Paste Girl+
1 Find... Ctrl+F
ﬂw“e x proc.v =l cache.w K | memory. Examine "

Thetitle bar of the Source window displays your current context, parenthetically, after thefile
name and location. This changes as you alter your context, either through the pop-up menu or
by changing your selection in the Structure window.

This functionality allows you to easily navigate your design for debugging purposes by
remembering where you have been, similar to the functionality in most web browsers. The
navigation options in the pop-up menu function as follows:

® Open Instance — changes your context to the instance you have selected within the
sourcefile. Thisisnot availableif you have not placed your cursor in, or highlighted the
name of, an instance within your sourcefile.

If any ambiguities exists, most likely due to generate statements, this option opens a
dialog box allowing you to choose from all available instances.

® Ascend Env — changes your context to the file and line number in the parent region
wherethe current regionisinstantiated. Thisisnot availableif you are at the top-level of
your design.

* Forward/Back — allows you to change to previously selected contexts. Thisis not
available if you have not changed your context.

The Open Instance option is essentially executing aCn environment command to change your
context, therefore any time you use this command manually at the command prompt, that
information is also saved for use with the Forward/Back options.
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Highlighted Text in a Source Window

The Source window can display text that is highlighted as aresult of various conditions or
operations, such as the following:

® Double-clicking an error message in the transcript shown during compilation

In these cases, the relevant text in the source code is shown with a persistent highlighting. To
remove this highlighted display, choose M ore > Clear Highlights from the right-click popup
menu of the Source window. If the Source window is docked, you can also perform this action
by selecting Source > More > Clear Highlights from the Main menu. If the window is
undocked, select Edit > Advanced > Clear Highlights.

Note
Clear Highlights does not affect text that you have selected with the mouse cursor.

Example

To produce a compile error that displays highlighted text in the Source window, do the
following:

1. Choose Compile > Compile Options

2. Inthe Compiler Options dialog box, click either the VHDL tab or the Verilog &
SystemVerilog tab.

3. Enable Show source lines with errors and click OK.

4. Openadesignfileand create aknown compile error (such as changing the word “ entity”
to “entry” or “modul€” to “nodule”).

5. Choose Compile > Compile and then complete the Compile Source Files dialog box to
finish compiling thefile.

6. When the compile error appearsin the Transcript window, double-click oniit.

7. The source window is opened (if needed), and the text containing the error is
highlighted.

8. Toremove the highlighting, choose Source > More > Clear Highlights.

Hyperlinked Text in a Source Window

The Source window supports hyperlinked navigation. To turn hyperlinked text on or off in the
Source window, do the following:

1. Click anywherein the Source window to make it the active window.

2. Select Source > Show Hyperlinks.
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When you double-click on hyperlinked text, the selection jumps from the usage of an object to
its declaration. This provides the following operations:

* Jump from the usage of asignal, parameter, macro, or a variable to its declaration.
* Jump from amodule declaration to its instantiation, and vice versa.

* Navigate back and forth between visited source files.

Coverage Numbers Mismatch Source

Setting File-Line Breakpoints with the GUI

Y ou can easily set file-line breakpointsin your source code by clicking your mouse cursor in the
line number column of a Source window. Click the left mouse button in the line number column
next to ared line number and ared ball denoting a breakpoint will appear (Figure 4-45).

Figure 4-45. Breakpoint in the Source Window

Ln# | 1% B How [#]k
22 [l] task write; ;l
53 input [‘"addr size-1:0] a;

54 input [“word _size-1:0] dr

55 © begin

o6 if {werbose) sdisplayv({"%t: Writing data=3%h to addr=3%h
37 0 addr r = a; —
5B rw r = 0;

59 strb r = 0;

al @ (posedge clk) strbk r = 1;

Lu]

1 data_r = d; il
4| | »

The breakpoint markers are toggles. Click once to create the breakpoint; click again to disable
or enable the breakpoint.

To delete the breakpoint completely, right click the red breakpoint marker, and select Remove
Breakpoint. Other options on the context menu include:

Disable Breakpoint — Deactivate the selected breakpoint.
Edit Breakpoint — Open the File Breakpoint dialog to change breakpoint arguments.
Edit All Breakpoints — Open the Modify Breakpoints dialog.

Run Until Here — Run the simulation from the current simulation time up to the
specified line of code. Refer to Run Until Here for more information.
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Add/Remove Bookmar k — Add or remove afile-line bookmark.

Adding File-Line Breakpoints with the bp Command

Use the bp command to add afile-line breakpoint from the VSIM> prompt.

For example:

bp top.vhd 147
sets a breakpoint in the source file top.vhd at line 147.

Editing File-Line Breakpoints

To modify (or add) a breakpoint according to the line number in a source file, do any one of the
following:

® Select Tools > Breakpoints from the Main menu.
* Right-click a breakpoint and select Edit All Breakpoints from the popup menu.
® Click the Edit Breakpointstoolbar button. See Simulate Toolbar.

This displays the Modify Breakpoints dialog box shown in Figure 4-46.
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Figure 4-46. Modifying Existing Breakpoints
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The Modify Breakpoints dialog box provides alist of al breakpointsin the design. To modify a
breakpoint, do the following:

1. Select afile-line breakpoint from the list.

2. Click Modify, which opens the File Breakpoint dialog box shown in Figure 4-46.

3. Fill out any of the following fields to modify the selected breakpoint:
Breakpoint Label — Designates alabel for the breakpoint.
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I nstance Name — The full pathname to an instance that sets an HDL or SystemC
breakpoint so it applies only to that specified instance.

Breakpoint Condition — One or more conditions that determine whether the
breakpoint is observed. If the condition is true, the simulation stops at the
breakpoint. If false, the simulation bypasses the breakpoint. A condition cannot refer
toaVHDL variable (only asignal). Refer to the tip below for more information on
proper syntax for breakpoints entered in the GUI.

Breakpoint Command — A string, enclosed in braces ({}) that specifies one or
more commands to be executed at the breakpoint. Use a semicolon (;) to separate
multiple commands.

0 Tip: All fieldsin the File Breakpoint dialog box, except the Breakpoint Condition field,
use the same syntax and format as the -inst switch and the command string of the bp
command. Do not enclose the expression entered in the Breakpoint Condition field in
quotation marks (“* ). For more information on these command options, refer to the bp
command in the Questa SV/AFV Reference Manual.

4. Click OK to close the File Breakpoints dialog box.
5. Click OK to close the Modify Breakpoints dialog box.

Loading and Saving Breakpoints

The Modify Breakpoints dialog (Figure 4-46) includes Load and Save buttons that allow you to
load or save breakpoints.

Setting Conditional Breakpoints

In dynamic class-based code, an expression can be executed by more than one object or class
instance during the ssimulation of a design. Y ou set a conditional breakpoint on the linein the
source file that defines the expression and specifies a condition of the expression or instance
you want to examine. Y ou can write conditional breakpoints to eval uate an absolute expression
or arelative expression.

Y ou can use the SystemVerilog keyword this when writing conditional breakpoints to refer to
properties, parameters or methods of an instance. The value of this changes every time the
expression is evaluated based on the properties of the current instance. Y our context must be
within alocal method of the same class when specifying the keyword thisin the condition for a
breakpoint. Strings are not allowed.

The conditional breakpoint examples below refer to the following SystemV erilog source code
file source.sv:

Figure 4-47. Source Code for source.sv
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W oo JoulidhWN R

class Simple;
integer cnt;
integer 1id;
Simple next;

function new(int x);
id=x;
cnt=0
next=null
endfunction

task up;
cnt=cnt+1;
if (next) begin
next.up;
end
endtask
endclass

module test;
reg clk;
Simple a;
Simple b;

initial
begin
a = new(7);
b = new(5);
end

always @ (posedge clk)
begin
a.up;
b.up;
a.up
end;
endmodule

Prerequisites

Compile and load your simulation.

Setting a Breakpoint For a Specific Instance

Enter the following on the command line:

Results

bp simple.sv 13 -cond {this.id==7}

The simulation breaks at line 13 of the simple.sv source file (Figure 4-47) the first time module
a hits the expression because the breakpoint is evaluating for anid of 7 (refer to line 27).
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Setting a Breakpoint For a Specified Value of Any
Instance

Enter the following on the command line:

bp simple.sv 13 -cond {this.cnt==8}

Results

The simulation evaluates the expression at line 13 in the simple.sv source file (Figure 4-47),
continuing the simulation run if the breakpoint evaluates to false. When an instance evaluates to
true the simulation stops, the source is opened and highlights line 13 with ablue arrow. The first
time cnt=8 evaluates to true, the simulation breaks for an instance of module Simple b. When
you resume the simul ation, the expression eval uates to cnt=8 again, but thistime for an instance
of module Simple a.

Y ou can also set this breakpoint with the GUI:

1. Right-click on line 13 of the simple.sv sourcefile.
2. Select Edit Breakpoint 13 from the drop menu.
3. Enter

this.cnt==8

in the Breakpoint Condition field of the M odify Breakpoint dialog box. (Refer to
Figure 4-46) Note that the file name and line number are automatically entered.

Checking Object Values and Descriptions

Y ou can check the value or description of signals, indexes, and other objects in the Source
window.There are two quick methods to determine the value and description of an object:

® Select an object, then right-click and select Examine or Describe from the context
menu.

® Pause the cursor over an object to see an examine pop-up
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Figure 4-48. Source Window Description
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Y ou can select Sour ce > Examine Now or Source > Examine Current Cursor to choose at
what simulation time the object is examined or described.

Y ou can aso invoke the examine and/or describe commands on the command line or in a
macro.

Marking Lines with Bookmarks

Source window bookmarks are blue flags that mark linesin a source file. These graphical icons
may ease navigation through a large source file by highlighting certain lines.

As noted above in the discussion about finding text in the Source window, you can insert
bookmarks on any line containing the text for which you are searching. The other method for
inserting bookmarks is to right-click aline number and select Add/Remove Bookmark. To
remove a bookmark, right-click the line number and select Add/Remove Bookmark again.

To remove all bookmarks from the Source window, select Source > Clear Bookmar ks from
the menu bar when the Source window is active.

Performing Incremental Search for Specific Code

The Source window includes a Find function that allows you to do an incremental

@ | search for specific code. To activate the Find bar (Figure 4-49) in the Source window
select Edit > Find from the Main menus or click the Find icon in the Main toolbar. For
more information see Find and Filter Functions.
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Figure 4-49. Source Window with Find Toolbar
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Customizing the Source Window

Y ou can customize the appearance and behavior of the Source window in several ways,
including, but not limited to:

® Changing amodelsim.ini variable: for example, character encoding of filesis controlled
by the DefaultRadix variable

® Changing a preference variable: for example,

o tab spacing: change the Pref Source(tabs) preference variable. Refer to Simulator
GUI Preferences for details on setting preference variables.

o Syntax highlighting: change the Pref Source(highlightExecutablel ines) preference
variable.

o Underlining of hyperlinked code: change the prefMain(HyperLinkingUnderline)
preference variable.

® Genera Source window fonts and appearance: select Source > Tools > Edit
Pr efer ences and make changes to the settings on the By Window tab.

Refer to the GUI Preferences appendix for more information.
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Use this window to view the hierarchical structure of the active simulation.

The name of the structure window, as shown in thetitle bar or in the tab if grouped with other
windows, can vary:

sim — Thisisthe name shown for the Structure window for the active simulation.

dataset_name — The Structure window takes the name of any dataset you load through
the File > Datasets menu item or the dataset open command.

Viewing the Structure Window

By default, the Structure window opensin atab group with the Library windows after starting a
simulation. Y ou can also open the Structure window with the “View Objects Window Button”.

The hierarchical view includes an entry for each object within the design. When you select an
object in a Structure window, it becomes the current region.

The contents of several windows automatically update based on which object you select,
including the Source window, Objects window, Processes window, and Locals window. All
mouse button operations clear the current selection and select the item under the cursor.

Accessing
Access the window using any of the following:
* Menuitem: View > Structure
® Command: view structure

® Button: View Objects Window Button
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Figure 4-50. Structure Window
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Structure Window Tasks

This section describes tasks for using the Structure window.

Using the Popup Menu

Right-click on an object in the Structure window to display the popup menu and select one of
the following options:

Table 4-33. Structure Window Popup Menu

Popup Menu Item Description

View Declaration Opens the source file and bookmarks the object.

View Instantiation
Add Wave
Add Wave New

Opens the source file and bookmarks the object.
Adds the selected object(s) to the Wave window.

Creates a new instance of the Wave window and
adds the selected object(s) to that window.
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Table 4-33. Structure Window Popup Menu (cont.)

Popup Menu Item

Description

Add WaveTo Opens adrop down list of Wave windows when
multiple windows exist. Adds the selected object(s)
to the selected Wave window.

Add Dataflow Adds the selected object(s) to a Dataflow window.

Add to Add the selected object(s) to any one of the
following: Wave window, List window, Log file,
Schematic window, Dataflow window. Y ou may
choose to add only the Selected Signals, all Signals
in Region, all Signalsin Design.

Copy Copies the object instance path to the clipboard

Find Opens the Search Bar (at bottom of window) in the
Find mode to make searching for objects easier,
especialy with large designs.

Save Selected Saves all hierarchy under the selected instance.

Expand Selected Displays the hierarchy of the object recursively.

Collapse Selected Closes the hierarchy of the object.

Collapse All Collapses the hierarchy to the top instance.

XML Import Hint

Displaysthe XML Import Hint dialog box with
information about the Link Type and Name

Show

Lists the design unit types that are currently
displayed.

® Processes

® Functions
Packages
Tasks
Statement
V Packages
VITypedef
SVClass
Class Instances
Capacity
Change Filter

Display Source Code of a Structure Window Object

Y ou can highlight the line of code that declares a given object in the following ways:

Double-click on an object — Opens the file in a new Source window, or activates the
fileif it is already open.
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® Single-click on an object — Highlights the code if the file is already showingin an

active Source window.

Add Structure Window Objects to Other Windows

Y ou can add objects from the Structure window to the Dataflow window, List window, Watch
window or Wave window in the following ways:

® Mouse— Drag and drop

* Menu Selection — Add > To window

® Toolbar — Add Selected to Window Button > Add to window

® Command — add list, add wave, Or add dataflow

When you drag and drop objects from the Structure window to the Wave, Dataflow, or
Schematic windows, the add wave, add dataflow, and add schematic (respectively) commands

will be reflected in the Transcript window.

Finding Items in the Structure Window

To find items in the Structure window, press Ctrl-F on your keyboard with the Structure
window active. This opens the Find bar at the bottom of the window. Refer to Find and Filter
Functions section for details. Asyou typein the Find field, a popup window opens to display a
list of matches (Figure 4-51). With 'Search While Typing' enabled (the default) each keypress

changes the pattern and restarts the search immediately.

Figure 4-51. Find Mode Popup Displays Matches
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The Structure window Find bar supports hierarchical searching to limit the regions of a search.
The forward slash (/) character is used to separate the search words. A double slash (/) is used
to specify arecursive search from the double slash down the hierarchy. For example:

foo — search the entire design space for regions containing "foo™" in the name.

foo?bar — search the entire design space for regions containing "foo" then any single
alphanumeric character, followed by "bar"

foo*bar — search the design for a name containing "foo", a string of zero or more
alphanumeric characters, followed by "bar. For example, to following names match a
search for "foo*bar": "foobar", "foo_fred bar", and "foolsAbar". "fool Sbad" does not
match the search string.

/foo — search the top of the design hierarchy for regions containing "foo".

/foo/bar — search for regions containing "foo" at the top, and then regions containing
"bar".

/fool/bar — search for regions containing "bar" recursively below all top level regions
containing "foo".

To search for aname that contains the slash (/) character, escape the slash using a backslash (\).
For example: \/bar.

When you double-click any item in the match list that item is highlighted in the Structure
window and the popup is removed. The search can be canceled by clicking on the ‘X’ button in
the popup window or by pressing the Esc key on your keyboard.

Filtering Structure Window Objects

Y ou can control the types of information available in the Structure window through the View >
Filter menu items.

Processes — Implicit wire processes
Functions— Verilog and VHDL Functions
Packages — VHDL Packages

Tasks— Verilog Tasks

Statement — Verilog Statements
VIPackage — Verilog Packages
VITypedef — Verilog Type Definitions

SV Class— SystemVerilog class instances

Cdll Instances— Verilog cell instances or
VHDL architecture instance.
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Capacity — Memory capacity design unit
Assertion — VHDL and Verilog assertions

Subprogram — VHDL procedures and
functions; Verilog functions and tasks

GUI Elements of the Structure Window

This section describes GUI elements specific to this Window. For acomplete list of all columns
in the Structure window and a description of their contents, see Table 4-34.

Column Descriptions

The table below lists columns in the Structure window with a description of their contents

(Table 4-34).

Table 4-34. Columns in the Structure Window

Column name Description

Design Unit The name of the design unit

Design Unit Type | Thetype of design unit

Visibility The +acc settings used for compilation/optimization of that design unit
184
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Transcript Window

The Transcript window maintains a running history of commands that are invoked and
messages that occur as you work with Model Sim. When a simulation is running, the Transcript
displaysaVSIM prompt, allowing you to enter command-line commands from within the
graphic interface.

Y ou can scroll backward and forward through the current work history by using the vertical
scrollbar. Y ou can also use arrow keysto recall previous commands, or copy and paste using the
mouse within the window (see Main and Source Window Mouse and Keyboard Shortcuts for
details).

Displaying the Transcript Window

The Transcript window is always open in the Main window and cannot be closed.

Viewing Data in the Transcript Window

The Transcript tab contains the command line interface, identified by the Model Sim prompt,
and the simulation interface, identified by the VSIM prompt.

Saving the Transcript File

V ariable settings determine the filename used for saving the transcript. If either PrefMain(file)
in the .modelsimfile or TranscriptFile in the modelsim.ini file is set, then the transcript output
islogged to the specified file. By default the TranscriptFile variable in modelsim.ini is set to
transcript. If either variable is set, the transcript contents are always saved and no explicit
saving is necessary.

If you would like to save an additional copy of the transcript with a different filename, click in
the Transcript window and then select File > Save As, or File > Save. Theinitial save must be
made with the Save As selection, which stores the filename in the Tcl variable

PrefM ain(saveFile). Subsequent saves can be made with the Save selection. Since no
automatic saves are performed for thisfile, it iswritten only when you invoke a Save command.
Thefileiswritten to the specified directory and records the contents of the transcript at the time
of the save.

Refer to Creating a Transcript File for more information about creating, locating, and saving a
transcript file.

Saving a Transcript File as a Macro (DO file)
1. Open asaved transcript file in atext editor.

2. Remove all commented lines leaving only the lines with commands.
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3.

Savethefile as <name>.do.

Refer to the do command for information about executing a DO file.

Changing the Number of Lines Saved in the Transcript
Window

By default, the Transcript window retains the last 5000 lines of output from the transcript. Y ou
can change this default by selecting Transcript > Saved Lines. Setting thisvariableto O
instructs the tool to retain all lines of the transcript.

Colorizing the Transcript

By default, al Transcript window messages are printed in blue. Y ou may colorized Transcript
messages according to severity as follows:

1

a > 0D

Select Tools > Edit Preferences from the Main window menus.

In the Preferences window select the By Name tab.

Expand the list of Preferences under "Main."

Select the colorizeTranscript preference and click the Change Value button.

Enter "1" in the Change Main Preference Vaue dialog and click OK (Figure 4-52).
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Figure 4-52. Changing the colorizeTranscript Preference Value
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Disabling Creation of the Transcript File

Y ou can disable the creation of the transcript file by using the following Model Sim command
immediately after Model Sim starts:

transcript file

Performing an Incremental Search

The Transcript tab includes an Find function (Figure 4-53) that allows you to do an incremental
search for specific text. To activate the Find bar select Edit > Find from the menus or click the
Find icon in the toolbar. For more information see Find and Filter Functions.
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Figure 4-53. Transcript Window with Find Toolbar
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Using Automatic Command Help

When you start typing a command at the prompt, a dropdown box appears which lists the
available commands matching what has been typed so far. Y ou may use the Up and Down
arrow keys or the mouse to select the desired command. When a unique command has been
entered, the command usage is presented in the drop down box.

Y ou can toggle this feature on and off by selecting Help > Command Completion.

Using drivers and Readers Command Results

The output from the drivers and readers commands, which is displayed in the Transcript
window as hypertext links, allows you to right-click to open a drop-down menu and to quickly
add signals to various windows. It also includes a"View Declaration” item to open the source
definition of the signal.

Figure 4-54. drivers Command Results in Transcript
L) Transcripk

WSIM 26> driwvers /top/dut/enable -
# Drivers for Stop/dut/enable:
# 5tl @ Net ftop/sdut/enahle

# Stl : Drlver J'lltpl:lp_.'lldut ANTAMT TOATT TTTTOT A oon 2121 =L M
# _eeopdut #IMPLICIT-WIRE(enable)#1

Yieww Declar ation

WaIM 27 =
fdd/Em Wawe L\E

fdd Ea List
#dd ko Schematic
Add ko Dataflow

Mowe: 170,170 ns  Delta: 3

Copy

ModelSim GUI Reference Manual, v10.3a 189



Window Reference
Transcript Window

Using Transcript Menu Items

When the Transcript window is active, a"Transcript”" menu selection appearsin the Main
window menu bar. The following items may be selected when you open the Transcript menu:

Adjust Font Scaling — Displays the Adjust Scaling dialog box, which allows you to
adjust how fonts appear for your display environment. Directions are available in the
dialog box.

Transcript File— Allows you to change the default name used when saving the
transcript file. The saved transcript file will contain all the text in the current transcript
file.

Command History — Allows you to change the default name used when saving
command history information. Thisfile is saved at the same time as the transcript file.

Save File— Allows you to change the default name used when selecting File > Save
As.

Saved Lines— Allows you to change how many lines of text are saved in the transcript
window. Setting this value to zero (0) savesall lines.

Line Prefix — Allows you to change the character(s) that precedes the linesin the
transcript.

Update Rate — Allows you to change the length of time (in ms) between transcript
refreshes.

ModelSim Prompt — Allows you to change the string used for the command line
prompt.

VSIM Prompt — Allows you to change the string used for the ssmulation prompt.
Paused Prompt — Allows you to change the string used for when the simulation is
paused.

Transcript Toolbar Items

When undocked, the Transcript window allows access to the following toolbars:

® Standard Toolbar
®* Help Toolbar
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Watch Window

Use the Watch window to view values for signals and variables at the current simulation time
and to explore the hierarchy of object oriented designs.

Unlike the Objects or Locals windows, the Watch window allows you to view any signal or
variable in the design regardless of the current context. Y ou can view the following objects:

VHDL objects— signals, aliases, generics, constants, and variables.
Verilog objects — nets, registers, variables, named events, and module parameters.

Virtual objects— virtual signals and virtual functions.
Accessing
Access the window using either of the following:

* Menuitem: View > Watch

® Command: view watch

Figure 4-55. Watch Window

‘am_th/spram2/data_in (0xff020f8) | am1/mem (0xf053230) | HEumilEe el NOFGE Sk ) 1#] B How |k
0767a [0] = 38 [0] =00010001100101000
[1] = 32 [1] = 00010001100101001
[2] = 3a [2] = 00010001100101010
fram_tbjspram/mem (0xff0529b0) | | () _ 44 [3] = 00010001100101011
o] =4£..} [4] =03 [4] = 00010001100101100
[1=4.} [5] = 72 [5] = 00010001100101101
[2] =1} [6] = 2e [6] = 00010001100101110
[€=1{.} [7] = 2f [7] = 000100011001011141
_ [8] = 30 [5] = 00010001100110000 e
kLR 9] = 31 [4] = 00010001100110001
00000012 [10] = 32 [10] = 00010001100110010
[11] = 33 [11] = 00010001100110011
[12] = 34 [12] = 00010001100110100
et etunt) gl [13] = 35 [13] = 00010001100110101
7a [14] = 36 [14] = 00010001100110110
[15] = 37 [15] = 00010001100110111
[16] = 00010001100111000 |
| | |

ModelSim GUI Reference Manual, v10.3a 191



Window Reference
Watch Window

Watch Window Tasks

This section describes tasks for using the Watch window.

Adding Objects to the Watch Window

To add objectsto the Watch window, drag -and-drop objects from the Structure window or from
any of the following windows: List, Locals, Objects, Source, and Wave. Y ou can aso use the
“Add Selected to Window Button”. Y ou can also use the add watch command.

Expanding Objects to Show Individual Bits

If you add an array or record to the window, you can view individual bit values by double-
clicking the array or record. As shown in Figure 4-56, /ram_tb/spram4/mem has been expanded
to show all theindividual bit values. Notice the arrow that “ties’ the array to the individual bit

display.

Figure 4-56. Expanded Array
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GUI Elements of the Watch Window

This section describes GUI elements specific to this window.
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Graphical Element

The primary graphical element of the watch window is the item box, which typically shows
information about a single signal. The item can also be a group of signals created with the
“group” popup window option.

Header — shows the signal name, followed, parenthetically, by its address (if it has
one).

Body — shows the current value of the signal. Values that are red have changed since
the previous run command.

SystemVerilog Classes — Items are displayed in a scrollable, hierarchical list, such as
in Figure 4-57 where extended SystemV erilog classes hierarchically display their super
members.

Current Time Label — Displays the Current Time or the Now (end of simulation)
time. Thisisthe time used to control state values annotated in the window. (For details,
refer to Current Time Label.)

Figure 4-57. Scrollable Hierarchical Display

Cwan {0 ]

File Edit Wiew &dd Tools Window

[top/scorebdfaf (0x7esbl290) ftop/stimfrequest_fifo (0x7e3b07 10}
(= —super.super {favm_pkg:avm_named_... =F—super {favm_pkg::avm_named_comp... |
| .m_name = sch_af_fifo — .m_name = request_fifo
— .m_parent = null — .m_parent = null
— .m_children = — .m_children =
— m_rh=4{...} — m_rh=4{...}
— .5_named_obiject_repositary = {,,.+ — .s_named_chject_repository = {...}
— .s_orphans =4...} L s_orphans =4{...} [
+—super (favm_pkg: :tm_fifo: km_fifo__2) =}
analysis_gxpork = {,..+ Jn_size =1
Jput_export =4}
blacking_put_expork = {...}
Jnonblocking_put_expart = 4., .- J

Two Ref handlesthat refer to the same object will point to the same Watch window box,
even if the name used to reach the object is different. This means circular references will
be draw as circular.
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Popup Menu
Table 4-35. Watch Window Popup Menu

Popup menu Item Description

Add Add the selected item or items to the desired
window

Force Opens the Force Selected Signal dialog box,
which alows you to force the signal to given
value. Refer to the force command for details
about the options.

NoForce Removes the force on the selected object.
Refer to the noforce command.

Clock Performs actions related to the force
command with the -repeat argument.

Change Performs actions related to the change
command.

Follow Selection Context Changes the current context in the Structure
window.

Save Format Saves anew (or loads an existing) .do file

Load Format containing add watch commands to recreate
the Watch window.

Group Groups several selected signalsinto asingle
item.

UnGroup Breaks a previously created group back into
itsindividual signals

Properties Opens the Properties dialog box, which
allows you to ater the properties of the
selected signal or group, including:

® Header name

® Radix type
This option is not available when multiple
signals are selected.

Delete Item Removes the selected signal from the
window. Y ou can alternatively use the delete
key.

Clear All Removes all signals from the window.

194 ModelSim GUI Reference Manual, v10.3a



Window Reference
Watch Window

Watch Menu

This menu becomes available in the Main menu when the Watch window is active

Table 4-36.

Watch Window Menu

Popup menu Item

Description

Force

Opens the Force Selected Signal dialog box,
which allows you to force the signal to given
value. Refer to the force command for details
about the options.

NoForce

Removes the force on the selected object.
Refer to the noforce command.

Clock

Performs actions related to the force
command with the -repeat argument.

Change

Performs actions related to the change
command.

Follow Selection Context

Changes the current context in the Structure
window.

Save Format Saves a new (or loads an existing) .do file

Load Format containing add watch commands to recreate
the Watch window.

Group Groups several selected signalsinto asingle
item.

UnGroup Breaks a previously created group back into
itsindividual signals

Tile Reorganizes the items in the Watch window
into different tiled formats.

Delete Item Removes the selected signal from the
window. Y ou can aternatively use the delete
key.

Clear All Removes all signals from the window.
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Wave Window

The Wave window, like the List window, allows you to view the results of your simulation. In
the Wave window, however, you can see the results as waveforms and their values.

Figure 4-58. Wave Window
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Add Objects to the Wave Window

Y ou can add objects to the Wave window from other windows in the following ways.

Mouse: Drag and drop.

Mouse: Click the middle mouse button when the cursor is over an object or group of

objectsin the Objects or Locals windows. The specified object(s) are added to the Wave

Window.

Toolbar: Click-and-hold the “ Add Selected to Window Button” to specify where
selected signals are placed: above the Insertion Point Bar in the Pathnames Pane,

appended after the Insertion Pointer in the Pathnames Pane, at the top or the end of the
Pathnames Pane.
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® Command: add wave

When you drag and drop objects into the Wave window, the add wave command is reflected in
the Transcript window.

Refer to Adding Objects to the Wave Window for more information about adding objects to the
Wave window.

Wave Window Panes

The Wave window is divided into a number of window panes. All window panesin the Wave
window can be resized by clicking and dragging the bar between any two panes.

Pathname Pane

The pathname pane displays signal pathnames. Signals can be displayed with full pathnames, as
shown here, or with any number of path elements. Y ou can increase the size of the pane by
clicking and dragging on the right border. The selected signal is highlighted.

The white bar along the left margin indicates the selected Wave window or pane of a split wave
window (see Splitting Wave Window Panes).
Insertion Point Bar

Y ou can select the location for inserting signals by placing the cursor over the left white bar in
the Pathnames Pane. The white arrow and green bar indicate the selected location for the
insertion pointer. Clicking the left mouse button sets the new insertion pointer.

Figure 4-59. Pathnames Pane
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Values Pane

The values pane displays the values of the displayed signals. Y ou can resize the values pane by
clicking on and dragging the right border. Some signals may be too wide (too many bits) for
their values to be fully displayed. Use the scroll bar at the bottom of the pane to see the entire
signal value. Small signal values will remain in view while scrolling.

The radix for each signal can be symbolic, binary, octal, decimal, unsigned, hexadecimal,
ASCII, or default. The default radix for al signals can be set by selecting Simulate > Runtime
Options.

Note

D When the symbolic radix is chosen for SystemVerilog reg and integer types, the values
are treated as binary. When the symbolic radix is chosen for SystemVerilog bit and int
types, the values are considered to be decimal.

To change the radix for just the selected signal or signals, select Wave > Format > Radix >
Global Signal Radix from the menus, or right-click the selected signal(s) and select Radix >
Global Signal Radix from the popup menu. This opens the Global Signal Radix dialog
(Figure 4-60), where you may select aradix. This sets the radix for the selected signal(s) in the
Wave window and every other window where the signal appears.

Figure 4-60. Setting the Global Signal Radix from the Wave Window
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The datain this paneis similar to that shown in the Objects Window, except that the values
change dynamically whenever a cursor in the waveform pane is moved.
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Figure 4-61. Values Pane

Waveform Pane

Figure 4-62 shows waveform pane, which displays waveforms that correspond to the displayed
signal pathnames. It can also display as many as 20 user-defined cursors. Signal values can be
displayed in analog step, analog interpolated, analog backstep, literal, logic, and event formats.
Y ou can set the format of each signal individually by right-clicking the signal in the pathname
or values panes and choosing For mat from the popup menu. The default format is Logic.

If you place your mouse pointer on asignal in the waveform pane, a popup menu displays with

information about the signal. Y ou can toggle this popup on and off in the Wave Window
Properties dialog box.

Figure 4-62. Waveform Pane
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Analog Sidebar Toolbox

When the waveform pane contains an anal og waveform, you can hover your mouse pointer over
the left edge of the waveform to display the Analog Sidebar toolbox (see Figure 4-63). This
toolbox shows a group of icons that gives you quick access to actions you can perform on the
waveform display, as described in Table 4-37.

Figure 4-63. Analog Sidebar Toolbox

Table 4-37. Analog Sidebar Icons

Icon Action

Description

Open Wave Properties

Opens the Format tab of the Wave Properties
dialog box, with the Analog format already
selected. Thisdialog box duplicates the Wave
Analog dialog box displayed by choosing
Format > Format... > Analog (custom)

from the main menu.

B Toggle Row Height

Changes the height of the row that contains the
analog waveform. Toggles the height between
the Min and Max values (in pixels) you specified
in the Open Wave Properties dialog box under
Analog Display.

E Rescaleto fit Y data

Changes the waveform height so that it fits top-
to-bottom within the current height of the row.

Show menu of other actions

Displays

® View MinY
View Max Y
Overlay Above
Overlay Below
Colorize All
Colorize Selected
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Table 4-37. Analog Sidebar Icons (cont.)

Icon | Action Description

. Drag to resize waveform height | Creates an up/down dragging arrow that you can
use to temporarily change the height of the row
containing the analog waveform.

Cursor Pane

Figure 4-64 shows the Cursor Pane, which displays cursor names, cursor values and the cursor
locations on the timeline. Y ou can link cursors so that they move across the timeline together.
See Linking Cursorsin the Waveform Analysis chapter.

Figure 4-64. Cursor Pane
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On the | eft side of this pane is agroup of icons called the Cursor and Timeline Toolbox (see
Working with Cursors). Thistoolbox gives you quick access to cursor and timeline features and
configurations. See Measuring Time with Cursors in the Wave Window for more information.

Messages Bar

The messages bar, located at the top of the Wave window, contains indicators pointing to the
times at which a message was output from the simulator. By default, the indicators are not
displayed. To turn on message indicators, use the -msgmode argument with the vsim command
or use the msgmode variable in the modelsim.ini file.

Figure 4-65. Wave Window - Message Bar

The message indicators (the down-pointing arrows) are color-coded as follows:

Red — Indicates an error.
Y ellow — Indicates awarning.
Green — Indicates a note.

Grey — Indicates any other type of message.
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You can use the Message bar in the following ways.
® Move the cursor to the next message — Y ou can do thisin two ways:

o Click ontheword “Messages’ in the message bar to cycle the cursor to the next
message after the current cursor location.

o Click anywhere in the message bar, then use Tab or Shift-Tab to cycle the cursor
between error messages either forward or backward, respectively.

* Display the Message Viewer Window — Double-click anywhere amongst the message
indicators.

* Display, inthe Message Viewer window, the message entry related to a specific
indicator — Double-click on any message indicator.

This function only worksif you are using the Message Viewer in flat mode. To display
your messages in flat mode:

a. Right-click in the Message Viewer and select Display Options

b. Inthe Message Viewer Display Options dialog box, deselect Display with
Hierarchy.

View Objects Window Button

This button opens the Objects window with a single click. However, if you click-and-hold the
button you can access additional options viaa dropdown menu, as shown in Figure 4-66

Figure 4-66. View Objects Window Dropdown Menu
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Wave Window Icons
The following icons can be found in the Wave window.

Table 4-38. Window Icons

Icon shape | Example Description

FSM button ! opensthe FSM Viewer window
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Table 4-38. Window Icons

Icon shape | Example Description

Null

n verilog/system verilog name event

Objects You Can View in the Wave Window

The following types of objects can be viewed in the Wave window

VHDL objects (indicated by adark blue diamond) — signals, aliases, process variables,
and shared variables

Verilog objects (indicated by alight blue diamond) — nets, registers, variables, and
named events

The GUI displaysinout variables of aclocking block separately, where the output of the
inout variable is appended with“ 0", for example you would see following two
objects:

clockl.cl /input portion of the inout cl
clockl.cl__ o /output portion of the inout cl

This display technique aso applies to the Objects window
Verilog transactions (indicated by a blue four point star) — see for more information

Virtual objects (indicated by an orange diamond) — virtual signals, buses, and
functions, see; Virtual Objects for more information

The datain the object values pane is very similar to the Objects window, except that the values
change dynamically whenever a cursor in the waveform pane is moved.

At the bottom of the waveform pane you can see atime line, tick marks, and the time value of
each cursor’s position. Asyou click and drag to move a cursor, the time value at the cursor
location is updated at the bottom of the cursor.

Y ou can resize the window panes by clicking on the bar between them and dragging the bar to a
new location.

Waveform and signal-name formatting are easily changed via the Format menu. Y ou can reuse
any formatting changes you make by saving a Wave window format file (see Saving the
Window Format).

Wave Window Toolbar

The Wave window (in the undocked Wave window) gives you quick access to the following
toolbars:
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Standard Toolbar
Compile Toolbar
Simulate Toolbar

Step Toolbar

Wave Cursor Toolbar
Wave Edit Toolbar
Wave Toolbar

Wave Compare Toolbar
Zoom Toolbar

Wave Expand Time Toolbar
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Keyboard Shortcuts and Mouse Actions

Window Specific Keyboard Shortcuts

Y ou can open adynamic list of common (pre-defined) and user defined keyboard shortcuts for
many windows by entering " Ctrl+/" on your keyboard. Figure 5-1 shows the keyboard shortcuts
for the Source window.

Figure 5-1. Keyboard Shortcuts for Source Window
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Y ou can find a complete list of al keyboard shortcuts - predefined and user defined - by
clicking "View All Shortcuts." Refer to User Defined Keyboard Shortcuts for moreinformation
on how to create a customized shortcut.

The following windows have keyboard shortcuts assigned:

® Dataflow Window
® Library Window

® Objects Window

® Source Window

® Structure Window
® Transcript Window

* \Wave Window

User Defined Keyboard Shortcuts

In addition to the predefined keyboard shortcuts you can create your own shortcuts or modify

predefined keyboard shortcuts with the Keyboard Shortcuts dialog box (Figure 5-2). Shortcuts
can be either window specific (available only when the window is active) or global (available
from anywhere in the tool). Y ou can create a keyboard shortcut for any window in Model Sim.
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Once a shortcut is defined, it will be available in all subsequent invocations of the tool. The
dynamic nature of the architecture makes the keyboard shortcuts available to any tool that is
based upon the ModelSim GUI, such as ADMS, 0-In, MV C, and Codelink.

The Keyboard Shortcuts Dialog Box

The Keyboard Shortcuts dialog box lists all existing keyboard shortcuts. The dialog
distinguishes between shortcuts that are user defined and shortcuts that come predefined in the
tool (Figure 5-2).

Figure 5-2. Keyboard Shortcuts Dialog Box
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The Keyboard Shortcuts Dialog Box allows you to:

® Addanew user defined keyboard shortcut. Refer to Creating A Keyboard Shortcut for
more information.

* Modify an existing keyboard shortcut. Any shortcut can be modified including
predefined shortcuts.

®* Delete ashortcut.

® Import shortcuts from a previously saved bindings.do file. Y ou can also reload the
keyboard shortcuts file with the do command.
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® Export all user defined keyboard shortcutsto bindings.do file. Keyboard shortcuts saved
in the file can be reloaded either by selecting the Import button in the Keyboard
Shorcuts Dialog Box or by entering do bindings.do on the command line.

Creating A Keyboard Shortcut

Y ou can create either a Global or awindow specific shortcut.

1. If you are creating awindow specific shortcut, the window must have been opened
sometime during the simulation run.

2. Openthe Add Keyboard Shortcut dialog box by selecting Window > Keyboard
Shortcuts.

3. Click the Add button to open the Add Keyboard Shortcut dialog box.

Figure 5-3. Add Keyboard Shortcut Dialog Box
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4. Select the Shortcut Type, either Global or Window. If you are creating a window
specific shortcut, click the window button to open the Select Window Type dialog box.
The dialog box displays every window that has been opened during the current
simulation. If you do not see the window you are looking for, close both dialog boxes,
open the window you want by entering view <window> on the command line, or by
selecting the window from the View menu. Choosing Global or a specific window
changes the options available in the Shortcut Key Operation field and the dynamically

populated field to the right.

5. Enter the key combination in the Shortcut Key field. Or select the Change Entry

M ode button to enter a key combination.

6. Choose the type of operation the shortcut will execute.

o A Popup or Pulldown Menu — Opensthe M enu Itemsdialog with ahierarchical list
of al popup and pulldown menu items available either globally or for the window

specified in step 4.

o A Toolbar button — Opens the Toolbar Buttons dialog with a hierarchical list of all
toolbar button actions available either globally or for the window specified in step 4.

o General Tcl script — Selecting this option opens the Tcl Script field to the right.
Y ou can enter any Tcl script or command line sequence.

o An Internal window command — This choice is available only for window specific
commands. Refer to step 4. Opens the Window Action dialog on the right with alist

of all window specific commands.

Main and Source Window Mouse and

Keyboard Shortcuts

The following mouse actions and special keystrokes can be used to edit commands in the entry
region of the Main window. They can also be used in editing the file displayed in the Source
window and all Notepad windows (enter the notepad command within Model Sim to open the

Notepad editor).

Table 5-1. Mouse Shortcuts

Mouse - UNI X and Windows Result
Click the left mouse button rel ocate the cursor
Click and drag the left mouse button select an area

Shift-click the left mouse button

extend selection

Double-click the left mouse button

select aword

Double-click and drag the left mouse button

select agroup of words

208

ModelSim GUI Reference Manual, v10.3a



Keyboard Shortcuts and Mouse Actions
Main and Source Window Mouse and Keyboard Shortcuts

Table 5-1. Mouse Shortcuts (cont.)

Mouse - UNI X and Windows

Result

Ctrl-click the left mouse button

move insertion cursor without changing the
selection

ModelSim or VSIM prompt

Click the left mouse button on a previous copy and paste previous command string to

current prompt

Click the middle mouse button

paste selection to the clipboard

Click and drag the middle mouse button scroll the window

Table 5-2. Keyboard Shortcuts

Keystrokes - UNIX and Windows

Result

Left Arrow
Right Arrow

move cursor left or right one character

Ctrl + Left Arrow
Ctrl + Right Arrow

move cursor left or right one word

Shift + Any Arrow

extend text selection

Ctrl + Shift + Left Arrow
Ctrl + Shift + Right Arrow

extend text selection by one word

Up Arrow
Down Arrow

Transcript window: scroll through command history
Source window: move cursor one line up or down

Ctrl + Up Arrow
Ctrl + Down Arrow

Transcript window: moves cursor to first or last line
Source window: moves cursor up or down one

paragraph

Ctrl + d (UNIX only)

Alt+/ Open a pop-up command prompt for entering
commands.

Ctrl + Home move cursor to the beginning of the text

Ctrl + End move cursor to the end of the text

Backspace delete character to the left

Ctrl + h (UNIX only)

Delete delete character to the right

Esc (Windows only)

cancel

Alt

activate or inactivate menu bar mode

Alt-F4

close active window
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Table 5-2. Keyboard Shortcuts (cont.)

Keystrokes - UNIX and Windows

Result

Home move cursor to the beginning of the line
Ctrl + a

Ctrl + Shift + a select all contents of active window

Ctrl +b move cursor |eft

Ctrl +d delete character to the right

End move cursor to the end of the line

Ctrl + e

Ctrl + f (UNIX)
Right Arrow (Windows)

move cursor right one character

Ctrl + k

delete to the end of line

Ctrl + n

move cursor one line down (Source window only
under Windows)

Ctrl + o (UNIX only)

insert a new line character at the cursor

Ctrl +p

move cursor one line up (Source window only under
Windows)

Ctrl + s(UNIX)
Ctrl + f (Windows)

find

Ctrl +/ (UNIX)
Ctrl + z (Windows)

Ctrl +1t reverse the order of the two characters on either side of
the cursor

Ctrl +u deleteline

Page Down move cursor down one screen

Ctrl + v (UNIX only)

Ctrl +x cut the selection

Ctrl +s save

Ctrl + x (UNIX Only)

Ctrl +v paste the selection

Ctrl + a(Windows Only) select the entire contents of the widget

Ctrl +\ clear any selection in the widget

Ctrl + - (UNIX) undoes previous edits in the Source window

Meta+ < (UNIX only)

move cursor to the beginning of thefile

Meta+ > (UNIX only)

move cursor to the end of thefile
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Table 5-2. Keyboard Shortcuts (cont.)

Keystrokes - UNIX and Windows | Result

Page Up Move CUrsor up one screen

Meta+ v (UNIX only)

Ctrl +c copy selection

F3 Performs a Find Next action in the Source window.

F4 Change focus to next pane in main window

Shift+F4 Change focus to previous pane in main window

F5 Toggle between expanding and restoring size of pane
to fit the entire main window

Shift+F5 Toggle on/off the pane headers.

F8 search for the most recent command that matches the
characterstyped (Main window only)

F9 run simulation

F10 continue simulation

F11 (Windows only) single-step

F12 (Windows only) step-over

The Main window allowsinsertions or pastes only after the prompt; therefore, you don’t need to
set the cursor when copying strings to the command line.

List of Keyboard Shortcuts in GUI Windows

Y ou can open adynamic list of keyboard shortcuts, predetermined and user defined, for most

windows by entering Ctrl-Shift-?
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Figure 5-4. Schematic Window Keyboard Shortcuts
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Y ou can create user defined keyboard shortcuts and change predetermined shortcuts. Refer to
User Defined Keyboard Shortcuts for more information.

List Window Keyboard Shortcuts

Using the following keys when the mouse cursor is within the List window will cause the

indicated actions:

Table 5-3. List Window Keyboard Shortcuts

Key - UNIX and Windows Action

Left Arrow scroll listing left (selects and highlights the item to the
left of the currently selected item)

Right Arrow scroll listing right (selects and highlights the item to
the right of the currently selected item)

Up Arrow scroll listing up

Down Arrow scroll listing down

Page Up scroll listing up by page

Ctrl + Up Arrow

Page Down scroll listing down by page

Ctrl + Down Arrow
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Table 5-3. List Window Keyboard Shortcuts (cont.)

Key - UNIX and Windows Action

Tab searches forward (down) to the next transition on the
selected signal

Shift + Tab searches backward (up) to the previous transition on
the selected signal

Shift + Left Arrow extends selection left/right

Shift + Right Arrow

Ctrl +f (Windows) opens the Find dialog box to find the specified item

Ctrl + s(UNIX) label within the list display

Wave Window Mouse and Keyboard Shortcuts

The following mouse actions and keystrokes can be used in the Wave window.

Table 5-4. Wave Window Mouse Shortcuts
M ouse actiont Result

Ctrl + Click left mouse button zoom area (in)
and drag \

Ctrl + Click left mouse button Zoom out
and drag /

Ctrl + Click left mouse button \ zoom fit

and drag

Click left mouse button and drag moves closest cursor

Ctrl + Click left mouse button on a scrolls window to very top or
scroll bar arrow bottom (vertical scroll) or far

left or right (horizontal scroll)

Click middle mouse button in scroll bar | scrolls window to position of
(UNIX only) click

Shift + scroll with middle mouse button | scrolls window

1. If you choose Wave > M ouse M ode > Zoom M ode, you do not need to press
the Ctrl key.
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Table 5-5. Wave Window Keyboard Shortcuts

Keystroke Action

S bring into view and center the currently active cursor

[ zoomin

Shift +i (mouse pointer must be over the cursor or waveform panes)

+

0 zoom out

Shift + o (mouse pointer must be over the cursor or waveform panes)

f zoom full

Shift + f (mouse pointer must be over the cursor or waveform panes)

I zoom last

Shift + | (mouse pointer must be over the cursor or waveform panes)

r zoom range

Shift +r (mouse pointer must be over the cursor or waveform panes)

m zooms all open Wave windows to the zoom range of the
active window.

Up Arrow scrolls entire window up or down one line, when mouse

Down Arrow pointer is over waveform pane
scrolls highlight up or down one line, when mouse pointer is
over pathname or values pane

Left Arrow scroll pathname, values, or waveform pane | eft

Right Arrow scroll pathname, values, or waveform pane right

Page Up scroll waveform pane up by a page

Page Down scroll waveform pane down by a page

Tab search forward (right) to the next transition on the selected
signal - finds the next edge

Shift + Tab search backward (l€eft) to the previous transition on the
selected signal - finds the previous edge

Ctrl+G automatically create agroup for the selected signals by region

with the name Group<n>.

If you use this shortcut on signals for which there is already a
“Group<n>" they will be placed in that region’s group rather
than creating a new one.

Ctrl + F (Windows)
Ctrl + S(UNIX)

open the find dialog box; searches within the specified field in
the pathname pane for text strings
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Table 5-5. Wave Window Keyboard Shortcuts (cont.)

Keystroke

Action

Ctrl + Left Arrow
Ctrl + Right Arrow

scroll pathname, values, or waveform pane left or right by a
page
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Chapter 6
GUI Customization

The ModelSim GUI is programmed using Tcl/Tk. It is highly customizable. Y ou can control
everything from window size, position, and color to the text of window prompts, default output

filenames, and so forth.

Most user GUI preferences are stored as Tcl variables in the .modelsim file on Unix/Linux
platforms or the Registry on Windows platforms. The variable values save automatically when
you exit Model Sim. Some of the variables are modified by actions you take with menus or
windows (for example, resizing a window changes its geometry variable). Or, you can edit the
variables directly either from the prompt in the Transcript window or the Tools > Edit

Prefer ences menu item.

Customizing the Simulator GUI Layout

There arefive predefined layout modes that the GUI will load dependent upon which part of the
simulation flow you are currently in. They include:

®* NoDesign — Thislayout is the default view when you first open the GUI or quit out of
an active smulation.

® Simulate— Thislayout appears after you have begun a simulation with vsim.

These layout modes are fully customizable and the GUI stores your manipulationsin the
.modelsim file (UNIX and Linux) or the registry (Windows) when you exit the simulation or
change to another layout mode. The types of manipulations that are stored include: showing,
hiding, moving, and resizing windows.

Layout Mode Loading Priority

The GUI stores your manipulations on a directory by directory basis and attemptsto load a
layout mode in the following order:

1. Directory — The GUI attempts to load any manipulations for the current layout mode
based on your current working directory.

2. Last Used — If thereis no layout related to your current working directory, the GUI
attempts to load your last manipulations for that |ayout mode, regardless of your
directory.

3. Default — If you have never manipulated alayout mode, or have deleted the .modelsim
file or the registry, the GUI will load the default appearance of the layout mode.
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Configure Window Layouts Dialog Box

The Configure Window Layouts dialog box allows you to alter the default behavior of the GUI
layouts. Y ou can display this dialog box by selecting the L ayout > Configure menu item. The
elements of this dialog box include:

® Specify aLayout to Use — This pane allows you to map which layout is used for the
four actions. Refer to the section Changing Layout Mode Behavior for additional
information.

® Savewindow layout automatically — This option (on by default) instructs the GUI to
save any manipulations to the layout mode upon exit or changing the layout mode.

® Save Window Layout by Current Directory — This option (on by default) instructs
the tool to save the final state of the GUI layout on a directory by directory basis. This
means that the next time you open the GUI from a given directory, the tool will load
your previous GUI settings.

* Window Restore Properties Button— Opens the Window Restore Properties Dialog
Box. Refer to Configuring Default Windows for Restored Layouts for more information.

Creating a Custom Layout Mode

To create a custom layout, follow these steps:

1. Rearrange the GUI asyou seefit.
2. Select Layout > Save Layout As.
This displays the Save Current Window Layout dialog box.
3. Inthe Save Layout Asfield, typein anew name for the layout mode.
4. Click OK.

The layout is saved to the .modelsimfile or registry. Y ou can then access this layout mode from
the Layout menu or the Layout toolbar.

Changing Layout Mode Behavior

To assign which predefined or custom layout appears in each mode, follow these steps.

1. Create your custom layouts as described in Creating a Custom Layout Mode.
2. Select Layout > Configure.
This displays the Configure Window Layouts Dialog Box.

3. Select which layout you want the GUI to load for each scenario. This behavior affects
the Layout Mode Loading Priority.
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4. Click OK.

The layout assignment is saved to the .modelsimfile or registry.

Resetting a Layout Mode to its Default
To get alayout back to the default arrangement, follow these steps:

1. Load the layout mode you want to reset viathe Layout menu or the Layout toolbar.
2. Select Layout > Reset.

Deleting a Custom Layout Mode
To delete a custom layout, follow these steps:

1. Load acustom layout mode from the Layout menu or the Layout toolbar.
2. Select Layout > Delete.
Displays the Delete Custom Layout dialog box.
3. Select the custom layout you wish to delete.
4. Delete.

Configuring Default Windows for Restored Layouts

The Window Restore Properties Dialog Box allows you to specify which windows will be
restored when alayout is reloaded.

1. Select Layout > Configur e to open the Configure Window L ayouts dialog box.

2. Click the Window Restor e Properties button to open the Window Restor e Properties
dialog box

3. Select the windows you want to have opened when anew layout isloaded. Windows
that are not selected will not load until specified with the view command or by selecting
View > <window>.

Y ou can also work with window layouts by specifying layout suppr esstype <window>, layout
restor etype, or layout showsuppr esstypes. Refer to the layout command for more
information.

User Defined Buttons and Menus

Y ou can create Tcl processes (procs) that add user-defined buttons and menus to the main
window of ModelSim. The Tcl procs are loaded after initialization by assigning them to the
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PrefMain(user_hook) preference variable. The procs must be saved in amodelsim.tcl file
located in theinstall directory for Windows platforms or in the directory from which ModelSim
isinvoked for other platforms (refer to The modelsim.tcl File for more information). Buttons
are added to the Standard toolbar and menus are added to the main menu bar in the GUI

The following Tcl example demonstrates two procs that create a menu and two buttons and the
syntax for setting the procs with the PrefM ain(user _hook) preference variable. Refer to
(Figure 6-1).

Figure 6-1. User-Defined Buttons and Menus

File Edit View Compile Simulate Add Library Tools Layout Bookmarks Windnwl UerenuIHeIp

Fun Long Run Shert J Gg v Bl BN BR .
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proc AddMyMenus {wname} {
global myglobalvar
set cmdl "echo my_own_thing Swname"
set cmd2 "echo my_to_upper Swname"
set cmd3 "echo my_to_lower Swname"

# WinName Menu Menultem label Command

# __________________________________________________________

add_menu Swname usrMenu

add_menuitem Swname usrMenu "Do My Own Thing" S$cmdl

add_separator S$Swname usrMenu -

add_submenu Swname usrMenu changeCase

add_menuitem Swname usrMenu.changeCase "To Upper" Scmd?2

add_menuitem Swname usrMenu.changeCase "To Lower" Scmd3

add_submenu Swname usrMenu vars

add_menucb Swname usrMenu.vars "Feature One" -variable \
myglobalvar \
-onvalue 1 \
-offvalue 0 \
-indicatoron 1 \

}

proc my_buttons {args} {
add button "Run Long" "run 2 us"
add button "Run Short" "run 2 ns"
}

lappend PrefMain (user_hook) AddMyMenus my_buttons

The code above is available in the following modelsim.tcl file:
<install_dir>/examples/gui/addmenu/modelsim.tcl
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* Menu proc

Adds a menu to the Main menu bar containing atop-level item labeled "Do My Own
Thing...", which prints "my_own_thing.signals." It adds a cascading submenu |abeled
"changeCase" with two entries, "To Upper" and "To Lower", which echo
"my_to_upper" and "my_to_lower" respectively. The menu selection User Menu >
Vars> Feature One sets a checkbox that controls the value of myglobalvar
(.signals.one).

* Button proc

Adds two buttons to the Standard tool bar. "Run Long," runs the simulation for 2 us,
"Run Short," runs the simulation for 2 ns.

®* Theline
lappend PrefMain (user_hook) AddMyMenus my_buttons

appends the two procs AddM yM enusand my_buttonsto theuser _hook variable when
ModelSim isfinished initializing. Multiple procs are specified as a space separated list.

User-Defined Radices

A user definable radix is used to map bit patternsto a set of enumeration labels. After defining a
new radix, the radix will be available for usein the List, Watch, and Wave windows or with the
examine command.

There are four commands used to manage user defined radices:

* radix define
® radix names
* radix list

* radix delete

Using the radix define Command

The radix define command is used to create or modify aradix. It must include a radix name and
a definition body, which consists of alist of number pattern, label pairs. Optionally, it may
include the -color argument for setting the radix color (see Example 6-2).

{
<numeric-value> <enum-label>,
<numeric-value> <enum-label>
-default <radix>

}

A <numeric-value> is any legitimate HDL integer numeric literal. To be more specific:
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<base>#<base-integer># --- <base> is 2, 8, 10, or 16

<base>"bit-value" --- <base> is B, 0, or X

<integer>

<size>'<base><number> --- <size> is an integer, <base> is b, d, o, or h.

Check the Verilog and VHDL LRMs for exact definitions of these numeric literals.

The comma (,) in the definition body is optional. The <enum-label> is any arbitrary string. It
should be quoted ("), especialy if it contains spaces.

The -default entry is optional. If present, it defines the radix to useif amatch isnot found for a
given value. The -default entry can appear anywherein thelist, it does not have to be at the end.

Example 6-1 shows the radix define command used to create aradix called “ States,” which
will display state valuesin the List, Watch, and Wave windows instead of numeric values.

Example 6-1. Using the radix define Command

radix define States {
11'b00000000001 "IDLE",
11'b00000000010 "CTRL",
11'b00000000100 "WT WD_1",
11'00000001000 "WT WD_2",
11'b00000010000 "WT_BLK_1",
11'b00000100000 "WT_BLK_2",
11'b00001000000 "WT_BLK_3",
11'b00010000000 "WT_BLK_ 4",
11'b00100000000 "WT_BLK 5",
11'01000000000 "RD_WD_1",
11'b10000000000 "RD_WD_2",
-default hex

}

Figure 6-2 shows an FSM signal called /test-sm/sm_seq0/sm_0O/state in the Wave window with
abinary radix and with the user-defined “ States” radix (as defined in Example 6-1).

Figure 6-2. User-Defined Radix “ States” in the Wave Window

m wave - defaulk
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Figure 6-3 shows an FSM signal called /test-smysm_seq0/sm_O/state in the List window with a
binary radix and with the user-defined “ States” radix (as defined in Example 6-1)
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Figure 6-3. User-Defined Radix “ States” in the List Window
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Using radix define to Specify Radix Color

The following example illustrates how to use the radix define command to specify the radix
color:

Example 6-2. Using radix define to Specify Color

radix define States {
11'b00000000001 "IDLE" -color yellow,
11'b00000000010 "CTRL" -color #ffeelO,
11'b00000000100 "WT_WD_1" -color orange,
11'b00000001000 "WT_WD_2" -color orange,
11'b00000010000 "WT _BLK_1",
11'b00000100000 "WT_BLK_2",
11'b00001000000 "WT_BLK_3",
11'b00010000000 "WT_BLK_4",
11'b00100000000 "WT_BLK_5",
11'b01000000000 "RD_WD_1" -color green,
11'b10000000000 "RD_WD_2" -color green,
-default hex
-defaultcolor white

3

If apattern/label pair does not specify a color, the normal wave window colors will be used. If
the value of the waveform does not match any pattern, then -default <radix_type> and
-defaultcolor will be used.

To specify arange of values, wildcards may be specified for bits or characters of the value. The
wildcard character is'?, similar to the iteration character in aVerilog UDP, for example:

radix define {
6'b01??200 "Write" -color orange,
6'b10??00 "Read" -color green

}

In this example, the first pattern will match "010000", "010100", *011000", and "011100". In
case of overlaps, the first matching pattern is used, going from top to bottom.
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Setting Global Signal Radix

The Global Signal Radix feature allows you to set theradix for a selected signal or signalsinthe
active window and in other windows where the signal appears. The Global Signal Radix can be
set from the Locals, Objects, Schematic, or Wave windows as follows:

® Select asignal or group of signals.
® Right-click the selected signal(s) and click the following popup menu option:
o Objects Window: Radix
o Locals Window: Global Signal Radix
o Wave Window: Radix > Global Signal Radix
o Schematic Window: Edit > Global Signal Radix

This opens the Global Signal Radix dialog box (Figure 6-4), where you may select a
radix. This sets the radix for the selected signal(s) in the active window and every other
window where the signal appears.

Figure 6-4. Setting the Global Signal Radix
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Setting a Fixed Point Radix

Fixed point types are used in VHDL and SystemC to represents non-integer numbers without
using afloating point format. Model Sim automatically recognizes VHDL sfixed and ufixeda
types aswell as SystemC SC_FIXED and SC_UFIXED types and displays them correctly with
afixed point format.
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In addition, a general purpose fixed point radix feature is available for displaying any vector,
regardless of type, in afixed point format in the Wave window. Y ou simply have to specify how
many bits to use as fraction bits from the whole vector.

With the Wave window active:

1. Select (LMB) asignal or signals in the Pathnames pane of the Wave window.

2. Right-click the selected signal(s) and select Radix > Fixed Point from the popup menu.
This opens the Fixed Point Radix dialog.

Figure 6-5. Fixed Point Radix Dialog

Fixed Point Rad x|
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3. Typethe number of bitsyou want to appear as the fraction and click OK.
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Chapter 7
GUI Preferences

Simulator GUI preferences are stored by default either in the .modelsimfile in your HOME
directory on UNIX/Linux platforms or the Registry on Windows platforms.

Simulator GUI Preferences

To edit avariable value from the GUI, select Tools > Edit Preferences. The dialog organizes
preferences into two tab groups. By Window and By Name.

By Window Tab

The By Window tab primarily alows you to change colors and fonts for various GUI objects.

Changing the Window Color Scheme

Thisisaplace holder. Do this then that.
1. Select "Source Windows' from the Window List column.

Preferences
By Window I By Mame ]

—Windaw List

Rssertions Window
Dataflow Windows
List Windows
Locals Window
Main Window
Memory Windows
0bjects Window
Frocess Window
Schematic Windows

Source Windows
Structure Windows

VM Details ConfigDB
WM Details Stream
Fave Windows
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2. Select "background” or “foreground" in the name pane of the Source Color Scheme
field.

FSource Windows Color Scheme

annotaticnBackground ;I
annotationForeground

// Module top

module top:s

reg i = 1'bl;
1'bl

R o R

foldBackground
foldForeground
foreground
arginBackground
EarginFcregrcund
selectBackground
selectForeground

19

Reset Defaults

3. Select the color from the palette for the new background color. The new color will be
displayed in the Color Scheme Window.

Changing the Global Fonts

Y ou can also make global font changes to all GUI windows with the Fonts section of the By
Window tab (Figure 7-1).

Figure 7-1. Making Global Font Changes

ixedFant ITahl:uma 8 Chl:u:use...| Restore default Fl:unts|

Preview

Sample Texk 0123456789ABCDEFLIW 2z
The Quick Brown Fox Jumped Ower The Lazy Dog!

Table 7-1. Global Fonts
Global Font Name | Description

fixedFont for al text in Source window and Notepad display, andin all text
entry fields or boxes

footerFont for al footer text that appears in footer of Main window and all
undocked windows
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Table 7-1. Global Fonts

Global Font Name | Description

menuFont for al menu text
textFont for Transcript window text and text in list boxes
treeFont for al text that appearsin any window that displays a

hierarchical tree

By Name Tab

The By Name tab lists every Tcl variablein atree structure. The procedure for changing a Tcl
variableis:

1. Expandthetree.
2. Highlight avariable.
3. Click Change Valueto edit the current value.

Clicking OK or Apply at the bottom of the Preferences dialog changes the variable, and the
change is saved when you exit Model Sim.

Y ou can search for information in the By Name tab by using the the Find button. However, the
Find button will only search expanded preference items, therefore it is suggested that you click
the Expand All button before searching within this tab.

Saving GUI Preferences

GUI preferences are saved automatically when you exit the tool.

If you prefer to store GUI preferences el sewhere, set the MODELSIM_PREFERENCES
environment variable to designate where these preferences are stored. Setting this variable
causes Model Sim to use a specified path and file instead of the default location. Here are some
additional pointsto keep in mind about this variable setting:

* Thefile does not need to exist before setting the variable as Model Sim will initiaize it.
* If thefileisread-only, ModelSim will not update or otherwise modify thefile.

®* Thisvariable may contain arelative pathname, in which case thefile isrelative to the
working directory at the time the tool is started.

The modelsim.tcl File

Previous versions saved user GUI preferencesinto amodelsim.tcl file. Current versionswill still
read in amodelsim.tcl fileif it exists. Model Sim searches for the file as follows:
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®* use MODELSIM_TCL environment variableif it exists (if MODELSIM_TCL isalist
of files, each fileisloaded in the order that it appearsin thelist); else

® use./modelsim.tcl; else
® use $(HOME)/modelsim.tcl if it exists

Note that in versions 6.1 and later, Model Sim will save to the .modelsim file any variables it
reads in from amodelsim.tcl file. The values from the modelsim.tcl file will override like
variables in the .modelsimfile.

GUI Preference Variables

Wave Window Variables

The LogicStyleTable combined with the ListTrans ateTable define how single bit waveforms
are displayed in the Wave window. The single valueisfirst mapped into one of nine (9)
possible states: U, 0, 1, X, Z, W, H, L, or - (Don't Care). Then the entry for the corresponding
valueinthe LogicStyleTableis used to determine what is drawn in the Wave window. Theline
styleiseither Solid or DoubleDash. The line is drawn in the color specified. Lastly, thelineis
drawn at the top of the row (2), the middle of the row (1), or the bottom of the row (0).

The mapping of bit valuesto the 9 statesis specified in the ListTrandateTable. Thetableis
searched to find a matching value. When a match isfound, the corresponding table entry
defines the 9 state value used to define the style.

Table 7-2. Default ListTranslateTable Values

Mapped State Bit Value
LOGIC U (U}
LOGIC X XX
LOGIC 0 '0' FALSE
LOGIC_1 'l' TRUE
LOGIC Z VAN A
LOGIC_W "W
LOGIC L L'
LOGIC_H 'H
LOGIC_DC
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Table 7-3. Default LogicStyleTable Values

Mapped State

Line Style Color

Row Position

LOGIC_U

Solid red

LOGIC_X

Solid red

LOGIC 0 Solid green
LOGIC_ 1 Solid green
LOGIC Z Solid blue

LOGIC_W

DoubleDash red

LOGIC_ L

DoubleDash grey90

LOGIC_H

DoubleDash grey90

RN O|lRr| RN O R R

DoubleDash blue

LOGIC_DC

Figure 7-2. Modifying Signal Display Attributes in the Wave Window
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Source window, viewing in, 165
Buttons

user-defined, 219

—C—
Call Stack pane, 95
Clear bookmarks

source window, 176
Clock change

sampling signals at, 130
Clocking block inout display, 203
Color

radix

example, 223

colorization, in Source window, 177
Colorize

Transcript window, 187
Combine Selected Signals dialog box, 116
Combine signals, 126
Command completion, 189
compare, 126
Compare signad

virtual, 126
Conditiona breakpoints, 173

use of SystemVerilog keyword this, 173
conditional breakpoints

use of keyword this, 173
Contains, 23, 27
Creating do file, 22, 126
Cursor linking, 201
Customize GUI

fonts, 228

—D—
Dataflow window, 104
<Italic>see also windows, Dataflow
window
Deltas
in List window, 128
descriptions of HDL items, 175
Design object icons, described, 35
DO files (macros)
creating from a saved transcript, 186

— F—
Edit
breakpoints, 171
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Editing
in notepad windows, 208
in the Main window, 208
in the Source window, 208
Expanded Time
viewing in List window, 117
Expression Builder, 120
configuring a List trigger with, 129
saving expressionsto Tcl variable, 122

— F—
F8 function key, 211
File-line breakpoints, 170
edit, 171
Files window, 109
Filter, 27
assertions, 183
subprograms, 183
Filtering
Containsfield, 23, 27
signalsin Objects window, 155
Find, 23
in Structure window, 182
inline search bar, 176, 188
prefill text entry field, 24
Fixed point radix, 224
FocusFollowsMouse, 16
Fonts
scaling, 23
fonts
setting preferences, 228
Format
saving/restoring, 22, 126
signal
Wave window, 199
Format file
Wave window, 125
Function call, debugging, 95

— G —
Global GUI changes

fonts, 228
Global signal radix, 155, 198, 224
Glob-style, 27
GUI preferences

fonts, 228

GUI_expression_format
GUI expression builder, 120

— H—
Help
command help, 189
highlighting, in Source window, 177
Highlights
in Source window, 169
— | —
Icons
shapes and meanings, 35
window based, 202
inline search bar, 176, 188

— K —
Keyboard shortcuts
user defined, 205
keyboard shortcuts
List window, 212
Main window, 208
Source window, 208
Wave window, 213

— L —
Link cursors, 201
List pane
<Italic>see also pane, List pane
List window, 114
expanded time viewing, 117
setting triggers, 129
Load
breakpoints, 173
Localswindow, 134

<Italic>see also windows, Locals window

— M —
Macros (DO files)

creating from a saved transcript, 186
Memories

navigation, 137

saveto WLFfile, 143

saving formats, 143

selecting memory instances, 142

viewing contents, 142

viewing multiple instances, 142
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Memory tab

memories you can view, 140
Menus

user-defined, 219
Message Viewer tab, 146
Messages, 146

MODELSIM_PREFERENCES variable, 229

modelsim.tcl, 229
user_defined menus, 219
user-defined buttons, 219

mouse shortcuts
Main window, 208
Source window, 208
Wave window, 213

msgmode variable, 146

— N —
Nets
Dataflow window, displaying in, 104
values of
displaying in Objects window, 154
waveforms, viewing, 196
Notepad windows, text editing, 208
-notrigger argument, 130

— 00—
Objects window, 154

—P—
Prefill text entry

find, 24
PrefMemory(ExpandPackedM em) variable,

142

Pref Source(OpenOnBreak) variable, 166
Pref Source(OpenOnFinish) variable, 166
Pref Source(OpenOnStep) variable, 166

—R—
Radix

change in Watch pane, 194

color

example, 223

List window, 123

set globally, 155, 198, 224

setting fixed point, 224

setting for Objects window, 155, 224

user-defined, 221

definition body, 221
radix
SystemVerilog types, 198
Radix define command
setting radix color, 223
Registers
values of
displaying in Objects window, 154
waveforms, viewing, 196
Regular-expression, 27
restart command
in GUI, 43
Restoring
window format, 22, 126

—S—
Save
breakpoints, 173
savel ines preference variable, 187
Saving
window format, 22, 126
Scaling fonts, 23
Search
in Structure window, 182
inline search bar
Source window, 176
Transcript, 188
prefill text entry field, 24
Search bar, 23
Searching
Expression Builder, 120
Setting radix
fixed point, 224
Shortcuts
text editing, 208
shortcuts
List window, 212
Main window, 208
Source window, 208
Wave window, 213
Signal format
Wave window, 199
Signal radix
for Objects window
Objects window
setting signal radix, 155, 224
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set globally, 155, 198, 224
Signals
combine into bus, 126
Dataflow window, displaying in, 104
sampling at clock change, 130
types, selecting which to view, 155
values of
displaying in Objects window, 154
waveforms, viewing, 196
signals
Filtering in the Objects window, 155
Simulating
viewing resultsin List window, 114
source highlighting, customizing, 177
Source window, 165
clear highlights, 169
colorization, 177
disable automatic opening
$finish call, 166
on break, 166
single stepping, 166
inline search bar, 176
tab stopsin, 177
<Italic>see also windows, Source window
Status bar
Main window, 34
Structure window
find item, 182
Subprograms
filtering, 183
syntax highlighting, 177
SystemVerilog, 173
classmethods, conditional breakpoints, 173
SystemVerilog types
radix, 198

— T —
tab stops

Source window, 177
tabbed toolbars, 70
Text

filtering, 27
Text editing, 208
Toolbar

filter, 27
toolbar

Compile, 50

Coverage, 50

Dataflow, 52

Help, 52

Layout, 53

Memory, 53

Mode, 54

Objectfilter, 55

Process, 55

Profile, 56

Schematic, 57

Simulate, 58

Source, 59

Standard, 60

Step, 62

tabs, 70

Wave, 63

Wave Compare, 65

Wave Cursor, 66

Wave Edit, 67

Wave Expand Time, 68

Zoom, 69
toolbar tabs, 70

Compiletab, 71

Coveragetab, 72

Debug tab, 74

Edit tab, 78

enabling, 70

Hometab, 79

Layout tab, 82

mapping to default toolbars, 91

Profile tab, 83

Schematic and Dataflow tab, 84

Simulate tab, 85

user modification, 89
Transcript

colorize, 187

command help, 189

disablefile creation, 188

inline search bar, 188

saving, 186

saving asaDO file, 186
Transcript window

changing buffer size, 187

changing line count, 187
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Triggers
in List window, 126
Triggers, in the List window, 129

—U—
user_hook variable, 219
User-defined bus, 126
User-defined radix, 221
definition body, 221

—V —
Values

of HDL items, 175
Variables

values of

displaying in Objects window, 154

Verilog

source code viewing, 165
VHDL

source code viewing, 165
viewing, 146
Viewing files for the simulation, 109
Virtual signal, 126

— W —

Wave window, 196
format signal, 199
saving layout, 125

<|talic>see also windows, Wave window

Waveforms
viewing, 196
Window format
saving/restoring, 22, 126
Windows
Active Processes pane, 160
Dataflow window, 104
List window, 114
display properties of, 123
formatting HDL items, 123
setting triggers, 126, 129
Locaswindow, 134
Main window
status bar, 34
time and delta display, 34
Objects window, 154
Signals window

VHDL and Verilog items viewed in,
154
Source window, 165
viewing HDL source code, 165
V ariables window
VHDL and Verilog items viewed in,
134
Wave window, 196
save format file, 125
windows
Main window
text editing, 208
Source window
text editing, 208
WLFfile
saving memoriesto, 143
write format restart, 22, 126
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End-User License Agreement

The latest version of the End-User License Agreement is available on-line at:
www.mentor.com/eula

IMPORTANT INFORMATION

USE OF ALL SOFTWARE IS SUBJECT TO LICENSE RESTRICTIONS. CAREFULLY READ THIS LICENSE
AGREEMENT BEFORE USING THE PRODUCTS. USE OF SOFTWARE INDICATES CUSTOMER’'S COMPLETE
AND UNCONDITIONAL ACCEPTANCE OF THE TERMS AND CONDITIONS SET FORTH IN THIS AGREEMENT.

ANY ADDITIONAL OR DIFFERENT PURCHASE ORDER TERMS AND CONDITIONS SHALL NOT APPLY.

END-USER LICENSE AGREEMENT (“Agreement”)

Thisisalegal agreement concerning the use of Software (as defined in Section 2) and hardwar e (collectively “Products”)
between the company acquiring the Products (“ Customer™), and the Mentor Graphics entity that issued the corresponding
quotation or, if no quotation was issued, the applicable local Mentor Graphics entity (“Mentor Graphics’). Except for license
agreementsrelated to the subject matter of thislicense agreement which are physically signed by Customer and an authorized
representative of Mentor Graphics, this Agreement and the applicable quotation contain the parties’ entire understanding
relating to the subject matter and supersede all prior or contemporaneous agreements. |f Customer does not agree to these
terms and conditions, promptly return or, in the case of Softwarereceived electronically, certify destruction of Software and all
accompanying itemswithin five days after receipt of Software and receive a full refund of any license fee paid.

ORDERS, FEESAND PAYMENT.

1.1. To the extent Customer (or if agreed by Mentor Graphics, Customer’s appointed third party buying agent) places and Mentor
Graphics accepts purchase orders pursuant to this Agreement (each an “Order”), each Order will constitute a contract between
Customer and Mentor Graphics, which shall be governed solely and exclusively by the terms and conditions of this Agreement,
any applicable addenda and the applicable quotation, whether or not those documents are referenced on the Order. Any additional
or conflicting terms and conditions appearing on an Order or presented in any electronic portal or automated order management
system, whether or not required to be electronically accepted, will not be effective unless agreed in writing and physically signed
by an authorized representative of Customer and Mentor Graphics.

1.2. Amountsinvoiced will be paid, in the currency specified on the applicable invoice, within 30 days from the date of such invoice.
Any past due invoices will be subject to the imposition of interest charges in the amount of one and one-half percent per month or
the applicable legal rate currently in effect, whichever is lower. Prices do not include freight, insurance, customs duties, taxes or
other similar charges, which Mentor Graphics will state separately in the applicable invoice. Unless timely provided with avalid
certificate of exemption or other evidence that items are not taxable, Mentor Graphics will invoice Customer for all applicable
taxes including, but not limited to, VAT, GST, sales tax, consumption tax and service tax. Customer will make all payments free
and clear of, and without reduction for, any withholding or other taxes; any such taxes imposed on payments by Customer
hereunder will be Customer’s sole responsibility. If Customer appoints a third party to place purchase orders and/or make
payments on Customer’s behalf, Customer shall be liable for payment under Orders placed by such third party in the event of
default.

1.3. All Products are delivered FCA factory (Incoterms 2010), freight prepaid and invoiced to Customer, except Software delivered
electronically, which shall be deemed delivered when made available to Customer for download. Mentor Graphics retains a
security interest in all Products delivered under this Agreement, to secure payment of the purchase price of such Products, and
Customer agrees to sign any documents that Mentor Graphics determines to be necessary or convenient for use in filing or
perfecting such security interest. Mentor Graphics' delivery of Software by electronic meansis subject to Customer’s provision of
both a primary and an alternate e-mail address.

GRANT OF LICENSE. The software installed, downloaded, or otherwise acquired by Customer under this Agreement, including any
updates, modifications, revisions, copies, documentation and design data (“ Software”) are copyrighted, trade secret and confidential
information of Mentor Graphics or its licensors, who maintain exclusive title to all Software and retain all rights not expressly granted
by this Agreement. Mentor Graphics grants to Customer, subject to payment of applicable license fees, a nontransferable, nonexclusive
license to use Software solely: (a) in machine-readable, object-code form (except as provided in Subsection 5.2); (b) for Customer’s
internal business purposes; (c) for the term of the license; and (d) on the computer hardware and at the site authorized by Mentor
Graphics. A siteisrestricted to a one-half mile (800 meter) radius. Customer may have Software temporarily used by an employee for
telecommuting purposes from locations other than a Customer office, such as the employee’s residence, an airport or hotel, provided
that such employee’s primary place of employment is the site where the Software is authorized for use. Mentor Graphics' standard
policies and programs, which vary depending on Software, license fees paid or services purchased, apply to the following: (a)
relocation of Software; (b) use of Software, which may be limited, for example, to execution of a single session by a single user on the
authorized hardware or for arestricted period of time (such limitations may be technically implemented through the use of
authorization codes or similar devices); and (c) support services provided, including eligibility to receive telephone support, updates,
modifications, and revisions. For the avoidance of doubt, if Customer provides any feedback or requests any change or enhancement to
Products, whether in the course of receiving support or consulting services, evaluating Products, performing beta testing or otherwise,
any inventions, product improvements, modifications or devel opments made by Mentor Graphics (at Mentor Graphics' sole discretion)
will be the exclusive property of Mentor Graphics.

ESC SOFTWARE. If Customer purchases a license to use devel opment or prototyping tools of Mentor Graphics Embedded Software
Channel (“ESC"), Mentor Graphics grants to Customer a nontransferable, nonexclusive license to reproduce and distribute executable
files created using ESC compilers, including the ESC run-time libraries distributed with ESC C and C++ compiler Software that are


http://www.mentor.com/eula

linked into a composite program as an integral part of Customer’s compiled computer program, provided that Customer distributes
these files only in conjunction with Customer’s compiled computer program. Mentor Graphics does NOT grant Customer any right to
duplicate, incorporate or embed copies of Mentor Graphics' real-time operating systems or other embedded software products into
Customer’ s products or applications without first signing or otherwise agreeing to a separate agreement with Mentor Graphics for such
purpose.

BETA CODE.

4.1. Portionsor al of certain Software may contain code for experimental testing and evaluation (which may be either alpha or beta,
collectively “Beta Code"), which may not be used without Mentor Graphics' explicit authorization. Upon Mentor Graphics'
authorization, Mentor Graphics grants to Customer atemporary, nontransferable, nonexclusive license for experimental useto test
and evaluate the Beta Code without charge for a limited period of time specified by Mentor Graphics. Mentor Graphics may
choose, at its sole discretion, not to release Beta Code commercialy in any form.

4.2. If Mentor Graphics authorizes Customer to use the Beta Code, Customer agrees to evaluate and test the Beta Code under normal
conditions as directed by Mentor Graphics. Customer will contact Mentor Graphics periodically during Customer’s use of the
Beta Code to discuss any malfunctions or suggested improvements. Upon completion of Customer’s evaluation and testing,
Customer will send to Mentor Graphics a written evaluation of the Beta Code, including its strengths, weaknesses and
recommended improvements.

4.3. Customer agrees to maintain Beta Code in confidence and shall restrict access to the Beta Code, including the methods and
concepts utilized therein, solely to those employees and Customer location(s) authorized by Mentor Graphics to perform beta
testing. Customer agrees that any written evaluations and all inventions, product improvements, modifications or developments
that Mentor Graphics conceived or made during or subsequent to this Agreement, including those based partly or wholly on
Customer’s feedback, will be the exclusive property of Mentor Graphics. Mentor Graphics will have exclusive rights, title and
interest in all such property. The provisions of this Subsection 4.3 shall survive termination of this Agreement.

RESTRICTIONS ON USE.

5.1. Customer may copy Software only as reasonably necessary to support the authorized use. Each copy must include all notices and
legends embedded in Software and affixed to its medium and container as received from Mentor Graphics. All copies shall remain
the property of Mentor Graphics or its licensors. Customer shall maintain a record of the number and primary location of all
copies of Software, including copies merged with other software, and shall make those records available to Mentor Graphics upon
request. Customer shall not make Products available in any form to any person other than Customer’s employees and on-site
contractors, excluding Mentor Graphics competitors, whose job performance requires access and who are under obligations of
confidentiality. Customer shall take appropriate action to protect the confidentiality of Products and ensure that any person
permitted access does not disclose or use Products except as permitted by this Agreement. Customer shall give Mentor Graphics
written notice of any unauthorized disclosure or use of the Products as soon as Customer becomes aware of such unauthorized
disclosure or use. Except as otherwise permitted for purposes of interoperability as specified by applicable and mandatory local
law, Customer shall not reverse-assembl e, reverse-compile, reverse-engineer or in any way derive any source code from Software.
Log files, datafiles, rule files and script files generated by or for the Software (collectively “Files”), including without limitation
files containing Standard Verification Rule Format (“SVRF”) and Tcl Verification Format (“TVF’) which are Mentor Graphics
trade secret and proprietary syntaxes for expressing process rules, constitute or include confidential information of Mentor
Graphics. Customer may share Files with third parties, excluding Mentor Graphics competitors, provided that the confidentiality
of such Filesis protected by written agreement at least as well as Customer protects other information of a similar nature or
importance, but in any case with at |east reasonable care. Customer may use Files containing SVRF or TVF only with Mentor
Graphics products. Under no circumstances shall Customer use Products or Files or allow their use for the purpose of developing,
enhancing or marketing any product that is in any way competitive with Products, or disclose to any third party the results of, or
information pertaining to, any benchmark.

5.2. If any Software or portions thereof are provided in source code form, Customer will use the source code only to correct software
errors and enhance or modify the Software for the authorized use. Customer shall not disclose or permit disclosure of source code,
in whole or in part, including any of its methods or concepts, to anyone except Customer’s employees or on-site contractors,
excluding Mentor Graphics competitors, with a need to know. Customer shall not copy or compile source code in any manner
except to support this authorized use.

5.3. Customer may not assign this Agreement or the rights and duties under it, or relocate, sublicense, or otherwise transfer the
Products, whether by operation of law or otherwise (“ Attempted Transfer”), without Mentor Graphics' prior written consent and
payment of Mentor Graphics' then-current applicable relocation and/or transfer fees. Any Attempted Transfer without Mentor
Graphics' prior written consent shall be a material breach of this Agreement and may, at Mentor Graphics' option, result in the
immediate termination of the Agreement and/or the licenses granted under this Agreement. The terms of this Agreement,
including without limitation the licensing and assignment provisions, shall be binding upon Customer’s permitted successors in
interest and assigns.

5.4. The provisions of this Section 5 shall survive the termination of this Agreement.

SUPPORT SERVICES. To the extent Customer purchases support services, Mentor Graphicswill provide Customer with updates and
technical support for the Products, at the Customer site(s) for which support is purchased, in accordance with Mentor Graphics' then
current End-User Support Terms located at http://supportnet.mentor.com/supportterms.

LIMITED WARRANTY.

7.1. Mentor Graphics warrants that during the warranty period its standard, generally supported Products, when properly installed, will
substantially conform to the functional specifications set forth in the applicable user manual. Mentor Graphics does not warrant
that Products will meet Customer’s requirements or that operation of Products will be uninterrupted or error free. The warranty
period is 90 days starting on the 15th day after delivery or upon installation, whichever first occurs. Customer must notify Mentor
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Graphicsin writing of any nonconformity within the warranty period. For the avoidance of doubt, thiswarranty applies only to the
initial shipment of Software under an Order and does not renew or reset, for example, with the delivery of (a) Software updates or
(b) authorization codes or alternate Software under a transaction involving Software re-mix. This warranty shall not be valid if
Products have been subject to misuse, unauthorized modification, improper installation or Customer is not in compliance with this
Agreement. MENTOR GRAPHICS' ENTIRE LIABILITY AND CUSTOMER'S EXCLUSIVE REMEDY SHALL BE, AT
MENTOR GRAPHICS OPTION, EITHER (A) REFUND OF THE PRICE PAID UPON RETURN OF THE PRODUCTS TO
MENTOR GRAPHICS OR (B) MODIFICATION OR REPLACEMENT OF THE PRODUCTS THAT DO NOT MEET THIS
LIMITED WARRANTY. MENTOR GRAPHICS MAKES NO WARRANTIES WITH RESPECT TO: (A) SERVICES; (B)
PRODUCTS PROVIDED AT NO CHARGE; OR (C) BETA CODE; ALL OF WHICH ARE PROVIDED “AS|1S.”

7.2. THE WARRANTIES SET FORTH IN THIS SECTION 7 ARE EXCLUSIVE. NEITHER MENTOR GRAPHICS NOR ITS
LICENSORS MAKE ANY OTHER WARRANTIES EXPRESS, IMPLIED OR STATUTORY, WITH RESPECT TO
PRODUCTS PROVIDED UNDER THIS AGREEMENT. MENTOR GRAPHICS AND ITS LICENSORS SPECIFICALLY
DISCLAIM ALL IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
NON-INFRINGEMENT OF INTELLECTUAL PROPERTY.

LIMITATION OF LIABILITY. EXCEPT WHERE THIS EXCLUSION OR RESTRICTION OF LIABILITY WOULD BE VOID
OR INEFFECTIVE UNDER APPLICABLE LAW, IN NO EVENT SHALL MENTOR GRAPHICS OR ITS LICENSORS BE
LIABLE FOR INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES (INCLUDING LOST PROFITS OR
SAVINGS) WHETHER BASED ON CONTRACT, TORT OR ANY OTHER LEGAL THEORY, EVEN IF MENTOR GRAPHICS
OR ITS LICENSORS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. IN NO EVENT SHALL MENTOR
GRAPHICS OR ITSLICENSORS' LIABILITY UNDER THIS AGREEMENT EXCEED THE AMOUNT RECEIVED FROM
CUSTOMER FOR THE HARDWARE, SOFTWARE LICENSE OR SERVICE GIVING RISE TO THE CLAIM. IN THE CASE
WHERE NO AMOUNT WAS PAID, MENTOR GRAPHICS AND ITS LICENSORS SHALL HAVE NO LIABILITY FOR ANY
DAMAGES WHATSOEVER. THE PROVISIONS OF THIS SECTION 8 SHALL SURVIVE THE TERMINATION OF THIS
AGREEMENT.

HAZARDOUS APPLICATIONS. CUSTOMER ACKNOWLEDGES IT IS SOLELY RESPONSIBLE FOR TESTING ITS
PRODUCTS USED IN APPLICATIONS WHERE THE FAILURE OR INACCURACY OF ITS PRODUCTS MIGHT RESULT IN
DEATH OR PERSONAL INJURY (“HAZARDOUS APPLICATIONS"). EXCEPT TO THE EXTENT THIS EXCLUSION OR
RESTRICTION OF LIABILITY WOULD BE VOID OR INEFFECTIVE UNDER APPLICABLE LAW, IN NO EVENT SHALL
MENTOR GRAPHICS OR ITS LICENSORS BE LIABLE FOR ANY DAMAGES RESULTING FROM OR IN CONNECTION
WITH THE USE OF MENTOR GRAPHICS PRODUCTS IN OR FOR HAZARDOUS APPLICATIONS. THE PROVISIONS OF
THIS SECTION 9 SHALL SURVIVE THE TERMINATION OF THIS AGREEMENT.

INDEMNIFICATION. CUSTOMER AGREES TO INDEMNIFY AND HOLD HARMLESS MENTOR GRAPHICS AND ITS
LICENSORS FROM ANY CLAIMS, LOSS, COST, DAMAGE, EXPENSE OR LIABILITY, INCLUDING ATTORNEYS' FEES,
ARISING OUT OF OR IN CONNECTION WITH THE USE OF MENTOR GRAPHICS PRODUCTS IN OR FOR HAZARDOUS
APPLICATIONS. THE PROVISIONS OF THIS SECTION 10 SHALL SURVIVE THE TERMINATION OF THIS AGREEMENT.

INFRINGEMENT.

11.1. Mentor Graphics will defend or settle, at its option and expense, any action brought against Customer in the United States,
Canada, Japan, or member state of the European Union which alleges that any standard, generally supported Product acquired by
Customer hereunder infringes a patent or copyright or misappropriates a trade secret in such jurisdiction. Mentor Graphics will
pay costs and damages finally awarded against Customer that are attributable to such action. Customer understands and agrees
that as conditions to Mentor Graphics' obligations under this section Customer must: (&) notify Mentor Graphics promptly in
writing of the action; (b) provide Mentor Graphics all reasonable information and assistance to settle or defend the action; and (c)
grant Mentor Graphics sole authority and control of the defense or settlement of the action.

11.2. If aclaim is made under Subsection 11.1 Mentor Graphics may, at its option and expense: (&) replace or modify the Product so
that it becomes noninfringing; (b) procure for Customer the right to continue using the Product; or (c) require the return of the
Product and refund to Customer any purchase price or license fee paid, |ess a reasonabl e allowance for use.

11.3. Mentor Graphics has no liability to Customer if the action is based upon: (@) the combination of Software or hardware with any
product not furnished by Mentor Graphics; (b) the modification of the Product other than by Mentor Graphics; (c) the use of other
than acurrent unaltered rel ease of Software; (d) the use of the Product as part of an infringing process; (€) aproduct that Customer
makes, uses, or sells; (f) any Beta Code or Product provided at no charge; (g) any software provided by Mentor Graphics'
licensors who do not provide such indemnification to Mentor Graphics' customers; or (h) infringement by Customer that is
deemed willful. In the case of (h), Customer shall reimburse Mentor Graphics for its reasonable attorney fees and other costs
related to the action.

11.4. THIS SECTION 11 IS SUBJECT TO SECTION 8 ABOVE AND STATES THE ENTIRE LIABILITY OF MENTOR
GRAPHICS AND ITS LICENSORS, AND CUSTOMER’S SOLE AND EXCLUSIVE REMEDY, FOR DEFENSE,
SETTLEMENT AND DAMAGES, WITH RESPECT TO ANY ALLEGED PATENT OR COPYRIGHT INFRINGEMENT OR
TRADE SECRET MISAPPROPRIATION BY ANY PRODUCT PROVIDED UNDER THIS AGREEMENT.

TERMINATION AND EFFECT OF TERMINATION.

12.1. If a Software license was provided for limited term use, such license will automatically terminate at the end of the authorized
term. Mentor Graphics may terminate this Agreement and/or any license granted under this Agreement immediately upon written
notice if Customer: (a) exceeds the scope of the license or otherwise fails to comply with the licensing or confidentiality
provisions of this Agreement, or (b) becomes insolvent, files a bankruptcy petition, institutes proceedings for liquidation or
winding up or enters into an agreement to assign its assets for the benefit of creditors. For any other material breach of any
provision of this Agreement, Mentor Graphics may terminate this Agreement and/or any license granted under this Agreement
upon 30 days written notice if Customer failsto cure the breach within the 30 day notice period. Termination of this Agreement or
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any license granted hereunder will not affect Customer’s obligation to pay for Products shipped or licenses granted prior to the
termination, which amounts shall be payable immediately upon the date of termination.

12.2. Upon termination of this Agreement, the rights and obligations of the parties shall cease except as expressly set forth in this
Agreement. Upon termination, Customer shall ensure that all use of the affected Products ceases, and shall return hardware and
either return to Mentor Graphics or destroy Software in Customer’s possession, including all copies and documentation, and
certify in writing to Mentor Graphics within ten business days of the termination date that Customer no longer possesses any of
the affected Products or copies of Softwarein any form.

EXPORT. The Products provided hereunder are subject to regulation by local laws and United States (“U.S.”) government agencies,
which prohibit export, re-export or diversion of certain products, information about the products, and direct or indirect products thereof,
to certain countries and certain persons. Customer agrees that it will not export or re-export Products in any manner without first
obtaining all necessary approval from appropriate local and U.S. government agencies. If Customer wishesto disclose any information
to Mentor Graphicsthat is subject to any U.S. or other applicable export restrictions, including without limitation the U.S. International
Traffic in Arms Regulations (ITAR) or specia controls under the Export Administration Regulations (EAR), Customer will notify
Mentor Graphics personnel, in advance of each instance of disclosure, that such information is subject to such export restrictions.

U.S. GOVERNMENT LICENSE RIGHTS. Software was developed entirely at private expense. The parties agree that all Softwareis
commercial computer software within the meaning of the applicable acquisition regulations. Accordingly, pursuant to U.S. FAR 48
CFR 12.212 and DFAR 48 CFR 227.7202, use, duplication and disclosure of the Software by or for the U.S. government or a U.S.
government subcontractor is subject solely to the terms and conditions set forth in this Agreement, which shall supersede any
conflicting terms or conditions in any government order document, except for provisions which are contrary to applicable mandatory
federal laws.

THIRD PARTY BENEFICIARY. Mentor Graphics Corporation, Mentor Graphics (Ireland) Limited, Microsoft Corporation and
other licensors may be third party beneficiaries of this Agreement with the right to enforce the obligations set forth herein.

REVIEW OF LICENSE USAGE. Customer will monitor the access to and use of Software. With prior written notice and during
Customer’s normal business hours, Mentor Graphics may engage an internationally recognized accounting firm to review Customer’s
software monitoring system and records deemed relevant by the internationally recognized accounting firm to confirm Customer’'s
compliance with the terms of this Agreement or U.S. or other local export laws. Such review may include FlexNet (or successor
product) report log files that Customer shall capture and provide at Mentor Graphics' request. Customer shall make records availablein
electronic format and shall fully cooperate with data gathering to support the license review. Mentor Graphics shall bear the expense of
any such review unless a material non-compliance is revealed. Mentor Graphics shall treat as confidential information all information
gained as aresult of any request or review and shall only use or disclose such information as required by law or to enforce its rights
under this Agreement. The provisions of this Section 16 shall survive the termination of this Agreement.

CONTROLLING LAW, JURISDICTION AND DISPUTE RESOLUTION. The owners of certain Mentor Graphics intellectual
property licensed under this Agreement are located in Ireland and the U.S. To promote consistency around the world, disputes shall be
resolved as follows: excluding conflict of laws rules, this Agreement shall be governed by and construed under the laws of the State of
Oregon, U.S,, if Customer is located in North or South America, and the laws of Ireland if Customer is located outside of North or
South America. All disputes arising out of or in relation to this Agreement shall be submitted to the exclusive jurisdiction of the courts
of Portland, Oregon when the laws of Oregon apply, or Dublin, Ireland when the laws of Ireland apply. Notwithstanding the foregoing,
all disputesin Asiaarising out of or in relation to this Agreement shall be resolved by arbitration in Singapore before a single arbitrator
to be appointed by the chairman of the Singapore International Arbitration Centre (“SIAC”) to be conducted in the English language, in
accordance with the Arbitration Rules of the SIAC in effect at the time of the dispute, which rules are deemed to be incorporated by
referencein this section. Nothing in this section shall restrict Mentor Graphics' right to bring an action (including for example amotion
for injunctive relief) against Customer in the jurisdiction where Customer’s place of business is located. The United Nations
Convention on Contracts for the International Sale of Goods does not apply to this Agreement.

SEVERABILITY. If any provision of this Agreement is held by a court of competent jurisdiction to be void, invalid, unenforceable or
illegal, such provision shall be severed from this Agreement and the remaining provisions will remain in full force and effect.

MISCELLANEOUS. This Agreement contains the parties’ entire understanding relating to its subject matter and supersedes all prior
or contemporaneous agreements. Some Software may contain code distributed under a third party license agreement that may provide
additional rights to Customer. Please see the applicable Software documentation for details. This Agreement may only be modified in
writing, signed by an authorized representative of each party. Waiver of terms or excuse of breach must be in writing and shall not
constitute subsequent consent, waiver or excuse.

Rev. 140201, Part No. 258976
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