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Creating a Libero Project for Firmware Catalog 
Sample Project - Libero SoC v11.6 and SoftConsole 
Flow Tutorial for SmartFusion2

Introduction
Libero® System-on-Chip (SoC) Firmware catalog shows a list of available firmware cores. Sample
projects for each firmware core can be generated from Firmware catalog. A sample project is an example
of how the firmware core can be integrated in a project. This sample project contains firmware project
using SoftConsole, IAR workbench, and Keil tools. This sample project does not have a Libero project for
that generated firmware project. Each sample project folder contains a Readme.text file which gives an
overview of the design and hardware requirements. Using this information, the Libero SoC project can be
generated.

This tutorial describes how to download the SoftConsole sample project from Firmware catalog and
create a Libero SoC hardware design for the downloaded sample project. This tutorial provides an
example design for system services.

This tutorial describes the following: 

• Downloading SoftConsole Project from Firmware Catalog

• Creating a Libero SoC Project

• Generating the Program File

• Programming SmartFusion2 Security Evaluation Board Using FlashPro

• Building Software Application Using SoftConsole
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Design Requirements

Project Files
The design files for this tutorial can be downloaded from the Microsemi® website:

http://soc.microsemi.com/download/rsc/?f=m2s_tu0487_creating_libero_project_libero11p6_df 

The design files include:

• Libero project

• Programming files

• SF2_GNU_SysServ_read_version

• Readme file

Table 1 • Design Requirements

Design Requirements Description

Hardware Requirements

SmartFusion®2 Security Evaluation Kit:

• FlashPro4 programmer

• USB A to Mini-B cable

• 12 V Adapter

Rev D or later

Host PC or Laptop Any 64-bit Windows Operating System

Software Requirements

Libero SoC v11.6

SoftConsole v3.4 SPI

FlashPro programming software  v11.6

Host PC Drivers USB to UART drivers

Any one of the following serial terminal emulation 
programs:

• HyperTerminal

• TeraTerm

• PuTTY

–
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Figure 1 shows the top-level structure of the design files. For further details, refer to the readme.txt file.

Design Overview
This tutorial demonstrates the following Device and Design Information services:

• Serial Number Service: Fetches the 128-bit device serial number (DSN) and is set during
manufacturing.

• USERCODE Service: Fetches the programmed 32-bit JTAG USERCODE.

• User Design Version Service: Fetches the 16-bit user design version.

• Device Certificate: Fetches the device certificate.

• NVM Data Integrity Check Service: Recalculates and compares cryptographic digests of the
selected NVM component(s)—fabric, eNVM0, and eNVM1—to those previously computed and
saved in NVM.

Note: In this tutorial, only fabric digest check is demonstrated.

System services Information is displayed on HyperTerminal using MMUART_1 interface. For more
information on System services, refer to the UG0450: SmartFusion2 FPGA SoC and IGLOO2 FPGA
System Controller User Guide.

Figure 1 • Demo Design Files Top-Level Structure
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Downloading SoftConsole Project from Firmware Catalog
The following steps describe how to download the SoftConsole project from Firmware catalog:

1. Click Start > Programs > Microsemi SoC Libero SoC 11.6 > Firmware Catalog v11.6 > 
Firmware Catalog. This opens Firmware Catalog windows as shown in Figure 2. 

2. Right-click on SmartFusion2 MSS System Services Driver and select Generate Sample 
Project > Cortex-M3 > SoftConsole > Read Version Information as shown in Figure 2. 

Note: Select the latest version of the SmartFusion2 microcontroler subsystem (MSS) services driver.

Figure 2 • Downloading Sample Project from Firmware CatalogSup
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The Generate Sample Options window is displayed as shown in Figure 3.

3. Browse to a location to save System services Read Version Information SoftConsole Project.

4. Open Readme file provided in the SF2_GNU_SysSer_read_version project folder. Readme file 
gives target hardware information.

5. SF2_GNU_SysSer_read_version project folder is also provided along with design files for 
reference.

Figure 3 • Generate Sample Options Window
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Creating a Libero SoC Project

Launching Libero SoC
The following steps describe how to launch Libero SoC:

1. Click Start > Programs > Microsemi Libero SoC v11.6 > Libero SoC v11.6, or click the shortcut 
on desktop to open the Libero 11.6 Project Manager. 

2. Create a new project using one of the following options:

– Select New on the Start Page tab as shown in Figure 4.

– Click Project > New Project from the Libero SoC menu.

Figure 4 • Libero SoC Project Manager
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3. Enter the following information in the Project Details page, as shown in Figure 5:

– Project Name: Sysservices

– Project Location: Select an appropriate location (for example, D:/SF2_Sysservices)

– Preferred HDL Type: Verilog

Figure 5 • Project Details Page
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4. Click Next. This opens Device Selection page as shown in Figure 6.

Select the following values from the drop down list:

– Family: SmartFusion2

– Die: M2S090TS

– Package: 484 FBGA

– Speed: -1

– Core Voltage: All

– Range: All

5. Click Next. This opens Device Settings page. Do not change the default settings.

Figure 6 • Device Selection Page
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6. Click Next. This opens Design Template page as shown in Figure 7. Under Design Templates 
and Creators, select Create a System Builder based design.

7. Click Finish. This opens System Builder window.

Figure 7 • Device Template Page
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8. Enter the name of the system as Sysservices and click OK.

Figure 8 shows the System Builder - Device Features page. 

Figure 8 • System Builders - Device Features Page
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9. Click Next. This opens System Builder - Peripherals page as shown in Figure 9.

10. Disable the following peripherals on the System Builder - Peripherals page as shown in 
Figure 9:

– MMUART_0 

– SPI_0 and SPI_1 

– I2C_0 and I2C_1 

– USB 

– Ethernet 

– CAN

Figure 9 • System Builder - Peripherals Page
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11. Click Next. This opens System Builder - Clocks page as shown in Figure 10.

12. In the System Builder - Clocks page (see Figure 10):

– Select System Clock frequency as 50 MHz and clock source as On-chip 25/50 MHz RC 
Oscillator

– Select M3_CLK as 50 MHz

– Select APB_0_CLK and APB_1_CLK frequency as M3_CLK/1

– Do not change the default settings of remaining parameters.

13. Click Next. This opens System Builder - Microcontroller page. Do not change the default 
selections.

14. Click Next. This opens System Builder - SECDED page. Do not change the default selections.

15. Click Next. This opens System Builder - Security page. Do not change the default selections.

16. Click Next. This opens System Builder - Interrupts page. Do not change the default selections.

17. Click Next. This opens System Builder - Memory Map page. Do not change the default 
selections.

18. Click Finish.

Figure 10 • System Builder - Clocks Page
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19. Select File > Save to save Sysservices_sb_0. Select the Sysservices tab on the Smart Design 
canvas, as shown in Figure 11.

Connecting Components in Sysservices_sb_0 SmartDesign
The following steps describe how to connect the components in the Sysservices_sb_0 SmartDesign:

1. Right-click POWER_ON_RESET_N and select Mark Unused.

2. Right-click MSS_READY and select Mark Unused.

3. Expand INIT_PINS, right-click INIT_DONE and select Mark Unused.

4. Expand FAB_CCC_PINS, right-click FAB_CCC_GL0 and select Mark Unused. 

5. Right-click FAB_CCC_LOCK and select Mark Unused.

6. Right-click FAB_RESET_N and select Tie High.

7. Click File > Save. 

The Sysservices_sb_0 design is displayed as shown Figure 12.

Figure 11 • Updating Sysservices_sb_0

Figure 12 • Sysservices_sb_0Sup
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Configuring and Generating Firmware
The following steps describe how to configure and generate firmware:

1. In the Design Flow tab, double-click on Configure Firmware Cores under Handoff design for 
Firmware Development. This opens DESIGN_FIRMWARE window as shown in Figure 13.

Figure 13 • Opening DESGIN_FIRMWARE Window
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2. Clear all drivers except CMSIS, MMUART_0, and System services as shown in Figure 14.

Note: The SoftConsole sample project for System services driver can also be downloaded from 
DESIGN_FIRMWARE window. Right-click SmartFusion2_MSS_System_Services_Driver_0 
and select Read Version Information.

Figure 14 • DESIGN_FIRMWARE Window
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After successful generation of all the components, the following message is displayed on the log 
window, as shown in Figure 15.

Info: 'Sysservices' was successfully generated.

Figure 15 • Generate Component
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Generating the Program File
The following steps describe how to generate the program file:

1. Click Generate Bitstream as shown in Figure 16 to complete place and route, and generate the 
programming file.

Figure 16 • Generate Bitstream Data
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2. Click Export Firmware. This opens Export Firmware dialog box as shown in Figure 18.

3. In the Export Firmware dialog box: 

– Select Create project for selected Software Tool Chain.

– Select SoftConsole3.4 from the drop down list.

Figure 17 • Export Firmware

Figure 18 • Export Firmware Dialog Box
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4. Click OK. The successful firmware generation window is displayed as shown in Figure 19. 

5. Click OK. 

The log window is displayed as shown in Figure 20.

Figure 19 • Firmware Successfully Exported Message

Figure 20 • Firmware Log Window

Sup
ers

ed
ed
Revision 4 21



Creating a Libero Project for Firmware Catalog Sample Project - Libero SoC v11.6 and SoftConsole Flow Tutorial for 
SmartFusion2
Programming SmartFusion2 Security Evaluation Board Using 
FlashPro

The following steps describe how to program the SmartFusion2 Security Evaluation board using
FlashPro:

1. Connect the FlashPro4 programmer to the J5 connector of the SmartFusion2 Security Evaluation 
Kit board.

2. Connect the jumpers on the SmartFusion2 Security Evaluation Kit board as per Table 2. For more 
information on jumper locations, refer to "Appendix 1: Jumper Locations" on page 36.

Caution: Ensure that the power supply switch,SW7 is switched OFF while connecting the 
jumpers on the SmartFusion2 Security Evaluation Kit.

3. Connect the power supply to the J6 connector.

4. Switch ON the power supply switch, SW7. Refer to "Appendix 2: Board Setup for Running the 
Tutorial" on page 37 for information on the board setup for running the tutorial.

5. To program the SmartFusion2 device, double-click Run PROGRAM Action in the Design Flow 
tab as shown in Figure 21. 

Table 2 • SmartFusion2 Security Evaluation Kit Jumper Settings

Jumper Number Pin (from) Pin (to) Comments

J22, J23, J24, J8, J3 1 2 These are the default jumper settings of the SmartFusion2 
Security Evaluation Kit board. Ensure that these jumpers are set 
accordingly.

Figure 21 • Run Program Action
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Building Software Application Using SoftConsole 
The following steps describe how to build a software application using SoftConsole:

1. Open the standalone SoftConsole IDE.

2. Right-click on the Project Explorer window and choose Import option as shown in Figure 23.

Figure 22 • Invoking SoftConsole IDE

Figure 23 • Importing Projects
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3. Select General > Existing Projects into Workspace as shown in Figure 24.

Import Window is displayed as shown in Figure 25.

Figure 24 • Importing Existing Projects

Figure 25 • Import Window
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4. Browse through the Sysservices projects folder and select it as shown in Figure 26.

Figure 26 • Selecting System services
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5. Click OK.

6. Click Finish.

Figure 27 • Adding Projects to SoftConsole IDE
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The SoftConsole perspective is displayed as shown in Figure 28. 

7. Go to the location where the SoftConsole sample Firmware catalog project is saved, as shown in 
Figure 29.

Figure 28 • SoftConsole Workspace

Figure 29 • Sample Project main. c File
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8. Copy the main.c file and replace it with the existing main.c file under 
Sysservices_sb_MSS_CM3 project in the SoftConsole workspace. The SoftConsole window is 
shown in Figure 30. 

Figure 30 • SoftConsole Workspace - main.c File
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9. Right-click Sysservices_sb_MSS_CM3 in the Project Explorer window of the SoftConsole 
project and select Properties as shown in Figure 31. 

Figure 31 • Project Explorer Window - SoftConsole Project
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10. In the Properties window, go to Settings under C/C ++ Build and select GNU C linker as 
debug-in-microsemi-smartfusion2-esram.ld as shown in Figure 32. Click Apply and then OK. 

Figure 32 • Sysservices_sb_MSS_CM3 Properties Window
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11. Perform a clean build by selecting Project > Clean. Accept the default settings in the Clean 
dialog box and click OK, as shown in Figure 33. The SoftConsole project must not have any 
errors.  

12. Install the USB driver. For serial terminal communication through the FTDI mini-USB cable, install 
the FTDI D2XX driver. Download the drivers and the installation guide from 
www.microsemi.com/soc/documents/CDM_2.08.24_WHQL_Certified.zip 

13. Connect the host PC to the J18 connector using the USB min-B cable. The USB to UART bridge 
drivers are automatically detected. Verify if the detection is made in the device manager, as 
shown in Figure 34 on page 32.

Figure 33 • Settings for Clean Build
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14. Start the PuTTY session. If the PuTTY program is not available in the computer system, use any 
free serial terminal emulation program such as HyperTerminal or TeraTerm. Refer to 
the Configuring Serial Terminal Emulation Programs Tutorial for configuring the HyperTerminal, 
TeraTerm, or PuTTY.

The PuTTY settings are as follows:

–    115,200 baud rate

–    8 data bits

–    1 stop bit

–    No parity

–    No flow control

Figure 34 • Device Manager Window
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15. Select Debug Configurations from the Run menu of the SoftConsole. The Debug dialog box is 
displayed. Double-click on Microsemi Cortex-M3 Target. This displays a window similar to 
Figure 35. 

16. Ensure that the following information appears on the Main tab in the Debug Configurations 
window, and click Debug:

– Name: Sysservices_sb_MSS_ CM3 Debug 

– Project: Sysservices_sb_MSS_ CM3

– C/C++ Application: Debug\Sysservices_MSS_MSS_CM3_app

17.  Click Yes when prompted for the Confirm Perspective Switch, as shown in Figure 36. This 
displays the debug view mode.

Figure 35 • Debug Configurations Window

Figure 36 • Confirm Perspective Switch
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The SoftConsole Debugger Perspective window is opened, as shown in Figure 37. 

Figure 37 • SoftConsole Debugger Perspective
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18. Run the application by clicking Run > Resume. The Information on the SmartFusion2 device and 
design, along with a greeting message is displayed on the PuTTY, as shown in Figure 38. 

19. Terminate execution of the code by choosing Run > Terminate.

20. Close Debug Perspective by selecting Close Perspective from the Window menu.

21. Close SoftConsole using File > Exit. 

22. Close the PuTTY. Click Yes when prompted for closing.

Figure 38 • PuTTY Window
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Conclusion
This tutorial describes how to download the SoftConsole Sample project from the Firmware catalog and
how to create a Libero SoC project. It explains the procedure to generate the programming file and to run
the SoftConsole project on the SmartFusion2 Security Evaluation Kit. A sample project for implementing
System services features is created to display the SmartFusion2 device and design information.

Appendix 1: Jumper Locations
Figure 39 shows the jumper locations in the SmartFusion2 Security Evaluation Kit board.

Note: The location of the jumpers in Figure 39 are searchable.

Figure 39 • Jumper Locations
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Creating a Libero Project for Firmware Catalog Sample Project - Libero SoC v11.6 and SoftConsole Flow Tutorial for
SmartFusion2
Appendix 2: Board Setup for Running the Tutorial
Figure 40 shows the board setup for running the tutorial on the SmartFusion2 Security Evaluation Kit
board.

Figure 40 • SmartFusion2 Security Evaluation Kit
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List of Changes

The following table shows important changes made in this document for each revision.

Date Changes Page

Revision 4
(October 2015)

Updated the document for Libero v11.6 software release (SAR 72552). NA

Revision 3
(February 2015)

Updated the document for Libero v11.5 software release (SAR 64799). NA

Revision 2
(October 2014)

Updated the document for Libero v11.4 software release (SAR 61636). NA

Revision 1
(April 2014)

Initial release. NA
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Product Support

Microsemi SoC Products Group backs its products with various support services, including Customer Ser-
vice, Customer Technical Support Center, a website, electronic mail, and worldwide sales offices. This
appendix contains information about contacting Microsemi SoC Products Group and using these support
services.

Customer Service
Contact Customer Service for non-technical product support, such as product pricing, product upgrades,
update information, order status, and authorization.

From North America, call 800.262.1060
From the rest of the world, call 650.318.4460
Fax, from anywhere in the world, 408.643.6913

Customer Technical Support Center
Microsemi SoC Products Group staffs its Customer Technical Support Center with highly skilled engineers
who can help answer your hardware, software, and design questions about Microsemi SoC Products. The
Customer Technical Support Center spends a great deal of time creating application notes, answers to
common design cycle questions, documentation of known issues, and various FAQs. So, before you con-
tact us, please visit our online resources. It is very likely we have already answered your questions.

Technical Support
For Microsemi SoC Products Support, visit 
http://www.microsemi.com/products/fpga-soc/design-support/fpga-soc-support 

Website
You can browse a variety of technical and non-technical information on the SoC home page, at 
http://www.microsemi.com/products/fpga-soc/fpga-and-soc.

Contacting the Customer Technical Support Center
Highly skilled engineers staff the Technical Support Center. The Technical Support Center can be con-
tacted by email or through the Microsemi SoC Products Group website.

Email
You can communicate your technical questions to our email address and receive answers back by email,
fax, or phone. Also, if you have design problems, you can email your design files to receive assistance.
We constantly monitor the email account throughout the day. When sending your request to us, please be
sure to include your full name, company name, and your contact information for efficient processing of
your request.
The technical support email address is soc_tech@microsemi.com.
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Product Support
My Cases
Microsemi SoC Products Group customers may submit and track technical cases online by going to My 
Cases.

Outside the U.S.
Customers needing assistance outside the US time zones can either contact technical support via email
(soc_tech@microsemi.com) or contact a local sales office. Visit About Us for sales office listings and cor-
porate contacts.

ITAR Technical Support
For technical support on RH and RT FPGAs that are regulated by International Traffic in Arms Regulations 
(ITAR), contact us via soc_tech@microsemi.com. Alternatively, within My Cases, select Yes in the ITAR 
drop-down list. For a complete list of ITAR-regulated Microsemi FPGAs, visit the ITAR web page.
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50200487-4/10.15

Microsemi Corporate Headquarters
One Enterprise, Aliso Viejo,
CA 92656 USA

Within the USA: +1 (800) 713-4113 
Outside the USA: +1 (949) 380-6100
Sales: +1 (949) 380-6136
Fax: +1 (949) 215-4996

E-mail: sales.support@microsemi.com

Microsemi Corporation (Nasdaq: MSCC) offers a comprehensive portfolio of semiconductor
and system solutions for communications, defense & security, aerospace and industrial
markets. Products include high-performance and radiation-hardened analog mixed-signal
integrated circuits, FPGAs, SoCs and ASICs; power management products; timing and
synchronization devices and precise time solutions, setting the world’s standard for time; voice
processing devices; RF solutions; discrete components; security technologies and scalable
anti-tamper products; Ethernet Solutions; Power-over-Ethernet ICs and midspans; as well as
custom design capabilities and services. Microsemi is headquartered in Aliso Viejo, Calif., and
has approximately 3,600 employees globally. Learn more at www.microsemi.com.

© 2015 Microsemi Corporation. All
rights reserved. Microsemi and the
Microsemi logo are trademarks of
Microsemi Corporation. All other
trademarks and service marks are the
property of their respective owners.

Microsemi makes no warranty, representation, or guarantee regarding the information contained herein or
the suitability of its products and services for any particular purpose, nor does Microsemi assume any
liability whatsoever arising out of the application or use of any product or circuit. The products sold
hereunder and any other products sold by Microsemi have been subject to limited testing and should not
be used in conjunction with mission-critical equipment or applications. Any performance specifications are
believed to be reliable but are not verified, and Buyer must conduct and complete all performance and
other testing of the products, alone and together with, or installed in, any end-products. Buyer shall not rely
on any data and performance specifications or parameters provided by Microsemi. It is the Buyer's
responsibility to independently determine suitability of any products and to test and verify the same. The
information provided by Microsemi hereunder is provided "as is, where is" and with all faults, and the entire
risk associated with such information is entirely with the Buyer. Microsemi does not grant, explicitly or
implicitly, to any party any patent rights, licenses, or any other IP rights, whether with regard to such
information itself or anything described by such information. Information provided in this document is
proprietary to Microsemi, and Microsemi reserves the right to make any changes to the information in this
document or to any products and services at any time without notice.
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