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Accessing Serial Flash Memory using SPI Interface
- Libero SoC v11.5 and IAR Embedded Workbench
Flow Tutorial for SmartFusion2

Introduction

The Libero® System-on-Chip (SoC) software generates firmware projects using IAR, Keil, and
SoftConsole tools. This tutorial describes the process to build an IAR application that can be
implemented and validated using the SmartFusion®2 system-on-chip (SoC) field programmable gate
array (FPGA) Security Evaluation Kit.

The same firmware project can be built using SoftConsole and Keil tools. Refer to the respective

tutorials:
* Accessing Serial Flash Memory using SPI Interface - Libero SeC and SoftConsole Flow Tutorial
for SmartFusion2 SoC FPGA
* Accessing Serial Flash Memory Using SPI Interface - Libero SoC and Keil uVision Flow Tutorial
for SmartFusion2 SoC FPGA

The tutorial describes the following:
» Creating a Libero SoC project using System Builder.
» Generating the programming file to program the SmartFusion2 device
* Opening the project in IAR Embedded Workbench from Libero SoC
» Compiling application code
« Debugging and run code using |AR Embedded Workbench
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Design Requirements

Table 1+ Design Requirements

Design Requirements Description

Hardware Requirements

SmartFusion2 Security Evaluation Kit Rev D or later
* FlashPro4 programmer
» J-Link programmer
* USB A to Mini-B cable
« 12V Adapter

Host PC or Laptop Any 64-bit Windows Operating System

Software Requirements

Libero SoC v11.5

FlashPro programming software v11.5

IAR Embedded Workbench for ARM 6.4

Host PC Drivers USB to UART drivers

Any one of the following serial terminal emulation programs: |-
e HyperTerminal
*  TeraTerm
e PuTTY

Project Files
The design files for this tutorial canbe downloaded from the Microsemi® website:
http://soc.microsemi.com/download/rsc/?f=m2s, tu0547 _liberov11p5 df
The design files include:
» Libero project
* Programming files
« Source files
» SPI_Flash_Drivers
* Readme files
Refer to the Readme.ixt file provided in the design files for the complete directory structure.

Target Board

SmartFusion2 Security Evaluation Kit Board, Rev D or later.
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Design Overview

Design Overview

This design example demonstrates the execution of basic read and write operations on the SPI flash
present on the SmartFusion2 Security Evaluation Kit board. This kit has a built-in winbond SPI flash
memory W25Q64FVSSIG, which is connected to the SmartFusion2 microcontroller subsystem (MSS)
through dedicated MSS SPI_0 interface.

Read and write data information is displayed using HyperTerminal, which communicates to the
SmartFusion2 MSS using the MMUART_1 interface.

For more information on SPI, refer to the SmartFusion2 Microcontroller Subsystem User Guide.
Figure 1 shows interfacing the external SPI flash to MSS SPI_0.

SmartFusion2
MSS
= B SP1L.0_DO
< Pl
_MMUART_1_TXD = o | SPI_0.CLK .
< C < L
HHZrS'IFerfwicrial MUART 1 RXD > 2l SPIL0_SSO iCK External Flash
yp e > 3 ° " SPI_0_DI S Memory
N < > so
Fabric

Figure 1 « SPI Flash Interfacing Block Diagram
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for SmartFusion2

Step 1: Creating a Libero SoC Project

The following steps describe how to create a Libero SoC project:

Launching Libero SoC

The following steps describe how to launch Libero SoC:

1. Click Start > Programs > Microsemi Libero SoC v11.5 > Libero SoC v11.5, or click the shortcut

on desktop to open the Libero SoC v11.5 Project Manager.
2. Create a new project using one of the following options:

— Select New on the Start Page tab as shown in Figure 2.

— Click Project > New Project from the Libero SoC menu.

rG\ Libero

Project File Edit View Design Tools Help
e 1 o~ e 1
NEe 2903+

4

m [ »

Welcome to Libero SoC

Libero SoC Ouickstart Welcome To Microsemi's Libero SoC v11.5

Libero SoC Interface Description o

Message

Q Errors &, Warnings o Info E] Manage suppressed messages

Log Message

Figure 2 » Libero SoC Project Manager
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Step 1: Creating a Libero SoC Project

3. Enter the following information in the Project Details page, as shown in Figure 3.
— Project Name: SPI_Flash
— Project Location: Select an appropriate location (for example, D:/Microsemi_prj)
— Preferred HDL Type: Verilog
— Enable Block Creation: Unchecked

G‘ MNew Project | ~
Project Details
Specify Praject Details
Project Details
Project Name: SPI_Flash
Praoject Location: D:/Microsemi_prj -Erowse‘.‘
Device Selection -
| Description:
I Device Settings
Design Template Preferred HOL Type:
|| Enable Block Creation
Add HDL Sources
Add Constraints
u
Libefo)
| systemonchip -
Figure 3 * Project Details Page
4. Click Next. This opens Device Selection page as shown in Figure 4.
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Select the following values from the drop down list:

Family: SmartFusion2
Die: M2S090TS
Package: 484 FBGA
Speed: -1

Core Voltage: 1.2
Range: COM

(-‘ New Project

=REe X

Device Selection
Select a part for your project from the Part Mumber list

Project

Details

Device Selection

Device Settings

Design Template

Add HDL Sources

Add Constraints

Libe

System-on-Chip

il\
ro

Selected Part: M25090T5-1FG484

Part Filter
Search Part:
Part Number 4UT DFF User If0s uSRAM 1K LSRAM 18K Math (18x18) PLLs and Q
M25030T5-1FG484 86184 86184 267 112 109 a4 [
L] m | C
< Back ]Il MNext > ] [ Finish ] [ Cancel

Figure 4 » Device Selection Page
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Step 1: Creating a Libero SoC Project

Click Next. This opens Device Settings page. Do not change the default settings.

Click Next. This opens Design Template page as shown in Figure 5, Under Design Templates
and Creators, select Create a System Builder based design.

G‘ MNew Project

-

B

—

Design Template
Choose a design template

Selected Part: M25090T5-1FG484

Project Details
Device Selection
Device Settings
Design Template
Add HDL Sources
Add Constraints

.
Libefo

M SystemonChip

Design Templates and Creators

(21 None

IO Create a System Builder based design I

() Create a Microcontroller(MSS) based design

Sheyv only latest version

Design Methodology

[] Use Standalone Initialization for MODR,FDDR /SERDES Peripherals

< Back ][ MNext =

|

Einish l [ Cancel

L

Figure 5 * Device Template Page

7.
Note:

Click Finish. This opens System Builder window.

System Builder is a graphical design wizard. It creates a design based on high-level design
specifications by taking the user through a set of high-level questions that will define the intended
system.

Enter the name of the system as SPI_Flash and click OK, as shown in Figure 6.

|7 e |

& | System Builder

Enter a name for your system:

SPI_Flash|
o) [ Concd
e
Figure 6 » System Builder Window
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Figure 7 shows the System Builder — Device Features page.

re‘ System Builder - Device Fe_atures i - - lilﬂ‘g‘
> Device Features » 7 Peripherals » ; Clocks » > Microcontroller » ; SECDED » ) Security » » Interrupts » > Memory Map >

Select the SmartFusion2 features you will be using in your design

Memory

[ M35 External Memory

DR Bri: e L2l M3
- -

-

@ MDDR
Soft Memory Controller (SMC)

[] M35 On-chip Flash Memory { eNVM )

[t

Fabric External DOR Memory { FDDR. )

High Speed Serial Interfaces

[ sERDESIF_0

Microcontroller Options
[ watchdog Timer
[ Peripheral DMA
[ Real Time Counter

S2d & By TN
= 13 B wun

H

=
=
&l
El

APE_SLAVE |
UG DULK E
AP PR B

JECECNERY

[E05 —
COSEECR

AEER L]
ZNIS S

SDR
RAK

____| DORD |- - oo o oo

Figure 7 » System Builder — Device Features Page

9. Click Next. This opens System Builder - Peripherals page as shown in Figure 8.

10. Under the. MSS Peripherals section, clear all the check boxes except MM_UART_1 and
MSS_SPI_0, as shown in Figure 8.
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Step 1: Creating a Libero SoC Project

@ System Builder - Peripherals ] |

> Device Features » > Peripherals » } Clocks > Microcontroller » 3 SECDED » > Security Interrupts » > Memory Map »

Select the peripherals and masters for each subsystem

Fabric Slave Cores Subsystems
Core Version L] MSS FIC 0 - MSS Master Subsystemn i
1 CoreAHBLSRAM 20113 drag and drop here to add to subsystem

=]

CoreGPIO 3.0120 =

o @ MSS FIC_0 - Fabric Master Subsystem |
Corel2E ro102 I drag and drop here to add to subsystem |
CorePWM 4.1.106
CoreSPI 30156 @ MSS FIC 1 - MSS Master Subsystem.

drag and drop here to add to subsystem

moonow

6 CoreTimer 11101
7 CoreUARToph 522 [®@  MSSFIC 1 - fabric Master Subsystem |
2 Fobric AVRA Tlove D002 I& <
Wl
Fabric Master Cores Configure Enable MName
Core Version D MHAUARTS
1 Fabric AMBA Master 0.0.102 & MM_UARTZL I
O |mssrece
O |msses
@ MS5_SPL0
[ 4455-sp |
O |msssmo
O |mssuse
O |mssaac
O |mescan i

To move a perpheral from one subsystem fo another, drag it from its present location and drop it onto the desired sushsystem.
You cannot drag and drop onto MSS Peripherals.

Masters are in bold and blue.

Figure 8 » System Builder — Peripherals Page
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11. Click Next. This opens System Builder - Clocks page as shown in Figure 9.
12. In the System Builder - Clocks page (see Figure 9):

— Select System Clock frequency as 50 MHz and clock source as On-chip 25/50 MHz RC
Oscillator

— Select M3_CLK as 100 MHz
— Select APB_0_CLK and APB_1_CLK frequency as M3_CLK/1
— Do not change the default settings of remaining parameters.

(@ system Builder- Clocks — A W= )
> Device Features » » Peripherals » 7 Clocks » » Microcontroller » 3 SECDED 3 Security » » Interrupts » > Memory Map »

Configure clock requirements

Clock Fabric CCC Chip Osdllators

System Clock

50,0 MHz
| (©n-chin 25/50 Mz R Oscilator 3
Cortex-M3 and M55 Main Clock
| M3_CLK = 100.00 MHz 100.000 |
MDDR. Clocks

MDDR CLK -mick* [1_ =

DOR/SMC FIC QLK =MDOR_CLK/ [T~

M55 APB_0/1 Clocks

APB 0 CLK =M3_ClK/ 100.000
APB 1 CLK =M3_ClK/ 100,000
Fabric Interface Clocks

FIC 0 CLK =mick/ [1_ ~

FIC 1 CIK =mick/ [1__~

Fabric DDR Clocks

FODR. CLK = [100 MHz

FDDR SUBSYSTEM CLK  =FDDR_CLK/ (1~

Figure 9 » System Builder - Clock Page
13. Click Next. This opens System Builder - Microcontroller page. Do not change the default
selections.
14. Click Next. This opens System Builder - SECDED page. Do not change the default selections.
15. Click Next. This opens System Builder - Security page. Do not change the default selections.
16. Click Next. This opens System Builder - Interrupts page. Do not change the default selections.

17.Click Next. This opens System Builder - Memory Map page. Do not change the default
selections.

18. Click Finish.
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Step 1: Creating a Libero SoC Project

19. Select File > Save to save SPI_Flash. Select the SPI_Flash tab on the Smart Design canvas, as
shown in Figure 10.

SPI_Flash_sb_0

FAB RESET N POWER ON_RESET N
\mp—: DEVRST N MSS_READY
SA_0_PADSE
MVIUART 1_FADSE
FAB_CCC_PNSE
INT_PNSE

g’-

Figure 10 » SPI_Flash Smart Design

Connecting Components in SPI_Flash SmartDesign

The following steps describe how to connect the components in the SPI_Flash SmartDesign:
Right-click POWER_ON_RESET_N and select Mark Unused.

Right-click MSS_READY and select Mark Unused.

Expand INIT_PINS, right-click INIT_DONE and select Mark Unused.

Expand FAB_CCC_PINS, right-click FAB_CCC_GLO0 and select Mark Unused.
Right-click FAB_CCC_LOCK and select Mark Unused.

Right-click FAB_RESET_N and select Tie High.

. Click File > Save.

The SPI_Flash design is displayed as shown in Figure 11.

No ok wDdh =

SPI_Flash_sb_0
4B FABRESET N POWER ON_RESET NP

\mp—z[}wm_m MSS_READY [ ¥

ER R Tt S SRR 1P
MVUART 1_PADSEIQ--------- v
FAB_CCC_PNSE)
FAB CCC GLO X
FAB_CCC [OCK X
INT_PNSE

g

Figure 11 « SPI_Flash Smart Design
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8. Generate the SPI_Flash Smart Design by clicking SmartDesign > Generate Component or by
clicking Generate Component on the SmartDesign toolbar as shown in Figure 12

B 5Pl Flash & %

EEAEEE

Figure 12 » Generate Component

After successful generation of all the components, the following message is displayed on the log
window, as shown in Figure 13.

Info: 'SPI Flash' was successfully generated.

Log

QErrors ¥, Warnings oInﬁ)

[ i Jorey System Builder successfully generated 'SPI_Flash sb'.
Info:

alh = == o » s ol o« @

Open System Builder summary.for detsils &
PAD pin "SPI_Flash sb 0:5PI_0_PADS® of 'SPI_Flash sb 0" is autcmatically ccmnected to & top-lewel port.
Info: PAD pin "SPI_Flash sb 0:MMURRT 1 PRDS™ of “SPI_Flash sb 0" is automatically connect®d to a top-level port.
FRD pin "3PI_Flash_sb 0:DEVRST N of "5FI_Flash sb 0" is automatically conmnected(to a top-level port.
'SPI_Flash' was successfully generated.

m

'SPI_Flash' manifest file 'D:/Microsemi_prj/SPI_Flash/component/woEk/SPI_Flash/SPI Flash manifest.txt' was successfully generated.

Figure 13 » Log Window

Step 2: Generating the Program File

The following step describe how to‘generate the program file:

Click Generate Bitstream as shown in Figure 14 to complete place and route, and generate the
programmingfile.

PBroject ~ File Edit VYiew Design Toecls SmartDesign Help

T 2o oA &*

| Generate Bitstrearn i

Design Flow

Figure 14 » Generate Bitstream

14 Revision 3



& Microsemi

Step 3: Programming SmartFusion2 Security Evaluation Board Using FlashPro

Step 3: Programming SmartFusion2 Security Evaluation
Board Using FlashPro

The following steps describe how to program the SmartFusion2 Security Evaluation Board using

FlashPro:
1. Connect the FlashPro4 programmer to the J5 connector of the SmartFusion2 Security Evaluation
Kit.

2. Connect the jumpers on the SmartFusion2 Security Evaluation Kit board as per Table 2.
For more information on jumper locations, refer to Appendix C - SmartFusion2 Security
Evaluation Kit Board Jumper Locations.

CAUTION: Ensure that the power supply switch, SW7 is switched OFF while connecting the
jumpers on the SmartFusion 2 Security Evaluation Kit.

Table 2 + SmartFusion2 Security Evaluation Kit Jumper Settings

Jumper Number Pin (from) Pin (to) Comments

J22, 423, J24, J8, J3 1 2 These are the default jumper settings of the'SmartFusion2
Security Evaluation Kit board. Ensure that these jumpers are
set accordingly.

3. Connect the power supply to the J6 connector.

4. Switch ON the power supply switch, SW7. Refer to.Appendix A - Board Setup for Programming
the Tutorial for information on the board setup for running the tutorial.

5. To program the SmartFusion2 device, double-click Run PROGRAM Action in the Design Flow
tab as shown in Figure 15.

Design Flow F X
SPI_Flash_top B O @
Tool gt

v % Compile
+1 ConfigureFlash*Freeze
v £ Place and Route
4 b Edit Constraints
+= /0 Constraints
d} Timing Caonstraints
ja Fleorplan Constraints
4 "% Werify Post Layout Implementation
+| Generate Back Annotated Files
. Simulate
& Verify Timing
o} Werify Power
4 p Edit Design Hardware Configuration
L Pregramming Connectivity and Interface
& Programmer Settings
ey Device /O States During Programming
4 p Configure Security and Programming Options
| Configure User Programming Data

m

@‘ Configure Programming Recovery
@ Configure Security
@‘ Update eMVM Memory Content

& 4 » Program Design
@‘ Configure Bitstream

v % Generate Bitstream

i W% Run PROGRAM Action

4 ¢ Debug Design -

Figure 15 « Run Program Action
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Step 4: Configuring and Generating Firmware

The Design Firmware window displays compatible firmware drivers based on peripherals configured in
the design. Following drivers are used in this tutorial:

+ CMSIS
+ MMUART
+ SPI

To generate the required drivers:

1. Double-click on Configure Firmware Cores in Handoff design for Firmware Development in
Design Flow window.

2. Clear all the drivers check boxes, except CMSIS, MMUART, and SPI as shownin Figure 16.
Note: Select the latest version of the drivers.

| Reports @ x | Starage @ x | EdsPrrAash o x | G DESIGN FRMWARE @ X |

Generate I Instance Name Core Type ersion Compatible Hardware Instance

i gt %I SmartFusion2_CMSIS_0 SmartFusion2_CMSIS 2.24101 . |SPI_Flash_sb,MsS

2 ]| !g SmartFusion2_MSS_HPDMA_Driver_0 SmartFusion2_MSS_HPDMA_Driver 2.0888 |SPI_Flash_sBiMSS

3 !g SmartFusion2_M35_MMUART _Driver_0 SmartFusion2_MS5_MMUART _Driver 2.0.101  |SPI_Flash sb_MS5:MMUART _1

4 B q; SmartFusion2_MSS_NVM_Driver 0 SmartFusion2_MSS_NVM_Driver 220100 - |SPISFEEh_sb_Mss

H v Driver_0 artFusio D PR 5PI_Flash_sb 0

& 0o !g SmartFusion2_MS5_System_Services_Driver _0 SmartFusion2_MS5_System_Services_[IFMEr 2.4, 100~ |SPI_Flash_sb_mss

7 B q; SmartFusion2_MSS_Timer_Driver_0 SmartFusion2_MSS_Tifiep Driver 2.0.101 SPI_Flagh_sb_mMss

Figure 16 « Configuring Firmware

3. Double-click on Export Firmware in Handoff design for Firmware Development in
Design Flow window.

Export Firmware dialog box is displayed as shown in Figure 17.

i ™
.| Export Firmware @Iﬂ
Location: D:\Microsemi_pri\sPI_Flash

Software Toal Chain: |TAR EVWARM -

Create project for selected Software Tool Chain

o] (o

Figure 17 » Export Firmware Dialog Box

4. In the Export Firmware dialog box:
— Select Create project for selected Software Tool Chain.
— Select IAR EWARM from the drop down list.
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Step 4: Configuring and Generating Firmware

5. Click OK. The successful firmware generation window is displayed as shown in Figure 18.

5| Information @

a-

| Firmware project was successfully exported to 'D:\Microsemi_prj\SPI_Flash'.

Figure 18 « Firmware Successfully Exported Message

6. Click OK.

The SmartFusion2 Security Evaluation Kit is ready for running and debugging the IAR Embedded
Workbench application through J-Link Debugger.
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Step 5: Building Software Application using IAR Embedded

Workbench

The following steps describe how to build a software application using IAR embedded workbench:

1. Connect the J-Link programmer to J4 connector of SmartFusion2 Security Evaluation Kit.

Refer to "Appendix B - Board Setup for Running the IAR Tutorial" on page 43 for information on
the board setup for running and debugging the IAR software application.

Ensure that the SmartFusion2 Security Evaluation Kit Jumper J8 is in 2-3 closed position for IAR
Embedded Workbench and J-Link communication.

Figure 19.

Open the IAR project by double-clicking SPI_Flash_sb_MSS_CM3 IAR project as shown in

& 1AR Embedded Workbench IDE =B x
File Edit View Project Tools Window Help ~ -~ -
DwHd &L BR|o ™| Y S E e @ P @ E VAR | W
\[NNIGDEOE * | 18R Information Center for ARM | -
-
i R
X G 3’2 Open Workspace 4 < ﬂ
Files R 7 . g -
y |21 E. @uv| .« Microsemi_prj » SPLFlash » IAR » - ‘ +4 Wl Segrch 1AR pel |
| LITTITTT —
Organize = Mew folder =~ i @
: - A - ;
45 Favorites MName Date modified Type Size
Bl Desktop L CMSIS 12/16/20143:29 PM  File folder
4 Downloads . drivers 12/16/2004'3:29 PM  File folder
=] Recent Places | drivers_config 12/16/2014 3:23 PM  File folder
L hal 12/16/2014 3:29 PM  File folder
i Ml Desktop ] SP1_Flash_sh_M55_CM3: 12/16/2014 3:29 PM  IAR IDE Workspace 1KB
Tl
Guidelin
your proj
files, cor
and debi
File name: SPL Flash_sb_MSS_CM3 [ Workspace Files (".evw) -
{ [ Open ] [ Cancel ]
by
Tutorisls o make you For questions about how All about the |atest Here you can download
familiar with the IBE to use your |AR product. festures, new device product updates,
and the features of the reporting & problem, or support, and program manage licenses and
1ARC-8FY debugger. finding support comections. contact information, snd |4
TESOUICEs. chedk your SUA status.
0] J=) 1 r -
Ready MUM

"

Figure 19 « Invoking IAR Embedded Workbench from Libero SoC Software
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Step 5: Building Software Application using IAR Embedded Workbench

The IAR workspace is displayed, as shown in Figure 20.

& SPI_Flash_sb_N 13 - IAR Embedded Warkbench IDE L — E=NACE X

File Edit View Project Simulator |Teols | Window Help

DS &% Ra| o o A4S Ee e P Ak RURS| DD |

_—
SPI_Flash_sh MS5_CM3 ke platfom - Debug -

Files L3

B BSPI_Flash_sh_MSS_CM3

I—EJ  SPI_Flash_sb_MSS5_CM3_h...
| CIcMsIs

| [ drivers

I [ drivers_config

|

|

Cahal .
CJHeaders
3 Output

I—E.| D SPI_Flash_sh_tMSS_CM3_app-...
— CfETE

I Owverview  SPI_Flazh_sh MSS_CM3_hwa_platfarr o | v

Ready

Figure 20 - IAR Workspace

3. Browse to the main.c fi
<download folder>\SF

4. Copy the main.
project in the

design files folder:
1 IAR_Tutorial_DF\SourceFiles.

the existing main.c file under SPI_Flash_sb_MSS_CM3_app
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The IAR window displays the main.c file, as shown in Figure 21.

-
# SPI_Flash_sb_MS5_CM3 - [AR Embedded Workbench IDE e G— - —_— - l_l_lﬂ":" =
File Edit View Project Simulator Tools Window Help
D H@ =] | | - |2t D5 & |
* | main | ) - ®
[SPI_FIash_sb_MSS_CM3_hw_pIatform -Debug - int main()
-
Files mo| B .
wvolatile uinté_t errors
ESP‘—FlﬁSh—Sh—MSS—CME uintf_t manufacturer_id
|- (3 SPI_Flash_sh_MSS_CM... uinté_t deviece_id = 0f

9 SF_Flash_sb_MS5_Ch3_a..

/* Disable Watchdog */
SYSREG->WDOG_CR = 0x00
M55 URRT init({sg_mss_uartl,
M55_UART_115200_BAUD,
MS5_UART_DATA_#_BITS | MS5_UART_NO_PARTTY | MSS UART_ONE_STOP BIT) :
M55_URRT polled tx string{sg_mss_uartl, g_greeting mag);

[Lm

=] i
* Flash Driver Initialization
. a—/
FLASH init{);

Overview  SPI_Flash_sb_M5S_Ch3 hw_pl[ 4 [+ < =

|-

Ready NUM

Figure 21 « IAR Workspace main.c file

5. winbondflash SPI flash drivers are not included in the Libero generated IAR workspace. To
include the drivers in the IAR workspace, browse to the location of the winbondflash drivers in the
design files folder: <download_folder>\SF2-SPI_Flash_IAR_Tutorial DF\SPI_Flash_Drivers.

6. Copy the winbondflash folder to the drivers folder of SPI_Flash_sb_MSS_CM3_hw_platform
project in the IAR workspace: projectdirectory\lAR\drivers.
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7. Right-click and add the driver files (winbondflash.c & winbondflash.h) to the
SPI_Flash_sb_MSS_CM3_hw_platform project in the IAR workspace as shown in Figure 22.

Workspace

[ SP|_Flash_sb M55 _Ck3_app - Debug

Files

B [ SPI_Flash_sh_ME5_Ch43
—= (3 SFPI_Flash_sh_tM55_Ch3_hw_platform - Debug

| e ——————— N

—H [ ChSIS
I drivers_ Options..
—& [ hal
Mak
—H [ Header : E_
= [ Output Compile
= (FSPI_Flas Rebuild All
rain.c Clean
= [ Output
Stop Build
Add
Remove
Rename...

Version Control System

Open ContainingiEclder...

File Prdperties,,

Set ag Aative

Add Files...

Add "main.c”
Add Group...

Figure 22 + 1AR Workspace Window - Add winbondflash SPI Driver Files
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Figure 23 shows the IAR workspace window displaying winbondflash SPI Driver Files.

Workspace x
ISF'I_FIash_sI:u_MSS_EMS_hw_pIatfu:urm -Debug -

Files LH

B [@SFl_Flash_sh_tS5_Chd3

—= (F SPI_Flash_sb_MS5_CM._ ..

—E (1 CMSIS

—= [ drivers
mss_spi.c

mss_uart.c

winbondflash.c

[n] winbondilash. h

1 drivers_config

—= (T hal

—= (1Headers

= (] Output

& SFI_Flash_sh_MS5_Chd3_a..

Figure 23 * IAR Workspace Window - Display winbondflash SPI Driver Files
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8. To configure the project, right-click the project name (SPI_Flash_sb_MSS_CM3_hw_platform)
and click Options as shown in Figure 24.

& SPI_Flash_sb_MSS_CM3 - IAR Embedded Workbench IDE

File Edit View Project Simulator Tocols Window Help

D& & % 2R o -4 %
Warkspace x
| SPI_Flash_sh_MSS_CM3_hw_platform - Debug v

Files LH

B & SFI_Flash_sb_35_Ch43

molE |SPI_Flash_sb_MSS_ghi b [
= [ CHSIS Options... .
—E (1 drivers
mss_pdma.c Make x
mss_spi.c Compile x
mss_uart.c Rebuild Al .
[ winbondflash.c Clean *
L— [ winbondflash.h
= [ drivers_config Stop Buifd x
—& (T hal x
—H [(JHeaders Add C
= [ Output
L1 () SPI_Flash_sh_MSS_Chs Remove
L— [ main.c Rename.d
Version Control System [
Open Containing Folder...
File Properties...
Set as Active

IDvewiew SP|_Flazh_sb M55_CkW3_hw_platform | SPI_Flazh_sb_M55_CM3_app

Figure 24 +1AR Workspace Window - Choose Options
This tutorial uses printf statements to display memory read data. Redirection of the output of
printf () toa UART is enabled by adding the MICROSEMI_STDIO_THRU_UART symbol.
9. In/Options window, click C/C ++ Compiler.
10: Click Preprocessor tab.
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11. Under Defined symbols enter MICROSEMI_STDIO_THRU_UART and click OK, as shown in

Figure 25.
_ _ ~
Options for node "SPLFlash_sb_MSS_CM3_hw_platform” [
ez [ Facton Settings ]
General Options [ Muiti-file Campilation
Dizzard Unuzed Publics
Azzembler
Custom Build | Language 2 I Code I Optimizations I Output I List | Preprocessar || 4 | ¢
Build Actions
Library Builder [ Ignare standard include directories
Additional include directories: jone per line) N n 4 0
SPROJ_DIRSS -
SPROJ_DIRS/CMSIS

SPROJ_DIRS/CMSIS /startup_iar L4
SPROJ_DIRS drivers
SPROJ_DIRS/drivers/mss_pdma

Preinclude file:

Defined symbols: jone perling)
MICROSEMI_STDIO_[THRU & (™| Preprocessor output to file

Preserve comments
| Fenerate Hine directives

-

[ OF. ] [ Cancel

Figure 25 * IAR Workspace Window - Adding Symbol

Revision 3



& Microsemi

Step 5: Building Software Application using IAR Embedded Workbench

12. To configure the project, right-click the project name (SPI_Flash_sb_MSS_CM3_app) and click
Options as shown in Figure 26.

Workspace x
[SF‘I_FIash_sI::_MSS_EM 3 hw_platform - Debug -
Files LH

B [ 5FI_Flash_sh_t35_Ch3
—= (3 SPI_Flash_sb_M55_CM3_hw_platfor._.
CICMSIS *
—E (1 drivers
mss_pdma.c *
mss_spi.c *
mss_uartc "
winhaondflash.c *
L — [ winbondflash.h
[ drivers_config x
[(Jhal *
[IHeaders
[ Cutput
e lnSFE_Flash sl — :
L — & main.c I Options... I
Make
Campile
Rebuild All
Clean
Stap Build
Add 3
Remove
Rename...
Version Control System [
Open Containing Folder...
File Properties...
Set as Active

Overviews  SPI_Flazh_sb bS5_CM3_ ke _platform | SPI_Flazh_|[ 4 |«

Figure 26 * IAR Workspace Window - Choose Options
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The Options for node SPI_Flash_sb_MSS_CM3_app window is displayed as shown in
Figure 27.

r ™
Options for node "SPL_Flash_sb_MSS_CM3_app" - [

Categon:

C/C++ Compiler

Aszembler

Output Converter Target | Output | Library Configuration | Library Options | MISRAC:200 * | *

Custom Build

Build Actions

Linker
| Debugger i@ Core [Curtex—l'ﬂﬂ - ]
Simulator
Angel (@) Device  |Mone 'Eh__]
GDE Server
IAR. ROM-monitor
It _
ink/1-Trace Endian mode ERL
TI Stellaris @) Little MNone
Macraigor ) Big
PE micro BE
RDI _
TTAGjet @ BE
STLIMK
Third-Party Driver
TI XD5100

Processor varant

2

| (== [

[ OF. J [ Cancel

Figure 27 + |IAR Node Options

13. Click Debugger. Under the Setup tab, select J-Link/J-Trace from the Driver the drop-down list
(refer to Figure 28).
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-

Options for node "SPI_Flash_sb_ M55 CM3_app”

A

25|

Categon:

General Options
C/C++ Compiler
Azzembler
Output Converter
Custom Build
Build Actions
Linker

Simulataor

Angel

GDE Server

IAR. R.OM-manitor
IHet
J-LinkfJ-Trace

TI Stellaris
Macraigor

PE micro

RDI

JTAGjet

STLIMK
Third-Party Driver
TI XD5100

Setup | Download I Images I Extra Options I F‘Iugins|

[ Factony Settings ]

Driver

[¥] Bun to

[J-Link/J-Trace |

main

Simulator

Angel

G0E Server

|AR ROM-monitar

et
T Stellaris

Macraigor

PE micro

RDI

JTAGjet

ST-LINK

Third-Party Driver
TIXDS100

L

_sb_MSS_CM3_hw platform mac E]

=

] [ Cancel

Figure 28 * IAR Debugger Options - Selecting Driver

Revision 3

27



& Microsemi

Accessing Serial Flash Memory using SPI Interface - Libero SoC v11.5 and IAR Embedded Workbench Flow Tutorial
for SmartFusion2

14. Click Download tab and select the Verify download check box as shown in Figure 29.

r —— - - [
Options for node "SPL Flash_sb_MSS_CM3_app" [

Categon: [ Factary Settings ]

General Options
C/C++ Compiler
Azzembler

Output Converter Setup | Download | Images I BExtra Optiong I F‘Iugins|
Custom Build [

Attach to program
Build Actions
Linker iR ad;

| [ Suppress download

Simulator
Angel [ Use flash loaderis)

GDE Server Dvemde default board file
IAR ROM-manitor STOOLKIT_DIRS\corfig'flashloader. j v
I4et .
J-LinkfJ-Trace Edit...

TI Stellaris
Macraigor

PE micro

RDI

TTAGet

STLIMK
Third-Party Driver
TI XD5100 [

(] J [ Cancel

N _

Figure 29 * IAR Debugger Options - Download
15. Click OK to close the Options window and build the project.
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16. Right-click SPI_Flash_sb_MSS_CM3_hw_platform - Debug and select Make as shown in

(Figure 30 and Figure 31).

Workspace

[ SP|_Flash_sb M55 _Ck3_hw_platform - Debug

Files

==la|SFl_Flash_sb_|

B O =F_Flash_shb_MM=5_Ch3

Owverview  SPI_Flazh_shb k5

= [ CHSIS Options...

=1 (1 drivers S
mss_pdma. :
mss_spi.c Compile
ss_uar.c Rebuild All
[ winbondflas Clean
L— B winbondflas

(I drivers_caonfig Stop Build

—= [T hal

—# (1 Headers Add

= [ Output

L= (9 SPI_Flash_sh_M HERTE
L— & main.c Rename...

Versign Control System

OpenContaining Folder...
File Properties...

Sebas Active

Figure 30 * 1AR Workspace - Hardware Platform Code Compilation using Make

Successful Hardware Platform Code Compilation page is displayed as shown in Figure 31.

Messages
sys_config.c
system_masxx.c
wvector_table.c
winbondflash.c
wite.c

Building librany

Tatal number of erfars: 0
Total numberaf warnings: 0

Build

File Line *

m

D:\Microsemi_prj\SPL_Flash\IAR\SPI_Flash_sb_PS5_CM3_hw_platform.ewp

Errors 0, Warnings 0

NUM

Figure 31 * IAR Workspace - Successful Hardware Platform Code Compilation using Make
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17. Right-click SPI_Flash_sb_MSS_CM3_app - Debug project name and select Set as Active as
shown in Figure 32.

Workspace x
[ SP|_Flagh_sb M55 Ch3 b platform - Debug -
Files LH

B L SF_Flash_sh_tS5_Chd3
—& (1 SPI_Flash_sb_MS55_CM3_hw_platform - Debug
—E [ ChSIS
—E (1 drivers
mss_pdma.c
mss_spi.c
mss_uartc
[ winbondflash.c
L— [ winbondflash.h
[ drivers_config

[(Jhal

[IHeaders

[ Cutput

=l ISP Flash_sh b i [

L— [ main.c Options...
Make
Compile
Rebuild All
Clean
Stop Build
Add 3
Remove
Rename...
Version Control System [
Open Containing Folder...
File Properties...

I Dwerview 5P|_F|aSh_Sb_M5I Set as Active | ]

Figure 32 + IAR Workspace - SPI_Flash_sb_MSS_CM3_app Set as Active
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18. Right-click SPI_Flash_sb_MSS_CM3_app - Debug project name and select Clean as shown in

Figure 33.
Workspace x
[SF‘I_FIash_sI::_MSS_EM 3 app - Debug -
Files LH

B L SF_Flash_sh_tS5_Chd3
—2 (1 SFI_Flash_sh_MS5_Ch3_hw_platform - Debug
—E [ ChSIS
—E (1 drivers
mss_pdma.c
mss_spi.c
mss_uartc
[ winbondflash.c
L— [ winbondflash.h
[ drivers_config

[(Jhal
[IHeaders
= [ Output
=l |SPI_Flash_sb_ g -
- & main.c Sl
= [ Output Make
Cofmpile
Febuild AII
| Clean |
Stog Build
Add 3
Remove
Rename...
Version Control System [
Open Containing Folder...
File Properties...
I Dewverview  SPI_Flash_sh M35 Set as Active Tl

Figure 33 * IAR Workspace - Execute Clean on SPI_Flash_sb_MSS_CM3_app Project
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19. After cleaning the project, the Messages log section shows that some files are deleted as shown

in Figure 34.

Messages File Line
Deleting outputs for configuration Debug
Updating build tree...
2 file(s) deleted.
=
=l
o
Ready Errors 0, Warnings 0 NUM

Figure 34 « IAR Workspace - Deleted Files

20. Right-click SPI_Flash_sb_MSS_CM3_app - Debug project name and click:Rebuild All as

shown in Figure 35.

Workspace

[ SP|_Flash_sb M55 _Ck3_hw_platform - Debug

Files

B & SFI_Flash_sb_k35_Ch43
9 SPI_Flash_sb_MSS_
l—E_l W ]SF|_Flash_sb_ g

main.c
[ Cutput

Options...

ake

Sampile

CM3_hw_platform - Debug

| Rebuild Al

Clean
Stop Build
Add

Remowve

Rename...

Version Control System [

Open Containing Folder...
File Properties...

Set as Active

Owverview  SPI_Flazh_sb S5_CM3_ ke _platform | SPI_Flash_sb M55 _Ch 4 .

Figure 35 * IAR Workspace - Select Rebuild All
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Messages

File Line
Building configuration: SPI_Flash_sb_MS55_CM3_app - Debug

Updating build tree...

2 file(s) deleted.

Updating build tree...

main.c

M\ wWarning[Pe223]: function "printf" declared implicithy Dikdicrosemi_pr..\main.c 89
M\ Warning[Pe111]: statementis unreachable Dikicrosermi_pt). Amainc 107
Linking

Total number of errors: 0
Total number of warnings: 2

Build

T

Figure 36 * IAR Workspace - Rebuild All
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Step 6: Configuring Serial Terminal Emulation Program

The following steps describe how to configure serial terminal emulation program:

1. Install the USB driver. For serial terminal communication through the FTDI mini USB cable, install
the FTDI D2XX driver. Download the drivers and the installation guide from:
www.microsemi.com/soc/documents/CDM_2.08.24 WHQL_Certified.zip.

2. Connect the host PC to the J18 connector using the USB Mini-B cable. The USB to UART bridge
drivers are automatically detected. Of the four COM ports, select the one with Location as on
USB Serial Converter D. Figure 37 shows an example Device Manager window.

&4 Device Manager = & =

File Action View Help
&= @ E HR | E&D

4= wi-onteddhus

> 8 Computer USB Serial Port (COM10) Properties [
b Disk drives ﬁ—|—|—|

b B, Display adapters eneral | Port Settings | Driver | Details

gy DVD/CD-ROM drives. USB Seral Port COM10)

» 5 Human Interface Devices i

> g IDE ATA/ATAPI controllers

b Keyboards Device type: Ports (COM & LPT)

b Jﬂ Mice and other pointing devices Manufacturer: FTDI

> B Monitors Location: on USE Seral Converter D

¥ Network adapters

Y3 Ports (COM & LPT)
: ¥F Communications Port (COML)
ECP Printer Port (LPT1

USE Serial Port (COMT)
Y% USB Serial Port (COMS)
YZ' USB Serial Port (COMP)
> |5 Processors =
b -%| Sound, video and game controllers
b M Systern devices

Device statua

This device is working propery.. -

> - § Universal Serial Bus controllers

Figure 37 » Device Manager Window

3. Start the HyperTerminal session. If the HyperTerminal program is not available in the computer,
any free serial terminal emulation program such as PuTTY or TeraTerm can be used. Refer to the

Configuring  Serial “Terminal Emulation Programs Tutorial for configuring the HyperTerminal,
TeraTerm, or PuTTY.

The HyperTerminal settings are as follows:
— 115200 baud rate

— / 8 data bits

— 1 stop bit

— No parity

— No flow control
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Step 7: Debugging the Application Project using IAR
Workbench

The following steps describe how to debug the application project using IAR Workbench:
1. Switch to SPI_Flash_sb_MSS_CM3_app - Debug tab from Overview tab as shown in Figure 38.

. . . . _
[Del:uug -
Files B

B SPI_Flash_sb_MS55_CM3_app - Debug
main.c
s outoet | |

SPI_Flash_sb MS5_CM3_kw_platfarm |§ SPI_Flash_sb_MSS_CM3 app § 4 |+

Figure 38 « Debug Window
2. In the IAR Workbench, click Download and Debug as shown in Figure 39.

v ¥ b r@n 2% Bl

| -
m= {bownload and Debug =

Figure 39 IAR Workbench - Download and Debug Option
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IAR Debugger Perspective window is opened, as shown in Figure 40.

/& SPL Flash_sb_MSS_CM3 - IAR Embedded Workbench IDE 0 [E=EEE
| File Edit View Project Debug Disassembly J-Link Tools Window Help
DEEH@ &% bR | YA e P @B BURS | D
Slel2x L2222 X
Workspace * | nain | w0 - x [Di o <
[Debug - — Goto -
Files ) dkdkkkkkdkhrdedrd SmartFusion? MSS SPI Flash eXample **#sddkerskes 0 Disassembly i
=] SPI_lﬂSh_S... - This example project demonstrates the use of the SmartFusion? MSS ! B mhilel readyl_
) main.c block.It reads and writes the content of an external SPI flash dew: 0z2000310=: D=t
L@ [ Output 0z20003212: 0=x2 ||
SRR R R R R R R R R R R AR R R R R AR R R AR AR AR AR AR 0x20003114: 0=d ||
T‘ * main function. j +
=/ 0z20003116: 0=k
int main() ??DataTableld:
(= 0=20003118: 0=2
volatile uint@_t errors = 0; int gnaing )
uinté_t manufacturer_id = 0; i
uinté_t device_id = 0; nain:
/% Disable Watchdog +/ wvolatile uint8
SYSREG->WDOG_CE = 0x00000000; UEIEL: [
M5S_URRT init(sg_mss_uartl, =20 005200 £
MS5_UART_115200_BAUD, D“;E;ggizl‘an;fz I
= o 0=
SPI_Flash_sb_MS5_CM3_app [+ [ @l - MSS TIART NATA & RTTS( | MSS TIART MO szT'l'lell Bl e -
Log i
Tue Mar 03, 2015 18:16:45: Software resetwas performed 3
=4 Tue Mar 03, 2015 18:16:45: Target reset -
g‘ < [ -~ b
& Debug Log | Build x
Ready NUM

Figure 40 * 1AR Workbench - Debugger Perspective

3. Click Go on IAR workbench to run the application as shown in Figure 41.

1R Embedded Workbenc b i1

Fie Edt View Project [[Nbug Dbassenbiy )Lk Took Window Help

D@ NG | v > @ WHES b
= 2 £ BRI x

Figure 41 + IAR Workbench - Go Option
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4. On successful operation, the HyperTerminal window displays a message as shown in Figure 42.

8 ° 5PL_Flash - HyperTerminal

~

[ =N

Eile Edit View (Call Transfer Help

BE B B -RE BE B RE BE B RE BE B RE BE B RE BE B RE BE B RE ME B RE ME B R ME MR ME MR ME MR E B R M B R ME B R W B R W B R E MR M MR W MR W MR M MR M MM

This example project demonstrates the use of the SmartFusion2 MSS.SPI
block.It reads and writes the cbntent of an external SPI flash device

Enter your choice and press Enter
1.Hrite
2 .Read

L e

Connected 0:00:49 Auto detect 115200 8-M-1 NUM

m

h

Figure 42 « HyperTerminal Window

5. Select option 1 and enter values to write to the SPI.Flash Memory.as shown in Figure 43.

B ' SPL_Flash - HyperTerminal

( = | (B

File Edit Wiew Call Transfer Help
0= & DB

1

Enter any 5 values between @ to 99 to write to Flash Memory

Enter vour choice and press Enter
1.Write
2 .Read

m

+ e

Connected 0:02:43 uto detect 115200 B-M-1 MNUM

A

Figure 43 * HyperTerminal Window - Option 1

Revision 3

37



& Microsemi

Accessing Serial Flash Memory using SPI Interface - Libero SoC v11.5 and IAR Embedded Workbench Flow Tutorial
for SmartFusion2

6. Select option 2 to read data from SPI Flash Memory as shown in Figure 44.

-
B ' 5PI_Flash - HyperTerminal l‘:' Cl ﬁ
File Edit View Call Transfer Help
O = & 0B

Enter vour choice and press Enter -
1. Urite

2 .Read

2

Read Data From Flash

Read operation is completed

Enter vour choice and press Enter
1.Hrite
2 .Read

m

€| 1 | 3

Connected 0:03:23 Auto detect 115200 8-N-1 iRy NCapt Pri

A

Figure 44  HyperTerminal Window - Option 2

7. Click View > Register to viewthe values of the ARM® Cortex®-M3 processor internal registers as
shown in Figure 45.

7 A
2 SPLFlash_sb_MSS_CM3 - AR Embedded WorkbenchDE o o
File Edit Project Debug Disassembly J-Link Toals' Window Help
=3 Messages v iy ¢ VRS b o
= | | Workspace
Workspace Source Browser = | main ‘ #) = x Disassembly = | Register x
Debug Breskpoints - — B - Cument CPU Registers =
Files R—— W *kkkEhE Rk RS+ 4 SmartFusion? MS5 SPI Flash example ***kwsx Disassembly - gg S Exggggg(ﬂ:gE
= H
= FE] Memary | This example project demonstrates the use of the SmarcFusion b while{ readVl—l R2 = 0x20003D50
Symbalic Memo block.It reads and writes the content of an external SEI fla 0=2000310e: 0xf—|| R3 = 022000801C
Ly ¥ y 0=20003112: 0=2 = 0=4001000(
T,j 0520003114 Oxd - 0220008Dé¢
Watch 3 * main function. i| i = 0=00003411
Locels "/ 0x20003116 . 032 * owaoniono
s ) ??DataTablell S FESTERLL
Statics { 0%20003118: Ox2 =
Auto wvolatile uintg_t errors = 0; int main() ; gzﬁgégggg;
uinté_t manufacturer id = 0; { = 0z4002904(
Live Watch uinté_t device_id = 0; main = UEZUUUSCZ[
Quick Watch 2 = 0x20003DAE
Call Stack /+ Disable Hatchdog &/ wvolatile uint8 = EXEEEEESEE
# Disable Watchdog * = Ox
Stack , [— BANTRNo: (i - 0=0100000¢
Terminal /O M55_URRT_init(sg_mss_uartl, 0=20003220HM0=6 = 0x2000311C
g M55 _UART_115200_BATD, urntSRcgnenafe) = 0=0000000C
mages MSS TTART DATR A RTTS | MSS TIART NO PRI _0320003124 0=2 —
SPI_Flash [ra— o li——— =l g B o v
o Symbols A
Tug Toolbars + i code (BP) slots and 2 literal slots
=l Tug reset was perormed K
é’l v Status Bar 2 \:\
i
‘§ Debug Log | Build x
Open a new Register window NUM =
— = — = — = L

Figure 45 + Values of Cortex-M3 Internal Registers
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8. Click View > Statics to view the values of variables in the source code as shown in Figure 46.

% SPL_Flash_sb_MSS_CM3 - IAR Embedded Workbench DE — . B
File Edit | View | Project Debug Disassembly J-Link Tools Window Help
D@ E  Mesages v YR Ee e B BWUNHS S
= | ['§ | Workspace
Warkspace Source Browser - ‘ #) - x Statics x
— i
[Dehug s \ENmh, i “ariable Value
4ddkaddkaskirdihss SmartFusion? MSS SPI Flash example *%s*+skessssssrss|piny SystemC.. 100000000
Files Disassembly
\rinh __wvector. {array:
E‘ﬂ Memory This example project demenstrates the use of the SmartFusion2 MSS SPINr\n\ address ... 0
C Symbalic Memary block.It reads and writes the content of an external SPI flash device\r\n) ch <main... '~0' (0=00
Register \rvnty g_Frequ.. 100000000
/,,,f,,x,,,,:,,x,,,,,,,”,,,,,,””,,,,,,”,,,,,,,,“,,,,”“,“,”“,“””//“ i qFrequ.. 100000000
Watch 3 I/m.z.r: function. |; o_Frequ._. 100000000
Locals = - L4 g_Frequ.. 100000000
£ !
‘E T‘ i) _Fragu.. »100000000
Auto wolatile uintg_t errcrs = 07 g_Fregu %ﬁDDDDDD
uint?_t manufacturer id = 0; g flash_r..
Lz iEtEs uinté_t device_id = g_flash_.
Quick Watch gegreeti Pz
Call Stack O_mss 8. <structy
/* Disable Watchdog */ f_mss_s <struct:
Stack 4 SYSREG->WDOG_CR = 0x00000000; g mss u. <struct:
Terminal O MSS_UZRT_init(sg_mss_uartl, g_mss_u. <struct:
Ta— MSS_URRT_115200_BAUD, o_stdio_.. D
9 ¥S5_UART_DATA_E_BITS | MS5_UART_NO_PARITY | MSS_UART ONE_SI0B.31T) & gp_my .. g_mss ua..
Code Coverage MSS_UART polled tx_string(sg_m3s_uartl, g_greeting mag): i<mainti>  '~0' (0=00
Symbols — loop_co. 0
SPI_Flash il B o ‘ il T —m— v
Toolbars L
Log ¥ | Status Bar -
Tue Mar 03, 2075 18:76:45 FPUnit b code (BP) slots and 2 literal slots
= Tue Mar 03, 2015 168:16:45: Software resetwas performed |
g. =
& Debug Log | Build x
Open the Statics window NUM =
—= = — — — =

Figure 46 * Values of Source Code Variables

9. Click View > Disassembly to view the values of variables in the source code as shown in
Figure 47.

— o
372 SPI_Flash_sb_MS5_CM3 - IAR Embedded Workbench IDE_0 . l ‘ —— - [E=REEn
FEile Edit Project Debug Disassembly J-Link Tools Window Helg y
D@k Mesages v e e P AR URS | D
= ‘ [ ‘ Workspace
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Figure 47 » Assembly Level Instructions
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10. When debug process is finished, terminate execution of the code by choosing Debug > Stop
Debugging as shown in Figure 48.

/5 1AR Embedded Workbench IDE

File Edit WView Project Debug  Disassembly  J-link Tools
NS U@ & § =@
e X

|5I:|:|p Debugginql

Y
=

Figure 48 * IAR Workbench - Stop Debugging Option

11. The Step Level Debugging can be performed before running the application using Go. These can
be accessed from the Debug menu or on the IAR workbench as shown in Figure 49:

& SPLFlash_sb_MSS_CM3 - IAR Embedded Workbench IDE

File Edit View Project Debug Disassembly  J-Link
- IE IR

— H e 4
Z| 82 LEEZ(IR

Figure 49 * 1AR Workbench - Step Level Debugging

|r |

— Source code can be single-stepped by selecting from the Debug menu Debug > Step Into,
Debug > Step Out, Debug > Step Over or selecting the respective options from the IAR
workbench as shown.in-Figure 49. Observe the changes in the source code window and
Disassembly view.Performing a Step Over provides an option for stepping over functions.
The entire function is run butthere is no need to single-step through each instruction
contained in the function.

12. Close Debug Perspective by selecting Close Perspective from the Window menu.
13. Close IAR‘Embedded Workbench using File > Exit.
14. Close the HyperTerminal using File > Exit.

Conclusion

This_tutorial provides steps to create a Libero SoC design using the System Builder. It describes the
procedure to build, debug, and run an IAR Embedded Workbench application. It also provides a simple
design to access the SPI flash.
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Appendix A - Board Setup for Programming the
Tutorial

Figure 1 shows the board setup for programming the tutorial on the SmartFusion2 Security Evaluation Kit
board.

v i 35
PASS FALL i

Reset
Switch SW6

USB Mini ' - 5
Connector =g

P

C

Figure 1 » SmartFusion2 Security Evaluation Kit Setup
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Appendix B - Board Setup for Running the IAR
Tutorial

Figure 1 shows the board setup for running and debugging the tutorial on the SmartFusion2 Security
Evaluation Kit board.

DC Jack to
Connect 12V -
Adapter

USB Mini-B
Connector

SW6 to Reset

Figure 1 » SmartFusion2 Security Evaluation Kit J-Link Programmer Connection
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Appendix C - SmartFusion2 Security Evaluation Kit
Board Jumper Locations

Figure 1 shows the jumper locations on the SmartFusion2 Security Evaluation Kit board.
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. D]:| - : ]J: S ::

Y1

ERDES_REFCLKIP (

IR

Figure 1 » SmartFusion2 Security Evaluation Kit Board Jumper Locations

Notes:
* Jumpers highlighted'inred (J22, J23, J24, J8, and J3) are set by default.
» The location of the jumpers in Figure 1 are searchable.

Revision 3 44



& Microsemi
List of Changes

The following table shows important changes made in this document for each revision.

Revision* Changes Page
Revision 3 Updated the document for Libero SoC v11.5 software release (SAR 64188). N/A

(March 2015)

Revision 2 Updated the document for Libero SoC v11.4 software release (SAR 61628). N/A

(November 2014)

Revision 1 Initial release. N/A

(April 2014)

Note:

*The revision number is located in the part number after the hyphen. The part number isdisplayed at the boftom
of the last page of the document. The digits following the slash indicate the month and year of publication.
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Product Support

Microsemi SoC Products Group backs its products with various support services, including Customer
Service, Customer Technical Support Center, a website, electronic mail, and worldwide sales offices.
This appendix contains information about contacting Microsemi SoC Products Group and using these
support services.

Customer Service

Contact Customer Service for non-technical product support, such as product pricing, product upgrades,
update information, order status, and authorization.

From North America, call 800.262.1060

From the rest of the world, call 650.318.4460

Fax, from anywhere in the world, 408.643.6913

Customer Technical Support Center

Microsemi SoC Products Group staffs its Customer Technical Support Center with highly skilled
engineers who can help answer your hardware, software, and design questions about Microsemi SoC
Products. The Customer Technical Support Center spends a great deal of time creating application
notes, answers to common design cycle questions, documentation of known issues, and various FAQs.
So, before you contact us, please visit our online resources. lt'is very likely we have already answered
your questions.

Technical Support

For Microsemi SoC Products Support, visit
http://www.microsemi.com/products/ipga-soc/designsupport/fpga-soc-support

Website

You can browse a variety of technical and non-technical information on the SoC home page, at
www.microsemi.com/soc.

Contacting the Customer Technical Support Center

Highly skilled engineers staff the Technical Support Center. The Technical Support Center can be
contacted by email or through the Microsemi SoC Products Group website.

Email

You can communicate your technical questions to our email address and receive answers back by email,
fax, or phone. Also, if you have design problems, you can email your design files to receive assistance.
We constantly monitor the email account throughout the day. When sending your request to us, please
be sure to include your full name, company name, and your contact information for efficient processing of
your request.

The technical support email address is soc_tech@microsemi.com.
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Product Support

My Cases

Microsemi SoC Products Group customers may submit and track technical cases online by going to My
Cases.

Outside the U.S.

Customers needing assistance outside the US time zones can either contact technical support via email
(soc_tech@microsemi.com) or contact a local sales office. Sales office listings can be found at
www.microsemi.com/soc/company/contact/default.aspx.

ITAR Technical Support

For technical support on RH and RT FPGAs that are regulated by International Traffic .in Arms
Regulations (ITAR), contact us via soc_tech_itar@microsemi.com. Alternatively, within My Cases, select
Yes in the ITAR drop-down list. For a complete list of ITAR-regulated Microsemi-FPGAs, visit the ITAR
web page.

48

Revision 3


http://www.microsemi.com/soc/mycases/
http://www.microsemi.com/soc/mycases/
mailto:tech@microsemi.com
http://www.microsemi.com/soc/company/contact/default.aspx
http://www.microsemi.com/soc/company/contact/default.aspx
http://www.microsemi.com/soc/company/contact/default.aspx#itartechsupport
mailto:soc_tech_itar@microsemi.com
http://www.microsemi.com/soc/mycases/
http://www.microsemi.com/soc/ITAR/

Microsemi.

Microsemi Corporate Headquarters
One Enterprise, Aliso Viejo,
CA 92656 USA

Within the USA: +1 (800) 713-4113
Outside the USA: +1 (949) 380-6100
Sales: +1 (949) 380-6136

Fax: +1 (949) 215-4996

E-mail: sales.support@microsemi.com

© 2015 Microsemi Corporation. All
rights reserved. Microsemi and the
Microsemi logo are trademarks of
Microsemi  Corporation. All  other
trademarks and service marks are the
property of their respective owners.

Microsemi Corporation (Nasdaq: MSCC) offers a comprehensive portfolio of semiconductor
and system solutions for communications, defense & security, aerospace and industrial
markets. Products include high-performance and radiation-hardened analog mixed-signal
integrated circuits, FPGAs, SoCs and ASICs; power management products; timing and
synchronization devices and precise time solutions, setting the world’s standard for time; voice
processing devices; RF solutions; discrete components; security technologies and scalable
anti-tamper products; Power-over-Ethernet ICs and midspans; as well as custom design
capabilities and services. Microsemi is headquartered in Aliso Viejo, Calif., and has
approximately 3,400 employees globally. Learn more at www.microsemi.com.

Microsemi makes no warranty, representation, or guarantee regarding the information contained herein or
the suitability of its products and services for any particular purpose, nor does Microsemi assume any
liability whatsoever arising out of the application or use of any product or circuit. The products sold
hereunder and any other products sold by Microsemi have been subject to limited testing and should not
be used in conjunction with mission-critical equipment or applications. Any performance specifications are
believed to be reliable but are not verified, and Buyer must conduct and complete all performance and
other testing of the products, alone and together with, or installed in, any end-products. Buyer shall not rely
on any data and performance specifications or parameters provided by Microsemi. It is the Buyer's
responsibility to independently determine suitability of any products and to test and verify the same. The
information provided by Microsemi hereunder is provided "as is, where is" and with all faults, and the entire
risk associated with such information is entirely with the Buyer. Microsemi does not grant, explicitly or
implicitly, to any party any patent rights, licenses, or any other IP rights, whether with regard to such
information itself or anything described by such information. Information provided in this document is
proprietary to Microsemi, and Microsemi reserves the right to make any changes to the information in this
document or to any products and services at any time without notice.
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