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Introduction

Libero SoC includes the ModelSim ME simulator, which is specially designed for integration with 
Microsemi’s Libero SoC. No special user action is required to use this version of ModelSim in Libero 
SoC.

To take advantage of the more advanced features available only with ModelSim SE/PE or QuestaSim, 
consider plugging ModelSim SE/PE or QuestaSim into the Libero SoC environment. These advanced 
simulation features, which may require special licensed features from Mentor Graphics, include:

• Faster simulation speed

• Mixed-Language simulation

• Advanced Optimizations

• Performance Analyzer

• C Debugger 

• Dataflow Window

• Saving and Comparing Simulation Waveform

• Code Coverage

• Standalone Viewer

• System C

• Assertions (PSL)

Refer to the Reference Manual (ModelSim or QuestaSim > Help > SE Documentation > PDF Bookcase) 
for details about the advanced feature set.

For a comparison of the different feature sets available with different ModelSim editions, refer to:

http://www.mentor.com/products/fv/modelsim/upload/ModelSimDE_Compare.pdf

This User Guide describes the steps required prior to using ModelSim SE/PE or QuestaSim in the Libero 
SoC environment to run simulation on your design targeted for Microsemi SmartFusion2, IGLOO2, 
RTG4, and PolarFire devices.



1 – ModelSim SE/PE and QuestaSim in the Libero 
SoC Environment

The steps to set up ModelSim SE/PE or QuestaSim in the Libero SoC environment are:

• Set up the license to use the ModelSim SE/PE Edition or QuestaSim.

• Compile the Microsemi simulation libraries with ModelSim SE/PE or QuestaSim.

• Create the tool profile in Libero SoC to use ModelSim SE/PE or QuestaSim.

• Edit the path to the simulation library location.

• Create a user-defined run.do file to drive simulation.

ModelSim SE/PE and QuestaSim License Setup
The Libero SoC license from Microsemi does not work with ModelSim PE/SE or QuestaSim. To use 
ModelSim SE/PE or QuestaSim in the Libero SoC environment, configure the licensing for ModelSim PE/
SE or QuestaSim with a license from Mentor Graphics. For details, refer to the ModelSim SE/PE 
Installation and Licensing Guide from Mentor Graphics:

http://vk.drlnet.dyndns.org/help/modelsim/pdfdocs/modelsim_se_install.pdf

Simulation Libraries Compiled with ModelSim SE/PE and 
QuestaSim

To run ModelSim SE/PE or QuestaSim in the Libero SoC environment, Microsemi recommends using the 
Microsemi simulation libraries compiled with ModelSim SE/PE or QuestaSim to take advantage of the 
faster simulation speed. The factory pre-compiled simulation libraries shipped with the Libero SoC 
software are compiled with ModelSim ME or QuestaSim. These pre-compiled libraries work with 
ModelSim SE/PE or QuestaSim, but the simulation speed will be slower when compared to the native 
ModelSim SE/PE or QuestaSim simulation libraries.

Simulation Libraries on the Web
Microsemi has pre-compiled the SmartFusion2/IGLOO2/RTG4/PolarFire libraries with specific ModelSim 
SE/PE or QuestaSim versions and other third-party simulators. They are available for download from 
http://www.microsemi.com/products/fpga-soc/design-resources/design-software/libero-soc/mentor-
compiled-simulation-libraries. If a specific ModelSim SE/PE or QuestaSim version on a specific platform 
(Windows or Linux) is desired and there are no pre-compiled libraries for that version/platform available 
on the web for download, contact Microsemi Technical Support at soc_tech@microsemi.com to request 
the compiled libraries for the specific ModelSim SE/PE or QuestaSim versions and the specific platform.

Compiling Simulation Libraries on Your Own
To compile the simulation libraries independently for use with a specific ModelSim SE/PE or QuestaSim 
version, the Verilog source for IGLOO2 and SmartFusion2 is installed with Libero SoC and located in: 

• <LiberoSoC_installation>/Designer/lib/vlog/smartfusion2.v. (Windows)

• <LiberoSoC_installation>/lib/vlog/smartfusion2.v. (Linux)

Use this source Verilog file to compile the simulation library for both SmartFusion2 and IGLOO2. This file 
exists in the Libero SoC installed location regardless of whether or not ModelSim ME or QuestaSim 
simulator is installed with Libero SoC.

Note: IGLOO2 and SmartFusion2 share the same simulation source and only Verilog is available. For 
IGLOO2, use smartfusion2.v file as source. There is no VHDL simulation source for IGLOO2 and 
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SmartFusion2. This is not a problem, because ModelSim SE/PE and QuestaSim support mixed 
language simulation. 

To compile the simulation libraries independently for use with a specific ModelSim SE/PE or QuestaSim 
version, the Verilog source for RTG4 is installed with Libero SoC and located in: 

• <LiberoSoC_installation>/Designer/lib/vlog/rtg4.v. (Windows)

• <LiberoSoC_installation>/lib/vlog/rtg4.v. (Linux)

To compile the simulation libraries independently for use with a specific ModelSim SE/PE or QuestaSim 
version, the Verilog source for PolarFire is installed with Libero SoC and located in: 

• <LiberoSoC_installation>/Designer/lib/vlog/polarfire.v. (Windows)

• <LiberoSoC_installation>/lib/vlog/polarfire.v. (Linux)

Note: The smartfusion2.v, rtg4.v, and polarfire.v Verilog sources include simulation models for the library 
cells and logic blocks in the FPGA fabric. It does not include simulation models for advanced blocks 
such as MSS, DDR, SerDes, XCVR, and PCIe. If the design for simulation contains advanced 
blocks, use the pre-compiled libraries shipped with Libero SoC which supports MSS, FDDR and 
SerDes simulation. In addition, simulation libraries compiled with ModelSim SE are available for 
download from the Microsemi website http://www.microsemi.com/products/fpga-soc/design-
resources/design-software/libero-soc/mentor-compiled-simulation-libraries. These Modelsim SE/
PE and QuestaSim based pre-compiled libraries support advanced blocks such as DDR, MSS, 
XCVR, SerDes, and PCie simulation, and they run faster than the Modelsim ME pre-compiled 
libraries shipped with Libero SoC. If the SE/PE_based pre-compiled simulation library available for 
download from the Microsemi website is not the desired version, contact Microsemi Technical 
Support at soc_tech@microsemi.com to request the version-specific simulation library. 

Simulation Library Compilation Steps 
Follow these steps to compile your own simulation libraries for SmartFusion2 and IGLOO2:

1. Create the “Microsemi” folder/directory under <ModelSim or QuestaSim_installed_location>/

mkdir <ModelSim or QuestaSim_install_location>/Microsemi

2. Invoke ModelSim SE/PE or QuestaSim Graphical Interface

Start > ModelSim SE/PE or QuestaSim <version>

3. In the Transcript window at the ModelSim or QuestaSim command prompt, change to the
Microsemi folder

> cd <ModelSim or QuestaSim_install_location>/Microsemi

4. Create the folders to store the compiled libraries

ModelSim or QuestaSim> vlib smartfusion2
ModelSim or QuestaSim> vlib igloo2 
ModelSim or QuestaSim> vlib rtg4
ModelSim or QuestaSim> vlib polarfire

5. Map the simulation library location to the simulation library name

vmap smartfusion2 <ModelSim_Install_Path>/Microsemi/smartfusion2 
vmap igloo2 <ModelSim or QuestaSim_Install_Path>/Microsemi/igloo2 
vmap rtg4 <ModelSim or QuestaSim_Install_Path>/Microsemi/rtg4 
vmap polarfire <ModelSim or QuestaSim_Install_Path>/Microsemi/polarfire 

6. Compile the simulation libraries from the Verilog source

vlog -work smartfusion2 "<Libero_Install_Path>/Designer/lib/vlog/
smartfusion2.v” 
vlog -work igloo2 "<Libero_Install_Path>/Designer/lib/vlog/smartfusion2.v”
vlog -work rtg4 "<Libero_Install_Path>/Designer/lib/vlog/rtg4.v”
vlog -work polarfire "<Libero_Install_Path>/Designer/lib/vlog/polarfire.v”

Note: For IGLOO2 devices, use smartfusion2.v as the source. 

The library compilation steps may be put in a script file “compile_lib.do” as follows:

mkdir “D:/<ModelSim or QuestaSim_install_location>/Microsemi”
cd "D:/"<ModelSim or QuestaSim_install_location>/Microsemi”
vlib smartfusion2
vlib igloo2
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vlib rtg4
vlib polarfire
vmap smartfusion2 smartfusion2
vmap igloo2 igloo2
vmap rtg4 rtg4
vmap polarfire polarfire
vlog  -work smartfusion2 "D:/<Libero_Install_Path>/Designer/lib/vlog/
smartfusion2.v"
vlog  -work igloo2 "D:/<Libero_Install_Path>/Designer/lib/vlog/smartfusion2.v 
vlog  -work rtg4 "D:/<Libero_Install_Path>/Designer/lib/vlog/rtg4.v"
vlog  -work polarfire "D:/<Libero_Install_Path>/Designer/lib/vlog/polarfire.v 

Before running any design simulations, execute the script once at the ModelSim or QuestaSim prompt to 
compile the simulation libraries as follows:

> do compile_lib.do

Simulator Version and Simulator Library Version
There is a compatibility dependency between the simulation library version and the ModelSim or 
QuestaSim simulator version.The compiled simulation library version needs to be the same version as 
the ModelSim simulator. Whenever the ModelSim or QuestaSim simulator version differs from the library 
version by a number instead of only a letter, refresh the simulation libraries. For example, ModelSim 
v10.3a and v10.3c can use the same compiled libraries. However, moving to ModelSim v10.4c requires a 
refresh of the simulation libraries. ModelSim may give an error if the simulation library is not refreshed:

This version of the compiler is incompatible with the library file .....

To refresh the simulation libraries, at the ModelSim or QuestaSim prompt, run the vlog command with the 
-refresh option as follows:

> vlog -refresh -work smartfusion2

> vlog -refresh -work igloo2

> vlog -refresh -work rtg4

> vlog -refresh -work polarfire

Note: This command requires write permission to the simulation library location. The refresh fails if 
there is no write permission to the simulation library location.

To refresh the library alternatively, go to the Library tab in ModelSim or QuestaSim, right-click the library 
to be refreshed and select Refresh. 

Figure 1-1 • Simulation Library Refreshed
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Note: Refreshing the simulation libraries is not guaranteed to always work, depending on libraries and
simulators used. If it does not work, you may need to request the library or libraries. 

For example, 10.3a and 10.3c libraries are compatible, but 10.3c libraries may not work in a 10.4a
simulator.

Setting Libero SoC Tool Profile
By default, the Libero SoC tool profile (Project > Tool Profile > Simulation) is set up to invoke 
ModelSim ME, which is integrated into Libero SoC. To use ModelSim SE/PE Edition or QuestaSim from 
Mentor Graphics, set up the simulation tool profile so that Libero SoC invokes ModelSim SE/PE or 
QuestaSim instead of the default ModelSim ME.

Follow these steps to set up the simulation tool profile for ModelSim SE/PE or QuestaSim:

1. Invoke the Tool Profile Setup dialog box (Project > Tool Profile).

2. Click Simulation.

3. Click the Add Profile (green) icon.The Add Profile dialog box appears.

4. Enter ModelSim_SE/PE <version> or QuestaSim <version> in the Name field.

5. Select ModelSim or QuestaSim from the pull-down list in the Tool Integration field.

Figure 1-2 • Tool Profile 
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6. Click Browse to navigate to the location of the modelsim.exe or questasim.exe.

7. Click Open to accept the modelsim.exe or questasim.exe path.

8. Click OK to exit the Add Profile dialog box.

Setting Simulation Library Path to Non-Default Location 
Libero SoC sets the simulation library by default to <LiberoSoC_installation>/Designer/lib/modelsim/
precompiled/<vlog | vhdl>/SmartFusion2 for both SmartFusion2 and IGLOO2 projects. This is the default 
location of the pre-compiled simulation library shipped with Libero SoC. To use the simulation library 
compiled independently with Modelsim SE/PE or QuestaSim, change the simulation library path from the 
default location to the location of the libraries independently compiled. If the simulation library is 
downloaded or requested from Microsemi Technical Support, change the library location to that of the 
downloaded/requested library.

To change the simulation library location:

1. From the Libero SoC Project menu, click Project Settings and then SmartFusion2 or IGLOO2 
under Simulation Libraries (Project > Project Settings > Simulation Libraries > 
SmartFusion2/IGLOO2).

2. Click the browse/navigation button to navigate to the location of the simulation libraries to use. 

Figure 1-3 • Add Tool Profile 
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3. Select the location and then click Save. The library path field now appears in the new library path.

User-defined DO file
By default, Libero SoC generates a run.do file and passes it to ModelSim or QuestaSim to run simulation. 
This file will be generated and overwritten every time ModelSim or QuestaSim is invoked from Libero 
SoC.

ModelSim SE/PE and QuestaSim offer advanced features such as dataflow window and C Debugger, 
which are not available in ModelSim ME and therefore not included in vsim commands in the default 
run.do file. To take advantage of these advanced features, create a user-defined Do file and put the 
command switches for these advanced features in the user-defined Do file. Save the user-defined Do file 
in the Simulation folder of the Libero SoC project. Unlike the default run.do file, this user-defined Do file is 
not overwritten every time ModelSim or QuestaSim is invoked from Libero SoC.

Creating the User-Defined Do File
1. Invoke ModelSim SE/PE or QuestaSim from Libero SoC (Design Flow Window > Verify Post-

Synthesis Implementation > Double-click Simulate). Libero SoC creates the run.do file and 
invokes ModelSim SE/PE or QuestaSim. 

2. Exit ModelSim SE/PE or QuestaSim simulation.

3. Click the Files tab in Libero SoC.

4. Expand the Simulation folder in the Files tab.

5. Double-click the run.do file to open it in the Libero SoC Editor.

6. Edit the run.do file. Include vsim advanced command switches such as -postsimdataflow or 
debugdb:

vsim -postsimdataflow -debugdb=<db_pathname> -wlf <db_pathname>
add log -r /*

7. Save the file with a different name (for example, my_run.do).

Figure 1-4 • Simulation Library Path 
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Running ModelSim SE/PE or QuestaSim with the User-defined Do 
File

1. From Libero SoC Project menu, click Project Settings and click DO file under Simulations 
(Project > Project Settings > Simulations Options > DO file).

2. Uncheck the “use automatic DO file” option.

3. Click the browse button to navigate to the /<Proj_location>/Simulation/myrun.do file. Select the 
file and click Open.

4. The user-defined “my_run.do” file path appears in the User-defined Do File field.

5. Click Save to exit. 

The next time ModelSim SE/PE or QuestaSim is invoked from Libero SoC, the file “my_run.do” is 
executed to run simulation.

ModelSim SE/PE or QuestaSim Simulation with Libero SoC 
Factory Pre-Compiled Libraries

The pre-compiled simulation libraries shipped with Libero SoC are factory-compiled with Modelsim ME. 
They work with Modelsim SE/PE and QuestaSim in the Libero SoC environment. However, with the pre-
compiled libraries, there is no speedup in simulation runtime, which is available only with the native 
ModelSim SE/PE and QuestaSim simulation libraries.

Take these steps before running ModelSim SE/PE or QuestaSim with the factory pre-compiled simulation 
libraries in Libero SoC:

1. Set up the licensing to run ModelSim SE/PE or QuestaSim with a license from Mentor Graphics.

2. Set up the Libero SoC Tool Profile to run ModelSim SE/PE or QuestaSim.

3. Make sure that there is write permission to the location of the factory pre-compiled simulation 
libraries.

4. Use the -novopt option in the vsim command to disable optimization. The Optimization feature is 
enabled by default in ModelSim SE/PE and QuestaSim. To set the vsim -novopt/-vopt options, 
click Project > Project Settings > Vsim Commands and enter “-novopt” or “-vopt” in the 
Additional Options field. This option will be included in the run.do file when Libero SoC generates 
the file for the simulation run.

Figure 1-5 • Project Settings and Simulations Options 
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Alternatively, include this option in the user-defined “my_run.do” to run simulation:

vsim -L SmartFusion2 -L postsynth  -t 1fs -novopt postsynth.test

5. Click SmartFusion2, IGLOO2, RTG4, or PolarFire under Simulation Libraries. 

6. Click Restore Default. This will restore the simulation library path to the default location, which is 
where the factory pre-compiled libraries reside.

Note: For the default pre-compiled library to appear, ModelSim ME and the pre-compiled simulation 
libraries must be installed.

Figure 1-6 • Adding vsim -novopt options 

Figure 1-7 • Setting Simulation Library Path Location 
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Summary
Table 1-1 is a matrix of the different combinations of Simulator Editions and Simulation Libraries. The 
advantages and disadvantages of each combination and the user actions are listed for comparison.

Table 1-1 • ModelSim Editions and Simulation Library Matrix

Simulation Libraries 

ModelSim Editions Factory pre-compiled 
with Modelsim ME and 
shipped with Libero 

Simulation library 
downloaded from 
Microsemi website 

User-compiled library 
with ModelSim SE/PE 
or QuestaSim from 
source in Libero 

ModelSim ME
(Default simulator 
shipped with Libero)

Default Libero Simulator. 
No user setup required. 
Supports MSS, FDDR, 
and SerDes 
components. Slower 
simulation speed. No 
advanced simulation 
features.

Incompatible with 
simulation library 
compiled with 
ModelSim SE/PE or 
QuestaSim. 

Incompatible. 

ModelSim SE/PE
QuestaSim

Non-default simulator in 
Libero SoC. Tool profile 
setup needed. Separate 
license direct from 
Mentor Graphics 
required. Supports MSS, 
FDDR, and SerDes 
components in the 
design. Slower 
simulation speed. 
Advanced features of 
ModelSim SE available if 
licensed. Need to run 
with the vsim -novopt 
switch because of 
simulation library 
limitations. 

Non-default simulator 
in Libero SoC. Tool 
profile setup required. 
Simulation library path 
setup required. 
Download from https:/
/www.microsemi.com/
product-directory/
libero-soc/5081-
mentor-compiled-
simulation-libraries 
or request simulation 
library from Microsemi 
Tech Support: 
soc_tech@microsemi.
com
Faster simulation 
speed. Supports 
MSS, FDDR, and 
SerDes components 
in the design. 
Advanced vsim 
command switches 
available if licensed 
from Mentor Graphics.

Non-default simulator 
in Libero SoC. Tool 
profile setup required. 
User compilation of 
simulation library 
required using Verilog 
sources from Libero 
installation.
Need simulation 
library path setup to 
non-default location. 
Faster simulation 
speed. No support for 
MSS, FDDR, and 
SerDes components 
in the design. 
Advanced vsim 
command switches 
available if licensed 
from Mentor Graphics.
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