Creating a Libero Project for Firmware
Catalog Sample Project

Libero SoC v11.4 and SoftConsole Flow Tutorial for
SmartFusion2

& Microsemi


krishnan.subramanian
Sticky Note
Accepted set by krishnan.subramanian


& Microsemi

Creating a Libero Project for Firmware Catalog Sample Project - Libero SoC v11.4 and SoftConsole Flow Tutorial for
SmartFusion2

Table of Contents

Creating a Libero Project for Firmware Catalog Sample Project - Libero SoC v11.4 and SoftConsole Flow

Tutorial for SmartFuSION2 . . . .. .. 3
INtrOdUCHON . . 3
Tutorial Requirements . ... ... e e 4

Associated Project Files . . ... . . e 4

Target Board . . ... ..o e 4
Design OVerVIEW . .. ... 4
Step 1: Downloading SoftConsole Project from Firmware Catalog . ........... ... ... .0 .. ... .. .0 ... 5
Step 2: Creating a Libero SOC Project . . . ... .. T e 6

Launching Libero SoC . . . . ... 6

Configuring and Generating Firmware . .......... ... .. . . . il 14
Step 3: Generating the Program File . ... ... .. .. . 16
Step 4: Programming the SmartFusion2 Board Using FlashPro .. ... ...« o o 20
Step 5: Building the Software Application using SoftConsole . ........ .. . . .. . .. . o . . . . . 21
CONCIUSION . . Lo e e 34
Appendix 1: Jumper Locations . . . . ... ... e 35
Appendix 2: Board Setup for Running the Tutorial . ........ .. .. .0 . .. . . . . 36
Appendix 3: Readme File . . ... ... .. 37
Appendix4: main.C File ... ... .. . 38

A Listof Changes . ... -43

B Product SUPPOIt . . .o e -44
CUStOmMEr SeIVICE . . ..o e e 44
Customer Technical Support Center . .. . @ 44
Technical SUPPOIt . . ... e 44
WebSite . . 44
Contacting the Customer Technical Support Center . ... ... ... .. . . e 44

Bl . o e 44
MY CaSES . .ottt i e e e e e e 45
Outside the U.S. . ... 45
ITAR Technical SUPPOI . . . . i o e e e e 45

Revision 2 2



& Microsemi

Creating a Libero Project for Firmware Catalog
Sample Project - Libero SoC v11.4 and SoftConsole
Flow Tutorial for SmartFusion2

Introduction

Libero® System-on-Chip (SoC) Firmware catalog shows a list of available firmware cores. Sample
projects for each firmware core can be generated from Firmware catalog. A sample project is an example
of how the firmware core can be integrated in a project. This sample project contains firmware. project
using SoftConsole, IAR workbench, and Keil tools. But a sample project does not have a Libero project
for that generated firmware project. Each sample project folder contains a.Readme. text file which gives
an overview of the design and hardware requirements. Using this information, the'Libero SoC project can
be generated.

This tutorial describes downloading the SoftConsole sample project-from Firmware catalog and creating
a Libero SoC hardware design for the downloaded sample project. This. tutorial provides an example
design for System Services.

Upon completion of this tutorial, you will be familiar with the following:
» Downloading SoftConsole sample project from/Firmware catalog
* Creating a Libero SoC project
» Generating the programming file
* Opening the project in SoftConsole
* Creating and launching a debug/session
* Running the System Services application
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Tutorial Requirements

Table 1+ Reference Design Requirements and Details

Reference Design Requirements and Details

Description

Hardware Requirements

SmartFusion®2 system-on-chip (SoC) field
programmable gate array (FPGA) Evaluation Kit

* FlashPro4 programmer
* USB A to Mini-B cable
e 12V Adapter

Rev C or later

Host PC or Laptop

Any Windows 64-Bit Operating System

Software Requirements

Libero SoC vi1.4
SoftConsole v3.4'SPI
FlashPro programming software vil.4

Host PC Drivers

USB to UART drivers

Any one of the following serial terminal emulation
programs:

e HyperTerminal
e TeraTerm
« PuTTY

Associated Project Files

The design files for this tutorial can be downloaded from the Microsemi® website:
http://soc.microsemi.com/download/rsc/?2f=SF2_SYS_SERVICES_Tutorial_11p4_DF

The design files include:
» Libero project
*  Programming files
* Readme file

Refer to the readme.. txt file provided in the design files for the complete directory structure.

Target Board

SmartFusion2 Evaluation Kit Board (SF2_EVAL_KIT) Rev C or later.

Design Overview

This tutorial demonstrates the following Device and Design Information services:

« Serial Number Service: Fetches the 128-bit device serial number (DSN) and is set during
manufacturing.

* USERCODE Service: Fetches the programmed 32-bit JTAG USERCODE.
» User Design Version Service: Fetches the 16-bit user design version.

* NVM Data Integrity Check Service: Recalculates and compares cryptographic digests of the
selected NVM component(s)—fabric, eNVMO, and eNVM1—to those previously computed and
saved in NVM.

Note: In this tutorial only fabric digest check is demonstrated.
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System Services Information is displayed on HyperTerminal using MMUART_O interface. For more
information on System Services, refer to SmartFusion2 System Controller User Guide.

Step 1: Downloading SoftConsole Project from Firmware
Catalog

1. Click Start > Programs > Microsemi SoC Libero SoC 11.4 > Firmware Catalog v11.4 >
Firmware Catalog. Right-click on SmartFusion2 MSS System Services Driver and select
Generate Sample Project > Cortex-M3 > SoftConsole > Read Version Information as shown
in Figure 1.

¢ Fimware Catalog 4 TRy = [

| File View Toole Help
i

| View CIER0): selarch by sl el (35/45):
77 T e & T/ .
| display only the latest version of a core i
MName . Version Size (MB) Status -
| .
SmartFusion2 M55 GPIO Driver 20101 063
SmartFusion2 M55 HPDMA Driver 20101 043 I
SmartFusion2 M55 MMUART Driver 20101 0.76
SmartFusion2 M55 PDMA driver 20.102 092
SmartFusion2 M55 5PI Drive 21103 032
Sma :> ' G- e T 1 i23102 333 =
Sma | Generate.. 20101 0.93
¥ : Remove from vault ? 103 21°
N
Doc. 43 Show detaile.. ) &
Smat Open documentation »  lpdf
Smar : ==t —_— —
Gersibe bk e D Cortedd3 » IAR Embedded Workbench  »
DS CrIPTION: STAT T SO T DSORTTOTEr Sl sy ey revwsroe
Keil-MDK 3
This driver requires the SmartFusion2 CMSIS Hardware Abstractidh Laye SoftConsole = FeTre—
ad Version Information
Compatible IP cores: .
ACtel:SmartFusionZMSs:MSS: from version 0,0.500 Random Numbes Generatar Services
Flash Fresze
Cryptography Services !
Zeroization |
Challenge Response
POR Digest Check |
= |
b bew cores are svalable fordownlosd  |Download them now! 5P USB 5P FLASH te

Figure 1+ Downloading Sample Project from Firmware Catalog

Note: Select latest version of SmartFusion2 MSS System Services driver.
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Generate Sample Options window is displayed as shown in Figure 2.

G\ Generate Sample Options lili—hj

Samples folder:  D:\SF2_Sysservices)| E]

Files wil be generated in:
DO:'\5F2_Sysservices\SF2_GMLU_SysServ_read_version

Show generation report

&) [ et

L%

Figure 2+ Generate Sample Options Window

2. Browse to a location to save System Services Read Version Information SoftConsole Project.

3. Open Readme file provided in the SF2_GNU_SysSer_read_version project folder. Readme file
gives target hardware information. Refer to "Appendix 3: Readme File" on-page 37 for the
Readme file.

Step 2: Creating a Libero SoC Project

This step helps you create a SmartFusion2 System Services design using the Libero tool.

Launching Libero SoC

1. Click Start > Programs > Microsemi Libero SoC v11.4 > Libero SoC v11.4, or click the shortcut
on desktop to open the Libero 11.4 Project Manager.
2. Create a new project using one of the following options:

— Select New on the Start Page tab as shown in Figure 3 on page 7.
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— Click Project > New Project from the Libero SoC menu.

r(-‘\ Libero

Project

File Edit View Design Tools Help

4

Recent Projects

Welcome to Libero SoC &

Libero SoC Quickstart V1 1 _4 SOftware |

Libero SoC Interface Description =

C
3
(2\
=

Welcome To Microsemi's Libero SoC

Log

€3 Errors 4, Warnings i Info

Fam: |Die: |Pkg:

%

Figure 3 »

Libero SoC Project Manager

3.

Enter the required information for the project and the device in the New Project dialog box, as
shown in Figure 4 on page 8:

— Project Name: Sysservices

— Project Location: Select an appropriate location (for example, D:/SF2_Sysservices)
— Preferred HDL Type: \erilog

— Family;: SmartFusion2

— Die: M28025T

— Package: 484 FBGA

—. Speed: STD

—  Die Voltage: 1.2

— Operating Conditions: COM
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4. Select Use Design Tool and System Builder in the Design Templates and Creators section of
the New Project window as shown in Figure 4.

[ G\ New Project @1

Project

|| Enable Blodk Creation

MName: Sysservices
Location: D:/5F2_Sysservices
Prefered HOL type: @ Verilog (7)) VHDL
Description:
|
L Device
] Farmily:
pacge:
Speed: -1 -
Caore Voltage (V): 1.2 - Ramp Rate:
Operating Conditions:
Range Best Typical Worst
1 Junction Temperature (C) [COM b I o} 25 a5
Core Voltage (V) [COM "l 1.260 1,200 1.140
|| system Contraller Suspend Mode
PLL Supply Voltage (V):
Design Templates and Creators
Use Design Tool
Core Version

em Builder 1.0
SmartFusion2 Microcontroller Subsystem,  (M55) 1.1.209

Show only latest version

[ 0K ] [ Cancel

Figure 4« Libero New Project Dialog Box

5. Click Edit Tool Profiles to display the Tool Profiles window as shown in Figure 5 on page 9.
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6. In the Tool Profiles window, verify the following tool settings and click OK:
— Software IDE: SoftConsole
— Synthesis: Synplify Pro ME 1-2013.09M-SP1
— Simulation: ModelSim ME 10.2c
— Programming: FlashPro 11.4

[ &3 Tool Profiles D [ |
‘ TDDISSDFM.EEIDE Software IDE profiles

Synthesi
yEnests Active Name Path
Simulation cp Files (x36)\Mi \Saftc |
. = LFrogram Fies | ICrosemi |0’ onsole
I§1IIr'r'ILI|Ll5 . L (2]  SoftConsole v3.4\Edipse\edipse.exe
rogr.ammmg = AR C:'Program Files (x36)\IAR Systems‘\Embedded Workbench
Identify Debugger - 6, 4\common \bin\larldePm. exe

kel Crigeilava\uve, exe

Export Proﬁles...] [ QK ] [ Cancel

A

Figure 5+ Tool Profiles Window

7. Click OK on the New Project window:.

The System Builder window is displayed and enter name for your system as Sysservices and
click OK.

Revision 2 9


krishnan.subramanian
Sticky Note
Accepted set by krishnan.subramanian

krishnan.subramanian
Sticky Note
Accepted set by krishnan.subramanian

krishnan.subramanian
Sticky Note
Accepted set by krishnan.subramanian

krishnan.subramanian
Sticky Note
Accepted set by krishnan.subramanian


& Microsemi

Creating a Libero Project for Firmware Catalog Sample Project - Libero SoC v11.4 and SoftConsole Flow Tutorial for
SmartFusion2

SmartDesign window with Sysservices_0 component is displayed as shown in Figure 6.

r = — —~— - - — — — = Al
(® System Builder - Device Features l = g}

> Device Features > > Peripherals > > Clocks > > Microcontroller > > SECDED > 2 Security > > Interrupts > > Memory Map >
Select the SmartFusion2 features you will be using in your design

Memory
[] M35 External Memory
(@ MDDR
Soft Memory Contraller (SMC)

ﬁ EER S m

SWITZH

[ M55 On-chip Flash Memary { elNyM )
] Fabric External DDR Memory ( FDDR )

High Speed Serial Interfaces

[ SERDESIF_0
[ SERDESIF_1

Microcontroller Options

1
'
1
|
'
'
1
|
'
'
1
|
'
'
i
'
'
'
i
'
'
'
|
1
'
'
|
1
|
'

[T Peripheral DMA 1
|
'
|
1
'
'
|
1
'
'
|
'
1
'
|
'
1
'
|
'
1
'
|
'
1
'
|
'
1
'
L

'
H FAR_COD i g g g
[ Watchdog Timer | B
! o G
555
i L
H ol o
i o
[] Real Time Counter I = i
! =
i i
' ®
: SHE Bk
' ABBS Pl
'
! i Phkss
' i
1 1
' ; i
i | :
o -Elue r E E !
| | i
Ele CCRESOR o i
A e 1
= [ i
H r 478 H
'
L OOt — SO — o I el H
,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,, 1

Figure 6 = SmartDesign Window with Sysservices_0 Component

8. Disable the following peripherals on the System Builder - Peripherals page:
- MMUART_1
— SPI_0and SPL_1
— 12C_0Oand I12C_1
- USB
— Ethernet
— CAN

After disabling the above components, the System Builder - Peripherals page configuration
window. is displayed similar to Figure 7 on page 11.
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(® System Builder - Peripherals - - - [ G S
Device Features » > Peripherals > > Clocks > > Microcontroller > > SECDED > > Security > 2 Interrupts > > Memory Map >
Select the peripherals and masters for each subsystem
Fabric Slave Cores Subsystems
Core Version (@ MSS FIC_0 - MSS Master Subsystem I~
1 CoreAHBLSRAM 20113 I drag and drop here to add to subsystem
2 CoreGPIO 30120 =
ore @ MSS FIC 0 - Fabric Master Subsystem
3 Corel2C 70102
I drag and drop here to add to subsystem
4 CorePWM 41106
5 CoreSPl 30156 ® MSS Perpherals
o p—— 11100 Confiqure Enable Name I
7 CoreUARTapb 522 MVELARED.
8 Fabric AMBA Slave 0.0.102 * RMMUARTEL

Fabric Master Cores

Core Version
Fabric AMBA Master 0.0.102

[ | | | | o | o | A | 43 | |

To move a peripheral from one subsystem to another, drag it ffom its present location and drap it onto the desived susbsystem.
You cannot cag and drop onto MSS Peripherals.

Masters are in bold and blue.

Figure 7+ Enabled and Disabled MSS Peripherals
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9. Double-click MMUART_1 and configure it as shown in Figure 8.
— Select Fabric as main connection for TXD and RXD Full Duplex MSIOs
— Click OK to complete the configuration

r — ™
[l Configuring MM_UART_1_0 (SF2UMSS_UART .. o] o[ s S
i

Configuration

Transmit-Receive

Duplex Mode

Transmission Mode

Full Duplex -

Asynchronous -

Connect To Fabric
Modem
Use Modem [
ConnectTo |10

Help (a4 ! [ Cancel

L

Figure 8+ MMUART_1 Configurator Window

10. Go to System Builder~ Clocks as shown in Figure 9 on page 13:

— Select System Clock frequency as 50 MHz and clock source as On-chip 25/50 MHz RC
Oscillator

— Select M3_CLK as 50 MHz

— Select’/APB_0_CLK and APB_1_CLK frequency as M3_CLK/1

— Leave the rest as default

— Click NEXT on System Builder to complete the clock configuration

12 Revision 2


krishnan.subramanian
Sticky Note
Accepted set by krishnan.subramanian

krishnan.subramanian
Sticky Note
Accepted set by krishnan.subramanian

krishnan.subramanian
Sticky Note
Accepted set by krishnan.subramanian

krishnan.subramanian
Sticky Note
Accepted set by krishnan.subramanian

krishnan.subramanian
Sticky Note
Accepted set by krishnan.subramanian


& Microsemi

Creating a Libero Project for Firmware Catalog Sample Project - Libero SoC v11.4 and SoftConsole Flow Tutorial for

SmartFusion2
@—SYSmmBuﬁderIbd?ﬁ —— — T T o v p——

> Device Features » > Peripherals > > Clocks > > Microcontroller » > SECDED > 2 Security > 2> Interrupts  » > Memory Map >

Configure clock requirements

Clock | FabricccC | Chip Osallators 1

System Clock
iz
[on-chip 25750 MHz RC Osllator -

Cortex-M3 and M55 Main Clock

M3 €K - 50.00 Mz 50.000

MDDR Clodks I
MDDR_CLK =M3OK® |1 -]

DDR/SMC_FIC_CLK = MDDR_CLK / [1 -]

M55 APB_0/1 Clocks

APB_D_CLK =M3_CLK [ 50,000
APE_1_CLK. =M3_CLK / 50.000

Fabric Interface Clocks

FIC_0_CLK =M3ck/ 1 -|
! [] aHBLite Bypass Mode
!
| FIC_1_ClK =M3ck/ 1 -|

[] aHBLite Bypass Mode

|
| Fabric DDR Clocks
i FDDR_SUBSYSTEM_CLK = FODR_CLK / |1 -]

) e

Figure 9+ MSS Clock Conditioning Circuitry Configurator
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11. Select File > Save to save Sysservices_0. Select the Sysservices tab on the Smart Design
canvas, as shown in Figure 10.

@ Libero - DASF2 S

-

e e S ———

Project _File

NEle~ ol &
Design Flow

Edt View Design Tools

Sysservices_top

Tool
V 4 b GeateDesign

& System Builder
VA ConfigureMss

B2 Creste SmartDesign

Create HDL

i Create SmartDesign Testbench

Creste HDL Testbench

PR

Synthestzed Design
D
4 =2 YO Consraints
@ consraintio\ysservices topi.pde
4 O Timing Constrints
8 synthesisSyssevice top_sdesde
i Floorplan Constrints
A < b Implement Design
L Synthesize
4} Verify PostSynthesis Implementation
 Simuiste
A 5o Compie
201 Configure Flash Freeze
& O PlceandRoute
4 ) Edit Constaints
g

SmartDesign  Help.

8 x

| vesonrin | I

[ cotiog [ Fies | |L¢

Repots_8 % | Esrmerees oo 8 x| srvoe 8% |

BeEar M 2B QAAMAE ANDO

Sysservices 0

_PINSE!
‘ MMUART_1_PADSE

4 DFABRESET N  POWER ON_RESET_NBX
DEVRST_N DEVRST_N MSS_READY DX

| FAB_CCC_PINSE

-@EMMUART_1_RADS ]

Log

Qe iy vamngs @ oo

Reading fite 'sysservices.v.
‘Syeasrices CCE_0_FCCEv.

16 rcoreresecp.v.

“Corereseth. poie_hotreset.v’
“Sysaervices. FABISC.0_0SC 1"
rose.corpa. v
“Syeservices i
12 Syecemvicerys

‘Syemesvicesope
The Sysservices project was cpensd.

@rnro: Upgrading page 'FDDR' o latest version:
@1nso: Sysservices MSS' vas successfully generated.

Ornco: ‘Sysservices’ vas successzully generaced.

©rnco: systen Builder successfully generated 'Sysservices'.

Log [ SearchResits | Cores

*Actel:SqCore:FDDRC:1.1.205"

Open Susten Builder sumary for details

Fom: SmartFusion2 [Die: M2S025T [Phg: 464FBGA [ Veriog

8 x

Figure 10

Updating the Sysservices_0

Configuring and Generating Firmware

1. Click Design > Configure Firmware in Libero SoC to open the DESIGN_FIRMWARE window,
as shown in Figure 11.

@ tbero 0157 e a— LT
Priec Fle £t Vien Deign foos Smanbeign ey N
=2 NC=¥x] ot
beamion B [ o | Toveves o Al 2 . Blcesim e o % s
i 2 0B Bomk B2 QABEAE AND
o ] H
B Contgure regramiming ek f i |
8 oty | Sysservices 0 |
& Update VM Mermory Content f;RB_RESEI'_N POWER_ON_RESET_ ND'X
* DEVRST_N DEVRST_N MSS_READY B X
PO P vt I FAB_COG_PNSE
L B run pROGRAM Acton | B.CCC.GLO X
> Debug Desion H | NIT_PNSE!
A Identity Debug DN ] MMUART_1_PADSEQ--------~ ENMMUART 1_PADS Wl
© SmartDeb§ Desian | i
S o |
£ Expor Bitstream
# Export Programming Job
20 e P oo
0 xponsor
R ] |
| DesonFow | oo errehy | St Frarchy | Catlog | Fis | | L 3
&= —

&e
Reading file coreresetp peie.
Reading file Sysservices FASO:
Resding file osc_co

Feading file 'Sy

Figure 11

Opening DESGIN_FIRMWARE Window
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2. Clear all drivers except CMSIS, MMUART_0, and System Services as shown in Figure 12.

Note: SoftConsole sample project for System Services driver can also be downloaded from
DESIGN_FIRMWARE window. Right-click SmartFusion2_MSS_System_Services_Driver_0.
Select Read Version Information.

® ASF2.S - - e e e — =
Project File Edt View Design Tools SmarDesign Help

DEWaxo el

oesn %[ reots 5 | Dsmencesiop 8% | s 8 | Gossian rmice o x | 5

ey 2 0 & | o

Tool
& Programmer Setngs
) Device VO States During Programming
4> Config ity "
8 Configure User Programming Data
& Confgure Programming Recovery
@ Configue Securty
. Update e\VM Memory Cotent
A < b Program Design
B Contgure itsream
i B Generate Bitstream
i & Run PROGRAM Acton
4 b DebugDesign
T Ldentity Debug Design
SmartDebug Design
4> Handoff Design for Production
#) Export Bitstream
£ bport Programming Job

[Generate T rstonce Nome CoreType Verson ston
@ |GF By snertsonz_ s 0 SmartFusonz_ QSIS [22.101 - [Syservies s

Iy S tusion?_MSS_HPDMA Drver_0 [SmartFusion?_MSS_HPDMA_Driver (20101 [sysservices s

Ly SmartFusion?_MSS_MMUART Drver_0 SmartFusion?_MSS_MMUART_Driver 20,101 |Sysservices MSSMMUART_1

[SH=]

Iy SmartFusion?_MSS_NWM _Driver_O [Smartr VM rives [2.2.100  [Sysservices_Mss

By SmartFusion?2_MSS_Systen_Senvices Driver_0 SmartFuson2_MSS System_Servies Diver 23102 - [Sysservices 15
[SmartFuson2_Mss_Timer Drver 20,101 [sysservices 155

[SH=)

r
&

+2] Export P Report L
+2J Export BSDL
+2] Export 8IS Model
4 > Handoff Design for Firmware Development
@ Configure Fimware Cores
B: Export Firmuare 3

vesonFow | Desprtieadhy” | Stmdks ey | ooy | Fies
oy & x

([Elessages) @ Errors iy Wamings @ o y .

Reading file 'Sysservices.v'.
Feading file 'Sysservices CCC_0_FCCC.v'.
Reading file '

_hotreser.v'.
Reading file 'Sysservices FABOSC_0_OSC.v'.

: *Actel:SgCore:FDDRC:1.1.205"
ysservices MSS' was successfully generated.

yeservices' was successfully generated.

jsten Builder successfully generated 'Sysservices'. Open System Builder summsry for details

wop [ SeadRet | o]

Fam:SmarFuson? D MZ025T [Pigs 49470GA.

Figure 12 + DESIGN_FIRMWARE Window

3. Select Sysservices tab-on the. SmartDesign canvas and click Generate Component as shown
in Figure 13.

© tibero-DAsF2 -  ————— E3-1 ]
Boject Fie Edt View Des
=2 M=%+
DesenFom &x|[ show 8 x | Eoymervces oo 8% | svage & x| EI0Esion FRAIARE 8 X s
Syssrvces o g0 3¢ B 2 P8 QAR E ANDO

Tool

& Programmer Setngs
5 Device O Sate During Programming
mming Options

i i |
e 4D MBRESET N  POWER ON_RESET_NBX
A ¢ aie DEVRST_N DEVRST_N MSS_READY B X
e reBisscom )
Bistream |
v B8 Run PROGRAM Action
4% Debug Desion ] _PNSE!
2 et Debug esign | MMUART_1_PADSEI@- -~ -~~~ EIMMUART_1_PADS
© SmarDebug Design . & |
2 HondottDesonfarPriton
£ Expor Biciitam
£ ExpaiBiogramipng Job
L Export Pin Report
2 EponsoL
-

ocsnrion | Gesin i Siis sy | Carsg | s | |

oo & x

S]vessages ) @ Evors i, Wamings @ Info

services' was successfully generated.
en Builder successfully generated 'Sysservices'. O

Figure 13+ Generate Component
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After successful generation of all the components, the following message is displayed on the log
window, as shown in Figure 13 on page 15.
Info: 'Sysservices' was successfully generated.

Step 3: Generating the Program File

1. Double-click I/O Constraints in the Design Flow window as shown in Figure 14. The 1/O Editor
window is displayed after completing Synthesize and Compile.

h ool 3

© Libero - DASF2S i — e+ ————
ols SmanDesign _Help

8% [ peports g x | & sysserices, _top & X | Startage & X

B0RN¢ Bompr B AAKRAE AND - -

Sysservices 0

4D FAB_RESET N POWER ON RESET NBX

DEVRST N DEVRST_N MSS_READY D X
FAB_CCC PNSEH®

FAB_.CCC GLO X
NT_PNSEQ

MMUART_1_PADSEH@--------~- EHMMUART_1_FPADS P
&

g [ [
Fam: SmartFusion2 |Die: M25025T |Pkg: 484FBGA |Veriog.

Figure 14 » Design Flow Window
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2. Make the pin assignments shown in Table 2. After the pins have been assigned, the 1/0O Editor is

displayed as shown in Figure 15.
Table 2 « Port-to-Pin Mapping
Port Name

Pin Number

MMUART_1_RXD
MMUART_1_TXD

G18

H19

-
+= 1/O Editor - Sysservices_top

P MMUART 1 R

Pin Number :_:_] Locked :_:_]

= E ez
P—— .
File Edit View Tools Help
y y =TS
MO Fw S
Forts | Package Pins | Package Viewer ‘
Port Mame (1|  Direction [¥]  I/O Standard [

Macro Cell :_:_] Bank Name E]

J

Ready

|Fam: SmartFusion2 | Die: M25025T |Pkg: 484 FBGA

2 MMUART_1_TXD Output LVCMOS525 H19 ADLIB:TRIBUFF Bankl
|
o (T 3y |
Log y 8%
Q Errors 4. Warnings o Info

Figure 15+ 1/O Editor

3.
4.
5.

After updating 1/O editor, click Commit and Check.
Close the 1/O editor.

programming file.

Click Generate Bitstream-as.shown in Figure 16 to complete place and route, and generate the

@ uibero- DASF2S
Brject fle fdt View Desgn Tools

e — - —
SmarDesign Help.

ax

Repors, B X | Esrmervess ton 8% |Isiapase 8% |
00RA¢ BeEk M 2° 08 Qc

L= | @ i)

#o° o

B vrty Power

1l Programming Connetivy and nterace

8 Progremmer Sttings

50 Device O Stotes During Pr
"

Sysservices 0
FAB_RESET_N  POWER ON RESET_N
DEVRST_N MSS_READY

FAB_CCC_PINSEl
FAB_CCC_GLO

INIT_PINSE)

MMUART_1_PADSE

2
 Con o
@ ContigureSecury

DEVRST_N
B Update ehVM Meskry Content
P

g Design
© Smanpeti Des

48 Biport Programming Job
+CJ Bxport Pin Report

+] Bxport BSDL

+J Bxport 8IS Model

| vesnrion | Do ey | SR e | catos

Log

Fies

EMMUART_1_PADS

(TR @rors i woronos @ 1rf0

zow global instances.
0 global instances.

F0: Reading User BDC file D:/SF2_
ile' comand succesded.

The Execute Scrip command succeeded.

Running 'sc_shell.exe’ in 64-bic mode

oo [ Swchrents | G|

_top-10.pde.

© error(s) and 0 warning(s)

Figure 16

8 x

Fom: SmariFusion? [Die: M25025T [Phg: 464F8GA. [Veriog

506PM

= B o

Generate Bitstream Data
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6. Click Export Firmware. The Export Firmware dialog box is displayed as shown in Figure 18.

— P Y ——, |\

|3 x | Dormaricm v 5% | suwom a1
=i B0RAE B AL AAMAE AND

Sysservices 0

4 PFABRESETN  POWER_ON_RESETN
DEVRST.N 1SS _READY

INT_PHSE
MMUART_{_PADSE
=

besinFon | Desanierrny Gy [T |
oo S ex
(i) @ s s @ v

" has been loaded successully.

- Foa.veRsion : 1.8
dea.

ed.

g Bitstrean File + Mon Oct 13 14:50:05 2014 (Elapsed time 00:00:26)

| oo et | coms

Figure 17 + Export Firmware

— Select the Create Project check box.
— Select SoftConsole3.4 from the drop down list.

-
1| Export Firmware h\

Location: D:\SF2_Sysservices\Sysservices
Create project |SeftConsele3.4

J

i o=

Figure 18 »+ Creating SoftConsole Project

18 Revision 2


krishnan.subramanian
Sticky Note
Accepted set by krishnan.subramanian

krishnan.subramanian
Sticky Note
Accepted set by krishnan.subramanian

krishnan.subramanian
Sticky Note
Accepted set by krishnan.subramanian

krishnan.subramanian
Sticky Note
Accepted set by krishnan.subramanian

krishnan.subramanian
Sticky Note
Accepted set by krishnan.subramanian


& Microsemi

Creating a Libero Project for Firmware Catalog Sample Project - Libero SoC v11.4 and SoftConsole Flow Tutorial for
SmartFusion2

7. Click OK. The successful firmware generation window is displayed.

5| Information - — @

'\'-I Firmware project was successfully exported to 'D:\sF2_Sysservices\Sysservices',

b - - AE— -

Figure 19 « Firmware Successfully Exported Message

8. Click OK. The log window is displayed as shown in Figure 20.

Leg

[[=]mecenges | € Enors i wamings i) info
Chais Frogrammisg Finished: Mon Aug O 12133130 2014 (Elapssd cise O0:01121)

mmazd succeeded.
mand Fucceeded

D5 _Sysservices\Sysservices\ ficire .

poar poltware development sindlmsament.

Figure 20 + Firmware Log
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Step 4: Programming the SmartFusion2 Board Using
FlashPro

1. Connect the FlashPro4 programmer to the J5 connector of SmartFusion2 SoC FPGA Evaluation
Kit.

2. Connect the jumpers on the SmartFusion2 Evaluation Kit board, as described in Table 3. For
more information on jumper locations, refer to "Appendix 1: Jumper Locations" on page 35.
Caution: While making the jumper connections, the power supply SW7 switch on the board
should be in OFF position.

Table 3 + SmartFusion2 SoC FPGA Evaluation Kit Jumper Settings

Jumper Number Pin (from) Pin (to) Comments

J22, J23, J24, J8, J3 1 2 These are the default jumper settings of the Evaluation Kit
board. Make sure these jumpers are set-accordingly.

3. Connect the power supply to the J6 connector.

4. Switch the power supply switch SW7 to ON position. Referto "Appendix 2: Board Setup for
Running the Tutorial" on page 36 for information on the board setup for running the tutorial.

5. To program the SmarFusion2 device, double-click Run PROGRAM Action in the Design Flow
window as shown in Figure 21.

© Libero - DASF2 - — C———— v - A e
Project File Edit View Design Tools SmartDesign Help

=1 IF%> 10 N2 1l

Desgn Fow 8 x| [ repos_&x | Eyservces top 8% | statroge 8 x| s

S B0RAE BoEme AL, AAHACE AND

Sysservices 0

4 D FAB RESET N POWER_ON_RESET_NBX
DEVRST_N DEVRST_N MSS_READY X

FAB_CCC_PINSE
FAB.CCC GLO DX
NIT_PINSE
MMUART_1_PADSE@- - - -----~- Bl

+2] Export BSDL
+21 Export BIS Model

besonFow T [ otnog | s | | L — -~

Log & x

" has been loaded successfully.

Fom: SmartFusin? [ Die: M25025T [ Pha: 464FBGA | Veriog

A %

509 PM
10/13/2014

Figure 21+ Run Programming Action

20 Revision 2



& Microsemi

Creating a Libero Project for Firmware Catalog Sample Project - Libero SoC v11.4 and SoftConsole Flow Tutorial for

SmartFusion2
Open the standalone SoftConsole IDE.

Step 5: Building the Software Application using SoftConsole
1.

secces- e SoftConsole D Vi Wicrorem SoRCamae e a4 ——— | T— — e
File Edt Source Refactor Nevigate Se ject_Run Window Help
C yisi@d-8-8-0- $-0 Q- B~ s ([@oes)
25 Project Explorer 27 = 0 [) Welcome £ = 0)(3 oui 2\ @Mk | = O
5 % 7| Microsemi SoftConsole IDE v3.4 [fnEulne ot 2k
p
avalabe for Creating '
ing to
oM.
2 Problems 53 Tasks| B Console| [ Properties
0 tems
Descrption Resource Path Location Type
o

Figure 22 « Invoking SoftConsole IDE

2. Right-click on Project Explorer window and choose Import option as shown in Figure 23.
seC/eee - osemi SoftConsole IDE v3.4 TE———— w ™ — o
=g 9 s i@ E-E-G R B0 B . - S v ([T
(2 Project xplorer 53 = 0)(B Welcome X By = 0)|Eouwi 2 Omak| = O

=% 7| Microsemi SoftConsole IDE v3.4 An 2tieknet maievle
‘
New i a
22 Import... Starta Project
4 Expor To begin your work, e > New > ¢ PR
&) Refresh 5 e ncroseifiCooc
P o cutue
A
|| =+ Additional Information
[ —————
21 Problems 55 71 Tasks| & Console| 1 Properties

Figure 23 »

Importing Projects
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3. Select Existing Projects into Workspace under General as shown in Figure 24.

SC C/C++ - Welcome to - SoRConaROE 34 p— ~— S —————— L= =
Fle Edit Source Refactor Navigate Search Project Run Window Help
o] 9 A G O-E-@ B B0 Q  dPiE -8l v g . = Eoer)
(2 Project Explorer £3° = 0)([) Welcome 5 = 082 outii 57 @ Mak | = O
= % 7| Microsemi SoftConsole IDE v3.4 An outfine & not 2valable
SoftConsole i  free software development environment
enablingthe rapid production o C and C++ executables for processors
Creat y
SC Import ST
5 N Select \
5 Starta Project V]
St ek cick Fle » News CPrect Creste new prjects from an rchive file o divectory. =L
Give your project  name, and select atoolchain f you re going to
Then click Finih. Selectan import source:
Add an initial source file with File > New > Source File type filter text
4 (& General
‘Add codeto t, and click the Buld Allicon B eeive Fie
L Brsting Projects into Workspace |
o 5, File System
o bsting Code  ton et " ) Preferences
0u can also import an exsting source tre using
File > Import... & C/Cer
and click b & s
‘General > File System & Run/Debug

> G Team

5 Additional Information
* Release Notes
hitp://www.actel.com/download/software/softconsole
* Online documentation

®

21 Problems 53 Tesks | &l Console| T3 Propertes
0items

Description ’ Resource. path Location  Type

o

0 items selected

&) ® o M A LERE

Figure 24 » Importing Existing Projects

4. Import Window is displayed as shown in Figure 25.

56 C/C++ - Welcome 1 - E —— ~— =lE] =
Fie £dt Source Refactor Novigate Search Project Run Window _Felp

= 9 s i@-@-B-6-4-B- %-0-Q- O @M B X o [@Te=)

(25 Project Explorer 523 = 0B Welcome 2

= B)(% ot X\ @Mak | = O
= % 7| Microsemi SoftConsole IDE v3.4 Ancutine & 0t SvaliblE
SoftConsole i  free software development environment
enabling the rapid production of C and C executables for processors

Creat

P SE==

Import Projects
 Starta Project
To begin your work, click File > Nei> QPiBject Select a directory o search for eiting Eclpse projects.
Give your project a name, and selécta toBlchain ifyou are going to -

‘Then click Finish.

8 Select roof directory: Browse...
‘Add an iniial source filEwith File > New > Source File ) seiect archive ile: e,
‘Add code to t, and click the Bulld Allicon, ey

Select All

@ Casgo o (emtisaten)

R o o e
C

[

) Additional Information
* Release Notes

lwwow.actel.com/download/softwaresoftconsole
*Online decumentation ) Copy projects nto workspace:
Working sets
]Add project to working sets

Select

|| ®

20 Problems 53 Tasks| B Console | (] Propertes
Oitems

Description B Resource. Path Location Type

O items selected

11:54 AM
187201

4

Figure 25+ Import Window
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5. Browse through the Sysservices projects folder and select it as shown in Figure 26.
SC C/C++ - Microsemi SoftConsole IDE v3.4 = 2
=he Pis @@ -F-C-i&-B- -0 AU iOF- B-F-ee-
[ Project Explorer 22\ ==l
SC Import B % ]
Import Projects -
© Select oot dectoy
i [ —
: B ‘ ‘ V e I
{21 Problems | ] Tasks| B Console 52 . [ Properties B-ri-=0
@

Foder:  projects

Make New Folder

I .

—

Figure 26 « Selecting System Services
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6. Click OK.

5C Import [ (=l ﬂ_hj

Import Projects —
Select a directory to search for existing Eclipse projects. .
-
1@ Select root directory:  DASF2_Sysservices)\Sysservices\SoftConsole Sy
(71 Select archive file: Browse. 4 |
Projects:

Sysservices_MS5_CM3_app (D:\SF2_Sysservices\Sysservices\SoftCe Celect Al

Sysservices_M55_CM3_hw_platform (D:\SF2_Sysservices\Sysservic
Deselect All

Refrezh

1| 1 | 3

Copy projects into workspace
Working sets
[ Add project to working sets

Select...

@ Next » Finish | [ Cancel

Figure 27 « Adding the Projects to SoftConsole IDE
7. Click Finish.
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The SoftConsole perspective is displayed as shown in Figure 28.

SmartFusion2

F
SC C/C++ - Welcome to Microsemi SoftConsole IDE v3.4 - Microsemi SoftConsole IDE v3.4

File Edit Source Window Help

L C R BB

Refactor Mavigate Search Project Run

$ s E-e- H-O-QU- B

_I
Li
4
&

[ Project Explorer &2 =0 Welcome 2

= % 7| Microsemi SoftConsole IDE ¥3.4

=5 Sysservices MSS_CM3_app

5 Sysservices MSS_CM3_hw_platform SoftCensole is a free software development environment

- - enabling the rapid production of C and C++ executables for processors
available for use in Microsemi devices, Creating a project inside SoftConsole

lets you write software that is immediately compiled into a usable binary.

(= Start a Project
To begin your werk, click File > New > C Project
I Give your project a name, and select a teolchain if you are going to
be compiling for a target other than the default choice of the Microsemi Cortex-M3,
Then click Finish.

Add an initial source file with File > New > Source File

Add codeto it, and click the Build All icon,

(=) Existing Code
You can also import an existing source tree using
File > Import...
and click
‘General > File System

[Zl Problems | %) Tasks £3

= Console] =] Pruper‘tieq

- =0

0 iterns

=

! Description Resource Path

Location Type

v A

Figure 28 + SoftConsole Workspace

1. Go to the location where the SoftConsole sample Firmware catalog project is saved, as shown in

Figure 29.
-
m L <« Local Disk (D:) » SF2 Sysservices w 5F2_GNU SysSen.r read_version » - ¢, | | Sﬂ:}m" SF2 GNU 5I:sS=rv read_version 0O |
= e - e = w-—  —~ — —
Organize = h,J Open = Burn Mew folder ] @
< At = Marge ’ Date modified Type Size
| P Desktop L CMSIS 3/27/2014 4:16 PM File folder
4. Downloads L J drivers 3/27/2014 416 PM File folder
| =l Recent Places 1 ,y drivers_config 3/27/2014 4:16 PM File folder
. hal 3/27/2014 416 PM File folder
=l Libraries | .cproject 3/24/2014 2:26 PM CPROJECT File 44 KB
@ Documents L | .project 3/24/2014 2:26 PM PROJECT File 3 KB
d‘! Music .| main 3/24/2014 2:26 PM C File 9 KB
Pictures = README 3/24/2014 2:26 PM Text Document 4 KB
gﬂ Subversion |
E Videos -
B main Date modified: 3/24/2014 2:26 PM Date created: 3/27/2014 4:16 PM I
C File Size: 8.64 KB J

Figure 29 « Sample Project main. c File
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2. Copythemain.c file and replace it with the existing main.c file under
Sysservices_MSS_CM3_app project in the SoftConsole workspace. The SoftConsole window
looks as shown in Figure 30.

r ——m . _ . - T T e 5 [ !‘
S8C C/C++ - Sysservices_MSS, app/main.c - Microsemi SoftConsole IDE v3.4 Sy — —u
File Edit Source Refactor Mavigate Search Project Run  Window Help
r~-Fele i Br-&-H-@- -8 $-0-%- @S- [FEE H-FH-wera- i %> Debug ”
[ Project Explorer 32 = O|(E Welcome [ f¢] maine £3 S0z~ =0
25| 2. 0 =
15 Sysservices_MSS_CM3_app 54 Main function. IEHR -
# Binaries “/ %
[l Includes int main() 2 stdioh
Deb
=] E.UQ i B drivers/r
A€ main.c uint8_t serial number[16]: 2 o drivers/r
25 Sysservices_MSS_CM3_hw_platform uint8_t user code[4]; ‘5 @ g greetit
B Archives uinté_t design_version[2]; il e 9-9
il Includes uind_t device certificare[512]; N gfse‘pm
= CMSIS uintd_t status: i?‘s d\sp‘ay,i
= Debug ints t tx_complete; '; Sl
I = drivers -
(= drivers_config M55_SYS_init (M55_SYS_NO_EVENT_HANDLER) ; || J_,: . rdﬂalTO :
isplay_¢
hal
il = MSS_UART_init (gp_my_uart, o % display_t

[0 Sysservices_hw_platform.h
MSS_UART_57600_BAUD,

MSS_UART_DATA 8 BITS | MSS_UART NO PARITY | MSS_UART ONE STOF BIT):

/* Display greeting message. */
display_greeting():

* Device Serial Number (DSN).

status = MSS_SYS_get_serial number(serial numbes);

< m . v « [m] v
[0 Problems 52 . ¥ Tasks| El Console| = Properties =0

0 errors, 2 wamings, 0 others

Description Resource Path Location  Type

/A Warninas (2 items]

Writable Smart Insert 74:81

Figure 30 « SoftConsole Workspace - main.c File

Device certificate service is not demonstrated in this tutorial. It will be available in future releases.
— Comment the lines in main.c file which execute the Device Certificate service

Modified main.c is available in "Appendix 4: main.c File" on page 38.

Figure 31 on/page 27 shows the SoftConsole workspace with modified main.c file
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53 if (M55_SYS _MEM ACCESS ERROR == status)
&0 {

&1 M55_UART polled tx string(gp_my uart,

&2 (gonst, uint8_t*) "Error

[ Sysservices_hw_platform.h

64 }
65 M35_UART polled_tx string(gp_my uart, g_separator);
66 do {

&7 tx_complete = M55 UART tx complete (gp_my uart):
&8 } while (0 == tx complete):

4 m

[ Problems &2 ¥ Tasltsw B Cnnsde] =] Plopel‘lis]

SmartFusion2
p/main.c - Microsemi IDE v
Edit Source Refactor MNavigate Search Project Run Window Help
‘nrEelRiPisalig @8-I B- it -0 o FEN H-FH e [E % Debug ”
|G Project Explorer 52 =8 —— =a(m~ = o
I G~ - - | =
— * Device certificate. o a
= S{SSEN\(E_ME_CME_app . 1B R e
4 Binaries /*status = M55_SYS_get_device certificate(device certificate); H*
)l Includes 48 if (MSS_SYS_SUCCESS == status) 0 sdioh
Deb ’
! (& Debug a3 o drivers/r ||
@ main.c 50 M35_UART polled tx string(gp_my uart, 5 drivers/r N
I =5 Sysservices MSS_CM3_hw_platform 51 (const uint@_t*)"Device certificate: ") &c rectit
I ﬁ, Archives 52 display hex walues(device certificate, sizeof (device certificate)): &c 9-9
- = - - separa
i [l Includes 53 3 5 2’ Ipa
(= CMSIS 54 else isplay_¢
I = Debug 55 f display_t
= drivers 56 MS5_URRT_polled tx_string(gp_my uart, pmy_t
(= drivers_config 57 (const uinté_t+)"Service get device certificate fails :
= hal 58 play_t
display_t

v =g

0 errors, 2 warnings, 0 others

| Description | Resource

(2 items)

s
-

Figure 31+ SoftConsole Workspace - Modified
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3. Right-click Sysservices_MSS_CM3_app in Project Explorer window of SoftConsole project
and select Properties as shown in Figure 32.

[ Project Explorer &3 &Y =0
4 |25 Sysservices MSS_CM3 |
s i{;p‘ Binaries E g
» il Includes GoInto
Deb
=4 E_UQ Open in New Window
> ] main.c
4 25 Sysservices_MSS_CM3 2 Copy CirleC
’ E’ Archives Paste Ctrl+V
> [t Includes
. = CMSIS K Delete Delete
: = Debug Move...
= drivers Rename... F2 I
» = drivers_config
. = hal g2 Import.. !
» [n| Sysservices_hw_pla iy Export...
Build Project |
Clean Project
& Refresh F5

Close Project

Close Unrelated Prajects

Exclude frgimrild...

Build Configurations 2
Make Targets 2
Index 2
Convert,To...

Run As 2
Debug As 2
Profile As 2
Teamn 3
Compare With 2

Restore from Lecal History...

Properties Alt+Enter

Figure 32 » Project Explorer Window of SoftConsole Project
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4.

SmartFusion2

In the Properties window, go to Settings under C/C ++ Build and select GNU C linker as
debug-in-microsemi-smartfusion2-esarm.ld as shown in Figure 33. Click Apply and OK.

-
SC Properties for Sysservices_ MSS_CM3_app

[ESTE==)

type filter text

Resource

Builders

C/C++ Build
Build Variables
Discovery Options
Environment

ool Chain Editor

C/C++ General
Project References
Run/Debug Settings

Settings

- * v

-

Configuration: [Debug [ Active]

'] [ Manage Configurations...

& Tool Settings ‘ . Build Steps |

Build Artifact I Binary Parsers | £ Error Parsers

a B GNU C Compiler
(%2 Preprocessor
2 Symbols
(%2 Directories
(#2 Optimization
(%2 Debugging
(#2 Warnings
(#2 Miscellaneous
a B8 GMU C Linker
(#2 General
(2 Libraries
[ Moo
a (53 GNUT Assembler
(#2 General
5 Memory map generator
a [53 GMNU Intel Hex File Generator
(#2 General
a [ GMU S-Record Generator
(#2 General
a B GNU Listing Generator
(#2 General

Linker flag sI -T../../Sysservices_MS5_CM3_hw_platform/CMSIS/startup_gec/debug-in-microsemi-smartfusion2-esram.|d I

Generate linker memory map

&l

Other options (-Xlinker [option])

Other objects LS SR~ R

"${workspace_loc:/Sysservices_MS5_CM3_hw |
"${waorkspace_loc/Sysservices_MS5_CM3_hw_platform/Debug/CMSIS/startup_gce/newlib_stubs.o}"

5_gcc/startup

< 0] | »

lRa:tﬂre Qefau\rs] l Apply It

@

Lo ]I

Cancel ]

Figure 33 «+ Sysservices_MSS_CM3_app Properties Window
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5. Perform a clean build by selecting Project > Clean. Accept the default settings in the Clean
dialog box and click OK, as shown in Figure 34. SoftConsole project must not have any errors.

s Clean )

Clean will discard all build problems and built states. The next time a build cccurs
the projects will be rebuilt from scratch.

@ iClean all prujects:f (") Clean projects selected below

= Sysservices_MS5_CM3_app
[l = Sysservices_MS5_CM3_hw_platform

Start a build immediately
(@ Build the entire workspace

() Build only the selected projects

[ K Cancel

Figure 34 « Settings for a Clean Build

6. Install the USB driver. For serial terminal communication through the FTDI mini-USB cable, install
the FTDI D2XX driver. Download the drivers and the installation guide from
www.microsemi.com/soc/documents/CDM_2.08.24 WHQL_ Certified.zip

7. Connect the host PC to the J18 connector using the USB min-B cable. The USB to UART bridge
drivers are automatically detected. Verify if the detection is made in the device manager, as
shown.in Figure 35 on page 31.
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r
i Device Manager

File Action View Help

o TEHE %S

4 2 wi-onteddhus s
. 48 Computer USE Serial Part (COM10) Properties

g Disk drives

o e Display adapters

> i DVD/CD-ROM drives

b &'ﬁ Hurnan Irterface Devices
B g JDE ATASATAPT controllers
» -2 Keyboards Devics type: Ferts (COM & LFT)
B B Mice and other pointing devices Manacurer ETOI

General | Pant Settings | Driver | Details |

USE Seral Poet (COM0)

» -l Monitors Lozation Fn 1USH Sesidl t:nnuenarul

o WF Network adapters
.J -..? Parts (COM & LPT) Devies status

T:?' Communications Port (COML)
Y57 ECP Printer Port (LPT1
[ USB Serial Port (COMLO)|
USE Serial Port (COMT)
5" 1USB Serial Port (COMS)
; % USE Serial Port (COMI)
N Processors
B q Sound, video and game controllers
o B8 Systenn devices
b ¥ Universal Serial Bus controllers

This device i warking praperdy,

Figure 35+ Device Manager Window

8. Start the PuTTY session. If the PUTTY program is not available in the computer system, any free
serial terminal emulation program such as HyperTerminal or TeraTerm can be used. Refer to
the Configuring SerialTerminal Emulation Programs Tutorial for configuring the HyperTerminal,

TeraTerm, or PuTTY.

The PuTTY settings are as follows:
— 57,600 baud rate

— .8 data bits

— 1 stop bit

— No parity

— No flow control
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9. Select Debug Configurations from the Run menu of the SoftConsole. The Debug dialog box is
displayed. Double-clicking the Microsemi Cortex-M3 Target displays a window similar to
Figure 36.

SC Debug Configurations

Create, manage, and run configurations

TEX[B3-

Mame: Sysservices MS5_CM3_app Debug

type filter text = .
& Launch G [E] Main %5 Debugger| Bl Commands| & Source| &= Common
aunch Group

SC Microsemi Core8051s Target Project (optional):
SC Microsemi CoreMP7 Target Sysservices_MSS_CM3_app
SC Microsemi Cortex-M1 Target |
4 SC Microsemi Cortex-M3 Target C/C++ Application:
SC Sysservices MS5_CM3_app Debug Debug\Sysservices_M55_CM3_app Search Project...] ’ Browse... ]

[] Application console

Apply Revert
Filter matched 6 of 9 items

@ Debug ] [ Close

=/

Figure 36 « Debug Configurations Window

10. Confirm that the following details appear on the Main tab in the Debug window and click Debug:
— Name: Sysservices_ MSS_ CM3_app Debug
— Project: Sysservices_ MSS_CM3_app
— C/C++ Application: Debug\Sysservices_ MSS_MSS_CM3_app

11. Click Yes when prompted for the Confirm Perspective Switch, as shown in Figure 37. This
displays the debug view mode.

SC Confirm Perspective Switch @

@ This kind of launch is associated with the Debug perspective.

This Debug perspective is designed to support application debugging. It
incerporates views for displaying the debug stack, variables and breakpeoint
managerment.

Do you want to open this perspective now?

[T Remember my decision

Yes | ’ No

Figure 37 + Confirm Perspective Switch
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The SoftConsole Debugger Perspective window is opened, as shown in Figure 38.

MSS_SYS_init (MS5_SYS_NO_EVENT_HANDLER) :

M55_UART_init (gp_my_uart,
M55 _URRT_S57600_BRUD,
WEE TADT NATA 8 RTTR

1 MEa TIADT WA DADTTV 1 wMmas

TIADT AME STAD RTTY -

8 = e ~ - S— —— —— — g‘
SC Debug - Sysservices MSS_CM3_app/miin.c - Microsemi SoftConsole IDE v3.4 C=RRC]
— -
File Edit Source Refactor Mavigate Search Project Run  Window Help
il = | 5 L) R v i@ B~ 5 o o - it Debug | 0 C/C+ >
2| o = g
% Debug 32 * §1 Oe ‘ | i _%El @ 7 = O)|[td= Variables £2 % Braakpointq bl Registers &Mﬂdu\aﬂ =0
SC Sysservices_MS5_CM3_app Debug [Microsemi Cortex-M3 Target] 5 B | 69 gd“ ®x % =7
&% Embedded GDB (8/2/13 11:41 AM) (Suspended) Val o
3me alue
o Thread [1] (Suspended) F
= = serial_number 02000ttt |
= 1 main() d\sf2_sysservices\sysservices\softconsole\sysservices_mss_cm3\sysservices_n bﬂ -
W C\MicrosemilLibero_vi11\SoftConsole\Sourcery-G++\bin\arm-none-eabi-gdb.exe (/2131 || (= usercode O:2000fed
4 | i | b
<[ [ ] 3
[¢] main.c £2 = O 5= Outline &2 =0
55 Main function. - lﬂz a \S @ * =7
56 é ) U stdioh
nt main(} %l drivers/mss_sys_services/mss sys_servic
uints_t serial number[16]: K| & drivers/mss_uart/mss_uarth
2inté t user codel4]: B s
wint® t design version[2]: ®© g _separator: const uint8_t[]
— - 5 S
uint8_t device_certificate[512]; 'H' display_greeting(void] : void
uint® t status; -HE display_hex_values(const uintd_t*, uint3
- @ gp_my_uart : mss_uart_instance_t* cons

@ main():int
display_greeting(void) : void
display_hex_values(const uintd_t*, uint3

4 3 [y T | 3
& Console 32 Z.Ta;kq B Prob\amq Q Executableq i Mamorﬂ N o ‘ 5" Eﬂ‘ s ‘;‘,—“ @I@‘ #B~-rg~-=0
Sysservices_MS5_CM3_app Debug [Microsemi Cortex-M3 Target] C:\Microsemil\Libero_v11.1\SoftConsole\Sourcery-G++\bin\arm-none-eabi~gdb.exe (8/2/1311:41 AM) I

1/SoftConsole/Eclipse//../Sourcer
"C:/Microsemi/Libero_vl

source C:/Microsemi/Libero_
target remote |

ar

—none-eabi-sprite:
0x00000188 in 2? ()

Target reset

-G++/share/gdbifdt /micrdSemi-cértex-m3-target-gdbinit
1/5oftConsole/Eclipse//. ./Sourcery-G++/Bin/ari Bone—c@bi —sprite” flashpro:?cpu=Cortex-M3 "D:/5F2_[7
arm-none-eabi-sprite: Using memory map D:/SF2_ Sysservices/Sysservices/SoftConsolefSydservices MSS CM3/Sysservices M35 CM3 app/Debug/memor

cont
Temporary breakpoint 1, main () at ../main.c:65 Z
‘| - - y=| |
o°® Writable Smart Insert 65:1
Figure 38 » SoftConsole Debugger Perspective
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12. Run the application by clicking Run > Resume. Information on the SmartFusion2 device and the
design, along with a greeting message is displayed on the PuTTY, as shown in Figure 39.

h

P COM7 - PuTTY ESNEENCE)

Figure 39 « PuTTY Window

13. Terminate execution of the code by choosing-Run > Terminate.

14. Close Debug Perspective by selecting Close Perspective from the Window menu.
15. Close SoftConsole using File = Exit.

16. Close the PuTTY. Click Yes when prompted for closing.

Conclusion

This tutorial describes how to.download the SoftConsole Sample project from the Firmware catalog and
how to create a Libero SoC project. It explains the procedure to generate the programming file and to run
the SoftConsole project on the SmartFusion2 Evaluation Kit. A sample project for implementing System
Services features.is created to display the SmartFusion2 device and design information.
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Appendix 1: Jumper Locations

Figure 40 shows the jumper locations in SmartFusion2 Evaluation Kit Board.

]
MBPS LINK L
LPDDR -

m
Lo CJE3
—————

m
[
C

&

3
i = . .
Q L Microsemi.- |
| e ‘szz

AP2VCUR_SENSE

C4d Jé}ov’_ w

Figure 40 « Jumper Locations

Note: The location of the jumpers in Figure 40 are searchable.
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Appendix 2: Board Setup for Running the Tutorial

Figure 41 shows the board setup for running the tutorial on the SmartFusion2 Evaluation Kit Board.

PELLEERLEEL LR REEEERLE

SR LLLLLRRR Ry

Microsemi ===

MU

Figure 41 + SmartFusion2 Evaluation Kit
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Appendix 3: Readme File

SmartFusion2 System Services Read Version example

This example project demonstrates the use of the SmartFusion2 System Services
functions:

- MSS SYS get serial number ()

- MSS SYS get user code()

- MSS SYS get design version()

- MSS SYS get device certificate()

- MSS SYS check digest ()

This example project requires MMUARTO to be connected to a host PC. The host PC must
connect to the serial port using a terminal emulator such as HyperTérminal or PuTTY
configured as follows:

- 57600 baud

- 8 data bits

- 1 stop bit

- no parity

- no flow control

The example project will display the following information about the SmartFusion2 device
on which it is executed:

- device serial number

- user code

- design version

- device certificate

- digest status

NOTE: In Release mode(i.e. when the code is executed from eNVM0O), Digest Check
service will not work for eNVMO option.

This example project is targeted at a SmartFusion2 design which has MMUARTO enabled and
connected to a‘host PC. The example project is built for a design using a SmartFusion2
MSS APB clock frequency of 83MHz. Trying to execute this example project on a different
design will“result in incorrect baud rate being used by MMUARTO or no output if MMUARTO
is not enabled and connected.

This example project can be used with another design using a different clock
configuration. This can be achieved by overwriting the content of this example project's
"drivers config/sys config" folder with the one generated by Libero as part of your
desd@n's .creation.

Please note that it is possible to redirect MMUARTO to the J198 RS232 connector on the
SmartFusion2 Development Kit despite J198 being connected to the MMUART1 SmartFusion2
pads. This can be done in your hardware design by selecting to direct the MMUARTO TXD
and RXD signals to the FPGA fabric and then connecting these signals to top level ports
assigned to pin H30 for TXD and pin G29 for RXD.

Silicon revision dependencies
RN RN NN NN R R NN RN RN

This example is built to execute on an M2S050T ES die (M2S050T revision B). You will
need to overwrite this example project's "drivers config/sys_config" and "CMSIS" folders
with the one generated by Libero for your hardware design if using a newer silicon
revision.
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The "drivers config/sys config" folder contains information about your hardware design.
This information is used by the CMSIS to initialize clock frequencies global variables
which are used by the SmartFusion2 drivers to derive baud rates. The CMSIS boot code may
also complete the device's clock configuration depending on silicon version. The "CMSIS"
and "drivers config/sys config" for your design can be found in the "firmware" folder

of your Libero design.

Appendix 4: main.c File

/********‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k*****************************************************

* (c) Copyright 2012-2013 Microsemi SoC Products Group. All rights reserved.
Retrieve device and design information using System Services.
Please refer to file README.TXT for further details about this example.

SVN $Revision: 5933 $

SVN $Date: 2013-11-04 15:00:37 +0530 (Mon, 04 Nov 2013) $
/

#include <stdio.h>

#include "drivers/mss_sys_services/mss_sys_services.h"
#include "drivers/mss_uart/mss_uart.h"

L T S .

/*
Messages displayed over the UART.
*/
const uint8 t g greeting msg[] =
"\r\n\r\n\

*********‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k*************************************\r\n\

*xxxxxxxx SmartFusion2 System Services' Read Versionm Example ***kkkkdis\r\n\
*********‘k************************************************************\r\n\
This example project displays infefmation about the device/design\r\n\
retrieved using the SmartFusion2 System Services.\r\n\
It uses the following System Services driver functions:\r\n\

- MSS SYS get serial number () \r\n\

- MSS SYS get user code()\r\n\

- MSS SYS get design version ()Ar\n\

- MSS_SYS check digest ()A\r\n\

/*
Private functions.
*/
static void display greeting(void);
statie woid display hex values
(
const uint8_t * in buffer,
uint32 t byte_ length

/*

UART selection.
Replace the line below with this one if you want to use UART1 instead of
UARTO:
mss_uart instance t * const gp_my uart = &g mss uartl;
*/
mss_uart instance t * const gp my uart = &g mss uartO;

/*
Main function.

*/
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int main ()

{

uint8 t serial number[16];
uint8 t user code[4];

uint8 t design version[2];
uint8 t device certificate[512];
uint8 t status;

int8 t tx complete;

MSS SYS init (MSS_SYS NO EVENT HANDLER) ;

MSS_UART init (gp_my uart,
MSS_UART_57600_BAUD,
MSS_UART DATA 8 BITS | MSS UART NO PARITY | MSS_UART_ONE STOP BIT);

/* Display greeting message. */
display greeting();

* Device Serial Number (DSN).
*/

status = MSS SYS get serial number (serial number) ;

if (MSS_SYS SUCCESS == status)
{
MSS UART polled tx string(gp_my uart,
(const uint8 t*)'"Device serial number: ");
display hex values(serial number, sizeof(serial number));
}
else
{
MSS UART polled tx stringd{gp my uart,
(const uint8 t*)"Service read device serial number

failed.\r\n");

if (MSS_SYS_MEM ACEESS_ERROR == status)
{
MSS UART polled tx string(gp_my uart,
(const uint8_t*)"Error - MSS memory access error.");

}
MSS_UART polled tx string(gp _my uart, g_separator);

/* __________________________________________________________________________
* User code.
*/
status = MSS SYS get user code(user_code);
ify(MSS_SYS SUCCESS == status)
{
MSS_UART_polled tx_string(gp_my_uart,
(const uint8 t*)"User code: ");
display hex values (user code, sizeof (user code));
1
else

{
MSS UART polled tx string(gp_my uart,
(const uint8 t*)"Service read user code failed.\r\n");

if (MSS_SYS MEM ACCESS ERROR == status)
{
MSS UART polled tx string(gp my uart,
(const uint8 t*)"Error - MSS memory access error.");
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*/

MSS UART polled tx string(gp my uart, g separator);

K
* Design version.
*/
status = MSS_SYS get design version(design version);
if (MSS_SYS SUCCESS == status)
{
MSS UART polled tx string(gp my uart,
(const uint8 t*)"Design version: ");
display hex values(design version, sizeof(design version));
}
else

{
MSS UART polled tx string(gp _my uart,
(const uint8 t*)"Service get design version failed.\r\n");

if (MSS_SYS MEM ACCESS ERROR == status)

{
MSS UART polled tx string(gp my uart,
(const uint8 t*)"Error - MSS memory access error.");

}
MSS UART polled tx string(gp_my uart, g separator);

/* __________________________________________________________________________
* Device certificate.
*/
/*status = MSS SYS get device certificate(device certificate);
if (MSS_SYS SUCCESS == status)
{
MSS UART polled tx string{gp my uart,
(const uint8 t*)"Device certificate: ");
display hex values (device certificate, sizeof (device certificate));
}
else

{
MSS_UART polled tx string(gp my uart,
(const wint8 t*)"Service get device certificate failed.\r\n");

if (MSS_SYS MEM ACCESS ERROR == status)

{
MSS UART polded tx string(gp_my uart,
(const uint8 t*)"Error - MSS memory access error.");

}
MSS UART polded tx string(gp_my uart, g_separator);

do {
tx complete = MSS_UART_tx_ complete(gp_my uart);
} while (0 == tx complete);
s — = —
* Check digest.
*/
status = MSS SYS check digest (MSS SYS DIGEST CHECK FABRIC);
if (MSS_SYS_SUCCESS == status)

{

MSS UART polled tx string(gp_my uart,

(const uint8 t*)"Digest check success.");

}
else
{

uint8 t fabric digest check failure;

uint8_t envmO_digest check failure;
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uint8_t envml_digest check failure;

fabric digest check failure = status & MSS SYS DIGEST CHECK FABRIC;
envm0 digest check failure = status & MSS SYS DIGEST CHECK ENVMO;
envml digest check failure = status & MSS_SYS DIGEST CHECK ENVMI;

MSS UART polled tx string(gp my uart,
(const uint8 t*)"\r\nDigest check failure:
if (fabric digest check failure)

{

MSS UART polled tx string(gp my uart,
(const uint8 t*)"\r\nFabric digest{check failed.");
}
if (envm0_digest check failure)
{
MSS UART polled tx string(gp my uart,
(const uint8 t*)"\r\neNVMO digest check failed.");
}
if (envml digest check failure)
{
MSS UART polled tx string(gp _my uart,
(const uint8 t*)"\¥\neNVMl digest check failed.");

}
MSS UART polled tx string(gp my uart, g separator);

for(;;)

{

/*

Display greeting message when application is started.
*/
static void display greetdng(void)
{
MSS UART polled tx string(gp my uart, g greeting msg);

/*

Display content of buffer passed as parameter as hex values
*/
static void display hex values
(
const uint8_t * in buffer,
uint32 €t byte length

uint8 t display buffer[128];
uint32_t inc;

if (byte_length > 16u)
{
MSS UART polled tx string( gp my uart, (const uint8 t*)"\r\n" );

for(inc = 0; inc < byte length; ++inc)
{
if ((inc > 1u) &&(0u == (inc % 1lou)))
{
MSS UART polled tx string( gp my uart, (const uint8 t*)"\r\n" );
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snprintf ((char *)display buffer, sizeof(display buffer), "%02x ",
in_buffer[inc]);

MSS UART polled tx string(gp my uart, display buffer);
}
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A — List of Changes

The following table lists critical changes that were made in each revision of the chapter in the demo

guide.
Date Changes Page
Revision 2 Updated the document for Libero v11.4 software release (SAR 61636). NA
(October 2014)
Revision 1 Initial release. NA
(April 2014)
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Microsemi SoC Products Group backs its products with various support services, including Customer
Service, Customer Technical Support Center, a website, electronic mail, and worldwide sales offices.
This appendix contains information about contacting Microsemi SoC Products Group and using these
support services.

Customer Service

Contact Customer Service for non-technical product support, such as product pricing, product upgrades,
update information, order status, and authorization.

From North America, call 800.262.1060
From the rest of the world, call 650.318.4460
Fax, from anywhere in the world, 408.643.6913

Customer Technical Support Center

Microsemi SoC Products Group staffs its Customer Technical Support Center with highly skilled
engineers who can help answer your hardware, software, and design questions about Microsemi SoC
Products. The Customer Technical Support Center spends a gteat deal of time creating application
notes, answers to common design cycle questions, documentation of known issues, and various FAQs.
So, before you contact us, please visit our online resources. ltis very likely we have already answered
your questions.

Technical Support

Visit the Customer Support website (www.microsemi.com/soc/support/search/default.aspx) for more
information and support. Many answers-available on the searchable web resource include diagrams,
illustrations, and links to other resources on the website.

Website

You can browse a variety of technical and non-technical information on the SoC home page, at
WWW.microsemi.com/soc.

Contacting the Customer Technical Support Center

Highly skilled engineers staff the Technical Support Center. The Technical Support Center can be
contacted by email or through the Microsemi SoC Products Group website.

Email

You can communicate your technical questions to our email address and receive answers back by email,
fax, or phone. Also, if you have design problems, you can email your design files to receive assistance.
We constantly monitor the email account throughout the day. When sending your request to us, please
be sure to include your full name, company name, and your contact information for efficient processing of
your request.

The technical support email address is soc_tech@microsemi.com.

Revision 2 44


http://www.microsemi.com/soc/support/search/default.aspx
http://www.microsemi.com/soc
mailto:soc_tech@microsemi.com

& Microsemi

Creating a Libero Project for Firmware Catalog Sample Project - Libero SoC v11.4 and SoftConsole Flow Tutorial for
SmartFusion2

My Cases

Microsemi SoC Products Group customers may submit and track technical cases online by going to My
Cases.

Outside the U.S.

Customers needing assistance outside the US time zones can either contact technical support via email
(soc_tech@microsemi.com) or contact a local sales office. Sales office listings can be found at
www.microsemi.com/soc/company/contact/default.aspx.

ITAR Technical Support

For technical support on RH and RT FPGAs that are regulated by International Traffic .in Arms
Regulations (ITAR), contact us via soc_tech_itar@microsemi.com. Alternatively, within My Cases, select
Yes in the ITAR drop-down list. For a complete list of ITAR-regulated Microsemi-FPGAs, visit the ITAR

web page.
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Microsemi.

Microsemi Corporate Headquarters

One Enterprise, Aliso Viejo CA 92656 USA
Within the USA: +1 (800) 713-4113
Outside the USA: +1 (949) 380-6100
Sales: +1 (949) 380-6136

Fax: +1 (949) 215-4996

E-mail: sales.support@microsemi.com

Microsemi Corporation (Nasdaq: MSCC) offers a comprehensive portfolio of semiconductor
and system solutions for communications, defense and security, aerospace, and industrial
markets. Products include high-performance and radiation-hardened analog mixed-signal
integrated circuits, FPGAs, SoCs, and ASICs; power management products; timing and
synchronization devices and precise time solutions, setting the world's standard for time; voice
processing devices; RF solutions; discrete components; security technologies and scalable
anti-tamper products; Power-over-Ethernet ICs and midspans; as well as custom design
capabilities and services. Microsemi is headquartered in Aliso Viejo, Calif. and has
approximately 3,400 employees globally. Learn more at www.microsemi.com.

© 2014 Microsemi Corporation. All rights reserved. Microsemi and the Microsemi logo are trademarks of
Microsemi Corporation. All other trademarks and service marks are the property of their respective owners.
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