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Accessing Serial Flash Memory using SPI Interface 
- Libero SoC and Keil uVision Flow Tutorial for 
SmartFusion2 SoC FPGA

Introduction
The Libero® System-on-Chip (SoC) software generates firmware projects using Keil, SoftConsole, and
IAR tools. This tutorial describes the process to build a Keil uVision application that can be implemented
and validated using the SmartFusion®2 system-on-chip (SoC) field programmable gate array (FPGA)
Development Kit. 

The same firmware project can be built using IAR and Keil tools. Refer to the respective tutorials:

• Accessing Serial Flash Memory using SPI Interface - Libero SoC and SoftConsole Flow Tutorial 
for SmartFusion2 SoC FPGA

• Accessing Serial Flash Memory using SPI Interface - Libero SoC and IAR Embedded Workbench 
Flow Tutorial for SmartFusion2 SoC FPGA

After completing this tutorial, you will be able to perform the following tasks:

• Create a Libero SoC project using System Builder

• Generate the programming file to program the SmartFusion2 device

• Open the project in Keil uVision from Libero SoC 

• Compile application code

• Debug and run code using Keil uVision

Tutorial Requirements
Table 1 • Reference Design Requirements and Details

Reference Design Requirements and Details Description

Hardware Requirements

• SmartFusion2 Development Kit

– FlashPro4 programmer 

– USB A to Mini-B cable

– 12 V adapter 

Rev C or later

Keil debugger -

Host PC or Laptop Any 64-bit Windows Operating System

Software Requirements

Libero SoC

• Keil uVision 5

• FlashPro programming software v11.3

11.3

USB to UART drivers -

One of the following serial terminal emulation programs:

• HyperTerminal

• TeraTerm

• PuTTY

-

Sup
ers

ed
ed
Revision 1 3



Accessing Serial Flash Memory using SPI Interface - Libero SoC and Keil uVision Flow Tutorial for SmartFusion2 SoC 
FPGA
Associated Project Files
Download the associated project files for this tutorial from the Microsemi® website: 
http://soc.microsemi.com/download/rsc/?f=SF2_SPI_Flash_Keil_Tutorial_DF 

The demo design files include:

• Libero project

• Source files

• Flash drivers

• Readme file

Refer to the Readme.txt file provided in the design files for the complete directory structure.

Target Board
SmartFusion2 Development Kit board (SF2_DEV_KIT) Rev C (or later).

Design Overview
This design example demonstrates the execution of basic read and write operations on the SPI flash
present on the SmartFusion2 Development Kit board. This kit has a built-in Atmel SPI flash memory
AT25DF641, which is connected to the SmartFusion2 microcontroller subsystem (MSS) through
dedicated MSS SPI_0 interface.

Read and write data information is displayed using HyperTerminal which communicates to the
SmartFusion2 MSS using the MMUART_1 interface.

For more information on SPI, refer to the SmartFusion2 Microcontroller Subsystem User Guide.

Figure 1 shows interfacing the external SPI flash to MSS SPI_0.

Figure 1 • SPI Flash Interfacing Block DiagramSup
ers

ed
ed
4 Revision 1

http://www.microsemi.com/document-portal/doc_download/130918-smartfusion2-microcontroller-subsystem-user
http://soc.microsemi.com/download/rsc/?f=SF2_SPI_Flash_Keil_Tutorial_DF


Step 1: Creating a Libero SoC Project
Step 1: Creating a Libero SoC Project

Launching Libero SoC
1. Click Start > Programs > Microsemi Libero SoC v11.3 > Libero SoC v11.3, or click the shortcut 

on desktop to open the Libero SoC v11.3 Project Manager.

2. Create a new project by selecting New on the Start Page tab (highlighted in Figure 2), or by 
clicking Project > New Project from the Libero SoC menu. 

3. Enter the information as required for the new project and the device in the New Project dialog
box as shown in Figure 3 on page 6.

– Project

- Name: SPI_Flash

- Location: Select an appropriate location (for example, D:/Microsemi_prj)

- Preferred HDL type: Verilog

– Device (select the following values using the drop-down list provided):

- Family: SmartFusion2

- Die: M2S050T

- Package: 896 FBGA

- Speed: STD

- Core Voltage: 1.2

– Operating conditions: COM

Figure 2 • Libero SoC Project Manager
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Accessing Serial Flash Memory using SPI Interface - Libero SoC and Keil uVision Flow Tutorial for SmartFusion2 SoC 
FPGA
4. Check the Use Design Tool check box and select Use System Builder in the Design 
Templates and Creators section of the New Project window as shown in Figure 3. 

Note: System Builder is a graphical design wizard. It creates a design based on high-level design 
specifications by taking the user through a set of high-level questions that will define the intended 
system.

Figure 3 • New Project Dialog BoxSup
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Step 1: Creating a Libero SoC Project
5. Clicking Edit Tool Profiles (highlighted in Figure 3 on page 6) displays the Tool Profiles window 
as shown in Figure 4. Check the following tool settings:

– Software IDE: Keil

– Synthesis: Synplify Pro ME I-2013.09M-SP1

– Simulation: ModelSim ME 10.2c

– Programming: FlashPro 11.3

6. Click OK on the Tool Profiles window.

7. Click OK on the New Project window. The System Builder dialog box is displayed.

8. Enter a name for your system, enter SPI_Flash as the name of the system and click OK. The 
System Builder dialog box is displayed with the Device Features page open by default, as 
shown in Figure 5. 

Figure 4 • Tool Profiles

Figure 5 • Create New System Builder Dialog BoxSup
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Accessing Serial Flash Memory using SPI Interface - Libero SoC and Keil uVision Flow Tutorial for SmartFusion2 SoC 
FPGA
9. In the System Builder – Device Features page, check the Peripheral DMA check box under
Microcontroller Options as shown in Figure 6. 

Figure 6 • System Builder – Device Features Page
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Step 1: Creating a Libero SoC Project
10. Click Next. The System Builder – Peripherals page is displayed. Under the MSS Peripherals
section, uncheck all the check boxes except MM_UART_1 and MSS_SPI_0, as shown in
Figure 7. 

Figure 7 • System Builder Configurator – Peripherals Page
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11. Configure MMUART_1 for Fabric by clicking on the MM_UART_1 configurator highlighted as 
shown in Figure 8. 

Figure 8 • System Builder – Peripherals Page
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Step 1: Creating a Libero SoC Project
12. In the MM_UART_1 configurator window, select Fabric from the Connect To drop-down list, as 
shown in Figure 9. 

13. Click Next. The System Builder – Clocks page is displayed, as shown in Figure 10. Select
System Clock source as On-chip 25/50 MHz RC Oscillator. The M3_CLK is configured to
100 MHz by default.

Figure 9 • Configuring MM_UART_1

Figure 10 • System Builder – Clocks Page

Sup
ers

ed
ed
Revision 1 11



Accessing Serial Flash Memory using SPI Interface - Libero SoC and Keil uVision Flow Tutorial for SmartFusion2 SoC 
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14. Click Next. The System Builder – Microcontroller page is displayed. Leave the default settings.

15. Click Next. The System Builder – SECDED page is displayed. Leave the default settings.

16. Click Next. The System Builder – Security page is displayed. Leave the default settings.

17. Click Next. The System Builder – Interrupts page is displayed. Leave the default settings.

18. Click Next. The System Builder – Memory Map page is displayed. Leave the default settings.

19. Click Finish.

The System Builder generates the system based on the selected options. The System Builder 
block is created and added to the Libero SoC project automatically, as shown in Figure 11.

Connecting Components in SPI_Flash_0 SmartDesign
Perform the following steps to connect the SmartDesign components:

1. Right-click FAB_RESET_N and select Tie High.

2. Right-click POWER_ON_RESET_N and select Mark Unused.

3. Right-click MSS_READY and select Mark Unused.

4. Right-click MMUART_1_FABRIC and select Promote to Top Level.

5. Expand INIT_PINS, right-click INIT_DONE and select Mark Unused.

6. Expand FAB_CCC_PINS, right-click FAB_CCC_GL0 and select Mark Unused.

7. Click File > Save. The SPI_Flash_0 is displayed as shown in Figure 12.

Configuring and Generating Firmware
The Design Firmware window displays compatible firmware drivers based on peripherals configured in 
the design. Following drivers are used in this tutorial:

• CMSIS

• MMUART

• PDMA

• SPI

Figure 11 •  System Builder Generated System

Figure 12 • SPI_Flash_0 DesignSup
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Step 1: Creating a Libero SoC Project
1. To generate the required drivers click Design > Configure Firmware and clear all drivers except 
CMSIS, MMUART, PDMA, and SPI as shown in Figure 14.

Note: Select the latest version of the drivers.

2. From the SPI_Flash_top tab, click Generate Component, as shown in Figure 14. 

If the design is generated without any errors, a message, ’SPI_Flash_top’ was generated is 
displayed on the Libero SoC Log window as shown in Figure 15. 

Figure 13 •  Configuring Firmware

Figure 14 • Generate Component

Figure 15 • Log WindowSup
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Accessing Serial Flash Memory using SPI Interface - Libero SoC and Keil uVision Flow Tutorial for SmartFusion2 SoC 
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Step 2: Generating the Program File
1. Double-click I/O Constraints in the Design Flow window as shown in Figure 16. The I/O Editor

window is displayed after completing Synthesize and Compile.  

2. In the I/O Editor window, make the pin assignments as shown in Table 2. 

Figure 16 • I/O Constraints

Table 2 • Port to Pin Mapping

Port Name Pin Number

MMUART_1_RXD_F2M R29

MMUART_1_TXD_M2F R24Sup
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Step 3: Programming the SmartFusion2 Board Using FlashPro
These pin assignments are for connecting MMUART_1 ports TX and RX to the mini-B USB 
through fabric I/Os. After the pins are assigned, the I/O Editor window is displayed as shown in 
Figure 17. 

3. After updating the I/O Editor, click Commit and Check.

4. Close the I/O Editor window.

5. Click Generate Programming Data as shown in Figure 18 to complete place-and-route and 
generate the programming file.

Step 3: Programming the SmartFusion2 Board Using 
FlashPro

1. Connect the FlashPro4 programmer to the J59 connector of the SmartFusion2 Development Kit.

2. Connect the jumpers on the SmartFusion2 Development Kit board as listed in Table 3 on 
page 16. For more information on jumper locations, refer to the "Appendix C- SmartFusion2 
Development Kit Board Jumper Locations" on page 44.

CAUTION: While making the jumper connections, the SW7 power supply switch on the board 
must be in OFF position.

Figure 17 • I/O Editor

Figure 18 • Generate Programming Data

Sup
ers

ed
ed
Revision 1 15



Accessing Serial Flash Memory using SPI Interface - Libero SoC and Keil uVision Flow Tutorial for SmartFusion2 SoC 
FPGA
3. Connect the power supply to the J18 connector.

4. Switch ON the SW7 power supply switch.

Refer to "Appendix B - Board Setup for Programming the Tutorial" on page 43 for information on 
board setup for running the tutorial.

5. To program the SmartFusion2 device, double-click Run PROGRAM Action in the Design Flow
window as shown in Figure 19. 

Table 3 • SmartFusion2 Development Kit Jumper Settings

Jumper Number Settings Notes

J70, J93, J94, J117, 
J123, J142, J157, J160, 
J167, J225, J226, J227

1-2 closed These are the default jumper settings of the Development 
Kit. Ensure that these jumpers are set properly.

J2 1-3 closed

J23 2-3 closed

J121, J110, J119, J118 1-2 closed To connect the SmartFusion2 SPI0 to the external flash

Figure 19 • Run Programming Action
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Step 4: Building the Software Application Using Keil uVision 5 IDE
Step 4: Building the Software Application Using Keil uVision 5 
IDE

1. After successful programming, open the Keil uVision project by double-clicking Write Application 
Code under Develop Firmware in the Design Flow window as shown in Figure 20.

Figure 20 • Invoking Keil uVision from the Libero SoC Software
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The Keil uVision workspace is displayed, as shown in Figure 21. 

2. Browse to the main.c file location in the design files folder:
<download_folder>/SF2_SPI_Flash_Keil_Tutorial_DF\SourceFiles.

3. Copy the main.c file and replace the existing main.c file under SPI_Flash_MSS_CM3_0_app
project in the uVision workspace.

Figure 21 • uVision Workspace
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Step 4: Building the Software Application Using Keil uVision 5 IDE
The uVision window displays the main.c file, as shown in Figure 22. 

4. at25df641 SPI flash drivers are not included in the Libero generated uVision workspace. To
include the drivers in the uVision workspace, browse to the location of the at25df641 drivers in the
design files folder: 
<download_folder>\SF2_SPI_Flash_Keil_Tutorial_DF\SPI_Flash_Drivers folder.

5. Copy the at25df641 folder to the drivers folder of SPI_Flash_MSS_CM3_hw_platform project in
the uVision workspace.

Figure 22 • uVision Workspace main.c file 
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6. Right-click drivers and add the driver file (at25df641.c) to SPI_Flash_MSS_CM3_hw_platform
project in the Keil uVision workspace as shown in Figure 23.

Figure 23 • Project Explorer Window
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Step 4: Building the Software Application Using Keil uVision 5 IDE
7. Change SPI_Flash_MSS_Cm3_hw_platform debug mode to Cortex-M3_SRAM by selecting
Cortex-M3_SRAM from the drop-down list, as shown in Figure 24.

This tutorial uses printf statements to display memory read data. Redirection of the output of 
printf() to a UART is enabled by adding the MICROSEMI_STDIO_THRU_UART symbol.

Figure 24 • Cortex-M3_SRAM Settings
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Follow the steps given below to add MICROSEMI_STDIO_THRU_UART symbol: 

a. Right-click Cortex - M3 SRAM under SPI_Flash_MSS_CM3_hw_platform and click Options 
for SPI_Flash_MSS_Cm3_hw_platform - Target Cortex - M3 SRAM.

b. Go to C/C++ tab and enter MICROSEMI_STDIO_THRU_UART at Define under Preprocessor 
Symbols as shown in Figure 26 on page 23.

c. Click OK.

Figure 25 • Target Options
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Step 4: Building the Software Application Using Keil uVision 5 IDE
Figure 26 • Target Options-Add Symbols
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8. Right-click Cortex-CM3_SRAM under SPI_Flash_MSS_Cm3_hw_platform and select Build
SPI_Flash_MSS_Cm3_hw_platform (Cortex-CM3 SRAM) as shown in Figure 27.

Figure 27 • Build HW Platform Window
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Step 4: Building the Software Application Using Keil uVision 5 IDE
9. Right-click SPI_Flash_MSS_CM3_app and select Set as Active Project.

Figure 28 • Set as Active Project
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10. Change SPI_Flash_MSS_CM3_app debug mode to Cortex-M3_SRAM by selecting Cortex-
M3_SRAM from the drop-down menu as shown in Figure 29.

Figure 29 • Cortex-M3_SRAM Settings
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Step 4: Building the Software Application Using Keil uVision 5 IDE
11. Right-click Cortex-M3 SRAM under SPI_Flash_MSS_CM3_app and click Options for project.

Figure 30 • Target Options
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12. Click the Debug tab and browse the //SF2_SPI_Flash_Keil_Tutorial_DF/SourceFiles/ folder for
initialization file provided as shown in Figure 31.

13. Click the Utilities tab and uncheck Use Debug Driver and Update Target before Debugging
check boxes.

Figure 31 • Target Options - Initialization File
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Step 4: Building the Software Application Using Keil uVision 5 IDE
14. Select ULINK2/ME Cortex Debugger from the drop-down list and click OK as shown in
Figure 32.

Figure 32 • Target Options - Utilities Settings
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15. Right-click Cortex-M3 SRAM under SPI_Flash_MSS_CM3_app and select Build
SPI_Flash_MSS_CM3_app (Cortex-M3 SRAM) as shown in Figure 33. It compiles all of the
source files and links the object files into an AXF file to debug. Make sure that there are no errors.
Correct any syntax errors and rebuild if necessary.

Figure 34 shows the messages that are displayed in the console after the build.

Figure 33 • Build Application Window

Figure 34 • Build Output
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Step 5: Configuring Serial Terminal Emulation Program
Step 5: Configuring Serial Terminal Emulation Program
1. Install the USB driver. For serial terminal communication through the FTDI mini USB cable, install 

the FTDI D2XX driver. Download the drivers and the installation guide from: 
www.microsemi.com/soc/documents/CDM_2.08.24_WHQL_Certified.zip.

2. Connect the host PC to the J24 connector using the USB Mini-B cable. The USB to UART bridge
drivers are automatically detected. Of the four COM ports, select the one with Location as on
USB Serial Converter D. Figure 35 shows an example Device Manager window.

3. Start the HyperTerminal session. If the HyperTerminal program is not available in the computer,
any free serial terminal emulation program such as PuTTY or TeraTerm can be used. Refer to the
Configuring Serial Terminal Emulation Programs Tutorial for configuring the HyperTerminal,
TeraTerm, or PuTTY.

The HyperTerminal settings are as follows:

– 57,600 baud rate

– 8 data bits

– 1 stop bit

– No parity

– No flow control

Figure 35 • Device Manager Window
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Step 6: Connecting the ULINK-ME to the Board and PC
This section describes the connection between the SmartFusion2 Development Kit board, ULINK-ME, 
and host PC. Use the appropriate settings for the board that is in use.

1. Connect Pin 2 and Pin 3 on the jumper J93 on the SmartFusion2 Development Kit board. 

2. Connect the USB A-Mini B cable between the host PC and the SmartFusion2 Development Kit 
board. This is used to display the HyperTerminal communications. 

3. Verify that the ULINK-ME debugger is connected to the SmartFusion2 Development Kit board 
RVI Header as shown in Figure 36 and also to the host PC through a USB A-Mini B cable. The 
ULINK-ME adapter has one LED that indicates connection status in the following ways: 

– Blinking slowly indicates that ULINK-ME is ready to communicate with the debugger. 

– Blinking speedily indicates that the target board is executing the program under debugger 
control. 

– Remaining ON during debugging indicates that the debugger has halted the target board. 

– Remaining ON during download indicates that target download and verification is in progress. 

4. Switch ON the SW7 power supply switch.

Figure 36 • ULINK-ME Connections
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Step 6: Connecting the ULINK-ME to the Board and PC
Refer to "Appendix A - Board Setup for Debugging from Keil uVision" on page 42 for information 
on the board setup for running the tutorial.

Figure 37 • ULINK-ME Debugger
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Accessing Serial Flash Memory using SPI Interface - Libero SoC and Keil uVision Flow Tutorial for SmartFusion2 SoC 
FPGA
Step 7: Debugging the Application Project using Keil 
uVision 5

1. Select Start/Stop Debug Session from the Debug menu in the uVision window to run it through 
the debug hardware as shown in Figure 38. The processor code will be downloaded to the 
SmartFusion2 eSRAM.

Figure 38 • Selecting Start/Stop Debug Session 
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Step 7: Debugging the Application Project using Keil uVision 5
The code will automatically 'run to main' and then stop as shown in Figure 39.

Figure 39 • Debug Menu
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FPGA
2. Click Run from the Debug menu as shown in Figure 40. 

Figure 40 • Selecting Run from the Debug Menu
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Step 7: Debugging the Application Project using Keil uVision 5
On successful operation, the HyperTerminal window displays a message as Read Data From 
Flash as shown in Figure 41.

Figure 41 • HyperTerminal Window
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The Disassembly window is displayed in the middle of the Debug section as shown in Figure 42. 
If not, click the Disassembly icon to display the Disassembly section.

Figure 42 • Disassembly Window
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Step 7: Debugging the Application Project using Keil uVision 5
3. Check the Registers section to view the values of the ARM® Cortex™-M3 processor internal 
registers.

Figure 43 • Values of the Cortex-M3 Internal Registers
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4. When debug process is finished, terminate execution of the code by choosing Debug > 
Start/Stop Debug Session as shown in Figure 44.

Figure 44 • Keil uVision Workbench - Stop Debug Option
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Conclusion
5. The Step Level Debugging can be performed before running the application using Run. These 
can be accessed from the Debug menu or on the Keil uVision workbench as shown in Figure 45:

– Source code can be single-stepped by selecting from the Debug menu Debug > Step, Debug 
> Step Over, Debug > Step Out or by selecting the respective options from the Keil uVision 
workbench as shown in Figure 45. Observe the changes in the source code window and 
Disassembly section. Performing a step over provides an option for stepping over functions. 
The entire function is run but there is no need to single-step through each instruction 
contained in the function.

– Select Debug > Step Out to exit the instruction in stepping mode.

6. Add breakpoints from the Debug menu in workbench to force the code to halt, start Debug 
session, and then single-step and observe the instruction sequence.

7. Close uVision using File > Exit. 

8. Close the HyperTerminal using File > Exit. 

Conclusion
This tutorial provides steps to create a Libero SoC software design using the System Builder. It describes 
how to build, debug, and run Keil uVision application. It also provides a simple design to access the SPI 
flash.

Figure 45 • Keil uVision Workbench - Step Level Debugging
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Appendix A - Board Setup for Debugging from Keil 
uVision

Figure 1 shows the board setup for debugging the Keil uVision on the SmartFusion2 Development Kit
board.

Figure 1 • SmartFusion2 Development Kit in Debug Mode using Keil uVisionSup
ers

ed
ed
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Appendix B - Board Setup for Programming the 
Tutorial

Figure 1 shows the board setup for running the tutorial on the SmartFusion2 Development Kit board.

Figure 1 • SmartFusion2 Development Kit in Programming Mode
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Appendix C- SmartFusion2 Development Kit Board 
Jumper Locations

Figure 1 shows the jumper locations on the SmartFusion2 Development Kit board.

Note:

• Jumpers highlighted in red are set by default.

• Jumpers highlighted in green to be set manually.

• The location of the jumpers in Figure 1 are searchable.

Figure 1 • SmartFusion2 Development Kit Board Jumper Locations

T1

C54

R97

C48

U10

R5
5

DS
10

R3
5

J5

D17

R3
25

U59

T2

C5
8

C4
4

C43

C38

C40

R5
6

DS
11

R3
6

R2
3

D19

SC
1

R74

C4
2

D7

R5
2

R2
4

R2
5

R3
39

Q1
8

Q15

Q14

C200 C202

U61

R137

R132

TP29

C37

D5

R2
6

J4

R3
38

TP
12

J2
08

J1
92

J1
71

J1
50

SC
2

R2
7

R350

TP24

D1
6

D1
4

R244

C1
19

C1
21

C1
20

L1
0

C74

C70

R28

D6

R3
53

C1
98

D1
5

TP25

C1
34

L5

C7

C25
R33

C26 R3
7

C18

C1
72

C1
04

C1
03

R6
80

C1
00 C9

6

U7

C102

R6
77

R6
78

R6
79

R6
81

C99

C101

C9
8C93

R134

R128

J3
7

R115

C47

C1
3

J2
25

U55

R3
11

R672

R6
75

R676

C97

R673
R674

J1
17

RS
2

R6
63

J93

U8

C21

C4

C1
73

U28

J94 U2
7

J34

C17

C10

J2
26

U42

TP3

C81

C82

J7
0

U4

C3

J2
27

C167

C1
59

U51

J104

SW
9

R1
48

LE
D9

C2
0

R3
12

U5
6

C164

C9
1

R176

R1
72

J105

J231

J3

Q20

R3
76

R3
68

R3
67

LE
D1R3
57

R3
58

TP22

C162

R2
86

R2
83

R2
82

C1
46

R265

C9
2

C8
6

C8
5

R175

R1
73

Q22Q21

R3
78

R3
77

R3
69LE

D2 R3
59

R2
74

R270

R285

C1
48

C1
47

R2
66

R2
05

R2
03

C114

C9
0

C8
9

C8
8

C8
7

Y2
J8

1

TP11

J2
6

J1
9

R3
8

SW
4

R1
3

SW
5

Q23

R3
79

R3
70 LE

D4

LE
D3 R3
60

R2
76

R2
75

R281

R268

C1
50

C1
49

J1
67

R213
R215

R2
12

R2
17

R2
07

R2
06

R2
04

RS4

RS3

U2
3

R1
46

R3
1

SW
3

Q24

R3
80

R3
71 LE

D5R3
61

R2
78

R269

R2
77

R280

C1
52

C1
51

RS5 J1
60

J1
42

R6
62

R161

R1
59

R1
60

R1
49

U22

C6
6

J25

J22

J20

J21

R57
R3

9
R1

4

Q26Q25

R3
81

R3
72

R3
73LE

D6R3
62

R3
63

R267

R2
79

C1
53

RS
6

L1
3

J123

C9
4

C9
5

R162

J5
4

R6
1

R5
3

R6
0

R5
4

SW
1

SW
2

Q27

R3
83

R3
82

R3
74LE

D7 R3
64

J211

R234
R235
R236
R237

R2
38

R2
39

R231
R232

R226
R229

U40

R1
83

L8 R1
84

R1
82

R1
79

R177 R1
78

L7

J3
3

R8
9

R8
8

R8
7

C5
0

C4
9

R72

R79

R75
R77

R84

R67

R71
R4

9
R4

8
R4

7
J1

2

J1
3

R2
9

LE
D8

J1
85

R2
40

R2
41

R2
42

R256

R218

C1
28

C1
29

C1
31

C1
30

J124

R1
85

R180

U3
6

J8
2

SW
8
C7

6
C7

5
C7

3

R145
R144
R141
R139
R138

C6
7

C7
2
C6

9

R135
R133

R136

R127
R129

C6
0

C6
2

C5
9

R119
R122

R126
R125

R118
R117

R9
0 R1

07
R1

08

R1
06

R4
5

C2
9

C2
8

J1
4

TP
10

J228

J219

TP14

R2
47

R2
20

U4
5

J1
51

L12

J125

Y1

R1
09

R1
10 R9
5

C5
2

R9
1

R51

R4
6

U9

R3
2

J1
5

J1
6

J1
1

TP1

J8J6

Q7

J1

J229

J1
86

R2
43

J1
82

R230
J177

R2
21

R670

J152

J153

SW10

J127J126

Y3

C80

J6
7

J30
U19

C5
3

J2
9

R9
2 R9

3
R9

4

R66
R68

C3
2

R3
0

TP2

Q10

J1
0

J9

Q8

J220

R2
19

R1
50

R1
11

R1
12

R1
00

R85

R76

R64

R62
R65

R5
0

C3
3

J7

J2
05

J1
89

J1
68J1
66

J1
56

J1
47

J128

J8
0

R1
51

R1
54

R1
57
R1

53
R1

52

J32

R1
13

R8
0

J17

R355
R354TP21

C191

J1
32

R186
R188

R671R181

J1
16

R167
R168

J1
12

R166

J1
03

C7
8

C7
9

R1
55

R1
58

J3
1

TC5
TC3
TC1

R1
14 DS

16
DS

17
DS

18
DS

19

R8
1

R8
2

R8
3

DS
12

L4

D18

R326

TP13

U37

U33

C77

J49

J4
4

TC7
TC6

TC2
TC4

DS
13

DS
14

DS
15

CO
NN

1

D20

R366

R365 C204

U60

R189

DS
25

R170

DS
22

R1
31C7
1

D10

R1
23SC
3

SC
4

R1
02

R1
03

TP30 Q13

R58

U2
0

C63

R1
30

R121

C51

R59

SW6

C6

C694

C693

R375

TP20

J2
06

J1
90

J1
69

J1
48

R143

D1
1

C6
8

C6
1

U1
5

R1
04

R86

C46

R73

R78

R69
R70

C39

R2
1

R2
2

C205

R3
56

R346

C1
89

C186

J2
07

J1
91

J1
70

J1
49

C111

C105

C84

C135

R3
47

J221

P1

CR3

CR4

C8 C9

R7

R8Q9

U62

C136

R2
22

C122

L11

J24

CR2

CR1

U3

R660
C683 TP16

R2
84

J1
98

U4
9

J163 C1
37

C138

C132

R228
R224

J1
64

C1
26

U43

TP4

C116

J1
13

J120

R1
69

J109

J4
2

R124

J52

C41

J1
8

R40

J216

U5
2

C170 R3
00
R2

94
R2

93

R298

TP26

U44

R2
10

R2
08

R2
09

TP5

C109

U3
8

Q17

J85

J71

J36

R96

J2

C196

C1
99

R343

R348
R352

R324C1
80

U5
7

C179

C1
76

R316
R313

J2
04

C1
69

R301

C168
R292

R297

C1
66

U5
0

R2
59

R251

R2
60

C1
45

C141

R2
50

J1
76

U4
7

U46

R214C1
27

R2
11

C1
17

U35

R164

R6
64

J76

J72

J96

J65

J56

J50

J46

U16

C5
6

L2
R1

6
C6

82

R669

R668

C201

R3
44

R3
45

R349

R3
51

C1
95

J222

R3
22

R3
14

C144
R264

C165

R255
R248

TP
27

R223

R225

R216

C1
23

C1
24

C1
18

DS24

DS23

J61
J95

DS21

DS20

C57

R9
8

U1
1

SW7

C1
2

U2

Q1
R1

DS
1

C1
90

C193

R3
37

R3
36

R3
35

C194

C1
85

R330
J218

C175

R3
23

R315

C174

C1
81J2
12

C171L15

U5
3

C161
C163

C1
43

C156

R252

R2
62

R2
61

J181

C1
39

R2
45

TP
28

J1
57

D13

R201

R1
99

C1
12

R1
97

C115

R2
00

C1
10

DS
27

U3
9

R174

R171

J6
6

J6
0

J87

J77

J73

J97

J86

R156

J57

J51

J47

R120

U18

R116

R101

TP19

D9
D8

R1
9

R2
0

R1
1

D4
C2

Q2
R2

DS
2

C203

R331
R328

R3
27

C1
77

C1
78

R3
21

R2
87

C1
54 R257

R2
71

R253

R2
63

R254

C157

R246 C140

L14

R2
02

U41

R195

C1
08

C106R1
93

R191

L9

TP8

J9
9

J9
8

J8
8

U24

R1
05

TP23

R1
2

Q4Q3

R4R3
DS

3

U58

C1
82

C1
83

R3
18

R3
17

C1
60 R2

88

U48

C1
55

C158

R258

R2
72

R2
73 R233

C1
42

R2
49 R227

J137

R198
R196

R194

J1
00

J1
01

J89 J90

X1

C6
4

C6
5

C5
5

C2
2

U6

TP18

R1
5

D2
U1

Q5
R5

DS
5

DS
4

J2
23

C1
92

C197R3
40 R3
41

R3
42

C1
88

R333
R332 R3

29

R334

C187

R3
19

R3
20

R2
89

J173

J165

C133

C113

C107

D1
2

DS
26

U34

J1
02

J84

J9
1

J78

J74

J62

J68

U21

U1
7

C45

C1
1

Q6
R6

DS
6

J2
24

R309

R307
R308

R306
R305

R303
R304

R302
R299

R291
R295
R296

J217
R290

J2
13

J215

J2
09

J203

J2
01

J1
99

J1
94

J1
96

J1
83

J1
87J193

J1
78

J1
74J180

J161

Q1
9

J158

J154

C1
25

J145

J143

J140

J138

J1
3

R1
90

J1
21

J114

J118

C8
3

J110

J92

R165

J83

J58
R140

R142

R1
7

R9
D3

C1
DS

9

DS
8

R3
84

TP7

J130
J234

R1
92

J75

J64J69

J6
3

J4
1

J4
8

L6
J3

9

TP15

Q1
1

R1
8

R1
0

DS
7

R187

U32

J79

U2
6

J53

J35

J2
7

J23

R3
4

D1

TP9

J233

J106

R147

R1
63

U2
9

J40

RS1

J2
8

U1
2

C24 C36

L3

TP17

J230

R3
85

J214

J210

J200

J202

J197

J188

J195

J184

J179

J172

J175

J162

J159

J155

J146

J144

J141

J139

J232

J135

J134

J122

J131

J115

J119

J111

J5
5

J45

J4
3

J3
8

C27

C15

C184

J1
08

J1
07

U3
0

U2
5

U13

Q12

R4
4

C23

C1
9

C16

C14

L1

U54

U69

J5
9

U14

C3
0

R4
1

R4
2

C3
1

R6
3

C3
5

C34

U5

R3
10

U3
1

R4
3

6
5

20

12

17

7

1 6

10
1

20

12

4
1

6
3

17

1

7

6

1

1

7
1

1

1

11

4
3

2
1

1

1

1

ON

ON

2
1

1 1

1

2

34

1

1
1

1
4

3

1

1 2 3

20
2

7 8 9

1
2

3
4

1

3 7 8

1

2

1

2

9

B49

J
K
L
M
N

C
B
D
E
F
G
H

A

1 2 3

9

10

19

20

1

7 8 9

19
1

1

JK
LM
N

C
D
E
F
G
H

B
A

1

9

1

5

10

1

10

2

1

1

J
K
L

M
N

C
B
D
E

F
G

H

A

1 2

1

1

31

B11

7

B14
B1

3

1

1

1

4

6

7

1

1

1

7

1

8

2

5
1

1
5

1

1

2

1
5

1

5
1

15
1

20 19

2
3 4

1

3

1

REFCLK0_N

ZL RST

1

A
1
2
3

B

7
8
9

R
9
9

M12

1
1

H
P
D
I
F
F
N
4
H
P
D
I
F
F
P
4

REFCLK0_P

C D E F G

M1

GND

SERDES1

GND

T
S
_
M
D
C

T
S
_
M
D
I
O

H J

1 1

1

P14

P1

A12

A1

DDR3_1P5V

REFCLK0_N

GND

1

1

P2LED2
P3LED0

SFP CONN

RXP2

TXP2

RXP0

TXP0

1

1
1

1

A14

A1

P3LED2

P
1
L
E
D
1

P
1
L
E
D
2

P
1
L
E
D
3

P
1
L
E
D
0

P
0
L
E
D
3

H
P
O
U
T
C
L
K
5

GND

GND

G
N
D

GND

1
P
0
V
_
P
H
Y

GND_C

P
0
L
E
D
2

P
0
L
E
D
1

P
0
L
E
D
0

P
O
E
 
P
W
R
 
E
N
B

P2LED0
P2LED3
P3LED1
P3LED3

O
N

RXN2

TXN2

RXN0

TXN0

2
P
5
V
_
L
D
O

A
T
 
F
L
A
G

O
F
F

RXP3

TXP3

RXN1

TXP1

P
G
O
O
D

DVDD12

RXN3

TXN3

RXP1

TXN1

GND_0

GND

1P0V_PHY

P
O
E
 
C
O
N
N

1

3

3

3

3

A1

K1

PCIEXVDD

SERDES0

A1

AK1

50 MHZ

REFCLK0_P

GND

REFP6

REFP5

RevC

3 1

1.2V

1.0V

GND

1 2

3

1

3

3

1

3P3V

3

N23

L23

F30

K25

H28

G29

J29

H30

L26

H26

K23

J27
3

L28

K30

M27

L29

P24

N26

V23

U24

T27

T26

M23

AA29

Y30

V24

3

F
M
C
 
H
E
A
D
E
R

GND

A40

K40

FP4 HEADER

ETM HEADER

GND

P
L
L
M
D
D
R
V
D
D
A

A30

J
T
A
G
 
S
E
L

1

3P3V_LDO

AK30

PLLFDDRVDDA

RVI HEADER

P
L
L
X
V
D
D
A

1

FMC HEADER
V
P
P

DVP-102-000400-001

1

RESET

R
S
T
 
L
E
D

G
N
D

DDR3_VTT

SF2 DEV KIT

U
S
B
 
M
I
C
R
O
 
A
B

USB MINI B

DC JACK12V/6A

H
D
R
-
R
S
4
8
5

O
T
G
 
S
u
p
p
o
r
t

1
2
V
_
P
C
I
E

FTDI INTERFACE

12_DCJACK

A
N
A
L
O
G
 
I
N
P
U
T

D
B
9
-
R
S
2
3
2

D
B
9
-
C
A
N
2

D
B
9
-
C
A
N
1

5P0V

1
2
V

VDDIO

1

3P3V_LDO

OFF

G
N
D

1
1

ON

1
2
V
_
P
O
E

1

1

HVDD

HVSS

H
V
D
D

PWR ENB
REMOTE

GND

1P
8V

1

1

DD
R3

-1
P5

V

G
N
D

1P8V

3P
3V

_L
DO

2P
5V

_L
DO

1
2P

5V

1

1

H
V
S
S

VD
D_

RE
G

1

V2
61

M2
5

M2
4

G3
0

H2
7

H2
91

J3
0

J2
8

K2
4

J2
6

K29

K28

L30

N24

M26

P23

N25

1

W27

AA28

V22

VDD_REG

2P5V

5P
0V

GND

1

1

1

1

R29
R24

W28

1

3P
3V

12
P0

V

13

3

3

3 1

1

Sup
ers

ed
ed



Product Support

Microsemi SoC Products Group backs its products with various support services, including Customer
Service, Customer Technical Support Center, a website, electronic mail, and worldwide sales offices.
This appendix contains information about contacting Microsemi SoC Products Group and using these
support services.

Customer Service
Contact Customer Service for non-technical product support, such as product pricing, product upgrades,
update information, order status, and authorization.

From North America, call 800.262.1060
From the rest of the world, call 650.318.4460
Fax, from anywhere in the world, 408.643.6913

Customer Technical Support Center
Microsemi SoC Products Group staffs its Customer Technical Support Center with highly skilled
engineers who can help answer your hardware, software, and design questions about Microsemi SoC
Products. The Customer Technical Support Center spends a great deal of time creating application
notes, answers to common design cycle questions, documentation of known issues, and various FAQs.
So, before you contact us, please visit our online resources. It is very likely we have already answered
your questions.

Technical Support
Visit the Customer Support website (www.microsemi.com/soc/support/search/default.aspx) for more
information and support. Many answers available on the searchable web resource include diagrams,
illustrations, and links to other resources on the website. 

Website
You can browse a variety of technical and non-technical information on the SoC home page, at
www.microsemi.com/soc.

Contacting the Customer Technical Support Center
Highly skilled engineers staff the Technical Support Center. The Technical Support Center can be
contacted by email or through the Microsemi SoC Products Group website.

Email
You can communicate your technical questions to our email address and receive answers back by email,
fax, or phone. Also, if you have design problems, you can email your design files to receive assistance.
We constantly monitor the email account throughout the day. When sending your request to us, please
be sure to include your full name, company name, and your contact information for efficient processing of
your request.

The technical support email address is soc_tech@microsemi.com.
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Product Support
My Cases
Microsemi SoC Products Group customers may submit and track technical cases online by going to My
Cases.

Outside the U.S.
Customers needing assistance outside the US time zones can either contact technical support via email
(soc_tech@microsemi.com) or contact a local sales office. Sales office listings can be found at
www.microsemi.com/soc/company/contact/default.aspx.

ITAR Technical Support
For technical support on RH and RT FPGAs that are regulated by International Traffic in Arms
Regulations (ITAR), contact us via soc_tech_itar@microsemi.com. Alternatively, within My Cases, select
Yes in the ITAR drop-down list. For a complete list of ITAR-regulated Microsemi FPGAs, visit the ITAR
web page.
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