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1 Preface

1.1 About this Document
This document explains how to install Libero SoC and the Linux packages required to run Libero SoC. It
also explains how to set up licensing.

This document contains the following sections:

• Preface
• Introduction
• Installation
• Appendix: Linux Packages to Run Libero SoC
• Appendix: Warning /Error Messages and Solutions
• Revision History
• Product Support

1.2 Intended Audience
This document is intended for users who will be running Libero SoC in a Linux environment.

1.3 References
The following document is referenced in this user guide.

1.3.1 Microsemi Publications
• Libero Software Installation and Licensing Guide 

http://www.microsemi.com/products/fpga-soc/design-resources/design-software/libero-soc#documents


Introduction

Revision 5 4

2 Introduction

This User Guide includes the following sections to enable you to run the Libero SoC Software in the
Linux environment:

• Install Libero SoC
• Set up licensing
• Installation of Linux packages required to run Libero SoC

2.1 Platform Support 
Libero SoC is supported on these Linux operating systems.

• RHEL5 64-bit
• RHEL6 64-bit
• RHEL7 64-bit (New with Libero SoC v11.8)
• CentOS 5 64-bit
• CentOS 6 64-bit
• CentOS 7 64-bit (New with Libero SoC v11.8)
• SuSE 11 SP4 (Libero only; FlashPro Express, SmartDebug, and Job Manager are not supported) 

Note: RHEL 5.x and CentOS 5.x do not support programming using FlashPro5.

2.1.1 Libero SoC Installation
Download the current release of Libero SoC for Linux from: 

http://www.microsemi.com/products/fpga-soc/design-resources/design-software/libero-soc#downloads

Follow the Installer UI prompts and install Libero. Ensure that the user accounts that will be used to
execute Libero have read access to the Libero installation area.

http://www.microsemi.com/products/fpga-soc/design-resources/design-software/libero-soc#downloads
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3 Installation

3.1 Step 1—Download License Daemons, License 
File, and Set Up Licensing on License Server
For some sites, the site's system administration policy requires a special user account to be set up for
administering site-wide licenses for all applications. The account "<caeadmin>" is just a hypothetical user
account name for this purpose. Use your regular user account (e.g., user_john) for these steps if it is
allowed at your site.

3.1.1 Download License Daemons
1. Open a terminal window by selecting Applications -> System Tools -> Terminal.
2. (Optional) At the Linux prompt, type su - <caeadmin> to switch to user "<caeadmin>" (assuming that 

your licenses are set up by a special user account called "<caeadmin>"). 
Note: Skip this step if your site's system administration policy allows a regular user to set up licens-
ing.

3. Get the hardware MAC-ID of the Linux Host you want to use as the License Server. 
a.    Type ifconfig | grep eth0
b.    The output from the command should be similar to: eth0 Link encap:Ethernet HWaddr 

00:0C:29:66:78:72
c.    Record the 12-digit hex number. Leave out the colon ":". You will need this HostID to get the 

license file.
4. Download the License Server Daemons for Linux from the following location:

http://www.microsemi.com/products/fpga-soc/design-resources/licensing#downloads

3.1.2 Request a Libero SoC License
5. Login to your Microsemi SoC customer portal http://soc.microsemi.com/portal/default.aspx?v=0 and 

request a new "Libero Silver Floating License for Windows or Linux Server". Use the recorded MAC-
ID from the previously entered ifconfig command (Step 3). 

6. Download the license file to the HOME directory of the user who will be installing and administering 
licensing for Libero.

3.2 Step 2—Add Packages to the Linux OS
A list of all required packages for RHEL5/6/7 and CentOS5/6/7 is provided in "Appendix: Linux Packages
to Run Libero SoC" on page 14".

Libero SoC requires the Linux system to have some special packages that may not be part of a standard
CentOS/RHEL distribution. To help you find out what additional packages are required, a shell script is
available in the <Libero_SoC_installed_location>/bin/check_linux_req directory. The script checks the
packages on the Linux system, identifies the required packages that are already installed, and lets you
know which packages need to be added. 

To run the script, at the prompt type:

% cd <Libero_SoC_installed_location>/bin/check_linux_req

% ./check_linux_req.sh

Note: This script is available beginning with the Libero SoC PolarFire v1.1 SP1 release (for PolarFire devices) 
and Libero SoC v11.8 SP1 Release (for all other devices).
Revision 5 5
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Red Hat uses the RPM (Red Hat Package Manager). However, the YUM (Yellowdog Updater Modified)
tool adds support for package management and dependency management. For this reason, YUM is the
preferred tool.

Installation  of  these  packages  requires  superuser  privileges  or  an  account  on  the  sudo  list.  Use
superuser account (root) or sudo access to run these commands:

1. Use the previously opened terminal or open a new terminal window by selecting Applications -> 
System Tools -> Terminal.

2. Do one of the following:
• At the prompt, type:

su -

• At the prompt, type:

sudo <commands>

3. Install the required packages as reported by the  check_linux_req.sh script:

yum install -y <package name>

4. Exit the root or sudo terminal after installation of all required packages

3.3 Step 3—Set Up Licensing (Floating License)
5. Unzip the previously downloaded licensing daemons file Linux_Licensing_Daemon.zip (from Step 

4): 
unzip Linux_Licensing_Daemon.zip; 

chmod 755 Linux_Licensing_Daemon/* 

6. Create a new directory called flexlm under <~caeadmin>: 
mkdir flexlm 

7. Move the previously downloaded license file (from Step 6) into the flexlm directory. 
8. Change directory into flexlm directory and unzip the License.dat file:

cd flexlm; 

unzip License.dat 

9. Start editing the License.dat file. Note: Linux filenames are case-sensitive.
gedit License.dat (if you are familiar with vi use vi License.dat) 

10. Edit the first four lines in the License.dat file to match your current environment: 
SERVER <localhost> <XXXXXXXXXXXX> 1702 <where <XXXXXXXXXXXX> is the 12-
digit MAC-ID of your Linux License server> 

DAEMON actlmgrd /home/<caeadmin>/Linux_Licensing_Daemon/actlmgrd 

DAEMON mgcld /home/<caeadmin>/Linux_Licensing_Daemon/mgcld 

VENDOR snpslmd /home/<caeadmin>/Linux_Licensing_Daemon/snpslmd

11. Replace the <XXXXXXXXXXXX> in the first line with the MAC-ID you have obtained from the 
ifconfig command.

12. Save the License.dat file and return to the <caeadmin> HOME directory (<~caeadmin>). 
Start the licensing server manager (lmgrd) by entering the following command (no line break): 
/home/<caeadmin>/Linux_Licensing_Daemon/lmgrd -c /home/<caeadmin>/flexlm/
License.dat -log /tmp/lmgrd.log 

13. Check the log file for errors: 
more /tmp/lmgrd.log 

14. If there are no errors, enter the following command:
tail -f -s10 /tmp/lmgrd.log

15. Leave the terminal window with the <caeadmin> account open. Whenever a license is checked in or 
out from the License Server, the tail command prints the information to the <caeadmin> terminal 
window. 

16. (Optional) Create the flexlm initialization script (see "Step 10—Create flexlm Initialization Script 
(Optional)" on page 11) to start the license server whenever the system boots up. An rc script is 
provided (Step 9).
Revision 5 6
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3.4 Step 4—Download and Install a PDF Reader
Note: If a PDF Reader is already installed, you can skip this step.

Libero requires a PDF reader to open the Libero Reference Manuals (Help > Reference Manuals).

3.5 Step 5—Set Up the User Environment Variables  to 
Start Libero SoC
This step sets up all user environment variables to run Libero SoC.

1. Open a terminal window by selecting Applications -> System Tools -> Terminal.
2. Use an editor and open the ~John/.bashrc file (for user John).
3. Use an editor to open and append the following four lines to the user startup file 

a.    For ~John/.bashrc (Bash-shell user John) 
# For Floating License from a License Server 

export LM_LICENSE_FILE=1702@localhost:$LM_LICENSE_FILE 

export SNPSLMD_LICENSE_FILE=1702@localhost:$SNPSLMD_LICENSE_FILE

# <1702> is the port number 

# <localhost> is the license server host name

#For Node-Locked License

export LM_LICENSE_FILE=<path_to_license.dat_folder>/license.dat:$LM_LICENSE_FILE 

export SNPSLMD_LICENSE_FILE=<path_to_license.dat_folder>/license.dat:$SNPSLMD_LICENSE_FILE                   

export LD_LIBRARY_PATH=/usr/lib:$LD_LIBRARY_PATH

export DISPLAY=:0

export PATH=/usr/local/microsemi/<Libero_current_rel>/Libero/bin:${PATH}

b.    For ~John/.cshrc (C-shell user John), append the following four lines:

#For Floating License from a License Server

setenv  LM_LICENSE_FILE=1702@localhost:$LM_LICENSE_FILE

setenv  SNPSLMD_LICENSE_FILE=1702@localhost:$SNPSLMD_LICENSE_FILE

# <1702> is the port number 

 # <localhost> is the license server host name

#For Node-Locked License

setenv LM_LICENSE_FILE=<path_to_license.dat_folder>/license.dat:$LM_LICENSE_FILE

setenv SNPSLMD_LICENSE_FILE=<path_to_license.dat_folder>/license.dat:$SNPSLMD_LICENSE_FILE

setenv LD_LIBRARY_PATH=/usr/lib:$LD_LIBRARY_PATH

setenv export DISPLAY=:0

setenv  PATH=/usr/local/microsemi/<Libero_current_rel>/Libero/bin:${PATH}

For details, refer to the instructions in the email you receive from Microsemi with the License.dat file.

For more information about licensing, refer to the Libero Software Installation and Licensing Guide. 

3. Save the .bashrc or .cshrc file and update your terminal window by typing source ~/.bashrc or 
source ~/.cshrc. (Alternatively, close the current window and open a new terminal window.)

4. Start Libero with the command "libero &". 

3.6 Step 6—Setting the Vault to Store IP Cores
Before IP cores from the IP catalog are available for use, the IP Cores must be downloaded and stored in 
a physical disk location called the Vault. To set the vault location, from the Project menu, select 
Vault/Repositories and then the Vault Location tab (Project > Vault/Repositories Settings > Vault 
Revision 5 7
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Location), and enter the disk location. The user must have write permission to the disk location before it 
can be set as the vault location. A warning message displays if the user does not have write permission.

Vault locations can be set to a disk location on a per-user basis or set to a central location for all users.

• One  vault location per user 

The individual user downloads and stores IP cores into this location. An internet connection is 
required for download. The individual user is responsible for maintaining the IP core versions and 
their availability in this vault.

• One single central vault location for multiple users

The System Administrator downloads and stores IP cores into this location. An internet connection is 
required for download. The System Administrator is responsible for maintaining the IP core versions 
and their availability. Multiple Individual users, who may not have an internet connection (and there-
fore cannot download IP cores), can set the vault to this central location and use the cores in the 
vault. 

Note: The individual user must have write permission to the disk location of this central vault.  If the 
user does not have write permission, he must copy the central vault to a disk location where he has 
write permission and set the vault to this copied location. 

3.7 Step 7—Downloading IP Cores
In the Libero GUI, click View > Windows > Catalog. The catalog tab indicates the availability of new
cores. Click "Download them now!" (Figure 1).
Revision 5 8
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Figure 1 •   Libero SoC IP Cores Downloading

3.8 Step 8—Setting the PDF Reader and Web Browser 
1. Set the PDF Reader (Project > Preferences > PDF Reader) to a PDF Reader, e.g.

/usr/bin/acroread.

2. Set the Web Browser to a browser of your choice (Project > Preferences > Web Browser), e.g.
/usr/bin/firefox.
Revision 5 9
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Figure 2 •   Project Preferences for PDF Reader

Figure 3 •   Project Preferences for Web Browser
Revision 5 10
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3.9 Step 9—Configure Linux to Detect and Use 
FlashPro5 Programmer Hardware
If you want a regular user (without root permission) to program the Flash based FPGA devices with
FlashPro5 hardware, you must run the udev_install script on the Linux machine as root. The udev_install
script helps you set up a udev rule file for the FLashPro5 hardware.

This udev rule authorizes the Linux user group (that you specify during execution of udev_install script) to
access the FlashPro5 hardware without sudo or root permission. 

1. At the prompt, type su -.
2. Change directory to the <caeadmin> HOME directory: cd /home/<caeadmin>.
3. Execute the udev_install script with the following option: ./udev_install -t /tmp.
4. The previous command generates a template file called "70-microsemi.rules" in the /tmp directory.
5. Modify the template file to match your group ID of the user "john" connecting the FlashPro5 

hardware (assuming the user "john" will attach the FlashPro5 hardware):
a.    Open a terminal and run the command id as user john. The output should be similar to the

following text: uid=500(john) gid=500(john)….
b.    Return to your terminal with root access. Open the "70-microsemi.rules" in an ASCII editor.
c.    Replace the "" with your current group ID # in the following two lines:

BUS=="usb",SYSFS{idProduct}=="2008",SYSFS{idVen-
dor}=="1514",MODE="0660",GROUP="",SYMLINK+="FlashPro5"

BUS=="usb",SYSFS{idProduct}=="6001",SYSFS{idVen-
dor}=="0403",MODE="0660",GROUP="",SYMLINK+="FTDI232"

Assuming the user john has "uid=500" and "gid=500", the line after editing should look like this:

BUS=="usb",SYSFS{idProduct}=="2008",SYSFS{idVendor}=="1514",MODE="0660"\ 
,GROUP="500",SYMLINK+="FlashPro5"

BUS=="usb",SYSFS{idProduct}=="6001",SYSFS{idVendor}=="0403",MODE="0660"\ 
,GROUP="500",SYMLINK+="FTDI232"

6. Move the "70-microsemi.rules" file to the proper location: 
mv /tmp/70-microsemi.rules /etc/udev/rules.d/

3.10 Step 10—Create flexlm Initialization Script 
(Optional)
The Linux boot process allows services to be started with the help of startup scripts. The flexm script
automatically launches the licensing server during the boot process and also properly shuts down the
license daemon when the license server machine shuts down. This script eliminates the need to
manually restart the licensing server after the license server Linux machine reboots. 

1. Open a new terminal window by selecting Applications > System Tools > Terminal.
2. At the prompt, type:

su - 

cd /etc/init.d

3. Start an editor with a new file flexlm.
4. Paste the following content into the editor:

#!/bin/bash 
# 
# flexlm This starts and stops flexlm 
# 
# description: Start or stop the flexlm license manager + vendor daemons 
# 
# Return values according to LSB for all commands: 
# 0 - success 
# 1 - generic or unspecified error 
Revision 5 11
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# 2 - invalid or excess argument(s) 
# 3 - unimplemented feature (e.g. "reload") 
# 4 - insufficient privilege 
# 5 - program is not installed 
# 6 - program is not configured 
# 7 - program is not running 
# 
# 
PATH=/sbin:/bin:/usr/bin:/usr/sbin 
LICENSE_FILE=/home/<caeadmin>/flexlm/License.dat 
LMGRD_HOME=/home/<caeadmin>/Linux_Licensing_Daemon 
LMGRD_LOGFILE=/tmp/lmgrd.log 
prog="flexlm" 
# Source function library. 
. /etc/init.d/functions 
# Check license file 
test -f $LICENSE_FILE || exit 6 
            RETVAL=0    

Start () {

test -x $LMGRD_HOME/lmgrd || exit 5
echo -n $"Starting Microsemi $prog: "
su -c "$LMGRD_HOME/lmgrd -c $LICENSE_FILE -log $LMGRD_LOGFILE" - 
caeadmin
RETVAL=$?
return $RETVAL

}
stop(){

echo -n $"Stopping Microsemi $prog: "
su -c "$LMGRD_HOME/lmutil lmdown -c $LICENSE_FILE -q" - caeadmin
RETVAL=$?
return $RETVAL

}
status(){

su -c "$LMGRD_HOME/lmutil lmstat -c $LICENSE_FILE" - caeadmin
RETVAL=$?
return $RETVAL

}
reload(){

stop
start

} 
restart(){ 

stop 
start 

} 
case "$1" in 

              start)

start 

;; 
  stop) 

stop 
Revision 5 12
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;; 
  status) 

status 
;; 

  restart) 
restart 
;; 

  reload|force-reload) 
reload 
;; 

*) 
echo $"Usage $0 {start|stop|status|restart|reload|force-reload}"

RETVAL=3

esac

exit $RETVAL

5. Save the file and exit the editor. 
6. Change the permission of the flexlm file to rxwr-xr-x as follows:

chmod 755 flexlm 

7. Create links for the Linux boot/shutdown process under the /etc/rc.d/rc5.d directory: 

cd /etc/rc.d/rc5.d  

ln -s ../init.d/flexlm S98flexlm

ln -s ../init.d/flexlm K98flexlm 

8. Check the content of the License Log File /tmp/lmgrd.log file if you encounter any issues. 
Revision 5 13
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4 Appendix: Linux Packages to Run Libero 
SoC

Libero supports RHEL5/CentOS5, RHEL6/CentOS6, and RHEL7/CentOS7. Libero SoC requires the
following Linux packages to be installed prior to running Libero SoC.

Packages required for RHEL5/CentOS5

• glibc.i686 
• expat.i386
• fontconfig.i386 
• freetype.i386 
• libgcc.i386 
• libICE.i386 
• libpng.i386 
• libSM.i386 
• libstdc++.i386 
• libX11.i386 
• libXau.i386 
• libXcursor.i386 
• libXdmcp.i386 
• libXext.i386 
• libXfixes.i386 
• libXinerama.i386 
• libXi.i386 
• openmotif22.i386 
• libXmu.i386 
• libXp.i386 
• libXrandr.i386 
• libXrender.i386 
• libXt.i386 
• zlib.i386 
• glib2.i386 
• ksh.x86_64 
• xorg-x11-fonts-75dpi 
• xorg-x11-fonts-100dpi 
• xorg-x11-fonts-Type1 

Packages required for RHEL6/CentOS6

• glibc.i686 
• compat-expat1.i686 
• fontconfig.i686 
• freetype.i686 
• libgcc.i686 
• libICE.i686 
• libpng.i686 
• libSM.i686 
• libstdc++.i686 
• libX11.i686 
• libXau.i686 
• libXcursor.i686 
• libXdmcp.i686 
• libXext.i686 
Revision 5 14
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• libXfixes.i686 
• libXinerama.i686 
• libXi.i686 
• openmotif22.i686 
• libXmu.i686 
• libXp.i686 
• libXrandr.i686 
• libXrender.i686 
• libXt.i686 
• zlib.i686 
• glib2.i686 
• ksh.x86_64 
• xorg-x11-fonts-75dpi 
• xorg-x11-fonts-100dpi 
• xorg-x11-fonts-Type1 

Packages required for RHEL7/CentOS7

• glibc.i686
• fontconfig.i686
• freetype.i686
• libgcc.i686
• libICE.i686
• libpng.i686
• libSM.i686
• libstdc++.i686
• libX11.i686
• libXau.i686
• libXcursor.i686
• libXdmcp.i686
• libXext.i686
• libXfixes.i686
• libXinerama.i686
• libXi.i686
• motif.i686
• ibXmu.i686
• libXp.i686
• libXrandr.i686
• libXrender.i686
• libXt.i686
• zlib.i686
• glib2.i686
• ksh.x86_64
• xorg-x11-fonts-75dpi
• xorg-x11-fonts-100dpi
• xorg-x11-fonts-Type1
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5 Appendix: Warning /Error Messages and 
Solutions

Linux users may encounter some or all of the following error messages. The solution for each is
described in this appendix.

• Error: Could not locate the Motif library in LD_LIBRARY_PATH
• Warning: Unknown locale
• Wind/U X-toolkit Error: wuDisplay: Can't open display
• Wind/U Error: Failed to connect to the registry on server
• Wind/U Error: A fatal registry I/O failure has occurred. A registry daemon may not be running.
• Designer GUI Appears Stretched When Running On Linux 
• Libero GUI is Distorted on Older Versions of Red Hat 5 Through VNC
• Libero GUI Fails to Start When Pre-loading a Project
• Viewing PDF Files and Online Help Files
• Segmentation fault "$exedir/$exename" "$@" message
• Warning: Failed to contact web Repositories
• JRE libraries are missing or not compatiblen
• Libero Installer stalled on Red Hat/CentOS 6.x
• Error when Installing Linux Packages
• During Installation Warning Message appears: /tmp does not have enough disk space
• X libraries not in LD_LIBRARY_PATH (Libero)
• Missing libgthread-2.0.so.0 libraries (Libero)
• Missing MOTIF libraries (Libero)
• Missing libncurses.so.5 libraries (ModelSim)
• Missing libXrender libraries
• Missing libfontconfig.sol.1 libraries
• Missing libfreetype.so.6 libraries
• Double Quotes around Vault Location Path on Linux installation
• Script "udev_install" to set up FlashPro fails on Linux
• Starting the License Manager gives Error on Linux

Wind/U Error: Failed to connect to the registry on server
Symptoms: Wind/U Error: Failed to connect to the registry on server [server_name]

Cause: This Error may indicate that there is a Linux security setting that prevents Libero from connecting
to the Wind/U Registry. This connection is typically made using a TCP port.

Solution: Resolve this error by modifying the Linux Security settings. For example, on RHEL5, navigate
to the desktop menu System > Administration > Login Screen > Security Tab and Uncheck the Security
Setting Deny TCP connections to Xserver. After making this change you must restart your computer for
the changes to take effect.

Run the actel_wuclean command to clean up any left-over processes.  At the command prompt:

% ./actel_wuclean -R -D

Warning: Unknown locale
Symptoms: Warning (241): Unknown locale specified locale:en_US.iso885915 LANGUAGE:
UNDEFINED SUBLANGUAGE: Wind/U Warning (241): Unknown locale specified locale:
en_US.iso885915 LANGUAGE:UNDEFINED SUBLANGUAGE:
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The four tabs on the lower left of the GUI are also displayed incorrectly.

Cause: This is caused by incorrect language setting on the Operating System.

Solution: Set the locale [elcap] with the following command:

% setenv LANG en_US

Note: if you experience this problem often, please add the above command to your shell setup (such as
.cshrc or .bashc) file.

Warning: Failed to contact web Repositories
The warning message "Failed to contact Web Repositories" appears in the Libero catalog window if any
one of the following conditions is true:

• You do not have a connection to the Internet.
• You do not have write permission to the disk location you have set your vault to.
• Your vault location runs out of disk space. (For the Linux environment, Libero's vault location is set 

by default to your user directory in ~/.actel/vault. If your work site imposes quota restrictions on the 
size of user directories, you user directory may run out of disk space).

• A firewall prevents access to the Web Repositories.

To correct the problem:

1. Check that you have an Internet connection.
2. Check that you have write permission to the vault location or change your vault location setting to a 

location that you have write permission (Project > Vault/Repositories Settings > Vault location).
3. Increase the disk space for the vault location to a minimum of 850 MB.
4. Contact your IT department about the firewall issue.

Error: Could not locate the Motif library in LD_LIBRARY_PATH
Cause: Libero uses Motif Graphical Toolkit Library for its Graphical Interface on Linux. RHEL OS
installation may not include a Motif Library.

Solution: If you have the Motif Library Installed, there should be an Environment Variable called
LD_LIBRARY_PATH that points to the location of the Motif Library. Ensure that the path of the Motif
Library is contained in the LD_LIBRARY_PATH Environment Variable. You can add the path with the
command:

set LD_LIBRARY_PATH = (<path to Motif Library> $LD_LIBRARY_PATH)

If you are not sure whether you have the Motif Library Installed, try the following commands: The
command "rpm -qa | grep -i motif" lists which Motif Library is installed.

The command "rpm -qal | grep -i motif" lists the files and paths associated with the motif library listed
above (notice the extra "l" in the second command).

If you do not have a Motif Library Installed, consider downloading and installing OPEN Motif for free from
http://www.openmotif.org/.

Libero Linux tools expect to see the libXm.so.3 package of the Motif Library. Different versions of OPEN
Motif could potentially install libXm.so.4 or others that are not compatible with Libero. Ensure that the
version of OPEN Motif used installs libXm.so.3. One example version that provides libXm.so.3 is
openmotif v2.2.3. Since Libero is a 32-bit application, the 32-bit Motif Library must be used even if the
computer is running a 64-bit Operating System.

Wind/U X-toolkit Error: wuDisplay: Can't open display
Set the $DISPLAY environment variable to:0 using the command:

setenv DISPLAY :0

Then run the command:

<Libero_Installation_Folder>/Libero/bin/actel_wuclean -R to clean up any 
processes left over from the first invocation of Libero
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Wind/U Error: A fatal registry I/O failure has occurred. A registry daemon 
may not be running.
Symptoms: Wind/U Error (251): Function RegPingDaemon - A fatal registry I/O failure has occurred. A
registry daemon may not be running. Restart your application and verify that a registry daemon is
running:

Wind/U Error (251): Function RegOpenKeyExA - A fatal registry I/O failure has 
occurred. A registry daemon may not be running. Restart your application and 
verify that a registry daemon is running.

Solution/Workaround: Run the 'actel_wuclean' utility found in the bin folder. Use the '-R' option as
follows:

.../bin/actel_wuclean -R

The following messages may appear:

Shutting down Actel applications.
All actgen_bin processes are shut down.
 
All smartgen_bin processes are shut down. 
All expert_bin processes are shut down.
All mvn_bin processes are shut down. 
All libero_bin processes are shut down. 
Shutting down Wind/U daemons...
All windu_scmd processes are shut down.
All windu_serviced processes are shut down. 
All windu_registryd processes are shut down.
Removing Wind/U temporary files from the temporary directories...
Removing cached Wind/U files from the home directory... 
Done

The actel_wuclean utility shuts down any Microsemi tools running on the same host by the same user.
Save any work you may have before invoking actel_wuclean. 

Segmentation fault "$exedir/$exename" "$@" message
Scenario 1: When trying to invoke Libero SoC 10.1 on Linux Red Hat 5.4 (32bit or 64-bit), Libero may
crash with segmentation fault message

Description: When you invoke Libero SoC v10.1 on Linux Red Hat 5.4 machine, Libero does not come
up and a crash with segmentation fault message is issued. For example:

<line 67: 10617 Segmentation fault       "$exedir/$exename" "$@">

Solution/Workaround: The templates file at <Installation-path-to-libero-10.1>/data/catalogs/
templates.xml may get corrupted and cause the crash. To resolve this issue, rename the file at
<Installation-path-to-libero-version>/data/catalogs/templates.xml to templates.xml.ori.

Make sure that there is enough disk space in the user's home directory, ~<user_name>.  

Run the "check_linux_req" script to make sure that all required packages have been installed on the
system.

Scenario 2: Multiview Navigator errors are reported upon opening the Constraints Editor.

Description: The following messages are displayed on the Linux terminal when the Floorplan
Constraints Editor is opened:

Start Server 1
Start Server 2
Failed to open Def Table: 9
Failed to open Def Table: 8
Failed to open Def Table: 12
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Running in orphan mode!

The following message appears on exiting MVN and a core file is created:

…/bin/mvn: line 69: 1675 Segmentation fault
(core dumped) "$exedir/../lib/$exename" "$@"

Solution/Workaround: These errors can be ignored.

Designer GUI Appears Stretched When Running On Linux 
Note: Designer is for IGLOO, SmartFusion, Fusion and ProASIC3 devices only.

Scenario: Log onto a Linux machine, then run Designer software

Symptoms: Some of the GUIs appear stretched

Description: Some Designer GUIs appear stretched on Linux when directly logged into the machine.
This is due to issues with mismatched color depths on the GUI and desktop

Solution/Workaround: Change the desktop color depth to resolve the issue. For Linux access via VNC,
change the color depth of the vncserver to 8, 16 or 24. Refer to the vncserver manual pages for details.

Libero GUI is Distorted on Older Versions of Red Hat 5 Through VNC
Scenario: The Libero GUI may appear distorted when VNC is used with Linux Red Hat versions older
than 5.3.

Description: When using VNC and Linux RH 5.2 or older, Libero GUI, fonts and background colors may
appear slightly faded or fuzzy. This issue is not unique to Libero but affects all Qt based software
including Synplify Pro. The problem is caused by the VNC server (Xvnc) not loading Xrender by default in
these older versions of RHEL 5.

Note that there should be no issue when using Linux RHEL 5 (Tikanga) 5.3 to 5.75 (32-bit and 64-bit).

Workaround/ Solution:

When using RHEL 5.2 (and older) with VNC:

• Microsemi has tested and recommends using Exceed 11 if possible. This version of Exceed is still 
on the support list at OpenText.

                                       Or

• Upgrade to a newer version of VNC server (Xvnc) that enables Xrender by default. One version that 
has been tested is Tiger (an open source vncserver that is available from 
http://sourceforge.net/projects/tigervnc/files/tigervnc/) VNC v1.2.0 instead of the default VNC server 
on RHEL 5.2.

Libero GUI Fails to Start When Pre-loading a Project
Scenario: Your most recent project file may have been corrupted and causes Libero to crash trying to
open the corrupted project file.

Solution: To change your user settings to prevent Libero from automatically opening your last project
when it invokes:

1. Open ~/.actel/libero.def.
2. Add the following line to the file: data IDE_OPEN_MRU_PROJECT 0.
3. Start Libero using <path_to_libero_install>/bin/Libero.

Viewing PDF Files and Online Help Files
To view online Help files and PDF files, you may need to set environment variables
LINUX_HTMLREADER to the full path of your web browser in your terminal before invoking Libero. For
example:

csh (C-shell):

setenv LINUX_HTMLREADER /usr/bin/firefox
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sh (Borne Shell)/ ksh (Korn Shell):

LINUX_HTMLREADER=/usr/bin/firefox; export LINUX_HTMLREADER

If you do not set the environment variable, some HTML files (such as the online help) will not be viewable
from within Libero.

JRE libraries are missing or not compatible
This is a Libero Installer Error message.

Description: The Installer script requires some Java Libraries to run and the libraries are missing. 

Solution: 

1. Go to the following Java Download website and install the missing Java libraries:

http://www.java.com/en/download/manual.jsp#lin

2. To download the 32-bit version, select "Linux RPM". The Instructions on how to install the RPM are 
under "Instructions" link located to the right of the "Linux RPM" link.

3. To download the 64-bit version, select "Linux x64 RPM". The Instructions on how to install the RPM 
are under "Instructions" link located to the right of the "Linux x64 RPM" link.

Figure 4 •   Java Download Website

Note: Alternatively, you may install the latest OpenJDK JRE as follows:

% su
% yum install java

4. If the installer still fails and you are using CentOS 6, run the installer as follows:

LiberoSoc_v<version>Linux_bin LAX_VM  <path_to_JRE>/java.exe

This forces the Libero Linux Installer to use the Java executable in the specified path.

Libero Installer stalled on Red Hat/CentOS 6.x
Description: Installation starts but then stalls half-way through installation when installing Libero on Red
Hat/CentOS 6.x machines. In the System Monitor, the Waiting Channel of the process is
futex_wait_queue_me.

Solution: Update the system kernel to version 2.6.32-504.16.2.el6.x86_64

Error when Installing Linux Packages
Description: Error Message while installing Linux packages: Protected multilib versions ……

Cause: There is package incompatibility between i686 (32-bit) and x86_64 (64-bit) packages when 32-bit
Linux packages are installed. 
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Solution: First upgrade the packages to 64-bit and then install the 32-bit package, e.g. for the gtk2
package, the commands are:

% su

% yum upgrade gtk2

% yum install gtk2.i686

During Installation Warning Message appears: /tmp does not have 
enough disk space
Cause: The Installer runs out of disk space in /tmp and tries to use /home/user instead, which also has
less disk space than required.  

Solution: At the Linux prompt, set the environment variable IATEMPDIR to a disk location with enough
disk space as follows:

• For Borne Shell (sh), Korn Shell (ksh), bash and zsh users:

% IATEMPDIR=/your/free/space/directory

%  export IATEMPDIR

• For C-shell (csh) and tcsh users:

setenv IATEMPDIR= /your/free/space directory

X libraries not in LD_LIBRARY_PATH (Libero)
Description: Libero has a dependency on the X Libraries but cannot find it.

Solution: 

1. Install the libXft package:

yum install libXft.i686

2. Set your LD_LIBRARY_PATH to include the libXft Libraries. 

Missing libgthread-2.0.so.0 libraries (Libero)
Description: Libero has a dependency on the glib2 Libraries but cannot find it.

Solution: 

1. Install the glib2 package:

yum install glib2.i686

Note: If the yum install command errors out because of a version conflict with x86_64 version already
installed, use the yum update command instead: 

yum update glib2 

2. Set your LD_LIBRARY_PATH to include the glib2 Libraries. 

Missing MOTIF libraries (Libero)
Description: Libero has a dependency on the MOTIF libraries but cannot find them.

Solution: 

1. Install the MOTIF libraries:

yum install openmotif (for CentOS 5/RedHat 5)

yum install openmotif22 (for CentOS 6/RedHat 6)

yum install motif (for CentOS7/RedHat 7)

2. Set your LD_LIBRARY_PATH to include the MOTIF Libraries.  
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Missing libncurses.so.5 libraries (ModelSim)
Description: ModelSim Simulator has a dependency on the libncurses.so.5 libraries but cannot find
them.

Solution:

Install the current package version of ncurses libraries:

1. yum install ncurses-libs.i686
2. Set your LD_LIBRARY_PATH to include the ncurses libraries.

Missing libXrender libraries
Description: Libero has a dependency for libXrender libraries but cannot find them.

Solution:

Install the current libXrender libraries:

1. yum install libXrender.i686
2. Set your LD_LIBRARY_PATH to include libXrender libraries.

Missing libfontconfig.sol.1 libraries
Description: Libero has a dependency for libfontconfig libraries but cannot find them.

Solution:

Install the libfontconfig libraries:

1. yum install fontconfig-2.8.0-3.el6.i686 (for Red Hat) or yum install 
fontconfig-2.8.0-5.el6.i686 (for CentOS).

2. Set your LD_LIBRARY_PATH to include libfontconfig libraries.

Missing libfreetype.so.6 libraries
Description: Libero has a dependency for libfreetype libraries but cannot find them.

Solution:

Install the current freetype libraries:

1. yum install freetype-2.3.11-14.el6_3.1.i686
2. Set your LD_LIBRARY_PATH to include the freetype libraries.

Double Quotes around Vault Location Path on Linux installation
Symptom: After console mode installation on Linux, the vault location displayed under Project > vault/
repositories setting shows <path install libero>/bin "<path common directory>/vault". The double quotes
around the vault path location should be removed.

Problem: The install.def file has double quotes around the variable for the vault location.

Workaround: Exit Libero, update the install.def file, and restart Libero.

1. Exit Libero.
2. At the Linux shell prompt, go to <Libero_installed_path>/data directory:

% cd <Libero_installed_path>/data

3. At the Linux shell prompt, apply the sed command to remove the double quotes in the install.def file:

% sed 's/"//g' install.def > tmp.def

% cp tmp.def install.def

% rm tmp.def

4. Restart Libero to check that the double quotes around the vault location path are removed.
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Script "udev_install" to set up FlashPro fails on Linux
Symptom: When running the "udev_install" script to set up FlashPro on Linux, the script fails with error
message:

% ./udev_install
/bin/sh^M: bad interpreter: No such file or directory

Problem: The script uses Windows CR/LF line termination instead of Unix/Linux LF only line termination
and, as such, is not a valid shell script for Linux.

Workaround: Users must run dos2unix command on the script "udev_install" to convert Windows CR/
LF line termination to Linux LF only line termination and run the script again. At the Linux shell prompt:

% dos2unix udev_install
% ./udev_install

Note:   If dos2unix is not available, run the following command to install dos2unix, then run dos2unix:

% sudo yum install dos2unix

Starting the License Manager gives Error on Linux
Symptom: When running lmgrd to start the License Manager on Linux, the system gives this error
message:

12:39:28 (actlmgrd) Vendor daemon can't talk to lmgrd (License server machine 
is down or not responding. (-96,7:2 "No such file or directory"))
12:39:28 (actlmgrd) EXITING DUE TO SIGNAL 37 Exit reason 5

Problem: The host is not recognized due to a problem in the /etc/hosts file on the Linux system.

Solution:

1. At the Linux prompt, edit the /etc/hosts file and add the following lines:

# IP address Hostname Alias
127.0.0.1 localhost <hostname>

Note:   <hostname> is the name of the Linux system.

2. Restart lmgrd.
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6 Revision History

The following table shows important changes made in this document for each revision.

Revision Changes 

Revision 1
(June 2016)

Initial release.

Revision 2
(October 2016)

Updated Chapter 3 - Installation.

Revision 3
(April 2017)

Updated Appendix to support RedHat/CentOS 7. Reversed the order of Installing 
Licenses and Adding Packages - Adding Packages should come before installing 
licenses.

Revision 4
(June 2017)

Updated Paragraph 3.2 to include shell script to check for required packages.

Revision 5
(June 2017)

Remove “compat-expat1.i686” from RHEL7/CentOS7 required packages list in 
Appendix: Linux Packages to Run Libero SoC.
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7 Product Support

Microsemi SoC Products Group backs its products with various support services, including Customer
Service, Customer Technical Support Center, a website, electronic mail, and worldwide sales offices.
This appendix contains information about contacting Microsemi SoC Products Group and using these
support services.

7.1 Customer Service
Contact Customer Service for non-technical product support, such as product pricing, product upgrades,
update information, order status, and authorization.

From North America, call 800.262.1060
From the rest of the world, call 650.318.4460
Fax, from anywhere in the world, 650.318.8044

7.2 Customer Technical Support Center
Microsemi SoC Products Group staffs its Customer Technical Support Center with highly skilled
engineers who can help answer your hardware, software, and design questions about Microsemi SoC
Products. The Customer Technical Support Center spends a great deal of time creating application
notes, answers to common design cycle questions, documentation of known issues, and various FAQs.
So, before you contact us, please visit our online resources. It is very likely we have already answered
your questions.

7.3 Technical Support
For Microsemi SoC Products Support, visit http://www.microsemi.com/products/fpga-soc/design-
support/fpga-soc-support.

7.4 Website
You can browse a variety of technical and non-technical information on the Microsemi SoC Products
Group home page, at www.microsemi.com/soc.

7.5 Contacting the Customer Technical Support 
Center
Highly skilled engineers staff the Technical Support Center. The Technical Support Center can be
contacted by email or through the Microsemi SoC Products Group website.

7.5.1 Email
You can communicate your technical questions to our email address and receive answers back by email,
fax, or phone. Also, if you have design problems, you can email your design files to receive assistance.
We constantly monitor the email account throughout the day. When sending your request to us, please
be sure to include your full name, company name, and your contact information for efficient processing of
your request.

The technical support email address is soc_tech@microsemi.com.

7.5.2 My Cases
Microsemi SoC Products Group customers may submit and track technical cases online by going to My
Cases.
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7.5.3 Outside the U.S.
Customers needing assistance outside the US time zones can either contact technical support via email
(soc_tech@microsemi.com) or contact a local sales office.

Visit About Us for sales office listings and corporate contacts.

Sales office listings can be found at www.microsemi.com/soc/company/contact/default.aspx.

7.6 ITAR Technical Support
For technical support on RH and RT FPGAs that are regulated by International Traffic in Arms
Regulations (ITAR), contact us via soc_tech_itar@microsemi.com. Alternatively, within My Cases, select
Yes in the ITAR drop-down list. For a complete list of ITAR-regulated Microsemi FPGAs, visit the ITAR
web page.
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