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Introduction 

The purpose of this document is to provide clear step-by-step instructions to take you through the first usage of the MPM GUI 

and design examples. The tutorial illustrates the usage of power sequencing and timing slots, trimming options and I2C 

communication.  

Software Installation 

Software Requirements 

1. MPM 6.0 for SmartFusion GUI and Design Files Installer 

http://www.actel.com/download/rsc/?f=SmartFusion_DMPM_DF 

2. Installed version of FlashPro Software, either as part of a full Libero
®
 SoC install (automatic) or standalone FlashPro 

installation from www.microsemi.com/soc/download/program_debug/flashpro/default.aspx 

3. USB to UART driver for development kit, if not already installed 

 http://www.actel.com/documents/CDM_2.08.24_WHQL_Certified.zip 

 

Run the installer and follow the installation wizard instructions. By default MPM installs into the 

C:\Microsemi\SF2_MPM_RefDesign_v6.0 folder and this is the recommended location for it. In particular 

avoid installing it in a folder than is very deeply nested or has a very long path name otherwise some tools 

may encounter problems accessing files with names longer than 259 characters
1
.  

Once installed MPM adds the following options to the Windows start menu: 

 Start 

 All Programs 

o Microsemi SmartFusion2 MPM Reference Design v6.0 

 Browse Design Files 

 Opens in Windows Explorer the folder containing the MPM Libero 

SoC hardware and SoftConsole firmware projects 

 MPM GUI 

 Runs the MPM GUI 

 Uninstall 

 Uninstalls MPM 

Hardware Setup 

Hardware Requirements 

This section explains how to prepare the hardware for programming the MPM reference design and running the 

default demonstration. 

You will need the following: 

1. SF2-DEV-KIT: SmartFusion2 Development Kit (Rev B or C Silicon/Board) 

http://www.actel.com/products/hardware/devkits_boards/smartfusion2_dev.aspx 

a. 12V Wall-mounted Power Supply 

2. SF2-DMPM-DC-KIT: SmartFusion2 Digital Mixed-Signal Power Management Daughter Card 

    a.     12V Wall-mounted Power Supply 

3. Devantech USB-ISS I2C communication module 

http://www.robot-electronics.co.uk/acatalog/USB_I2C.html 

a. (1) USB type A cable 

b. (3) Jumper wires 

http://www.actel.com/download/rsc/?f=SmartFusion_DMPM_DF
http://www.microsemi.com/soc/download/program_debug/flashpro/default.aspx
http://www.actel.com/documents/CDM_2.08.24_WHQL_Certified.zip
http://www.actel.com/products/hardware/devkits_boards/smartfusion2_dev.aspx
http://www.robot-electronics.co.uk/acatalog/USB_I2C.html
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4. FlashPro4 

a.  (1) USB Mini-B cable 

5. USB Mini-B Cable 

SmartFusion2 Development Kit Board Setup 

The following provides basic setup information for the hardware and firmware for the DMPM 6.0 Beta Release. The setup 

is based on the initial porting of MPM to the SmartFusion2 platform with the Rev B Dev Kit and the Rev A DMPM board. 

The following jumper settings are required on the SmartFusion2 Dev Kit to route the signals required for the DMPM 

board to the FMC connector. 

Ensure that the following jumpers are installed: 

Jumper Pins Jumper Pins 

J174 2-3 J172 2-3 

J184 2-3 J175 2-3 

J179 2-3 J195 2-3 

J200 2-3 J194 2-3 

J202 2-3 J210 2-3 

J201 2-3 J209 2-3 

J155 2-3 J146 2-3 

J140 2-3 J138 2-3 

J158 2-3 J154 2-3 

J143 2-3 J141 2-3 

J111 2-3 J133 1-2 

J214 2-3 J213 2-3 

J178 2-3 J188 2-3 

J187 2-3 J197 2-3 

J196 2-3 J145 pin 2 connected via flying lead to J199 pin 3 
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The Dip switch SW10 is used to provide another 4 of the MPM inputs and also 

to select optional operational modes for MPM. 

SW10.1 is connected to MPM input 5. 

SW10.2 is connected to MPM input 6. 

SW10.3 is connected to MPM input 7. 

SW10.4 is connected to MPM input 8. 

SW10.1 also selects whether MPM shuts down if a POL goes 

to OV2 or UV2 or not. When OFF MPM does not shut down 

and when ON MPM does shut down. 

SW10.2 selects whether MPM reloads the configuration in 

eNMV with known good values on power up or not. 

*******SET SW10.2 to the OFF position******* 

 

J20, J21, J22 and J25 should have their jumpers removed as they currently replicate the signals going to 

LEDs 5 to 8 to provide convenient access for logic analysers or oscilloscopes to measure task timing in 

MPM. 

SF2 DMPM Daughter Board Setup 

 

JP23 should have pins 1 and 2 jumpered and J24 should be jumpered to provide 3.3V and 2.5V supplies to 

the DMPM board from the FMC connector. 

J22 should have 7 x 3 jumpers installed as shown above, to link the 8 DPOLs to PMBus 1. The last pair of 

pins labeled PMBUS2 are unjumpered but are used to connect the Devantech USB Adaptor as shown 

below. A suitable ground connection for this can be found on J3 - second pin from the left on the bottom row. 
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For the APOLs on the DMPM board JP3, JP26, JP27, JP28, JP2, JP29, JP30 and JP31 must be jumpered 

to enable trimming. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

For the DPOLs on the DMPM board JP21, JP22, JP32 and JP33 must be jumpered on pins 1 and 2 to route 

the regulator enables of the first 4 DPOLs to the FMC connector. 

 

 

 

 

 

 

 

 

 

 

 

 

Programming MPM 
The first time you use MPM you need to use the MPM GUI to program the MPM design to the target 

hardware. 

 For the SmartFusion2 Development Kit Board 

 Connect the 12V 6A power supply to the J18 12V INPUT SUPPLY connector 

 Connect a FlashPro4 programmer to the J59 – FP4 Header 

 Connect a mini USB cable between your PC and the FlashPro4 

 Power the board on using SW7 
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 Run the MPM GUI.  

 Select Data > FlashPro > Choose STAPL template and select the appropriate STAPL file for 

your target hardware from the C:\Microsemi\SF2_MPM_RefDesign_v6.0\template folder.
1
 

o Use MPM_M2S050T_ES_template.stp for Rev B silicon on the LCP kit. 

o Use MPM_M2S050T_template.stp for Rev C silicon on the PP kit. 

 Select Data > FlashPro > FlashPro Setup and browse to and select the FlashPro software 

executable in your Libero SoC v10.1 or later installation. 

 Select Data > FlashPro > Write NVM & Fabric and the MPM GUI will launch FlashPro and 

program the full design (MSS configuration, MPM firmware, MPM configuration data in ENVM 

along with the FPGA fabric logic) to the target hardware. You will see a Command Shell “DOS 

Box” appear reporting progress. When prompted you can close this. At this stage the MPM target 

should be programmed with the MPM reference design. 

 Power off the SmartFusion2 board by disconnecting the USB cable and power supply cables. 

 Connect the SF2 DMPM Daughter Board to the SmartFusion2 Development Kit Board by connecting their 

respective FMC connectors. 

 Connect the 12V power supply to the SF2 DMPM Daughter Board’s J1 12V DC IN connector 

 Reconnect power and USB to the SmartFusion2 Dev Kit as described above. 

 Power the MPM Daughter Board on using SW2 

 Reset the SmartFusion2 board by pressing SW9 RESET. 

 Once the initial programming of the MPM design to the target has been performed then MPM configuration 

setting changes alone can be programmed to the target’s MSS ENVM over an I
2
C connection between the 

MPM GUI and the MPM target hardware using Data > I
2
C > Read Config Via I

2
C and Write Config Via I

2
C. 

I
2
C Setup 

Use the MPM GUI to connect to the MPM target via I
2
C the included Devantech/Robot Electronics USB-ISS 

communications module. Ensure that the USB-ISS Power Link has a jumper removed for 3.3V operations 

for compatibility with the MPM target.  

Use the included standard USB A/B cable to connect the USB-ISS to your PC. Install the drivers that are 

bundled with MPM GUI install in the C:\Microsemi\SF2_MPM_RefDesign_v6.0\Devantech_USB-

ISS_drivers folder. 

After installing the drivers, and plugging the USB-ISS module into a spare USB port, you need to know to 

which COM port it has been assigned to. This will vary from system to system depending on how many 

COM ports you currently have installed. To find out where it is, right-click on your My Computer desktop 

icon and select Properties > Hardware > Device Manager. Now scroll down and open the Ports (COM & 

LPT) tab. You should see the USB serial port listed - COM5 in the example below. If you want to change the 

COM port number - just right-click on it, select properties > advanced > COM port number from the 

available list. The COM port default settings are sufficient.  

 

 

 

                                                           

 

 

Figure 1 Device Manager 
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To allow the MPM GUI to communicate with MPM, connect the Devantech USB-ISS to the SmartFusion2 board’s MSS I2C_1 

by installing female to female jumper cables between the following pins: 

Devantech/Robot Electronics USB-ISS Connections 

 

  

Figure 1 Devantech/Robot Electronics USB-ISS  

 

Figure 2 · USB-ISS Module with Wires Connected 

 

As explained earlier note the COM port assigned to the USB-ISS communications module. Run the MPM 

GUI, select Data > I
2
C > Test I

2
C Dongle. Select the USB-ISS COM port from the Communications > 

Port: drop-down list. Select Test Dongle from the Activity > Action drop-down list and click the Go button. 

If the test is successful then you should see the following in the Status text box. 

 

I
2
C Signal Board SCL SDA GND 

Devantech/Robot Electronics USB-ISS 

http://www.robot-electronics.co.uk/htm/usb_iss_tech.htm 

SCL (I/O 3) SDA (I/O 4) 0V/Groun

d 

SF2 DMPM Board Rev A 

 

J22P pin 16 J22P pin 32 3 pin 8 

http://www.robot-electronics.co.uk/htm/usb_iss_tech.htm
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Figure 3 · MPM I2C Communications Success 

 

Figure 4 · MPM I2C Communications Failure 
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 Fully Connected Hardware Setup 

 

Power-Up and Power-Down System  
 

The first 4 of the 8 LEDs on the Dev Kit are used to display the current state of 

the MPM system as follows:  

LED 1 – This is on when the MPM system is in the off state. (Always ensure 

this LED is lit before trying to power up the system) 

LED 2 – This is on when the MPM system is sequencing power up.  

LED 3 – This is on when all POLs have been sequenced on.  

LED 4 - This is on when the MPM system is sequencing power down. 
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1. Press SW3 on the DEV KIT to initiate a startup sequence. 

2. Observe the LEDs around the outer edge of the DMPM board turn on one at a time starting with APOL1 – APOL8 and 

then DPOL1 – DPOL8. 

3. Notice which LED is lit on DEV KIT. LED3 indicates that the system has powered on and all POLs are in a nominal 

state. 

4. Press SW3 again to initiate a shutdown. 

5. Observe all of the LEDs turn off in reverse sequence. 

6. Also notice which LED on the DEV KIT is lit during shutdown. Ensure the state of the system corresponds with the LED 

indicated above. 

7. Press SW3 to start the system up. 

8. Once the system has completed startup, press any of the white push-button switches associated with any of the POLs. 

This drops the voltage of that POL to 0V and simulates a fault. The reference design is programmed to initiate an auto-

shutdown if this occurs. 

 

The 8 LEDs on the DMPM board display the 

state of the first 8 MPM outputs. With the 

default configuration for the Beta release, 

these LEDs represent the state of the first 8 

APOLs. When an LEDs is on, the 

corresponding APOL is in a non nominal 

state. When an LED is off, the corresponding 

channel is in the nominal state. This is useful 

when sequencing the APOLs as you can 

adjust the pot for a channel until it enters the 

nominal state by watching for the LED to turn 

off. 

 

 

If you press SW 3 to initiate power-up sequencing, the MPM state changes to Starting and you can see the various 

regulator enabled LEDs on the SF2 DMPM Daughter Board turning on in sequence. If the status does not change to 

Started and the power-on sequence restarts, you can adjust the voltage of the individual APOL channels via the 

associated potentiometers to complete the sequencing. If open-loop trimming is enabled, the open-loop trim pin 

voltage will only achieve nominal value if the potentiometer is suitably adjusted. 

Trimming 
 

When power sequencing has completed and all regulators have reached nominal voltage, the status changes to 

Started and APOL closed-loop trimming is also enabled if applicable. Closed-loop trimming keeps the APOL channel 

output voltage at the nominal value specified in the GUI, even when the potentiometer is adjusted. You can disable 

trimming by removing the Trim jumper for a given regulator. The following list shows which jumper configures which 

APOL: 

Jumper APOL 

JP3 1 

JP26 2 

JP27 3 

JP28 4 

JP2 5 

JP29 6 

JP30 7 

JP31 8 
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Removing one of these jumpers disables closed-loop trimming for the associated APOL and you see that the output voltage 

can be varied using the potentiometer for that channel. Reinstalling the jumper reactivates closed-loop trimming and brings it 

back to nominal. 

 

9. Power on the system by pressing SW3 on the DEV KIT. Once it has completed startup. Try rotating any of the APOL 

potentiometers to adjust the voltage. Notice that it doesn’t go into the critical non-nominal ranges even at the 

extremes of the potentiometer. 

10. While the system is still powered up, remove the jumper JP3 for the APOL1 listed above in the table. 

11. Try adjusting the potentiometer for the APOL1 and notice the corresponding LED on the DMPM board turn on once it 

goes into a critical voltage range. This will initiate a shutdown of the system. 

12. Replace the jumper and do a power up cycle to ensure the system can properly start up. 

MPM GUI 
1. Open the I2C Communication window by selecting Data > I

2
C > Test I

2
C Dongle. Select the USB-ISS COM port from 

the Communications > Port: drop-down list. Select Test Dongle from the Activity > Action drop-down list and click the 

Go button. This is a repeat of a previous step to ensure the I2C communication is still active. 

2. In the main MPM GUI window, select Data > File > Load Values and browse to 

C:\Microsemi\SF2_MPM_RefDesign_v6.0\bin\SF2_MPM_Reference_Design.txt to load the default values. 

3. Back in the I2C COMM window, in the activity drop down menu, select Write and click Go. This will write the 

configuration from the MPM GUI into the eNVM. 
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4. Successful write of the configuration will produce the below window. 

5. Once you have successfully written the configuration data, click Start under the MPM Commands to initiate a startup 

sequence. All LEDs corresponding to the POLs should light up and sequence. 

6. Click Stop under MPM Commands to initiate a shutdown. 

Power Sequencing 
 

1. In the MPM GUI window under the Power tab, in the Power 

Sequencing section, each of the power rails can be assigned a 

Slot.  

2. Assign the first four rails (A1-A4) to Slot 1. 

3. Assign the next four rails (A5-A8) to Slot 2. 

4. Assign the next four rails (A9-A12) to Slot 3. 

5. Assign the final four rails (A13-A16) to Slot 4. 

 

6. Check your assignments by looking at the Sequencing view. 

Click View > Sequencing.  It should look as shown. 

7. After finishing configuration, ensure the system is powered 

down by either clicking Stop in the MPM I2C window or 

pressing SW3 on the DEV KIT. 

8. With the system powered down, write the configuration to the 

eNVM by using the Write command in the I2C window. 

9. After successfully writing the configuration, click Init under the 

MPM commands. 

10. Click Start under the MPM commands to initiate a power up. 

11. Observe the POL LEDs turning on in groups of 4 according to 

the slots they were assigned to. 

12. Note: time delays can be inserted for power on and off for each 

of the rails. 

13. Click Stop in the MPM Commands window to initiate a 

shutdown. 
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14. The POLs will shutdown in the same slot groups as they powered up in as 

expected. 

 

Live Metering 
1. Revert back to the default MPM configuration by clicking Data > File > Load 

Values and selecting SF2_MPM_Reference_Design.txt 

2. For Rails A9-A16, set the Point of Load Type to ACE Analog and set the 

Slot to No Sequencing.  

3. Once this configuration has been set, write the config to eNVM in the I2C 

window. 

4. After writing the configuration, click Init under MPM Commands. 

5. In the MPM GUI, click View > Meters. 

6. For the purposes of this exercise, it is advisable to resize the Meters window 

to show only the first 8 meters. 

7. In the MPM I2C window, select Monitor in the Activity drop down menu and 

click Go. 

8. This will initiate the I2C communication to monitor the voltages on all of the 

active rails. 

9. On the DEV KIT, press SW3 to start the power up sequence. 

10. On the DMPM board, only the first 8 APOL’s should turn on. 

11. Observe the voltages on each of the rails show live readings. 

 

 

 

 

 

 

 

 
Figure 2 Details of Meter Information 
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Margining 
 

 

 

 

12. In the I2C window, click Stop to halt the monitoring. 

13. For Rail 1-8, click margin low.  

14. Restart live voltage monitoring by clicking Go while the Monitor Action is selected. 

15. Observe the voltages across all 8 rails are now lower according to the Closed-Loop Margin Low value in the MPM GUI 

for each of the rails.  

Try to margin high all 8 rails to confirm.

 

 

 

 

Product Support 
Microsemi SoC Products Group backs its products with various support services, including Customer 

Service, Customer Technical Support Center, a website, electronic mail, and worldwide sales offices. This 

appendix contains information about contacting Microsemi SoC Products Group and using these support 

services. 

Customer Service 
Contact Customer Service for non-technical product support, such as product pricing, product upgrades, 

update information, order status, and authorization. 

From North America, call 800.262.1060 
From the rest of the world, call 650.318.4460 
Fax, from anywhere in the world 408. 643.6913 

Customer Technical Support Center 
Microsemi SoC Products Group staffs its Customer Technical Support Center with highly skilled engineers 

who can help answer your hardware, software, and design questions about Microsemi SoC Products. The 

Customer Technical Support Center spends a great deal of time creating application notes, answers to 

common design cycle questions, documentation of known issues and various FAQs. So, before you contact 

us, please visit our online resources. It is very likely we have already answered your questions. 

Technical Support 
Visit the Microsemi SoC Products Group Customer Support website for more information and support 

(http://www.microsemi.com/soc/support/search/default.aspx). Many answers available on the searchable 

web resource include diagrams, illustrations, and links to other resources on website.  

http://www.microsemi.com/soc/support/search/default.aspx
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Website 
You can browse a variety of technical and non-technical information on the Microsemi SoC Products Group 

home page, at http://www.microsemi.com/soc/.  

Contacting the Customer Technical Support Center 
Highly skilled engineers staff the Technical Support Center. The Technical Support Center can be contacted 

by email or through the Microsemi SoC Products Group website. 

Email 

You can communicate your technical questions to our email address and receive answers back by email, 

fax, or phone. Also, if you have design problems, you can email your design files to receive assistance. We 

constantly monitor the email account throughout the day. When sending your request to us, please be sure 

to include your full name, company name, and your contact information for efficient processing of your 

request. 

The technical support email address is soc_tech@microsemi.com. 

My Cases 

Microsemi SoC Products Group customers may submit and track technical cases online by going to My 

Cases. 

Outside the U.S. 

Customers needing assistance outside the US time zones can either contact technical support via email 

(soc_tech@microsemi.com) or contact a local sales office. Sales office listings can be found at 

www.microsemi.com/soc/company/contact/default.aspx. 

ITAR Technical Support 
For technical support on RH and RT FPGAs that are regulated by International Traffic in Arms Regulations 

(ITAR), contact us via soc_tech_itar@microsemi.com. Alternatively, within My Cases, select Yes in the ITAR 

drop-down. 

50200319-0/4.12 

http://www.microsemi.com/soc
http://www.microsemi.com/soc/
file:///C:/Documents%20and%20Settings/alim/Local%20Settings/Temporary%20Internet%20Files/Content.Outlook/BPCDM203/soc_tech@microsemi.com
http://www.microsemi.com/soc/mycases/
http://www.microsemi.com/soc/mycases/
mailto:tech@microsemi.com
http://www.microsemi.com/soc/company/contact/default.aspx
http://www.microsemi.com/soc/company/contact/default.aspx
http://www.microsemi.com/soc/company/contact/default.aspx
http://www.microsemi.com/soc/company/contact/default.aspx#itartechsupport
mailto:soc_tech_itar@microsemi.com
http://www.microsemi.com/mycases/

