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Installing IP Cores and Drivers

This document covers the download and installation of Actel DirectCores, SGCores, and Driver firmware cores that 
must be localized on the personal computer where Actel's Libero IDE is installed when designing with Actel FPGAs. 

Actel IP and firmware cores are regularly added or updated and deposited to a virtual repository to which Libero IDE 
can connect and download the cores into a local vault. If you do not have these cores downloaded and available in the 
Libero IDE Catalog, you cannot complete design projects and design examples targeting Actel devices. You need a non-
constrained broadband or ethernet network connection for the shortest download time. Allow at least 30 minutes for 
downloading all cores. Individual cores may be downloaded to reduce download time. Download instructions are given 
below.

The Libero IDE installation does NOT include installation of DirectCores, SmartGen (SG), or Firmware driver cores 
into the local vault. So these cores are not available from the Libero IDE Catalog until you download them manually. 

Definitions:

• IP Repository: Actel specific URLs to which Libero IDE connects to download IP cores. There are 3 repository URLs 
visible from the Catalog Options menu that are added during the Libero IDE or SA installation. These are not web 
pages that you can view. They are connections to servers where Libero IDE downloads the cores. The defaults are: 

• www.actel-ip.com/repositories/SgCore

• www.actel-ip.com/repositories/DirectCore

• www.actel-ip.com/repositories/Firmware

• IP Vault: A folder on the target PC where the cores are downloaded. The default location is 
C:\Actel\Common\Vault\Data\IP, which is created during the Libero IDE installation. You can create a different 
folder/path in the Catalog Options menu but Actel recommends using the default location to avoid any confusion.

• DirectCores: Configurable IP cores that can be instantiated into a design. 

• Catalog: That window within the Libero IDE Project Manager that displays all Actel Cores and functional building 
blocks, including DirectCores, SGCores, Basic Blocks, and more.

• SGCores: Other Actel generated configurable cores, including SmartFusion MSS and DSP cores

• Firmware Driver Cores: Firmware drivers required for utilizing certain DirectCores or SGCores that are instantiated 
into a design. Firmware Driver Cores are viewable in the Firmware Catalog, which is a separate program from the 
Libero IDE Project Manager Catalog.

This document is organized into the following sections (click the text to go directly to that section):

• “Typical IP/Driver Installation Using an Internet Connection” on page 5

• “Libero IDE Does Not Connect to the Repositories or You Do Not Have Internet Access” on page 6

• “Installing IP and Drivers from the Libero IDE v9.0 DVD” on page 7

• “Copying IP and Drivers from Another PC” on page 7

• “If Your IT Manager or Another PC Has Internet Access” on page 8

• “If You Have an Internet Connection But Libero IDE Does Not Connect to the Default Repositories” on page 8

Typical IP/Driver Installation Using an Internet Connection
Depending on how your preferences are set in Libero IDE > Project > Preferences > Updates, a message at the bottom of 
the Libero IDE Project Manager Catalog window indicates that you have cores to download. 

Cores that are not yet downloaded from the repository show in the Catalog as grayed-out and italicized. Right-click any 
italicized core and choose Download to download only that core.

Click the Download Now button and all available cores will be downloaded. If the Vault is empty and you choose to 
download all cores this process can take 15-30 minutes depending on your internet connection. 
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Installing IP Cores and Drivers
Downloading Firmware Drivers
Only SgCores and DirectCores are downloaded via the Download Now or Download option in the Libero IDE Project 
Manager Catalog. 

To download Firmware Driver Cores: 

1. Go to Start > Libero IDE v9.0 > Firmware Catalog. When the Firmware Catalog opens, if you are connected to the 
internet, you will see a New cores are available for download message at the bottom of the User Interface. Available 
cores are displayed as grayed-out and italicized. 

2. Click Download now to download all cores or right-click any individual core to download that specific core.

Cores displayed in the Catalog with a horizontal line (strikethrough) indicate that you cannot use the installed 
version of the Libero IDE software with that core version. 

Libero IDE Does Not Connect to the Repositories or You Do Not 
Have Internet Access 

If you do not have access to the internet or internet access fails to connect to the repositories:

• At the bottom of the Libero IDE Catalog you will see a message Failed to contact web repositories

• The log file contains the message Could not resolve host: www.actel-ip.com (Domain name not found)

• If you have internet access and Libero IDE does not connect to the repositories noted above see section the sections 
“Copying IP and Drivers from Another PC” on page 7, “If Your IT Manager or Another PC Has Internet Access” on 
page 8, or “If You Have an Internet Connection But Libero IDE Does Not Connect to the Default Repositories” on 
page 8 below for possible resolution
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Copying IP and Drivers from Another PC
Installing IP and Drivers from the Libero IDE v9.0 DVD
The Libero IDE v9.0 DVD contains an IP_Files folder that contains all DirectCore/SGCore/Firmware cores and 
versions of those cores that were available March 01, 2010 when the DVD master was created. This IP_Files folder of 
cores on the v9.0 DVD is NOT included as part of the Libero IDE Tools installation. 

With the Libero v9.0 DVD in the DVD drive, open My Computer and right-click Libero 9.0 DVD, and choose 
Explore. Copy the IP_Files folder into the directory c:\Actel. Note that this does not actually install the cores. You must 
install the cores to your local machine. 

To install the cores to your local machine and enable access from the Catalog: 

1. In the Libero IDE Project Manager Catalog click the Options button and choose Import Files. The Options button 
is in the top right corner of the Catalog. 

2. Browse to the c:\Actel\IP_Files\DirectCores folder that you copied from the DVD. 

3. Open the DirectCores folder and look for <IP Corename.cpz>. The Import menu looks for a *.cpz file type.

4. Hold down the Ctrl key and select the cores of interest for the design project. Click OK to continue. 

Optional: hold down the Shift key to highlight and select all the cores. Note that it can take up to 15 minutes to 
import all IP files.

5. From the Libero IDE Project Manager Files menu, choose Import Files. 

6. Browse to the c:\Actel\IP\DirectCores directory. Change the Files of Type selection to IP Control File (*.icf ) and 
select the file Control_file_Actel_DirectCore.1.icf. This file aligns cores with FPGA families. Cores are FPGA 
family specific.

7. Repeat steps 1-6 for the SgCores directory in C:\Actel\IP_Files. 

Note: When designing with SmartFusion, you must import all SmartFusion_MSS.cpz cores.

8. Open the Actel Firmware Catalog from the Start > All Programs > Actel Libero IDE v9.0 > Firmware Catalog v9.0 
> Firmware Catalog. 

9. From the File menu, choose Import. 

10. Browse to C:\Actel\IP_Files\FirmwareCores. Open the Firmware Cores Folder and change Files of Type to Core 
File (*.cpz). 

11. Hold down the Ctrl key and select only the cores of interest for the design project. 

Optional: Hold down the Shift key to highlight and import all cores. 

12. Click OK to import the cores. 

Copying IP and Drivers from Another PC
It is possible to copy files from another PC where the files have been successfully installed. 

On the PC where the files are installed, open the c:\Actel\Common\Vault folder. You MUST copy the Components, 
Data, and the index.xml directories to the target PC. You cannot copy individual files within these folders. This means 
that if you have downloaded the entire contents of the repositories into the connected PC, you MUST copy that entire 
vault to the target PC. 
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Installing IP Cores and Drivers
If Your IT Manager or Another PC Has Internet Access
A current set of all IP Cores and drivers is available at: 

• http://www.actel-ip.com/cwps/download_index/DirectCore

• http://www.actel-ip.com/cwps/download_index/SgCore

• http://www.actel-ip.com/cwps/download_index/Firmware

From these URLs you can locate and download the core and core version of interest. 

1. Download the cores of interest to a USB external portable drive.

You must also download the control_file_Actel_DirectCore.1.icf from the web page if it exists

2. Move the portable drive to the PC where Libero IDE is installed.

For DirectCore and SgCores, follow the steps 1-7 above. 

For Firmware Drivers, follow the same steps 8-12 above. 

When downloading and installing SmartFusion MSS from http://www.actel-ip.com/cwps/download_index/SgCore, for 
each top-level MSS core version (e.g. MSS 2.1.108), you must also download all dependent MSS sub-cores obtained 
from the dependent cores link. 

After download, use steps 1-7 from “Installing IP and Drivers from the Libero IDE v9.0 DVD” on page 7 to first install 
each dependent sub-core, and install the top-level MSS core last. You MUST install the each dependent sub-core 
BEFORE you install the top-level MSS core. 

If You Have an Internet Connection But Libero IDE Does Not 
Connect to the Default Repositories

Verify that the URLs shown in your catalog options window are correct Libero > Catalog > Options > Vault 
Repositories Settings/Repositories: 

• www.actel-ip.com/repositories/SgCore

• www.actel-ip.com/repositories/DirectCore

• www.actel-ip.com/repositories/Firmware

When Libero IDE fails to connect to the web repositories on a computer connected to the internet, it typically means 
that the connection is being blocked by a network firewall or that the internet connection is made via a proxy server. If 
your internet gateway uses a proxy server:

1. From the Libero IDE toolbar, go to Project > Preferences and click the Proxy tab. 

2. Check the Use a Proxy Server checkbox. 

3. Put in the Proxy Server name on the network. 

In most cases, using the proxy server name solves the problem. If the server name does not work, enter the IP address 
of the proxy server. 

If that does not work, contact Actel Tech Support. 
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A
Product Support

Actel backs its products with various support services including Customer Service, a Customer Technical Support 
Center, a web site, an FTP site, electronic mail, and worldwide sales offices. This appendix contains information about 
contacting Actel and using these support services.

Customer Service
Contact Customer Service for non-technical product support, such as product pricing, product upgrades, update 
information, order status, and authorization.

From Northeast and North Central U.S.A., call 650.318.4480
From Southeast and Southwest U.S.A., call 650. 318.4480
From South Central U.S.A., call 650.318.4434
From Northwest U.S.A., call 650.318.4434
From Canada, call 650.318.4480
From Europe, call 650.318.4252 or +44 (0) 1276 401 500
From Japan, call 650.318.4743
From the rest of the world, call 650.318.4743
Fax, from anywhere in the world 650.318.8044

Actel Customer Technical Support Center
Actel staffs its Customer Technical Support Center with highly skilled engineers who can help answer your hardware, 
software, and design questions. The Customer Technical Support Center spends a great deal of time creating application 
notes and answers to FAQs. So, before you contact us, please visit our online resources. It is very likely we have already 
answered your questions.

Actel Technical Support
Visit the Actel Customer Support website (www.actel.com/support/search/default.aspx) for more information and 
support. Many answers available on the searchable web resource include diagrams, illustrations, and links to other 
resources on the Actel web site. 

Website
You can browse a variety of technical and non-technical information on Actel’s home page, at www.actel.com. 

Contacting the Customer Technical Support Center
Highly skilled engineers staff the Technical Support Center from 7:00 A.M. to 6:00 P.M., Pacific Time, Monday through 
Friday. Several ways of contacting the Center follow:

Email
You can communicate your technical questions to our email address and receive answers back by email, fax, or phone. 
Also, if you have design problems, you can email your design files to receive assistance. We constantly monitor the email 
account throughout the day. When sending your request to us, please be sure to include your full name, company name, 
and your contact information for efficient processing of your request.

The technical support email address is tech@actel.com.
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tel Corporation • 2061 Stierlin Court • Mountain View, CA 94043 • USA
one 650.318.4200 • Fax 650.318.4600 • Customer Service: 650.318.1010 • Customer Applications Center: 800.262.1060 

tel Europe Ltd. • River Court, Meadows Business Park • Station Approach, Blackwater • Camberley Surrey GU17 9AB • United Kingdom
one +44 (0) 1276 609 300 • Fax +44 (0) 1276 607 540

tel Japan • EXOS Ebisu Building 4F • 1-24-14 Ebisu Shibuya-ku • Tokyo 150 • Japan
one +81.03.3445.7671 • Fax +81.03.3445.7668 • http://jp.actel.com 

tel Hong Kong • Room 2107, China Resources Building • 26 Harbour Road • Wanchai • Hong Kong
one +852 2185 6460 • Fax +852 2185 6488 • www.actel.com.cn 

tel is the leader in low-power and mixed-signal FPGAs and offers the most comprehensive portfolio of system 
d power management solutions. Power Matters. Learn more at www.actel.com.

Phone
Our Technical Support Center answers all calls. The center retrieves information, such as your name, company name, 
phone number and your question, and then issues a case number. The Center then forwards the information to a queue 
where the first available application engineer receives the data and returns your call. The phone hours are from 7:00 A.M. 
to 6:00 P.M., Pacific Time, Monday through Friday. The Technical Support numbers are:

650.318.4460
800.262.1060
Customers needing assistance outside the US time zones can either contact technical support via email (tech@actel.com) 
or contact a local sales office. Sales office listings can be found at www.actel.com/company/contact/default.aspx.
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