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1 Revision History

The revision history describes the changes that were implemented in the document. The changes are 
listed by revision, starting with the most current publication.

1.1 Revision 3.0
The following is a summary of the changes in revision 3.0 of this document.

• Updated the document for Libero SoC v2021.2.
• Updated Figure 1, page 3.

1.2 Revision 2.0
The following is a summary of the changes in revision 2.0 of this document.

• Updated Table 1, page 2
• Updated section Step 1—Creating a Libero SoC PolarFire Project, page 3
• Updated section Step 3—Synthesis and Pin Assignment, page 9
• Replaced Figure 17, page 11, Figure 18, page 12, and Figure 20, page 13

1.3 Revision 1.0
Revision 1.0 was published in September 2018. It was the first publication of this document.
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2 Introduction

This tutorial demonstrates how to implement basic PolarFire® Field Programmable Gate Array (FPGA) 
designs leveraging the Libero® System-on-Chip (SoC) PolarFire design tool. Each section builds 
complexity and introduces new features on top of the previous section. After completing this tutorial, you 
will be familiar with the following steps.

• Step 1—Creating a Libero SoC PolarFire Project, page 3
• Step 2—Creating Your Design, page 6
• Step 3—Synthesis and Pin Assignment, page 9
• Step 4—Programming the Device, page 13
• Step 5—Running the Design, page 17
• Step 6—Design Iterations in the Libero SoC PolarFire, page 18

2.1 Prerequisites
The following table lists the prerequisites for the tutorial.

Table 1 • Prerequisites for the Tutorial

Type Details
Software requirements Libero SoC PolarFire v2021.2

Hardware requirements PolarFire Evaluation Kit (MPF300-EVAL-KIT)

Source files Not required. The design will be created from scratch

https://www.microsemi.com/existing-parts/parts/150789
https://www.microsemi.com/product-directory/design-resources/3863-libero-soc-polarfire#downloads
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3 Running the Tutorial

The following sections describe the step-by-step procedure to be followed to run this tutorial.

3.1 Step 1—Creating a Libero SoC PolarFire Project
In this step, you create a Libero SoC project.

1. Click Start > Programs > Microsemi Libero SoC PolarFire v2021.2 > Libero SoC PolarFire 
v2021.2, or click the shortcut on your desktop. The Libero SoC PolarFire Project Manager will open, 
as shown in the following figure.

Figure 1 • Libero SoC PolarFire Project Manager



Running the Tutorial

Microsemi Proprietary TU0844 Revision 3.0 4

2. Create a new project by selecting New on the Start Page tab (shown in the preceding figure), or by 
clicking Project > New Project from the Libero SoC menu. The New Project wizard will open.

Figure 2 • New Project Window

3. Enter the information given in the following list, in the Project Details page of the New Project 
dialog box and click Next.

• Project name: PolarFire_basic
• Project location: <C: or D:>/Microsemiprj (or the path to where the files were extracted).
• Preferred HDL type: Select either VHDL or Verilog based on your HDL preferences.

Note: Project name is case sensitive for Verilog design.

Figure 3 • Project Details
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4. Enter the following details in the Device Selection page of the New Project dialog box and click 
Next.

• Family: PolarFire
• Die: MPF300TS
• Package: FCG1152
• Speed: –1
• Range: IND

Figure 4 • Device Selection

5. Enter the following details in the Device settings page of the New Project dialog box and click 
Finish.

• Core Voltage: 1.0 (default)
• I/O settings

• Default I/O technology: LVCMOS 1.8 V
• Reserve pins for probes: Checked (default)

• System controller suspended mode: Un-checked (default)
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Figure 5 • Device Settings

3.2 Step 2—Creating Your Design
The following steps describe how to create the design.

1. The Design Flow window is used to manage most of the flow. This window has multiple tabs. You 
can switch between these tabs by clicking the tab names at the bottom, as shown in the following 
figure.

Figure 6 • Design Creation
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2. In the Design Flow window, double click Create SmartDesign and name your design “andgate,” 
then click OK. This opens the SmartDesign Canvas.

Figure 7 • Create New SmartDesign

3. Select the Catalog tab in the Design Flow window and expand the Macro Library section, as 
shown in the following figure.

Figure 8 • Catalog Tab

4. Drag the AND2 gate from the Catalog onto the blank SmartDesign Canvas on the right.
5. Use the mouse to select A and then right click to bring up the menu. From the menu, select 

Promote to Top Level, as shown in the following figure. This creates an external connection on the 
device that is connected to a switch. Repeat the same steps for B and Y.

Figure 9 • AND2 Gate
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6. When you have completed this step, you should have the view shown in the following figure.
Figure 10 • AND2 Connection

7. Click the Generate Component button  on the top of the canvas to generate the design.
8. The message, “'andgate' was successfully generated.” is displayed in the Libero SoC Log tab, as 

shown in the following figure.
Figure 11 • Success Message in Libero SoC Log Tab

9. Select the Design Hierarchy window, set andgate as root and click Build Hierarchy as shown in 
the following figure.

Figure 12 • Design Hierarchy

10. “andgate” will appear in bold font on the Design Hierarchy tab, indicating that it is the root level.
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3.3 Step 3—Synthesis and Pin Assignment
The following steps describe the synthesis process and pin assignment.

1. Double-click Synthesize under Implement Design in the Design Flow window, as shown in the 
following figure, to synthesize the design with Synplify Pro. Synplify Pro adds I/O pads to the design. 
A green check mark will appear in the Design Flow window to indicate synthesis was successful.

Figure 13 • Synthesize in Design Flow
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2. This is a very simple design, hence, the only other step required is, configuration of the I/Os. 
Double-click Manage Constraints in the Design Flow window to open the Libero SoC 
Constraints Manager.

Figure 14 • Libero SoC Constraints Manager

3. Confirm that the I/O Attributes tab is selected. Use the pull-down menu on the Edit button to select 
Edit with I/O Editor (highlighted in the preceding figure) to open the I/O Editor.

4. Select the Port View tab of the I/O Editor, as shown in the following figure.
Figure 15 • I/O Editor
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5. Use this window to set the I/O Standard and Pin Number. Confirm that LVCMOS18 is the I/O 
standard for each pin, as shown in the following figure.

6. Click Unassigned in the Pin Number column to reveal available I/O pins. Make the following 
assignments. You can either type the pin number in the field or use the pull-down menu to select the 
pin.

• A—B19
• B—C21
• Y—C26
7. Make sure the connections match the following screenshot, then click on File > Commit and close 

the window by clicking File > Exit.
Figure 16 • I/O Standard and Pin Number Assignments

Push-Button Switches

The PolarFire evaluation board comes with four debug push-button switches connected to the PolarFire 
FPGA. The following table lists the on-board push-button switches. 

The following figure shows push-button and pin connections.

Figure 17 • Push-Button and Pin Connections

Table 2 • PolarFire Evaluation Kit - Push-Button Switches

PolarFire Evaluation Board Pin
PolarFire FPGA 
Pin Number PolarFire FPGA Pin Name Bank

SW10 B19 HSIO46PB6 Bank - 6

SW9 C21 HSIO49PB6 Bank - 6

SW8 A25 HSIO68PB6/DQS/CCC_SE_PLL1_OUT0 Bank - 6

SW7 B27 HSIO69NB6 Bank - 6

PolarFire

B27

C21

A25

B19

SW7

SW8

SW9

SW10

1.8 V

10
 k

10
 k
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User LEDs

The board provides user access to eight active-High LEDs that are connected to the PolarFire device for 
debugging applications. The following table lists the onboard user LEDs. 

The following figure shows how the LEDs are connected to the PolarFIre FPGA. When the PolarFire 
output goes high (logic 1), the LED turns on. When the output goes low (logic 0), the LED turns off.

Figure 18 • PolarFire Evaluation Kit User Defined LEDs

Note: For more information, see the PolarFire Evaluation Board Schematic document provided separately.

8. If you click the green arrow button at the top of the Design Flow window, circled in the following 
figure, you can now run the design all the way through place and route.

Figure 19 • Running the Design

Note: Double click Verify Timing to perform timing analysis for sequential circuits and to analyze the 
generated timing report.

Table 3 • PolarFire Evaluation Kit - User LEDs

PolarFire Evaluation Board Pin

PolarFire 
FPGA Pin 
Number Number PolarFire Pin Name Bank

LED7 D25 HSIO70PB6/CCC_SE_PLL1_OUT1 Bank - 6

LED6 C26 HSIO70NB6 Bank - 6

LED5 B26 HSIO71NB6 Bank - 6

LED4 F22 HSIO64NB6 Bank - 6

LED11 H21 HSIO36NB6 Bank - 6

LED10 H22 HSIO60NB6 Bank - 6

LED9 F23 HSIO62PB6/DQS/CCC_SE_PLL0_OUT0 Bank - 6

LED8 C27 HSIO71PB6/CCC_SE_CLKIN_S_15 Bank - 6

PolarFire
NPN 

Transistor
499 

3.3 V

https://www.microsemi.com/document-portal/doc_download/136590-polarfire-evaluation-kit-schematics
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3.4 Step 4—Programming the Device
The following steps describe how to run the FlashPro in batch mode to program the PolarFire MPG300 
on the PolarFire evaluation board, as shown in the following figure.

Figure 20 • PolarFire Evaluation Kit Board
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1. Prior to programming (and powering up) the PolarFire evaluation board, confirm that the jumpers are 
positioned as listed in the following table.

2. Connect 12 V power supply brick to the J2 connector.
3. Connect a USB cable between the J1 mini USB connector and the host PC.
4. Slide the main power switch SW1 to on.
5. Install the FlashPro4 drivers if prompted. The drivers are located in the <Libero SoC PolarFire 

v2021.2 Installation Directory>\drivers folder.

Table 4 • Jumper Settings

Jumper Description Pin Default Setting
J18, J19, J20, J21, 
J22

Jumpers to select 
the PolarFire JTAG 
or A2F JTAG

Close pin 1 and 2 for programming the power sequence 
and monitoring chip through the FTDI

Close pin 2 and 3 for programming the PolarFire FPGA 
through FTDI
User must always retain the default jumper setting

Open

Closed

J46 Jumper to select 
switch-side MUX 
inputs of A or B to 
the line side

Close pin 1 and 2 (Input A to the line side) for routing the 
on-board 122.88 MHz differential clock oscillator output to 
the line side

Close pin 1 and 2 (Input B to the line side) for routing the 
on-board 125 MHz differential clock oscillator output to the 
line side

Open

Closed

J28 Jumper to select 
the external JTAG 
or the onboard 
FlashPro5 for 
programming the 
PolarFire device

Close pin 1 and 2 for programming through the on-board 
FlashPro5

Closed

J26 Jumper to select 
the FTDI SPI or 
SC_SPI header

Close pin 1 and 2 for programming through the SC_SPI 
Header

Open

J27 Jumper to select 
between FTDI SPI 
or External SPI 
Flash to program 
the device

Close pin 1 and 2 for programming through the External 
SPI flash

Open

J23 Jumper to define 
the SPI interface 
mode

Close pin 1 and 2 to define the SPI Slave mode Open

J4 Jumper to select 
the SW3 input or 
the ENABLE_FT4 
232 signal from the 
FT4232H chip

Close pin 1 and 2 for manual power switching using SW3

Close pin 2 and 3 for remote power switching using the 
GPIO capability of the FT4232 chip

Closed

Open

J12 Jumper to select 
the PolarFire 
VCCIO voltage 
(VCCIO_HPC_VA
DJ) to 1.2V, 1.5V, 
1.8V, 2.5V, or 3.3V

Close pin 1 and 2 for 3.3 V
Close pin 3 and 4 for 2.5 V
Close pin 5 and 6 for 1.8 V
Close pin 7 and 8 for 1.5 V
Close pin 9 and 10 for 1.2 V

Open
Closed
Open
Open
Open

J43 Jumper to select 
the VDD voltage

Close pin 1 and 2 for 1.05 V Open
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6. Expand Program Design in the Design Flow window. Right-click Run PROGRAM Action and 
select Run to generate the programming file and begin programming.

Figure 21 • Run Program Action

7. FlashPro runs in batch mode and programs the device. Programming messages will be visible in the 
Libero SoC log window (programmer number will differ).

Note: Do not interrupt the programming sequence.

8. The following message should be visible in the Reports view under Run PROGRAM Action, when 
the device is programmed successfully (programmer number will differ).
programmer 'E2001JZK2X': device 'MPF300T_ES': Executing action PROGRAM 
PASSED.

programmer 'E2004OQL7D': device 'MPF300TS': Executing action PROGRAM 
PASSED.
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Figure 22 • Reports Tab

A green tick mark will appear next to Program Design and Run PROGRAM Action in the Design Flow 
window to indicate successful programming as shown in the following figure.

Figure 23 • Design Flow Green Tick Marks
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9. Click Project > Save from the Libero menu to save your completed project.
Note: Do not close the window.

3.5 Step 5—Running the Design
This is a very simple design designed to show an AND gate. The following steps are performed to run the 
design.

• Observe LED1 with switch 5 and switch 6 released—it will illuminate.
• Press switch 5 and observe the behavior of LED1—it will turn off.
• Press switch 6 and observe the behavior of LED1—it will turn off.
• Press both switches and LED1 will turn off.
For and AND gate, users would expect the LED to illuminate when both switches are pressed, but in this 
application, releasing the switch generates a logic one, which illuminates the LED. To correct this, we 
need to invert the inputs to the AND gate. For more information, see Figure 16• Switches Interface in 
UG0747: PolarFire FPGA Evaluation Kit User Guide.

https://www.microsemi.com/document-portal/doc_download/136765-ug0747-polarfire-fpga-evaluation-kit-user-guide
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3.6 Step 6—Design Iterations in the Libero SoC PolarFire
The following steps describe the design iteration in the Libero SoC PolarFire v2021.2.

1. Reopen the SmartDesign Canvas again, look for the  tab.
2. Hold the CTRL key and select input ports A and B of AND2_0, then right-click, to bring up the menu. 

Select Invert to invert the signals, as shown in the following figure. This is built into the SmartDesign 
capabilities to invert or tie off any I/O.

Figure 24 • Design Iterations

3. The ports will be inverted.
Figure 25 • Ports Inversion

4. Generate the Component . It resets the rest of the compilation functions, but keeps your I/O 
constraints.

5. Right-click Run PROGRAM Action on the Design flow window, then select Update and Run to run 
all the steps in between and reprogram the device in one click.

6. Check if the Warning dialog box about running in non-timing-driven mode is displayed behind your 
active window.

7. Observe the correct behavior on the board by pressing both switches simultaneously to illuminate 
LED1.

This step completes the tutorial of the Libero SoC PolarFire v2021.2 design flow.



References

Microsemi Proprietary TU0844 Revision 3.0 19

4 References

The following documents are referred for this tutorial.

• UG0758: PolarFire FPGA Design Flow User Guide
• UG0779: SmartDesign User Guide for PolarFire
• UG0750: PolarFire FPGA I/O Editor User Guide
• PolarFire FPGA Tcl Commands Reference Guide
• UG0776: PolarFire FPGA Design Constraints User Guide
• UG0769: Timing Constraints Editor User Guide for PolarFire
• UG0738: Netlist Viewer Interface User Guide for PolarFire
• UG0821: PolarFire FPGA Chip Planner User Guide
• SmartPower User Guide for Libero SoC PolarFire
• UG0773: PolarFire FPGA SmartDebug User Guide
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http://www.microsemi.com/index.php?option=com_docman&amp;task=doc_download&amp;gid=%20136923
http://www.microsemi.com/index.php?option=com_docman&amp;task=doc_download&amp;gid=%20136580
http://www.microsemi.com/index.php?option=com_docman&amp;task=doc_download&amp;gid=%20136574
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